# Table Of Contents

## Part A  Introduction

1. **Glossary** ................................................. 10
2. **System Requirements** ................................. 15
3. **MADRIX KEY [Software License]** ..................... 23
4. **MADRIX KEY [Activation]** ........................... 29
5. **Update From MADRIX 2 Or 3 To MADRIX 5** .......... 32
6. **Supported Fixtures [LED Products]** ................ 35
7. **Supported Interfaces [DMX512 / Art-Net]** ........... 37
8. **Web Links** ............................................. 39

## Part B  Getting Started

1. **Installation Process** ................................... 43
2. **Starting The Software** ............................... 51
3. **Language Settings** .................................... 54
4. **5-Step Quick Start** .................................. 55
5. **Audio And Sound** .................................... 57
6. **PC Power Management** ................................ 72
7. **Tips [Microsoft Windows / Networks / USB]** ....... 77
8. **Using The Mouse** ..................................... 92
9. **Keyboard Shortcuts [Hotkeys]** ....................... 95
10. **Tips [Workflow]** ...................................... 98
11. **Examples** ........................................ 100
12. **2D Or 3D [X, Y, Z]** .................................. 102

## Part C  User Interface [GUI]

1. **Menu** .................................................. 110
2. **Operating Modes [Programmer / Operator]** ....... 118
3. **Views** .................................................... 120
4. **3 Previews** ......................................... 123
5. **Crossfader** ............................................ 138
6. **Main Output / Master / Audio Levels** .............. 147
7. **Controls [Deck A / Deck B]** .......................... 156
8. **Storages** ............................................. 160
9. **Storage Places [256 x 256]** .......................... 166
10. **Effect Areas [Deck A / Deck B]** ..................... 174
11. **Cue List Section** ..................................... 178
12. **Full-Screen Mode** .................................... 180
13. **Touch Screen** ....................................... 183
# Table Of Contents

Part D  Using The Software  189

1  MADRIX Setup [New / Open] .................................................. 191
2  Patching ............................................................................. 196
    - Matrix Generator ......................................................... 197
    - Patch Editor ................................................................... 212
    - DVI Patch ..................................................................... 248
    - CSV Fixture List Import ................................................. 264
    - Merging Patches .............................................................. 283
    - Background Image ............................................................ 293
3  Fixture Groups [Group Control] ........................................... 297
4  Effects [Visuals] ................................................................. 317
5  Filters [FX] ....................................................................... 320
6  Layers ............................................................................... 328
7  Mapping / Tiling / Rotation .................................................. 348
8  Chasers .............................................................................. 359
9  Tools ................................................................................ 391
10 Backup System ................................................................. 401
11 File Types ........................................................................ 411
12 Recording ........................................................................ 417

Part E  Options  434

1  Startup ............................................................................. 435
2  General ............................................................................ 438
3  Devices USB ..................................................................... 442
4  Devices Network ............................................................... 445
5  User Interface .................................................................. 448
6  Recording ......................................................................... 451
7  Previews .......................................................................... 454
8  Performance ...................................................................... 458

Part F  OUTPUT Settings  462

1  DVI ................................................................................ 464
    - DVI ............................................................................... 465
    - DVI Examples ................................................................. 481
2  Art-Net [DMX Over Ethernet] ............................................ 485
3  DMX512 [DMX-OUT] .......................................................... 501
4  Philips Color Kinetics [KNET] ............................................. 507
5  ESTA - Streaming ACN [sACN / E1.31] ............................ 518
6  Proprietary DVI Devices [5A / A8 / T9]. ............................ 529
7  Philips Hue ........................................................................ 540

Part G  INPUT And Remote Control  549

1  DMX-IN / Art-Net Remote / sACN Input ............................... 551
    - DMX-IN / Art-Net Remote / sACN Input Configuration .... 552
DMX-IN [Essential Protocol] ................................................................. 583
DMX-IN [Standard Protocol] ............................................................... 585
DMX-IN [User] .................................................................................. 589
DMX-IN Remote Editor ........................................................................ 590

2 MIDI-IN ............................................................................................ 598
   MIDI-IN Configuration ................................................................. 600
   MIDI Remote Editor ...................................................................... 611
   Akai Professional APC40 .............................................................. 625
   Akai Professional APC40 MKII ...................................................... 627
   Akai Professional APCkey25 .......................................................... 633
   Akai Professional APCmini ............................................................. 637
   Akai Professional LPD8 .................................................................. 642
   Akai Professional LPK25 ................................................................ 644
   Akai Professional MIDIMIX ........................................................... 646
   Akai Professional MPK249 .............................................................. 648
   Akai Professional MPK261 .............................................................. 651
   Akai Professional MPKmini MKII .................................................... 654
   Behringer BCD3000 ...................................................................... 656
   Behringer BCF2000 ...................................................................... 658
   Behringer BCR2000 ...................................................................... 660
   Creative Prodikeys PC-MIDI ............................................................ 662
   Elation Professional MIDIICON ...................................................... 663
   Hercules DJ Console Rmx ............................................................... 665
   Hercules DJ Control MP3 And DJ Console MiQ .................................. 668
   Hercules DJ Control MP3 e2 ............................................................ 671
   KORG nanoKONTROL ................................................................. 673
   KORG nanoKONTROL2 ................................................................. 674
   Livid Instruments Ohm64 ............................................................... 675
   M-AUDIO Code 49 ........................................................................ 677
   M-AUDIO Oxygen 8 v2 ................................................................ 679
   M-AUDIO Torq Xponent ............................................................... 681
   MIDI Keyboards ........................................................................... 683
   MIDI Universal .............................................................................. 685
   Novation Launchpad ...................................................................... 691
   Novation Launchpad Mini .............................................................. 693
   Numark NuVJ ................................................................................ 695
   Numark Omni Control ................................................................. 697
   Numark Stealth Control ............................................................... 698
   Numark Total Control ................................................................. 699
   Omnitronic MMC-1 .................................................................... 701
   Stanton SCS.3d ............................................................................. 703
   USER User .................................................................................... 705
   Vestax VCI-100 ............................................................................. 706
   Vestax VCM-100 ........................................................................... 708

3 MA-Net .............................................................................................. 711
5 CITP ................................................................................................. 726
6 Remote HTTP .................................................................................. 733
7 GamePort .......................................................................................... 741

Part H MADRIX Effects ............................................................................ 751

1 [SCE] Static Color Effects ................................................................. 753
   SCE Bounce ................................................................................ 755
   SCE Capture ................................................................................ 759

www.madrix.com
<table>
<thead>
<tr>
<th>Effect Name</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>SCE Drops</td>
<td>765</td>
</tr>
<tr>
<td>SCE Color</td>
<td>768</td>
</tr>
<tr>
<td>SCE Color Change</td>
<td>770</td>
</tr>
<tr>
<td>SCE Color Scroll</td>
<td>772</td>
</tr>
<tr>
<td>SCE Counter</td>
<td>775</td>
</tr>
<tr>
<td>SCE Drops</td>
<td>785</td>
</tr>
<tr>
<td>SCE Explosions</td>
<td>790</td>
</tr>
<tr>
<td>SCE Fill Drops</td>
<td>794</td>
</tr>
<tr>
<td>SCE Fill Random</td>
<td>797</td>
</tr>
<tr>
<td>SCE Fill Snake</td>
<td>800</td>
</tr>
<tr>
<td>SCE Fill Solid</td>
<td>804</td>
</tr>
<tr>
<td>SCE Fire</td>
<td>807</td>
</tr>
<tr>
<td>SCE Flames</td>
<td>810</td>
</tr>
<tr>
<td>SCE Fluid</td>
<td>813</td>
</tr>
<tr>
<td>SCE Gradient</td>
<td>816</td>
</tr>
<tr>
<td>SCE Graph</td>
<td>819</td>
</tr>
<tr>
<td>SCE Image</td>
<td>825</td>
</tr>
<tr>
<td>SCE Level Color Simulator</td>
<td>838</td>
</tr>
<tr>
<td>SCE Metaballs</td>
<td>841</td>
</tr>
<tr>
<td>SCE Noise</td>
<td>845</td>
</tr>
<tr>
<td>SCE Plasma</td>
<td>849</td>
</tr>
<tr>
<td>SCE Pulse / Stroboscope</td>
<td>852</td>
</tr>
<tr>
<td>SCE Rotating Shapes</td>
<td>855</td>
</tr>
<tr>
<td>SCE Screen Capture</td>
<td>860</td>
</tr>
<tr>
<td>SCE Shapes</td>
<td>870</td>
</tr>
<tr>
<td>SCE Simple Shape</td>
<td>874</td>
</tr>
<tr>
<td>SCE Starfield</td>
<td>878</td>
</tr>
<tr>
<td>SCE Swarm</td>
<td>882</td>
</tr>
<tr>
<td>SCE Ticker / Scrolling Text</td>
<td>886</td>
</tr>
<tr>
<td>SCE Tubes</td>
<td>892</td>
</tr>
<tr>
<td>SCE Video</td>
<td>895</td>
</tr>
<tr>
<td>SCE Wave / Radial</td>
<td>906</td>
</tr>
</tbody>
</table>

2 **[S2L] Sound2Light Effects.** .................................................... 909

<table>
<thead>
<tr>
<th>Effect Name</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>S2L Drops</td>
<td>911</td>
</tr>
<tr>
<td>S2L EQ / Spectrum</td>
<td>916</td>
</tr>
<tr>
<td>S2L Frequency Flash</td>
<td>920</td>
</tr>
<tr>
<td>S2L Level Color</td>
<td>923</td>
</tr>
<tr>
<td>S2L Level Color Scroll</td>
<td>926</td>
</tr>
<tr>
<td>S2L Level Meter</td>
<td>929</td>
</tr>
<tr>
<td>S2L Level Shape</td>
<td>932</td>
</tr>
<tr>
<td>S2L Shapes</td>
<td>936</td>
</tr>
<tr>
<td>S2L Tubes</td>
<td>940</td>
</tr>
<tr>
<td>S2L Waveform</td>
<td>943</td>
</tr>
<tr>
<td>S2L Wavegraph</td>
<td>946</td>
</tr>
</tbody>
</table>

3 **[M2L] Music2Light Effects.** ....................................................... 949

<table>
<thead>
<tr>
<th>Effect Name</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>M2L Color Change</td>
<td>951</td>
</tr>
<tr>
<td>M2L Color Scroll</td>
<td>953</td>
</tr>
<tr>
<td>M2L Drops</td>
<td>956</td>
</tr>
<tr>
<td>M2L Note Flash</td>
<td>960</td>
</tr>
<tr>
<td>M2L Shapes</td>
<td>963</td>
</tr>
<tr>
<td>M2L Single Tone Spectrum</td>
<td>967</td>
</tr>
<tr>
<td>M2L Tubes</td>
<td>971</td>
</tr>
</tbody>
</table>

4 **[TRI] Trigger Effects** .............................................................. 974

<table>
<thead>
<tr>
<th>Effect Name</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuration Of TRI</td>
<td>975</td>
</tr>
<tr>
<td>TRI Color Change</td>
<td>976</td>
</tr>
<tr>
<td>TRI Drops</td>
<td>976</td>
</tr>
<tr>
<td>Chapter</td>
<td>Title</td>
</tr>
<tr>
<td>---------</td>
<td>-------</td>
</tr>
<tr>
<td>5</td>
<td>[MAS] MADRIX Script Effect</td>
</tr>
<tr>
<td>6</td>
<td>Using BPM Control</td>
</tr>
<tr>
<td>7</td>
<td>Using Colors And Intensity</td>
</tr>
<tr>
<td>8</td>
<td>Using Directions</td>
</tr>
<tr>
<td>9</td>
<td>Using Shapes [Shape Table]</td>
</tr>
<tr>
<td>10</td>
<td>Macros And Scripts</td>
</tr>
<tr>
<td>Part I</td>
<td>Cue List</td>
</tr>
<tr>
<td>1.</td>
<td>Cue List</td>
</tr>
<tr>
<td>Part J</td>
<td>Extra Tools And 3rd-Party Software</td>
</tr>
<tr>
<td>1.</td>
<td>MADRIX 5 Fixture Editor</td>
</tr>
<tr>
<td>2.</td>
<td>MADRIX 5 Device Updater</td>
</tr>
<tr>
<td>3.</td>
<td>MADRIX 5 KEY Firmware Updater</td>
</tr>
<tr>
<td>4.</td>
<td>MADRIX 5 Quick Support</td>
</tr>
<tr>
<td>5.</td>
<td>MADRIX 5 Restore</td>
</tr>
<tr>
<td>6.</td>
<td>MADRIX 5 Time Code Sender</td>
</tr>
<tr>
<td>Part K</td>
<td>MADRIX Hardware</td>
</tr>
<tr>
<td>1.</td>
<td>MADRIX USB ONE</td>
</tr>
<tr>
<td>2.</td>
<td>MADRIX NEQ</td>
</tr>
<tr>
<td>3.</td>
<td>MADRIX PLEXUS</td>
</tr>
<tr>
<td>4.</td>
<td>MADRIX LUNA</td>
</tr>
<tr>
<td>5.</td>
<td>MADRIX NEBULA</td>
</tr>
<tr>
<td>6.</td>
<td>MADRIX STELLA</td>
</tr>
<tr>
<td>7.</td>
<td>MADRIX ORION</td>
</tr>
<tr>
<td>8.</td>
<td>MADRIX I/O</td>
</tr>
<tr>
<td>Part L</td>
<td>Tips And Tricks</td>
</tr>
<tr>
<td>Part M</td>
<td>Imprint And Copyright</td>
</tr>
</tbody>
</table>
//PART A
Introduction
1 Introduction

Welcome To MADRIX

The MADRIX 5 Software is an outstanding tool for modern LED control and the ultimate software for 2D pixel mapping and 3D voxel mapping.

It is an advanced LED lighting controller. MADRIX 5 combines stunning real-time effects with an easy to use user interface that will allow you to create unique lighting patterns very easily. A wide range of software features allow for [nearly] endless possibilities and many options available to you. Please use this user guide to learn how to operate the software and its various tools.

Thank you for choosing MADRIX!

How To Use This User Guide

- Press F1 on your keyboard while working with the application to quickly call up the MADRIX 5 Help and Manual.
- **LINKS** are displayed in orange. Simply click through and you will be taken to the corresponding part within the same topic.
- »**LINKS** will take you away from the topic which you are currently reading to another section in this guide or to an external website.
- 🍃 - Shows new or updated topics for this MADRIX Software release version. This manual refers to MADRIX 5.0c
- This user guide is available in English.

## Topics Of This Chapter

- »**Glossary**
- »**System Requirements**
- »**MADRIX KEY [Software License]**
- »**MADRIX KEY [Activation]**
- »**Update From MADRIX 2 Or 3 To MADRIX 5**
- »**Supported Fixtures [LED Products]**
- »**Supported Interfaces [DMX512 / Art-Net]**
- »**Web Links**
1.1 Glossary

2D

MADRIX makes it possible to control numerous LED fixtures, also of different kinds, and to position them according to your needs in nearly any form or shape. This could be LED walls, arch shapes, ceilings, stripes, tiles, dance floors, etc. You can control pixel by pixel [pixel mapping].

3D

MADRIX supports volumetric pixel rendering as well [voxel mapping]. That means, MADRIX also allows you to control real 3D LED matrices. This approach is fundamentally different to the 3D projections or the physical layout of 2D surface areas that are widely known nowadays.

Art-Net

Art-Net is a communication protocol that allows to distribute DMX512 data over Ethernet network. Often, so-called Art-Net nodes then act as Ethernet-to-DMX512 converters and hardware interfaces. MADRIX LUNA is such an Art-Net node, for example.

Art-Net Remote

Art-Net Remote refers to DMX512 input that is sent and received over Ethernet network.

CITP

Is another communication protocol for exchanging information, often used between media servers, lighting consoles, and visualizers.

Colorlight 5A, Colorlight A8, Colorlight T9, Colour Smart Link

Are network-based communication protocols to control compatible LED fixtures and classified as DVI-based output in MADRIX.

DMX512 [DMX-OUT]
DMX512, often abridged to DMX, is an unidirectional communication protocol used mainly to control stage lighting, which uses 5-pin XLR connectors as defined by the standard. 3-pin connectors are also common, but not defined as standard connectors.

When working with DMX-based products, each fixture needs a specific attribution via its DMX channel and its DMX universe. With the specific DMX channel and DMX universe, the LED product can be identified directly for a correct communication with the fixture.

**DMX-IN**

You can send or receive DMX512 data. DMX-IN refers to DMX512 input, which you can receive in MADRIX.

**DMX Channel**

A total of 512 DMX channels is available per DMX universe. Each DMX channel is an individual control channel. Valid values range from 0 to 255, with a total of 256 values.

**DMX Universe**

A DMX universe contains 512 DMX channels and represents 1 DMX line. To control more than 512 DMX channels, more than 1 DMX universes need to be used. For example, 2 DMX universes represent 1024 DMX channels.

For example, you can control 170 RGB fixtures per DMX universe. That means, calculating 170 fixtures x 3 channels results in 510 DMX channels. Therefore, channel 511 and 512 will be left empty.

And if you are using more than 170 fixtures, those DMX channels will be assigned to a new DMX universe [e.g., DMX universe 2].

**DVI**

DVI is another way to output a video signal for your LEDs. Certain LED products use this type of communication. MADRIX features 2 DVI outputs, which are 1-to-1 output windows. You can then send the DVI outputs to any graphics card port [such as, VGA, HDMI, DVI, etc.]. Other solutions use screen-capturing to capture such a DVI output window and send them to the LED controller via Ethernet.

**Eurolite T9**

Is a network-based communication protocol to control compatible LED fixtures and classified as DVI-based output in MADRIX.
Fixtures

When talking about an LED product, the specific product is often called fixture. When talking about fixtures, often you will automatically get the information about the number of color channels [e.g., RGB] and the number of pixels.

Input

MADRIX can send data out, but at the same time data can be sent to MADRIX. That means data is sent to the MADRIX PC through various means [mostly USB or network]. MADRIX can then be controlled remotely by you, or you can merge or use incoming signals, etc.

IP Address

Is an identifier for devices that enables network communication. When using network protocols, it needs to be set up for each individual sender or recipient in the network.

KiNET

KiNET, the Philips Color Kinetics network protocol, is another communication protocol. It transfers data over Ethernet network as well. Only declared Philips Color Kinetics products work with this type of protocol.

MAC Address

Is a unique, technical identifier for interfaces in a network.

MA-Net

Is a proprietary communication protocol from MA Lighting between compatible products in a network.

MIDI

MIDI is short for Musical Instrument Digital Interface, a well-known technical standard that provides standardized ways for equipment to communicate. In case of MADRIX, MIDI can be used for MIDI Time Code, MIDI notes, or other MIDI hardware, such as DJ/VJ controllers.

Output
To control your LEDs, MADRIX needs to send data to the LEDs. In this way it communicates with your controllers and/or your LEDs. This is referred to as output. There are different ways on how this process can work [e.g., protocols]. But most importantly, you need to configure which output method MADRIX should use in order to control your LED products.

**Philips Hue**

Is a proprietary range of products including communication protocol for personal wireless lighting made by Philips Lighting.

**Pixel**

A pixel refers to one lighting point. When using RGB LEDs, one pixel usually includes 1 [or 2] red LEDs, 1 blue LED, and 1 green LED. 1 control channel is required for each color [3 in total per pixel], but as a total they represent one pixel. LED fixtures often have a certain number of pixels per unit.

**Pixel Mapping**

MADRIX contains an effect generator as well as a graphics render engine that support pixel rendering for 2D effects and volume rendering for 3D effects.

**Remote HTTP**

Remote HTTP is a way to control MADRIX remotely using standards known from the internet [HTTP - Hypertext Transfer Protocol].

**RGB**

The acronym stands for Red, Green, Blue. The 3 colors are the main colors for additive color mixing of LED fixtures. As a result, a vast number of colors can be mixed.

**RGBW**

The acronym stands for Red, Green, Blue, White. The 4 colors are also used for additive color mixing of LED fixtures. As a result, a vast number of colors can be mixed.

**Streaming ACN [sACN / E1.31]**
Streaming ACN or sACN or E1.31 is another communication protocol that allows DMX512 data to be transmitted over Ethernet. Data is broadcasted by MADRIX to recipients in the network.

**Subnet Mask**

Is a technical grouping mechanism for network devices. When using network protocols, it needs to be set up for each sender or recipient in the network for correct data routing.

**Virtual LED Matrix**

MADRIX needs to know how your LED installation looks like and which fixtures you want to use. [You can use the Matrix Generator or the Patch for this task.] In the end you will have configured the virtual LED matrix with its total pixel count in X, Y, and Z set up as the Matrix Size as well as the position and location of each pixel or fixture. The virtual LED matrix represents your LED installation in MADRIX.

**Volume Rendering / Voxel Mapping**

MADRIX contains an effect generator as well as a graphics render engine that support pixel rendering for 2D effects and volume rendering for 3D effects.

**Voxel**

Voxel is short for volumetric pixel. In addition to its pixel mapping features [2D], MADRIX can control 3D LED matrices, which is called voxel mapping. Lighting effects are correctly mapped to each voxel of a 3D LED matrix.

**XLR Pin Layout**

XLR connectors are used for DMX512. There are different types.

<table>
<thead>
<tr>
<th>5-Pin, Female</th>
<th>5-Pin Male</th>
<th>Pin Assignment</th>
<th>3-Pin, Female</th>
<th>3-Pin, Male</th>
</tr>
</thead>
</table>
| ![5-Pin Female](image1.png) | ![5-Pin Male](image2.png) | 1 Ground  
2 Data -  
3 Data +  
4 Spare  
5 Spare | ![3-Pin Female](image3.png) | ![3-Pin Male](image4.png) |
1.2 System Requirements

This topic includes:
- Minimum System Requirements
- Supported Operating Systems
- Optimal Computer Specifications
- Guidelines
- Setting The Graphics Processor
- Using NVIDIA Quadro Graphics Cards

Minimum System Requirements

- 2.0 GHz dual-core CPU
- OpenGL 2.1 graphics card [NVIDIA recommended]
- 2 GB RAM
- 1 GB free harddisk space
- 1280 x 768 screen resolution
- Network card
- Sound card
- USB 2.0

Optimal system specifications will often be higher.
See Guidelines

Supported Operating Systems

- Microsoft Windows 7
- Microsoft Windows 8
- Microsoft Windows 8.1
Microsoft Windows 10

- 64 bit only.
- Please keep the system, drivers, and updates up to date.

**Optimal Computer Specifications**

While MADRIX will run under the minimum system requirements described above, the optimal system specifications will vary greatly depending on your usage. The performance of the MADRIX Software on your computer system will depend mainly on these factors:

- Pixel resolution [2D], voxel resolution [3D], and total Matrix Size.
- Type of output [DVI output usually requires more performance. DVI-based output allows to put out a higher number of pixels.]
- MADRIX Effects in use and their individual settings [Different effects in MADRIX require different performance. For example, SCE Fluid, SCE Metaballs, and SCE Plasma are among the effects that require the most performance.]
- Number of Layers in use per Storage Place.
- Number of Storage Places in use [1 or 2] and render mixing via the Crossfader.
- Map Settings [The Matrix Size, and thus the pixel resolution on which effects are rendered, can easily scaled up to twice the size, for example. This will increase the performance requirements of an effect considerably.]
- Previews used in 3D Mode [3D Mode requires considerably more performance of the graphics card than 2D Mode does.]

The more pixels/voxels, Layers, and Storage Places are used, the more computer performance is required. If you aren’t sure if your configuration is sufficient, use the MADRIX Software in demo mode to test the software prior to purchase.

**Guidelines**
Important Information

- Please always pay attention to the minimum system requirements as well.
- The MADRIX Software generally runs on notebooks/laptops as well as desktop computers. Desktop computers are recommended since their available components usually provide more performance and better component cooling.
- The more performance the system provides, the better.

- The recommendations below can usually be found in so-called 'Gaming PCs' or 'Workstations' should you prefer a pre-configured system.
- Necessary input or output devices and accessories, such as computer mouse, keyboard, monitor, or cables are usually necessary, but not listed separately.

- The recommended computer components refer to the two latest product generations. This is especially true for the main processor [CPU] and the graphics card [GPU].
- The recommendations and guidelines are based on the latest information from manufacturers [such as Intel]. Changes of information and data are possible at any time.
- Please pay special attention to the details of product names and product descriptions! Often, unobtrusive abbreviations [single letters or product line suffixes, such as T, U, Y] can make a huge difference towards the provided performance of a product [such as desktop edition or mobile edition].
- The base frequency of the CPU is very important. As an example, a CPU with fewer cores and a higher base frequency might then outperform a CPU with more cores and a much lower base frequency per core.

- According to Microsoft and processor manufacturers, the latest CPU generations are only fully supported by Windows 10. As such, Windows 10 is recommended.

- Using external media [such as video files in HD or Full-HD resolution and using them in a high number] will use a lot of RAM.
- Solid-state drives [SSD] allow you to quickly load files, especially video files, by providing very high read speeds.
- Network-based communication protocols do require a network card. You may share data load/network traffic across several network cards [in case of Art-Net, for example].
- When using DVI output, you might require a graphics card with at least 2 monitor outputs to
  - A] drive the monitor,
  - B] connect to the LED controller/video processor,
  - C] connect possibly even more devices.

- When using an NVIDIA Quadro graphics card, it is necessary to change the driver settings for optimal performance. Learn more Using NVIDIA Quadro Graphics Cards

- When using 2D fixtures with a high pixel resolution as well as 3D fixtures in one, single Patch, the system requirements can extremely increase. Please contact inoage/MADRIX for more information!

  Make sure to check »PC Power Management

  Make sure to follow »Tips [Microsoft Windows / Networks / USB]

Error and omissions excepted.

Contact

Please contact us if you need more information. »Imprint And Copyright

Setting The Graphics Processor

Choosing High Performance

When using a computer that offer two graphics cards, it is recommended to choose the high-performance graphics processor. This is especially the case for laptops/notebooks, which often provide a dedicated video processor as well as an integrated graphics card.

[This option is not available when only one graphics card is being used.]
• **Right Mouse Click on the Application Icon > Run with graphics processor > High-performance processor**

![Menu options](image)

**Open**

- Run with graphics processor
- Open file location
- Troubleshoot compatibility
- Pin to taskbar
- Restore previous versions
- Send to
- Cut
- Copy
- Create shortcut
- Delete
- Rename
- Properties

**High-performance NVIDIA processor**

**Integrated graphics (default)**

**Change default graphics processor...**

---

**Selecting The Default Graphics Processor**

If the default graphics processor is set to the integrated graphics card, you can choose to select your high-performance graphics card as the default option. The step-by-step instructions below refer to drivers for NVIDIA graphics cards.

- In Windows 7, go to **Start > Control Panel > NVIDIA Control Panel > 3D Settings > Manage 3D settings > Program Settings > 1. Select a program to customize > Add > Choose MADRIX > Click Add Select Program > 2. Select the preferred graphics processor for this program: > Choose High-performance processor > Click Apply**

- In Windows 10, go to **Desktop > Right Mouse Click > NVIDIA Control Panel > 3D Settings > Manage 3D settings > Program Settings > 1. Select a program to customize > Add > Choose MADRIX > Click Add Select Program > 2. Select the preferred graphics processor for this program: > Choose High-performance processor > Click Apply**
Part A: Introduction
Using NVIDIA Quadro Graphics Cards

When using an NVIDIA Quadro graphics card, please set up the following settings:

- In Windows 7, go to Start > Control Panel > NVIDIA Control Panel > 3D Settings > Manage 3D settings > Global Settings > Global presets: > Choose Workstation App - Dynamic Streaming > Click Restore > Click Apply

- In Windows 10, go to Desktop > Right Mouse Click > NVIDIA Control Panel > 3D Settings > Manage 3D settings > Global Settings > Global presets: > Choose Workstation App - Dynamic Streaming > Click Restore > Click Apply

MADRIX will show a message to you on the first start should you not have activated the preset yet.
1.3 MADRIX KEY [Software License]

This topic includes:

- Overview
- Demo Mode
- Important Information
- Interruption-Free Operation
- MADRIX KEY & MADRIX 5 License
- End-Of-Life

Overview

The MADRIX KEY is a USB dongle.
It needs to be connected to your computer. Only then, it activates the full license of the software and corresponding output. You will receive your personal MADRIX KEY, when purchasing a MADRIX 5 Software product.

The MADRIX KEY is available as:

- **MADRIX 5 KEY start**
  [1x MADRIX KEY incl. 1x MADRIX 5 License start]

- **MADRIX 5 KEY entry**
  [1x MADRIX KEY incl. 1x MADRIX 5 License entry]

- **MADRIX 5 KEY basic**
  [1x MADRIX KEY incl. 1x MADRIX 5 License basic]
**Demo Mode**

MADRIX 5 offers a demo mode. As such, you can download the latest MADRIX Software to test for free at »[www.madrix.com](http://www.madrix.com).

What are the features of the Demo Mode?

- You can test MADRIX 5 for free.
- The software is fully functional.
- Demo mode is useful for computer and other hardware performance tests.
- Files and settings of demo mode are fully compatible with the full version [it is the same software].
- MADRIX runs in Demo Mode if you do not connect a valid MADRIX KEY to your computer.

What are the limitations of the Demo Mode?

- All Previews will display "! NO MADRIX 5 KEY !".
- All Previews and DVI outputs have a color-changing, rotating cross on top.
- All Previews have a reduced overall brightness.
- There is no output of any other control data. That means no Art-Net, DMX512, KINET, Philips Hue, Streaming ACN, ColourSmart Link, Colorlight A8, Colorlight 5A, Colorlight T9, or Eurolite T9 is sent out.
Important Information

- The MADRIX KEY is the most important item when you buy MADRIX. Do not lose it!
- A MADRIX KEY is not bound to one computer and can be used with each of your computers.
- Do not connect the MADRIX KEY to your computer before installing the MADRIX Software.

Interruption-Free Operation

To ensure interruption-free operation of the software and devices, please make sure to check the power saving settings of Windows. Learn more »PC Power Management

MADRIX KEY & MADRIX 5 License

License Check

You can check which MADRIX 5 License your MADRIX KEY provides.

- Start the MADRIX Software.
- Go to the menu Help > About...
- A new window will open.
MADRIX 5 Software

- Purchase a MADRIX 5 Software product that includes a MADRIX KEY with a MADRIX 5 License to unlock the corresponding output in the MADRIX 5 Software.
  
  Online activation is initially required one time. Learn more »[MADRIX KEY [Activation]]

- Physical shipment of the boxed MADRIX KEY required.

MADRIX 5 Licenses

- Require a valid, empty, and metallic MADRIX KEY.
  
  Online activation is initially required one time. Learn more »[MADRIX KEY [Activation]]

- Only one MADRIX 5 License is possible per MADRIX KEY.

MADRIX 5 License Upgrades
• Upgrade your MADRIX 5 License on your MADRIX KEY to a higher license in order to increase the available output.

• MADRIX 5 License Upgrades to higher licenses are possible several times per MADRIX KEY.

• Online activation is initially required one time. Learn more »MADRIX KEY [Activation]

• Require a valid and metallic MADRIX KEY with a MADRIX 5 License.

MADRIX 5 Software Updates

• Take advantage of the latest MADRIX 5 Software. This will even automatically increase your available output. Update from MADRIX 2 or MADRIX 3.

• Online activation is initially required one time. Learn more »MADRIX KEY [Activation]

• The MADRIX 5 Software Update is free of charge if you have bought MADRIX Software on April 01, 2017 or any later date.

• Requires a valid and metallic MADRIX KEY. Any green MADRIX KEY needs to be disabled and physically replaced, i.e. purchase of 1x MADRIX KEY required.

MADRIX Hardware

• All MADRIX hardware requires a MADRIX KEY with a valid MADRIX 5 License in order to work with the MADRIX 5 Software.

• No MADRIX hardware product provides a MADRIX 5 Software license automatically. A MADRIX KEY is always needed.

End-Of-Life
This electrical device and its accessories need to be disposed of properly. Do not throw the device into normal trash or household waste. Please recycle packaging material whenever possible.
1.4 MADRIX KEY [Activation]

This topic includes:
- Overview
- Online Activation
- Manual File Creation

Overview

Please activate your MADRIX KEY first, when using the MADRIX Software for the first time
[or when having acquired a MADRIX 5 License, MADRIX 5 License Upgrade, or MADRIX 5 Software
Update].

Online Activation

Please follow the steps described in the MADRIX 5 Quick Start Guide or below:

1] Make sure you are online. An active internet connection is required for the activation.

2] Download the latest MADRIX 5 Software from www.madrix.com or use at least MADRIX in version 5.0.

3] Connect the MADRIX KEY to your computer and install the MADRIX Software.
4] Start MADRIX 5 now and go to the menu Help > MADRIX KEY > Activate MADRIX KEY...

5] Enter your ticket number and follow the on-screen instructions. Double-check your MADRIX 5 License in the menu Help > About...

Manual File Creation

For the update process, you might be asked to manually create files from the MADRIX KEY. Please follow the steps below:

1] Connect exactly one MADRIX KEY to your computer!
2] Start MADRIX 5.
3] Go to the menu Help > MADRIX KEY > Update MADRIX KEY...
And a new window will open.

4] Click **Create RaC File**.
- Save the file to your harddisk.
- MADRIX will automatically choose the serial number of the MADRIX KEY as file name and add the file type *.WibuCmRaC as file extension depending on the MADRIX KEY.
- After the successful creation, the software will open the directory on your harddisk again.
- Use **View Dir** to manually open the directory where you just saved the file.
- This file needs to be sent to your supplier/dealer by e-mail.

5] You will receive a new RaU file from your supplier by e-mail.
- Save it onto the harddisk of your computer.
- This file will be of the file type *.WibuCmRaU.

6] Go again to **Help > MADRIX KEY > Update MADRIX KEY...** and click **Update MADRIX KEY**

7] Select the RaU file on your harddisk and click **OK**

8] After the successful update, the software will automatically create a new receipt file.
- The file will be of the file type *.WibuCmRaC.
- The software will open the directory on your harddisk again.
- Please send the receipt file to your supplier/dealer by e-mail.

9] Restart MADRIX.

10] Double-check if the update or upgrade was successful under **Help > About...**
1.5 Update From MADRIX 2 Or 3 To MADRIX 5

This topic includes:

- Introduction
- Setup File Conversion
- Fixture Library Conversion

Introduction

MADRIX 5.0c is a version of the MADRIX 5 Software series. Before that, MADRIX 2 and MADRIX 3 were available for several years. Users may choose to update your software license from MADRIX 2 or 3 to MADRIX 5. As such, this topic summarizes key points to remember when updating.

Setup File Conversion

MADRIX 2

MADRIX 5 uses its own file types. Please follow these steps to convert your MADRIX 2 Setup file into a MADRIX 3 Setup file, which can be loaded into MADRIX 5:

- Install MADRIX 2.14i [or higher].
- Start MADRIX 2 and load your current Setup [of the file type *.ms2].
  [Go to the menu File > Open Setup...]
- Go to the menu File > Export > Export for MADRX3... > Setup...
- A new window opens. Simply enter a name for the file and click Save
- Start MADRIX 5 and load your newly created MADRIX Setup file [of the file type *.msz].
  [Go to the menu File > Open Setup...]
MADRIX 3

- MADRIX 5 can automatically load MADRIX 3 Setup files [of the file type *.msz].
- Once saved in MADRIX 5, they are MADRIX 5 files.
- Make sure to make a backup of your old MADRIX 3 files before converting them to MADRIX 5 files.
- MADRIX 3 cannot load MADRIX 5 files.

Fixture Library Conversion

MADRIX 2

MADRIX 5 uses its own file types. Please follow these steps to convert your MADRIX 2 Fixture Library file into a MADRIX 3 Fixture Library file, which can be loaded into MADRIX 5:

- Install MADRIX 2.14i [or higher].
- Start the MADRIX 2 Fixture Editor and load your currently used Fixture Library [of the file type *.mfl].
  [Go to the menu File > Open Library...]
- Go to the menu File > Export Library for MADRX3...
- A new window opens. Simply enter a name for the file and click Save
- Start the MADRIX 5 Fixture Editor and load your newly created MADRIX Fixture Library [of the file type *.mflx].
  [Go to the menu File > Open Library...]

MADRIX 3

- MADRIX 5 can automatically load MADRIX 3 Fixture Library files [of the file type *.mflx].
- Once saved in MADRIX 5, they are MADRIX 5 files.
- Make sure to make a backup of your old MADRIX 3 files before converting them to MADRIX 5 files.
- MADRIX 3 cannot load MADRIX 5 files.
1.6  Supported Fixtures [LED Products]

This topic includes:

- Overview
- Communication With LED Products
- MADRIX Fixture Library
- MADRIX Fixture Editor
- Additional Support

Overview

The MADRIX software already includes a very large selection of configuration for various lighting fixtures. This includes 1 channel fixtures, RGB and RGBW fixtures, LED Tubes, LED sticks, LED panels, and curtains to name a few. All fixture profiles are stored in the so-called MADRIX Fixture Library. The software has access to this library and thus knows all included fixture configurations. Learn more about the MADRIX Fixture Library below.

Communication With LED Products

- Depending on your LED product, communication with your LEDs is done through interfaces, controllers, drivers, or directly with the fixtures.
- MADRIX supports various industry-wide communication standards to send data to your LEDs.
- These standards include DMX512, DVI, Art-Net, and many more.
- Learn more »OUTPUT Settings

MADRIX Fixture Library
The MADRIX Fixture Library is a file that includes all current fixture profiles. The library will be updated with every new MADRIX version as well.

The library includes profiles for products by #G-LEC, Acclaim Lighting, Acme, Alkalite, American DJ, Blizzard Lighting, Botex, BriTeQ, CHAUVET, Chroma-Q, Chromlech, Clay Paky, CLS, Coemar, Color Kinetics, Creative Consultants, Designgroup, Ehrgeiz, Elation Professional, EUROLITE, EXPOLITE, Extra Dimensional Technologies, Futurelight, GLP, Highlite, Ilumenite, img Stage Line, INSTA, LEDWalker, Lightmaster, Litecraft, Magic Led, magiclights Eventtechnology, Martin Professional, Mega Lite, Neo-Neon, Nova Vision NY, PixelRange, QuadLED, ROBE, Room Division, Schnick Schnack, Showtec, Stairville, Teko, TRAXON, Varytec, Yifeng Light, and many more!

You can create your virtual LED matrix in MADRIX using fixtures with the help of the »Matrix Generator or »Patch Editor
If you do not find your fixture in the library, you can create your own fixtures. Learn more about the MADRIX 5 Fixture Editor below.

**MADRIX 5 Fixture Editor**

The MADRIX 5 Fixture Editor is a separate application that will be automatically installed together with MADRIX. You can simply configure your own fixture profiles using this handy tool. In this way MADRIX ensures the support of available fixtures on the market. Learn more »MADRIX 5 Fixture Editor

**Additional Support**

We constantly want to make sure that we support all available products on the market. And we want to support your fixtures. If you have a lighting fixture that is currently not supported by MADRIX or if you need help with your fixture, please contact us! »Imprint And Copyright
1.7  **Supported Interfaces [DMX512 / Art-Net]**

This topic includes:
- Supported DMX512 Interfaces
- Supported Art-Net Interfaces

### Supported DMX512 USB Interfaces

**MADRIX**
- MADRIX USB ONE
- MADRIX NEO
- MADRIX PLEXUS
- MADRIX LUNA 4
- MADRIX LUNA 8
- MADRIX LUNA 16
- MADRIX NEBULA
- MADRIX STELLA
- MADRIX ORION

### Supported Art-Net Interfaces

**MADRIX**
- MADRIX PLEXUS
- MADRIX LUNA 4
- MADRIX LUNA 8
- MADRIX LUNA 16
- MADRIX NEBULA
Third Parties

All interfaces that are fully compatible with Art-Net [Art-Net I, Art-Net II, Art-Net 3, Art-Net 4] will work with MADRIX. Support is defined by product compatibility with Art-Net and not limited to specific brands.
1.8 Web Links

This topic includes:

- Overview

Overview

You can find a selection of useful internet links here:

- MADRIX Website
  - www.madrix.com
- Windows Drivers
  - www.madrix.com/support/download
- User Guides [Online And Downloadable PDF]
  - help.madrix.com
- Hardware Quick Start Guides / Technical Manuals [Downloadable PDF]
  - help.madrix.com
- Online Forum
  - www.madrix.com/support/forum
- Software Release Notes
  - www.madrix.com/products/software/releases
- Tutorials
  - help.madrix.com/tutorials/html/index.html
2 Getting Started

Introduction

Learn in this chapter how to

- install the MADRIX Software.
- get started quickly.
- configure audio input and output.
- create a stable operation environment.

Topics Of This Chapter

- »Installation Process
- »Starting The Software
- »Language Settings
- »5-Step Quick Start
- »Audio And Sound
- »PC Power Management
- »Tips [Microsoft Windows / Networks / USB]
- »Using The Mouse
- »Keyboard Shortcuts [Hotkeys]
- »Tips [Workflow]
- »Examples
• >2D Or 3D [X, Y, Z]
2.1 Installation Process

This topic includes:
- Important Notes
- Using The MADRIX USB Flash Drive
- Downloading The Software Online
- Setup Process
- Software Update

Important Information

- Please note regarding Purchased Products, Demo Mode, and Updates:
  - The MADRIX Software can be downloaded from »www.madrix.com. Regular updates of the software are also available online. If no MADRIX KEY is connected, the software will run in demo mode.
  - Learn more »MADRIX KEY [Software License]
- It is highly recommended to always use the latest software update.

Using The MADRIX USB Flash Drive

When using a MADRIX USB flash drive for the installation process, please connect the drive to a free USB port of your operational computer. The MADRIX setup will start automatically using an Auto Installer. Please wait until the setup has fully loaded. Then, proceed with the Setup Process as described below. When the Auto Installer does not launch, please navigate to the drive in Windows and manually start the setup process by performing a double-click on MADRIX_64Bit_Install.exe

Downloading The Software Online
Download *MADRIX_Full_Install.exe* from »[www.madrix.com](http://www.madrix.com)

After downloading the installer, please double-click with your mouse on this file in order to start the setup process.

Please wait while the Auto Installer is loading the setup.

Afterwards, proceed with the **Setup Process** as described below.

---

**Setup Process**

Please make sure to:

1] Log into Windows as administrator [Admin].

2] Let the computer process the setup. This may take some minutes depending on the speed of your computer.

3] Allow Windows to install all drivers. Windows may ask for your permission to install drivers and expects your confirmation. Please search for such pop-up windows; they might have opened in the background and might be covered by other windows.

4] Connect your MADRIX KEY before you start a software update. In this way, the MADRIX KEY firmware can automatically be updated if required.

---

**Please install the MADRIX Software before you connect a MADRIX KEY or a MADRIX hardware interface.**
Step 1]

- Please select your preferred language and confirm with OK
- You can always quit the setup by choosing Cancel
- Click Back in order to return to a previous step during the setup process.

Step 2]

- Click Next to start the installation.

Step 3]

- The License Agreement will appear. It outlines the terms you are agreeing to by installing the software. You must accept these terms in order to continue.
- Please click I Agree
Step 4]

- This window allows you to select which components and which drivers you want to install. A description is given for each item.

- **MADRIX** - This component is always required and refers to the MADRIX software and all additional software tools.

- **MADRIX KEY Driver** - Select if you wish to use MADRIX KEY start, entry, basic, professional, ultimate, or maximum. This installs the driver for the USB software protection dongle.

- **MADRIX Interface Driver** - Includes the drivers for all MADRIX hardware interfaces, such as MADRIX NEO, MADRIX PLEXUS, MADRIX LUNA, MADRIX NEBULA, MADRIX STELLA, MADRIX ORION, etc.

- **MADRIX KEY Firmware Update** - Installs the latest firmware on connected USB protection dongles. Please disconnect any unwanted dongles.

- **Desktop Shortcut** - Select if you wish to create a shortcut to the MADRIX software on your Windows desktop.

- **Quick Launch Shortcut** - Select if you wish to create a shortcut to the MADRIX software in your Windows taskbar.

- **Examples** - Select if you wish to install examples including setups, effects, scripts, etc. Learn more » Examples
- **Interface Drivers** - Select in order to copy the drivers for the MADRIX hardware interfaces. The drivers can be found separately in the MADRIX installation directory then.

- **WinPcap Driver** - Select if you wish to use the DVI device types Colorlight 5A, Colorlight A8, Colorlight T9, EuroLite T9, or ColourSmart Link.

- **Next** - Click Next after choosing the components in order to continue.

### Step 5]

- Choose an installation directory on your harddisk where the software will be installed. A default **Destination Folder** will automatically be provided by the setup.

- **Browse...** - Click to change the folder.

- **Install** - Click to start the installation process.
**Step 6**

- The installation process may take a few minutes.

- **Installation Complete** - Click *Next* when this message shown.

**Step 7**

- **Run MADRIX 5** - Deselect if you do not wish to start the software now.

- **Finish** - Click to quit the setup.

- When starting MADRIX for the first time, please make sure to learn more about working with Windows. Learn more »[Tips](https://www.madrix.com/tips-Microsoft_Windows/) [Networks / USB]
Software Update

Checking For New Software Version

It is always recommended to run the latest software version. MADRIX can search for new software updates.

- Select the menu Help > Check For Software Updates...

Or you can let MADRIX automatically search for updates.

- To do so, select the menu Preferences > Options... > Startup > Check For Software Updates

- Choose Skip Update if you would like to skip a particular version.

- View Release Notes - Is a link that will open your default web browser and launch the MADRIX website to show all changes and improvements of MADRIX Software updates.

- Download - Is a direct link to quickly download the latest MADRIX Software version.

Installing New Software Versions

When a new software version has been released, please update your current MADRIX installation to the newest version.
• Check and download the latest MADRIX Software directly as described above.

• You can also directly download it from »[www.madrix.com](http://www.madrix.com)

• It is not required to deinstall MADRIX before you install a new software version.

• Instead, follow the process described under [Downloading The Software Online](http://www.madrix.com).

• The installer will ask you if you would like to update your current MADRIX software installation. Confirm with **Yes**.
2.2 Starting The Software

This topic includes:
- Desktop Shortcut
- MADRIX Setup File
- Windows Start Menu

Introduction

You can start the MADRIX Software in different ways. Among those, the Windows Start Menu is the standard way to launch applications under the Windows operating system.

Desktop Shortcut

- **Left Mouse Double-Click** - Perform a double-click with your left mouse button on the desktop shortcut in order to start the MADRIX Software.
- It is required that the shortcut has been manually placed on the Desktop or was automatically installed during the »Installation Process

MADRIX Setup File
- **Left Mouse Double-Click** - Perform a double-click with your left mouse button on the MADRIX Setup file in order to start the MADRIX Software.
  - The project and configuration that is included in the Setup file will automatically be loaded.

## Windows Start Menu

- In Windows, go to `Start > MADRIX 5 > MADRIX 5`
  - The MADRIX Software will start.

In addition, the Start Menu contains the following main items:

- **MADRIX 5**
- **MADRIX 5 Fixture Editor**
- **MADRIX 5 Device Updater**
- **MADRIX 5 KEY Firmware Updater**
- **MADRIX 5 Quick Support**
- **MADRIX 5 Restore**
- **MADRIX 5 Time Code Sender**
- **MADRIX 5 verbose**
- **Help MADRIX 5 Fixture Editor**
- **Help MADRIX 5 PLEXUS**
- **Help MADRIX 5 Script**
- **Help MADRIX 5**
- Manual MADRIX 5 Fixture Editor
- Manual MADRIX 5 PLEXUS
- Manual MADRIX 5 Script
- Manual MADRIX 5
- Quick Start MADRIX 5 LUNA
- Quick Start MADRIX 5 NEBULA
- Quick Start MADRIX 5 ORION
- Quick Start MADRIX 5 PLEXUS
- Quick Start MADRIX 5 STELLA
- Quick Start MADRIX 5
2.3 Language Settings

This topic includes:
- Changing The User Interface Language

Changing The User Interface Language

Before starting work with the MADRIX Software, you can choose the language of the user interface. Navigate to the main menu at the top of the software window.

- In the menu Language, choose from:
  - Deutsch [German]
  - English
  - Español [Spanish]
  - Français [French]
  - 简体中文 [Simplified Chinese]

[This user manual is only written in English.]
2.4 5-Step Quick Start

This topic includes:
- Introduction
- First Use

Introduction

If you want to quickly start using the MADRIX Software, we recommend to at least set up the following initial configuration.

First Use

Step 1] Configure The Virtual LED Matrix

You need to tell MADRIX how your LED installation looks like and how many fixtures [or pixels, voxels] you wish to use. Start by using the Matrix Generator for this task or use the default configuration. By default, MADRIX will have set up 50 x 50 x 1 DMX-based RGB pixels.

Learn more »Matrix Generator

Step 2] Configure Audio

Many MADRIX Effects work without audio. But many MADRIX Effects do require audio input. Configure audio to see stunning S2L or M2L effects that react to the music in real time and play back video files with their audio track.

Learn more »Audio And Sound
Step 3] Configure Output

MADRIX needs to communicate with your LED fixtures. The software is very versatile and supports many industry standards and communication protocols to put out data. Because of this, you need to configure which output method MADRIX should use to control your LEDs.
Learn more » OUTPUT Settings

Step 4] Basic User Interface And The Crossfader

MADRIX is very easy to use. To quickly see results, it is recommended learn a few basics about the user interface first.
Learn more » Crossfader
Learn more » Main Output / Master / Audio Levels

Step 5] MADRIX Effects

There is a whole variety of stock effects and lighting visuals available to you. And you can customize all of them. Begin to use the creative power of MADRIX and start using the built-in MADRIX Effects.
Learn more » Effects
2.5 Audio And Sound

This topic includes:
- Introduction
- Audio Configuration In The Windows Operating System
- Audio Configuration In The MADRIX Software
- Troubleshooting

Introduction

- Overview
- Audio Input Sources
- Audio Output Sources

Overview

MADRIX 5 supports audio input as well as audio output.

- Audio input is used for a variety of MADRIX Effects and therefore audio-reactive visuals. The software uses incoming audio signals to create lighting effects. These include the S2L, M2L, and MAS Effects.
- Audio output is used as audio playback for video files in the SCE Video Effect.

MADRIX can work with an audio signal and it can work without an audio signal. But audio input is highly recommended. S2L and M2L Effects will create unique real-time effects based on sound, which will take your lighting display to the next level.

Audio Input Sources

Audio input can come from different sources [internal or external]. It is just a matter of configuration. MADRIX will allow you to set up every device that the Microsoft Windows operating system offers for recording.
Internal sources:
- Software MP3 players [including other audio file types or music tracks]
- Other music or audio applications
- Microphone [e.g., built into notebooks]
- Audio-CD
- Stereo Mix
- Others

External sources:
- Line-In
- Microphone
- SPDIF
- Others

**Audio Output Sources**

Audio output can only come from videos played back in the SCE Video Effect. [The MADRIX Software is primarily a lighting control tool without advanced audio functions.]

Learn more »[SCE Video](#)

**Audio Configuration In The Windows Operating System**

- [Overview](#)
- [Sound Recording Device](#)
- [Sound Playback Device](#)
- [Volume Mixer](#)
Overview

If MADRIX should use an audio input or audio output signal, you have to define the proper audio device in Windows first.

Sound Recording Device

The Recording device is used for audio input.

- In Windows 7, go to **Start > Control Panel > Sound**
- In Windows 10, go to **Start > Windows System > Control Panel > Sound**
- A new window will open.
- Select *Recording*

![Sound window]

- Call up the context menu by using a right click with your mouse in this window [*Right Mouse Click*].
- Enable *Show Disabled Devices*
- Enable *Show Disconnected Devices*
• Stereo Mix is the recommended recording device.

• **Right Mouse Click** on **Stereo Mix** and choose **Enable**

• Or you can use any other input source.
  - **Right Mouse Click** on the input source [e.g., Line In] and choose **Enable**
  - [You may have to plug an audio jack into Line In before it gets activated in Windows.]

• Afterwards, also click **Set as Default Device** in the context menu.

• If you do not have a useful recording device available, you may install a virtual audio cable to solve the issue. Please search the web for proper downloadable software.
Finally, **Stereo Mix** [or any other input source] is activated and correctly set as recording source.

- MADRIX can now analyze your music from software applications [such as Windows Media Player or Winamp] or use the signal from your defined input source.
- Click **OK**

### Sound Playback Device

The Playback device is used for audio output.

- In Windows 7, go to **Start > Control Panel > Sound**
- In Windows 10, go to **Start > Windows System > Control Panel > Sound**
- A new window will open.
- Select **Playback**
Call up the context menu by using a right click with your mouse in this window [Right Mouse Click].

Enable **Show Disabled Devices**

Enable **Show Disconnected Devices**

Choose your preferred audio output device [such as **Speakers**].

**Right Mouse Click** on **Speakers** and choose **Enable**

Or you can use any other playback device.

- **Right Mouse Click** on the playback device [e.g., Digital Audio] and choose **Enable**

Afterwards, also click **Set as Default Device** in the context menu.

Finally, **Speakers** [or any other output device] is activated and correctly set as playback device.

MADRIX can now output the sound track of videos.

Click **OK**
Volume Mixer

Make also sure to set the right settings for the Windows Volume Mixer.

- Find the Windows Taskbar and its toolbars.
  [It is usually positioned at the bottom of the monitor.]

- Right Mouse Click on the Sound symbol

- Choose Open Volume Mixer

- Make sure that your sound recording devices and sound playback devices have the right sound level.
- Make sure that it is not 0 or no sound can be processed by the MADRIX Software.

Audio Configuration In The MADRIX Software
Overview

- Go to the menu Preferences > Device Manager... > Audio
  [Keyboard shortcut: F4 > Audio]

Audio Input Configuration With WDM

- Enable Audio Input
  - Enables the standard Windows audio drivers [Windows Driver Model]. It is activated by default.
- **Audio Device** - Shows all available audio input sources.
  - You can properly assign your Stereo Mix, Line In, Microphone, or other specific devices by selecting the device from the drop-down list.
  - **Stereo Mix** is the accumulation of all channels and often is used as default. [This setting is recommended.]
  - If you cannot select your preferred audio input device, make sure it is correctly set up in Windows. Learn more about [Sound Recording Device](#).

- **Use For S2L Effects** - Is activated by default. Deactivate this option if incoming audio signals should not be used for MADRIX S2L Effects [not recommended].

- **Use For M2L Effects** - Is activated by default. Deactivate this option if incoming audio signals should not be used for MADRIX M2L Effects [not recommended].

### Audio Input Configuration With ASIO

ASIO [Audio Stream Input/Output] is a widely known audio standard. Above all, the standard provides low latency; a feature often requested by professionals. When using ASIO, the MADRIX audio analysis will be faster and more precise. While the WDM drivers often provide 100 FPS, even higher sampling rates are possible with ASIO. ASIO is a registered trademark of Steinberg Media Technologies GmbH.

- **Before using ASIO with MADRIX,** please make sure that the ASIO drivers are installed on your computer. If the drivers are not installed, MADRIX will not be able to find the ASIO audio hardware.

- **It is recommended to connect external ASIO hardware [a USB sound card, for example] directly to a USB controller of your PC.** It is not recommended to use a USB hub or the front-USB of your computer.

- **Use USB 2.0.**

- **Enable Audio Input**

  - Enables the ASIO audio drivers.
Configure the following settings:

- **Audio Device** - Select your interface or sound card in this drop-down list.
- **Left Channel** - Select the appropriate device for the left audio channel.
  - If you are seeing the message *No input channel was found!* [like shown in the screenshot above], please connect your ASIO device.
- **Right Channel** - Select the appropriate device for the right audio channel.
  - If you are seeing the message *No input channel was found!* [like shown in the screenshot above], please connect your ASIO device.
- **Use For S2L Effects** - Is activated by default. Deactivate this option if incoming audio signals should not be used for MADRIX S2L Effects [not recommended].
- **Use For M2L Effects** - Is activated by default. Deactivate this option if incoming audio signals should not be used for MADRIX M2L Effects [not recommended].

Will let you configure your ASIO device further if advanced settings are available. Usually, the ASIO drivers that come with your interface will be launched. Make sure that your ASIO hardware is connected. Or else, no configuration window may be launched.
In this configuration window you can set various settings. The music analysis will be more precise if the latency / amount of samples is as low as possible. Often, this setting is called 'Buffersize'. You can achieve milliseconds with ASIO. 1000 frames represent 1 ms. 500 frames represent 2 ms. 250 frames represent 4 ms, and so on. You will be able to see the number of frames that is captured in the Task Watcher.

- Click **Apply** to save the settings.

**Audio Output Configuration**

- Enable **Audio Output**

MADRIX will automatically use the sound playback device configured in the Windows operating system. Learn more [Sound Playback Device](#).

**Audio Performance**

The results of the audio analysis are mainly influenced by the following factors:

- Computer speed.
Level of the audio signal.

Audio Performance settings.

You are able to adjust Audio Performance settings, which are the parameters for the audio analysis.

- Go to the menu **Preferences > Audio Performance...**
  [Keyboard shortcut: **Ctrl+Alt+A**]
- A new window will open.

![Audio Performance settings](image)

- **S2L M2L Performance** - Defines how much data is available for the audio analysis. The default value is 3.
  - The higher the value, the more data is available and the more precisely especially M2L Effects can be. That also means that the delay increases [in ms]. If the value is too high, it can affect the performance of MADRIX/of the computer.
- **M2L Cleaner** - Works only for M2L Effects and harmonic frequencies. It cleans the incoming audio signal for resonances and secondary frequencies to filter out unwanted tones.
  - The higher the value, the more likely a note/tone has in fact occurred in the music. But the higher the value, the more notes will be filtered out as well.
- **M2L Threshold** - Works only for M2L Effects and defines a threshold value.
  - The higher the value, the more likely a certain note/tone has in fact occurred in the music.
  - The lower the value, the more notes will be used for M2L Effects.
  - **Setting up a very low M2L Sensibility value [such as 0] can require a lot of computer performance and might negatively affect the display of S2L Effects and M2L Effects. Increase the value again if you are experiencing any issues.**
- **Defaults** - Restores the default settings.
- **OK** - Applies any changes and closes the window.

- **Apply** - Applies any changes without closing the window. [In this way, this allows you to quickly test different settings. Change the settings, click Apply, and observe the results for S2L and M2L Effects.]

- **Cancel** - Disregards any changes and closes the window.

---

**Different styles of music may require different Audio Performance settings for an optimal display.**

---

**Volume**

The volume or audio input level as well as audio output level can be controlled on the user interface.

- Learn more »[Main Output / Master / Audio Levels](#)
- Learn more »[SCE Video](#)

---

**Troubleshooting**

If you are having problems with the audio configuration, try the following:

- Select **Preferences > Device Manager... > Audio > Defaults** to restore the default settings. Alternatively, select the correct audio device [e.g., Stereo Mix].
  Then, click **Apply**. Click **OK** to close the window.

- Check the Windows audio settings and see if your recording or playback devices are configured correctly.

- Check that the Windows Volume Mixer has the right sound levels and is not set to 0.

- Check the installation of the [latest] drivers of your sound card.

- Check the installation of Microsoft DirectX®.

- Test with a different sound card.

- If you are encountering problems with ASIO [when effects freeze or single frequencies overmodulate], change the latency settings. A higher latency and thus lower capture frame rates can solve the problem.
2.6 PC Power Management

This topic includes:
- Why Is Power Management Important?
- Usage
- Activate High Performance
- How To Change USB Power Settings

Why Is Power Management Important?

We strongly recommend to deactivate all power saving options in Microsoft Windows in order to ensure an interruption-free operation of MADRIX.

Microsoft Windows operating systems offer a wide variety of power management options. In most cases, laptops, notebooks, and netbooks benefit from a longer battery life if a good power management is in use. But certain problems might occur because of computer power savings nevertheless:

- After a while your MADRIX KEY cannot be identified by the software anymore.
- Your hardware interfaces are suddenly deactivated.

Usage

Make sure to set up power-saving settings especially if you are using:

- A MADRIX KEY [USB dongle]
- MIDI controllers [via USB]
- USB hardware interfaces [such as MADRIX NEO]
- A notebook/laptop to run MADRIX
Additionally:

- Make sure to change the USB power settings.
- Especially for notebooks, we recommend to activate the High performance power plan.

**Activate High Performance**

This setting will make sure that your notebook or laptop will have all its potential performance available for MADRIX.

- In Windows 7, select **Start > Control Panel > Power Options**, and change the power plan to **High performance**
  [You might need to click on Show additional plans].
- In Windows 10, select **Start > Windows System > Control Panel > Power Options**, and change the power plan to **High performance**
  [You might need to click on Show additional plans].
How To Change USB Power Settings

- In Windows 7, select **Start > Control Panel > Power Options > Change power-saving settings / Change plan settings**
- In Windows 10, select **Start > Windows System > Control Panel > Power Options > Change plan settings**

- Click **Change advanced power settings**
- Especially the **USB settings** are important. Disable the suspend settings!

![Power Options](image)

- Change any other settings that might interrupt the operation as required.
2.7 Tips [Microsoft Windows / Networks / USB]

This topic includes:
- Errors When Saving Files
- USB
- The Windows Firewall
- Working With Ethernet Networks
- Changing The Priority Of Network Adapters
- Working With Files
- Operating System Security
- Up-To-Date Drivers
- Windows Restart / Shut Down
- Monitoring Computer Performance

Error When Saving Files

If you are experiencing issues when trying to save files, there are two solutions to this problem:
Right Click > Run as administrator
- In order to save files as a user that is logged-in into Windows, you need to have the permissions set by Windows to do so.
- When you do not have the right permissions, saving files can lead to errors.
- To circumvent such issues, you can run the MADRIX Software as administrative computer user, the so-called administrator.
- Perform a right mouse click on the MADRIX.exe [or a shortcut to the MADRIX Software] and choose Run as administrator
- Note: You need to have access to the administrator account (i.e., password). Logging in as administrator grants extensive rights for any computer changes. If you are not familiar with Windows or computers, please seek advice.

Choose A Different Directory
- When you are experiencing issues and running as administrator is not an option, choose a different directory on your harddisk to save the files.
- There are locations on your computer/harddisk where you will have the permission to save files. Choose such a location.
- Examples are:
  C:\Users\USERNAME\Desktop
  C:\Users\USERNAME\Documents
  [USERNAME specifies your Windows account name.]

USB
Among others, USB is an important way to work with MADRIX, MADRIX KEYS, MADRIX hardware interfaces, MIDI controllers, etc. In order to ensure a stable work environment, we highly recommend setting up corresponding USB settings in Windows.

Learn more » [PC Power Management]

---

**The Windows Firewall**

**Correct Settings**

The primary purpose for the Windows Firewall [or any other firewall] is to block any unwanted incoming or outgoing data and access. But this can lead to problems, when data that should go through is automatically blocked. MADRIX will automatically set the correct firewall settings for you during the installation process.

Please follow the steps below if this Windows message appears when you start the MADRIX Software for the first time.

Select and set a checkmark for

- **Private networks**

and
- **Public networks**

- Click *Allow access* to confirm.

**Not selecting both options can cause problems with network communication.**

### Resetting The Settings

If you have already chosen the wrong options MADRIX, you can delete the settings and choose again.

- In Windows 7, go to **Start > Control Panel > Windows Firewall > Advanced settings > Inbound Rules**
- In Windows 10, go to **Start > Windows System > Control Panel > Windows Defender Firewall > Advanced settings > Inbound Rules**
- Select and delete any entries relating to MADRIX [e.g., madrix.exe or MADRIX - music makes the light].
- With your next start of MADRIX, select both options as described above.
Working With Ethernet Networks

Configuration Of Network Settings

When working with network-based products and MADRIX [for example, Art-Net, KiNET, sACN, etc.], you will have to set up the IP address of your network card in Windows. Learn how to set it up here.

- In Windows 7, go to **Start > Control Panel > Network and Sharing Center > Change adapter settings > Local Area Connection > Properties > Internet Protocol Version 4 (TCP/IPv4) > Properties**
- In Windows 10, go to **Start > Windows System > Control Panel > Network and Sharing Center > Change adapter settings > Local Area Connection > Properties > Internet Protocol Version 4 (TCP/IPv4) > Properties**
[Part B] Getting Started
Set up the following settings:

- **Enable Use the following IP address:**
  - **IP address** - Sets the IP address for this computer and this network card.
    - If you have several network cards in your computer, you can set up an individual address for each network card.
    - An IP address has 4 parts. Enter the complete address as explained in the specific chapter of this user guide [e.g., 10.0.0.1].
    - You only have to enter the numbers.

- **Subnet mask** - Sets up the Subnet mask for this computer.
  - This is an important part of the network settings, just as the IP address.
  - A Subnet mask has 4 parts. Enter the complete address as explained in the specific chapter of this user guide [e.g., 255.0.0.0].
  - You only have to enter the numbers.

- **OK** - Click to save your settings.
  - [Make also sure to close the Local Area Connection Settings with OK and close the Local Area Connection Status window with Close.]

- Restart the MADRIX Software if you have changed any network settings!

Learn more below.

**Using Several Devices In A Network**
Usually, you will use at least 2 devices in a network [for example, 1 MADRIX PC and 1 Art-Net node or 1 MADRIX PC and 1 console]. As explained above, you will need to configure various network settings not only for your MADRIX PC but also for the other devices.

To be able to communicate with each other, all devices have to be in "the same network". That means:

- All devices need to be physically connected with each other [through network equipment, such as hubs or switch and/or network cables]
- All devices need to have compatible network settings

Using several devices in a network does not mean that all should have the same IP address. That will not work! Instead, follow these rules:

- **Set up all devices within the same IP address range, but never with the same IP address**
  
  [for example, MADRIX PC: 10.204.226.101 and Art-Net node: 10.204.226.102]
- **Set up all devices with the same Subnet mask e.g., 255.0.0.0**
- **If recommended, set up all devices with the same Default gateway [e.g., 10.0.0.1]**

### Changing The Priority Of Network Adapters

You can change the order in which Windows and MADRIX accesses your network adapters. By changing the order, you can specify which network adapter [network card] is used first and as the main connection.

1. In Windows 7, go to **Start > Control Panel > Network and Sharing Center > Change adapter settings**
2. In Windows 10, go to **Start > Windows System > Control Panel > Network and Sharing Center > Change adapter settings**
2] Press **Alt** on your keyboard.

- A menu appears at the top, which is otherwise hidden.

3] Go to **Advanced > Advanced Settings**...

- A new window opens.
4] Select your preferred network connection[s] in the list of **Connections**:

5] Change the order by clicking on the **green up and down arrow buttons** on the right hand side.
   - The connection which is listed on top, is the first and prioritized adapter.

6] Click OK to confirm.

7] Restart your computer.

**Working With Files**

When working with computers in general, you should be aware that any digital data is sensitive and prone to failure and hardware errors.

We recommend

- to save regularly when creating a show in MADRIX.
- to make backup copies of your show files from time to time [MADRIX Setup files]
- to make backup copies to different or external storage mediums [e.g., USB stick/thumbdrive].
Operating System Security

It is recommended

- to keep Windows up-to-date by installing security updates using *Windows Update*
- to use a virus detection software when working with files from external sources.

Up-To-Date Drivers

Please always keep all component drivers up-to-date by installing the latest available driver. Among others, this may include drivers for:

- Processor
- Graphics Card
- USB
- Capture Card
- Sound/Audio Card
- Video Codecs

Windows Restart / Shut Down

According to the requirements of Windows, MADRIX will behave in the following way:

- MADRIX will be closed instantly, when you trigger a Restart or Shut Down of Windows.
- If you have not saved any changes yet, you may be provided the chance and a short time frame [30 seconds] to react and save your progress before the MADRIX software is forcefully closed by Windows itself.
- **Make sure to save your files before executing a Restart or Shut Down!**
Monitoring Computer Performance

Windows allows you to monitor the overall performance of your computer.

- Press **Ctrl + Alt + Del** and choose **Start Task Manager**
  [German shortcut: Strg + Alt + Entf]
- A new window opens [Windows Task Manager].
- Go to **Performance**

![Task Manager](image)

- You can now monitor the **CPU Usage** as well as the **Memory** usage.

- MADRIX has its own monitoring tools.
  Learn more »**Tools**
2.8 Using The Mouse

This topic includes:

- Overview

Overview

The mouse is the main input device to work with a software like MADRIX. In this topic various general functionalities are provided as an overview.

Deviating functionality is explained throughout this manual when necessary. Some controls on the user interface can support several of the functionalities described below.

Left Mouse Click

- Click once on the left mouse button to perform various actions:

  Selection - Selects a button, fader, list item, text, number, on the user interface.

  Open Window - Opens a window that grants access to another part of the software.
  [A small, black square will be shown as overlay on top of the control in the upper left corner if you hover with your mouse of the button.]
**Left Mouse Click**

- Click once on the left mouse button to perform various actions:

  **Show Selection Menu** - Opens a submenu for you to choose and select a different item from the provided options.
  [Two small, black lines will be shown as overlay on top of the control in the upper left corner if you hover with your mouse of the button.]

  **Activate / Deactivate** - Activates or deactivates a button or check box in order to enable or disable the corresponding functionality.

  **Action** - Activates a button once to perform a specific action.
  [A black line will be shown as overlay on top of the control in the upper left corner if you hover with your mouse of the button.]

**Left Mouse Click And Hold**

- Click once on the left mouse button, continue to hold the button, and finally release the mouse button to perform various actions:

  **Move** - Moves a control, such as a fader, to a different position in order to set a different value.

  **Increase / Decrease** - Select a number in an input field and move the mouse up or down while continuing to hold the left mouse button in order to increase or decrease the selected value.
**Left Mouse Click And Hold**

- Click once on the left mouse button, continue to hold the button, and finally release the mouse button to perform various actions:

  **Show Control** - Shows the full control, such as a vertical slider or color control, for you to set a different value.
  
  [A visual representation will be shown as overlay on top of the control.]

  **Activate Temporarily** - Activates a specific functionality only as long as you continue to hold the mouse button.

  **Drag And Drop** - Click with the left mouse and hold. A small + appears. Continue to hold and move your mouse to the same kind of control. Release the mouse button to paste a copy onto the other control.

**Left Mouse Double-Click**

- Quickly click twice on the left mouse button to perform various actions:

  **Restore Default Value** - Double-click on a control, such as a horizontal fader, to restore the default value.

  **Edit Value** - Allows you to edit an item in a list.

  **Activate Permanently** - Double-click on a control, such as a button, to activate the functionality until you click on the control again to deactivate it.
Right Mouse Click

- Click once on the right mouse button to perform various actions:

  **Context Menu** - Shows the corresponding context menu and hence allows you to perform further actions. [Two small, black lines will be shown as overlay on top of the control in the upper right corner if you hover with your mouse of the button.]

  **Edit Value** - Allows you to edit an item in a list or multiple items when multiple items have been selected first.

  **Restore Default Value** - Right click on a control, such as a vertical fader, to restore the default value.

2.9 Keyboard Shortcuts [Hotkeys]

This topic includes:

- Overview

Overview

You can use various shortcuts on the computer keyboard, while working with MADRIX.

Specific Functionality:

<table>
<thead>
<tr>
<th>New Setup</th>
<th>Ctrl+N</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Setup...</td>
<td>Ctrl+O</td>
</tr>
<tr>
<td>Save Setup</td>
<td>Ctrl+S</td>
</tr>
</tbody>
</table>
### General Functionality:

- **Help And Manual [User Guide]**  
  F1

- **Various functions [e.g., Reset, Color value 0 or 255, Selection, etc.]**  
  Space

- **Select all characters of a number, word, etc. / Select all items of a list**  
  Ctrl+A

- **Confirm your selection**  
  Enter

- **Remove items from list**  
  Backspace, Del [Delete]

- **Move items in list [Up, Left, Down, Right]**  
  W, A, S, D [QWERTY] \n  Z, Q, S, D [French AZERTY]
<table>
<thead>
<tr>
<th><strong>Cancel</strong></th>
<th><strong>Esc [Escape]</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Close a window [e.g., Cue List, Fader Box, Macro Editor, etc.]</td>
<td>Alt+F4</td>
</tr>
</tbody>
</table>
2.10 Tips [Workflow]

This topic includes:
- Windows Taskbar
- On-Screen Keyboard

Windows Taskbar

If do not wish to use the integrated full-screen mode of the software [Full-Screen Mode], you can still maximize the screen size that is available to you.

- In Windows 10, **Right Mouse Click > Taskbar settings** - Perform a right mouse click on the Windows Taskbar and choose Taskbar settings.
- Or go to **Start > Settings > Personalization > Taskbar**

- Set **Automatically hide the taskbar in desktop mode** to **On**
- Set **Use small taskbar buttons** to **On**

On-Screen Keyboard

If you are missing a physical keyboard on your computer, if you currently cannot reach it, or if it is not accessible to you in any other way, you can choose to use the on-screen keyboard provided by the Windows operating system.

- In Windows 10, go to **Start > Windows Ease of Access > On-Screen Keyboard**
2.11 Examples

This topic includes:
- Installation
- More Information

Installation

During the MADRIX installation process, you can choose to install various examples. These samples include:

- Setups,
- Effects,
- Scripts,
- And Color Tables.

During the setup, choose Examples from the list of components.
After the installation, you can find the examples on your hard disk.

- Navigate to C:\Users\USERNAME\Documents\MADRiX5 Samples\  
  [Please insert your Windows username for USERNAME].

**More Information**

MADRiX uses a variety of different kinds of files.  
Learn more »[File Types](#)
2.12 2D Or 3D [X, Y, Z]

This topic includes:
- Introduction
- Settings
- 2D [X-Axis And Y-Axis]
- 3D [X-Axis, Y-Axis, And Z-Axis]

Introduction

MADRIX is a versatile and powerful software that can control 2D and/or 3D LED installations.

You can use MADRIX

- to map and control pixel by pixel [pixel mapping, 2D].
- to map and control volumetric pixels, i.e. voxels [voxel mapping, 3D].
- to combine both options.

Settings

Virtual LED Matrix

You automatically choose to work with a 2D or 3D project by configuring the virtual LED matrix in the Matrix Generator or Patch Editor.

- If Z is 1, then you are automatically working in 2D.
• If Z higher than 1, then you are automatically working in 3D.

  Learn more »Matrix Generator
  Learn more »Patch Editor

**Workflow**

In addition, many other parts of the software can work in 2D mode or in 3D mode. For example:

• Previews
• Effects
• Mapping

  Learn more »3 Previews
  Learn more »MADRIX Effects
  Learn more »Mapping / Tiling / Rotation

**2D [X-Axis And Y-Axis]**

• In 2D, only 2 axes are involved:
  - X-Axis [horizontal]
  - Y-Axis [vertical]
3D [X-Axis, Y-Axis, And Z-Axis]

- In 3D, 3 axes are involved:
  - X-Axis [horizontal]
  - Y-Axis [vertical]
  - Z-Axis [depth] [Z-levels]
//PART C

User Interface [GUI]
3 User Interface [GUI]

This topic includes:

- Introduction
- Overview
- Topics Of This Chapter

Introduction

The user interface is what you see of the software. You will immediately see it when starting MADRIX for the first time. This graphical user interface [abbr.: GUI] provides visual feedback, controls, and information for you.

The GUI is one of the most important parts of MADRIX. We designed it with you—the user—in mind and to provide great usability, easy to use controls, and the most efficient ways to operate the software. The following topics will help you get to know the different parts and individual elements of the layout.

Overview

The GUI of MADRIX is divided into different parts. The following chapters will explain each section in more detail.
Topics Of This Chapter

- **Menu**
  This topic introduces the menu bar of the software found at the top of the screen.

- **Operating Modes [Programmer / Operator]**
  MADRIX provides different modes for different parts of the overall workflow.

- **3 Previews**
  3 Preview Windows [Preview Deck A, Preview Deck B, and Preview Output] will show you a preview of your lighting effects. They are explained in detail here.

- **Crossfader**
  Learn how to use the Crossfader.

- **Main Output / Master / Audio Levels**
  What is the purpose of these controls? It is explained in this topic.

- **Controls [Deck A / Deck B]**
  Quickly set up the global filters and other controls.

- **Storages**
  A brief overview will introduce all the controls of Storage Deck A and Storage Deck B.

- **Storage Places [256 x 256]**
  Learn how to manage and organize your visuals.

- **Effect Areas [Deck A / Deck B]**
  How can I use Effects? Effect Area Deck A and Effect Area Deck B will be explained here.

- **Cue List Section**
  These buttons are used to control the automatic playlist feature of MADRIX.

- **Full-Screen Mode**
  You can use the full size of your monitor to display the user interface of MADRIX.

- **Touch Screen**
  An additional touch screen interface is built right into MADRIX. Learn more about it in this topic.
3.1 Menu

This topic includes:
- Introduction
- Extra Information Displayed
- File Menu
- View Menu
- Preferences Menu
- Tools Menu
- Previews Menu
- Help Menu

Introduction

Several menus are located at the top of the MADRIX window. In addition, there are several sub-menus to choose from.

Extra Information Displayed

Ctrl+N - This represents a keyboard shortcut that will perform the action directly rather than using the menu.
... - Indicates that a new window will open on top of the main MADRIX window.
> - Indicates that this entry has sub-entries.

File Menu
File

- **New Setup** - Creates a new MADRIX Setup file. This file will include your entire show and certain configurations of the software. A new Setup file is empty.

- **Open Setup...** - Loads a previously saved Setup file [of the file type *.msz or *.msx].

- **Save Setup** - Saves your show settings in an external file [of the file type *.msz or *.msx] in order to preserve them.

- **Save Setup As...** - Saves your Setup file as a separate, duplicate file. And you can choose a different name.

- **Import** - Loads different parts of a show into your currently opened Setup file.
  
  You may load a complete Storage [including all of its Storage Places], a single Storage Place, a Patch, the Group Control, DMX Device Settings, and DVI Device Settings

- **Export** - Saves the above described parts of a show into external files.
  
  You may save a Storage, a Storage Place, a Patch, the Group Control, DMX Device Settings, and DVI Device Settings

  Choose Export > Storage Place > All... to save all occupied Storage Places, all in separate files.

- **Recent Files** - Displays Setup files that were used last. Click on an entry to quickly load this Setup file.

- **Exit** - Closes the software.

Learn more » **File Types**
View Menu

- **Touch**... - Opens the additional touch screen user interface to control MADRIX via a touch screen panel. 
  Learn more » [Touch Screen](#)

- **Move Touch To Next Screen**... - Relocates the additional touch screen user interface to the next monitor or display [away from the main monitor].
  Learn more » [Touch Screen](#)

- **Theme > Dark** - Activates the user interface theme that is darker.
- **Theme > Light** - Activates the user interface theme that is light.

- **Theme > Switch To Next Theme** - Changes away from the currently selected theme to the next theme [either light or dark].
- **Full Screen** - Maximizes the graphical user interface to fit the entire screen of your monitor.
  Learn more » [Full Screen Mode](#)

- **Restore Default Size** - Applies the default window size. As such, it resets any changes in size you made to the MADRIX window by moving its borders with the mouse.

Preferences Menu
- **Matrix Generator**... - Setting up your virtual LED matrix is a required step. This tool is the easiest way to do that.
  Learn more »[Matrix Generator](#)

- **Patch Editor**... - Is an advanced tool to set up your virtual LED matrix, which is required. The Patch Editor offers much more options than the Matrix Generator.
  Learn more »[Patch Editor](#)

- **Device Manager**... - Is the main tool to configure your [hardware] devices.
  Learn more »[OUTPUT Settings](#), »[INPUT And Remote Control](#), »[Audio And Sound](#)

- **Audio Performance**... - Offers advanced options for the audio analysis.
  Learn more »[Audio And Sound](#)

- **Remote Control**... - Offers different options for controlling MADRIX remotely [incl. HTTP, DMX, and MIDI].
  Learn more »[INPUT And Remote Control](#)

- **Backup System**... - Allows you to set up a fallback solution.
  Learn more »[Backup System](#)

- **Options**... - Allows you to configure various important settings for the software.
  Learn more »[Options](#)

---

**Tools Menu**
### Tools

- **Cue List...** - Opens the Cue List.
  
  Learn more »[Cue List](#)

- **Group Control...** - Opens the Group Control.
  
  Learn more »[Fixture Groups](#)

- **DMX Fader Tool...** - Allows you to send individual DMX values on top of any other data output.
  
  Learn more »[Tools](#)

- **Logfile...** - Keeps track of all warnings and error messages as well as information about the computer system.
  
  Learn more »[Tools](#)

- **Task Watcher...** - Provides detailed operational information.
  
  Learn more »[Tools](#)

- **DMX Watcher...** - Allows you to monitor any DMX Output or DMX Input.
  
  Learn more »[Tools](#)

- **MIDI Watcher...** - Allows you to monitor incoming MIDI signals.
  
  Learn more »[Tools](#)

- **Record Editing...** - Opens a tool to edit recorded MADRIX Effects.
  
  Learn more »[Recording](#)

- **PLEXUS Configuration...** - Is a tool to configure and manage MADRIX PLEXUS interfaces.
  
  Learn more »[MADRIX PLEXUS](#)
- **MADRIX Device Configuration**... - Is a tool to configure and manage MADRIX LUNA, MADRIX NEBULA, MADRIX STELLA, and MADRIX ORION interfaces.

  Learn more » [MADRIX LUNA](#)
  Learn more » [MADRIX NEBULA](#)
  Learn more » [MADRIX STELLA](#)
  Learn more » [MADRIX ORION](#)

## Previews Menu

MADRIX features a number of Preview Windows. These sub-menus give access to their context menus.

Learn more » [2 Previews](#)

## Language Menu
- **Deutsch** - Activates the German language for the software user interface.
- **English** - Activates the English language for the software user interface.
- **Español** - Activates the Spanish language for the software user interface.
- **Français** - Activates the French language for the software user interface.
- **简体中文** - Activates the *Simplified Chinese* language for the software user interface.

**Help Menu**

- **User Manual...** - Opens this user guide, locally on your computer.
- **User Manual Online** - Opens this user guide online by calling up a website using your default web browser. This requires an internet connection.

- **Forum** - Is an online link that will take you to the MADRIX Online Forum, where users and developers exchange ideas about MADRIX. This requires an internet connection.

- **Feedback** - Is an online link that will open your web browser with the MADRIX Contact Form. If you wish, please enter your comments into the form and send it to us. Thank you! This requires an internet connection.

- **Website** - Is an online link for the MADRIX website »www.madrix.com. This requires an internet connection.

- **Launch Remote Support Tool...** - Opens the external support tool provided by MADRIX. This requires an internet connection. MADRIX technical support may request that you launch this tool for further assistance.

- **Check For Software Updates...** - Checks online if a software update is available for downloading. This requires an internet connection.

- **MADRIX KEY > Update MADRIX KEY Firmware...** - Allows you to update the firmware of your MADRIX KEY. Learn more »[MADRIX 5 KEY Firmware Updater](#)

- **MADRIX KEY > Activate MADRIX KEY...** - Allows you activate the MADRIX KEY. Learn more »[MADRIX KEY [Activation]](#)

- **MADRIX KEY > Update MADRIX KEY...** - Allows you to update the MADRIX KEY. Learn more »[MADRIX KEY [Activation]](#)

- **About...** - Provides information about the MADRIX Software, the MADRIX KEY you own, and legal information.
3.2 Operating Modes [Programmer / Operator]

This topic includes:
- Introduction
- Programmer
- Operator
- Important Notes

Introduction

MADRIX 5 introduces operating modes. There are two modes available. Each mode represents a different workflow, i.e. programming and creating effects and operating the software live.

You can choose the operating mode on the main user interface [below the crossfader]:

- Programmer
- Operator

Programmer

This operating mode is the main mode to preprogram your show and create your visuals and effects.

- All changes to the MADRIX Setup file will be communicated as a modification. The MADRIX Software will ask if the Setup file should be saved when exiting the software, for example.
- When working with Storage Places, all changes and modifications to your visuals and effects will be applied when switching away from your last used Storage Place. If you call up this Storage Place again, all of your last changes will be there [the last state will be activated again].
All tools and features are available to you.

**Operator**

This operating mode is new to the MADRIX Software. It is the main mode to operate the software live. Due to the nature of this mode, certain features work differently or are not available.

- You may change a number of settings during live operation, but those changes are only temporarily and will not be communicated as changes to the MADRIX Setup file.
- When working with Storage Places, you may change the effect parameters, but these changes will not be applied. If you switch away from your last used Storage Place and call it up again later, the state of the Programmer mode will be there. Any changes in the Operator mode will be discarded.
- You may use live features [such as Submaster, Speed Pitch, Speed Master, FX Filters, etc.], but in general they will also be discarded eventually.
- Many tools and features are not available to you. For example, many of the regular functionality is disabled [such as New, Open, Save, Import, Export, Copy, Cut, Paste, Drag & Drop, Edit, Record].
- You may open a MADRIX Setup file.
- Cue List and Group Control only make playback functionality available, but no edit functionality.
- **Note:** If you create a new visual while having Operator mode enabled, you may change back to Programmer mode in order to save your Setup file including the new effect.

**Important Notes**

- The Operating Mode will be saved in the MADRIX Setup file. You may decide to restore or disregard its state when loading a Setup file.
3.3 Views

This topic includes:
- Introduction
- Layer Control
- Cue List
- Group Control

Introduction

MADRIX 5 offers 3 views of the main user interface.

You can choose the view on the main user interface [below the crossfader]:

- Layer Control
- Cue List
- Group Control

Layer Control

The Layer Control view is the main view to create effects and visuals. Learn more »[Effect Areas [Deck A / Deck B]]
Cue List

The Cue List is an automated playlist and scheduler. It offers the possibility to precisely manage the automatic playback of effects. Learn more »[Cue List]

Group Control

Fixture groups allow you to organize fixtures that are included in your Patch in clusters and then to control them together as a group. Learn more »[Fixture Groups [Group Control]]
3.4 3 Previews

This topic includes:
- Introduction
- 2D Or 3D Mode
- Working With Previews
- More Information
- Options
- Preview Benchmark
- DVI Output And External Previews
- Troubleshooting

Introduction

MADRIX features 3 main Previews.
That means that you can have a look at your effects and visuals before they are displayed on your LED installation. These are live previews and they show everything in real time.

- Preview Deck A
- Preview Deck B
- Preview Output

- Preview Deck A / Preview Deck B - Located to the upper left and to the upper right of the user interface. They represent the two preview windows for the 2 Effect Pipelines.
[Part C] User Interface [GUI]

- **Preview Output** - Is located in the middle. This window is a preview of the actual data output that is sent to your interfaces/LEDs.

- A MADRIX Preview is a technical representation of your installation. You will see the individual pixels/voxels and how the effects will look on your LEDs, but not realistic renderings of your projects you may know from visualizers.

- DVI output is explained at the end of this topic. Learn more [DVI Output And External Previews](#).

---

## 2D Or 3D Mode

As explained earlier, you can use MADRIX to control 2D and/or 3D projects. The 3 Previews support a 2D mode and a 3D mode to adequately represent your LED installation. In this way, they are an important part of your workflow when working with your project.

- Go to the menu *Previews > Preview Deck A/Deck B/Output > 2D Mode* to choose 2D mode for the left/right/middle Preview.

---

- Go to the menu *Previews > Preview Deck A/Deck B/Output > 3D Mode* to choose 3D mode for the left/right/middle Preview.
MADRIX can run a benchmark to test your computer's performance with regards to the recommended maximum 3D voxel resolution. Learn more Preview Benchmark

You can use the Previews in 3D Mode, even if your virtual LED matrix is only 2D. And you can use the Previews in 2D Mode, even if your virtual LED matrix is in 3D.

**Working With Previews**

**Overview**

You have different options of working with each Preview. It depends on 2D mode or 3D mode which options are available to you.

**2D Mode**

**Using The Mouse**

[Stretch Pixels needs to be deactivated.]

- **Left Mouse Click And Hold And Move** - Click with your left mouse button on a Preview, continue to hold, and move your mouse in order to move and relocate the Preview.
- **Middle Mouse Click And Hold And Move** - Click with your middle mouse button on a Preview, continue to hold, and move your mouse in order to move and relocate the Preview.

- **Right Mouse Click And Hold And Move** - Click with your right mouse button on a Preview, continue to hold, and move your mouse in order to zoom in or to zoom out.

- **Left Mouse Double-Click** - Perform a double-click with your left mouse button to reset the Preview to its default view. This removes any changes, such as zoom or relocation.

- **Right Mouse Click** - Calls up the context menu as explained below.

- **Scroll Wheel** - Click on a Preview to focus it. Then, use the scroll wheel of your mouse to zoom in or to zoom out.

**Keyboard Shortcuts**

- **Space Bar** - Use the space bar on your keyboard to reset the Preview to its default view. This removes any changes, such as zoom or relocation.

**Context Menu**

- **3D Mode** - Switches to 3D mode.

- **2D Mode** - Is activated in 2D mode.
- **Patch Mask** - Is only available for Preview Output. Learn more [More Information](#).
- **Use Master** - Applies the Master to the Preview Output. Deactivate it if the middle Preview should not reflect the main brightness and instead is always shown at full intensity.
- **Use Fixture Groups Intensity** - Applies the Fixture Groups to the Preview Output. Deactivate it if the middle Preview should not reflect the group brightness values and instead is always shown at full intensity.
- **Stretch Pixels** - Extends the Preview to the full size. The content [i.e., the effects] will also be stretched.
- **Show Status Information** - Provides further information and displays the name of the Preview, the current size of the virtual LED matrix, the current frames per second of this preview [FPS], and which Storage [e.g., S1] and which Storage Place [e.g., P1] are currently selected.
- **Show Clock** - Will display the system time in the preview.
- **Show Grid** - Activates an optical raster separating the single pixels. If the resolution or the zoom level is too high, the grid will not be visible anymore.
- **Show Background Image...** - You may load *.bmp, *.gif, *.jpg, *.png, *.tif, or *.tiff files as background images for your Previews. They will replace the standard gray background color.

- **Restore Default View** - Resets the Preview to the default size and position. This removes any changes, such as zoom or relocation.
- **Disable** - Deactivates a Preview. This can be helpful to save computer resources and increase performance.

### 3D Mode

**Using The Mouse**

- **Left Mouse Click And Hold And Move** - Click with your left mouse button on a Preview, continue to hold, and move your mouse in order to rotate the 3D Preview. You can also add a spin and let the Preview rotate constantly.
- **Middle Mouse Click And Hold And Move** - Click with your middle mouse button on a Preview, continue to hold, and move your mouse in order to move and relocate the Preview.
- **Right Mouse Click And Hold And Move** - Click with your right mouse button on a Preview, continue to hold, and move your mouse in order to zoom in or to zoom out.
- **Left Mouse Double-Click** - Perform a double-click with your left mouse button to reset the Preview to its default view. This removes any changes, such as zoom or relocation.
- **Right Mouse Click** - Calls up the context menu as explained below.
- **Scroll Wheel** - Click on a Preview to focus it. Then, use the scroll wheel of your mouse to zoom in or to zoom out.

### Keyboard Shortcuts
- **Space Bar** - Use the space bar on your keyboard to reset the Preview to its default view. This removes any changes, such as zoom or relocation.

### Context Menu

- **3D Mode** - Is activated in 3D mode.
- **2D Mode** - Switches to 2D mode.

- **Patch Mask** - Is only available for Preview Output. Learn more [More Information](#).
- **Use Master** - Applies the Master to the Preview Output. Deactivate it if the middle Preview should not reflect the main brightness and instead is always shown at full intensity.
- **Use Fixture Groups Intensity** - Applies the Fixture Groups to the Preview Output. Deactivate it if the middle Preview should not reflect the group brightness values and instead is always shown at full intensity.
• **Show Status Information** - Provides further information and displays the name of the Preview, the current size of the virtual LED matrix, the current frames per second of this preview [FPS], and which Storage [e.g., S1] and which Storage Place [e.g., P1] are currently selected.

• **Show Clock** - Will display the system time in the Preview.

• **Show Pivot Element** - Displays a helpful icon for visual guidance. Three arrows are always shown at position X=0, Y=0, Z=0 [not matter if the Preview is rotated]. The X-axis is red [horizontal; width], the Y-axis is green [vertical; height], and the Z-axis is blue [level; depth].

• **Show Background Image...** - You may load *.bmp, *.gif, *.jpg, *.png, *.tif, or *.tiff files as background images for your Previews. They will replace the standard gray background color.

• **Default View** - Choose your point of view and the default view for this Preview.

• **Restore Default View** - Resets the Preview to its Default View. This removes any changes, such as zoom or relocation.

• **Disable** - Deactivates a Preview. This can be helpful to save computer resources and increase performance. Especially, 3D mode requires a lot of computer performance.

**Messages**

• **Clear Message** - Only the Preview Output offers this option. MADRIX may show information or error messages in the Preview Output.

  - **X** - Discards any messages that MADRIX shows. The messages will not be displayed anymore.

  - Such a message could look like this:

![Message Example](image)

**More Information**
Overview

The Previews mainly show your effects and visuals. Depending on different settings and requirements they convey additional information.

**Note:** The different scenarios explained below can apply at the same time.

Intensity

When controlling LED lighting, the intensity of the light output makes up a large factor of the light design. The Previews will represent your intensity settings.

There are many ways how to control the intensity in MADRIX. The main examples are:

- **Master**, including **Blackout**
  
  Learn more » [Main Output / Master / Audio Levels](#)

- **Storage Place Submaster**
  
  Learn more » [Storages](#)

- **Layer Submaster**
  
  Learn more » [Effect Areas [Deck A / Deck B]](#)

- **Layer Opacity**
  
  Learn more » [Layers](#)

- **Colors**
  
  Learn more » [Using Colors And Intensity](#)
Rendering

One of the main features of MADRIX is that it renders visuals and effects live in real time. Regarding the overall performance, you can define a specific setting in the Options that will also influence the Previews. Depending on your settings, MADRIX will include all voxels in the rendering process or only the ones that are patched. Learn more »Performance

Patch Mask

When letting MADRIX render all voxels, you can further decide how the Previews work. Voxels that are used [a fixture is set up at this position] are displayed brighter than voxels without LED fixtures. Compared to this, MADRIX offers two choices in order to show or hide voxels that are not used. This will influence all 3 Previews. Positions without fixtures will be dark gray or they will not be shown and set to black.

Note: The Patch Mask will only fully apply, when your performance settings include all voxels, as explained above. If your performance options are set to only include patched voxels, the voxels will always be shown opaque. Changing the Patch Mask setting will not influence the Previews anymore.

- Right Mouse Click on the Preview Output > Patch Mask > Transparent/Opaque
- Or go to the menu Previews > Preview Output > Patch Mask > Transparent/Opaque

Patch Mask: Transparent
Patch Mask: Opaque
MADRIX License

The Previews will indicate if you are using a higher output [as set by the virtual LED matrix in the Matrix Generator or Patch Editor] than your MADRIX license version provides. Unlicensed areas will be shown darker.

Select Help > About... to check your MADRIX license version and product serial numbers.

Output Fully Covered By License

Output Not Fully Covered By License

Individual Patch
When setting up an individual Patch in the Patch Editor, there might be areas where no fixtures are located according to your LED installation. These areas without any fixtures will automatically be displayed darker to indicate that this area is not in use.

**Options**

You can change further settings of the Previews.

Learn more »[User Interface](#)

Learn more »[Performance](#)

**Preview Benchmark**

- When running MADRIX for the first time, you will be asked to perform a short benchmark test for the Previews.
- Or go to the menu **Previews > Preview Benchmark**...
- Click **Start**
Since using the Previews in 3D Mode can require a certain computer performance, MADRIX allows you to run the Benchmark to see the recommended maximum 3D voxel resolution for your computer.

It is recommended to run this test once for your computer setup.

Please close other programs, windows, and background tasks during the test since they can negatively affect the performance and outcome.
More Information:
- MADRIX mainly uses the computer’s main processor [CPU] for the effect rendering process.
- MADRIX mainly uses the computer’s graphics card [GPU] to display these effects in the Previews.
- The Benchmark evaluates the performance of the computer system regarding the Previews. This means that it mainly tests the performance of the graphics card.
- The Benchmark result does not necessarily represent the overall computer performance. The CPU might be able to handle a higher resolution than the graphics card can display smoothly in the Previews.
- The Benchmark evaluates the performance of the Previews in 3D Mode. The result of the Benchmark will show the total number of voxels your computer should be able to display with sufficient performance when using one or more Previews in 3D Mode.
- The Benchmark result does not represent the performance for 2D.
- You can save overall computer performance when using a 3D Matrix Size by setting the Previews to 2D Mode.
- The Benchmark result does not refer to each Preview independently, but for all Previews in total. That means by default it is assumed that all three Previews are enabled as well as set to 3D Mode.
- You can save computer performance by only setting one Preview to 3D Mode and setting the other two Previews to 2D Mode or disabling them, for example. [When disabling one or several Previews, a single Preview can sufficiently display a higher resolution.]
- The Benchmark result is an information. It shows what is recommended and not necessarily what is possible.
- When exceeding the recommended 3D voxel resolution, MADRIX will ask you if you are sure to use the Preview in 3D Mode. In this way, poor performance can be avoided:

Examples:

<table>
<thead>
<tr>
<th>Benchmark Result Examples</th>
<th>Assumed Activated Previews</th>
<th>Recommended 3D Preview Resolution Per Preview [X x Y x Z]</th>
<th>Calculation</th>
</tr>
</thead>
<tbody>
<tr>
<td>10,125 Voxels</td>
<td>3</td>
<td>15 x 15 x 15</td>
<td>15 * 15 * 15 * 3 = 10,125</td>
</tr>
<tr>
<td>24,000 Voxels</td>
<td>3</td>
<td>20 x 20 x 20</td>
<td>20 * 20 * 20 * 3 = 24,000</td>
</tr>
</tbody>
</table>
### DVI Output And External Previews

The 3 Preview windows explained above are technical representations of the effects MADRIX creates for you. But they are not pixel-perfect outputs.

DVI is another way to work with LED products which requires such a correctly sized output. To use DVI, MADRIX offers other options.

All MADRIX 5 KEYs support DVI output:

- **MADRIX KEY start**
- **MADRIX KEY entry**
- **MADRIX KEY basic**
- **MADRIX KEY professional**
- **MADRIX KEY ultimate**
- **MADRIX KEY maximum**

DVI output allows you to easily control large LED pixel walls or use screen-capturing, for example.

Learn more »[DVI](#)

---

### Troubleshooting

**Invalid OpenGL Version**
MADRIX might show the following error message:

- **Preview Disabled**
  
  *Invalid OpenGL Version: 1.1*
  
  *Minimum Required Version: 2.1*

If the Previews show this error message, it means that there is a problem with the graphics card of the computer:

- The graphics card might be too old and might not support OpenGL 2.1.
- The driver of the graphics card for the Windows operating system might be outdated.

To solve the issue:

- Check if your computer’s graphics card supports OpenGL 2.1. If it is not supported, your computer/the graphics card does not meet the minimum requirements of MADRIX 3. Please upgrade to a newer graphics card, which supports OpenGL 2.1.
- Download and install the latest driver version for your graphics card in order to update the driver. [You might need to restart the computer afterwards.]
3.5 Crossfader

This topic includes:
- Introduction
- Overview
- Crossfader
- Fade Types

Introduction

The Fade Area, including the important Crossfader, is positioned right in the middle of the MADRIX user interface.

Overview

Crossfader - Determines which Effect Pipeline is send to the output, i.e. visuals from which side. Perform a right mouse click to reset to the default value [50%]. Learn more Crossfader
**Fade To Left** - Triggers an automatic fade to the left and applies the currently set Fade Time and Fade Type.

**Fade To Middle** - Triggers an automatic fade to the middle and applies the currently set Fade Time and Fade Type.

**Fade To Right** - Triggers an automatic fade to the right and applies the currently set Fade Time and Fade Type.

**Skip To Left** - Perform a double-click in order to immediately skip to the left [without applying a Fade Time or Fade Type].

**Skip To Middle** - Perform a double-click in order to immediately skip to the middle [without applying a Fade Time or Fade Type].

**Skip To Right** - Perform a double-click in order to immediately skip to the right [without applying a Fade Time or Fade Type].

Learn more [Crossfader](#)

**Fade Type** - Shows the fade will look like. Perform a right mouse click to reset to the default value [XF]. Learn more [Fade Types](#)

**Automatic Fade** - Is part of the Crossfader. It triggers an automatic fade and applies the currently set the Fade Time and Fade Type from left to right or right to left. Learn more [Crossfader](#)

**Fade Time** - Is part of the Crossfader. It specifies the duration of the fade, when an automatic fade is triggered. [To change the time, select the value via left double-click first. Then, enter a value using the keyboard, use the mouse wheel, or use a left mouse click and hold while dragging the mouse up or down.] Learn more [Crossfader](#)
Overview

The Crossfader specifies which effect [from Deck A or Deck B] is displayed on Preview Output. As such, the Crossfader specifies the source of the final output. The Preview Output will show you the results and the final output towards your LEDs.

- Set the Crossfader to the far left to show only the effect of Deck A [Preview Deck A/Storage Deck A].
- Set the crossfader to the far right to show only the effect of Deck B [Preview Deck B/Storage Deck B]
- Any position in between is also possible to mix both effects.

Automatic Fades

- **FADE** - Starts an automatic fade.
  - The fader will automatically fade to the other side according to the Fade Time and the Fade Type.
  - If the fader is positioned on the right side, it will automatically move to the left side. If the fader starts on the left side, it will move to the right side.
- **Fade Time** - Defines the duration of the automatic fade.
  - Set the time using seconds and tenths of seconds.
  - To change the time, select the value via left click first. Then, enter a value using the keyboard, use the mouse wheel, or use a left mouse click and hold while dragging the mouse up or down.
  - Example: Enter '2.5' for a fade duration of 2.5 seconds.
- **Fade To Left / Fade To Middle / Fade To Right** - Click on the arrow buttons to fade to a specific position: left, middle, right.

Manual Fades

- **Left Mouse Click And Hold And Drag** - Click with your left mouse button on the Crossfader, continue to hold, and move your mouse in order to change its position. You can fade manually in this way.
- **Left Mouse Click** - Click with your left mouse button directly on the Crossfader panel to instantly change the position to the mouse location.
- **Left Mouse Double-Click** - Perform a double-click with your left mouse button directly on the Crossfader panel to reset the Crossfader to 50%, i.e. to the exact middle position between left and right.
- **Right Mouse Click** - Perform a right click with your mouse on the Crossfader to reset the Crossfader to 50%, i.e. to the exact middle position between left and right.

- **Skip To Left / Skip To Middle / Skip To Right** - Perform a double-click on the arrow buttons to instantly skip to a specific position: left, middle, right.

### Examples

**Crossfader To The Left**

**Crossfader To The Right**

![Crossfader To The Left](image1)

![Crossfader To The Right](image2)

### Fade Types

All fades [manual and automatic] are of a certain type. By changing the Fade Type, you can change how a fade will look like. Learn more [Fade Types](#).

### Fade Types

**Introduction**

The Crossfader creates a fade between Deck A and Deck B. You can specifically control the visual result of the fade:

- You can choose from different types of fades using the drop-down list as shown below.
- The fade types will influence how Effect Deck A is mixed with Effect Deck B during the fade or vice versa.
Overview

The following table describes how the different fade types work.

For these examples, let us assume that Effect Deck A is currently playing and that you would want Effect Deck B to be displayed next. So we will fade from Preview Deck A to Preview Deck B.
A cross-fade starts by dimming Effect on Deck A linearly from 100% to 0% during the fade time. But at the same time, Effect on Deck B starts to fade in until it is fully shown at the end of the fade. As a result, an interpolation of the colors of Deck A and Deck B will be used during the fade.

At the beginning of the whole fade procedure, Effect on Deck A stands at 100%, while Effect on Deck B is not displayed [0%]. Halfway through, both effects are dimmed to 50%, as you can see in the picture. Neither Effect on Deck A nor Effect on Deck B are displayed with 100%. That is why the cross-fade appears to be darker. At the end of the fading procedure, Effect on Deck A stands at 0%, while Effect on Deck B is shown with 100%.
A White-fade is the opposite of a black-fade. It starts with Effect on Deck A being shown at 100% for the first half of the fade time. At the same time, Effect on Deck B fades in during the first half until it is also shown with 100%. Afterwards, Effect on Deck B remains at 100% for the rest of the fade procedure, while Effect on Deck A is dimmed from 100% to 0%.

Halfway through, both effects are shown with 100%. Because of that, a white-fade does not necessarily display a white color in middle position. Instead, this fade type uses addition of all color values. For example, if your are using a SCE Color in pure red on Effect on Deck A [255, 0, 0] and SCE Color in turquoise/cyan on Effect on Deck B [0, 255, 255], the result will indeed be a pure white halfway trough as it adds up to 255, 255, 255. But using a SCE Color in pure red on Effect on Deck A [255, 0, 0] and SCE Color in pure green on Deck B [0, 255, 0], this results in pure yellow in the middle of the fade procedure [255, 255, 0], for example.

A Black-fade starts with dimming Effect on Deck A from 100% to 0% for the first half of the fade time. Effect on Deck B remains at 0% during this time. Then, halfway through the fade procedure, Effect on Deck B starts to increase until 100% shown. Effect on Deck A was already at 0% and remains at this level for the rest of the fade.

Since both effects are shown with 0% in the middle of the fade, this always results in a black output, and therefore the name.
Horizontal Wipe

Wipes one side over another horizontally [from the right or left side]. The currently active effect stays and will be shown in the background until the new effect fully covers the output.

Vertical Wipe

Wipes one side over another vertically [from above or below]. The currently active effect stays and will be shown in the background until the new effect fully covers the output.

Depth Wipe

Wipes one side over another vertically [from back or front]. The currently active effect stays and will be shown in the background until the new effect fully covers the output.

Horizontal Cross Wipe

Wipes one side over another horizontally [from the right and the left side] and splits the new effect at the same time during the fade. The currently active effect will be shown in the background until the new effect fully covers the output.

Vertical Cross Wipe

Wipes one side over another vertically [from the top and the bottom side] and splits the new effect at the same time during the fade. The currently active effect will be shown in the background until the new effect fully covers the output.

Depth Cross Wipe

Wipes one side over another vertically [from the back and the front] and splits the new effect at the same time during the fade. The currently active effect will be shown in the background until the new effect fully covers the output.
**Slide X**

*Horizontal Slide*

Pushes the old effect out of the frame horizontally [from the left to the right and vice versa]. The currently running effect will move accordingly to the side until it vanishes.

---

**Slide Y**

*Horizontal Slide*

Pushes the old effect out of the frame vertically [from the top to the bottom and vice versa]. The currently running effect will move accordingly to the top or bottom until it vanishes.

---

**Slide Z**

*Depth Slide*

Pushes the old effect out of the frame vertically [from the back to the front and vice versa]. The currently running effect will move accordingly to the top or bottom until it vanishes.

---

**Slide XC**

*Horizontal Cross Slide*

Pushes the old effect out of the frame horizontally [from the left to the right and vice versa] and splits both effects at the same time during the fade. The currently running effect will move accordingly until it vanishes.

---

**Slide YC**

*Vertical Cross Slide*

Pushes the old effect out of the frame vertically [from the top to the bottom and vice versa] and splits both effects at the same time during the fade. The currently running effect will move accordingly until it vanishes.

---

**Slide ZC**

*Depth Cross Slide*

Pushes the old effect out of the frame vertically [from the back to the front and vice versa] and splits both effects at the same time during the fade. The currently running effect will move accordingly until it vanishes.
3.6 Main Output / Master / Audio Levels

This topic includes:
- Introduction
- Main Output Controls
- Master
- Audio Output Level
- Audio Input Level

Introduction

The Main Output and accompanying Master, Audio Output Level, and Audio Input Level are central controls of the MADRIX user interface.

- Several controls are available for the Main Output [including Color Filter, FX Filter, and Strobe].
- The Master controls the overall brightness of the Main Output [i.e. of the LED fixtures].
- The Audio Output Level controls the maximum sound level that is sent.
- The Audio Input Level controls the maximum sound level that is received and used for the real-time audio analysis.
Main Output Controls

Main Output Color Filter

Color Filter - Filters the colors of the Main Output.
- **Left Mouse Click And Hold** - Select the color using the Color Picker to activate the Color Filter.

- **Right Mouse Click** - Calls up the context menu.

  ![Context Menu]

- **Edit...** - Calls up the Color Fader Box.

- Choose from 3 modes:
  - **Allow Through** - Lets only the color that is chosen through and filters every other color out.
  - **Filter Out** - Removes the color that is chosen and lets all other colors through.
  - **Colorize** - Applies the chosen color as tint color.

- **Defaults** - Restores the default color. The default value is White, which means that no filter is active.

### Main Output FX Filter

![FX]

**Filter** - Applies special filters to quickly change your visuals. Learn more »[Filters [FX]]

### Main Output Strobe

![Strobe]

**Strobe** - This strobe applies directly to the Main Output.
**Left Mouse Click and Hold** - Activates the strobe. Continue to hold as long as the strobe should be active [Flash button].
- Simply release the mouse button to deactivate the strobe again.

**Strobe Frequency** - Sets the speed of the strobe.
- **Left Mouse Click and Hold** - Allows you to choose the frequency.
- **Right Mouse Click** - Restores the default value. The default value is 6.3 Hz.

**Strobe Color** - Allows you to choose the color of the strobe.
- Simply hover over the new color with your mouse and release the mouse button to select the color.

- **Right Mouse Click** - Calls up the context menu.
Edit... - Calls up the Color Fader Box.

Defaults - Restores the default color. The default value is White.

Strobe Mode - Defines how the main output strobe works.

- Right Mouse Click - Calls up the context menu. You can choose from 3 different modes:
  [Depending on the visual result you want to achieve, one mode might be more favorable than the others.]
  
  **Output And Strobe Color** - Strobes between the regular output and the strobe color you have chosen. As such, it will affect the effects that are put out. But if for the most part the output has the same color as the strobe, the actual strobe effect might be difficult to see.

  **Output And Black** - Strobes between the regular output and the color black. The strobe color you have chosen will be ignored. Choose this mode if you want to make sure that the output itself is strobed.

  **Black And Strobe Color** - Strobes only between the color black and the strobe color you have chosen. The output will be ignored. Chose this mode if you want to achieve a pure strobe that is independent of the output and will always be clearly visible.

Defaults - Restores the default value. The default value is Output And Strobe Color.

Main Output Macro

Main Output Macro

The Main Output Macro is 1 of 4 locations to apply a Macro.

A Macro is a Script written to further influence the functionality of the effect or output. A Macro is not necessary, but can add further functionality to your project. The Main Output Macro is a Macro that affects the entire main output.
Learn more » [Macros And Scripts]

**Master**

**Overview**

**Freeze** - Puts the output on hold [pauses it]. Click and hold the mouse button to freeze temporarily. Double-click it to freeze it permanently; click again to deactivate.

**Fader** - Use the fader to directly control the intensity.

By default the Fader is set to 255, the maximum value.

**Input Field** - Directly enter a value ranging from 0 to 255.

The Input Field will also display the currently set up value.

**Blackout** - Forces an immediate blackout on the output. Click it once to render the output completely black. When activated, the button will pulsate in red. Click again to deactivate the function. Blackout does not affect the value of the master fader.

**Options**

- Go to **Preferences > Options... > Previews > General**
  [Keyboard shortcut: **Ctrl+Alt+O > Previews**]

- **Use Master** - Applies the Master to the Preview Output. Deactivate it if the middle Preview should not reflect the main brightness and instead is always shown at full intensity.

Learn more » [Previews]
Audio Output Level

Overview

**Fader** - Use the fader to directly control the audio output level. The Fader will limit the sent level.
- By default the Fader is set to 100, the maximum value.
- The audio output level is only available when Audio Output is enabled in the Device Manager.

**Input Field** - Directly enter a value ranging from 0 to 100 [in %].
The Input Field below will display the currently set fader value.

**Mute Audio Output** - Disables the audio output. When activated, the button will pulsate in red.
Click again to deactivate. Mute does not affect the value of the audio output fader.

More Information

Learn more »[Audio And Sound](#)

Audio Input Level

Overview
**AGC** - Activates Automatic Gain Control. When activated, the button will glow green and MADRIX will automatically and constantly increase or decrease the input level to receive the optimal sound level.
- Automatic Gain Control will be interrupted as long as you are manually controlling the Fader with the help of the mouse.

**Fader** - Use the fader to directly control the input level. The Fader will limit the incoming level.
- By default the Fader is set to 100, the maximum value.
- The audio input level is only available when Audio Output is enabled in the Device Manager.

**Input Field** - Directly enter a value ranging from 0 to 100 [in %].
The Input Field below will display the currently set fader value.

**Mute Audio Input** - Disables the audio input. When activated, the button will pulsate in red. Click again to deactivate. Mute does not affect the value of the audio output fader.

### Optimal Input Level
To get optimal results from the audio analysis, it is recommended to set up the audio input level correctly.

- Adjust the audio signal in order to avoid an input signal that is too low.
- Levels that are too low will negatively affect the quality of the audio analysis.
- Red lights indicate that levels are too high.

- Use the **AGC** [Automatic Gain Control] for automatic control.
More Information

Learn more » Audio And Sound
3.7 Controls [Deck A / Deck B]

Topics of this chapter:
- Overview
- Submaster Deck A/Deck B
- Color Filter Deck A/Deck B
- Filter [FX] Deck A/Deck B
- Speed Master Deck A/Deck B

Overview

Next to Preview Deck A and next to Preview Deck B you will find different controls that affect the outcome of the entire Deck A or Deck B. They are available to you per side, as explained below.

Submaster Deck A/Deck B

- **Submaster** - Controls the intensity of the entire Deck A or Deck B.
• It will affect the visual outcome on the left or right side, independently of which Storage, Storage Place, or Layer is selected.

• **Left Mouse Click And Hold** - Select the required value by moving the fader with the help of your mouse. Release the mouse button to set up the specific value [The fader will disappear automatically].

• A value of 255 means full intensity.

• A value of 0 means no intensity and will render the effect completely black.

• The tooltip shows the currently set value.

---

**Color Filter Deck A/Deck B**

• **Color Filter** - Filters the colors of the entire Deck A or Deck B.

• **Left Mouse Click And Hold** - Select the color using the Color Picker to activate the Color Filter.

• **Right Mouse Click** - Calls up the context menu.

• **Edit...** - Calls up the Color Fader Box.

• Choose from 3 modes:
  - **Allow Through** - Lets only the color that is chosen through and filters every other color out.
  - **Filter Out** - Removes the color that is chosen and lets all other colors through.
  - **Colorize** - Applies the chosen color as tint color.

• **Defaults** - Restores the default color. The default value is White, which means that no filter is active.
Filter [FX] Deck A/Deck B

- **Filters FX** - Special filters can be applied to an entire Effect Pipeline Deck A or Deck B to quickly change your visuals.
- Learn more »[Filters [FX]]

Speed Master Deck A/Deck B

Overview

- **Speed Master Deck A/Deck B** - Allows you to speed up or slow down effects.
- Each Speed Master influences the speed of the entire Deck A or Deck B.
- The Speed Masters work as a multiplier of the current speed of an effect [that includes the BPM of a Layer, the Pitch of a Layer, and the Pitch of a Storage Place.]
- Example: A Speed Master of 2.0 will double the current speed.

How To Use
• Move the fader upwards to increase the speed.
• Move the fader downwards to decrease the speed.
• The default value is 1.0 [which is normal speed].
• A value of 0.0 will stop the effects.
• The highest value is +10.
• The lowest value is -10.
• Negative values will reverse the direction of effects [if possible].
• Double-click or right-click on the Speed Master button to reset to the value of 1.0

Pause

- **Pause** - Will halt the effect.
- **Left Mouse Click And Hold** - Pauses the effect as long as you hold the mouse button [temporarily].
- **Left Mouse Double-Click** - Pauses the effects permanently. A single click deactivates the permanent stop again.
3.8 Storages

This topic includes:
- Introduction
- Overview
- Selecting A Storage
- Submaster
- Storage Options

Introduction

MADRIX features 2 separate Storage Areas [on Deck A and Deck B]. They are positioned directly below Preview Deck A and Preview Deck B.

As will be explained in the next chapter, you can use so-called Storage Places to organize your lighting effects. In addition, all Storage Places and further options are managed with the help of Storages.

- MADRIX features a total of 256 Storages.
- 1 Storage includes 256 Storage Places.

Overview
**Storage Selection** - Select which Storage you would like to use via Left Mouse Click. Learn more [Selecting A Storage](#).

**Storage Options** - Calls up various options for Storages via Right Mouse Click. Learn more [Storage Options](#).

**Home** - Instantly jumps back to your currently selected Storage Place and brings it into focus [Keyboard shortcut: Ctrl+F].

**Description** - Includes a description for each individual Storage Place. You can change this label as you wish. The label will also be used for other MADRIX features, such as the Touch Screen or Cue List.

**Cue** - Automatically adds the currently selected Storage Place to the Cue List. The newly created Cue List entry will include all applied parameters, like the description or the fade duration and fade type of the crossfader. Learn more »[Cue List](#).

**Submaster** - Calls up the Submaster of the Storage Place to adjust the intensity of the complete effect including all of its Layers. It applies only to the currently selected Storage Place and can be set up for every Storage Place individually. Learn more »[Submaster](#).

**Speed Pitch** - Calls up the Pitch slider of the Storage Place to adjust the speed of the complete effect including all of its Layers. It applies only to the currently selected Storage Place and can be set up for every Storage Place individually. The tooltip shows the currently set value.

**Filters/Effects FX** - Special filters can be applied to a Storage Place including all of its Layers in order to quickly change your visuals. Learn more »[Filters [FX]](#).

**Storage Place Parameter Chaser** - Controls the Storage Place Parameter Chaser for advanced customization of effects. It applies only to the currently selected Storage Place and can be set up for every Storage Place individually. Learn more »[Chaser](#).

**Storage Place Macro Editor** - Controls the Storage Place Macro Editor to add macros to the effect. It applies only to the currently selected Storage Place and can be set up for every Storage Place individually. Learn more »[Macros And Scripts](#).
**Selecting A Storage**

- You can freely choose which Storage to use on the left side or the right side of MADRIX.
- Click on the Storage Selection Button and a submenu will open. Simply select which Storage you would like to use [Numbers 1 to 256].
- The currently selected Storage is shown in green.
- Occupied Storages [which include customized Storage Places] are shown in blue.
- **When switching to another Storage, MADRIX will not automatically select a specific Storage Place for you. The currently selected Storage Place remains selected until you selected the next one.**
- **Submaster** - intensity of a selected Storage Place including all of its Layers. It only works for the Storage Place you have currently selected.

- **Left Mouse Click And Hold** - Select the required value by moving the fader with the help of your mouse. Release the mouse button to set up the specific value [The fader will disappear automatically].

- A value of 255 means full intensity.

- A value of 0 means no intensity and will render the effect completely black.

- The tooltip shows the currently set value.

[The Storage Submaster does not control the main output brightness. If you want to adjust the overall intensity, you need to use the »**Submaster Deck A/Deck B** or the »**Master**]

### Storage Options

#### Overview

- **Right Mouse Click** - Opens the context menu.
- **Open**... - Loads a complete MADRIX Storage from a previously saved, external file [of the file type *.mstz or *.mstx]. A new window opens for you to select the file on your harddisk.

- **Save**... - Saves the current Storage including all of its Storage Places in an external file [of the file type *.mstz or *.mstx]. Simply enter a *File name* when the new window opens, choose a location, and click **Save**

- **Copy** - Copies the current Storage into the clipboard as a duplicate.

- **Cut** - Copies the current Storage into the clipboard and applies a **Clear**.

- **Paste** - Inserts a copy of a Storage from the clipboard into the currently selected Storage.

- **1x1** - Selects a different view with very large Storage Place buttons. Please see below.

- **2x2** - Selects a different view with large Storage Place buttons. Please see below.

- **4x4** - Selects a different view with normal-sized Storage Place buttons. This is the default view. Please see below.

- **8x8** - Selects a different view with small Storage Place buttons. Please see below.

- **Clear** - Removes the current Storage including all of its Storage Places and restores the default, blank Storage.

**Views**

The Storage Options allow you to select one of 4 different views.

1x1

![1x1 View](image)

2x2

![2x2 View](image)
3.9 **Storage Places [256 x 256]**

This topic includes:

- Introduction
- Overview
- Workflow
- Controls
- Working With Storage Places
- Context Menu
- Thumbnails
- Export / Import
- Important Information

**Introduction**

MADRIX uses so-called Storage Places [storage bins] to store and organize your lighting visuals.

- Storage Places are part of a Storage.
  
  [Because of this, a Storage offers options that affect a single Storage Place or all of its included Storage Places.]

- The screenshot below shows the complete Storage Deck A including the numbered Storage Places [Storage Place 1 to 62 can be seen by default]. Learn more ➔ Storage

![Storage Places Screenshot](image)

**Overview**
- A single Storage contains 256 Storage Places. And MADRIX offers up to 256 Storages.
- In total, you have therefore access to 256 x 256 Storage Places.

**Workflow**
- Storage Places allow you to access, manage, and organize your different lighting visuals.
- In order to use MADRIX Effects and light effects, you need to set them up first.
  Learn more »[Effect Areas [Deck A / Deck B]]

**Controls**
- Shows an empty Storage Place with its default configuration.
  [The default MADRIX Effect is: SCE Color with the color Black.]
- Shows a preselected Storage Place, which is not active yet.
- Shows the currently selected Storage Place. This Storage Place is active on the selected Storage.
- Shows that this Storage Place contains visuals configured by you. The Storage Place is occupied and not empty.
- Shows a Storage Place that is currently selected on the other side. You can only select a Storage Place once on either side. This Storage Place is shown already on the left or the right side and cannot be accessed.
- You can increase the size of a Storage Place as shown on the user interface [Learn more »[Storages]]. When the size is large enough, MADRIX will include a small Thumbnail preview of the MADRIX Effect that is stored in the Storage Place. Learn more below.
You can decrease the size of a Storage Place as shown on the user interface [Learn more » Storages]. When the size is too small, MADRIX will only show small icons.

Shows a Thumbnail. Hover with your mouse over a single Storage Place in order to see a small preview of the MADRIX Effect that is stored in the Storage Place. The Thumbnail can be generated automatically or manually. Learn more below.

The scroll bar at the bottom is used for scrolling through the panel.

Is part of the scroll bar and shows the location of occupied Storage Places.

Is part of the scroll bar and shows the location of the currently selected Storage Place.

## Working With Storage Places

### Using The Mouse

- **Left Mouse Click** - Click with your left mouse button directly on a single Storage Place to select and activate it. MADRIX will automatically fade to the new Storage Place according to the Fade Time and Fade Type of the crossfader.

- **Left Mouse Double-Click** - Perform a double-click with your left mouse button directly on a single Storage Place to select and activate it immediately without using the Fade Time and Fade Type of the crossfader.

- **Right Mouse Click** - Calls up the context menu as explained below.

- **Left Mouse Click And Hold And Swipe/Drag** - Click with your left mouse button in the general direction of the Storage Place panel, continue to hold, and move your mouse in order to swipe and drag the entire panel. This allows you to navigate through the Storage Place panel. [You can also use the scroll bar at the bottom.]

- **Scroll Wheel** - Click in the general direction of the Storage Place panel to focus it. Then, use the scroll wheel of your mouse to scroll through the panel.

- Click with your left mouse on this scroll bar to scroll through the Storage Place panel.

### Automatic Fade
- MADRIX automatically applies an automatic fade according to the Fade Time and Fade Type of the Crossfader when you are switching from one Storage Place to another Storage Place within one, single Storage.

- Example: S1 P34 is currently selected. Now, select S1 P22 and MADRIX will automatically do a crossfade for you [incl. Fade Time and Fade Type].

- [Perform a Left Mouse Double-Click to not use the automatic fade. This will activate the next Storage Place without a crossfade.]

**Drag And Drop [Copy/Cut/Paste]**

**Copy And Paste**

- **Left Mouse Click and 2 Sec. Hold** - You can perform a Copy and Paste with the mouse.
  
  Use a left mouse click on a Storage Place and continue to hold for 2 seconds. A small + appears. Continue to hold and move your mouse to another Storage Place. Release the mouse button to paste a copy onto the new Storage Place.

**Cut And Paste**

- **Left Mouse Click and 2 Sec. Hold + Shift** - You can perform a Cut and Paste with the mouse.
  
  Use a left mouse click on a Storage Place and continue to hold for 2 seconds. Press Shift in addition. A small rectangle appears. Continue to hold the buttons and keys and move your mouse to another Storage Place. Release the mouse button to move the previously selected Storage Place to the new position.

**Drag And Drop**

- **File Drag And Drop** - You can select a MADRIX Storage Place file [of the file type *.mspz or *.mspx] in Windows and drag it to a Storage Place of your choice in MADRIX in order to load it in MADRIX.

**Keyboard Shortcuts**

- **Arrow Keys** - Use the 4 arrow keys on your computer keyboard to navigate and in order to preselect a specific Storage Place.

- **Spacebar/Enter** - Press the Spacebar or Enter key on your keyboard to actively select a preselected Storage Place.
- **Page Up/Page Down** - Press the Page Up and Page Down keys to scroll through the Storage Place panel back and forth.

- **Home/End** - Press the Home key to instantly display the first Storage Place [P1]. Press the End key to instantly display the last Storage Place [P256].

- **Ctrl+F** - Press F to instantly jump back to your currently selected Storage Place and to bring it into focus.

---

**Context Menu**

There are several options available for each Storage Place via a context menu.

- **Right Mouse Click** on a Storage Place to call up the context menu.
  
  A small window will be shown.

You can use the following options:

- **Cue** - Adds the currently selected Storage Place to the Cue List.

- **Open...** - Loads a previously saved MADRIX Storage Place file [of the file type *.mspz or *.mspx]. A new window opens for you to select the file on your harddisk.

- **Save...** - Saves the current Storage Place configuration to an external file [of the file type *.mspz or *.mspx]. A new window opens for you to select a location on your harddisk. Simply enter a name and click **Save**

- **Copy** - Copies the current Storage Place configuration into the clipboard as a duplicate.
- **Cut** - Copies the current Storage Place configuration into the clipboard and applies a **Clear**

- **Paste** - Inserts a copy of a Storage Place from the clipboard into the currently focused Storage Place.

- **Thumbnail** - Defines how MADRIX manages the Thumbnail of the currently selected Storage Place. Learn more below.

- **Clear** - Removes the current Storage Place configuration and restores the default, blank Storage Place.

### Thumbnails

Hover with your mouse over a single Storage Place in order to see a small preview of the MADRIX Effect that is stored in the Storage Place.

When using the context menu of a Storage Place, you can set up how MADRIX manages the Thumbnail of each individual Storage Place. First, make sure that the currently selected Storage Place is also the active Storage Place of this Storage.

- **Right Mouse Click** on a Storage Place to call up the context menu.

- A small window will be shown.

- Navigate to **Thumbnail**
- **Automatic** - Is activated by default. MADRIX will automatically generate a new Thumbnail each time you leave this Storage Place and switch to another Storage Place. That means the Thumbnail preview will always be up to date and show the last visual status.

- **Generate** - Allows you to manually generate a new Thumbnail at this moment. Automatic will then be deactivated as a result. Once a manual Thumbnail has been generated, MADRIX will use this Thumbnail until you manually generate a new Thumbnail or activate Automatic again.

### Export / Import

#### Import

Learn more » [File Types](#)

**File Menu**

- Go to the menu *File > Import > Storage Place > Storage Place Deck A / Deck B...*

- You can import previously saved MADRIX Storage Place file [of the file type *.mspz or *.mspx] onto the currently selected Storage Place on the left or on the right side. A new window opens for you to select the file on your harddisk. [This is the same functionality as Open... from the context menu.]

#### Drag And Drop

- **File Drag And Drop** - You can select a MADRIX Storage Place file [of the file type *.mspz or *.mspx] in Windows and drag it to a Storage Place of your choice in MADRIX in order to load it in MADRIX.

### Export

**File Menu**
• Go to the menu **File > Export > Storage Place > Storage Place Deck A / Deck B...**
  You can export the currently selected Storage Place to an external file [of the file type *.mspz or *.mspx]. A new window opens for you to select a location on your harddisk. Simply enter a name. [This is the same functionality as Save... from the context menu.]

• Go to the menu **File > Export > Storage Place > All...**
  You can export all currently occupied Storage Place to individual, external files [of the file type *.mspz or *.mspx]. A new window opens for you to select a location on your harddisk. Simply enter one name and MADRIX will automatically add the Storage Place number to the file as well.

**Important Information**

• Make sure to save your MADRIX Setup file after configuring your MADRIX Effects [and working with Storage Places].

• When switching to a different Storage, MADRIX will not automatically select a new Storage Place for you. When switching to another Storage, you need to actively select a different Storage Place if that is what you want.
3.10 Effect Areas [Deck A / Deck B]

This topic includes:
- Overview
- Programmer View
- Effect Selection
- Individual Controls [Effect Settings]
- Universal Controls [Layer Settings]

Overview

The MADRIX Effects are one of the most important parts of the software. The user interface offers dedicated work areas for you to work with visuals [Effect Area Deck A and Effect Area Deck B].

When you select an empty Storage Place, the corresponding Effect Area will look like this by default:

![Effect Area Preview](image)

Programmer View

- In order to have access to the Effect Areas, make sure to select the Programmer and Layer Control view first!
Effect Selection

- Effect Selection
  - Left Mouse Click - Allows you to select a specific MADRIX Effect from the library of stock effects.

- SCE Color is the default setting.

- Learn more »Effects [Visuals]
- Learn more »MADRIX Effects

Individual Controls [Effect Settings]
Each MADRIX Effect has its own buttons and controls. In this way you can customize your visuals as you wish.

Have a look at the 3 examples below and you will see that the standard controls [see below] are always there, while the rest of them changes with every effect.
Universal Controls [Layer Settings]

At the same time, a standard set of controls is available for each MADRIX Effect [i.e. each Layer] for additional customization. Learn more » Layers
3.11 **Cue List Section**

This topic includes:
- Overview
- Controls
- More Information

**Overview**

The MADRIX 5 main user interface offers 3 quick access buttons to control the Cue List.

**Controls**

- **Next** - Skips to the next Cue List entry.
- **Previous** - Goes back to the previous Cue List entry.
- **Play/Pause** - Starts or stops the Cue List.
- **Progress** - Shows the progression of the current Cue regarding its Duration with the help of a progress bar.
- **Cue List** - Changes the view and opens the Cue List. More options will be available to you then.
More Information

You need to configure a Cue List in order to use the Cue List features.

Learn more » Cue List
3.12 Full-Screen Mode

This topic includes:
- Overview
- Options

Overview

- Go to the menu View > Full Screen
  [Keyboard shortcut: F11]
- Press F11 again to deactivate the full-screen mode.

The graphical user interface (GUI) can be extended to fill the entire size of your monitor. This mode is called Full Screen. There is a difference between maximizing the user interface window or enabling the full-screen mode:

- The title bar will not be visible anymore in the full-screen mode, which saves space for the user interface.
- In addition, you can choose to show the menu bar or to hide the menu bar to save further space. Change the setting as described below. By default, the menu bar is shown.

MADRIX will also automatically hide the Windows taskbar in the full-screen mode.
[Use the Windows key on your keyboard to temporarily access the taskbar again.]
Options

- Go to the menu Preferences > Options... > User Interface
- **General > Show Menu In Full Screen Mode** - Shows the menu bar also in Full Screen mode. Deactivate this option to hide the menu in Full Screen mode. [By default, the menu is shown in Full Screen mode.]
3.13 Touch Screen

Topics of this chapter:

- Overview
- Important Notes
- Options
- Moving The Touch Screen To A Different Monitor

Overview

- Go to the menu View > Touch...
  [Keyboard shortcut: F8]
- Or when enabled in the settings, you can open/close the touch screen window by clicking on the MADRIX Logo.

The touch screen interface was especially designed to provide you with an intuitive and easy to use interface. It was designed for touch screen panels, but can also be used with the help of the mouse.
**Submaster Deck A / Deck B** - Regulates the overall intensity of an entire Storage. Learn more » [Controls [Deck A / Deck B]]

**Color Filter Deck A / Deck B** - Applies a color filter to the entire Storage. Learn more » [Controls [Deck A / Deck B]]

**Filter [FX] Deck A / Deck B** - Applies a special filter to the entire Storage. Learn more » [Controls [Deck A / Deck B]]

**Close/Open Preview** - Opens or closes Preview Deck A or Preview Deck B.

**Storage Place Scroll** - Scrolls through the 256 Storage Places of a single Storage.

**Storage Selection** - Allows you to select the Storage.

---

**Important Notes**
- All 3 Previews of the main MADRIX user interface will be disabled, when the Touch Screen is activated and has the focus. This ensures high performance. However, they will be activated again when the user interface has the focus again [click on the user interface to get the focus].
- The Cue List is not available, when using the Touch Screen. / The Touch Screen is not available when the Cue List is running.

**Options**

- Go to the menu *Preferences > Options... > User Interface*

![Options](image)

- **Touch:**
- **Open And Close Also Via MADRIX Logo** - Allows you to open or close the Touch Screen Interface by clicking on the MADRIX logo.
- **Fade Automatically When Switching Storage Places** - Activate this option if the Crossfader should make an automatic crossfade when you select a new Storage Place on the opposite Storage [e.g., from S1 P1 to S2 P1].

- **Maximum Fade Time (s)** - Defines the maximum Fade Time in seconds you can set up in the Touch Screen for the automatic fade of the Crossfader.
  - **D** - Restores the default value. The default value is 10 s.

- **Show Description As Button Label** - Will show the individual Description of a Storage Places on the Touch Screen interface instead of the standard numbering [1, 2, 3, etc]. If the Storage Place has the standard Description **Color**, the standard numbering will be shown.

- **Storage Place Button Size** - Choose from three different size of how small or large Storage Places are shown on the Touch Screen Interface.
  - Chose from **Small, Medium, Large**.
  - **D** - Restores the default value. The default value is Medium.

- **Storage Place Button Count** - Choose how many Storage Places are shown on the touch interface.
  - Enter a value from 1 to 256.
  - **D** - Restores the default value. The default value is 256.

---

![Button Size Selection](image)

- **Moving The Touch Screen To A Different Monitor**

  - Go to the menu **View > Move Touch To Next Screen**
- **Tab** - Or use the Tabulator key on your keyboard [repeatedly] to move the Touch Screen interface to your first, second, third, etc. computer monitor or display. [This only works when the Touch Screen Window has the focus.]
PART D

Using The Software
4 Using The Software

This topic includes:
- Introduction
- Topics Of This Chapter

Introduction

MADRIX already is an easy-to-use, user-friendly, and reliable Windows software. You can use it to create complex lighting scenes and entire shows from a normal computer or laptop. You can learn how to use MADRIX in this chapter.

Topics Of This Chapter

- »MADRIX Setup [New / Open]
- »Matrix Generator
- »Patch Editor
- »DVI Patch
- »CSV Fixture List Import
- »Merging Patches
- »Background Image
- »Fixture Groups [Group Control]
- »Effects [Visuals]
- »Filters [FX]
- »Layers
- »Mapping / Tiling / Rotation
- »Chasers
- »Tools
- »Backup System
- »File Types
- »Recording
4.1 MADRIX Setup [New / Open]

This topic includes:
- Introduction
- New Setup
- Open Setup
- Setup Options

Introduction

The MADRIX Setup file is the most important file type you are working with when using the MADRIX Software. The Setup file includes your configuration and visuals.

Note: The MADRIX Setup file does not include videos or images. These are both only referenced from your harddisk. [When moved or deleted, MADRIX cannot access them anymore.]

New Setup

- Go to the menu File > New Setup
  [Keyboard shortcut: Ctrl+N]
When creating a new MADRIX Setup, you can choose which components to disregard and reset to their default values and empty states.

- All items that are selected will be cleared and made new.
- Learn more below.

**Open Setup**

- Go to the menu *File > Open Setup...*
  [Keyboard shortcut: *Ctrl+O]*

- Choose a Setup file from your harddisk.
- Select which parts to load from the Setup file.
- All items that are selected will loaded from the Setup file.
- Any settings that are deselected will remain as they currently are and not be loaded from the Setup file.
- Learn more below.
## Setup Options

The following items can be selected/deselected when creating a new Setup file or when loading an existing Setup file.

<table>
<thead>
<tr>
<th>Setup Options</th>
<th>Includes</th>
<th>Learn More</th>
</tr>
</thead>
</table>
| **Global**    | ● **Operating Mode** - Includes if Programmer mode or Operator mode are selected.  
                ● **Macro** - Includes the Main Output Macro. | ● Learn more  
               » [Operating Modes](#)  
               » [Programmer / Operator](#)  
               ● Learn more  
               » [Macros And Scripts](#) |
### Output & Decks
- **Deck A Settings** - Includes the settings of the left deck, including Submaster, Color Filter, Filter FX, and Speed Master.
- **Deck B Settings** - Includes the settings of the right deck, including Submaster, Color Filter, Filter FX, and Speed Master.
- **Output Settings** - Includes the settings of the main output, including Color Filter, Filter FX, Strobe, Master, Freeze, Blackout, as well as Audio Output Level, and Audio Input Level.

### Content
- **Storage Places** - Includes all Storage Places, which include all effects, visuals, and Layers, and accompanying settings, such as Storage Place Description, Storage Place Submaster, Storage Place Speed Pitch, Storage Place Filter FX, Storage Place Parameter Chaser, and Storage Place Macro.
- **Cue List** - Includes the Cue List including all of its settings and cues.

### Patch & Fixture Groups
- **Patch** - Includes the Patch including Fixture Groups.
- **Group Control** - Includes all group control presets and settings.

### Devices
- **DMX Device Settings** - Includes all settings for DMX-based devices that are configured in the Device Manager.
- **DVI Device Settings** - Includes all settings for DVI-based devices that are configured in the Device Manager.
- **Audio Settings** - Includes all main audio settings, including Audio Performance, Audio Input, and Audio Output.

---

Learn more

» **Controls [Deck A / Deck B]**

» **Main Output / Master / Audio Levels**

» **Storage Places [256 x 256]**

» **Cue List**

» **Patching**

» **Fixture Groups [Group Control]**

» **OUTPUT Settings**

» **Audio And Sound**
4.2 Patching

This topic includes:
- Introduction
- Topics Of This Chapter

Introduction

Patching fixtures and thereby telling the software which fixtures to control, where they are placed, and how they are addressed is a very important step of the overall first configuration of a project. The MADRIX Software offers different tools and features to achieve this.

Topics Of This Chapter

Patching include the following topics:

- >Matrix Generator
- >Patch Editor
- >DVI Patch
- >CSV Fixture List Import
- >Merging Patches
- >Background Image


4.2.1 Matrix Generator

This topic includes:
- Introduction
- When To Use The Matrix Generator
- Overview
- Step-By-Step Configuration
- Settings
- Examples For Start Corner, Main Orientation, and Snake Mode
- 2D DMX Configuration
- 2D DVI Configuration
- 3D DMX Configuration
- 3D DVI Configuration
- Important Notes
- Further Configuration
- Further Tips

Introduction

You need to tell the MADRIX Software

1] which LED fixtures you are going to use.
2] how many LED fixtures you are going to use.
3] how they are placed.

This configuration of the virtual LED matrix is stored in a so-called Patch file.

Setting up the virtual LED matrix/the Patch file is a requirement! It is necessary for the initial configuration of MADRIX.

MADRIX offers 2 tools for this task:

- Matrix Generator
- **Patch Editor**

---

**When To Use The Matrix Generator**

The Matrix Generator helps you to generate a virtual LED matrix automatically according to your settings. This automatic process can be very helpful, when your LED installation is set up in a very simple, logical, or linear way and only uses 1 fixture type. The Patch file will be automatically generated by MADRIX for you.

The Patch Editor is a graphical editor to directly create the Patch file. The Patch Editor offers the same functions as the Matrix Generator and many more options. It allows you to configure your virtual matrix in great detail. You can place LED fixtures freely and individually. If you have more than 1 kind of fixture, use the Patch Editor.

This topic explains the Matrix Generator.

---

**Overview**

- Go to Preferences > Matrix Generator...
  
  [Keyboard shortcut: F2]

- A new window will open.
Now, configure your virtual LED matrix according to the following settings.

**Step-By-Step Configuration**

To work with the Matrix Generator, follow these steps:

1] Open the Matrix Generator.

2] Set up all settings, including **Fixture**, **Placement**, and **Addressing**.

3] Click **Apply** to confirm your settings and MADRIX will create the Patch file automatically for you.

- Click **OK** to confirm your settings and to close the Matrix Generator.
- Click **Cancel** to discard any changes and to close the Matrix Generator.
Settings

In this user guide it is not possible to give universal recommendations for the required settings, because every LED project is different. You need to configure the settings of the Matrix Generator according to your individual LED setup.

1] Fixture

This section defines which fixtures you want to use. To assist you, a **Fixture Preview** is shown that includes the start channel in blue, the number of pixels, and orientation. [Imagine to look directly at the LED products in camera view.]

- **Protocol** - First, choose the general type of LED fixture you are using [**DMX** or **DVI**].
  - DMX-based fixtures include DMX512, Art-Net, Streaming ACN [sACN / E1.31], Philips Color Kinetics [KiNET], and Philips Hue.
  - DVI-based fixtures include DVI, ColourSmart Link, Colorlight A8, Colorlight 5A, Colorlight T9, and Eurolite T9 products.
  - If you wish to used both fixture types at the same time, please configure your virtual LED matrix with the help of the »[Patch Editor](#)

  **Note:** If **DVI** is selected, all controls that are not relevant to DVI fixtures will be disabled.

- **Product** - Second, choose your exact LED product.
  - You can use the downward triangle to call up the complete list of fixtures.
  - Perform a left mouse click and you can use the input field as a filter to type in the fixture you are looking for.
  - If your fixture is not yet available, please see »[Supported Fixtures](#) [LED Products]

- **Start Fixture ID** - Defines where MADRIX starts indexing fixtures. The Fixture ID is a unique identifier for each fixture that is added.
  - The default value is 1.
  - When using the Matrix Generator, the default setting is also recommended setting.

- **A general option for DMX:** Select *Generic RGB Light 1 pixel* for any LED product with RGB LEDs and 3 DMX channels.
- **A general option for DMX**: Select *generic RGBW Light 1 pixel* for any LED product with RGBW LEDs and 4 DMX channels.

- **A general option for DVI**: Select *generic DVI 1x1 RGB* for any DVI-based LED product and simply enter the pixel resolution under *Placement*.

## 2) Placement

This section defines how many fixtures you want to use and how they are placed.

- **Rotation** - Uses the original rotation of the fixtures, as defined in the »MADRIX Fixture Editor. Or you can add to all of your fixtures a rotation of 90°, 180°, 270°.

- **Count X / Y / Z** - Defines the number of LED fixtures you are using.
  - *X* sets the number of fixtures on the X-axis [horizontal; width].
  - *Y* sets the number of fixtures on the Y-axis [vertical; height].
  - *Z* sets the number of fixtures on the Z-axis [level; depth].

- **Please set up the number of fixtures you are using. Do not enter the total number of pixels. All fixtures profiles are already implemented with their specific number of LED pixels.**

- When setting up a 2D virtual LED matrix, *Z* should be 1. If *Count Z* is higher than 1, you will automatically create a 3D LED matrix.

- The maximum value that can be entered is 65536. The number that can actually be used by you has theoretic limits as well as practical limits. Learn more [Limitations](#).

- **Merge Fixtures** - Is only available for *Protocol > DVI*
  - Activate this option if all your DVI fixtures, should be merged to one fixture. This can save computer performance.
  - Deactivate this option, if you want to be able to manage all your DVI fixtures separately, for example when creating a »DVI Patch.

- **Offset X / Y / Z** - Adds spacing [gaps] to your virtual LED matrix separately for the X-axis, Y-axis, and Z-axis.
  - The value defines the size of the gaps between fixtures in pixels.
  - A value of 0 means that all fixtures are placed next to each other without spacing.
  - For example, a value of 1 means that 1 pixel spacing is added between fixtures.

- **Note**: When using DMX-based products, please pay attention to the maximum number of DMX channels according to your MADRIX 5 License and according to the performance of your PC.
Note: When using DVI-based products, please pay attention to the maximum number of supported DVI voxels according to your MADRIX 5 License and according to the performance of your PC.

3] Addressing

This section defines the numbering of fixtures [DVI] and addressing of fixtures [DMX]. Since MADRIX will do this automatically, certain parameters need to be specified by you on how MADRIX should number or address fixtures automatically.

To assist you, a graphic is shown. [Imagine to look directly at the LED products in camera view.]

- **Start Corner** - Defines where the automatic addressing starts and works together with Main Orientation. Learn more [Examples]
- **Main Orientation** - Defines if MADRIX automatically addresses fixtures in a horizontal or vertical way. Addressing will start at the Start Corner and continue to the opposite direction [e.g., from left to right]. Please see the example below. Learn more [Examples]
- **Snake Mode** - Without Snake Mode, MADRIX will address row by row or column by column [e.g., left to right, left to right, left to right, etc.]. With Snake Mode, MADRIX will use alternate directions for each row or column [e.g., left to right, right to left, left to right, etc.]. Learn more [Snake Mode]
- **Apply Fixture Rotation** - Only works when Snake Mode is enabled. Rotates fixtures in each alternating row by 180°.
- **Z-Order** - Is only available for 3D. Defines if addressing in 3D starts with the first Z-axis in front [Front To Back] or with the last Z-axis in the back [Back To Front].
- **Snake Mode Z** - Is only available for 3D. Automatic addressing of fixtures on the Z-axis is done level by level. Activate this option if the Start Corner for each alternating level should be different.
  - **Flip H** - Switches the Start Corner horizontally [e.g., from Top Left to Top Right].
  - **Flip V** - Switches the Start Corner vertically [e.g., from Top Left to Bottom Left].
  - Activate both, Flip H and Flip V, to assign the complete opposite Start Corner [e.g., from Top Left to Bottom Right].
- **DMX Start Universe** - MADRIX will start addressing using this DMX universe and automatically increment the DMX universe for each fixture when necessary.
  - A total of 512 DMX channels is available per DMX universe.
  - If your fixture addressing is greater than 512, MADRIX will automatically assign a new DMX universe and start at DMX channel 1 in this new universe again.
  - The maximum number that can be entered has theoretic limits as well as practical limits. Learn more [Limitations]
- **DMX Start Channel** - MADRIX will start the addressing using this DMX channel and automatically increment the DMX channel for each fixture.
  - Valid values range from 1 to 512.

- **Apply To Each Universe** - Uses the entered value for each DMX universe instead of only the first universe.

- **Fixture Count Limit Per Universe** - Defines the maximum number of fixtures the MADRIX Software will place and address in a single DMX universe.
  - By default, the maximum number will automatically be provided. Adjust the number as needed or leave the default value.

### 4] Confirmation

- Press **Apply** to confirm your settings.
- Press **OK** to close the window.

### Examples For Start Corner, Main Orientation, and Snake Mode

#### Start Corner And Main Orientation

<table>
<thead>
<tr>
<th>DMX Start Corner</th>
<th>Main Orientation: Horizontal</th>
<th>Main Orientation: Vertical</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top Left</td>
<td>Top Right</td>
<td></td>
</tr>
<tr>
<td>----------</td>
<td>-----------</td>
<td></td>
</tr>
</tbody>
</table>

**Addressing:**
- Downwards
- From Left to Right
- From Left to Right
- From Left to Right
- etc.

**Addressing:**
- To the Right
- From Top to Bottom
- From Top to Bottom
- From Top to Bottom
- etc.

- Downwards
- From Right to Left
- From Right to Left
- From Right to Left
- etc.
### Snake Mode

- Without Snake Mode, MADRIX will address row by row or column by column [e.g., left to right, left to right, left to right, etc.].

- With Snake Mode, MADRIX will use alternate directions for each row or column [e.g., left to right, right to left, left to right, etc.].

- In this example we configured a virtual LED matrix of 4 x 5 pixels using **Snake Mode**
The **Matrix Generator** settings would look like this:

![Matrix Generator settings](image)

- In theory, the LEDs are arranged as follows: 3 pixels per LED (due to RGB), 4 fixtures per row, and a total of 5 rows. Please see the illustration below:
2D DMX Configuration

To configure a 2D LED matrix with DMX-based fixtures, follow these steps:

1] Choose Protocol > DMX
2] Choose your Product
3] Set up Rotation if required
4] Set up Count X and Count Y
5] Set Count Z to 1
6] Set up Offset X and Offset Y if required
7] Set Offset Z to 0
8] Set up Start Corner and Main Orientation
9] Set up Snake Mode and Apply Fixture Rotation if required
10] Set up DMX Start Universe, DMX Start Channel, and Fixture Count Limit Per Universe
2D DVI Configuration

To configure a 2D LED matrix with DVI-based fixtures, follow these steps:

**Merge Fixtures**

1] Choose Protocol > DVI
2] Choose your Product
3] Set up Rotation if required
4] Set up Count X and Count Y
5] Set Count Z to 1
6] Leave Merge Fixtures activated

**Separate Fixtures**

1] Choose Protocol > DVI
2] Choose your Product
3] Set up Rotation if required
4] Set up Count X and Count Y
5] Set Count Z to 1
6] Deactivate Merge Fixtures
7] Set up Start Corner and Main Orientation if required
8] Set up Snake Mode and Apply Fixture Rotation if required

3D DMX Configuration

To configure a 3D LED matrix with DMX-based fixtures, follow these steps:

1] Configure all Settings as described under Settings
3D DVI Configuration

To configure a 3D LED matrix with DVI-based fixtures, follow these steps:

Merge Fixtures

1] Choose Protocol > DVI
2] Choose your Product
3] Set up Rotation if required
4] Set up Count X and Count Y and Count Z
5] Leave Merge Fixtures activated
6] Set up Z-Order

Separate Fixtures

1] Choose Protocol > DVI
2] Choose your Product
3] Set up Rotation if required
4] Set up Count X and Count Y and Count Z
6] Deactivate Merge Fixtures
7] Set up Offset X / Y / Z if required
8] Set up Start Corner and Main Orientation if required
9] Set up Snake Mode and Apply Fixture Rotation if required
10] Set up Z-Order and Snake Mode Z if required
Important Notes

<table>
<thead>
<tr>
<th>LED Fixtures</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td>EUROLITE LSD</td>
<td>The fixtures are pre-patched and included with their amount of pixels. Please only define how many fixtures you are using and not the total number of pixels.</td>
</tr>
<tr>
<td>Color Kinetics eW Flex SLX, Color Kinetics iColor Flex SLX</td>
<td>If you are using a PDS-150, a sPDS-480ca, or a PDS-60ca with one or two strings per controller, please select the correct fixture.</td>
</tr>
</tbody>
</table>

Limitations

Count X / Y / Z

- The maximum value you can enter is 65536 by default.
- Please note that this is a theoretical limit.
- The maximum value that can be used depends on the capabilities of your computer.
  - The graphics card needs to support these values. [The Logfile shows the highest available values for your current system via viewport size X and viewport size Y in combination with 2D texture size for 2D mode and 3D texture size for 3D mode. Search for these items or choose Filter > Previews. Learn more »Tools]
  - The overall computer performance defines the maximum resolution your PC can handle in 2D or 3D. Learn more »System Requirements
  - The available, contiguous memory also defines the maximum available resolution [RAM; up to the theoretic maximum of 2 GB as a 32-bit application, which is much lower in practice].
- Examples:
  - It is not feasible to set up extremely high resolutions, such as 65536 x 65536 x 65536 or 500 x 500 x 500, for example.
  - High values can be useful when setting up extremely rectangular 2D matrices, such as 10000 x 20 x 1 or 20 x 10000 x 1, for example.
DMX Start Universe

- The maximum value you can enter is 2048 by default and the maximum value.
- You can change the maximum value in by changing the Virtual DMX Universes setting in the Options.
  Learn more » Performance
- It is possible to use more virtual DMX universes than actual DMX universes by using less than 512 DMX channels per universe.
- The actual number of DMX universes [i.e. DMX channels] that can be used for output depends on your MADRIX 5 License.
  » MADRIX KEY [Software License]

Further Configuration

- MADRIX offers many more options to configure your virtual LED matrix.
  Learn more » Patch Editor
- If your fixture is not yet available or if you would like to add it,
  please see » Supported Fixtures [LED Products]

Further Tips

Make sure to save your MADRIX Setup File after the configuration process.
4.2.2 Patch Editor

This topic includes:

- Introduction
- When To Use The Patch Editor
- Additional Information
- Step-By-Step Configuration
- Examples
- User Interface Of The Patch Editor
- Menu
- Options
- Patch Properties Overview
- 2D Or 3D
- Working With The Patch Editor
- Fixture Configuration
- How The Patch Affects The Live Previews
- DMX Map
- Further Tips

Introduction

You need to tell the MADRIX Software

1) which LED fixtures you are going to use.
2) how many LED fixtures you are going to use.
3) how they are placed.

This configuration of the virtual LED matrix is stored in a so-called Patch file.

Setting up the virtual LED matrix/the Patch file is a requirement! It is necessary for the initial configuration of MADRIX.

MADRIX offers 2 tools for this task:

- Matrix Generator
- Patch Editor
When To Use The Patch Editor

The Matrix Generator helps you to generate a virtual LED matrix automatically according to your settings. This automatic process can be very helpful, when your LED installation is set up in a very simple, logical, or linear way and only uses 1 fixture type. The Patch file will be automatically generated by MADRIX for you.

The Patch Editor is a graphical editor to directly create the Patch file. The Patch Editor offers the same functions as the Matrix Generator and many more options. It allows you to configure your virtual matrix in great detail. You can place LED fixtures freely and individually. If you have more than 1 kind of fixture, use the Patch Editor.

This topic explains the Patch Editor.
Additional Information

The Patch Editor is a powerful tool. While this chapter explains the main features, there are several other chapters that explain more advanced topics regarding the Patch Editor.

- >DVI Patch
- >CSV Fixture List Import
- >Merging Patches
- >Background Image

Step-By-Step Configuration

To work with the Patch Editor, follow these steps:

1] Open the Patch Editor.
2] Delete all currently included fixtures [except when they are needed].
3] Add all fixtures you require and configure them accordingly.
4] Set up the Matrix Settings.
5] Close the Patch Editor.

1] Open The Patch Editor

- Go to the menu Preferences > Patch Editor...
  [Keyboard shortcut: F3]
- A new window will open.

- The Patch Editor is a separate window. Hence, you will be able to control MADRIX while working with the Patch Editor.
2] Delete Fixtures

- Click **Select All** to select all fixtures or single-handedly select unnecessary fixtures. 
  [Keyboard shortcut: **Ctrl+A**]

- Click **Delete** to delete the selected fixtures from the workspace. 
  [Keyboard shortcut: **Del**]

- You can also click **New** to create a new Patch file and remove all fixtures at once.  
  [Menu **File > New Patch**; Keyboard shortcut: **Ctrl+N**]

3] Add And Configure Fixtures

- Click **Add +** to add new fixtures to the workspace. 
  [Keyboard shortcut: **Ins**]

- A new window will open.

- Add your fixtures as explained in the chapter »**Matrix Generator** and consider the following settings additionally:
  - The **Start Fixture ID** needs to be a number that is not yet occupied by fixtures in the Patch. Each fixture needs its own, unique Fixture ID. MADRIX will automatically provide the next number that is free to use. [You will not be able to add new fixtures if an ID is not unique.]
  - You can choose not to set up all **Addressing** in the Add Fixtures window. The Patch Editor allows you to configure each fixture individually later.
  - **DMX Start Universe** - MADRIX will automatically calculate the next free start universe according to the fixture profile you have currently selected [**Fixture > Product**] and according to any changes you are making regarding your Patch. In order for this to work, **Auto Address** needs to be enabled in the Patch Editor [**Preferences > Automatically Address New DMX Fixtures**].
  - **DMX Start Channel** - MADRIX will automatically calculate the next free start channel according to the fixture profile you have currently selected [**Fixture > Product**] and according to any changes you are making regarding your Patch. In order for this to work, **Auto Address** needs to be enabled in the Patch Editor [**Preferences > Automatically Address New DMX Fixtures**].
  - Make sure to set up **Start Position X / Y / Z**. This will position fixtures correctly on the workspace and prevent fixtures to overlap. [You will not be able to add new fixtures if their positions overlap. However, you can intentionally allow overlapping fixtures if you want to as explained below.]
- Click **Add** to add your fixtures.

- Configure your fixtures further if needed. [Please see below]
- Repeat the steps to add more fixtures or fixtures of different types.
- The Patch Editor is very flexible. Fixtures can simply and are often required to be rearranged, readdressed, added, and deleted later. Adding fixtures is an initial step to create the individual Patch for your individual LED installation.
- Click **Close** to close the window.

### 4] Set Up The Matrix Settings

- After you have set up and configured all of your fixtures, it is important to define the Matrix Settings.
- Click **Matrix Settings**
  
  [menu *Edit > Matrix Settings...*]

- A new window will open.

![Matrix Settings dialog box]

A new window will open.
The virtual LED matrix represents your LED fixtures. Therefore, it is the area on which the MADRIX Effects are rendered and displayed, and ultimately sent to your output. MADRIX needs to know in pixels/voxels how large your LED project is in total.

Set up the Matrix Size according to all of these parameters:

- **Match Voxel Map Area** - Automatically adjusts the Matrix Size Settings to the fixtures that are placed in the Voxel Map of the Patch Editor.

- **Size X** - Defines the total size of the virtual LED matrix in X in pixels/voxels [horizontal; width].

- **Size Y** - Defines the total size of the virtual LED matrix in Y in pixels/voxels [vertical; height].

- **Size Z** - Defines the total size of the virtual LED matrix in Z in pixels/voxels [level; depth].
  - Choose **Size Z = 1** to work in 2D.
  - Choose a value higher than 1 and MADRIX will automatically create a virtual matrix in 3D.

- **Match Color Depth** - Automatically adjusts the Matrix Color Depth Settings to the color depth of the fixtures that are placed in the Voxel Map of the Patch Editor.

- **Color Depth** - Defines the number of color channels your LED fixtures use.
  [For example, a color depth of 3 resembles RGB and a color depth of 4 represents RGBW.]

- Confirm your changes with **OK**

### 5] Close The Patch Editor

- Close the Patch Editor when you have fully set up and configured your Patch correctly.
  [Continue to learn how to work with the Patch Editor below.]

- When you want to close the Patch Editor, click **X**
  or go to the menu **File > Close** when you want to close the Patch Editor.
  [Keyboard shortcut: **F3**]

- When you save your MADRIX Setup file, the Patch file is automatically included.
Examples

- **Note:** Each LED project is different. That is why each Patch in the Patch Editor will look different. There are no general settings that can be applied to every project. Instead, please make sure that the Patch is set up in MADRIX according to your individual LED installation.

- Here are just a few examples of how a Patch could look like:
User Interface Of The Patch Editor

Overview

The user interface of the Patch Editor is divided into several, different parts.

- On top, you will find the menu.
- Below the menu, you see the toolbar.
- Below the toolbar, 3 sections are available.
- On the left side, you see the Fixture List.
- The middle section represents a graphical version of your workspace and of your virtual LED matrix. [There are three different view modes available for this section. Learn more below.]
- On the right side, you can use various settings for the fixture configuration.
- Rearrange the width of each section by dragging the section edges.
- Hide the left section or the right section by dragging their edge to the outer border of the Patch Editor window. Display them again by dragging the border back.
Choose View > Restore Default Window Layout in order to reset the layout of the Patch Editor to its original settings [or if you are experiencing graphical glitches].

Menu And Toolbar

The Patch Editor has a separate menu and a toolbar for shortcuts:

- All items of the menu are explained below.
- The toolbar provides shortcuts to convenient tasks and includes the majority of options that are also included in the menu.
  - You can rearrange the toolbar using Left Mouse Click And Drag And Drop

Fixture List [Left Side]

The left side of the Patch Editor shows the Fixture List:

- The Fixture List provides information and allows you to select specific fixtures.
  - You can choose to show DVI fixtures [DVI] and DMX fixtures [DMX Universes]. Select it if you want to see DVI fixtures or which particular DMX universe.
  - DMX fixtures are shown with their name, index number, and DMX start channel.
  - DVI fixtures are shown with their index number, and if DVI Mapping is active.
  - Select fixtures with your mouse and they will be automatically selected in the graphical middle section. Select several fixtures by using the Shift or Ctrl button in addition.
  - Select the Fixture List and use the Left Arrow Key and the Right Arrow Key to navigate through all DMX Universes and DVI.
Information And Configuration [Right Side]

The right side of the Patch Editor is a context-sensitive panel that shows different items depending on your selection [fixtures, fixture groups, no selection].

- Learn more about the right section to configure your fixtures and read the information provided below.
Graphical Overview [Middle Section]

- The middle section is the most important section.

- 3 view modes are available for the graphical overview:
  - **Voxel Map** - Is the default view mode to work with the Patch Editor. The following explanations mainly reference this view mode!
  - **DVI Map** - Is only relevant when working with DVI fixtures. Learn more »[DVI Patch]
  - **DMX Map** - Allows you to view the Patch with regards to occupied and used DMX channels. This mode will be explained separately. Learn more »[DMX Map]
- The Voxel Map shows fixtures and settings in the following ways:
  - The size of the virtual LED matrix [Matrix Settings] is shown with the help of a light gray grid.
  - The total workspace you can work on is shown with the help of a dark gray grid.
  - You can see the position of fixtures.
  - DVI fixtures are displayed in light gray with a dark outline.
  - Selected DVI fixtures are displayed in green.
  - DMX fixtures are displayed in dark gray with a light outline.
  - Selected DMX fixtures are displayed in green.
  - There is an integrated system for error and information messages. A message box will be displayed at the bottom of the middle section. Close the message with x.

The following work-flows are mainly relevant for the view mode Voxel Map, but can also work selectively in the DMX Map.
Menu

- **Ctrl+N** - This is a keyboard shortcut that will perform the action directly rather than using the menu.
- ... - Indicates that an extra window will open on top of the Patch Editor window.

File Menu

- **New Patch** - Removes all fixtures and creates a new and empty workspace [MADRIX can only have one Patch file at a time].
- **Open Patch**... - Loads a previously saved patch file.
- **Merge Patches**... - Allows you to merge different Patch files and combine them in order to create a single, large Patch file.
  Lear more »**Merging Patches**
- **Save Patch** - Saves the Patch file in its current state.
- **Save Patch As**... - Saves the Patch file as a new file.

- **Import Fixture List**... - Allows you to import a list of fixtures in CSV file format.
- **Export Fixture List...** - Allows you to export the currently patched fixtures as a convenient HTML site for further use.

- **Print Fixture List...** - Allows you to send the currently patched fixtures as a convenient list directly to your printer.

- **Update Fixtures From Library** - Allows you to refresh all fixture profiles in the Patch from the currently loaded MADRIX Fixture Library, in case you changed fixture profiles that are included in the Fixture Library with the help of the Fixture Editor. Changing the fixture profiles after creating the Patch can sometimes be necessary and is often easier than creating the Patch again from the beginning [MADRIX will not update fixtures under certain circumstances. That is the case, when the Fixture Library does not contain the fixture type, i.e. the unique fixture ID is not included (UUID), or when a DVI fixture is made out of more voxels than defined in the Fixture Library, for example when having chosen Merge Fixtures while adding them.]

- **Export Selected Fixture...** - Allows you to save a fixture directly from the Patch to an external file [of the file type *.mfxx] without using the Fixture Editor. Simply select a fixture in the Patch Editor first. Then, choose a name.

- **Close** - Closes the Patch Editor.

### Edit Menu
- **Undo** - Restores the previous state of the Patch and reverts your last actions.
- **Redo** - Recreates the state again after having performed an Undo.

- **Matrix Settings** - Defines the main settings of the Patch file [as explained above].

- **Add Fixtures** - Opens a new window in order to add fixtures to the workspace.
- **Remove Selected Fixtures** - Removes the selected fixtures from the workspace.
- **Restore DVI Mapping Defaults For Selection** - Is only relevant when working with DVI fixtures. Learn more »
- **DVI Patch**
- **Move Map Area To Matrix Origin** - Moves the entire map area and all of its included fixtures to position 0, 0, 0.

- **Flip Selection Horizontally** - Flips all the selected fixtures horizontally. This flips the entire selection once as one block instead of all fixtures individually.
- **Flip Selection Vertically** - Flips all the selected fixtures vertically. This flips the entire selection once as one block instead of all fixtures individually.
- **Flip Selection Horizontally And Vertically** - Flips all the selected fixtures horizontally and vertically. This flips the entire selection once as one block instead of all fixtures individually.
  - When flipping multiple fixtures, these 3 functions will flip the entire block of fixtures. The position of each fixture will change as they are flipped using the central point of all fixtures.
  - Therefore, it is different to the **Flipping** that can be applied in the section **Voxel Mapping** when a fixture is selected. That function will flip each fixture individually and not change the positions.

- **Rotate Selection By 90°** - Changes the rotation of the selected fixtures by 90°. This rotates the entire selection once as one block instead of all fixtures individually.

- **Rotate Selection By 180°** - Changes the rotation of the selected fixtures by 180°. This rotates the entire selection once as one block instead of all fixtures individually.

- **Rotate Selection By 270°** - Changes the rotation of the selected fixtures by 270°. This rotates the entire selection once as one block instead of all fixtures individually.
  - When rotating multiple fixtures, these 3 functions will rotate the entire block of fixtures. The position of each fixture will change as they are rotated using the central point of all fixtures.
  - Therefore, it is different to the **Rotation** that can be applied in the section **Voxel Mapping** when a fixture is selected. That function will rotate each fixture individually and not change the positions.

### View Menu

<table>
<thead>
<tr>
<th>View</th>
<th>F5</th>
<th>F6</th>
<th>F7</th>
</tr>
</thead>
<tbody>
<tr>
<td>Voxel Map</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DVI Map</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DMX Map</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Background Image</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- **Voxel Map** - Is one of three view modes. It is the default view mode to work with the Patch Editor.
**DVI Map** - Is one of three view modes. It is only relevant when working with DVI fixtures. Learn more »[DVI Patch](#)

**DMX Map** - Is one of three view modes. Allows you to view the Patch with regards to occupied and used DMX channels. Learn more [DMX Map](#)

**Background Image** - Is an additional viewing feature for Voxel Map and DVI Map. Allows you to load an image into the background to make placing fixtures easier. Learn more »[Background Image](#)

**Zoom In** - Determines the level of detail. Zoom in to see single fixtures, their assigned universe, channel, and rotation.

**Zoom Out** - Determines the level of detail and allows you to see more of the workspace.

**Focus All** - Automatically adjusts the zoom level to show all fixtures on the workspace.

**Focus Selection** - Automatically adjusts the zoom level to show all currently selected fixtures.

**Toolbars** - Shows or hides the corresponding toolbars and icons [File, Edit, View, Preferences, Fixture Groups, Select].

**Restore Default Window Layout** - Restores the default user interface and layout of the Patch Editor.

---

### Preferences Menu

<table>
<thead>
<tr>
<th>Preferences</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Highlight Selected</td>
<td></td>
</tr>
<tr>
<td>Fixtures</td>
<td></td>
</tr>
<tr>
<td>Allow Fixtures To</td>
<td></td>
</tr>
<tr>
<td>Overlap</td>
<td>Ctrl+I</td>
</tr>
<tr>
<td>Link DVI Mapping</td>
<td></td>
</tr>
<tr>
<td>And Voxel Mapping</td>
<td></td>
</tr>
<tr>
<td>Copy DVI Mapping</td>
<td></td>
</tr>
<tr>
<td>Automatically</td>
<td></td>
</tr>
<tr>
<td>Address New DMX</td>
<td></td>
</tr>
<tr>
<td>Fixtures</td>
<td>Ctrl+Alt+O</td>
</tr>
</tbody>
</table>

**Highlight Selected Fixtures** - Makes selected fixtures flash with white color. This makes it easier to identify and see them on stage. This feature is available for DMX-based fixtures.

**Allow Fixtures To Overlap** - Allows fixtures as well as their DVI Mapping to be arranged on top of each other on the virtual LED matrix. If deactivated, you cannot place any fixture on a position that is already occupied by another fixture or DVI Map.
- **Link DVI Mapping And Voxel Mapping** - Is only relevant when working with DVI fixtures. Learn more » [DVI Patch]

- **Copy DVI Mapping** - Is only relevant when working with DVI fixtures. Learn more » [DVI Patch]

- **Automatically Address New DMX Fixtures** - Automatically sets up the DMX addresses for DMX fixtures that are added to the Patch by newly adding or copying them. Learn more below.

- **Options...** - Will open a new window in order to change various options of the Patch. Learn more below

### Fixture Groups Menu

- **Create Empty Fixture Group** - Creates a fixture groups which does not contain any fixtures yet.

- **Create Fixture Group From Selected Fixtures** - Creates a fixture group that automatically includes all fixtures that have been selected before.

- **Remove Selected Fixture Groups** - Removes all fixture groups that are currently selected from the Patch.

- **Assign Selected Fixtures To Selected Fixture Groups** - Adds all currently selected fixtures to all fixture groups that are currently selected.

- **Release Selected Fixtures From Selected Fixture Groups** - Releases all currently selected fixtures from all fixture groups that are currently selected.

- **Release Selected Fixtures From All Fixture Groups** - Releases all currently selected fixtures from all fixture groups that they are assigned to.

- Learn more » [Fixture Groups [Group Control]]
Select Menu

- **Select All** - Selects every single fixture that is included in your Patch. At the same time, all fixtures will be selected in the Fixture list on the left.
- **Deselect All** - Revokes the current fixture selection.
- **Invert Selection** - Selects every fixture except the ones you have currently selected.

Options

Overview

- In the Patch Editor, go to the menu **Preferences > Options**...
  
  [Keyboard shortcut: Ctrl+Alt+O]
Workspace

The workspace allows you to freely position fixtures and work with them on a grid.
By default, the workspace size is set to 512 x 512 x 1 pixels [X x Y x Z].

- If needed, change the size of the workspace according to your needs by adjusting Width, Height, and Depth.
- MADRIX will automatically increase the size of the workspace if you are adding fixtures to positions that are outside of the current workspace size.

Note: The workspace is the large grid you are working on. In contrast, the virtual LED matrix [i.e., Matrix Settings] tells MADRIX the total size of the fixtures and of the LED installation.

Undo And Redo

You can use Undo and Redo to revert actions while working in the Patch Editor.
By default, the Patch Editor allows 500 steps to be reversed.

- If needed, change this so-called Undo History Limit according to your needs.

Highlight
Highlight Options allow you to change how the built-in Highlight mode for fixtures work [menu Preferences > Highlight Selected Fixtures].

- **Color** - Defines the color that is sent to highlighted fixtures. By default color is white.
- **Mode** - Defines how the highlight mode works. Select from 2 options:
  - **Highlight Color And Black** - Uses the defined Color and highlights all selected fixtures. All fixtures that are currently not selected will receive the color black. This is useful to single out fixtures in a test environment.
  - **Highlight Color And Output** - Uses the defined Color and highlights all selected fixtures. All fixtures that are currently not selected will receive the normal output of the MADRIX Software. This is useful during a show to not interrupt the data and effects for all other fixtures.

**Patch Properties Overview**

The Patch Editor can provide a useful overview over the most important settings, such as Matrix Size and Workspace. The overview is provided in the lower right corner. First, make sure that no fixture is selected!
• **Patch Properties** - The following information is available to you:

  - **Total DMX Fixture Count** - Shows the overall number of DMX fixtures that are currently included in your Patch file.

  - **Total DVI Fixture Count** - Shows the overall number of DVI fixtures that are currently included in your Patch file.

  - **Total Fixture Group Count** - Shows the overall number of Fixture Groups that are currently included in your Patch file.

  - **Workspace Size** - Shows the currently set up size of the Workspace.

  - **Matrix Size** - Shows the currently set up Matrix Size in the Matrix Settings.

  - **Voxel Map Area X** - Shows the size of the area on which fixtures are patched and located in X, independently of the Matrix Size that is defined.

  - **Voxel Map Area Y** - Shows the size of the area on which fixtures are patched and located in Y, independently of the Matrix Size that is defined.

  - **Voxel Map Area Z** - Shows the size of the area on which fixtures are patched and located in Z, independently of the Matrix Size that is defined.

  - **DVI Map Area X** - Is only visible when DVI fixtures are included in the Patch. Shows the size of the area on which DVI fixtures with DVI Mapping are patched and located in X. »[DVI Patch]

  - **DVI Map Area Y** - Is only visible when DVI fixtures are included in the Patch. Shows the size of the area on which DVI fixtures with DVI Mapping are patched and located in Y. »[DVI Patch]

  - **DVI Map Area Z** - Is only visible when DVI fixtures are included in the Patch. Shows the size of the area on which DVI fixtures with DVI Mapping are patched and located in Z. »[DVI Patch]


2D Or 3D

Overview

- MADRIX can control 2D projects as well as 3D projects. Learn more »2D Or 3D [X, Y, Z]
- You automatically choose to work in 2D or in 3D, when you add new fixtures or set up the virtual LED matrix [Matrix Settings]. Learn more above

Z-Levels

Make sure to select the view mode Voxel Map first.

- The Patch Editor only provides a 2D, graphical representation, even if you are working in 3D.
- To access and configure all fixtures of a 3D project, you can select the different Z-levels that make up your project.

- When working in 2D, only one Z-level is needed and available [Z-Layer 1].
When working in 3D, you can select and view each Z-level according to your needs.

A] You want to select only one Z-level:
1] **View From** - Select the **Z-Layer** you wish to see and work with.
2] Leave **To** deactivated.
3] You will be able to select and work with the fixtures of only 1 Z-level at a time.

![View From Z-Layer selection](image)

B] You want to select several or all Z-levels at once:
1] **View From** - Select the first **Z-Layer** you wish to see and work with.
2] **To** - Activate it. Then, select the last **Z-Layer** you wish to work with.
3] All Z-levels and their corresponding fixtures within that range of Z-levels will be selectable.

**Example:**
If you want to select and work with all fixtures of your 3D project that features 10 Z-levels, set up **View From Z-Layer 1 To Z-Layer 10**

![View From Z-Layer selection](image)

- If you now want to select all fixtures, click **Select All** [or press **Ctrl+A**].
- If you want to select one fixture, simply click on it.
- If you want to select a fixture and all other corresponding fixtures on the same position on each Z-level, make sure to use the ways of selecting multiple fixtures as described below [e.g., rectangular selection mode via **Shift**].
- If you are selecting multiple fixtures on the Z-level you currently see, all corresponding fixtures on each Z-level will also be selected.
- Use the Fixture List [on the left side of the Patch Editor] to double-check which fixtures you have currently selected.
More Information:

- Z-Layers with a **green** background show the currently selected Z-level.
- Z-Layers with a **blue** background show the currently occupied and used Z-levels. There are fixtures patched on those Z-Layers.
- Z-Layers with a **black** background show Z-levels that are set up in the Matrix Size, but there are no fixtures patched on those Z-levels.

---

**Working With The Patch Editor**

The following work-flows are mainly relevant for the view mode *Voxel Map*, but can also work selectively in the *DMX Map*.

**Overview**

- **Selection**
  
  A] Left-click on a single fixture in the graphical middle section in order to select it.
  
  B] Left-click a fixture in the Fixture List and it will automatically be selected in the graphical middle section.
Multiple Selection

A] Left-click on fixtures while holding Ctrl on your keyboard in order to select several fixtures.
B] Hold Shift on your keyboard. Then, hold your left mouse button and drag your mouse. A selection mask will become visible. It is displayed with the help of a dotted line.
Additionally, hold the Ctrl button and you will be able to select different areas of the Patch which will be added to your selection.
C] Hold Shift, left-click the first fixture, then left-click the last fixture, and applying a rectangular selection mode, every single fixture between the first and the last fixture will be selected.
Hold Ctrl and Shift at the same time and you can select different fixtures each time, while the previously selected fixtures remain selected.
D] Select several fixtures via Shift+Left click or Ctrl+left click in the Fixture List and they will be automatically selected in the graphical middle section.

Zoom

- Use the scroll wheel to zoom in or to zoom out.

Navigation

- Press Space and left click in order to drag the graphical middle section for navigation. [You can also use the scroll bars.]

Position [Drag And Drop]

- Select a fixture and hold the mouse button. Then, move your cursor. Your selection will stand out from the rest of the Patch. Drop it on the new position and it will automatically snap to this position according to the grid.
- This also works with multiple fixtures.
- Use drag and drop in combination with Ctrl to copy fixtures and the DMX universe and DMX channel will be automatically adjusted [if this option is activated in the menu]. Learn more Copying Fixtures

Position [Keyboard]

- Select one or several fixtures and use the arrow keys on your keyboard to move them to a different position.

Rotation

- Select multiple fixtures and use Page Up or Page Down on your keyboard to rotate the entire block of fixtures. They will be literally rotated using the central point of all fixtures. Hence, the position will be changed automatically. [In contrast, if you select several fixtures and adjust the Rotation in the Fixture settings, each fixture will be rotated individually. Their positions will not change. ]

Copying DVI Fixtures

Single DVI Fixtures
- Select a single DVI fixture while holding Ctrl. Then, continue to hold Ctrl and the left mouse button and drag your mouse and a copy of the DVI fixture will be created. Simply release the mouse at the fixture's new position.

Multiple DVI Fixtures

- Select multiple DVI fixtures while holding Ctrl. Now hold down the left mouse button at the same time on any of the selected fixtures. Drag your mouse and copies of the DVI fixtures in a corresponding pattern will be created. Simply release the mouse at the fixtures' new position.

Copying DMX Fixtures [Auto Addressing]

Overview

Pay attention when using auto addressing and double-check if each fixture is addressed correctly!

- Copying DMX fixtures has been improved by adding auto addressing.
- If auto addressing is enabled, MADRIX will automatically increase the DMX channel [and DMX universe] of the copied fixture.
- In the Patch Editor, go to Preferences > Automatically Address New DMX Fixtures to activate auto addressing.
- Disable this feature and the copied fixtures will have the same DMX channel and universe as their sources.

Single Fixtures

- Select a single DMX fixture while holding Ctrl. Then, continue to hold Ctrl and the left mouse button and drag your mouse and a copy of the DMX fixture will be created. Simply release the mouse at the fixture's new position.
- The DMX channel and the DMX universe will be automatically adjusted if auto addressing is enabled.
- **Example:** The original fixture at position 1,1 is patched to DMX universe 1 and channel 1. It requires 3 DMX channels. Therefore the first copy, fixture number 2, is automatically set to channel 4, and so on.
Multiple Fixtures

- If you select several DMX fixtures, auto addressing also works. The intelligent function calculates the next free DMX address for each of the copied DMX fixtures and automatically adjusts the DMX channel and the DMX universe for each fixture.

- **Example 1:** A row of four linearly addressed fixtures shall be copied at once [6 DMX channels per fixture]. Result: Each fixture will be addressed to the next free DMX address in comparison to the previous fixture.

- **Example 2:** A row of four linearly addressed fixtures shall be copied at once, while fixture number 3 has a higher address than fixture number 4 [6 DMX channels per fixture]. Result: Fixture number 7 has also a higher DMX address than fixture number 8.
Example 3: A row of three linearly addressed fixtures should be copied at once, while spacing and an offset is added to fixture number 3 [6 DMX channels per fixture]. Result: Fixture number 6 continues with the next free addressing of fixture number 5 and does not have an additional offset, while keeping the spacing.

Highlight Selected Fixtures

- Makes corresponding fixtures flash for better identification. This makes it easier to see them on stage/in your LED installation. That means, if you select one or several fixtures within the Patch Editor, the corresponding LED fixtures in your installation will light up completely white.
- This feature is available for DMX-based fixtures without restrictions.
- Highlighting DVI-based fixtures is possible. For the feature to work, make sure that the External Previews are set to DVI Map Mode.

Allow Fixtures To Overlap

- This feature allows fixtures to overlap. In order to rearrange the Patch, a fixture may be dragged/repositioned to the position of another fixture.

Fixture Configuration
The following work-flows are mainly relevant for the view mode *Voxel Map*, but can also work selectively in the *DMX Map*.

**Overview**

- In order to configure a fixture in the Patch Editor, select it first.
- The corresponding information will be displayed in the third column.
- When selecting multiple fixtures, settings can be confirmed with **OK** and will apply to each fixture individually.
- **Configure each fixture according to your requirements!**
- **General Fixture Settings**
  - *Display Name* - Defines a label for the fixture.
  - *Fixture ID* - Defines the unique identifier for this fixture. Each fixture needs its own, unique Fixture ID.
  - Always confirm with **OK**

- **Voxel Mapping** - Includes settings that refer especially to pixel mapping and voxel mapping [e.g., the position of fixtures].
  - *Flipping* - Allows you to flip a fixture horizontally, vertically, or both. Learn more [below](Glossary)
  - *Rotation* - Allows you to rotate a fixture. Learn more [below](Glossary)
  - *Position X* - Defines the horizontal position of the fixture.
  - *Position Y* - Defines the vertical position of the fixture.
  - *Position Z* - Defines the depth position of the fixture.
  - Always confirm with **OK**

- **DMX Addressing** - Includes settings that refer especially to the DMX address of a fixture.
  - *DMX Universe* - Defines the second part of the DMX address of DMX fixtures. Usually, each fixture has a specific and unique DMX address. Learn more [Glossary](Glossary)
  - *DMX Channel* - Defines the first part of the DMX address of DMX fixtures. Usually, each fixture has a specific and unique DMX address. Learn more [Glossary](Glossary)
  - Always confirm with **OK**

- **Offset** - Allows you to quickly add or subtract values from a setting. For example, if you have multiple fixtures selected and want to increase all their DMX channels by 3, simply add an Offset of 3.

- **OK** - Always confirm any changes with OK.
- **Reset** - Allows you to discard changes before having confirmed any changes in order to use the values that were set up last.
- **Fixture Properties** - Provides basic information about the fixture profile of the currently selected fixture.
  - **Fixture ID** - Shows the unique identifier of the fixture.
  - **Manufacturer** - Shows the name of the manufacturer of the fixture as defined in the MADRIX Fixture Editor.
  - **Fixture Name** - Shows the name of the fixture as defined in the MADRIX Fixture Editor.
  - **Operation Mode** - Shows the mode of the fixture as defined in the MADRIX Fixture Editor.

  - **Protocol** - Shows the type of the fixture as defined in the MADRIX Fixture Editor.
  - **Size** - Shows the amount of pixels/voxels of the fixture as defined in the MADRIX Fixture Editor.
  - **Color Depth** - Shows the color depth of the fixture as defined in the MADRIX Fixture Editor.
  - **DMX Channel Count** - Shows the number of DMX channels that the fixture uses as defined in the MADRIX Fixture Editor.

  - **Valid DMX Address Range** - Shows the lowest and highest possible DMX channel address for the fixture as defined in the MADRIX Fixture Editor.

  - **DVI Mapping** - Shows if an individual DVI Mapping is configured for the DVI fixture.

- **DVI Mapping** - Is only relevant for DVI fixtures. Learn more »[DVI Patch](#)

**Fixture Rotation**

- Fixture rotation is shown for both DMX and DVI fixtures with the help of a solid arrow.

- A small baseline indicates the opposite direction of the direction the arrow shows for better identification.

<table>
<thead>
<tr>
<th>Original [0°]</th>
<th>90°</th>
<th>180°</th>
<th>270°</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="DVI Original" /></td>
<td><img src="image" alt="DVI 90°" /></td>
<td><img src="image" alt="DVI 180°" /></td>
<td><img src="image" alt="DVI 270°" /></td>
</tr>
</tbody>
</table>
Fixture Flipping

- Fixture flipping is shown for both DMX and DVI fixtures with the help of a double arrow [two-way symbol].
- If a fixture is not flipped, no symbol will be shown.
- **Flipping is applied to the original fixture position, before rotation.**

How The Patch Affects The Live Previews

- All Previews [including Preview Deck A, Preview Deck B, Preview Output as well as External Preview 1 and External Preview 2] are affected by your individual Patch [i.e. virtual LED matrix].
- The Patch represents your LED installation on a more technical level.
- The Previews will represent the Patch and in this way your LED installation.
- Learn more »[3 Previews](#)

DMX Map

The DMX Map is one of three view modes that are available for the Patch Editor.

- **Voxel Map** - Is the default view mode in order to work with the Patch Editor and the Patch.
- **DVI Map** - Is only relevant when working with DVI fixtures. Learn more »DVI Patch
- **DMX Map** - Allows you to view the Patch with regards to occupied and used DMX channels.

- To display DMX Channel mode, click **DMX Map**
  
  [menu View > DMX Map]

  [Keyboard shortcut: F7]

- The DMX Map:
  - Is a separate view mode. But it is not independent from the Voxel Map. If you change something here, the corresponding settings will also change in the Voxel Map.
  - Shows all 512 DMX channels per DMX universe.
  - Shows the fixtures not based on their pixel/voxel count, but on the DMX channels they use.
  - Shows 16 DMX addresses per row. If a fixture uses DMX channels that are located on several rows, the Patch Editor will display such a fixture with the help of a split arrow.
  - Is another way to work with DMX fixtures. It will be empty if you are only using DVI fixtures.
  - Can be used to work with DMX fixtures. A lot of the work-flows of the Voxel Map will work here as well.

- In order to work in a specific DMX universe, select the particular **DMX Universe** first.
Further Tips

Make sure to save your MADRIX Setup file after the configuration process.

You may also save and/or export the Patch file [of the file type *.mpz or *.mpx] separately. In the Patch Editor, go to File > Save Patch As...
4.2.3 DVI Patch

This topic includes:
- Introduction
- Usage
- How DVI Hardware Controllers Work
- Step-By-Step Configuration
- DVI Mapping
- Important Information
- DVI Map Mode For The External DVI Outputs
- Example

Introduction

This chapter is an addition to the chapter »Patch Editor«. Please read the chapter Patch Editor in order to learn more about the Patch in general. This chapter focuses on working with DVI fixtures.

Patch Editor and DVI Patch are about one and the same tool. The term DVI Patch specifically refers to working with DVI fixtures.

- Go to the menu Preferences > Patch Editor
  [Keyboard shortcut: F3]

Usage
On the one hand, working with DMX-based fixtures is relatively easy and can be managed with the help of the Patch Editor without much difficulty. You can simply add fixtures, rotate them, or add space between fixtures, for example. Without the DVI Patch, on the other hand, it would not be possible to add rotation or spacing to DVI-based fixtures, because of how DVI hardware controllers work.

The DVI Patch allows you to add

- rotation
- flipping
- spacing

To your LED installations with DVI fixtures.

The DVI Patch can be used when working with DVI fixtures and the following output methods:

- DVI
- Proprietary DVI Devices [5A / A8 / T9]

### How DVI Hardware Controllers Work

DVI controllers receive a signal [input] and map it to the LED fixtures [output]. But due to their construction, DVI controllers usually need to receive the input images in a linear way, in one whole block of information [often like a rectangle] — no matter how the actual LED installation looks like. You could also say that DVI controllers expect DVI fixtures to be installed in a predefined way. If you install the DVI fixtures differently, you need to change the input, too.

In other words, when your LED installation looks like this for example:
Then, your DVI controller will probably need the input signal to look like this:

![DVI signal example]

This is no problem for MADRIX. It will transform the signal for your DVI controller according to your Patch configuration.

While the DVI fixtures represent your LED installation in MADRIX and its Previews, you can customize their DVI Mapping settings for the controller that receives the signal. As shown above, DVI fixture settings and their DVI Mapping often are two different things if you add rotation, flipping, or spacing. That is why you will have to configure the normal DVI fixture settings and their DVI Mapping settings separately.

The Patch Editor provides three view modes. Regarding the DVI Patch, the DVI Map is of special importance, since makes it possible to configure the required DVI Mapping of the DVI fixtures.

**Step-By-Step Configuration**

In order to work with DVI fixtures, follow the instructions below:

1. Position your DVI fixtures in the graphical workspace of the Patch Editor according to your LED installation [using the view mode Voxel Map].

2. Set up the size of your virtual LED matrix [using the Matrix Settings]. Normally, the area it defines should include all of your DVI fixtures.


4. Adjust the DVI Mapping of every single DVI fixture according to the requirements of your DVI hardware controller. [The DVI Mapping of the first DVI fixture normally starts at position X:1, Y:1.]

5. When using »DVI, activate the DVI Map Mode of the external DVI Outputs. When using »Proprietary DVI Devices [5A / A8 / T9], Step 5 is not required.
Step 1 and 2 are explained in the chapter »Patch Editor
Step 3, 4, and 5 will be explained below.

Step 3, 4, and 5 are only necessary, if you wish to add spacing, rotation, or flipping to your Patch that includes DVI fixtures.

DVI Mapping

Overview

The DVI Mapping of DVI fixtures represents the fixture configuration for the DVI hardware controller. DVI Mapping settings can include their own position, rotation, and flipping settings. In order to work with DVI Mapping, you need to activate the DVI Map of the Patch Editor.

- In the Patch Editor, select View > DVI Map
  [Keyboard shortcut: F6]

You only need DVI Mapping if you are using DVI fixtures in a different way than what the DVI controller expects.

Comparison Of Voxel Map And DVI Map
DVI Mapping is inactive in the Voxel Map. It is shown in gray with a diagonal grid. 
[Column 1 shows a selected DVI fixture and its DVI Mapping. Column 2 shows a non-selected fixture and its DVI Mapping.]

DVI Mapping is active in the DVI Map. It is shown in yellow with a diagonal grid. 
[Column 1 shows a selected DVI fixture and its DVI Mapping. Column 2 shows a non-selected fixture and its DVI Mapping.]

When DVI fixture and its DVI Mapping have the same position, the DVI fixture is shown.

When DVI fixture and its DVI Mapping have the same position, the DVI Mapping is shown.
By default, DVI fixture and DVI Mapping settings are linked together. If a setting, such as rotation, is changed for the fixture or the DVI Mapping, the opposite setting [DVI Mapping or fixture, respectively] will receive the same change or a corresponding offset. Deactivate the feature in the menu **Preferences > Link DVI Mapping and Voxel Mapping** [Keyboard shortcut: **Ctrl+L**]. If activated, the icon glows green in the toolbar.

DVI fixtures can overlap. That means that one fixture can be positioned over another fixture. You need to activate the feature in the menu **Preferences > Allow Fixtures To Overlap**. If activated, the icon glows green in the toolbar.

DVI fixtures can be copied very easily. Before copying a DVI fixture, you can decide how its DVI Mapping is handled during the copy process. Enable or disable the feature in the menu **Preferences > Copy DVI Mapping**.

| Disabled: If a DVI fixture is copied, the DVI Mapping is reset to its default settings. That means it will have the settings of the newly copied DVI fixture. In fact, the copied DVI fixture has its own DVI Mapping. | | | DVI fixtures with adjusted DVI Mapping settings can overlap. That means that one Map can be positioned over another Map. You need to activate the feature in the menu **Preferences > Allow Fixtures To Overlap**. If activated, the icon glows green in the toolbar. | In the DVI Map, DVI Mapping settings cannot be copied like DVI fixtures. Please switch back to the Voxel Map. |
**B]** Enabled: If a DVI fixture is copied, the DVI Mapping includes the same settings as the DVI Mapping of the source or the settings plus a corresponding offset.

If activated, the icon glows green in the toolbar.

<table>
<thead>
<tr>
<th>Restore the default DVI Mapping settings of selected DVI fixtures by choosing <strong>Edit &gt; Restore DVI Mapping Defaults For Selection</strong> [Keyboard shortcut: <strong>Ctrl+R</strong>]. If clicked, the icon shortly flashes green in the toolbar.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restore the default DVI Mapping settings of selected DVI fixtures by choosing <strong>Edit &gt; Restore DVI Mapping Defaults For Selection</strong> [Keyboard shortcut: <strong>Ctrl+R</strong>]. If clicked, the icon shortly flashes green in the toolbar.</td>
</tr>
</tbody>
</table>
### Interaction And Settings

- The DVI Mapping of DVI fixtures can be used and interacted with in the Patch Editor just as any other fixture. In other words, it can be positioned with the mouse or keyboard, for example.

  Learn more »[Patch Editor](#)

- You may also edit the DVI Mapping settings directly.
  - Make sure view mode **DVI Map** is active.
  - Select the DVI Mapping of a DVI fixture and go to the section **DVI Mapping** to the right.
  - You may change the **Flipping**, **Rotation**, or **Position X**, **Position Y**, **Position Z**.
  - You can also add or subtract an **Offset** for each of these items.
  - Always confirm with **OK**

  Learn more »[Patch Editor](#)

- At the same time, the section **Fixture Properties / Value** shows all necessary information for the DVI Mapping.

### Important Information

- When working in 2D, make sure to position your DVI fixtures and their DVI Mapping always on the first Z-level. That means **Position Z** must be 1!

  Learn more »[Patch Editor](#)
DVI Map Mode For The External DVI Outputs

- DVI Map Mode is automatically activated for a DVI output if you have configured a DVI Map in the Patch Editor.

- The external DVI outputs offer a number of additional configuration settings. Make sure to configure everything as needed!

Learn more » DVI
Example

How To Configure Two Rotated EUROLITE LSD 37.5

Normal Setup

The normal setup of two EUROLITE LSD 37.5 fixtures looks like this [schematic):

![Schematic of normal setup]

Sample Setup

In this example, we will configure the two fixtures to be installed like this [schematic; without space):

![Schematic of sample setup]

Step 1] Adding DVI Fixtures

1] Create a new Patch. Go to the menu File > New Patch [Keyboard shortcut: Ctrl+N].

2] Add the two fixtures. Go to the menu Edit > Add Fixtures... [Keyboard shortcut: Ins]. Make sure not to select Merge Fixtures

Use the settings as shown in the screenshot:
3] The Patch will look like this:
4] We need to rotate both fixtures to match the LED installation. The left fixture is rotated by 90°. The right fixture is rotated by 270°.

[If you receive an error message about the fixtures being out of range, move your fixture towards a free location on your workspace. Then, rotate them and move them back.]

Step 2] DVI Map

5] Switch to the DVI Map. Select View > DVI Map

[Keyboard shortcut: F6]
Step 3] DVI Mapping

6] Deactivate Link

7] Select the first DVI fixture with its DVI Mapping and position it in the center of your workspace. In the section DVI Mapping, change Rotation to Original and click OK

8] Select the second DVI fixture with its DVI Mapping and position it in the center of your workspace. In the section DVI Mapping, change Rotation to Original and click OK

10] Switch back to the Voxel Map. Select View > Voxel Map [Keyboard shortcut: F5].

Step 4] Matrix Settings


Step 5] Result
Your final Patch should look like this:

![Patch Editor](image)

The DVI fixtures and therefore the 3 Previews will represent your LED installation:

- It was necessary to configure the DVI Mapping of the fixtures separately because the DVI hardware controller expects to receive the input signal like this [also shown above in the Normal Setup].
- The EUROLITE LSD 37.5 works with the EuroLite T9 protocol. No screen-capturing is needed and therefore the external DVI output window is not needed for this example.
Tips

- Make sure that DVI Mapping and DVI fixtures are not linked in the DVI Map [Disable Link mode].
- If you receive an error message about the fixtures being out of range, then move your fixture towards a free location on your workspace.

Further Tips

Please make sure to save your MADRIX Setup file after the configuration process.

You may also save and/or export the Patch as a separate file [of the file type *.mpz or *.mpx].
4.2.4 CSV Fixture List Import

This topic includes:
- Introduction
- Examples
- Data Requirements
- Step-By-Step Instructions
- Importing Several Fixture Lists
- Troubleshooting

Introduction

Depending on your lighting design, you may wish to control very complex LED layouts. You may also have already created your design in a separate software tool.

The widely used CSV file format can be imported into the Patch Editor of the MADRIX Software. It will quickly generate complex patch layouts based on data of third-party software, such as visualizers, consoles, CAD software, other lighting design tools, or even manually.

CSV is an acronym and stands for comma-separated values. This is a very general file format that makes it easy to record, save, and exchange structured data.

It is widely available in other software tools for data import and export. This also means that data which is not yet available in this format can usually be converted into CSV or can even be created manually/semi-automatically.

The CSV Fixture List Import is a feature that is part of the MADRIX Patch Editor. Learn more »Patch Editor

Examples

The CSV Fixture List Import makes it possible to very quickly create complex layouts, such as the following examples.
Data Requirements
CSV files are usually text files with tabularly structured data. Since CSV is a very general file format, the data can be structured in many different ways. The MADRIX Software is extremely flexible and has a variety of options during the import process in order to be able to process as many different CSV files as possible.

The MADRIX Software expects a file in the following format:

- Files should be UTF-8 encoded. [In order to not misinterpret special characters.]
- A Unicode Byte Order Mark [BOM] can be included but will be skipped automatically.
- Each line will be interpreted as data set, except for the following rules:
  - Any line can be used as header line [optional].
  - Empty lines or invalid lines can be included but will be skipped automatically.
- Each data set includes data fields that are separated
- Each data field, except the last data field of a line, ends with a single, special characters, i.e. field separators.
- Text that should be processed can be included in a pair of special characters, i.e. text delimiters.
- If text delimiters are used, only whitespace [spaces, tabulators] is allowed outside of those delimiters, which then is automatically ignored.
- If text delimiters are used, no additional text can be outside of those delimiters.
- Should field separators and text delimiters be interpreted as valid data, they need to be included within text delimiters themselves.
- Field separators and text delimiters should be the same for all data sets throughout the whole file.
- All data sets should have the same amount of data fields. Otherwise they will be filled up with empty data fields automatically.

**Step-By-Step Instructions**

To import a list of fixtures into the Patch Editor, follow these steps:

0] Export your lighting design as CSV file.

1] Open the Patch Editor.

2] Start the CSV import process.
3] Define CSV Import Settings.

4] Define Fixture List Import Settings and end the CSV import process.

5] Set up the final Patch.

0] Export Your CSV File

- Export your fixture list in the CSV file format from your visualizer, console, CAD software, other lighting design tool, or create it manually.
  [Alternatively, export your data from your software tool in the native file format that is possible and then convert it to CSV with the help of a spreadsheet program, for example.]

1] Open The Patch Editor

- Go to the menu Preferences > Patch Editor...
  [Keyboard shortcut: F3]
- A new window will open.

2] Start The CSV Import Process

- In the Patch Editor, go to File > Import Fixture List...
A new window will open. Select your CSV file in the File dialog and confirm with **Open**

2] **Define CSV Import Settings**

The main import process has two separate steps. This is the first step.
Syntax Settings

Set up the Syntax Settings according to all of the parameters below. Double-check by using the Data Preview.

Use the Data Preview to see how the data will be processed. If not configured correctly, your data will not be imported in a way that makes sense. The data should be structured and previewed in a useful way. For example, fixture names should be identifiable as such and fixture positions should be only sensible numbers instead of text. [Please see the next screenshot below.]
**Use Header Line** - Defines if the CSV file has a descriptive first line that provides a definite name for each data set and column. Activate this option if there is a header line. Set up the line number where this header line is located. The default value is 1.

[Otherwise the text provided in this line would be seen as usable data and errors would occur during the import process. If activated, the header line will be automatically excluded from the data sets.]

**Line From To** - Defines all the lines that the MADRIX Software imports as data sets. Therefore, you can define a range of line numbers in order to include or exclude specific lines. The default values range from 1 to the maximum line number that can be found in the file.

[If a header line is used, it will be excluded automatically.]

**Field Separator** - Defines how data sets are separated within the CSV file. Data can be structured using specific characters. The default value is Comma.
- **None** - There is no character used to separate the data fields.
- **Space** - A single space [ ] separates the data fields.
- **Tabulator** - Uses a tabulator [ tab ] for the separation.
- **Comma** - A comma [ , ] separates the data fields.
- **Semicolon** - A semicolon [ ; ] separates the data fields.
- **Period** - A period [ . ] separates the data fields.
- **Colon** - A colon [ : ] separates the data fields.
- **Underscore** - An underscore [ _ ] separates the data fields.
- **Hyphen** - A hyphen [ - ] separates the data fields.
- **Pipe** - A pipe [ | ] separates the data fields.
- **Custom Character...** - Allows you to define the field separator individually if it cannot be selected via the options above. Define the custom character by entering it via the keyboard and confirm with **OK**

**Text Delimiter** - Allows you to define how text is marked in the data fields.
- **None** - There is no character to mark text.
- **Single Quote** - A single quote [''] marks text.
- **Double Quote** - A double quote ["" ] marks text.
- **Custom Character...** - Allows you to define the field separator individually if it cannot be selected via the options above. Define the custom character by entering it via the keyboard and confirm with **OK**

**Trim Whitespace** - Defines if the software should automatically remove spaces, tabulators, and other whitespace characters that might be unnecessarily included in the data fields. Data sets, which are already clean or cleaned up in this way, are required in order to be able to process them without issues.

---

**Data Preview**
The Data Preview shows a preview of how the software will process the data sets that are included in the CSV file.

- Since you might want to import a very high number of data sets, only the first four lines are shown as well as the last four lines.
- By default, the line numbers are shown in addition to the various columns [A to Z].
- If Use Header Line is activated, the descriptions provided by the header line will be automatically used as column titles.
- If Line From To is customized to exclude certain lines, the data preview will reflect that.
- **Total Line Count** - Shows the overall number of lines that is found in the CSV file.
- **Excluded Line Count** - Shows how many lines are not included in the import process according to the Syntax Settings [such as the header line, for example].
- **Valid Data Set Count** - Shows how many data sets will be imported according to the Syntax Settings.
- **Blank Line Count (Skipped)** - Shows how many blank lines are skipped in the process [lines that do not contain any valid data sets].
- **Invalid Line Count (Skipped)** - Shows how many lines are seen as invalid and are therefore skipped and not included in the process [lines that contain invalid data sets].
- Follow the advice of the error messages if they appear at the bottom.

If you know that your CSV file should not have any blank or invalid lines, or that it should have more valid data sets, you should double-check your software data export and the final CSV file. [A text editor or spreadsheet program might also help to manually make any required adjustments in that case.]
The following screenshot is a sample how such Data Preview could look like:

If your Data Preview shows sensible and useful data, continue with a click on Next.

4] Define Fixture List Import Settings

The main import process has two separate steps. This is the second step.
Fixture Settings Assignment

Now, assign your imported data sets to the corresponding settings in the MADRIX Software.

- **Left Mouse Double-Click** - Perform a double-click with your left mouse button on the corresponding column in the line *Assignment* and change *None* to one of the following fixture settings.

  [If you defined a header line in the first step, the columns are now appropriately named according to the CSV contents. This helps assigning the fixture settings in this step. Otherwise, the columns are named A to Z.]
You can assign the following fixture settings:

- **Product** - Assigns this column to a fixture/product. According to all the different products that are found, you can assign fixture profiles below by using **Product Settings**
- **Product 2** - Is available if the complete product name is split into several parts/data fields.
- **Product 3** - Is available if the complete product name is split into several parts/data fields.
- **Display Name** - Assigns this column to the [short] name for fixtures used in the Fixture Editor and ultimately in the Patch Editor.
- **Fixture ID** - Assigns this column to the Fixture ID that is used in the Patch Editor as a unique identifier for each fixture.
- **Position X** - Assigns this column to the horizontal position of fixtures. It is assumed that fixture are included in the CSV data with their middle position.
- **Position Y** - Assigns this column to the vertical position of fixtures. It is assumed that fixture are included in the CSV data with their middle position.
- **Position Z** - Assigns this column to the depth position of the fixture. It is assumed that fixture are included in the CSV data with their middle position. [For a 2D patch, this value is 1 and will even be assigned automatically if this column is not assigned.]
- **Rotation Z** - Assigns this column to the rotation of the fixture around the Z-axis.
- **DMX Address** - Assigns this column to both, the DMX universe and the DMX channel. This means that the column needs to include the data for both of those fixture settings. [If assigned, DMX Universe as well as DMX Channel are not available separately anymore.]
**DMX Universe** - Assigns this column to the DMX universe of fixtures. [If assigned, DMX Address is not available anymore.]

**DMX Channel** - Assigns this column to the DMX start channel of fixtures. [If assigned, DMX Address is not available anymore.]

**You need to assign at least Product**

Aside from Product, all other settings are optional. The more settings you can assign, the more data can be used in the MADRIX Software.

Each fixture setting can only be assigned once.

It is not necessary to assign fixture settings to all columns/data fields that are found in the file.

If you do not assign all of the fixture settings above, those will be ignored and default values will be generated automatically for the corresponding settings for each fixture.

- If Position X is not assigned, all fixtures will be placed at position X = 1, which is the left border of the Patch.
- If Position Y is not assigned, all fixtures will be placed at position Y = 1, which is the top border of the Patch.
- If Position Z is not assigned, all fixtures will be placed at position Z = 1, which is the front border of the Patch.
- If Rotation Z is not assigned, they will be placed in the original rotation according to the MADRIX Fixture Library.
- If DMX Address, DMX Universe, or DMX Channel are not assigned, fixtures will be addressed automatically in ascending order.
- If only DMX Universe is assigned, the DMX channel will be set to 1.
- If only DMX Channel is assigned, the DMX universe will be set to 1.
- If Display Name is not assigned, fixtures will be named based on a combination of the fixture profile and the fixture ID.

It is assumed that the fixture IDs provided in the CSV file are decimal numbers and unique. If Fixture ID is not assigned, fixtures will be numbered in ascending order automatically.

The following screenshot is a sample how such Fixture Settings Assignment could look like, including making use of a header line:

![Fixture Settings Assignment](image-url)
Product Settings

- Becomes only available when a Product has been assigned in the Fixture Settings Assignment.
- When Product has been assigned in the Fixture Settings Assignment, you need to further specify the correct product and fixture profile from the MADRIX Fixture Library.
- You need to assign the correct fixture profile to the products found in the data sets.
- Each different product that was found in the data sets will be listed separately.
- You can individually assign a fixture profile to each product that was found.
- At least one product needs to be assigned.
- You do not have to assign a product to all of the Source Products. Unassigned products will be ignored automatically.

Left Mouse Double-Click - Perform a double-click with your left mouse button on the column Assigned Products > None

- A new window will open.

- Protocol - Choose the general fixture protocol.
  - DMX - Makes all DMX-based fixture profiles available as Product
  - DVI - Makes all DVI-based fixture profiles available as Product
The software provides several settings for the fixture profiles:

- **Product** - Choose the corresponding fixture profile from the MADRIX Fixture Library.
  
  [This is the product selection known from the Matrix Generator and Patch Editor.]

- **Rotation** - Choose the corresponding fixture rotation. The fixture preview to the right will help you assess the correct rotation.

---

### Position Settings

The CSV import process proves extremely useful when you can assign the fixture settings Position X, Position Y, and Position Z. Depending on your imported data sets, you may want to adjust the settings further regarding the position of fixtures.

- **Becomes only available when** Position X, Position Y, and/or Position Z have been assigned respectively in the **Fixture Settings Assignment**

- **It is assumed that the fixture positions provided in the CSV file represent the center of the fixture.**

- **Scale X / Y / Z** - Changes the total dimensions in X, Y, and Z by proportionally increasing or decreasing the horizontal, vertical, and depth aspects with the help of a multiplicative factor. **Note:** The overall Matrix Size of the Patch affects the performance!
  
  [By default, the distances are applied according to the scale and in the units of the CSV data. These might fundamentally differ from the MADRIX Software: E.g. meters or pixel pitch compared to pixels in MADRIX.]

- **Start Position X / Y / Z** - Defines an offset for the position of fixtures instead of always starting at 1 / 1 / 1.
  
  [By default, the software automatically crops/removes any empty spaces the data sets might produce regarding the start position. This means that the start position of the first fixture is set to 1 / 1 / 1 in order to reduce the Matrix Size. If you need to set your fixtures to a certain area, use this setting to enter the appropriate offset.]

---

### Rotation Settings

The rotation of fixtures in the CSV data sets might be different to the rotation of the corresponding fixture profiles of the MADRIX Fixture Library.

- **Becomes only available when** Rotation Z has been assigned in the **Fixture Settings Assignment**

- **It is assumed that the fixture rotations provided in the CSV file are provided in degrees.**
Free angles can be included but will be rounded up to the next available quarter rotation [0°, 90°, 180°, 270°].

- **Direction** - Allows you to define the general direction of the rotation.
  - **Clockwise** - Defines the rotation according to the direction of the clock.
  - **Counterclockwise** - Defines the rotation as the opposite of the normal clock rotation.

- **Offset** - Allows you to add [in case of clockwise rotation] or subtract [in case of counterclockwise rotation] from the rotation value set in the data sets.
  - **Original** - Leaves the rotation as defined in the data sets.
  - **90°** - Offsets the rotation value by 90 degrees.
  - **180°** - Offsets the rotation value by 180 degrees.
  - **270°** - Offsets the rotation value by 270 degrees.

### DMX Address Settings

The DMX addresses of the CSV data sets might be managed differently than the settings of the MADRIX Software.

- Becomes only available when **DMX Address**, **DMX Universe**, and/or **DMX Channel** have been assigned respectively in the **Fixture Settings Assignment**
- It is assumed that the DMX addresses provided in the CSV file are provided as decimal numbers.
- **Field Separator** - Is only available when DMX Address has been assigned in the Fixture Settings Assignment. Defines the way DMX universe and DMX channel are combined as a single DMX address.
  - **Space** - A single space [ ] separates universe and channel.
  - **Tabulator** - Uses a tabulator [ tab ] for the separation.
  - **Comma** - A comma [ , ] separates universe and channel.
  - **Semicolon** - A semicolon [ ; ] separates universe and channel.
  - **Period** - A period [ . ] separates universe and channel.
  - **Colon** - A colon [ : ] separates universe and channel.
  - **Underscore** - An underscore [ _ ] separates universe and channel.
  - **Hyphen** - A hyphen [ - ] separates universe and channel.
  - **Pipe** - A pipe [ | ] separates universe and channel.
  - **Custom Character...** - Allows you to define the field separator individually if it cannot be selected via the options above. Define the custom character by entering it via the keyboard and confirm with **OK**
- **Index** - Defines how the DMX addressing starts in the CSV data sets regarding DMX universe as well as DMX channel.
  - **0-Based** - DMX addressing starts with value 0 and ranges from 0 to 255.
  - **1-Based** - DMX addressing starts with value 1 and ranged from 1 to 256.
Import Preview

While configuring all options in the Fixture List Import Settings dialog, the Import Preview shows a preview of the overall properties that will be set after the import process has been finished.

- **DMX Fixture Count** - Shows the total number of DMX fixtures that will be imported.
- **DVI Fixture Count** - Shows the total number of DVI fixtures that will be imported.
- **Fixture IDs** - Shows the range of unique identifiers that will be imported [or generated automatically by the software if not assigned in the Fixture Settings Assignment].
- **Map Area X** - Shows the range of positions where which fixtures will be patched and located in X as well as the total size of that area in brackets.
- **Map Area Y** - Shows the range of positions where which fixtures will be patched and located in Y as well as the total size of that area in brackets.
- **Map Area Z** - Shows the range of positions where which fixtures will be patched and located in Z as well as the total size of that area in brackets.
- **DMX Universes** - Shows the range of DMX universes that will be imported [or generated automatically by the software if not assigned in the Fixture Settings Assignment].
- **DMX Channels** - Shows the range of DMX channels that will be imported [or generated automatically by the software if not assigned in the Fixture Settings Assignment].

Message And Errors

The software will show various messages and errors below the Import Preview to guide you through the process.

- Red Exclamation Mark - Shows errors that you will have to fix. Otherwise, the import process cannot be finalized.
- Grey Exclamation Mark - Shows messages that hold valuable information for you. Please decide to adjust the settings accordingly or choose to leave the settings as they are and regard this message only as information.

End The CSV Data Import
Since the Fixture List Import Settings dialog is the second step of the main import process, the main import process will end after this step.

Double-check and confirm all of your settings via the Import Preview before ending the process!

- **OK** - Imports the configured data into the Patch Editor.

**5] Set Up The Final Patch**

After the import process, the final Patch is not yet finished since just now you have imported a large list of fixtures, but not created a Patch for the MADRIX Software yet.

- Double-check all imported fixtures. Repeat the CSV Fixture List Import process and modify your data or import settings if you are not satisfied with the result, or do any required changes manually in the Patch Editor [»Patch Editor].

- After you have set up and configured all of your fixtures, it is important to define the Matrix Settings.

  - Click **Matrix Settings**
    [menu Edit > Matrix Settings...]

  - A new window will open.

![Matrix Settings Window]
The virtual LED matrix represents your LED fixtures. Therefore, it is the area on which the MADRIX Effects are rendered and displayed, and ultimately sent to your output. MADRIX needs to know in pixels/voxels how large your LED project is in total.

Set up the Matrix Settings manually or use the semi-automatic options: according to all of these parameters:

- **Match Voxel Map Area** - Automatically defines the total size of the virtual LED matrix in X, Y, and Z according to the placed fixtures.
- **Match Color Depth** - Automatically defines the number of color channels your LED fixtures use according to the placed fixtures.
- Confirm with OK
- Close the Patch Editor when you have finished the configuration.

### Importing Several Fixture Lists

If you wish to import several, different CSV files, i.e. several fixture lists, follow these steps:

- Import the first CSV file/fixture list.
- Save the Patch as a separate file via **Patch Editor > File > Save Patch As**...
- Import the second CSV file/fixture list.
- Save the second Patch as a separate file via **Patch Editor > File > Save Patch As**...
- Repeat the process for all the different fixture lists.
- In the Patch Editor, use **File > Merge Patches**... in order to combine all separately saved Patch files.

Learn more » [Merging Patches](#)

### Troubleshooting
If you are encountering problems, please work through the following checklist:

- **The assignment of 'Product' is required! Please change the Fixture Settings Assignment.**
  If you see this message, you need to assign the fixture setting Product in the section Fixture Settings Assignment.

- **The assignment of one or more products is required. Please change the settings.**
  If you see this message, you need to assign the correct fixture profile to the products found in the data sets in the section Product Settings.

- If you want to undo a Fixture Settings Assignment or assign a setting to a different column, set the incorrect column to *None* again and assign the fixture settings to the correct column instead.

- If you are not satisfied with the results, please double-check:
  - Your software data export from your third-party software, such as visualizers, consoles, CAD software, other lighting design tools, or other software for data export.
  - The CSV file
  - The CSV Import Settings [step one of the main import process]
  - The Fixture List Import Settings [step two of the main import process]

- Or modify the data sets manually [a text editor or spreadsheet program might help in this case]

- Check any messages or errors of the CSV Import Settings [step one of the main import process] or Fixture List Import Settings [step two of the main import process] and act accordingly by fixing the error and evaluating if the settings a message refers to need to be modified or can remain unchanged.

- Instead of assigned all fixture settings that are provided in the CSV file, you may choose not to assign certain settings and let the MADRIX Software use or generate default values instead.
4.2.5 Merging Patches

This topic includes:
- Introduction
- Overview
- Step-By-Step Instructions

Introduction

Merging several Patches into a single Patch is a feature and part of the MADRIX Patch Editor. Learn more »Patch Editor

Overview

While the Patch Editor can only load and activate 1 Patch at a time, it allows you to merge Patches together. That means you can combine separate Patch files into one Patch file.

- The Patch Editor allows you to merge 2 Patches in one procedure.
- By repeating the procedure, you can merge more than 2 Patches.

Merging several Patches can be useful, for example, when:

- Working on a large LED installation and first creating and testing the Patch for each section separately.
- Having different team members create different parts of an overall Patch.
- Wanting to join two separate LED projects into one larger project later.
Step-By-Step Instructions

1] Create Your Patches

- In order to merge two Patches, the different Patches need to be ready and available first.
- Make sure to have all Patch files saved and available in one location, such as the hard drive of your computer.

![Patch 1 Example](image1.png) ![Patch 2 Example](image2.png)

2] Load Patch 1

- Load Patch 1 in the Patch Editor [menu Preferences > Patch Editor... > File > Open Patch...].
- Or load Patch 1 as part of a MADRIX Setup [menu File > Open Setup...].

3] Activate The Merge Patches Feature

- Go to the menu Preferences > Patch Editor... > File > Merge Patches...
- Select Patch 2 from its stored location, such as the hard drive of your computer.
- A new window will open.
The Merge Patches windows provides information about Patch 1 and Patch 2 and it requires you to adjust several settings in order that both Patches are merged according to your requirements.

See the following table for more information:

### General Information

<table>
<thead>
<tr>
<th>Properties</th>
<th>Patch 1</th>
<th>Patch 2</th>
<th>Merged Patch</th>
</tr>
</thead>
<tbody>
<tr>
<td>DMX Fixture Count</td>
<td>2500</td>
<td>2500</td>
<td>5000</td>
</tr>
<tr>
<td>DVI Fixture Count</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Fixture Group Count</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

### Merge Settings

Please change the values for Adjusted Patch 2 and Merged Patch according to your requirements:

<table>
<thead>
<tr>
<th>Properties</th>
<th>Patch 1</th>
<th>Patch 2</th>
<th>Adjusted Patch 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixture IDs</td>
<td>1-2590</td>
<td>1-2500</td>
<td>2561-5000</td>
</tr>
<tr>
<td>Fixture Group IDs</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>Map Area X</td>
<td>1-50 (50 px)</td>
<td>1-50 (50 px)</td>
<td>1-50 (50 px)</td>
</tr>
<tr>
<td>Map Area Y</td>
<td>1-50 (50 px)</td>
<td>1-50 (50 px)</td>
<td>1-50 (50 px)</td>
</tr>
<tr>
<td>Map Area Z</td>
<td>1 (1 px)</td>
<td>1 (1 px)</td>
<td>1 (1 px)</td>
</tr>
<tr>
<td>DMX Universes</td>
<td>1-15</td>
<td>1-15</td>
<td>1-15</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Properties</th>
<th>Patch 1</th>
<th>Patch 2</th>
<th>Merged Patch</th>
</tr>
</thead>
<tbody>
<tr>
<td>Matrix Size X</td>
<td>50 px</td>
<td>50 px</td>
<td>50 px</td>
</tr>
<tr>
<td>Matrix Size Y</td>
<td>30 px</td>
<td>30 px</td>
<td>30 px</td>
</tr>
<tr>
<td>Matrix Size Z</td>
<td>1 px</td>
<td>1 px</td>
<td>1 px</td>
</tr>
<tr>
<td>Color Depth</td>
<td>3</td>
<td>3</td>
<td>3</td>
</tr>
</tbody>
</table>
### Properties

<table>
<thead>
<tr>
<th></th>
<th>Patch 1</th>
<th>Patch 2</th>
<th>Merged Patch</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>DMX Fixture Count</strong></td>
<td>Shows the total number of DMX fixtures included in Patch 1.</td>
<td>Shows the total number of DMX fixtures included in Patch 2.</td>
<td>Shows the total number of DMX fixtures that will be included when the Patches are merged into one Patch.</td>
</tr>
<tr>
<td><strong>DVI Fixture Count</strong></td>
<td>Shows the total number of DVI fixtures included in Patch 1.</td>
<td>Shows the total number of DVI fixtures included in Patch 2.</td>
<td>Shows the total number of DVI fixtures that will be included when the Patches are merged into one Patch.</td>
</tr>
<tr>
<td><strong>Fixture Group Count</strong></td>
<td>Shows the total number of fixture groups in Patch 1.</td>
<td>Shows the total number of fixture groups in Patch 2.</td>
<td>Shows the total number of fixture groups that will be included when the Patches are merged into one Patch.</td>
</tr>
</tbody>
</table>

### Merge Settings

<table>
<thead>
<tr>
<th></th>
<th>Patch 1</th>
<th>Patch 2</th>
<th>Adjusted Patch 2</th>
</tr>
</thead>
</table>
| **Fixture IDs**     | Shows the unique identifiers for fixtures included in Patch 1.         | Shows the unique identifiers for fixtures included in Patch 2.         | - Since all Fixture IDs need to be unique, the settings for Patch 2 need to be adjusted here.  
- Adjust this setting as needed.  
- MADRIX will automatically provide a sensible suggestion for you [Space - Restores this automatic value].  
- Please enter the first Fixture ID and MADRIX will automatically set up the range of values. |
### Fixture Group IDs

| Shows the unique identifiers for fixture groups included in Patch 1. | Shows the unique identifiers for fixture groups included in Patch 2. | - Since all Fixture Group IDs need to be unique, the settings for Patch 2 need to be adjusted here.  
  - Adjust this setting as needed.  
  - **Left Mouse Double-Click** - Allows the value to be edited.  
  - **Enter** - Applies the edited values.  
  - MADRIX will automatically provide a sensible suggestion for you [**Space** - Restores this automatic value].  
  - Please enter the first Fixture Group ID and MADRIX will automatically set up the range of values. |

### Map Area X

| Shows where fixtures are mapped in Patch 1 along the X-axis (e.g., position 1 - 50) and how many pixels are mapped in X in total (e.g., 50 px). | Shows where fixtures are mapped in Patch 2 along the X-axis (e.g., position 1 - 50) and how many pixels are mapped in X in total (e.g., 50 px). | - Defines the adjusted position of Patch 2 in X.  
  - Allows you to position Patch 2 to the left, to the right, or overlapped on top of Patch 1.  
  - Adjust this setting as needed.  
  - **Left Mouse Double-Click** - Allows the value to be edited.  
  - **Enter** - Applies the edited values.  
  - Please enter the first position in X and MADRIX will automatically set up the value range. |
| **Map Area Y** | Shows where fixtures are mapped in Patch 1 along the Y-axis (e.g., position 1 - 50) and how many pixels are mapped in Y in total (e.g., 50 px). | Shows where fixtures are mapped in Patch 2 along the Y-axis (e.g., position 1 - 50) and how many pixels are mapped in Y in total (e.g., 50 px). | - Defines the adjusted position of Patch 2 in Y.  
- Allows you to position Patch 2 above, below, or overlapped on top of Patch 1.  
- Adjust this setting as needed.  
[Left Mouse Double-Click] - Allows the value to be edited.  
[Enter] - Applies the edited values.  
- Please enter the first position in Y and MADRIX will automatically set up the value range. |
| **Map Area Z** | Shows where fixtures are mapped in Patch 1 along the Z-axis (e.g., position 1) and how many pixels are mapped in Z in total (e.g., 1 px). | Shows where fixtures are mapped in Patch 2 along the Z-axis (e.g., position 1) and how many pixels are mapped in Z in total (e.g., 1 px). | - Defines the adjusted position of Patch 2 in Z.  
- Allows you to position Patch 2 in front, behind, or overlapped on top of Patch 1.  
- Adjust this setting as needed.  
[Left Mouse Double-Click] - Allows the value to be edited.  
[Enter] - Applies the edited values.  
- Please enter the first position in Z and MADRIX will automatically set up the value range. |
| **DMX Universes** | Shows which DMX universes are used in Patch 1. | Shows which DMX universes are used in Patch 2. | - Defines the adjusted DMX universes for Patch 2.  
- Allows you to re-address your fixtures.  
- Adjust this setting as needed.  
[Left Mouse Double-Click] - Allows the value to be edited.  
[Enter] - Applies the edited values.  
- Please enter the first DMX universe and MADRIX will automatically set up the value range. |
<table>
<thead>
<tr>
<th>Properties</th>
<th>Patch 1</th>
<th>Patch 2</th>
<th>Merged Patch</th>
</tr>
</thead>
</table>
| **Matrix Size X** | Shows the total number of DMX fixtures included in Patch 1. | Shows the total number of DMX fixtures included in Patch 2. | - Defines the Matrix Size in X that will be set when the Patches are merged into one Patch.  
- Adjust this setting as needed.  
[ **Left Mouse Double-Click** - Allows the value to be edited.  **Enter** - Applies the edited values. ]  
- MADRIX will automatically provide the maximum value as a suggestion for you [  
**Space** - Restores this automatic value].  
- Make sure that all fixtures from Patch 1 and Patch 2 will be included in the final Matrix Size. |
| **Matrix Size Y** | Shows the total number of DVI fixtures included in Patch 1. | Shows the total number of DVI fixtures included in Patch 2. | - Defines the Matrix Size in Y that will be set when the Patches are merged into one Patch.  
- Adjust this setting as needed.  
[ **Left Mouse Double-Click** - Allows the value to be edited.  **Enter** - Applies the edited values. ]  
- MADRIX will automatically provide the maximum value as a suggestion for you [  
**Space** - Restores this automatic value].  
- Make sure that all fixtures from Patch 1 and Patch 2 will be included in the final Matrix Size. |
| **Matrix Size Z** | Shows the total number of fixture groups in Patch 1. | Shows the total number of fixture groups in Patch 2. | - Defines the Matrix Size in Z that will be set when the Patches are merged into one Patch.  
  - Adjust this setting as needed.  
  [Left Mouse Double-Click] - Allows the value to be edited.  
  [Enter] - Applies the edited values.  
  - MADRIX will automatically provide the maximum value as a suggestion for you [Space] - Restores this automatic value.  
  - Make sure that all fixtures from Patch 1 and Patch 2 will be included in the final Matrix Size. |
|-------------------|---------------------------------------------------|---------------------------------------------------|--------------------------------------------------|
| **Color Depth**   | Shows the maximum color depth as defined in Patch 1. | Shows the maximum color depth as defined in Patch 2. | - Defines the color depth that will be set when the Patches are merged into one Patch.  
  - Adjust this setting as needed.  
  [Left Mouse Double-Click] - Allows the value to be edited.  
  [Enter] - Applies the edited values.  
  - MADRIX will automatically provide the maximum value as a suggestion for you [Space] - Restores this automatic value.  
  - Make sure to use the maximum color depth from Patch 1 and Patch 2 in order to allow for all possible fixtures. |

- Please set up all settings of the column **Adjusted Patch 2** as required and confirm with **OK**
- You can abort the process at any time with **Cancel**

5] **Result**
As a result of the Merge Patches procedure, you will now have created 1 Patch out of 2 Patches.

- **Overlapping** will be activated in the Patch Editor automatically if needed.
- The **Workspace** of the Patch Editor will be extended automatically if needed.
- All imported fixtures of Patch 2 will be automatically selected for you after the procedure.
- You can use **Undo** or **Redo** to rewind the procedure or apply it again after a rewinding.
- Make sure to save your Patch or MADRIX Setup afterwards!

 Merge Settings Result Example

![Merge Settings Result Example](image)

Merged Patch Result Example

![Merged Patch Result Example](image)
4.2.6 Background Image

This topic includes:
- Introduction
- Overview
- Settings

Introduction

In order to help you with the placement of fixtures for your Patch, you may load a background image. As such, this is a feature of the MADRIX Patch Editor. Learn more »Patch Editor

Overview

While the Patch Editor allows you to semi-automatically place fixtures according to your requirements, loading an image into its background can assist you with the manual placement of fixtures.

- Go to the menu Preferences > Patch Editor...
  [Keyboard shortcut: F3]
- A new window will open.
  In the Patch Editor, go to View > Background Image

- In the Patch Editor, choose to View > Voxel Map / DVI Map / DMX Map in order to close the Background Image View again.

Settings
Adjust the following settings according to your needs:

**Background Image Settings**

- **Enable** - Activates the usage of the background image. Deactivate it in order to hide the image again.
- **Image > Load** - Allows you to select the background image from your harddisk.
- **Image > Remove** - Removes the selected file again.
- **Position** - Defines the location of the image on the workspace of the Patch Editor in X and Y. Confirm with **Apply**
- **Keep Aspect Ratio** - Places the image using its original aspect ratio. Otherwise, the image can be scaled independently in X and Y. Confirm with **Apply**

- **Scale** - Allows you to scale the image and therefore adjust its size in X and Y. Scale Y is not available if Keep Aspect Ratio is activated. Confirm with **Apply**

- **Apply** - Always confirm any changes.

- **Reset** - Restores the last used values again.

### Using The Mouse

- **Left Mouse Click And Hold And Move** - Click with your left mouse button on the image, continue to hold, and move your mouse in order to position the image accordingly.

- **Right Mouse Click And Hold And Move** - Click with your right mouse button on the image, continue to hold, and move your mouse in order to scale the image.

### Example

![Example Image](image-url)
In the Patch Editor, choose to **View > Voxel Map / DVI Map / DMX Map** in order to close the Background Image View again.
4.3 Fixture Groups [Group Control]

This topic includes:
- Introduction
- Managing Fixture Groups
- Controlling Fixture Groups
- Using Fixture Groups As Map Settings Preset
- Calling Group Presets Using The Cue List

Introduction

Fixture groups allow you to organize fixtures that are included in your Patch in clusters and then to control them together as a group.

Note: Fixture groups are part of the Patch. Changing the Patch will likely result in changes to the Fixture Groups as well.

To work with fixture groups, follow these steps:

1] Manage your fixture groups.
2] Control your fixture groups.

Managing Fixture Groups

Overview

Fixture Groups are managed in the Patch Editor.

- Go to the menu Preferences > Patch Editor
  [Keyboard shortcut: F3]
Menu

Within the Patch Editor, a dedicated menu is available.

- Go to **Fixture Groups**

![Fixture Groups Menu](image)

Toolbar

All items from the menu shown above are also available for quick access in the toolbar of the Patch Editor.

![Toolbar](image)

Creating Fixture Groups

A] Creating An Empty Fixture Group

1] Go to **Fixture Groups > Create Empty Fixture Group**

[Toolbar: **Create**]

- Enter a **Display Name**
  - Choose a name that helps you easily identify the fixture group later.

- Set the **Display Color**
  - This color is useful to distinguish between fixture groups when controlling them in the Group Control. Learn more [Controlling Fixture Groups](#)

- Set the **Fixture Group ID**
  - The ID is a unique identifier for this specific fixture group.
  - Each fixture group must have a different ID!

  [The Fixture Group ID is different to the Display Name of the fixture group. Several fixture groups can have the same Display Name, but the ID must be different.]

- The new fixture group will be created. The fixture group will not yet include any fixtures.
  - [See the bottom left of the Patch Editor.]

### B] Creating A Fixture Group From Currently Selected Fixtures

1] First, select all the fixtures you wish to include in the fixture group.

Learn more [Patch Editor](#)

2] Go to **Fixture Groups > Create Fixture Group From Selected Fixtures**

  [Keyboard shortcut: **Ctrl+G**]
  - [Toolbar: **Create From Selection**]

- Enter a **Display Name**
  - Choose a name that helps you easily identify the fixture group later.

- Set the **Display Color**
  - This color is useful to distinguish between fixture groups when controlling them in the Group Control. Learn more [Controlling Fixture Groups](#).

- Set the **Fixture Group ID**
  - The ID is a unique identifier for this specific fixture group.
  - Each fixture group must have a different ID.
  [The Fixture Group ID is different to the Display Name of the fixture group. Several fixture groups can have the same Display Name, but the ID must be different.]

- The new fixture group will be created. All previously selected fixtures will already be assigned to the fixture group.
  [See the bottom left of the Patch Editor.]

### Working With The Fixture Group List

The Patch Editor will show your fixture groups in the bottom left. Use the following options to work with the list of fixture groups:

- **Expand List** - Shows the fixture groups including the fixtures that are assigned to the fixture groups.

- **Collapse List** - Shows only the fixture groups.

- **Expand Item** - Shows the fixture group and extends the list to show the fixtures assigned to this particular fixture group.
Assigning Fixtures To A Fixture Group

Follow these steps if you wish to assign fixtures to an empty fixture group or if you wish to add more fixture to a fixture group that already includes fixtures:

1] Select all fixtures you wish to assign to an existing fixture group.

2] Select the fixture group or multiple fixture groups in the fixture group list in the bottom left of the Patch Editor. Both, fixtures and fixture groups, will now be selected in the Patch Editor.
3] Go to  **Fixture Groups > Assign Selected Fixtures To Selected Fixture Groups**  
[Toolbar:  **Assign**]

- The Patch Editor will assign all selected fixtures to the selected fixture groups.

### Releasing A Fixture From A Fixture Group

Follow these steps if you want to revoke the assignment of a fixture from a single fixture group or multiple fixture groups:

1] Select all fixtures you wish to release.

2] Select the fixture group or multiple fixture groups in the fixture group list in the bottom left of the Patch Editor. Both, fixtures and fixture groups, will now be selected in the Patch Editor.

3] Go to  **Fixture Groups > Release Selected Fixtures From Selected Fixture Groups**  
[Toolbar:  **Release**]

- The Patch Editor will release all selected fixtures from all selected fixture groups.
Releasing A Fixture From A Fixture Group

Follow these steps if you want to revoke the assignment of a fixture from a single fixture group or multiple fixture groups:

1] Select all fixtures you wish to release.

2] Go to **Fixture Groups > Release Selected Fixtures From All Fixture Groups**

[Toolbar: *Release From All*]

- The Patch Editor will release all selected fixtures from all the fixture groups they are currently assigned to.

Removing Fixture Groups

Follow these steps if you want to remove fixture groups from the Patch:

1] Select all fixture groups you wish to remove.

2] Go to **Fixture Groups > Remove Selected Fixture Groups**

[Toolbar: *Remove*]
• The Patch Editor will remove all selected fixture groups from the Patch.

Fixture Group Settings

Overview

• Select a fixture group [to the left of the Patch Editor] in order to change its settings [to the right of the Patch Editor].

• You can also select multiple fixture groups in order to change their settings.
General Fixture Group Settings

- **Display Name** - Allows you to change the name for the fixture group. [Or use the default name provided by MADRIX.]

- **Display Color** - Allows you to change the individual color for the fixture group.
  - This color is useful to distinguish between fixture groups when controlling them in the Group Control view.
  - Learn more Controlling Fixture Groups

- **Fixture Group ID** - Defines the unique identifier for the selected fixture group.
Fixture Group Control Settings

- **Default Value** - Defines the standard value of a fixture group fader. This is important when launching the Group Control for the first time and when restoring the default values in the Group Control view.
  - Valid values range from 0 to 255 [0% to 100% intensity]. By default, the default is set to 255.

- **Minimum Value** - Defines the lowest value a fixture group can be set to.
  - Setting a fixture group fader to 0 will set the intensity to this Minimum Value.
  - Valid values range from 0 to 255 [0% to 100% intensity]. By default, the default is set to 0.

- **Maximum Value** - Defines the highest value a fixture group can be set to.
  - Setting a fixture group fader to 255 will set the intensity to this Maximum Value.
  - Valid values range from 0 to 255 [0% to 100% intensity]. By default, the default is set to 255.

- Learn more [Controlling Fixture Groups](#)

- **Apply** - Always confirm any changes with Apply.

- **Reset** - Allows you to discard changes before having confirmed any changes in order to use the values that were set up last.

Controlling Fixture Groups

Creating Fixture Groups

- **First, make sure to create fixture groups in the Patch Editor.**
  - Otherwise, the Group Control view will be empty and no fixture group can be controlled.
  - Learn more [Managing Fixture Groups](#)

Overview

Fixture groups are controlled in the Group Control view.
You can open the Group Control in 3 ways:

- Go to the menu **Tools > Group Control...**
- Press **F9**
- Or click **Layer Control > Group Control** on the user interface.

To close the Group Control and change back to the Programmer view:

- Go to **Tools > Group Control...**
- Press **F9**
- Or click **Group Control > Layer Control** on the user interface.

- The Group Control view will include a fader for each fixture group you have created.
- Each individual fader will be shown with the color you have set up as the fixture group’s **Display Color**
- Each individual fader will be shown with the label you have set up as the fixture group’s **Display Name**

## Controlling A Fixture Group

**Control**
• Use the fader of a fixture group to control its intensity.

Fixture Group Faders

• Each fader regulates the intensity of a single fixture group.
  - You can set the fader to a specific position.
  - You can enter a value in the input field.
  - You can flash the fader.

Important Information

• You will immediately see the changes in the Preview Output.
• When controlling fixture groups, your settings will be immediately applied and visible on the output/the LEDs!

Mouse Control And Keyboard Shortcuts

• Single Selection
  - A single fader regulates the intensity of a single fixture group.
  - Left Arrow / Right Arrow - Quickly switch between faders by using the left or right arrow key.

• Multiselection
  - Use Ctrl + Left Mouse Click to select multiple faders at the same time. A green outline will show that a fader is selected. When multiple faders are selected, you can control them at the same time.
  - Use Shift + Left Mouse Click to select multiple faders at the same time. A green outline will show that a fader is selected. When multiple faders are selected, you can control them at the same time.
  - Ctrl+A - Selects all faders of the Group Control.
  - Ctrl+D - Deselects the current fader selection.

• Flash
  - Use the button showing the fixture group's Display Name or the keyboard shortcut Space
  - It instantly sets the intensity to 255 as long as you hold the button/key down.
  - To use this feature, the fader needs to be set to a lower value than 255 first.
- **Restoring The Default Value**
  - **Left Mouse Double-Click** - Perform a double-click with your left mouse button directly on a single or multiple faders to restore the Default Value
  - **Right Mouse Click** - Perform a click with your right mouse button directly on a single or multiple faders to restore the Default Value

**Minimum Values And Maximum Values**

- A fixture group fader in the Group Control view always ranges from 0 to 255, independently of what Minimum Value or Maximum Value you have defined for the fixture group.

- Setting a fixture group fader to 0 will set the lowest intensity for this fixture group as defined by **Minimum Value**.
  - That means that a fader set to 0 will not necessarily set the intensity of the fixture group to 0. Instead, it will be set to the minimum value you defined.

- Setting a fixture group fader to 255 will set the highest intensity for this fixture group as defined by **Maximum Value**.
  - That means that a fader set to 255 will not necessarily set the intensity of the fixture group to 255. Instead, it will be set to the maximum value you defined.

**Restoring The Default Fixture Group Values**

Quickly reset any changes and set all fixture group faders to their default values in the Group Control view:

- Restores the default fixture group values for all fixture groups as defined by their Default Value

**Updating The Default Fixture Group Values**

Quickly update all default fixture group values using the Group Control view:
- Overwrites the **Default Value** as defined in the Patch Editor with the current fader position of the Group Control for each fixture group individually.

### Saving a Fixture Group Preset

1. Set each fixture group fader to its required position.

2. Enter a description for the Group Preset.

3. Click **Set**

   - Define the **Preset Number**
     - Your Group Preset will be saved there.
     - Valid values range from 1 to 256.
     - MADRIX will automatically suggest the next free Group Preset number [which is one number higher than the currently highest preset number].

5. MADRIX will save the currently set fader positions as a Group Preset.
   - Saved presets will be shown as blue on the left side of the Group Control view.
   - Empty Group Presets are deactivated and shown in gray.
Calling A Saved Group Preset

- **Left Click** - Calls a previously saved Group Preset. MADRIX will automatically fade according to the Fade-In Time.
  - Make sure to click on preset number shown in blue.
  - An activated Group Preset will be shown in green for a short while. This indicates that it has been activated.

- **Left Mouse Double-Click** - Calls a previously saved Group Preset and activate it immediately without using the Fade-In Time.
  - Make sure to click on preset number shown in blue.
  - An activated Group Preset will be shown in green for a short while. This indicates that it has been activated.

  - **Note**: MADRIX will not automatically overwrite a Group Preset!
    [When changing group values, you need to save the current values again as a Group Preset or overwrite an existing Group Preset if you want to store the new values.]

Fading Between Group Presets

  - **Fade-In Time** - Defines the duration of the automatic fade between fader positions [in s], when selecting a different Group Preset.
    - To change the time, select the value via left double-click first. Then, enter a value using the keyboard, use the mouse wheel, or use a left mouse click and hold while dragging the mouse up or down.
    - A value of 0 means that no fade-in is applied. Faders will be set immediately to their new positions [using a hard transation].

Group Preset Context Menu
- **Right Mouse Click** on a Group Preset number to quickly perform various actions.

  **Set** - Saves the current group values as Group Preset to this Group Preset number.

  **Open...** - Loads a previously saved MADRIX Group Preset file [of the file type *.mgpz or *.mgpx]. A new window opens for you to select the file on your harddisk.

  **Save...** - Stores a previously saved Group Preset as an external file [of the file type *.mgpz or *.mgpx]. A new window opens for you to select a location on your harddisk. Simply enter a name and click **Save**

  **Copy** - Copies a previously saved Group Preset into the clipboard as a duplicate.

  **Cut** - Copies a previously saved Group Preset into the clipboard and then applies a Clear

  **Paste** - Inserts a copy of a Group Preset from the clipboard into the currently focused Group Preset.

  **Clear** - Removes the currently focused Group Preset.

**Group Control Options**
• Click on the Group Control Options button to open a submenu.

Open... - Loads a previously saved MADRIX Group Control file [of the file type *.mgcz or *.mgcx]. A new window opens for you to select the file on your harddisk.

Save... - Saves the Group Control to an external file [of the file type *.mgcz or *.mgcx]. This includes all Group Presets and the Fade-In Time. A new window opens for you to select a location on your harddisk. Simply enter a name and click Save

Clear - Removes all Group Presets and restores the default Fade-In Time.

Chasing Group Values

Group Value Chaser - Allows you to chase group values.
- The Group Value Chaser will also be saved when saving a Group Preset.
- Learn more »Chaser

Drag And Drop [Copy/Cut/Paste]

Copy And Paste

• Left Mouse Click And 2 Sec. Hold - You can perform a Copy and Paste with the mouse.

  Use a left mouse click on a Group Preset and continue to hold for 2 seconds. A small + appears. Continue to hold and move your mouse to another Group Preset number. Release the mouse button to paste a copy onto the new Group Preset.

Cut And Paste
- **Left Mouse Click And 2 Sec. Hold + Shift** - You can perform a Cut and Paste with the mouse.
  Use a left mouse click on a Group Preset and continue to hold for 2 seconds. Press Shift in addition. A small rectangle appears. Continue to hold the buttons and keys and move your mouse to another Group Preset number. Release the mouse button to move the previously selected Group Preset to the new position.

**Drag And Drop**

- **File Drag And Drop** - You can select a MADRIX Group Preset file [of the file type *.mgpz or *.mgpx] in Windows and drag it to a Group Preset of your choice in MADRIX in order to load it in MADRIX.

**Using Fixture Groups As Map Settings Preset**

In addition to controlling fixture groups directly in the Group Control, you can use fixture groups in other ways. Since fixture groups include specific fixtures, these fixtures cover a well-defined area of the Patch. As such, you can use a fixture group as preset for the Map Settings of a Layer.

- **Click** **Map**

  ![Map Settings Preset](image)

  - A new window will open.
  - Go to **Mapping > Preset** or **Tiling > Preset**
  - The list will include an item for each fixture group you have created by using the fixture group's **Display Name**
    [You will find these items below **Full Size**]
  - Select the fixture group from the list.
  - MADRIX will automatically set the correct Map Settings.
    - The Mapping or Tiling will be repositioned and resized according to the fixture group.
    - The adjusted Map Settings will always be a rectangular selection since MADRIX uses the bounding box of the fixture group with only its largest dimensions in X, Y, and Z.
Calling Group Presets Using The Cue List

Controlling fixture groups in the Group Control view is mainly a live feature that works independently of other controls, such as Storage Places for example. But you can further integrate Group Presets into your workflow. You can use the Cue List to trigger Group Presets for each Cue.

- Open the **Cue List** and make sure to set up the **Group Preset** for a Cue where required.
  - Valid values range from 1 to 256.

- Learn more »**Cue List**
4.4 Effects [Visuals]

This topic includes:
- MADRIX Effects
- Selecting An Effect
- Variety Of Effects
- Configuration Of Effects And Layers
- Using Several Effects And Saving Effects

MADRIX Effects

MADRIX allows you to quickly produce an extraordinary light show. This is the purpose and probably most important part of the software.

- The term MADRIX Effects includes all lighting visuals and patterns you can create with MADRIX and display on your LEDs.
- MADRIX is a unique LED lighting controller. It is an effect generator with a graphics render engine and also includes media server features.
- You can use the integrated effects of the effect generator or external content [such as images or video files].
- MADRIX allows you can create stunning real-time lighting visuals with ease.

Selecting An Effect

- Choosing a lighting effect is simple.
- Thanks to its user interface layout, MADRIX includes 2 dedicated areas [Effect Area A and Effect Area B].
- By default, SCE Color is selected.
- A drop-down list allows you to select a MADRIX effect.
- Simply click on **SCE Color** to select a MADRIX stock effect from the list.
- Click on the MADRIX Effect in order to select it.
**Variety Of Effects**

MADRIX offers a large variety of effects and visuals. All MADRIX Effects are arranged into 5 distinct categories with various features:

- **SCE** - Static Color Effects
- **S2L** - Sound2Light Effects
- **M2L** - Music2Light Effects
- **TRI** - MADRIX Trigger Effects
- **MAS** - MADRIX Script Effect

Learn more »[MADRIX Effects](#)

---

**Configuration Of Effects And Layers**
Every single MADRIX Effect has different controls to easily customize how the effect looks and behaves.
Learn more »Effect Areas [Deck A / Deck B]

Extra settings provide further option for customization. In addition, you can combine each effect with every other effect. This allows you to create an unlimited amount of different lighting effects.
Learn more »Layers

Using Several Effects And Saving Effects

MADRIX offers certain possibilities to manage and organize your effects.

- Effects will be automatically saved in the selected Storage Place in Programmer mode.
  Learn more »Operating Modes [Programmer / Operator]

- MADRIX offers 256 x 256 Storage Places. Hence, you will be able to create a lot of effects and storing is automatically handled by the software.
  Learn more »Storage Places [256x 256]

- On the other hand, Storage Places and other configurations are ultimately saved in MADRIX Setup files.
  **Do not forget to regularly save your MADRIX Setup file!**
  Learn more »MADRIX Setup [New / Open]
4.5 Filters [FX]

This topic includes:

- Introduction
- Overview

Introduction

- Applies a special filter to quickly change your visuals.

- You can choose to quickly change your visuals with the help of filters.
- There are several categories to choose from. Each category contains several options to change the visual appearance of your effect.
- MADRIX offers filters in 4 distinct locations, but they can be activated at the same time if needed.

- **Main Output Filter** - Applies the filter to the Main Output. That means that the overall and final output is affected. Learn more »[Crossfader And Main Output](#)

- **Filter Deck A / Filter Deck B** - Applies the filter to an entire effect pipeline, Deck A or Deck B. That means that all Storages, Storage Places, and Layers will be affected. Learn more »[Controls [Deck A / Deck B]](#)

- **Storage Place Filter** - Applies the filter to a single Storage Place and its Layers. That means that the Storage Place and all of its included Layers will be affected. Learn more »[Storages](#)

- **Layer Filter** - Applies the filter to a single Layer. That means that only the single Layer will be affected. Learn more »[Layers](#)

- **Right Mouse Click** - Resets the filter to its default value [No FX].

Overview
**Part D: Using The Software**

---

**No FX** - Disables all additional filters. The effect will be displayed as normal.

**Blur / Sharpen** - Includes 5 modes to blur/smudge and 1 mode to sharpen the effect.

- **Blur** softens the visuals.
- **Blur B-Spline** softens the visuals.
- **Blur Catmull Rom** softens the visuals.
- **Blur Gauss** softens the visuals.
- **Blur Mitchell** softens the visuals.

- **Sharpen** increases the contrast.

**Brightness Graph** - Includes 3 modes to show the brightness of an effect by plotting a graph from it.

- **XYZ**
- **XZY**
- **YXZ**
Color Correction - Includes 4 modes to change the colors of your effect.

- **Brighten** increases the intensity.
- **Darken** decreases the intensity.
- **Grayscale** uses only shades of gray.
- **Invert Color** inverts the color values.
**Color Swap** - Includes various modes to swap colors with each other from RGB or from RGBW.

- **BGR** swaps from RB to BR.
- **BRG** swaps all three colors.
- **GRB** swaps from RG to GR.
- **GBR** swaps all three colors.
- **RGB** swaps from GB to BG.

- **WBGR** swaps all four colors.
- **WBRG** swaps all four colors.
- **WGRB** swaps from RBW to WRB.
- **WGBR** swaps from RW to WR.
- **WRBG** swaps from RGW to WRG.
- **WRGB** swaps all four colors.

- **BWGR** swaps all four colors.
- **BWRG** swaps all four colors.
- **GWBR** swaps all four colors.
- **GWBR** swaps from RGW to GWR.
- **RWBG** swaps from GW to WG.
- **RWGB** swaps from GBW to WGB.

- **BGWR** swaps from RBW to BWR.
- **BRWG** swaps all four colors.
- **GRWB** swaps all four colors.
- **GBWR** swaps all four colors.
- **RBWG** swaps from GBW to BWG.
- **RGWB** swaps from BW to WB.
**Color Mask** - Includes various modes to filter colors.

- **R** shows only red color values.
- **G** shows only green color values.
- **B** shows only blue color values.
- **W** shows only white color values.

- **RG** shows only red and green color values.
- **RB** shows only red and blue color values.
- **GB** shows only green and blue color values.
- **RW** shows only red and white color values.
- **GW** shows only green and white color values.
- **BW** shows only blue and white color values.

- **RGB** shows only red, green, and blue color values.
- **RGW** shows only red, green, and white color values.

- **RBW** shows only red, blue, and white color values.
- **GBW** shows only green, blue, and white color values.

**Kaleidoscope** - Includes 3 modes to change the style of your effect.

- **6x** applies triangular mirrors.
- **8x** applies rectangular mirrors.
- **12x** applies triangular mirrors and adds additional mirroring.
Quantization - Includes 3 modes to change the colors of your effect.

- **Low** summarizes adjacent colors slightly to create a comic-like style with harder edges.
- **Middle** summarizes adjacent colors to create a comic-like style with harder edges.
- **High** summarizes adjacent colors a lot to create a comic-like style with harder edges.

Style - Includes 4 modes to highlight the edges of effects or to add an imprinted visual style.

- **Edges** highlights the edges of objects and colors.
- **Edges Popup** highlights the edges of objects and colors.
- **Emboss** creates bevels and imprints of objects.
- **Emboss Popup** creates bevels and imprints of objects.
Transformation - Includes 7 modes to flip the effect quickly.

- **Mirror H** flips the effect horizontally.
- **Mirror V** flips the effect vertically.
- **Mirror HV** flips the effect horizontally and vertically.
- **Mirror D** flips the effect regarding the depth.
- **Mirror HD** flips the effect horizontally and regarding the depth.
- **Mirror VD** flips the effect vertically and regarding the depth.
- **Mirror HVD** flips the effect horizontally, vertically, and regarding the depth.

- **Swap H** $> 1x/2x/3x/4x/5x$ splits the effect the selected number of times and switches the parts horizontally.
- **Swap V** $> 1x/2x/3x/4x/5x$ splits the effect the selected number of times and switches the parts vertically.
- **Swap HV** $> 1x/2x/3x/4x/5x$ splits the effect the selected number of times and switches the parts horizontally and vertically.
- **Swap D** $> 1x/2x/3x/4x/5x$ splits the effect the selected number of times and switches the parts in the depth.
- **Swap HD** $> 1x/2x/3x/4x/5x$ splits the effect the selected number of times and switches the parts horizontally and in the depth.
- **Swap VD** $> 1x/2x/3x/4x/5x$ splits the effect the selected number of times and switches the parts vertically and in the depth.
- **Swap HVD > 1x/2x/3x/4x/5x** splits the effect the selected number of times and switches the parts horizontally, vertically, and in the depth.
4.6 Layers

This topic includes:
- Introduction
- Layer Tabs
- Context Menu
- Layer Settings
- Layer View

Introduction

- MADRIX Effects and Layers are closely related.
- Layers can be used to combine visuals and to create completely new effects.
- By default, only 1 Layer is created and shown.
- You can choose to use only 1 Layer or multiple Layers. Using multiple Layers can alter the displayed visuals immensely.
- MADRIX supports an unlimited number of Layers.
  [The actual number of Layers available for use depends on your computer performance and Matrix Size.]
- This chapter describes ways to work with Layers in particular.
  - A general overview about the controls for Layers and MADRIX Effects is provided in a previous chapter. Learn more »Effect Areas [Deck A / Deck B]

Layer Tabs
- Every Layer is represented by a Layer Tab.

- **Layer Order**

  - **Left Mouse Click And Hold And Move** - Changes the order of Layers via Drag and Drop.
    - When changing the order, you change the visual outcome of your effect.

  - **Layer Name** - You can change the Layer’s label.

  - **Right Mouse Click > Rename or Double-Click on Layer Tab** - Allows you to rename the description label of the Layer tab. Simply enter a new name and click **OK**

---

**Context Menu**

A context menu offers various options when working with Layers.

You can access the Layer context menu in 3 ways:

- **Right Mouse Click** on **Layer**
- Or **Right Mouse Click** on a Layer Tab
Layer Settings

Overview

Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer:

- **Layer > New** - Creates a new Layer.
- **Layer > Duplicate** - Creates an exact copy of the currently selected Layer.
- **Layer > Copy** - Copies the Layer into the clipboard of the computer.
- **Layer > Cut** - Copies the Layer into the clipboard and removes the Layer.
- **Layer > Paste** - Applies all settings of the Layer in the clipboard to the currently selected Layer.
- **Layer > Insert** - Creates a new Layer and applies all settings of the Layer in the clipboard to the currently selected Layer.
- **Layer > Rename** - Allows you to change the label of the Layer.
- **Layer > Remove** - Removes the currently selected Layer entirely.
Effect Parameter Chaser

- Effect Parameter Chaser - Controls the Effect Parameter Chaser to add playlist functionality to the Layer. Learn more »Chaser

Layer Macro

- Effect Macro Editor - Controls the Effect Macro Editor to add scripting functionality to the Layer. Learn more »Macros And Scripts

Defaults
**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].

---

**Submaster**

**Submaster** - Regulates the intensity of an effect.

- Click **SUB** and the button extends into a fader.
- Make sure to click and continue to hold the mouse button at the same time.
- Afterwards, simply move the fader with the help of your mouse.
- Release the mouse button to set up the specific value [The fader will disappear automatically].
- A value of 255 means full intensity.
- A value of 0 means no intensity and will render the effect completely black.
- The tooltip shows the currently set value.

The Submaster allows you to solely adjust the intensity of the running effect or Layer. To adjust the intensity of all running effects you have to use the Master.

Learn more » [Main Output / Master / Audio Levels](#)

---

**Map Settings**

Modifying the Map Setting allows to freely resize, reposition, and further modify every MADRIX Effect.

Learn more » [Mapping / Tiling / Rotation](#)

---

**Mix Modes**
Overview

Just like an image-editing software, you can use different Mix Modes to mix Layers with each other. This results in diverse color combinations and often completely new effects. These can also be referred to as blend modes.

How Mix Modes Work

- Mix Modes are based on basic mathematical calculations.
- As such, Mix Modes combine the color values [tonal values] of 2 Layers in different ways. A foreground Layer and a background Layer are used.
- All Mix Modes, except for Mask, work pixel by pixel and color channel by color channel.
  - Each single pixel of the foreground Layer is combined with the corresponding pixel of the background Layer.
  - Each color channel of a single pixel is combined with the equivalent color channel of the corresponding pixel.

Applying A Mix Mode

- You can use Mix Modes if you have at least 2 Layers [foreground and background]. Then, you can apply the Mix Mode to the second Layer.
- In MADRIX, the second Layer is positioned to the right. It is the foreground Layer. In MADRIX, the last Layer is on top.
- If you apply the Mix Mode to the first Layer, nothing will happen.
- You can decrease [or increase] the impact that each Layer has on the visual result by using the Opacity slider.
- In the example below, Mix Mode Mask is selected.
- By default, **Normal** is selected.

- **Right Mouse Click** - Resets the filter to its default value [**Normal**].

---

**List Of Mix Modes**
**Normal** - Is the default setting.

If you do not wish to use a Mix Mode or if you want to deactivate a selected Mix Mode, choose **Normal**

**Normal** is also a Mix Mode and the default way of how Layers are mixed together. Since it is the default Mix Mode, you can only use the Opacity Slider to change the visual outcome. If you set Opacity of Layer 2 to 50%, you will create a result like a cross-fade between the two Layers.

If you change the position of one Layer with the position of the other Layer, the result will not look the same.

**Darken** - Compares both Layers and only uses the darkest color value for each color channel per pixel [this will be the lower color value].

The result will look the same if you change the position of one Layer with the position of the other Layer.

**Multiply** - Multiplies the color values of each pixel of Layer 2 with the color values of each pixel of Layer 1.

[Values are converted to always ensure a maximum color value of 255].

The result will look the same if you change the position of one Layer with the position of the other Layer.

**Color Burn** - Is the inversion of Color Dodge.

Layer 1 will be darkened by Layer 2. The darker Layer 2, the darker the result.

If you change the position of one Layer with the position of the other Layer, the result will not look the same.
**Linear Burn** - Is subtractive color mixing.
The color values of both Layers will be added up. But when the result is lower than 255, the values will be set to 0 [black].

The result will look the same if you change the position of one Layer with the position of the other Layer.

**Lighten (HTP)** - Is the inversion of Darken.
It compares both Layers and only uses the brightest color value for each color channel per pixel [this will be the higher color value].

Is at the same time the Mix Mode HTP, applying the Highest Takes Precedence principle for DMX values.

The result will look the same if you change the position of one Layer with the position of the other Layer.

**Screen** - Is the inversion of Multiply.
Layer 2 and Layer 1 will be negatively multiplied and often brighten each other.

The result will look the same if you change the position of one Layer with the position of the other Layer.

**Color Dodge** - The brighter Layer 2, the brighter will be Layer 1.
A completely black Layer 2 will not change Layer 1.
A completely white Layer 2 will brighten every color channel, except for black color values.

If you change the position of one Layer with the position of the other Layer, the result will not look the same.

**Linear Dodge** - Will simply add up the color values of both Layers.

The result will look the same if you change the position of one Layer with the position of the other Layer.
**Overlay** - Is a combination of Multiply and Screen.
The result depends the intensity of Layer 1. If Layer 1 is darker than 50% Gray, the color values of both Layers will be multiplied. If Layer 1 is brighter than 50% Gray, the color values will be negatively multiplied and the amount will be doubled. A Layer 2 with 50% Gray will have no affect on Layer 1.

If you change the position of one Layer with the position of the other Layer, the result will not look the same.

**Soft Light** - Layer 2 will modulate the color values of Layer 1 and create soft mixtures in areas of highlights and shadows.
[Overlay is quite similar, but creates sharp contrasts instead.]

If you change the position of one Layer with the position of the other Layer, the result will not look the same.

**Hard Light** - Creates the result of Overlay, when changing the position of Layer 2 with the position of Layer 1.
It compares the intensity of both Layers.
If Layer 2 is brighter than 50% Gray, Layer 1 will be brightened.
If Layer 2 is darker than 50% Gray, Layer 1 will be darkened.

If you change the position of one Layer with the position of the other Layer, the result will not look the same.

**Vivid Light** - Will mainly increase the contrast of highlights and shadows.
The result is like a combination of Color Burn for shadows and Color Dodge for highlights.

If you change the position of one Layer with the position of the other Layer, the result will not look the same.
Linear Light - Increases the contrast.
It is similar to Linear Burn, but color values of Layer 2 have greater affect.

If you change the position of one Layer with the position of the other Layer, the result will not look the same.

Pin Light - Is like a combination of Darken and Lighten.
It compares the color values of both Layers and creates one of three results.
Average color values will often remain unaffected.
The result can be twice the brightness of Layer 2 darkened by a full 255 if Layer 1 is darker than that.
The result can also only be Layer 1 if Layer 1 is brighter than the first result and darker than the third result.

Or the result can be twice the brightness of Layer 2 if Layer 1 is brighter than that.

If you change the position of one Layer with the position of the other Layer, the result will not look the same.

Hard Mix - Only uses the six primary colors red, green, blue, yellow, cyan, magenta, or black, or white.
Color channels will be mixed and either be set to 0 or 255. [255 will be set for every color channel result from 1 to 254. 0 will be set, when the color channel result is 0.]

The result will look the same if you change the position of one Layer with the position of the other Layer.
**Difference** - Will calculate the difference between color values for each pixel. 
[If the result is negative, it will be multiplied by -1 to always have positive color values.]
Differences in color values will be easily visible for each pixel. If both pixels are identical, the difference will be 0 and thus black could be the maximum result for a pixel.

The result will look the same if you change the position of one Layer with the position of the other Layer.

**Exclusion** - Bright color areas will invert the color values of the corresponding area of the other Layer.
White areas will completely invert the color.
Very dark areas [black] will change nothing on the other Layer.
Average gray values will heavily change the contrast, up to a complete gray.

The result will look the same if you change the position of one Layer with the position of the other Layer.

**Subtract** -

**Divide** -

**Mask** - Uses the alpha channel of Layers.
It will merge the Layers together. The result will only be visible on areas where the two Layers overlap. The rest will be set to black.

The result will look the same if you change the position of one Layer with the position of the other Layer.

**Negative Mask** -
Overview

- **Link** - Combines 2 Layers with each other.
- If you activate Link mode, the currently selected Layer will be linked to the Layer underneath. It means that it will be linked to the **Layer left to it**.

Example 1


2] As a first result, you will see the following image in the Previews. Because of the standard settings, the Layer order, and the 2 Layers, only SCE Plasma is visible.

![SCE Plasma settings](image)

4] As a result, both Layers will be merged and the preview looks completely different. The text will be filled with the Plasma effect and in this way, both Layers are used to create a new effect.

![MADRIX image with Link Mode](image)

**Example 2**

- You could describe Link Mode differently.
- As previously described, effects may be build out of several Layers. Each Layer can contain a different MADRIX Effect.
- All Layers of that effect will be used to render the visual outcome. When rendering the visuals, Mix Modes, Opacity, position of Layers, etc. will all be included in the render process.
- Because of this, Link Mode can also be very useful when using more than two Layers.
- Use Link Mode and MADRIX will handle two linked Layers like one Layer in the render process.

![SCE Plasma settings](image)

2] As a result, you can see that the Plasma effect of Layer 3 is only visible on the text of Layer 2. The Metaballs effect [Layer 1] has not been affected at all.

![MADRIX logo](image)
3] If we now add a fourth Layer [SCE Gradient at Layer position 2] and activate Link Mode for this Layer, we will see that the text looks still the same. But the Metaballs effect [Layer 1] now has the colors of the Color Gradient.

**Filters [FX]**

*Filters* - Special filters can be applied to Layers in order to quickly change your visuals. Learn more »[Filters [FX]]

**Stepped Rendering**
**Step**

*Stepped Rendering* - Is only available for specific MADRIX Effects. It only applies to any movement of the input, i.e. when a Direction other than Stop is activated. Instead of creating a smooth transition for the movement from one voxel to the next voxel [sub-pixel rendering], MADRIX will move the input from voxel to voxel and from step to step without this transition. This might create a rougher overall movement, but it can produce a visually better outcome on the LEDs in certain cases [such as slow movement of large text].

**Opacity**

*Layer Opacity* - Makes the Layer transparent. This is mainly useful when using at least 2 Layers or more.
- If you are using only 1 Layer, the submaster controls the Layer brightness.
- The default value is 255 [100%].
- Perform a right-click to reset to 255 [100%].

**Blind And Solo**

Blind Mode and Solo Mode are 2 modes to quickly hide or show Layers. You can quickly include or exclude them from the visual end result of your effect.
**Blind** - Hides the currently selected Layer.
- The Layer will not be visible anymore in the Previews and Output, but you will still be able to adjust its settings. In this way, you may have a look at your created effect excluding certain Layers.
- Blind Mode will stay activated even if you switch to other Layers or Storage Places.
- The Layer tab will pulsate in red if Blind Mode is active.
- Blind Mode also affects Link Mode. A Layer with an activated Link Mode will also be set to Blind Mode if Blind Mode is activated for the Layer it is linked to.

**Solo** - Hides every Layer except the currently selected Layer. Hence, this Layer is the only one that will be displayed.
- Solo Mode will stay activated even if you switch to other Layers or Storage Places.
- The Layer tab will pulsate in green if Solo Mode is active.
- Solo Mode overrides Blind Mode.

## Layer View

### Overview

You can switch between 2 views.

- By default, the regular Effect Area is shown.
  - Learn more »[Effect Areas](Decks A / Deck B)

- **Layer View** - Activates the second view available for Layers.
  - The user interfaces changes as shown below [4 Layers are currently active in this example].
Solo And Blind

- **Solo** - Activates Solo Mode for the corresponding Layer.
- **Blind** - Activates Blind Mode for the corresponding Layer.

Faders

- Each fader regulates the Opacity of a single Layer.
  - You can set the fader to a specific position.
  - You can enter a value in the input field.
  - You can flash the fader.

Mouse Control And Keyboard Shortcuts

- **Single Selection**
  - A single fader regulates the Opacity of the corresponding Layer.
  - **Left Arrow / Right Arrow** - Quickly switch between faders by using the left or right arrow key.
- **Multiselection**
  - Use **Ctrl + Left Mouse Click** to select multiple faders at the same time. A green outline will show that a Layer is selected. When multiple faders are selected, you can control them at the same time.
  - Use **Shift + Left Mouse Click** to select multiple faders at the same time. A green outline will show that a Layer is selected. When multiple faders are selected, you can control them at the same time.
  - **Ctrl+A** - Selects all faders of all Layers.
  - **Ctrl+D** - Deselects the current fader selection.

- **Flash**
  - Use the button showing the Layer’s Name or the keyboard shortcut **Space**
  - It instantly sets the intensity to 255 as long as you hold the button/key down.
  - To use this feature, the fader needs to be set to a lower value than 255 first.

- **Restoring The Default Value**
  - **Left Mouse Double-Click** - Perform a double-click with your left mouse button directly on a single or multiple faders to restore the **Default Value**
  - **Right Mouse Click** - Perform a click with your right mouse button directly on a single or multiple faders to restore the **Default Value**
4.7 Mapping / Tiling / Rotation

This topic includes:

- Introduction
- Important Information
- Overview
- Mapping
- Mapping Example
- Using Fixture Groups As Mapping Preset
- Rotation
- Rotation Example
- Tiling
- Tiling Example
- Using Fixture Groups As Tiling Preset
- Saving And Loading
- Drag And Drop [Copy And Paste]
- Context Menu

Introduction

You can resize, reposition, and further modify every MADRIX Effect; independently of your configuration in the Matrix Generator or Patch Editor.

By default, every Layer [i.e. every MADRIX Effect] is shown on the complete virtual LED matrix [Matrix Size]. It is mapped to the complete LED installation. You can change that.

- Click Map

- A new window will open [in 2D or 3D view according to the Matrix Settings].
Important Information

Before you start making any changes, choose between relative values in percent [%] or absolute values in pixels [Pixels].

Overview

The Map Effect window has 4 sections:
- **Mapping**
- **Rotation**
- **Tiling**

and a graphical overview showing you the consequences of your changes.

- You will see a graphical 2D or 3D model of the virtual LED matrix.
- Because you can change the size and position of a Layer, the graphical model will change accordingly.
- Various guidelines referring to all edges of the graphical model will help you with the perspective [e.g., through parallel shift].
- You can also use the mouse to position the graphical model.
- The graphical model represents your virtual LED matrix, which is your LED installation.

- All 3 options can be used in combination [Mapping / Rotation / Tiling].
- All 3 options are powerful ways to customize visuals.
- All options refer to the virtual LED matrix [Matrix Size] you have configured in the Matrix Generator or Patch Editor.

- You can save Map Settings to an external file or load previously saved settings from an external file. Learn more Saving And Loading

- Click **Defaults** to cancel any changes and restore the default settings.
- Click **Close** to close the window.

**Mapping**

Mapping allows you to change the size and position of a Layer.

In this way, you can assign different MADRIX Effects to different areas of your LED installation [and also different fixtures].

- **Preset** - Instead of adjusting the below values manually, you can decide to use these presets. MADRIX will then automatically adjust the above settings accordingly. The default value is Full Size.
- **Position X** - Defines the horizontal position of the Layer.
- **Position Y** - Defines the vertical position of the Layer.
- **Position Z** - Defines the position of the Layer in the depth.
- **Size X** - Defines the horizontal size of the Layer.
- **Size Y** - Defines the vertical size of the Layer.
- **Size Z** - Defines the size of the Layer in the depth.
- **Mirror Mode** - Mirrors the Layer [flipping]. You can choose to not apply mirroring [None], to mirror horizontally [Mirror H], vertically [Mirror V], regarding the depth [Mirror D], or in any combination [e.g., Mirror HVD]. The default value is None.

**Mapping Example**

- Set up a virtual LED matrix of 100 x 100 x 1.
- Create 2 Layers.
- For Layer 1, choose **SCE Plasma** and the preset **Left** in the section **Mapping**.
- For Layer 2, choose **SCE Wave / Radial** and the preset **Right** in the section **Mapping**.
- The result could look like this:

![Mapping Example Image]

**Using Fixture Groups As Mapping Preset**

Fixture groups, when configured in the Patch Editor, are available as presets for Mapping and Tiling.

Learn more »[Fixture Groups [Group Control]]
1] Go to Mapping > Preset
- When your Patch includes Fixture Groups, as configured in the Patch Editor, the list of presets will include an item for each fixture group you have created. You will see the fixture group’s Display Name.
- You will find these items below Full Size
2] Select the fixture group from the list.
3] MADRIX will automatically set the correct settings.
- The Mapping will be set according to the fixture group.
- The adjusted Map Settings will always be a rectangular selection. MADRIX uses the bounding box of the fixture group with its largest dimensions in X, Y, and Z.

Rotation

This section allows you to rotate a Layer.
You can rotate layers once or continuously.

- **X-Axis** - Defines the clockwise or counter-clockwise rotation of the Layer in percent around the X-axis.
- **Y-Axis** - Defines the clockwise or counter-clockwise rotation of the Layer in percent around the Y-axis.
- **Z-Axis** - Defines the clockwise or counter-clockwise rotation of the Layer in percent around the Z-axis.

- **Anti-Aliasing** - Rotating a MADRIX Effect can produce hard edges for certain visuals. Anti-aliasing improves the image quality by reducing the hard edges.
  - Choose *None, 2x, or 4x*
  - [The higher the setting, the more performance will be required.]
  - The default value is None.

- *Animates the Layer and rotates it around the corresponding axis permanently.*

![Diagram showing rotation axes: X-Axis, Y-Axis, Z-Axis]

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>![No Rotation Image]</td>
<td>![X-Axis Rotation Image]</td>
<td>![Y-Axis Rotation Image]</td>
<td>![Z-Axis Rotation Image]</td>
</tr>
</tbody>
</table>

- ![Layer images demonstrating rotation effects](image-url)
Rotation Example

- Set up a virtual LED matrix of 100 x 100 x 1.
- Use only 1 Layer.
- For Layer 1, choose SCE Graph and set Z-Axis to 45 in the section Rotation
- The result could look like this:

![Rotation Example Image]

Tiling

This section allows you to duplicate the Layer and its content. You can use it to create new repeating or mirrored patterns [Depending on the settings it might remind you of a kaleidoscope]. It also means that you can show the same content, and the same MADRIX Effects, on different parts of your LEDs or different LED fixtures.

- **Preset** - Instead of adjusting the below values manually, you can decide to use these presets. MADRIX will then automatically adjust the below settings accordingly [except for Tile Count]. The default value is Full Size.
- **Tile Count** - Scales the Layer to a fraction of its size and therefore creates the number of tiles as set by this value. Is an automatic way to tile the Layer and influences the sizes below and always centers the positions. Tile mode Repeat is automatically activated. E.g., a Tile Count of 4 will reduce the size to 25% and create 4 Layers.
- **Position X** - Defines the horizontal position of the Layer.
- **Position Y** - Defines the vertical position of the Layer.
- **Position Z** - Defines the position of the Layer in the depth.
- **Size X** - Defines the horizontal size of the Layer.
- **Size Y** - Defines the vertical size of the Layer.
- **Size Z** - Defines the size of the Layer in the depth.

- **Offset X** - Defines the spacing between repeated or mirrored sections regarding the X-axis and only works when a Tile Mode other than None is selected.

- **Offset Y** - Defines the spacing between repeated or mirrored sections regarding the X-axis and only works when a Tile Mode other than None is selected.

- **Offset Z** - Defines the spacing between repeated or mirrored sections regarding the X-axis and only works when a Tile Mode other than None is selected.

- **Tile Mode** - You can choose to not apply tiling [None], to tile repeatedly [Repeat], horizontally [Mirror H], vertically [Mirror V], regarding the depth [Mirror D], or in any combination [e.g., Mirror HVD]. The default value is None.

### Tiling Example

- Set up a virtual LED matrix of 100 x 100 x 1.

- Use only 1 Layer.

- For Layer 1, choose **SCE Wave / Radial** and set **Tile Count** to 11 in the section **Tiling**

- The result could look like this:

![Tiling Example](image)

### Using Fixture Groups As Tiling Preset

Fixture groups, when configured in the Patch Editor, are available as presets for Mapping and Tiling.

Learn more »[Fixture Groups [Group Control]]
1] Go to **Tiling > Preset**
- When your Patch includes Fixture Groups, as configured in the Patch Editor, the list of presets will include an item for each fixture group you have created. You will see the fixture group’s Display Name.
- You will find these items below **Full Size**

2] Select the fixture group from the list.

3] MADRIX will automatically set the correct settings.
- The Tiling will be set according to the fixture group.
- The adjusted Map Settings will always be a rectangular selection. MADRIX uses the bounding box of the fixture group with its largest dimensions in X, Y, and Z.

**Saving And Loading**

- ![Loads Maps Settings from a previously saved, external file [of the file type *.mmapx]. A new window opens for you to select the file on your harddisk.](image)
- Saves the current Map Settings, including all mapping, tiling, and rotation settings, in an external file [of the file type *.mmapx]. Simply enter a File name when the new window opens, choose a location, and click Save.

Drag And Drop [Copy And Paste]

- Left Mouse Click And Hold - You can perform a Copy and Paste with the mouse. Click with the left mouse button on the Map button and hold for 3 seconds. A small + appears. Now, continue to hold and drag the mouse to another Map button of another Layer and release the mouse to instantly copy the settings to the other Layer.

Context Menu

- Right Mouse Click - You can call up the context menu by performing a right mouse click on Map.

A small window will be shown.

You can quickly perform the following actions:

- Edit... - Opens the Map Settings window [in the same way you can open the window by clicking on Map with the left mouse button].

- Open... - Loads Maps Settings from a previously saved, external file [of the file type *.mmapx]. A new window opens for you to select the file on your harddisk.
- **Copy** - Copies all your mapping, tiling, and rotation settings for this Layer into the clipboard.

- **Paste** - Applies all settings that are stored in the clipboard to this Layer. [In this way, you can quickly copy and paste Map Settings from one Layer to other Layers.]

- **Clear** - Clears all changes and restores the default settings [in the same way you can restore the default settings by clicking *Defaults* in the Map Settings window].
4.8 Chasers

Introduction

A Chaser is a powerful and creative tool within MADRIX. It offers a lot of possibilities to further customize visuals or your workflow in MADRIX.

You can set up a Chaser to remember specific settings. MADRIX can then automatically chase them or you can manually load and control them as needed.

A Chaser:

- Can be used as a playlist to change and customize visuals.
- Is a list of Steps played back as a sequence.
- Can be time-controlled or controlled manually.
- Each Step remembers the settings as you configured them.
- Can even be used to create animations.

Overview
MADRIX offers 3 different Chasers:

<table>
<thead>
<tr>
<th>Effect Parameter Chaser</th>
<th>Storage Place Parameter Chaser</th>
<th>Group Value Chaser</th>
</tr>
</thead>
<tbody>
<tr>
<td>- Can be configured for Layers only. Learn more »Layers</td>
<td>- Can be configured for Storage Places, including their Layers. Learn more »Storage Places [256 x 256]</td>
<td>- Can be configured in the Group Control to further control fixture groups. Learn more »Fixture Groups [Group Control]</td>
</tr>
<tr>
<td>- Can be configured for every single Layer.</td>
<td>- Can be configured for every single Storage Place and can include every single Layer of that Storage Place.</td>
<td>- Can only be used to chase fixture group values.</td>
</tr>
<tr>
<td>- Visuals can be customized by chasing MADRIX Effect settings and Layer settings.</td>
<td>- Visuals can be customized by chasing Storage Place settings and Layer settings.</td>
<td></td>
</tr>
<tr>
<td>- Can be seen as an easy way to customize effects instead of using a Macro. Learn more »Macros And Scripts</td>
<td>- Can be seen as an easy way to customize effects and workflows instead of using a Macro. Learn more »Macros And Scripts</td>
<td></td>
</tr>
<tr>
<td>- Is different to the Cue List. Each Cue in the Cue List references a single Storage Place. An Effect Parameter Chaser can be used independently from the Cue List and can be set up for each single Layer.</td>
<td>- Is different to the Cue List. Each Cue in the Cue List references a single Storage Place. A Storage Place Parameter Chaser can be used independently from the Cue List and can be set up for each single Storage Place.</td>
<td></td>
</tr>
</tbody>
</table>

**Effect Parameter Chaser**
Storage Place Parameter Chaser

Group Value Chaser
Example

An Effect Parameter Chaser, for example, offers many ways to customize visuals. In this first example, we will use the Effect Parameter Chaser to set 4 different movement directions for SCE Color Scroll within 60 seconds.

Step 1]

For the first 15 seconds, MADRIX should show SCE Color Scroll with the **Direction Top Left**

Preview
Step 2]

For the next 15 seconds, MADRIX should show SCE Color Scroll with the **Direction Top Right**

*Preview*

Step 3]

For the next 15 seconds, MADRIX should show SCE Color Scroll with the **Direction Bottom Right**
Step 4] For the last 15 seconds, MADRIX should show SCE Color Scroll with the *Direction Bottom Left*
Creating A Chaser

Overview

- Right Mouse Click on \( \text{Playback} > \text{Edit} \)... 
- A new window will open.

Effect Parameter Chaser
Step-By-Step Configuration

1] Select which kind of Parameters to include for a Step.
3] Control the Chaser playback.
1] Selection Of Parameters

You can use each Step to change a variety of settings.

- You can freely choose which kind of Parameters should be included in a Step.
- Each Step can include different kind of Parameters.
- That also means that you can exclude certain kind of Parameters for each Step.
- Only the kind of Parameters that has been selected and is therefore included in a Step will be chased.
- Parameters that are not included in a Step will not be chased and can still be used in the normal way.
- Any combination of the settings described below is possible.

- Parameters
  - Left Mouse Click - Opens the Parameters submenu for selection.
Effect Parameter Chaser

- **All** - Includes all available Parameters in a Step [Effect Settings, Layer Visibility Settings, Layer Submaster, Layer Map Settings, Layer Mix Settings, Layer Filter].

- **All Effect Settings** - Includes all available Effect Parameters in a Step [Effect Settings].

- **All Layer Settings** - Includes all available Layer Parameters in a Step [Layer Visibility Settings, Layer Submaster, Layer Map Settings, Layer Mix Settings, Layer Filter].

- **None** - Includes no Parameters [can be used to add empty Steps/pauses, for example].

- **Effect Settings** - When selected, includes all the individual settings of a MADRIX Effect that are exclusive to this effect.
  - This can be any effect setting, such as colors, directions, modes, etc.
  - You can change single effect settings or multiple effect settings at the same time.
  - For example: Stretch, Contrast, and Detail for SCE Clouds. Learn more »**SCE Clouds**
  - **Note:** Steps that include Effect Settings as Parameters will only fully work for the same kind of MADRIX Effect! The Effect Settings of such a Step will be ignored by other MADRIX Effects.

- **Layer Visibility Settings** - When selected, includes the visibility settings of this Layer, including **Opacity**, **Blind**, and **Solo**.
  - Learn more »**Layers**

- **Layer Submaster** - When selected, includes **submaster** of this Layer.
  - Learn more »**Layers**

- **Layer Map Settings** - When selected, includes the **Map Settings** of this Layer.
  - Learn more »**Mapping / Tiling / Rotation**
- **Layer Mix Settings** - When selected, includes the Mix Mode and Link Mode settings of this Layer.
  - Learn more »[Layers](#)

- **Layer Filter** - When selected, includes the Filter [FX] settings of this Layer.
  - Learn more »[Layers](#)

- **OK** - Confirms your selection of Parameters and closes the Parameters submenu.
### Storage Place Parameter Chaser

- **All** - Includes all available Parameters in a Step [Storage Place Submaster, Storage Place Speed Pitch, Storage Place Filter, Layer Visibility Settings, Layer Submaster, Layer Map Settings, Layer Mix Settings, Layer Filter].

- **All Storage Place Settings** - Includes all available Storage Place Parameters in a Step [Storage Place Submaster, Storage Place Speed Pitch, Storage Place Filter].

- **All Layer Settings** - Includes all available Layer Parameters in a Step [Layer Visibility Settings, Layer Submaster, Layer Map Settings, Layer Mix Settings, Layer Filter].

- **None** - Includes no Parameters [can be used to add empty Steps/pauses, for example].

- **Storage Place Submaster** - When selected, includes the **submaster** of the Storage Place.
  - Learn more »[Storages](#)

- **Storage Place Speed Pitch** - When selected, includes the **speed pitch** of the Storage Place.
  - Learn more »[Storages](#)

- **Storage Place Filter** - When selected, includes the **Filter [FX]** of the Storage Place.
  - Learn more »[Storages](#)

- **Layer Visibility Settings** - When selected, includes the visibility settings of all Layers, including **Opacity**, **Blind**, and **Solo**.
  - These are the same Layer settings, which the Effect Parameter Chaser can control for a single Layer.
Layer Submaster - When selected, includes submasters of all Layers.
- These are the same Layer settings, which the Effect Parameter Chaser can control for a single Layer.

Layer Map Settings - When selected, includes the Map Settings of all Layers.
- These are the same Layer settings, which the Effect Parameter Chaser can control for a single Layer.

Layer Mix Settings - When selected, includes the Mix Mode and Link Mode settings of all Layers.
- These are the same Layer settings, which the Effect Parameter Chaser can control for a single Layer.

Layer Filter - When selected, includes the Filter [FX] settings of all Layers.
- These are the same Layer settings, which the Effect Parameter Chaser can control for a single Layer.

OK - Confirms your selection of Parameters and closes the Parameters submenu.

Group Value Chaser
- It is not necessary to select any Parameters, since only one set of Parameters can be chased [fixture group values].

2] Adding New Steps Or Editing Steps

Overview

A Chaser is represented by a list of Steps in the Chaser window.
- Add and configure or edit Steps as needed.
- A Chaser normally runs through the list in a sequence. The order is defined by the Playback Mode.
  [The direction may also be reversed when using negative values for the Speed Pitch or the Speed Masters. Learn more below.]
- When a loop is set up, the Chaser repeats.

### Adding Or Editing Steps

Use the following controls on the right side of the Chaser window:

- **Add Step** - Adds a new Step to the list.
  - The newly added Step includes all currently set Parameters [according to your Parameters selection. Learn more Selection Of Parameters].
  - A newly added Step will be created with the default values for Fade Time, Fade Type, Wait Time, and Description.
  - First, make sure that the visuals look as intended, that all settings are defined as required, and then add the Step.
  - Please stop the Chaser if it is currently running.
**Remove Steps** - Removes all currently selected Steps from the list.

**Duplicate Steps** - Copies the currently selected Steps and adds them as new Steps to the list.

**Set** - Updates the Step by overwriting the saved settings in the Step with the current settings.

- **Note:** Before updating a Step, make sure that your current settings are correctly set. This includes all settings on the user interface as well as the selection of **Parameters** of the Chaser window. It is therefore highly recommended to 1) first load the Step [if a Fade Time is set up, wait until the Step has fully loaded and stopped], 2) second to change all required settings, and 3) update the Step via **Set**. Learn more [Activating A Step / Loading A Step](#).

**Synchronize Parameter Selection** - Is only visible when necessary and if a Step is selected. Shows that your current selection of **Parameters** [learn more [Selection Of Parameters]](#) is different to the Parameters of the selected Step [learn more **Parameters**]. In order to set the selection of Parameters to the Parameters of the Step, click the equal sign.

**# 3**

- Shows the total number of Steps in the Step list. An empty list shows **# 0**

**Swap Position** - Swaps the position of Steps in the Step list when several Steps are selected first.

**Position Up** - Changes the order, and positions currently selected Steps one item higher up in the list.

**Position Down** - Changes the order, and positions currently selected Steps one items lower down in the list.

**Configuring Steps In the Step List**

Use the following columns of the Step list:
# Shows the index number of this Step in the list.
- This index number cannot be edited in the list.
- But you can change the order of Steps by changing the position of Steps via Swap Position, Position Up, and Position Down

**Description**
- Allows you to provide a label for the specific Step. Perform a left mouse double-click and enter any name or text.
- The default value is Step.

**Fade Type**
- Defines how the Step is faded in, when a Fade Time has been set.
  - You can choose from a variety of types [Linear, Ease In Bounce, Ease Out Bounce, Ease In Out Bounce, Ease In Circular, Ease Out Circular, Ease In Out Circular, Ease In Cubic, Ease Out Cubic, Ease In Out Cubic, Ease In Sinusoidal, Ease Out Sinusoidal, Ease In Out Sinusoidal, Ease In Exponential, Ease Out Exponential, Ease In Out Exponential].
  - The default value is Linear.

**Fade Time**
- Defines how long the Step is faded in [in s]. Change it to any time. This creates an automatic transition from one Step to another Step.
  - When possible a smooth transition is automatically created by gradually increasing or decreasing values for Parameters.
  - Certain Parameters can be used for a smooth transition.
  - Certain Parameters cannot be used for a smooth transition and will be selected or switched on or off at the beginning of the Fade Time.
  - The transition is affected by Fade Type and Fade Time.
  - Valid values range from 0.0 to 99999.99.
  - The default value is 0.0 [which means that there is no transition/fade-in by default].
  - Learn more Fade Time And Animations

**Wait Time**
- Defines how long the Step is shown before skipping to the next Step in the list [in s].
  - Is separate from the Fade Time, which means it does not include the Fade Time.
  - Valid values range from 0.0 to 99999.99.
  - The default value is 1.0.

**Parameters**
- Shows which Parameters were included for this specific Step.
  - This column cannot be edited in the list.
  - But you can specify the values by selecting the Parameters before adding a new Step via + or before changing an existing Step via Set.
Monitoring The Duration

See the following controls at the bottom of the Chaser window:

* **Step Time (s)** - Shows the duration of the currently selected or currently running Step in seconds as well as graphically as a progress bar.

* **Loop Time (s)** - Shows the duration of the overall loop including all Steps in seconds as well as graphically as a progress bar.

* **Current Loop** - Shows in which loop the Chaser currently is. Only when an overall loop has been completed, the count will be increased.

Managing Chasers

Use the following controls on the left side of the Chaser window:

* **New** - Immediately removes all items from the list.

* **Open** - Loads a previously saved Chaser from an external file [of the file type *.mepcz or *.mepcx for Effect Parameter Chasers; of the file type *.msppcz or *.msppcx for Storage Place Parameter Chasers; of the file type *.mgvcz or *.mgvcx for Group Value Chasers].
  - A new window opens for you to select the file on your harddisk.

* **Save** - Saves the Chaser to an external file.

3] Controlling The Chaser Playback

Control the Chaser playback using the following controls at the bottom of the Chaser window:
[Part D] Using The Software

Stop - Stops the Chaser.

Stopped - Shows that the Chaser has been stopped.

Play/Pause - Starts the Chaser or pauses the playback and remembers the current position.
- Playback will start from the beginning if the Chaser has not been started before or if the playback has been stopped via Stop
- Playback will continue from the current position if the Chaser has been paused.

Playing - Shows that the Chaser is currently running.
Paused - Shows that the Chaser has been paused.

Previous Step - Returns to the previous Step and plays back that Step.
- If the Chaser has not been running, playback will stop after the Fade Time of this Step has passed.
- If the Chaser is running, playback will continue with the following Step automatically.

Next Step - Skips to the following Step and plays back that Step.
- If the Chaser has not been running, playback will stop after the Fade Time of this Step has passed.
- If the Chaser is running, playback will continue with the following Step automatically.
**Pitch** - Defines the overall speed of the Chaser and the Step List. It works as a multiplier/a factor.

- Example: A pitch of 2.0 will double the current speed.
- Move the fader upwards to increase the speed.
- Move the fader downwards to decrease the speed.
- The default value is 1.0 [which is normal speed].
- A value of 0.0 will stop the Chaser.
- The highest value is +10.
- The lowest value is -10.
- Negative values will reverse the playback direction. When setting a negative pitch during playback, the current Step will be fully played and only after its Step Time is over, the following Step will be chased.
  [The playback direction depends on the Playback Mode.]
- Right-click on the Pitch button to reset to the value of 1.0
- The tooltip shows the currently set value.

**Playback Mode** - Defines in which order Steps are played back. This only affects the order in the Step List, not the playback direction of a Step itself.

- **Forward** - Steps will be played back in the order of the Step List.
- **Backward** - Steps will be played back as configured in the Step List but backwards.
- **Ping Pong** - Steps will be played from top to bottom in the Step List and then from bottom to top again. The first and last Step will be played only once every time.
- **Random** - Steps will be chosen randomly and only once during a single loop. The random order remains when pausing playback. Only when stopping the Chaser, the order will be randomly created again.
**Loop Count** - Defines how often the Chaser is being played.
- **Endless** - The Chaser will always run until you manually stop or pause it.
- **1x** - The Chaser will run once and automatically stop at the end of the last Step.
- **2x to 100x** - The Chaser will run multiple times as indicated by the loop number.

**Autostart** - Starts the Chaser automatically again when switching back to the Storage Place or Group Preset.

### Activating A Step / Loading A Step

- **Left Mouse Double-Click** - Perform a double-click with your left mouse button directly on the index number of a Step [as shown in the column # of the Step list].
  - **Activating a Step** is possible at any time when the Chaser is running. Playback will automatically continue with the following Step.
  - **Loading a Step** and therefore loading its settings is recommended before updating the Step via **Set**. Stop or pause the Chaser first. Playback will stop at the end of the Step if the Chaser has been stopped or paused. Learn more **Set**

### Resizing The Window

- You can resize the window according to your needs by dragging the window borders outwards or inwards.

### Closing The Window

**Close** - Closes the window.
Fade Time And Animations

Overview

- When configuring Steps in the Step list, you can choose to set up a specific Fade Time and Fade Type.
  - When setting up a Fade Time that is higher than 0.0, MADRIX will automatically create a transition from one Step to another Step [fade-in].
  - A transition/fade-in is specified by the Fade Time and the Fade Type.
  - When leaving the default value of 0.0 [or when manually setting up a Fade Time of 0.0], the Step will not be faded in.
- When possible a smooth transition is automatically created by gradually increasing or decreasing values for Parameters. In this way, you can create animations.
- Certain Parameters can be used for smooth transitions:
  - Horizontal sliders that allow you to set a specific range of possible values. Example: SCE Ticker / Scrolling Text > BPM or Layer Opacity
  - Input fields that allow you to enter a specific range of possible values. Example: SCE Wave / Radial > Position X, Y, Z
  - Certain colors. Example: SCE Color > Color
- Certain Parameters cannot be used for smooth transitions and will be selected once or switched on or off at the beginning of the Step:
  - Colors in Color Tables or Color Gradients. Example: SCE Drops > Colors
  - Any settings that can only be activated or deactivated. Example: S2L EQ / Spectrum > Mirror
  - Any settings or modes where only one selection is possible at a time. Example: Direction, Look-At Type, Shape, Shape Alignment, Filter [FX], etc.
- Many Effect Settings can be used to create transitions/animations.
- Many Map Settings are very suitable to create transitions/animations.
- Such a procedure may be similar to a Key Frame Animation, where each Step in MADRIX represents a key frame of the animation.

Animation Example
The following example shows a simple animation in 4 Steps by using an Effect Parameter Chaser and only changing the Effect Setting **Position** of SCE Wave / Radial [while all other Parameters remain unchanged with their default values].

**Step 1**

**Effect Settings** - The animation starts in the upper left corner with **Position 0, 0, 0**

**Effect Parameter Chaser** - The **Fade Time** is set to **1.0** and the **Fade Type** is set to **Linear**. The **Wait Time** is set to **0.0**. This means that MADRIX will automatically create a smooth animation, when possible. In this example, it is possible.

**Preview**
Step 2]

Effect Settings - The animation continues to the upper right corner with Position 100, 0, 0

Effect Parameter Chaser - The Fade Time is set to 1.0 and the Fade Type is set to Linear. The Wait Time is set to 0.0. MADRIX will gradually increase the value of Position, until the values of Step 2 are reached. In this example, the center of the SCE Wave /Radial effect will be moved to the left. Two seconds have past.

Preview

Step 3]

Effect Settings - The animation continues to the lower right corner with Position 100, 100, 0

www.madrix.com
Effect Parameter Chaser - The Fade Time is set to 1.0 and the Fade Type is set to Linear. The Wait Time is set to 0.0. MADRIX will gradually increase the value of Position, until the values of Step 3 are reached. In this example, the center of the SCE Wave /Radial effect will be moved to the bottom. Three seconds have passed.

Preview

Effect Settings - The animation ends at the lower left corner with Position 0, 100, 0
Effect Parameter Chaser - The Fade Time is set to 1.0 and the Fade Type is set to Linear. The Wait Time is set to 0.0. MADRIX will gradually increase the value of Position, until the values of Step 3 are reached. In this example, the center of the SCE Wave /Radial effect will be moved to the left. Four seconds, which is the total Loop Time, have passed.

Preview

Endless Loop - Since the Loop Count is set to Endless, MADRIX will continue with Step 1 again. In this example, the center of the SCE Wave /Radial effect will be moved to the top. This means the animation runs smoothly and endlessly.

Starting And Pausing A Chaser

A] Using The User Interface

- Left Mouse Click - You can control the Chaser playback by performing a left mouse click on.

- Shows that the Chaser is currently running and being played.

- Shows that a Chaser has been set up, but it is currently paused.
B] Using The Context Menu

- Open the context menu and use the playback options of the context menu.
- Learn more Context Menu

C] Using The Chaser Window

- Open the Chaser window and use the provided playback controls.
- Learn more Controlling The Chaser Playback

Context Menu

The main options are also available via a context menu.

- **Right Mouse Click** - You can call up the context menu by performing a right mouse click on . A small window will be shown.

![Context Menu Options](image.png)

You can use the following options:

- **Edit** - Opens the Chaser window. Learn more Creating A Chaser
[Part D] Using The Software

- **Add Step** - Immediately adds a new Step to the Step list of the Chaser. The currently chosen Parameters that will be included in the Step are shown after the colon [e.g., **Add Step : Effect** shows that the **Effect Settings** are included for an Effect Parameter Chaser, for example].

- **Open...** - Loads a previously saved Chaser file.
  - Effect Parameter Chaser files of the file type *.mepcz or *.mepcx.
  - Storage Place Parameter Chaser files of the file type *.msppcz or *.msppcx.
  - Group Value Chaser files of the file type *.mgvcz or *.mgvcx.
  - A new window opens for you to select the file on your harddisk.

- **Copy** - Copies the current Chaser into the clipboard as a duplicate.

- **Paste** - Inserts a copy of a Chaser from the clipboard into the currently selected Chaser.

- **Stop** - Stops the Chaser.

- **Play** - Starts the Chaser.
  - Playback will start from the beginning if the Chaser has not been started before or if the playback has been stopped via **Stop**
  - Playback will continue from the current position if the Chaser has been paused via **Pause**

- **Pause** - Pauses the playback and remembers the current position.

- **Clear** - Removes any Steps and restores an empty, default Chaser.

---

**Drag And Drop [Copy And Paste]**

You can perform a Copy and Paste with the mouse:

- **Left Mouse Click And 2 Sec. Hold** - Use a left mouse click on an Effect Parameter Chaser button or Storage Place Parameter Chaser button and continue to hold for 2 seconds. A small + appears. Continue to hold and move your mouse to another Layer and Effect Parameter Chaser button or Storage Place and Storage Place Parameter Chaser button. Release the mouse button to paste a copy onto the new Chaser.
### More Information

**The following information can be very important when working with a Chaser in general:**

- A Chaser should contain at least 1 Step in the Step list.
- When setting up a Fade Time of 0.0 as well as a Wait Time of 0.0 for a Step, MADRIX will **not** ignore such a Step in the Step list. Although, this configuration says that this Step should not be displayed, MADRIX will use it as starting point for the transition to the next Step [if the next Step includes a Fade Time]. In this way, a Step with a total Step Time of 0.0 will influence the visual outcome of the transition.
- When a Chaser is playing, the user interface will be deactivated according to the Parameters selection of the Step.
  - For example, if the Step includes Map Settings, the Map button will be deactivated.
  - Any controls that are not deactivated, can be used in the normal way.
- Regarding the Loop Count and Current Loop, MADRIX counts from the beginning again, if the playback had been stopped beforehand.
  - Only complete loops will be counted. Inverting the Speed Pitch during a loop, will not count towards the Loop Count.
  - The Current Loop will be reset when performing a Clear, New, or manually removing all Steps from the Step List.

**The following information can be very important when working with the Effect Parameter Chaser:**

- Should it be necessary to calculate random values, MADRIX will generate random values once at the beginning of a Step.
- A Chaser should contain at least 1 Step in the Step list.
  - Including only 1 Step can be useful when chasing an Effect Setting that generates random values [such as `RND`], for example. As explained above, MADRIX will generate random values once at every beginning of a Step.
  - Including 2 Steps or more is probably the usual case to chase Parameters.
- The following Layer Settings will still be available, even when an Effect Parameter Chaser is running. That also means that they cannot be chased with the Effect Parameter Chaser.
  - **Step** - Stepped Rendering
  - **Effect Macro Editor**
  - **R** - Restore Default Layer Settings
The following Parameters will still be available, even when an Effect Parameter Chaser with Effect Settings as Parameters selection is running. That also means that they cannot be chased with the Effect Parameter Chaser.

- SCE Capture
  - Open [i.e. loaded streams]
  - SL

- SCE Clouds
  - Generate

- SCE Counter
  - Start

- SCE Graph
  - X-Axis Registers [X1, X2, X3]
  - Z-Axis Registers [Z1, Z2, Z3]
  - Phase Registers [P1, P2, P3]

- SCE Image
  - Open [i.e. loaded images]
  - Images [i.e. loaded images]

- SCE Noise
  - Generate

- SCE Screen Capture
  - SL
  - Screen Capture Configuration > Capture Frame Rate > FPS / R

- SCE Video
  - Open [i.e. loaded video files]
  - SL
  - Position
  - Skip To Start
  - Step 1 Frame Back
  - Skip 1 Frame
  - Skip To End

- MAS Script
  - Load
  - MAS Effect Script Editor
  - Limit Script Execution
  - ASYNC
- When chased, the following Effect Settings will cause the corresponding MADRIX Effect to start again from the beginning. Chasing these Effect Settings might therefore provide limited possibilities.
  - SCE Fill Drops
    - **Direction**
    - **Size X [Width]**
    - **Size Y [Height]**
    - **Size Z [Depth]**
    - **Pitch 1**
    - **Pitch 2**
    - **Position Origin Type**
  - SCE Fill Random
    - **Size X [Width]**
    - **Size Y [Height]**
    - **Size Z [Depth]**
    - **Pitch X**
    - **Pitch Y**
    - **Pitch Z**
    - **Position Origin Type**
  - SCE Fill Snake
    - **Size X [Width]**
    - **Size Y [Height]**
    - **Size Z [Depth]**
    - **Pitch X**
    - **Pitch Y**
    - **Pitch Z**
    - **Position Origin Type**
    - **Start Corner**
    - **Orientation Mode**
    - **Circle Mode**
    - **Center Mode**
    - **Mirror Mode**

- An Effect Parameter Chaser is applied to the current Layer. The Chaser will still be there even when changing the MADRIX Effect for this Layer.
  - Please note: Depending on your configuration, the Chaser might then work or not work for the newly selected MADRIX Effect.
  - To avoid problems, select another Storage Place or clear the Effect Parameter Chaser first.
  - When changing the MADRIX Effect for this Layer, the Chaser will be stopped.
In order to configure a Chaser, the associated Layer needs to be active on the MADRIX user interface. If you change to another Layer or Storage Place, for example, the Effect Parameter Chaser window will be closed automatically.

Even during Chaser playback, you will be able to control certain functionality of the Effect Parameter Chaser window [such as playback or managing the Step list].

The Speed Masters do affect the Effect Parameter Chaser.
- As a result, playback speed can be increased, decreased, and the Chaser can also be played backwards [when the Speed Master has a negative value].
- A Speed Master with a negative value will let the Chaser play backwards, which means that the Steps will be played back in reversed order [and according to the Playback Mode].
- A Speed Master with a negative value will not change a fade-in [as set via Fade Time].
- Learn more »Controls [Deck A / Deck B]

The following information can be very important when working with the Storage Place Parameter Chaser:

- The Storage Place Parameter Chaser can chase Layer settings, but not MADRIX Effect settings. [That means that you will be able to switch to another MADRIX Effect or change the MADRIX Effect settings, while a Storage Place Parameter Chaser is running.]

- The following Layer Settings will still be available, even when a Storage Place Parameter Chaser is running. That also means that they cannot be chased with the Effect Parameter Chaser.
  - Step - Stepped Rendering
  - Effect Parameter Chaser
  - Effect Macro Editor
  - R - Restore Default Layer Settings

- When playing a Storage Place Parameter Chaser, you are also able to run an Effect Parameter Chaser per Layer. In addition, you are able to override the Layer settings of the Storage Place Parameter Chaser with the Layer settings of an Effect Parameter Chaser.

- When deleting a Layer after a Storage Place Parameter Chaser has been created, the Parameters of this Layer will be removed from the Chaser.

- When adding a Layer after a Storage Place Parameter Chaser has been created, the Parameters of this Layer will always be set to the default values in each Step.

- When swapping the position of two Layers after a Storage Place Parameter Chaser has been created, the Parameters of these Layers will be kept and will be correctly applied to the Layers in their new order.
A Storage Place Parameter Chaser is applied to the current Storage Place. The Chaser will still be there even when changing the Storage Place.

In order to configure a Chaser, the associated Storage Place needs to be active on the MADRIX user interface. If you change to another Storage Place, for example, the Storage Place Parameter Chaser window will be closed automatically.

Even during Chaser playback, you will be able to control certain functionality of the Storage Place Parameter Chaser window [such as playback or managing the Step list].

The Speed Masters do affect the Storage Place Parameter Chaser.
- As a result, playback speed can be increased, decreased, and the Chaser can also be played backwards [when the Speed Master has a negative value].
- A Speed Master with a negative value will let the Chaser play backwards, which means that the Steps will be played back in reversed order [and according to the Playback Mode].
- A Speed Master with a negative value will not change a fade-in [as set via Fade Time].
- Learn more »Controls [Deck A / Deck B]
4.9 Tools

This topic includes:
- Introduction
- DMX Fader Tool
- Logfile
- Task Watcher
- DMX Watcher
- MIDI Watcher
- PLEXUS Configuration
- MADRIX Device Configuration

Introduction

MADRIX provides several helpful tools for various tasks.

DMX Fader Tool

The DMX Fader Tool provides access to twelve different DMX channels, which you can choose individually. The DMX Fader Tool can be used to send output signals using these DMX channels. This feature can be very useful if you want to test single fixtures individually.

The DMX Fader Tool will overwrite any DMX data that is regularly sent to your LEDs by MADRIX. The Main Output will be overwritten on the particular channels.

- Go to the menu Tools > DMX Fader Tool...
  [Keyboard shortcut: Ctrl+Alt+F]
- **All On** - Activates all 12 channels with one mouse click.
- **All Off** - Deactivates all 12 channels with one click.
- **On** - Activates the channel.
- **Universe** - Defines the DMX universe that will be used.
- **Channel** - Defines the DMX channel that will be used.
- **Fader** - Allows you to control the DMX values from 0 to 255.
- **Value** - Allows you to set up a specific DMX value.
- **Flash** - Sets the value of the channel instantly to 255, the maximum value. Release the Flash button to set the previous value again. In order to work, the value [i.e. the Fader] must be lower than 255.
- **Defaults** - Restores the default values and resets all DMX values and faders back to 0.

**Logfile**

The Logfile keeps track of all warnings and system information.

If you search for an error and are unable to locate the problem, please check the logfile first. This Logfile is also needed for every support request.

- Go to the menu **Tools > Logfile**...
  
  [Keyboard shortcut: **F6**]
- **Level** - Defines which kind of information is shown, including only information, warnings, and errors.
- **Filter** - Allows you to only show specific messages for certain features and topics.
- **Search** - Allows you to enter keywords or text you are looking for.
- **History Limit** - Defines the maximum number of list items.
- **Clear** - Removes all entries from the list [except items that are locked].
- **Save As** - Saves the current list as an external file. All entries logged up to this point will be included.
- **Save And Log** - Creates a file and keeps track of messages until MADRIX is closed. [The button will be shown in green when activated.]
- **Close** - Closes the window.
**Task Watcher**

The Task Watcher is an important monitoring tool that provides detailed technical information, mainly about the performance.

- Go to the menu **Tools > Task Watcher...**
  [Keyboard shortcut: **F5**]

- The Task Watcher is mainly divided into 3 parts.
- You can resize the window according to your needs by dragging the window borders outwards or inwards.

- The first part shows how fluently effects can be rendered:
  - **Deck A** - Shows which effects and Layers are active on Deck A [Effect Pipeline Deck A].
  - **Deck B** - Shows which effects and Layers are active on Deck B [Effect Pipeline Deck B].
  - **Task** - Shows various render tasks that MADRIX manages in the background.
  - **FPS** - Displays the currently rendered frame rate [Frames Per Second] as well as the target frame rate [in brackets ()].
- **Memory (Available / Total)** - Shows the available memory of the computer's RAM as well as the total memory.

- **GDI Object Count (Current / Maximum)** - Shows the current number of graphical objects used for the MADRIX user interface and software as well as the maximum number, which is set in the operating system.

- The second part shows connected devices:
  - **Type** - Displays if the devices is a DMX-based or DVI-based device.
  - **Device** - Displays the name and description of the device.
  - **FPS** - Displays the currently rendered frame rate [Frames Per Second].
  - **State** - Displays if the device is working [Sending or Receiving] or not [?].
  - **Connected DMX Device Count (Active / All)** - Shows the number of connected DMX devices that are active and a total number.

- The third part shows active and occupied Storage Places:
  - **Description** - Displays the Storage Place Description.
  - **Storage** - Displays on which Storage the effect is stored.
  - **Place** - Displays on which Storage Place the effect is stored.
  - **Storage Place Count** - Shows the total number of occupied and used Storage Places.

**DMX Watcher**

The DMX Watcher allows you to monitor your DMX output or DMX input in MADRIX.

- Go to **Tools > DMX Watcher...**
  - [Keyboard shortcut: **Ctrl+Alt+D**]
- **Virtual OUT** - Activates monitoring of data output, which is the data that is created by MADRIX in order to be sent to your hardware.
  - It is the point in time before the data is actually delivered to the DMX hardware.
- **Input** - Activates monitoring of the current data input.
- **Universe** - Defines the DMX universe you are currently looking at. Adjust the number to your requirements!

- **DMX** - Displays data with the help of DMX values [0 to 255].
- **%** - Displays data with the help of percentage values [0 to 100].
- **HEX** - Displays data with the help of HEX values [0 to FF].
- **BAR** - Displays data with the help of graphical bars.

- **Blank** - Leaves the background blank [i.e., black].
- **Lines** - Shows cell borders of the data table.
- **Rows** - Displays a gray background for all rows for better identification.
- **COL** - Displays a gray background for all columns for better identification.
- **Chess** - Displays an alternating, gray background for rows and columns for better identification.

- **Freeze** - Stops refreshing of data. The last data sent or received will be shown.
- **1 Hz** - Defines the refresh rate of how fast data is shown.
- **10 Hz** - Defines the refresh rate of how fast data is shown.
- **50 Hz** - Defines the refresh rate of how fast data is shown. This is the fastest mode.

- New data, i.e. data that was just received or sent will be displayed in green. It fades to gray after a short while, when the data has not changed during that period of time.
- -- is shown when not data is sent or received.

---

**Per 512 DMX channels, 170 RGB fixtures can be controlled. That means, calculating 170 fixtures x 3 color channels results in 510 DMX channels. Therefore, channel 511 and 512 will be left empty, because they are simply not in use.**
MIDI Watcher

The MIDI Watcher allows you to check your MIDI connection when you are using any MIDI device. The MIDI Watcher is a useful tool in order to start your search if problems occur with your MIDI connection.
Go to the menu Tools > MIDI Watcher...
[Keyboard shortcut: Ctrl+Alt+M]

- **Type** - Allows you to specify the type of messages shown.
- **Filter** - Allows you to only show specific MIDI messages.
- **History Limit** - Defines the maximum number of list items.
- **Clear** - Removes all entries from the list.
- **Save As** - Allows you to save the current list into an external file.
- **Close** - Closes the window.

**PLEXUS Configuration**
The PLEXUS Configuration window is an important tool to work with the MADRIX PLEXUS hardware interface.

Learn more » MADRIX PLEXUS

**MADRIX Device Configuration**

The MADRIX Device Configuration window can be used to configure MADRIX LUNA, MADRIX NEBULA, MADRIX STELLA, and MADRIX ORION hardware interfaces.

Learn more » MADRIX LUNA

Learn more » MADRIX NEBULA

Learn more » MADRIX STELLA

Learn more » MADRIX ORION
4.10 Backup System

This topic includes:

- Introduction
- Overview
- Step-By-Step Instructions

Introduction

The MADRIX Backup System is a type of network communication between two or more MADRIX computers in order to set up a reliable backup solution.

- A backup solution should get involved as soon as the main control solution fails.
- Regarding the MADRIX Backup System, so-called keep-alive messages are sent by one MADRIX computer to other computers to check if the connection between the computers is working properly.
- If the Master fails, i.e. if the Master does not send keep-alive messages in a certain time interval [in seconds], the Slave is automatically activated and sends the output data to the LEDs.
- Similarly, the Slave is sending keep-alive messages.
- The MADRIX Backup System works in combination of the Cue List in order to synchronize Master and Slave for backup purposes.

Overview

- Go to the menu Preferences > Backup System...
- A new window will open.
**Step-By-Step Instructions**

1) Make sure that all requirements are met.

2) Set up both computers and the network.

3) Configure the Master.

4) Configure the Slave.

5) Configure the MADRIX Setup and Cue List.

6) Learn about additional hints and

7) Test if all systems are working correctly.

**1] Requirements**

- Make sure that all computers are equipped with a MADRIX KEY [i.e. a MADRIX software license].

- Make sure that all computers are using the same MADRIX software version.

**2] Setup**
Set up both computers and the network according to the instructions below:

**How To Connect Master And Slave**

- You can utilize your network card with an Ethernet port to connect two or more computers using a network switch.
- Set up the IP addresses from the computers like in the picture above.
- Both computers have to be in the same network address area [e.g., 192.168.0.1 to 192.168.0.254].

**Example 1: How To Use The Backup System And Art-Net**
It is recommended to always use two separate networks with two network cards if you want to sync Master and Slave and use Art-Net at the same time.

Minimum requirements for this setup are:
- 2 computers
- 2 Ethernet switches
- 1 or more Art-Net devices
- Ethernet cables
- DMX cables.

Apart from that, both computers need to have two network cards installed. The setup for the first network is 192.168.0.X and the second is 2.0.0.X
- The former will be used as the backup system, the latter is transferring Art-Net data.

Example 2: How To Use The Backup System And Art-Net [Low-Budget Alternative]
In addition, you may use a variation of the example above.

Depending on your installation, it can be possible to do the setup without the second network. It is a smaller budget alternative and in this case only the Art-Net network will be used.

At the same time this means that traffic from both Art-Net and the backup system will be transferred over this single network. In larger installations this might cause network problems due to high data traffic!

Connecting this backup system to the internet is not recommended because problems with the internet connection are likely to occur [such as connection errors, dropouts, etc.]. WiFi-nodes are also not recommended. The Art-Net data will simply interfere with the internet data in the 2.0.0.X network.

If your Art-Net interfaces support the 10.0.0.X network, you may establish an internet connection since the Art-Net data may be blocked by your router and does not interfere with the internet connection.

Such an installation is at your own risk.
Example 3: How To Use The Backup System And USB DMX512 Interfaces

- If you are going to use an USB DMX512 interface, you can work with one network card to sync Master and Slave.
- Minimum requirements for this set-up are:
  - 2 computers
  - 1 Ethernet switch
  - 1 DMX merger
  - 2 DMX512 devices
  - Ethernet cables
  - DMX cables
- Apart from that, both computers need to have a network card installed. The set-up for this network is 192.168.0. X. Only this card/network will be used for the backup system.

3] Configuration Of The Master

Configure the Master using the following options and settings:

- **Enable** - Activates the backup system.
- **Keep-Alive Time (s)** - Defines the time range between keep-alive messages [in seconds]. Valid values range from 0.1 to 25.6. The default and recommended value is 1.1.
  
  [If the network connection is working correctly, you will see Yes in the column Alive. If the connection is lost, you will see Timeout.]

- **Drop-Down List** - Allows you to choose the correct network card if your computer or laptop is equipped with more than one network card.

- **(Local)** - Specifies that this is your local computer on which you are currently working.

- **-** - Allows you to manually remove outdated list entries.

### 4] Configuration Of The Slave

Configure the Master using the following options and settings:

- **Enable** - Activates the backup system.

- **Keep-Alive Time (s)** - Defines the time range between keep-alive messages [in seconds]. Valid values range from 0.1 to 25.6. The default and recommended value is 1.1.

  [If the network connection is working correctly, you will see Yes in the column Alive. If the connection is lost, you will see Timeout.]
• **Drop-Down List** - Allows you to choose the correct network card if your computer or laptop is equipped with more than one network card.

![Backup System](image)

- **(Local)** - Specifies that this is your local computer on which you are currently working.
- **Validate MADRIX KEY** - MADRIX automatically monitors if the MADRIX KEY is plugged into the Master.
- **** - Allows you to manually remove outdated list entries.

Please activate:

- **Receive Sync Commands From Master** - Activates that the computer receives synchronization signals from the Master.

Now, select the Master in the list and click:

- **Change Master** - Allows you to select another computer in the list of found network computer and set this computer as the Master. You are not allowed to select your local computer as Master. You will have to choose a remote computer.

The Master will be activated as Master in the Backup System of the Slave:
The Slave will be activated as Slave in the Backup System of the Master:

Result:

- If the Backup System is activated, the Slave will not output any data as long as the Master is properly connected and alive in the network.
- If the Master is disconnected and receives a timeout, the Slave will start sending data when it receives the timeout message.
5] Setup And Cue List

- Finally, make sure that Master and Slave have the correct configuration of devices, patch, and effects. Ideally, you can load the same MADRIX Setup on both computers.

- Make sure that all computers are using the same Cue List.
  [As a minimum requirement, the number of Cues needs to be identical.]

6] Additional Information

- Please note that the MADRIX Software automatically tries to restart after any unexpected software shutdown or failure.
  - For example, that could mean that your Master comes back up after a crash, while the Slave already overtook.

- Due to this behavior, it might be advisable to further set up the MADRIX Startup Options.
  - For example, go to the menu Preferences > Options... > Startup > Open This Setup and choose the correct MADRIX Setup file via the button ...
  - Enable this option on both, Master and Slave, and choose the same Setup file in both cases.
  - This ensures that a Master which came back also already and automatically loads the correct Setup file.

- Check if any other Startup options may be relevant for your use case.

- Please note further that a Slave does not sync back its position when it overtook.
  - That could mean that your Master starts at a different cue than what your Slave was already using.
  - Using Time Code can soften this issue, but it may not be able to avoid it entirely.

7] Tests

Perform the following tests in order to ensure that all systems are working correctly:

- Test if the Master is controlling the LED installation correctly.

- Test if the Slave is controlling the LED installation correctly.

- Test if the Backup System is working correctly, if the Cue List is being synchronized between Master and Slave, and especially if the Slave is sending data in case the Master is disconnected and receives a timeout.
4.11 File Types

This topic includes:

- Introduction
- MADRIX 5 File Types
- Images And Videos

Introduction

You will come across several file types, while working with the MADRIX Software. This chapter explains which file type belongs to which function or which part of the software.

MADRIX 5 File Types

<table>
<thead>
<tr>
<th>File Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>*.msz</td>
<td>MADRIX Setup</td>
</tr>
<tr>
<td>*.msx</td>
<td>MADRIX Setup Uncompressed</td>
</tr>
<tr>
<td>*.mszbackup</td>
<td>Backup of a MADRIX Setup</td>
</tr>
</tbody>
</table>

Your whole show will be saved. It stores relevant data in one single file; including but not limited to Patch, effects, settings, Cue List, etc. 

Note: Images and videos will not be included in this file, for example.
### Using The Software

<table>
<thead>
<tr>
<th>Extension</th>
<th>Description</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>*.mpz</td>
<td>MADRIX Patch</td>
<td>Stores your Patch. <a href="#">Patch Editor</a></td>
</tr>
<tr>
<td>*.mpx</td>
<td>MADRIX Patch Uncompressed</td>
<td></td>
</tr>
</tbody>
</table>
| *.mfix    | MADRIX Fixture Library | Stores the whole Fixture Library. [MADRIX Fixture Editor](#)  
  **Note:** The madrix.mfix is being overwritten with an updated version every time a new MADRIX version [software update] is installed. |
<p>| *.mfxx    | MADRIX Fixture | Stores one single fixture. <a href="#">MADRIX Fixture Editor</a> |
| *.mstz    | MADRIX Storage | |
| *.mstx    | MADRIX Storage Uncompressed | Stores a complete Storage including all of its Storage Places [i.e., effects]. <a href="#">Storages</a> |
| *.mspz    | MADRIX Storage Place | |
| *.mspx    | MADRIX Storage Place Uncompressed | Stores one single Storage Place, and thereby one effect you created. <a href="#">Storage Places</a> |
| *.mdmxx   | MADRIX DMX Device Settings | Stores all relevant settings for your [connected] DMX devices. <a href="#">OUTPUT Settings</a> |
| *.mdvix   | MADRIX DVI Device Settings | Stores all relevant settings for your [connected] DVI devices. <a href="#">OUTPUT Settings</a> |
| *.mpdx    | MADRIX PLEXUS Device Settings | Stores all relevant settings for a MADRIX PLEXUS interface. <a href="#">MADRIX PLEXUS</a> |
| *.xml     | MADRIX PLEXUS Configuration | Stores a PLEXUS Configuration, i.e. show, for a MADRIX PLEXUS interface. <a href="#">MADRIX PLEXUS</a> |</p>
<table>
<thead>
<tr>
<th>Extension</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>*.mldx</td>
<td>MADRIX LUNA Device Settings &lt;br&gt;Stores all relevant settings for a MADRIX LUNA interface.</td>
</tr>
<tr>
<td>*.mndx</td>
<td>MADRIX NEBULA Device Settings &lt;br&gt;Stores all relevant settings for a MADRIX NEBULA interface.</td>
</tr>
<tr>
<td>*.msdx</td>
<td>MADRIX STELLA Device Settings &lt;br&gt;Stores all relevant settings for a MADRIX STELLA interface.</td>
</tr>
<tr>
<td>*.modx</td>
<td>MADRIX ORION Device Settings &lt;br&gt;Stores all relevant settings for a MADRIX ORION interface.</td>
</tr>
<tr>
<td>*.mmrx</td>
<td>MADRIX MIDI Remote Configuration &lt;br&gt;Stores a MIDI Remote Configuration [MIDI map] for a MIDI controller for the MIDI Remote Editor.</td>
</tr>
<tr>
<td>*.mdrx</td>
<td>MADRIX DMX Remote Configuration &lt;br&gt;Stores a DMX Remote Configuration for DMX-IN for the DMX-IN Remote Editor.</td>
</tr>
<tr>
<td>*.mrec</td>
<td>MADRIX Record &lt;br&gt;Stores recorded effects.</td>
</tr>
<tr>
<td>*.dxd</td>
<td>MADRIX DMX Data &lt;br&gt;Stores DMX data for the MADRIX PLEXUS hardware interface.</td>
</tr>
<tr>
<td>*.mdx</td>
<td>MADRIX Cue List &lt;br&gt;Stores the Cue List and its entries as well as settings.</td>
</tr>
<tr>
<td>*.csv</td>
<td>Comma-Separated Values &lt;br&gt;A file format that can be used for the Cue List or the Fixture List Import of the Patch Editor.</td>
</tr>
<tr>
<td>Ext.</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>*.mgcz</td>
<td><strong>MADRIX Group Control</strong></td>
</tr>
<tr>
<td>*.mgcx</td>
<td><strong>MADRIX Group Control Uncompressed</strong></td>
</tr>
<tr>
<td></td>
<td>Stores the Group Control including fade-in time, Group Presets, and current values.</td>
</tr>
<tr>
<td></td>
<td><strong>Groups</strong></td>
</tr>
<tr>
<td>*.mitz</td>
<td><strong>MADRIX Image Table</strong></td>
</tr>
<tr>
<td>*.mitx</td>
<td><strong>MADRIX Image Table Uncompressed</strong></td>
</tr>
<tr>
<td></td>
<td>Stores an Image Table for the SCE Image effect.</td>
</tr>
<tr>
<td>*.mctx</td>
<td><strong>MADRIX Color Table</strong></td>
</tr>
<tr>
<td></td>
<td>Stores color information [Color Table, Gradient, M2L Color Table, etc.] for various MADRIX effects.</td>
</tr>
<tr>
<td>*.mstrtx</td>
<td><strong>MADRIX String Table</strong></td>
</tr>
<tr>
<td></td>
<td>Stores a String Table including its strings and characters for the SCE Counter effect.</td>
</tr>
<tr>
<td>*.mshtx</td>
<td><strong>MADRIX Shape Table</strong></td>
</tr>
<tr>
<td></td>
<td>Stores a Shape Table for various MADRIX Effects.</td>
</tr>
<tr>
<td>*.mepcz</td>
<td><strong>MADRIX Effect Parameter Chaser</strong></td>
</tr>
<tr>
<td>*.mepcx</td>
<td><strong>MADRIX Effect Parameter Chaser Uncompressed</strong></td>
</tr>
<tr>
<td></td>
<td>Stores an Effect Parameter Chaser including its Step list for a Layer.</td>
</tr>
<tr>
<td>*.msppcz</td>
<td><strong>MADRIX Storage Place Parameter Chaser</strong></td>
</tr>
<tr>
<td>*.msppcx</td>
<td><strong>MADRIX Storage Place Parameter Chaser Uncompressed</strong></td>
</tr>
<tr>
<td></td>
<td>Stores an Effect Parameter Chaser including its Step list for a Layer.</td>
</tr>
<tr>
<td>File Extension</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>*.mgvcz</td>
<td>MADRIX Group Value Chaser</td>
</tr>
<tr>
<td>*.mgvcx</td>
<td>MADRIX Group Value Chaser Uncompressed</td>
</tr>
<tr>
<td>*.mmapx</td>
<td>Map Settings</td>
</tr>
<tr>
<td>*.mfelx</td>
<td>MADRIX File Extension List</td>
</tr>
<tr>
<td>*.log</td>
<td>Log File</td>
</tr>
<tr>
<td>*.mas</td>
<td>MADRIX Script File</td>
</tr>
<tr>
<td>*.macs</td>
<td>MADRIX Script Encrypted</td>
</tr>
<tr>
<td>*.mms</td>
<td>MADRIX Effect Macro</td>
</tr>
<tr>
<td>*.mcm</td>
<td>MADRIX Effect Macro Encrypted</td>
</tr>
<tr>
<td>* WibuCmRaC</td>
<td>MADRIX KEY File</td>
</tr>
<tr>
<td>* WibuCmRaU</td>
<td>MADRIX KEY Update File</td>
</tr>
</tbody>
</table>
Images And Videos

Furthermore, MADRIX supports every image and video type that is supported by your Windows PC. In most cases, a specific video codec needs to be installed on your computer.

- Images
  Examples: *.bmp, *.gif [including animated GIFs], *.jpg, *.png, *.tif, *.tiff
  Learn more » [SCE Image]

- Videos
  Learn more » [SCE Video]

If you are encountering problems using image or video files, please install the required video codec or image codec on your PC.
4.12 Recording

This topic includes:

- Introduction
- Overview
- Initial Configuration
- Main Output Recording
- Cue List Recording
- Record Editing
- SCE Video

**Introduction**

You can use the Recording functionality to create MADRIX Record files [of the file type *.mrec].

This file type can be used in 2 ways:

- **A** *.mrec files can be converted to create Stand-alone Shows for MADRIX PLEXUS. Learn more »[MADRIX PLEXUS](#)
- **B** *.mrec files can be played just like a video using SCE Video [as described in this topic]. Learn more »[SCE Video](#)

**Overview**

There are two locations in the MADRIX Software where you can create records.

- [Main Output Recording](#)
- [Cue List Recording](#)
**Initial Configuration**

**Patching**

Please configure your virtual LED matrix with the help of the »Matrix Generator« or »Patch Editor« to define the correct resolution for your record.

**Options**

Before you start recording, make sure to set up your required frequency [FPS] in the Options.

Learn more »Recording

**Main Output Recording**

**Overview**

You can find the Main Output Recording directly on the main user interface.
As the name implies, you will record everything from your Main Output. This will include any crossfades, effect changes, brightness changes, etc.

**Important Note**
Only the Main Output will be recorded. Make sure that your content is displayed on Preview Output before you start to record.

How To Record

- **Left Mouse Click** - Click **REC** in order to start the recording process.
  - The context menu allows for more options. Learn more below.
  
  ![REC button]

- The button will now pulsate in red and a new window will open to see more details.
  
  ![Main Output Recording window]

  - **State** - Shows the current status of the recording process [**Started**,** Stopped**].
  - **FPS** - Shows the currently set recording frequency in Frames Per Second. Learn more » [Recording]
  - **Duration** - Shows how long the record currently is in **HH:MM:SS:FF** [hours:minutes:seconds:frames].
  - **Frame Count** - Shows the total number of single frames that has been recorded and created.
  - **Key Frame Count** - Shows the total number of frames that differ from each other. The MADRIX Software will automatically optimize the file size of records if recorded frames are identical. Hence, the total number of frames can be different to the number of recorded key frames. For example, a color change [without a fade] might use only two colors. In this case, the record may have 400 frames in total, but just 2 key frames.
  - **Buffer Usage** - Shows the status of the temporary storage.

- **Left Mouse Click** - Click **REC** a second time in order to stop the recording process.

- Please wait a few seconds to let the software process the data. You will be asked for the location to store the record file on your hard driver as well as a name for the file. Click **Save** in order to confirm.
If needed, you can edit your records after the initial recording process. Learn more below.

**Context Menu**

- **Right Mouse Click** - Click **REC** in order to call up the context menu.

  - **Set Duration...** - Allows you to set a specific time that the record should last.
  - **Watch...** - Calls up the **Main Output Recording** window again for more details.
  - **Cancel** - Aborts the recording process without asking you to save the file.

**Cue List Recording**

**Overview**

The Cue List Recording features are part of the Cue List.

You can open the Cue List in 3 ways:

- Go to the menu **Tools > Cue List**...
- Or press **F7**
- Or click **Layer Control > Cue List** on the user interface.
Important Note

- Make sure to create a **Cue List** first. Otherwise, **Cue List Recording** is not available to you.
- All cues need to have a **Duration** set.
- Learn more »[Cue List](#)

How To Record

- **From** - Defines the cue to start with. Enter the desired value. The default value is 1.
- **To** - Needs to be activated first. Allows to set the last cue to record to and thus create a range from cue to cue. If deactivated, the recording will automatically stop at the last cue.
- **Left Mouse Click** - Click **REC** in order to start the recording process.
• The button will now pulsate in red and a new window will open to see more details.

- **State** - Shows the current status of the recording process [Started, Stopped].
- **FPS** - Shows the currently set recording frequency in Frames Per Second. Learn more »Recording
- **Duration** - Shows how long the record currently is in HH:MM:SS:FF [hours:minutes:seconds:frames].
- **Frame Count** - Shows the total number of single frames that has been recorded and created.
- **Key Frame Count** - Shows the total number of frames that differ from each other. The MADRIX Software will automatically optimize the file size of records if recorded frames are identical. Hence, the total number of frames can be different to the number of recorded key frames. For example, a color change [without a fade] might use only two colors. In this case, the record may have 400 frames in total, but just 2 key frames.
- **Buffer Usage** - Shows the status of the temporary storage.

• The software will automatically stop the recording process according to your settings.

• Please wait a few seconds to let the software process the data. You will be asked for the location to store the record file on your hard driver as well as a name for the file. Click **Save** in order to confirm.

• If needed, you can edit your records after the initial recording process. Learn more below.

**Context Menu**
- **Right Mouse Click** - Click **REC** in order to call up the context menu.

- **Watch**... - Calls up the **Cue List Recording** window again for more details.
- **Cancel** - Aborts the recording process without asking you to save the file.

**Record Editing**

**Overview**

- Go to the menu **Tools > Record Editing**...
  [Keyboard shortcut: **Ctrl+Alt+R**]

- A new window will open.
This section allows you to work with your record files.

**Directory**
- Defines a directory on your harddisk/computer. All record files will be saved in this folder.
- By default, a useful folder is automatically already chosen for you [For example C: \Users\USERNAME\Documents\MADRIX\records].
- Use ... to choose a different folder.

**Filter**
- Simply enter a name/word and the filter will only show files that include these characters in their file name. Delete any input to show all files again.

**List**
- Files, i.e. records, will be displayed in the large list of the Recording window. If you did not create any records yet, the list is empty [as shown above].
- Shows all MADRIX Record files [of the file type *.mrec] in the list that could be found in the specified directory. When activated, the button is green. Disable the option to hide all Record files.

- Show all DMX Data files [of the file type *.dxd] in the list that could be found in the specified directory. When activated, the button is green. Disable the option to hide all DMX Data files.

- Refreshes the list of records. Please make sure to select your preferred records directory first.

**File**
- Shows the name of the record and its file type [of the file type *.mrec or *.dxd]. Double-click on the list entry to change the name of the file.

**Date - Time**
- Shows the time and date when the record was created.

**Matrix Size**
- Shows the size of the virtual matrix [Matrix Size] used for this record. Learn more »[Patch Editor](#)

**Duration**
- Shows the length of the record, i.e. how long it is. The format is HH:MM:SS:FF [Hours: Minutes:Seconds:Frames].

**KF**
- Stands for Key Frames. MADRIX will automatically optimize the file size of records if recorded frames are identical. Hence, the total number of frames can be different to the number of recorded key frames. For example, a color change [without a fade] might use only two colors. In this case, the record may have 400 frames in total, but just 2 key frames.

**FPS**
- Stands for Frames Per Second. Shows the number of frames recorded per second of the record file.

- Deletes selected files from your harddisk. You can also use the Del key on your keyboard.

**File Information**
- Select a file in the list.
Go to the tab **File Information** to show detailed information about the record file you have created.

![File Information Tab](image)

**Record Editing**

After creating a record, you can edit the record.

- Select your Record file in the list.
- Select the tab **Record Editing**
A small preview window is provided in the lower left to inspect the record.

**Please note:** If you see the message *INO MADRIX 5 KEY!* in the preview window and a rotating cross, that means that you are using MADRIX in demo mode. However, this is no problem. Your record will NOT include this text!

Use the provided controls to edit your record:

- Use the slider to select a specific frame.
- Use the small, white triangles to manually set up the In Frame [start frame] and the Out Frame [end frame] for the record.
- This field displays the current frame that is also shown in the small preview window. Enter a number to jump directly to this frame.
- Start or stop the preview playback.

- Rewind or forward one frame per click.

- Skip directly to the In Frame or the Out Frame.

- Skip to the beginning or the end of the record.

- Enter a number or use the slider to select a specific frame. Then, use the $button to set the In Frame [start frame].

- Enter a number or use the slider to select a specific frame. Then, use the $button to set the Out Frame [end frame].

- MADRIX will search the Record File in order to find a segment that is loopable. It will automatically set the In Frame and Out Frame afterwards. Use the button Export to export your loop. Before that, you can also insert Blend Frames.

- Insert Blend Frames into your record if you want to.
  - First, enter the number of frames you wish to use. This defines the length.
  - Second, choose the fade mode [XF: Cross-Fade, WF: White-Fade, BF: Black-Fade, Learn more »Crossfader And Main Output].
  - Third, click Blend.
  - Fourth, use Play/Pause to preview the edited record.
  - Fifth, use the button Export to export your loop.

**Note:** The beginning of your record will be cut by the defined frame number. This is indicated by a red line below the slider.

Example: If you enter 100 frames, MADRIX will create the fade using the first 100 frames and the last 100 frames. Those frames will blend into each other. To have a smooth fade, the record is then cut by 100 frames and starts at frame 101.
Use this button to export the edited record. Choose a name in the second step.

PLEXUS Conversion

- Use this tab to convert MADRIX Record files [of the file type *.mrec] into DMX Data files [of the file type *.dxd].
- A MADRIX KEY with a valid MADRIX 5 License is required in order to use this feature!
  Learn more »MADRIX PLEXUS

SCE Video

Follow these steps to play back a record file in SCE Video:
1] Select the effect SCE Video.

2] The controls of the SCE Video effect become available as a result.

3] Load your MADRIX Record file [of the file type *.mrec].

Use Open and select the file you wish to play.
4] The SCE Video effect will play your Record File.

Recording

Overview

- Go to the tab **Recording** to create a new record.

**Step 1**

- Click **Start** to start recording. MADRIX will begin to record the Main Output.

**Note:**
- When recording without a Cue List, you can change Storage Places, use the crossfader, change the Opacity, use the Master, etc. in order to customize your record.
- When creating a Record file to be played via SCE Video, SCE Video will ignore intensity changes by the Master. However, a Blackout will be recorded and played back as such by SCE Video.
Step 2]

- Various information will be displayed during recording.
  - **Duration** - Is displayed in HH:MM:SS:FF [Hours:Minutes:Seconds:Frames].
  - **Frames** - Displays the total number of recorded frames.
  - **Key Frames** - Displays the number of key frames. MADRIX will automatically optimize the file size of records if recorded frames are identical. Hence, the total number of frames can be different to the number of recorded key frames. For example, a color change [without a fade] might use only two colors. In this case, the record may have 400 frames in total, but just 2 key frames.
5 Options

This topic includes:
- Introduction
- Topics Of This Chapter

Introduction

You can set up specific options for MADRIX.

To ensure optimal operation, we highly recommend to set up MADRIX Options.

Topics Of This Chapter

MADRIX Options include the following topics:
- »Startup
- »General
- »Devices USB
- »Devices Network
- »User Interface
- »Recording
- »Previews
- »Performance
5.1  **Startup**

**This topic includes:**
- Overview
- Options
- Important Notes

---

### Overview

MADRIX provides various settings to choose which features should be enabled when the software or your computer starts.
Go to the menu **Preferences > Options... > Startup**

[Keyboard shortcut: **Ctrl+Alt+O > Startup**]

- Set up the options as explained below.

**Options**

- **Start MADRIX After Booting Windows** - Starts MADRIX automatically once you log in into Windows.

- **Start With Timeout (s)** - Starts the software with a delay. You can define a time frame in seconds. MADRIX will not fully start until the time has passed.
  A new loading window will appear before the software starts. It shows a countdown and 2 options:
  - **Start Now** - Start the software immediately.
  - **Cancel Startup** - Cancels the startup and MADRIX will not be launched.

This timeout is particularly useful when using network devices with MADRIX. Windows needs some time to initialize such devices first. But MADRIX might be already loaded completely and as a result may not detect the devices. This option prevents that.
- **Load Alternative Fixture Library** - Automatically loads a separate MADRIX Fixture Library and not the default library provided by MADRIX.
  - Choose the file via the button ...
  - Learn more »[Fixture Editor](#)

- **Open This Setup** - Automatically loads a specific MADRIX Setup File.
  - Choose the file via the button ...

  **Start Cue List After Loading The Start Setup** - Is only available when Open This Setup is activated. Automatically starts the Cue List once your Setup File has been loaded [if a Cue List has been included by you in the Setup File]. Automatically disables Open Touch Window since the Touch Window cannot be opened when the Cue List is running.

- **Open Touch Window** - Loads the Touch Screen interface when MADRIX starts. Automatically disables Start Cue List After Loading The Start Setup since the Touch Window cannot be opened when the Cue List is running. Learn more »[Touch Screen](#)

- **Check For Software Updates** - Automatically searches for software updates. This requires an internet connection.

---

**Important Notes**

- All *Startup options* will be saved locally on your computer. These settings will not be saved in your MADRIX Setup file.
5.2 General

This topic includes:

- Overview
- File Watcher
- File Recovery
- Important Notes

Overview

- Go to the menu Preferences > Options... > General
  [Keyboard shortcut: Ctrl+Alt+O > General]

- Set up the options as explained below.
File Watcher

Overview

MADRIX can automatically and regularly reload a Cue List within a pre-defined refresh time.

- Activate **Reload This Cue List Upon External Changes**
- Select the Cue List file via the button ...
- Enter the **Refresh Time (min)** in minutes.

Usage

The File Watcher with its Automatic Cue List Reloading feature is very useful if you are using an external program that creates a Cue List in the *.csv file format.

- If this Cue List is changed, you are easily able to access the new Cue List without modifying settings within MADRIX.
- In order to work with this feature, simply create a new Cue List, save it using the *.csv file format and open the file with a text editor or other appropriate software.
- MADRIX can save its Cue List also in *.csv file format.

Here is an example with two Cue List entries:

```
MADRIX;CSV;CUELIST;FILE;;;;;;;;;;;;;;;;;;
VERSION;50593792;;;;;;;;;;;;;;;;;;
TIMECODE FORMAT;1;TIMECODE SOURCE;0;;;;;;;;;;;;;;;;;
CUE;DESCRIPTION;DATE;TIMECODE;DURATION;FOLLOW CUE;STORAGE;PLACE;FADETYPE;FADETIME;R;G;B;W;GROUP PRESET
1;"Color Scroll";"Daily";-1;180000;0;0;0;1;2.00;0;0;0;0;0;
2;"Red";"Daily";-1;266000;0;2;0;1;2.00;0;0;0;0;0;
```
**File Recovery**

MADRIX can automatically create a backup copy of your MADRIX Setup file whenever you choose to save your Setup file. That means, before the new Setup file is saved, the previous state will be stored as a backup. [Should the saving process fail, you can access your Setup file again in the state it was saved last.]

- **Setup File Backup Count** - Sets the maximum number of backup files that are created. The default value is 10. [MADRIX creates separate copies to minimize the chance that a valid backup is overwritten by an invalid Setup file.]
- **Save Backup Files To Specific Directory** - Enable this option if you want to set up a specific directory where the backup files should be stored. This can be external drives. If this option is disabled, MADRIX will save the backups in the same directory as the Setup files.
  - Choose the directory via the button ...
  - By default, MADRIX automatically chooses a user directory for Setup files.

MADRIX will save a backup in the following way:

```
Filename_Date_Time.msz.msbackup
```

In order to restore a Setup file, remove `.msbackup` from the file name. The restored Setup file should then have a name, such as `Filename_Date_Time.msz`
Important Notes

- All General options will be saved locally on your computer. The settings described in this topic will not be saved in your MADRIX Setup file.
5.3 Devices USB

This topic includes:
- Overview
- Supported MADRIX Devices
- Supported Third-Party Devices
- Further Configuration
- Important Information

Overview

MADRIX allows to activate or deactivate drivers for various hardware interfaces, such as MADRIX NEO and others.

- Go to the menu Preferences > Options... > Devices USB
  [Keyboard shortcut: Ctrl+Alt+O > Devices USB]

- Activate the required drivers for your hardware interfaces.
[When activated, MADRIX automatically searches for supported devices at startup.]

### Supported MADRIX Devices

- [MADRIX USB ONE](#)
- [MADRIX NEO](#)
- [MADRIX PLEXUS](#)
- [MADRIX LUNA](#)
- [MADRIX NEBULA](#)
- [MADRIX STELLA](#)
- [MADRIX ORION](#)
- [MADRIX I/O](#)
- [MADRIX USB SMPTE](#)

### Supported Third-Party Devices

MADRIX also supports a number of 3rd-party interfaces.
Learn more » [GamePort](#)

### Further Configuration

Further configuration is needed:

- Devices USB only activates the required drivers.
- Make sure to enable and configure your hardware interfaces also according to your requirements. Learn more »[DMX512][DMX-OUT]

Important Information

- If you only activate drivers for devices which you are effectively going to use,
  - you can speed up the loading/starting time of MADRIX.
- All options of Devices USB will be saved locally on your computer. The settings described in this topic will not be saved in your MADRIX Setup file.
5.4 Devices Network

This topic includes:
- Overview
- Further Configuration
- Important Notes

Overview

MADRIX allows to activate or deactivate drivers or network communication protocols for various products.

- Go to the menu Preferences > Options... > Devices Network
  [Keyboard shortcut: Ctrl+Alt+O > Devices Network]
  
  ![Options Window]

- Activate the required drivers.

- [When activated, MADRIX automatically searches for supported devices at startup.]
You can enable the following network drivers here:

- **Philips Color Kinetics - KiNET**
- **inoage - MADRIX** [for MADRIX LUNA, MADRIX NEBULA, MADRIX PLEXUS, MADRIX STELLA, and MADRIX ORION]
- **MA Lighting - MA-Net**
- **ESTA - Streaming ACN**
- **Capture - CITP**
- **Philips - Hue**

**When activating a driver, please always make sure that you have selected the correct network card.**

### Further Configuration

Further configuration is needed:

- Devices Network only activates the required drivers and often the corresponding network card.
- Make sure to configure your hardware interfaces also according to your requirements.

Learn more

- [Philips Color Kinetics](#) [KiNET](#)
- [MADRIX LUNA](#)
- [MADRIX NEBULA](#)
- [MADRIX PLEXUS](#)
- [MADRIX STELLA](#)
- [MADRIX ORION](#)
- [MA-Net](#)
Important Notes

- Only activate the drivers you require. In this way, you can speed up the loading/starting time of MADRIX.

- All options of Devices Network will be saved locally on your computer. The settings described in this topic will not be saved in your MADRIX Setup file.
5.5 **User Interface**

This topic includes:

- Overview
- General
- Cue List
- Thumbnails
- Touch
- Important Notes

---

**Overview**

- Go to the menu *Preferences > Options... > User Interface*

  [Keyboard shortcut: *Ctrl+Alt+O > User Interface*]

- Set up the options as explained below.
General

- *Show Menu In Full Screen Mode* - Allows you to display or hide the menu bar in full screen mode.
  Learn more »[Full Screen Mode](#)

Cue List

You can choose how MADRIX manages the user interface when playing back the Cue List.
Learn more »[Cue List](#)

Thumbnails

MADRIX provides thumbnails to preview Storage Places and their included visuals on the main user interface »[Storage Places](#) as well as on the touchscreen interface »[Touch Screen](#). Since these buttons are usually square-like, it depends on the aspect ratio of your virtual matrix how much button space is used. When using a very rectangular matrix, the thumbnail is often shown very wide, but not very high. You can change that and activate the option to stretch the thumbnails to the full button size.

- *Stretch*

For example:

- **Stretch Activated**
- **Stretch Deactivated**
Please note: According to the way thumbnails are generated, your thumbnails need to be up to date before the stretch option is applied. They will be updated when switching to another Storage Place to always show the last visual state.

**Touch**

MADRIX features a special Touch Screen window to control the software via a touch screen panel. You can set up certain options for this extra panel.

Learn more » [Touch Screen](#)
Important Notes

- All options of User Interface will be saved locally on your computer. The settings described in this topic will not be saved in your MADRIX Setup file.

5.6 Recording

This topic includes:
- Overview
- General
- Important Notes

Overview

MADRIX provides settings for the different recording features [Main Output Recording and Cue List Recording].
Go to the menu *Preferences > Options... > Recording*

[Keyboard shortcut: *Ctrl+Alt+O > Recording*]

- Set up the options as explained below.

**General**

- **FPS** - Defines the frequency with which records are recorded [in Frames Per Second].
  - **D** - Restores the default settings. The default value is 33.3 FPS.

**Important Notes**

- All *Recording* options will be saved locally on your computer. These settings will not be saved in your MADRIX Setup file.
5.7 Previews

This topic includes:
- Overview
- General
- 2D Mode / DVI Map Mode
- 3D Mode
- Important Notes

Overview

- Go to the menu Preferences > Options... > Previews
  [Keyboard shortcut: Ctrl+Alt+O > Previews]

- Set up the options as explained below.
General

- **Use V-Sync** - Activates the Vertical Synchronization function of your graphics card for your display monitor or output device. V-Sync is deactivated by default. This is mainly useful when screen-capturing a DVI output window.

- **FPS** - Allows you to manually set the frame rate of the 3 Previews and 2 External Previews [in Frames Per Second].
  - A higher number of frames generates smoother results, but requires much more computer performance.
  - This option can be set independently of V-Sync. But if V-Sync is activated, the maximum frame rate will be set by the highest possible V-Sync frame rate of your monitor or output device, even if you entered a higher number.
  - D - Restores the default settings. The default value is 50.0 FPS.

2D Mode / DVI Map Mode

You can influence how the Previews display your effects. By changing the grid proportions, you can influence the size of the displayed pixels.

- **Grid Proportion X (%)** - Defines the horizontal space between pixels in the Previews.
  - D - Restores the default settings. The default value is 20%.

- **Grid Proportion Y (%)** - Defines the vertical space between pixels in the Previews.
  - D - Restores the default settings. The default value is 20%.

- These settings only work for the Previews in 2D Mode [as well as DVI Map Mode for the External Previews].

  20% Grid Proportion [Default] 99% Grid Proportion [Example]
3D Mode

The following settings only work for Previews in 3D Mode. Learn more » 3 Previews

In this way, you can better adjust the display mode to the physical layout of your LED fixtures.

- **Voxel Pitch X** - Defines the horizontal spacing factor between voxels in the Previews [as multiple of the voxel size]. A value of 1 means that there is no spacing.
  - *D* - Restores the default settings. The default value is 5.

- **Voxel Pitch Y** - Defines the vertical spacing factor between voxels in the Previews [as multiple of the voxel size].
  - A value of 1 means that there is no spacing.
  - *D* - Restores the default settings. The default value is 5.

- **Voxel Pitch Z** - Defines the spacing factor between voxels in the Previews regarding the depth [as multiple of the voxel size]. A value of 1 means that there is no spacing.
  - *D* - Restores the default settings. The default value is 5.

- **Voxel Shape Type** - Changes how voxels are shown in the Previews. Choose from 4 different types [Square, Circle, Cube, Sphere].
  - Square and Circle are flat 2D shapes, while Cube and Sphere show voxels as actual 3D shapes.
  - The default value is Cube.
  - Voxel Shape Tape Square offers the highest performance, then Circle, then Cube, then Sphere.
Important Notes

- All options of *Previews* will be saved locally on your computer. The settings described in this topic will not be saved in your MADRIX Setup file.
5.8 Performance

This topic includes:
- Overview
- Main Mixing
- Rendering
- Virtual DMX Universes
- Important Notes

Overview

- Go to the menu Preferences > Options... > Performance
  [Keyboard shortcut: Ctrl+Alt+O > Performance]

- Set up the options as explained below.
Main Mixing

MADRIX includes effect generators and graphics render engines. Rendering is done in FPS [Frames Per Second].

- **FPS** - Defines the frame rate of the Main Mixing, the high-level render process. Normally you do not need to change this setting.
  
  D - Restores the default settings. The default value is 50.0 FPS.

- **Only change this value if it is really necessary!**

- **Suspend DMX Output On Output Value 0** - Stops sending DMX data if the master is set to 0 or blackout is activated.

  Delay (s) - Defines the remaining time in seconds that DMX data is sent based on the main mixing frame rate.

  D - Restores the default settings. The default value is 0.5 s.

Rendering

This performance setting refers to the overall rendering process in MADRIX.

- **Included Voxels** - Defines which voxels of the virtual LED matrix will be included in the rendering process. You can choose from 2 modes:

  All - Includes all voxels of the virtual LED matrix as defined by the Matrix Size in the Patch Editor. This includes all voxel positions with placed fixtures or without placed fixtures. Learn more »[Patch Editor](#)

  Patched Only - Includes only voxels where fixtures are patched. Voxel positions where no fixtures are patched will be excluded from the rendering process. [This can improve the overall performance considerably.]

  D - Restores the default settings. The default value is Patched Only.

Virtual DMX Universes
**Output** - Defines the number of virtual universes which MADRIX can address.
- Change this value if you need to use more virtual universes than actual DMX universes in your Patch.
- It is possible to use more virtual DMX universes than actual DMX universes by using less than 512 DMX channels per universe.
- The maximum value is 2048.
- It is recommended to set up the value that you are actually using in order to save memory.
  - *D* - Restores the default settings. The default value is 2048 DMX universes.

**Please remember that your MADRIX KEY [MADRIX product] limits the number of actual DMX universes available for output.**

»MADRIX KEY [Software License]

**Input** - Defines the number of universes which MADRIX can use for input [Preferences > Device Manager... > DMX Input].
- *D* - Restores the default settings. The default value is 8 DMX Input universes.
- Learn more »DMX-IN / Art-Net Remote / sACN Input

- Please restart the MADRIX Software if you have changed any settings.

**Important Notes**

- All options of Performance will be saved locally on your computer. The settings described in this topic will not be saved in your MADRIX Setup file.
PART F
OUTPUT Settings
You need configure the output that MADRIX should use.

There are several ways on how MADRIX controls LEDs. Please collect information on how MADRIX can communicate with your LED products. MADRIX supports a lot of well-known industry standards. In the following chapters each output method will be explained.

- **DVI**
- **Art-Net [DMX over Ethernet]**
- **DMX512 [DMX-OUT]**
- **Philips Color Kinetics [KiNET]**
- **ESTA - Streaming ACN [sACN / E1.31]**
- **Proprietary DVI Devices [5A / A8 / T9]**
- **Philips Hue**

### MADRIX Hardware Products

The MADRIX range of products includes several hardware interfaces.

- **MADRIX USB ONE**
Supported 3rd-Party Interfaces

In addition to MADRIX hardware products, the MADRIX software supports a number of 3rd-party interfaces. Learn more »Support DMX512 And Art-Net Interfaces

Restrictions Of Demo Mode

MADRIX can run in demo mode. For this reason, there are limitations to the available output. Learn more »MADRIX KEY [Software License]
6.1 DVI

This topic includes:
- Introduction
- Topics Of This Chapter

Introduction

MADRIX offers DVI output.
DVI output is useful when using a video beamer, a DVI wall, the software LED Studio, on-screen capturing, or when using it in similar fields of application.

The term DVI does not refer to DVI only.
DVI output in MADRIX can also be used for VGA, HDMI, and other graphic card output ports.

Topics Of This Chapter

- »DVI
- »DVI Examples
6.1.1 DVI

This topic includes:
- Overview And Usage
- Restrictions Of Demo Mode
- Configuration Of Microsoft Windows
- Initial Setup
- DVI Outputs
- Step-By-Step Configuration
- Slice Alignment
- More Information
- Switching Screens In Full Screen Mode
- Scaling
- Further Configuration
- Important Information

Overview And Usage

MADRIX can control DVI-based LED products.
DVI output is particularly useful when using a video beamer [VGA or DVI, for example], a DVI video wall, the software LED Studio, on-screen capturing, or in similar fields of application.

All MADRIX 5 KEYS support DVI output:
**MADRIX KEY start**

- Supports up to 4,096 native DVI voxels.
- Render resolution example: 64 x 64 voxels.

**MADRIX KEY entry**

- Supports up to 16,384 native DVI voxels.
- Render resolution example: 128 x 128 voxels.

**MADRIX KEY basic**

- Supports up to 262,144 native DVI voxels.
- Render resolution example: 512 x 512 voxels.

**MADRIX KEY professional**

- Supports up to 1,048,576 native DVI voxels.
- Render resolution example: 1,024 x 1,024 voxels.

**MADRIX KEY ultimate**

- Supports up to 2,097,152 native DVI voxels.
- Render resolution example: 2,048 x 1,024 voxels.

**MADRIX KEY maximum**

- Supports up to 2,097,152 native DVI voxels.
- Render resolution example: 2,048 x 1,024 voxels.

- Stretching and scaling to lower or higher resolutions is possible.
- Please pay attention to other restricting factors, such as hardware limitations.

Learn more »[System Requirements](#)

---

**Restrictions Of Demo Mode**

- If you do not connect a MADRIX KEY, the MADRIX Software will run in demo mode.
- In demo mode, every single feature will be available to you. Only the data output is restricted:
  - DVI output is overlaid by a colorful, rotating grid/cross.
  - You can see 'NO MADRIX 5 KEY'.
  - Learn more »[MADRIX KEY [Software License]](#)

---

[www.madrix.com](http://www.madrix.com)
Configuration Of Microsoft Windows

When using DVI output, make sure to configure the graphic card outputs in Windows first!

- In Windows 7, go to Start > Control Panel > Display > Change display settings
- In Windows 10, go to Start > Settings > System > Display
- Windows shows all detected graphic card output ports
  - Click Detect to search for undetected outputs.
- Resolution - Defines the pixel resolution of this output port.
  [When working with DVI, it is often necessary to position the DVI output precisely and exactly where needed. The resolution is an important information that helps you set up your DVI output.]
- Multiple displays - Defines the display mode. The recommended setting is Extend these displays
- Confirm any changes with Apply
- Close the window with OK
Initial Setup

Make sure to configure your virtual LED matrix in MADRIX before using DVI output.

Configuration of the virtual LED matrix is a requirement!

You can use the Matrix Generator or the more advanced Patch Editor for this task.
Learn more » Matrix Generator or Patch Editor
DVI Outputs

MADRIX features 2 DVI outputs.

- **External Preview 1**
- **External Preview 2**

Moreover, there are 3 modes available for DVI output:

- **DVI**
- **Window**
- **FullScreen**

- **DVI** - Activates a floating, borderless DVI window. This is the most important DVI output. It is especially useful when using on-screen capturing. A well known example is the software LED Studio, which uses screen capturing.
- **Window** - Opens a floating window with a border. This might be a useful option if you choose to use DVI output as an additional preview window.
- **FullScreen** - Enables a floating, borderless full screen window to fit the entire output device. This is particularly useful for output devices, such as projectors, beamers, monitors, and large TV screens.

- Often, 1 DVI output will be enough for your LED project. But in certain cases you might need 2 DVI outputs [for example when your DVI video processor needs 2 inputs to drive a large number of pixels].
- If you do not need the second DVI output, you may simply use it as another preview window or not use it at all.

Step-By-Step Configuration

1] Activate DVI Output.
2] Configure DVI Options.
3] Configure External Window Settings.
1] Activating DVI Output

To activate DVI output:

- Go to the menu Previews > External Preview 1 > DVI
- Or choose Previews > External Preview 1 > Window
- Or choose Previews > External Preview 1 > Full Screen

To activate the second DVI output:

- Go to the menu Previews > External Preview 2 > DVI
- Or choose Previews > External Preview 2 > Window
- Or choose Previews > External Preview 2 > Full Screen

2] DVI Options

Each of the DVI outputs has a context menu.

This menu makes various options available to you for External Preview 1 and External Preview 2, respectively.

**Note:** Should an option be grayed out, it is not available at this moment or for this particular DVI output.

- Go to the menu Previews > External Preview 1
  [or Right Mouse Click on the DVI window]
- **DVI** - Is explained above.

- **Window** - Is explained above.

- **FullScreen** - Is explained above.

- **External Preview Settings...** - Opens a new window with very useful and important settings for DVI output. Learn more [External Preview Settings](#).  

- **Lock Position** - Locks the DVI output to the current position. It cannot be moved around with the mouse anymore. You can still change the position in the External Window Settings.

- **Keep Always On Top** - Brings the DVI output in front of all other windows at all times. No other window will overlap the DVI output.

- **Move To Next Screen** - Moves the output to the next monitor or graphics card output port. This option is only available for **FullScreen**. Learn more [Switching Screens In Full Screen Mode](#).

- **3D Mode** - Activates the 3D mode for the output. This option is only available for **Window** and **FullScreen**.
- **2D Mode** - Activates the 2D mode for the output. This is the default mode.

- **Stretch Pixels** - Scales the content to the maximum size of your preview window. This option is only available for *Window* and *Full Screen*

- **Show Status Information** - Displays extra information of the DVI output, such as the size of the matrix or the frame rate. This option is only available for *Window* and *Full Screen*

- **Show Clock** - Shows the time on the DVI output. This option is only available for *Window* and *Full Screen*

- **Show Grid** - Overlays the DVI window with a grid to show the individual pixels. This option is only available for *Window* and *Full Screen*

- **Show Pivot Element** - Displays a helpful icon for visual guidance. Three arrows are always shown at position X=0, Y=0, Z=0 [not matter if the Preview is rotated]. The X-axis is red [horizontal; width], the Y-axis is green [vertical; height], and the Z-axis is blue [level; depth]. This option is only available for *Window* and *Full Screen*

- **Show Background Image...** - Allows you to use a picture instead of the gray background. This option is only available for *Window* and *Full Screen*

- **Default View** - Choose your point of view and the default view for this output. This option is only available for *3D Mode*

- **Restore Default View** - Resets the Preview to its Default View. This removes any changes, such as zoom or relocation.

- **Close** - Closes the DVI output.

### 3] External Preview Settings

External Preview Settings are an important part of the DVI output configuration!

- Go to the menu *Previews > External Preview 1 > External Preview Settings...*
  
  [or *Right Mouse Click* on the DVI window > *External Preview Settings...* ]
- **DVI Window Position** - Defines the exact position of the DVI output for DVI
  - The coordinate system used for this starts with 0,0 at the top left of the entire screen/monitor. In this way, Left: defines the X coordinate and Top: represents the Y coordinate.
  - Valid values range from -10,000 to 10,000.
- **DVI Window Size** - Determines the actual size of the DVI output for DVI
  - Activate Use Display Area Size to set the size of the window to the settings of Display Area, which determines what is shown of your matrix.
  - Using different values for Width and Height than the maximum size of the Display Area will stretch or compress the content [you can make the window size smaller or bigger, but the pixel resolution will stay the same resulting in an image that is stretched or compressed.
  - The pixel resolution is set using the »Matrix Generator or »Patch Editor».
- **Display Area** - Defines what is shown in the DVI output. This option is available for all 3 DVI output modes.
  - Activate Use Full Size and your complete LED matrix will be displayed. Or you can select a certain cut-out and specify which details of your matrix will be shown. You can choose the start coordinates and the end coordinates of this area.
  - Left and Top define the start coordinates in a coordinate system that starts with 0,0 in the top left corner. For example, for the default matrix with 50x50 pixels, Left and Top are 0 by default and Right and Bottom are 49, by default.
  - Right and Bottom define the end coordinates. The end coordinates cannot be higher than the full size of the matrix. For example, for the default matrix with 50x50 pixels, Left and Top are 0 by default and Right and Bottom are 49, by default.
- **Slice Alignment** - Is particularly relevant when using 3D and DVI-based LED fixtures that require a 2D input signal. This option is available for all 3 DVI output modes. Learn more Slice Alignment
**Display Transformation** - Allows you to flip or rotate the DVI output. This option is available for all 3 DVI output modes.
- **None** does not flip the output, **Flip H** flips it horizontally, **Flip V** flips it vertically, **Flip HV** flips it horizontally and vertically.
- Rotate the output by 0° degrees [no rotation], 90° degrees, 180° degrees, or 270° degrees clock-wise. This rotation applies to the Display Area.

- Click **Apply** to confirm your changes. Click **OK** to close the window.

**Defaults** - Restores the default settings. [These settings represent a standard 1:1 DVI window.]
- If you have set up custom settings, MADRIX will show a check mark in front of **External Window Settings**... in the menu.

---

**Slice Alignment**

**3D Mapping For DVI**

- MADRIX can control 2D projects as well as 3D projects.
  Learn more »[2D Or 3D](#)

- The chapters »[Patch Editor](#) and »DVI Patch already explained that DVI-based fixtures are often used in combination with a DVI controller. Such a DVI controller might require to receive the incoming single in a specific way to receive the correct image on the LEDs. This is true for 2D and controlling a 3D project adds further complexity.

- DVI controllers usually do not accept any 3D input image. That is why, you will often need to send a 2D signal to the DVI controller, even though your project might be in 3D.

- MADRIX can create **Slices** to produce such a 2D signal for 3D projects.

- By default, each Z-level is placed beside the previous Z-level from left to right.

- You can change the Slice Alignment for **DVI, Window**, and **FullScreen**.

---

**Example**
- The following example was chosen to explain Slice Alignment and 3D mapping for DVI.
- A virtual LED matrix of 15x8x3 is used.
- The first Z-level is the brightest, while the second and third Z-level have their Opacity increasingly reduced.
- A color gradient is applied as lighting effect.

<table>
<thead>
<tr>
<th>View</th>
<th>3D Mode [Preview Deck A]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default View: Left</td>
<td><img src="image" alt="Default View: Left" /></td>
</tr>
<tr>
<td>Default View: Top</td>
<td><img src="image" alt="Default View: Top" /></td>
</tr>
<tr>
<td>Default View: Front</td>
<td><img src="image" alt="Default View: Front" /></td>
</tr>
</tbody>
</table>

### Slice Alignment Settings
- Go to the menu **Previews > External Preview 1 > External Preview Settings... > Slice Alignment**
- You can set up the **Slice Type**. Choose from **X-Slices**, **Y-Slices**, or **Z-Slices**
You can set up the Slice Order. Choose from Left To Right, Right To Left, Top To Bottom, or Bottom To Top.

- **X-Slices** - MADRIX produces slices along the X-axis. Since X = 15 regarding the virtual LED matrix in the example above, 15 slices are produced below. Above, Default View: Left can be used to imagine the different slices from the front to the back.

- **Y-Slices** - MADRIX produces slices along the Y-axis. Since X = 8 regarding the virtual LED matrix in the example above, 8 slices are produced below. Above, Default View: Top can be used to imagine the different slices from the front to the back.

- **Z-Slices** - MADRIX produces slices along the Z-axis. Since X = 3 regarding the virtual LED matrix in the example above, 3 slices are produced below. Above, Default View: Front can be used to imagine the different slices from the front to the back.

- **Z-Slices / Left To Right** is the default setting.

<table>
<thead>
<tr>
<th></th>
<th>Left To Right</th>
<th>Right To Left</th>
<th>Top To Bottom</th>
<th>Bottom To Top</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>X-Slices</strong></td>
<td><img src="image1.png" alt="Image" /></td>
<td><img src="image2.png" alt="Image" /></td>
<td><img src="image3.png" alt="Image" /></td>
<td><img src="image4.png" alt="Image" /></td>
</tr>
<tr>
<td><strong>Y-Slices</strong></td>
<td><img src="image5.png" alt="Image" /></td>
<td><img src="image6.png" alt="Image" /></td>
<td><img src="image7.png" alt="Image" /></td>
<td><img src="image8.png" alt="Image" /></td>
</tr>
<tr>
<td><strong>Z-Slices</strong></td>
<td><img src="image9.png" alt="Image" /></td>
<td><img src="image10.png" alt="Image" /></td>
<td><img src="image11.png" alt="Image" /></td>
<td><img src="image12.png" alt="Image" /></td>
</tr>
</tbody>
</table>

[Default]
More Information

- Each DVI Output is a Preview at the same time. That means you have various options to work with them as DVI output or Preview.
  Learn more »3 Previews
- This manual includes additional examples on how to set up DVI output.
  Learn more »DVI Examples

Switching Screens In Full Screen Mode

You may want to send your Full Screen DVI output to another screen that is not the one you are using MADRIX on. This could be a second monitor or a projector, for example.

One Monitor

- Use the keyboard shortcut Alt + Tab to switch to the Full Screen Output.
- Use the Alt + Tab again to switch back to the MADRIX user interface.

Several Monitors

- Make sure to select the full screen DVI output with your mouse [left mouse click].
  
- Press the Tabulator key [Tab] on your keyboard to simply move the full screen window to an additional monitor or beamer.
- Or choose Right Mouse Click > Move To Next Screen
- In this way, you can use the Full Screen mode to completely visualize effects on your second monitor or output device, while you are working with MADRIX on your first screen.
You must install and configure your graphics card and monitors correctly in Windows first to use this feature!

**Scaling**

You can upscale or downscale the DVI Output.
That means you can increase or decrease its size without changing the native pixel render resolution [as defined in the Matrix Generator or Patch Editor].

- **Activate a DVI output as described above.**
  - For example, go to the menu *Previews > External Preview 1 > DVI*

- **Go to the menu Previews > External Preview 1 > External Preview Settings...**

- **Deactivate Use Display Area Size** in the section *DVI Window Size*
- Set up **Width** as well as **Height** according to your requirements.
  - Use larger values to upscale the output.
  - Use smaller values to downscale the output.

- It is recommended to use multiples of the native pixel resolution [in order to not stretch the output].
  - Example: Your virtual LED matrix might have a pixel resolution of 50x50 pixels. Enter 25x25 or 100x100 to use multiples of that resolution.

- Upscaling requires less performance than using a native pixel resolution but negatively affects the image quality in most cases.

**Further Configuration**

Further settings are available in the MADRIX Options.
Learn more »**Performance**

**Important Information**

- Please make sure to save your MADRIX Setup file after the configuration process.
6.1.2 DVI Examples

This topic includes:
- Overview
- Example: Screen-Capturing With 1 Monitor
- Example: Screen-Capturing With 2 Graphic Card Output Ports
- Example: Using Beamers/Projectors/TVs

Overview

This topic presents various scenarios how DVI output can be used.

Example: Screen-Capturing With 1 Monitor

- You might only have 1 monitor [1 monitor output on the graphics card]. But you need to use MADRIX and the DVI output at the same time.
- In this case, it is recommended to use the MADRIX interface and the DVI output next to each other on your main monitor.
- Your main monitor has a certain pixel resolution [e.g., 1920 x 1080]. Learn more »DVI
- Position MADRIX in the upper, left corner.
- Go to the menu Previews > External Preview 1 > DVI to activate the DVI output.
- Go to the menu Previews > External Preview 1 > External Preview Settings...
- Set up Left and Top under DVI Window Position [e.g., 1300 and 0].
  - The standard size of the MADRIX user interface is 1280 x 768.
- Activate Previews > External Preview 1 > Lock Position
- Activate Previews > External Preview 1 > Keep Always On Top
Example: Screen-Capturing With 2 Graphic Card Output Ports

- When using screen-capturing, it is usually recommended to use a graphics card with 2 monitor outputs.
- In this case, you can use the complete monitor 1 for the MADRIX user interface. The DVI output is simply positioned on the monitor output 2.
- Your main monitor has a certain pixel resolution [e.g., 1920 x 1080]. Learn more »DVI
- Position MADRIX on your main monitor. Use the normal window size, maximize the window, or use Full Screen mode for MADRIX.
- Go to the menu Previews > External Preview 1 > DVI to activate the DVI output.
- Go to the menu Previews > External Preview 1 > External Preview Settings...
- Set up Left and Top under DVI Window Position. Make sure to use values that are outside of Monitor 1; Monitor 1 starts at 0,0 instead of 1,1 [e.g., 1920 and 0].
- Activate Previews > External Preview 1 > Lock Position
- Activate Previews > External Preview 1 > Keep Always On Top
Example: Using Beamers/Projectors/TVs
- You might want to bring MADRIX Effects to external equipment, such as projectors, beamers, or large TVs.
- Often, the Full Screen DVI output is needed in this case.
- Also, projectors, beamers, and TVs often require a high pixel resolution.
  - The pixel resolution can be set up using the »Matrix Generator or »Patch Editor
  - The higher the pixel resolution, the more computer performance is required. Learn more »System Requirements
- Position MADRIX on your main monitor. Use the normal window size, maximize the window, or use Full Screen mode for MADRIX.
- Go to the menu Previews > External Preview 1 > Full Screen to activate the DVI output.
- Click on the DVI output with your mouse to focus it. Now, perform a Right Mouse Click > Move To Next Screen
- Activate Previews > External Preview 1 > Keep Always On Top
- If required, activate Previews > External Preview 1 > Stretch Pixels
- Activate other options as required. Learn more »DVI
Graphics Card Output 1 [Monitor 1]
- MADRIX GUI [Maximized Window]

Graphics Card Output 2
- Previews > External Preview 1 > Full Screen
- Move To Next Screen
6.2 Art-Net [DMX Over Ethernet]

This topic includes:
- Introduction
- Network Equipment
- Step-By-Step Configuration
- Art-Net Device Settings
- Additional Functionality
- Important Information
- Troubleshooting

Introduction

Art-Net is a communication protocol that allows to distribute DMX512 data over Ethernet network [DMX over Ethernet].

Art-Net has been invented by Artistic Licence and has now been published into the public domain. Often, so-called Art-Net nodes then act as Ethernet to DMX512 converters and hardware interfaces. Especially, long distances can be covered using Ethernet cabling.

MADRIX is compatible with
- Art-Net I
- Art-Net II
- Art-Net 3
- Art-Net 4
- MADRIX supports all devices that are fully compatible with Art-Net.
  - You can use Art-Net nodes either as output or input devices.

**Network Equipment**

*It is highly recommended to only use Gigabit Ethernet network components [such as network card, switches, network cabling, etc].*

**Step-By-Step Configuration**

1. Set up the correct network settings in Windows.
2. Activate Art-Net in MADRIX.
3A. Add your Art-Net devices automatically.
3B. Add your Art-Net devices manually.
4. Edit the settings of your devices.
5. Activate your devices.
6. Assign the correct DMX universes.
7. Set up the Frame Time.
8. Choose to send optimized frames or full frames.

- Repeat steps 4] to 8] for each of your devices.

**1] Windows Network Settings**

Art-Net is a network-based protocol. MADRIX will use the network card of your computer to send data.
It is required to set up the correct network settings in Windows, first.

You must use these IP address and Subnet mask settings. Otherwise, Art-Net might not work!

The IP addresses of your computer and your Art-Net devices need to be different.

Set up an individual **IP address** in the following IP address range:
- 2.0.0.1 ... 2.255.255.254 or
- 10.0.0.1 ... 10.255.255.254

Set up the corresponding **Subnet mask**
- 255.0.0.0

Restart MADRIX, if you have changed the network settings in Windows while MADRIX was running.

Check the settings of the Windows Firewall. Learn more »[Tips [Microsoft Windows / Networks / USB]]

Example for PCs that are running MADRIX:

![Internet Protocol Version 4 (TCP/IPv4) Properties](image)

Please remember to restart MADRIX, if you have changed the network settings in Windows while MADRIX was running.
2] Activating Art-Net In MADRIX

- Go to the menu Preferences > Device Manager... > Art-Net
  [Keyboard shortcut: F4 > Art-Net]

- Activate the checkbox Enable [in the upper, right corner].

3A] Adding Devices Automatically

MADRIX can automatically add devices using the ArtPoll Reply functionality if supported by the Art-Net device.

- Click
  [MADRIX will automatically search the network for connected Art-Net devices. MADRIX will scan even across multiple network cards. Devices that are found will appear in the list.]
  [Please make sure that your devices also have the correct network settings.]
3B] Adding Devices Manually

Some interfaces might not support ArtPoll Reply in order to add them automatically. Then, you need to add your devices manually.

- Click 

- A new window will open.
- **Port Type** - Choose *Output*.

- **Number Of New Devices** - Enter the number of devices you wish to add.

- **Port Count Per Device** - Enter the number of ports each newly created device should have. Per device a maximum number of 4 ports is available.
  - *In order to create an 8-port node, set up 2 devices with 4 ports each. In most cases the same IP address should be entered then for both devices.*

- **Send Via Unicast Mode** - Activates Unicast Mode for all newly created output devices.

- **Send Full Frames** - Activate this option if output devices should always send a single data frame including a full number of 512 channels. If this option is disabled, MADRIX will automatically send optimized frames that reduce network traffic. Learn more below.
4] Device Settings

- Select your device in the list.

- Click [ ]

- A new window will open [Art-Net Device Configuration].
Set up specific settings for your device. The following settings are available [this depends if the device was added automatically or manually]:

- **Short Name** - Represents a short description of your device.
- **Long Name** - Represents a long description of your device.
- **LED Status Indicators** - Allows you to switch off all LED status indicators of a device if supported by the device via **Mute** [ArtAddress needs to be enabled first in MADRIX.]
- **Port Count** - Represents the number of ports for this particular device.
- **State** - Displays if the ports have been activated under Preferences > Device Manager... > DMX Devices. Learn more below.

- **Universe Port OUT** - Defines the general allocation of DMX universe and device port for output. E.g., the fourth DMX universe is sent to port 4. [When changing one value, you can quickly adjust all values linearly increasing or decreasing them via the appearing button, 1 - 4, for example.]

- **Send Broadcast Mode** - Activates Broadcast Mode. Learn more below.
  - **Network** - Defines the network card that is used for Broadcast Mode. Learn more below.

- **Send Unicast Mode** - Activates Unicast Mode. Learn more below.
  - **IP Address** - Defines the IP address of the Art-Net device when data is sent via Unicast Mode.

### 5] Activating Devices

Each of your Art-Net devices need to be activated.

- Go to the menu Preferences > Device Manager... > DMX Devices
  [Keyboard shortcut: F4]

- Select your devices in the list.

- Activate **Enable**

- Activate **Output**

- Click **Apply**

![Device Manager screen capture]
6] DMX Universe

- Make sure that your device is still selected under Preferences > Device Manager... > DMX Devices
- Set up Universe
  - Enter the specific DMX universe number
- This setting assigns a specific DMX universe [of the Patch] to the device or the port of the device.
- Make sure the correct universe is assigned according to your requirements.
  Learn more »Glossary
- Click Apply

7] Frame Time

- Make sure that your device is still selected under Preferences > Device Manager... > DMX Devices
- Set up Frame Time (ms)
  - The Frame Time affects the Frame Rate. The Frame Rate specifies how fast data is sent to the device or received from it [Frames Per Second; FPS].
  - Increase the Frame Time in order to decrease the Frame Rate [e.g., 40ms = 25 FPS].
  - Decrease the Frame Time in order to increase the Frame Rate [e.g., 20ms = 50 FPS].
  - The default value is 30 ms / 33.3 FPS.
  - Some LED fixtures might have problems with a high Frame Rate. Then, it is recommended to increase the Frame Time / to decrease the Frame Rate.
- Click Apply

8] Optimized Frames Or Full Frames

- Make sure that your device is still selected under Preferences > Device Manager... > DMX Devices
• Activate or deactivate **Send Full Frames**
  - Per DMX512 standard, MADRIX only sends the number of DMX channels that is configured. For example, if you are using 312 DMX channels on a DMX universe, only 312 DMX channels will be sent with every single frame on this universe [Optimized Frames].
  - Activate Send Full Frames if devices should always send full frames on a particular universe, instead of optimized frames. Sending full frames means that always the full 512 DMX channels of a DMX universe will be sent with every frame [even when you are using less than 512 channels].
  - **Activating Send Full Frames is recommended if problems with the data output of your devices occur.**

• Click **Apply**

---

**Art-Net Device Settings**

**It is very important to set up the correct settings of your devices!**

**Broadcast Mode Or Unicast Mode**

MADRIX can send Art-Net data in 2 ways to your Art-Net devices:

• **Broadcast Mode** - Means that every packet sent from a single transmitter will be received by all recipients in the network. MADRIX will send data to all devices in the network.
  - Advantage: The same data [e.g., DMX universe 1 and 2] can be made available at different points of your setup.
  - Disadvantage: A potentially huge number of data packages will be sent over the network. This can reduce the overall network performance and cause data issues or instability.

• **Unicast Mode** - Means that the specific data will only be sent to the specified recipient.
  - Advantage: Data traffic is reduced immensely, which means that a larger number of Art-Net devices can be used in one network. Reduced network traffic increases the performance and stability.
  - Disadvantage: The network settings of all devices need to be 100% correct.
- Go to the menu Preferences > Device Manager... > Art-Net
  [Keyboard shortcut: F4 > Art-Net]
- Select your device in the list.
- Click
- A new window will open.

A] Choose **Send Unicast Mode** to activate Unicast Mode:
- Make sure to enter the correct **IP Address** of your device that should receive the Art-Net data.
- MADRIX will send the corresponding data only to this device.

B] Choose **Send Broadcast Mode** to activate Broadcast Mode:
- Make sure to select the correct **Network** card of your computer that should send the Art-Net data.
- MADRIX will send data to the whole Art-Net network.
- Click **Apply**

Unicast Mode is recommended in general.

Sync Mode

**ArtSync** - Allows you to activate or deactivate the usage of sync packages for Art-Net.
- Your Art-Net devices need to support this feature in order for it to work correctly.
- All MADRIX hardware Art-Net nodes support ArtSync.

In addition, you can choose between **Post-Sync** [default] and **Pre-Sync**. By default, the sync data is sent after the color data. Pre-Sync would send it before the color data.

- Before activating sync, make sure that all activated Art-Net devices are available in your network! Else, the frame rate of Art-Net might drop. If you are not sure, do not enable any sync mode.
MAC To IP Conversion

MAC To IP - Allows you to include a tool to convert MAC addresses to IP addresses, and vice versa.

- Go to the menu Preferences > Device Manager... > Art-Net >  > MAC To IP
- A new window will open.
- OEM Code - Choose the manufacturer of the device.
- A] MAC Address - Enter the MAC address of the device and the tool automatically converts it into the correct IP address.
- B] IP Address - Enter the IP address of the device and the tool automatically converts it into the correct MAC address.

Additional Functionality

Managing Devices

Refresh Device List - Communicates with connected devices to see if there have been any changes to update them in MADRIX accordingly.
**Duplicate Devices** - Duplicates the selected devices to quickly add new similar devices.

**Remove Devices** - Removes the selected devices from the list. [Keyboard shortcut: Del / Delete]

**Web Configuration**

**HTTP Configuration** - Allows you to configure your Art-Net device remotely with the help of a web browser if this feature is supported by your device. If this feature is available, a new browser window will be opened using the specified IP address. This offers you access to the configuration of your Art-Net device. If this is not possible, a message box will be displayed in MADRIX.

**Status Indicators [ArtAddress]**

In order to use these features, please **Enable ArtAddress** first.

[Please make sure that your nodes fully support this Art-Net feature, such as MADRIX LUNA, MADRIX NEBULA, MADRIX PLEXUS, MADRIX STELLA, MADRIX ORION. You will also get notified by a message box. Confirm the message with **OK** or abort via **Cancel**]

**Mute Status Indicators** - Switches off and disables all built-in status indicators of a device over Art-Net [ArtAddress > AcLedMute].

**Operate Status LEDs Normally** - Allows the built-in status indicators of a device to operate normally again, after having them switched off [ArtAddress > AcLedNormal].
**Highlight Device** - Activates the highlight mode [ArtAddress > AcLedLocate]. Select one or more interfaces and click the button. The corresponding status indicators of the selected interfaces will flash for a better identification or tests. This makes it easier to see them on site/stage. It considerably speeds up the procedure of programming or testing the selected interfaces.

**DMX Watcher**

**DMX Watcher** - Opens the DMX Watcher to monitor your DMX output or input. Learn more » Tools

**Resizing The Window**

If wish to resize the window of the Device Manager to see more devices in the list, simply move your mouse pointer to the bottom of this window. Then, select the border and hold the left mouse button, while moving your mouse downwards.

**Important Information**

- Remember to configure your light matrix. Learn more » Matrix Generator or » Patch Editor
- Make sure to save your MADRIX Setup file after the configuration process.
- Keep in mind that network devices, if activated, cause network traffic!
- If you are using a network-based output protocol and if the Startup option Start MADRIX After Booting Windows is activated, it is highly recommended to also activate the Startup option Start With Timeout (s) with a value of 30.
When activating Art-Net, MADRIX will create a so-called shared socket and not an exclusive socket. Therefore, other software on the computer has the chance access Art-Net using the same socket, when running MADRIX and another software at the time.

It is not recommended to operate Art-Net and access to the World Wide Web/Internet in the same network! It is recommended to run it in a separate network without internet access.

Troubleshooting

If you are encountering problems, please work through the following checklist:

- Double-check the settings of your network card [IP address, Subnet mask].
- Make sure to set up the Windows Firewall correctly or deactivate the Windows Firewall if possible [only if no connection to the internet is available]. Learn more »Tips [Microsoft Windows / Networks / USB]
- If MADRIX does not use the correct network card for Art-Net Remote, change the order of network adapters and set a higher priority for your preferred network. Learn more »Tips [Microsoft Windows / Networks / USB]
- Double-check the settings of the Art-Net devices in MADRIX.
- Use the DMX Watcher to monitor outgoing data. Learn more »Tools
- Use only GIGABIT [1GBit/s or 1000 MBit/s] network components [such as, switches and network cards].
- Use high-quality network components [cables, switches, cards, etc.].
- Remove any routers from the network.
- Check all other IP addresses and cabling. Having the same IP address in the network causes problems. Make sure that the network is not forming a ring, were the start point is also the end point, and that data is not sent back to the source [the computer].
- Use **Start With Timeout (s)** in the MADRIX Options to make sure network is initialized correctly before MADRIX starts. Learn more »Startup
- If output problems occur, decrease the output frame rate [FPS] in the Device Manager.
- Make sure that Art-Net is set up as an individual network and separate from the Internet.
6.3 DMX512 [DMX-OUT]

This topic includes:
- Overview
- Configuration Of Devices
- Step-By-Step Configuration
- Additional Functionality
- Important Information

Overview

- Go to the menu Preferences > Device Manager... > DMX Devices
  [Keyboard shortcut: F4]

MADRIX supports various communication protocols and hardware interfaces. The majority of these communication protocols is based on DMX512. That is why these interfaces will be listed here.
Configuration Of Devices

- Depending on your hardware interface further configuration may be required.
- Make sure to read the corresponding chapter of this user guide regarding the correct output settings.
  Learn more »OUTPUT Settings

Step-By-Step Configuration

1] Enable drivers in MADRIX.
2] Activate your device.
3] Choose if you want to use Input or Output.
4] Set up the correct DMX universe.
5] Set up the Frame Time.
6] Choose to send optimized frames or full frames.

1] Enable Drivers In MADRIX

- First, make sure to activate the required USB or network drivers in MADRIX.
  Learn more »Devices USB
  Learn more »Devices Network

2] Activating Devices

- Go to the menu Preferences > Device Manager... > DMX Devices
  [Keyboard shortcut: F4]
- The tab DMX Devices will be selected automatically.
- Click [ ]
  - MADRIX disconnects all DMX512, Art-Net, and other devices and starts to search for new or newly connected devices.
  - **Do not rescan for devices if all of your interfaces have been found correctly.**
- Select your device in the list.
- Activate **Enable**
- Click **Apply**

### 3] Output or Input

- Make sure that your device is still selected.
- **A]** Enable **Output** if you wish to send data to this device in order to put it out onto your LED fixtures.
- Click **Apply**

- **B]** Enable **Input** if you wish to receive incoming data through this device.
  - Learn more » [DMX-IN / Art-Net Remote / sACN Input]
- Click **Apply**
4] DMX Universe

- Make sure that your device is still selected.
- Set up **Universe**
  - Enter the specific DMX universe number
- This setting assigns a specific DMX universe [of the Patch] to the device or the port of the device.
- **Make sure the correct universe is assigned according to your requirements.**
  
  Learn more »[Glossary](#)
- Click **Apply**

5] Frame Time

- Make sure that your device is still selected.
6] Optimized Frames Or Full Frames

- Make sure that your device is still selected.
- Activate or deactivate Send Full Frames
  - Per DMX512 standard, MADRIX only sends the number of DMX channels that is configured. For example, if you are using 312 DMX channels on a DMX universe, only 312 DMX channels will be sent with every single frame on this universe.
  - Activate Send Full Frames if devices should always send full frames on a particular universe, instead of optimized frames. Sending full frames means that always the full 512 DMX channels of a DMX universe will be sent with every frame [even when you are using less than 512 channels].
- Activating Send Full Frames is recommended if problems with the data output of your devices occur.
- Click Apply

Additional Functionality

Highlight Mode
**Highlight** - Activates the highlight mode for the selected interface and universe under *Preferences > Device Manager... > DMX Devices*. Select one or more interfaces and click the button. The corresponding fixtures at the selected interfaces will flash for a better identification or tests. This makes it easier to see them on stage. It considerably speeds up the procedure of programming or testing the selected DMX512/Art-Net interfaces.

### DMX Watcher

*DMX Watcher* - Opens the DMX Watcher to monitor your DMX output or input under *Preferences > Device Manager... > DMX Devices*

Learn more »[Tools](#)

### Resizing The Window

If wish to resize the window of the Device Manager to see more devices in the list, simply move your mouse pointer to the bottom of this window. Then, select the border and hold the left mouse button, while moving your mouse downwards.

### Important Information

- Remember to configure your light matrix. Learn more »[Matrix Generator](#) or »[Patch Editor](#)
- Make sure to save your MADRIX Setup file after the configuration process.
- Make sure to have the correct drivers enabled in the MADRIX Options. Learn more »[Options](#)
6.4 Philips Color Kinetics [KiNET]

Topics of this chapter:
- Introduction
- Note
- Step-By-Step Configuration
- Additional Functionality
- Further Configuration
- Important Notes
- Troubleshooting
- Additional Information

Introduction

MADRIX natively supports Philips Color Kinetics [KiNET]. The protocol is implemented in the software, which makes it easy to use Color Kinetics fixtures and Color Kinetics power supplies with MADRIX.

MADRIX supports
- KiNET V1
- KiNET V2

Note

There are several steps required to set up KiNET products in MADRIX. This chapter is only part of the process. You need to set up other configurations as well [such as virtual LED matrix, DMX Devices, MADRIX Effects, Audio, etc.].
Step-By-Step Configuration

1] Set up the correct network settings in Windows.
2] Enable drivers in MADRIX.
4] Set up the DMX universe.
5] Set up the Frame Time.

1] Windows Network Settings

KINET is a network-based protocol. MADRIX will use the network card of your computer to send data.

- It is required to set up the correct network settings in Windows, first.
- You must use these IP address and Subnet mask settings. Otherwise, KINET might not work!
- The IP addresses of your computer and your KINET devices need to be different.

- Set up an individual IP address in the following IP address range:
  - 10.0.0.1 ... 10.255.255.254
- Set up the corresponding Subnet mask
  - 255.0.0.0

- Restart MADRIX, if you have changed the network settings in Windows while MADRIX was running.
- Check the settings of the Windows Firewall.
- Learn more »Tips [Microsoft Windows / Networks / USB]

Example for PCs that are running MADRIX:
2] Enabling Drivers In MADRIX

- Go to the menu Preferences > Options... > Devices Network
  [Keyboard shortcut: Ctrl+Alt+O > Devices Network]
  
  - Activate Philips Color Kinetics - KiNET

  - Choose the correct network/network card from the drop-down list.
  - Always make sure that you have selected the correct network. Otherwise, the network device might still be found. But no data can be sent.
- **Time To Detect Devices (s)** - Defines how long MADRIX searches the network for devices during startup. Type in a value in seconds.
  - The default value is 15.
  - **We recommend to utilize at least a value of 15 to allow for a sufficient search. Higher values are recommended for larger installations.**

- **Discovery Repetition To Detect Devices** - Defines how often MADRIX repeats to search for and discover devices in the network within the Time To Detect Devices (s).
  - The default value is 3.

- **Acquire Universe Assignment From Devices** - If activated and if KiNET devices have been fully configured, MADRIX reads the assigned DMX universe from newly found devices and automatically sets it in the Device Manager for these devices.

### 3] Activating Device

- Go to the menu **Preferences > Device Manager… > DMX Devices**
  
  [Keyboard shortcut: `F4`]
MADRIX automatically adds network devices it has found during startup to the list.

- Click if the devices have not been found.
  - MADRIX disconnects all DMX512, Art-Net, and other devices and starts to search for new or newly connected devices.
  - Do not rescan for devices if all of your interfaces have been found correctly.

- Select your devices in the list.
- Activate Enable
- Activate Output
- Click Apply

There is a difference between KiNET V1 and V2. KiNET V2 makes sure that the panels will receive the data at the same time. This is particularly useful for large installations.

Please see the Color Kinetics documentation to see which protocol is supported by your power supply.

5] DMX Universe

- Make sure that your device is still selected.
Set up **Universe**
- Enter the specific DMX universe number

This setting assigns a specific DMX universe [of the Patch] to the device or the port of the device.

**Make sure the correct universe is assigned according to your requirements.**
Learn more »[Glossary](#)

- Click *Apply*

### 6] Frame Time

- Make sure that your device is still selected.

- **Set up **Frame Time (ms)**
  - The Frame Time affects the Frame Rate. The Frame Rate specifies how fast data is sent to the device or received from it [Frames Per Second; FPS].
  - Increase the Frame Time in order to decrease the Frame Rate [e.g., 40ms = 25 FPS].
  - Decrease the Frame Time in order to increase the Frame Rate [e.g., 20ms = 50 FPS].
  - The default value is 30 ms / 33.3 FPS.
  - **Some LED fixtures might have problems with a high Frame Rate. Then, it is recommended to increase the Frame Time / to decrease the Frame Rate.**

- Click *Apply*

### Additional Functionality

**Rescan For Devices**

*Rescan For Devices* - MADRIX disconnects all DMX512, Art-Net, and other network devices and starts a new search for devices.
Highlight Mode

**Highlight** - Activates the highlight mode for the selected interface and universe under Preferences > Device Manager... > DMX Devices. Select one or more interfaces and click the button. The corresponding fixtures at the selected interfaces will flash for a better identification or tests. This makes it easier to see them on stage. It considerably speeds up the procedure of programming or testing the selected interfaces.

DMX Watcher

**DMX Watcher** - Opens the DMX Watcher to monitor your DMX output or input under Preferences > Device Manager... > DMX Devices

Learn more »Tools

Resizing The Window

If wish to resize the window of the Device Manager to see more devices in the list, simply move your mouse pointer to the bottom of this window. Then, select the border and hold the left mouse button, while moving your mouse downwards.

Further Configuration

<table>
<thead>
<tr>
<th>LED Fixtures</th>
<th>Comments</th>
</tr>
</thead>
</table>
### Color Kinetics eW Flex SLX
If your are using a PDS-60ca with one or two strings per controller, a PDS-150, or sPDS-480ca, please select the correct fixture in the » Matrix Generator

### Important Notes
- Keep in mind that network devices, if activated, cause network traffic!
- When using a network-based output protocol and when the Startup option Start MADRIX After Booting Windows is used, it is highly recommended to also activate the Startup option Start With Timeout(s) with a value of 30 or higher.
- It is not recommended to operate KiNET and access to the World Wide Web/Internet in the same network! It is recommended to run it in a separate network without internet access.

### Troubleshooting
If you are encountering problems, please work through the following checklist:
- Check if all network cables are connected and if Gigabit network components are used.
- Check if your light matrix is configured correctly in the Matrix Generator or Patch Editor
• Have all devices been found under Preferences > Device Manager... > DMX Devices?
  If not,
  1] Check if the IP address and Subnet mask are configured correctly in Windows and your devices.
  2] Go to the menu Preferences > Options > Devices Network. Select Philips Color Kinetics - KiNET
  3] Go to the menu Preferences > Options > Devices Network. Select the correct network card in the section Philips Color Kinetics - KiNET
  4] Go to the menu Preferences > Options > Devices Network. Increase the value for Time To Detect Devices (s) in the section Philips Color Kinetics - KiNET
  5] Click Rescan For Devices under Preferences > Device Manager... > DMX Devices.
  6] Try and deactivate your Firewall in Windows.
  7] Make sure that the network is not forming a ring, were the start point is also the end point, and that data is not sent back to the source [the computer].

• Are all devices activated under Preferences > Device Manager... > DMX Devices?
  Check if Enable and Output are activated.

• Check if all ports you are using on your device are configured correctly. Please check if ports, that are not used, are deactivated in MADRIX.

• Check if the DMX addressing and DMX universes are assigned correctly. Also check the Patch.

• Test if MADRIX is connected to the devices. Use Highlight Device for each of your devices.

• Go to Tools > Task Watcher. Check if the devices are sending data.

• Go to Tools > Logfile. Check if any error or warnings occur regarding the network or KiNET.

• Make sure all power supplies and controllers are working correctly.

• Remove any routers from the network.

Additional Information

Addressing And Configuration

• Regarding the configuration and addressing of Philips Color Kinetics lighting fixtures and power supplies, the company offers extensive information on the following website: http://www.colorkinetics.com/support/addressing/
In addition, there is a software tool called QuickPlay Pro for configuration and multiple addressing. Here is an excerpt from the website:

"With QuickPlay Pro, you can:

• Use serial numbers to program fixtures with light numbers or DMX addresses
• Assign base light numbers to power / data supplies, allowing automatic fixture configuration
• Test light numbers and DMX channels
• Demonstrate a lighting system using four built-in light shows: fixed color, color wash, rainbow, and streak"

• For example, the tool can be used to change the IP addresses of Color Kinetics lighting fixtures.
• Please note: Working with such a tool is only recommended for advanced users because settings can easily be adjusted wrong!

You can download the tool on the website mentioned above or at »http://www.colorkinetics.com/support/downloads/

The download archive for older products can be found at »http://www.colorkinetics.com/support/downloads/archive/

Information About PDS-60ca Power Supplies

The PDS-60ca is a well-known and often used power/data supply from Philips Color Kinetics. Three different versions are offered:

• PDS-60ca PREPROGRAMMED
• PDS-60ca DMX
• PDS-60ca ETHERNET

You can identify your version of the device using the following item numbers written on the case of the PDS-60ca:

• 109-000016-00 [Pre-programmed]
• 109-000016-01 [DMX]
• 109-000016-02 [Ethernet]
The PDS-60ca DMX supports DMX512 via an extra interface [controlled by MADRIX] or Color Kinetics DMX controllers.
The PDS-60ca ETHERNET uses KINET and can be controlled via MADRIX without an extra interface.
And the PDS-60ca PREPROGRAMMED does not support external data input.

Information Update

The official website now only lists two PDS-60ca. The second power supply now automatically switches between DMX and Ethernet mode.

- 109-000020-00 PDS-60ca 12V [Pre-programmed]
- 109-000020-03 PDS-60ca 12V [DMX / Ethernet]
6.5 **ESTA - Streaming ACN [sACN / E1.31]**

This topic includes:
- Introduction
- Note
- Step-By-Step Configuration
- Additional Functionality
- Important Notes
- Troubleshooting
- Further Configuration

### Introduction

Streaming ACN [sACN/E1.31] is a protocol that transfers DMX data over Ethernet. It is another network-based DMX protocol. It is a standard created by ESTA [Entertainment Services and Technology Association; web link »[www.esta.org](http://www.esta.org)].

### Note

There are several steps required to set up Streaming ACN products in MADRIX. This chapter is only part of the process. You need to set up other configurations as well [such as virtual LED matrix, DMX Devices, MADRIX Effects, Audio, etc.].
Step-By-Step Configuration

1] Configure network settings in Windows.
2] Activate Streaming ACN in MADRIX.
3A] Configure single DMX devices.
3B] Configure multiple DMX devices.
4] Choose if you are going to use your devices as output or input interfaces.
5] Set up the correct DMX universe.
6] Set up the Frame Time.

1] Windows Network Settings
MADRIX automatically sets up Streaming ACN network settings for you.

[MADRIX supports multicast Streaming ACN. Data is automatically sent to all corresponding sACN devices in the network. Unicast is also supported.]

- You only need a computer with a network card and a valid IP address.

- You do not have to change the IP address settings in Windows for Streaming ACN!

- The IP address range for sACN devices is 239.255.X.X according to the Streaming ACN specifications.
  [Even if your sACN devices are set to a different IP address range, you may try the connection from MADRIX to your devices.]

- Make sure that your Firewall does not block data of the 239.255.X.X IP address range!

- Check the settings of the Windows Firewall.

- Learn more »Tips [Microsoft Windows / Networks / USB]

2] Activating Streaming ACN

- Go to the menu Preferences > Options... > Devices Network
  [Keyboard shortcut: Ctrl+Alt+O > Devices Network]

- Activate ESTA - Streaming ACN

- Choose your network card from the drop-down list. Make sure to select the correct network adapter that will be used for Streaming ACN!
  [The IP address and Subnet mask label should help you select the correct adapter. It is not necessary to change any of these networks settings.]

- ACN Device Count - Set up how many you are going to use.
  [This is the total amount of OUT and IN devices. Please set the exact number of devices you are using. If the count is higher, this creates unnecessary network traffic.]

- Press Apply
ACN CID - Being a network protocol, Streaming ACN sends a so-called CIDs [Component Identifier].
- Every single ACN device has such a unique ID.
- When using Streaming ACN, your MADRIX software is one of those devices.
- When you start MADRIX for the first time, this ID will be generated automatically for you. From this point onwards it will be used on your PC.
- With this ID your MADRIX software can be easily identified in the network. Interfaces can detect this unique ID and can be configured to receive data from this particular device. Please note that the ACN interface must support this feature.
- **Do not change the ACN CID, unless you are an experienced user!**

Press OK to close the window.

3A] Configuration Of Single Devices

- Go to the menu **Preferences > Device Manager... > DMX Devices**
  
  [Keyboard shortcut: **F4**]
MADRIX automatically creates and adds the number of interfaces to the list.

[according to ACN Device Count]

- Select a device in the list and click ![button](image)
- A new window will open.

Set up the following settings for your devices:
- **Source Name** - Allows you to set up a specific name for the device. This name is send via network as well. Therefore, interfaces may be able to retrieve this name and can be configured to receive data from this source. 
- If you are using the default name **MADRIX U:X**, the universe will automatically be displayed in the name [represented by X: 1, 2, 3, etc.].

- **ACN Universe** - Defines the DMX universe of the device. 
  - **Set up the same universe that is set up in your sACN device.**
  - According to the Streaming ACN specifications, MADRIX will automatically change the ACN IP Address according to the ACN Universe.

- **ACN Priority** - Was implemented for backup solutions. Valid values range from 0 to 200, which is the highest priority. 
  - For example, you may have set up two MADRIX PCs. One gets a priority of 100. The second PC gets a priority of 50. If the first PC fails and only if it malfunctions, data will be automatically received from PC #2.
  - Data will always be received from the device with the highest priority. Please note that the ACN device must support this feature.

- **ACN Protocol** - Automatically selects the **ANSI 2009** standard.

- **Use Multicast**
  - **ACN Multicast IP Address** - Displays the IP address of the device as automatically assigned by MADRIX according to the Streaming ACN specifications. The last 2 digits match the assigned DMX universe.

- **Use Unicast**
  - **ACN Unicast IP Address** - Uses a specific IP address to send data to.

- Press **Apply** to confirm your changes.
- Press **OK** to close the window.

### 3B] Configuration Of Multiple Devices

- You can configure **several interfaces** at the same time.

- Follow the steps of 3A, but select multiple devices and press ![image]
- A new window will open.
Set up the settings as described under 3A].

For **ACN Universe** you have now additional options for **Auto Numbering**:

- Leave this button deactivated and every device will get the same number of universes.
- Activate the button and MADRIX will automatically increase the number for all the selected devices, starting with the ACN Universe value you entered.

- Press **Apply** to confirm your changes.
- Press **OK** to close the window.

### 4] Output or Input

- Make sure that your device is still selected under **Preferences > Device Manager... > DMX Devices**.
- **A]** Enable **Output** if you wish to send data to this device in order to put it out onto your LED fixtures.
  - Click **Apply**

- **B]** Enable **Input** if you wish to receive incoming data through this device.
  - Click **Apply**

- In DMX-IN mode, you will not be able to select the ACN protocol. MADRIX will automatically select the correct protocol version.
- Learn more »[DMX-IN / Art-Net Remote / sACN Input](#)

![Device Manager](image)

- **Note:** If you are loading a MADRIX Setup, please check if the number of ACN devices in your setup corresponds with the number that is activated. The Setup stores the number of devices. But if you changed the amount and then loaded the Setup, the newly defined number will be activated.

5] **DMX Universe**

- Make sure that your device is still selected.

- Set up *Universe*
  - Enter the specific DMX universe number

  - This setting assigns a specific DMX universe [of the Patch] to the device or the port of the device.

  - **Make sure the correct universe is assigned according to your requirements.**

    Learn more »[Glossary](#)

- Click **Apply**

6] **Frame Time**
Make sure that your device is still selected.

Set up **Frame Time (ms)**
- The Frame Time affects the Frame Rate. The Frame Rate specifies how fast data is sent to the device or received from it [Frames Per Second; FPS].
- Increase the Frame Time in order to decrease the Frame Rate [e.g., 40ms = 25 FPS].
- Decrease the Frame Time in order to increase the Frame Rate [e.g., 20ms = 50 FPS].
- The default value is 30 ms / 33.3 FPS.
- **Some LED fixtures might have problems with a high Frame Rate. Then, it is recommended to increase the Frame Time / to decrease the Frame Rate.**

Click **Apply**

---

**Additional Functionality**

**Rescan For Devices**

Rescan For Devices - MADRIX disconnects all DMX512, Art-Net, and other network devices and starts a new search for devices.

**Highlight Mode**

Highlight - Activates the highlight mode for the selected interface and universe. Select one or more interfaces and click the button. The corresponding fixtures at the selected interfaces will flash for a better identification or tests. This makes it easier to see them on stage. It considerably speeds up the procedure of programming or testing the selected DMX512/Art-Net interfaces.
DMX Watcher

**DMX Watcher** - Opens the DMX Watcher to monitor your DMX output or input
Learn more »[Tools](#)

Resizing The Window

If wish to resize the window of the Device Manager to see more devices in the list, simply move your mouse pointer to the bottom of this window. Then, select the border and hold the left mouse button, while moving your mouse downwards.

Important Notes

- Please switch off your Firewall or configure your Firewall accordingly. sACN might not work with a Firewall!
- It is recommended to run sACN in a separate network without internet access. Else, the internet connection may not work properly.
- Keep in mind that network devices, if activated, cause network traffic!
- When using a network-based output protocol and when the startup option *Start MADRIX After Booting Windows* is used, it is highly recommended to also activate the Startup option *Start With Timeout (s)* with a value of 30 or higher.

Troubleshooting

If you are encountering problems, please work through the following checklist:
• Make sure to set up the Windows Firewall correctly or deactivate the Windows Firewall if possible [only if no connection to the internet is available]. Learn more »[Tips](#) [Microsoft Windows / Networks / USB]

• Use **Start With Timeout (s)** in the MADRIX Options to make sure network is initialized correctly before MADRIX starts. Learn more »[Startup](#)

• If output problems occur, decrease the output frame rate [FPS] in the Device Manager.

• Make sure that sACN is set up as an individual network and separate from the Internet.

• Double-check if routers and switches in the network allow communication and IP address forwarding for the 239.255.X.X range of IP addresses.

• Double-check if your sACN devices support multicast Streaming ACN and are configured accordingly.

---

**Further Configuration**

Remember to configure your light matrix in the **Matrix Generator** or **Patch Editor**

Make sure to save your MADRIX Setup after the configuration process.
6.6 Proprietary DVI Devices [5A / A8 / T9]

This topic includes:

- Introduction
- Initial Configuration
- Note
- Gigabit Network Card
- Step-By-Step Configuration
- Further Configuration
- Important Notes
- Troubleshooting

Introduction

Certain DVI hardware is equipped with proprietary protocols. MADRIX has implemented a range of products that are natively supported because of this.

MADRIX currently supports the following DVI device types:
Initial Configuration

Before you can use MADRIX, please make sure that you have configured your LED fixtures and hardware correctly.

Note

There are several steps required to set up proprietary DVI products in MADRIX. This chapter is only part of the process. You need to set up other configurations as well [such as virtual LED matrix, DMX Devices, MADRIX Effects, Audio, etc.].

Gigabit Network Card

- Only use a GIGABIT network card [1 GBit/s or 1000 MBit/s]. 100 MBit/s network cards or lower will not work!
- It is only recommended to use a wired network connection. Using wireless transmission will not work!
Step-By-Step Configuration

1] Install the correct driver.
2] Activate the DVI device in MADRIX.
3] Configure various settings.

1] Installing The WinPcap Driver

- To use DVI devices with MADRIX, you have to install the correct driver first.
- During the MADRIX installation process, make sure to select the check box WinPcap Driver.
- If you have already installed MADRIX without this component, re-install MADRIX.
- The WinPcap driver will be installed using a second installer. Confirm this setup wizard to install the driver.
- Learn more »Installation Process
Welcome to the WinPcap 4.1.3 Setup Wizard

The Wizard will guide you through the entire WinPcap installation. For more information or support, please visit the WinPcap home page.

http://www.winpcap.org
2] Activating The DVI Device

- Go to the menu Preferences > Device Manager... > DVI Devices
  [Keyboard shortcut: F4 > DVI Devices]

  - Click
  [MADRIX will automatically search for connected devices. It will also search across multiple networks if there is more than one network card is available.]
  [Note: Automatic search will default to EuroLite T9 for all T9 devices found, incl. ColourSmart Link, EuroLite T9, and Colorlight T9.]
• **B) Add devices manually.**
  - Click 
  - A small selection list will be opened above the button.
  - Select your DVI device type now.
  - A new window will open [Device Configuration].

1] If the drop-down list at the top of the Device Configuration window does not contain an entry, there is either no network card available or the WinPcap driver is not installed properly.

• If you are receiving this error message, please resolve these issues and run the MADRIX installer again to install the required drivers [WinPcap Driver].
2] If everything is installed properly, select the network device that communicates with your DVI fixture in the drop-down list at the top of the Device Configuration window.

- Do not change any other settings here [such as, Color Master] unless you are an experienced user.
- Advanced users may adjust the color settings via the Color Master if the DVI device renders colors incorrectly.
- When adding Colorlight 5A devices, you may choose an additional Screen Number. Set up the same index number as is configured in your 5A device. Leave the default setting if you are not sure.

- Click OK

- The new DVI device will appear in the list after is has been added automatically or manually.
3] Settings

There are different Settings available for further configuration. By default, all settings should be set up correctly already.

- If you change a setting, always click **Apply** to confirm the changes.

- **Enable** - Activates or deactivates the currently selected DVI device. This is activated by default. It needs to be activated in order to work correctly.

- **Use Full Size** - Displays the full Matrix Size on the device. This is activated by default and the recommended setting.
  - Deactivate if you want to set up a certain cut-out and specify which details of your matrix will be shown. You can choose the start coordinates and the end coordinates of this area. **Left** and **Top** define the start coordinates in a coordinate system that starts with 0,0 in the top left corner. **Right** and **Bottom** define the end coordinates.

**Scaling is not available.**

Your virtual LED matrix will not be stretched or compressed in order to fit the DVI device or vice versa.
- **Set Frame Time** - Activate in order to set a different frame time in milliseconds. By default, the DVI device is set to be an *Event* type with a frame rate of 50 FPS.
  - If you manually set a new frame time, the output might judder.
  - It is not recommended to set a higher frame rate than 50 FPS. But if your hardware controller requires a frame rate that is lower than 50 FPS, adjust the value to these requirements. Then, the type of your device will be set to *Frame* in the list.

- **-** - Removes the currently selected DVI devices.
- **楔** - Calls up the configuration window again.
- **-** - Makes your device flash and will set all pixels instantly to white for testing purposes.

### Further Configuration

Remember to configure your light matrix in the »**Matrix Generator** or »**Patch Editor**

Make sure to save your MADRIX Setup after the configuration process.

### Important Notes

<table>
<thead>
<tr>
<th>Device Type</th>
<th>Comments</th>
</tr>
</thead>
</table>

### All DVI Device Types

1. Please do not use a network hub or switch. Please only use a direct network connection.
2. Use only Gigabit network cards.
3. Only connect via network cabling. A wireless connection [WiFi] will not work!
4. A maximum of 75 m of network cabling is recommended. When covering higher distances, data issues can occur.
5. Please note that the hardware controller needs to be configured correctly, before MADRIX can be used.
6. The configuration cannot be rotated. If you have rotated fixtures in your installation, please use the rotation features provided by each MADRIX effect.
7. Do not use different DVI device types on the same network! Always use a separate network for each proprietary DVI device type.

### EuroLite T9

1. Before using MADRIX, please make sure that you have configured your EUROLITE LED fixture and hardware correctly. The configuration is described in the EUROLITE user manual. Repeat the steps if necessary.
2. You can only create and use one single DVI device in MADRIX per network card. This means that a maximum of 56 controllers connected in series can be used per one network card with a maximum of 128x128 pixels for each controller.
3. Please note: Configure only one hardware controller at a time with the software EUROLITE LED Show T9. Please do not connect several controllers while setting the parameters.
4. See web link [www.eurolite.de](http://www.eurolite.de) for the latest documentation.

### Troubleshooting

If you are encountering problems, please work through the following checklist:

- Check if all network cables are connected correctly. Please do not use a network hub or switch.
- Check if your hardware is working without MADRIX.
- Check if you have installed the **WinPcap Driver** during the installation of MADRIX.
• Check if your light matrix is configured correctly in the **Matrix Generator** or **Patch Editor**

• Go to the menu **Preferences > Device Manager... > DVI Devices**. Check if you have added a new DVI device.

• Check if **Enable** and **Use Full Size** are activated for your device under **Preferences > Device Manager... > DVI Devices**

• Configure your hardware controller again if this seems to be necessary.

• Always configure only one hardware controller. Do not connect two or more controllers while setting the parameters.

• When using LED Show T9,
  1] repeat the steps described in the manual.
  2] make sure to click **Send** two times in order to save the **parameter set** on your PC and on your controller.
  3] download the configuration file again [for example, **Presets T9.DAT**] and use this default configuration file to configure your controller again.
  4] uninstall the software and then install it again. Reconfigure all settings.
6.7 Philips Hue

Topics of this chapter:
- Introduction
- Note
- Step-By-Step Configuration
- Additional Functionality
- Further Configuration
- Important Notes
- Additional Information

Introduction

MADRIX natively supports Philips Hue.

The protocol is implemented directly in the software, which makes it easy to use Philips Hue bridges and lamps with MADRIX.

Note

There are several steps required to set up Philips Hue products in MADRIX. This chapter is only part of the process. You need to set up other configurations as well [such as virtual LED matrix, DMX Devices, MADRIX Effects, Audio, etc.].

Step-By-Step Configuration

1] Set up the correct network settings in Windows.

2] Enable drivers in MADRIX.
3) Authorize A Bridge.

4) Set up the DMX universe.

5) Set up the Frame Time.

1] Network Settings

Philips Hue is a network-based protocol. MADRIX will use the network card of your computer to send data to the bridges.

- Connect the computer that runs the MADRIX Software and your Philips Hue bridges with the same computer network.
- To use Philips Hue, you need to have a separate DHCP server.
  - This can be a software or hardware DHCP server, which handles and assigns the IP addresses to the Hue bridges and to the MADRIX computer.
  - It is recommended that the DHCP server binds MAC addresses to IP addresses.

2] Enabling Drivers In MADRIX

- Go to the menu Preferences > Options... > Devices Network
  [Keyboard shortcut: Ctrl+Alt+O > Devices Network]

  - Activate Philips - Hue
- **Time To Detect Bridges And Lamps (s)** - Defines how long MADRIX searches the network for devices during startup. Type in a value in seconds.
  - The default value is 10.
  - *We recommend to utilize at least a value of 10 to allow for a sufficient search.*

**3] Authorize A Bridge**

- Go to the menu *Preferences > Device Manager... > DMX Devices*
  [Keyboard shortcut: F4]
- MADRIX automatically adds network devices it has found during startup to the list.
- Click if the devices have not been found.
  - MADRIX disconnects all devices and starts to search for new or newly connected devices.
  - *Do not rescan for devices if all of your interfaces have been found correctly.*
Select your device in the list.

- Activate **Enable**
- Confirm with **Apply**

1. When connecting a Hue bridge to MADRIX for the first time, you need to authorize the bridge first. MADRIX will ask you to authorize it:

![MADRIX Authorization Message](image)

2. In order to authorize the bridge, press the large Link button on the bridge itself.

3. Click **OK** in MADRIX in order to confirm that you have pressed the button on the bridge.

4. The authorization process starts. MADRIX will wait up to 30 seconds for the device to respond.
5A] When unsuccessful, MADRIX will provide an error message that the authorization process failed. If that is the case, please try to authorize it again.

![Error Message](image)

5B] When successful, the bridge will be authorized and enabled in MADRIX.

![Device Manager](image)

- If you wish to deactivate a bridge, select in in the **Device Manager > DMX Devices** and deactivate **Enable** under **Settings**. Confirm with **Apply**

5] DMX Universe

- Make sure that your device is still selected.
Set up *Universe*
- Enter the specific DMX universe number

This setting assigns a specific DMX universe [of the Patch] to the device or the port of the device.

**Make sure the correct universe is assigned according to your requirements.**
Learn more »Glossary

- Click *Apply*

### 6] Frame Time

- Make sure that your device is still selected.

- Set up *Frame Time (ms)*
  - The Frame Time affects the Frame Rate. The Frame Rate specifies how fast data is sent to the device or received from it [Frames Per Second; FPS].
  - Increase the Frame Time in order to decrease the Frame Rate [e.g., 40ms = 25 FPS].
  - Decrease the Frame Time in order to increase the Frame Rate [e.g., 20ms = 50 FPS].
  - The default and recommended value is 100 ms / 10 FPS.
  - *Some LED fixtures might have problems with a high Frame Rate. Then, it is recommended to increase the Frame Time / to decrease the Frame Rate.*

- Click *Apply*

### Additional Functionality

**Rescan For Devices**

*Rescan For Devices* - MADRIX disconnects all devices and starts a new search for devices.
Highlight Mode

*Highlight* - Activates the highlight mode for the selected interface and universe under *Preferences > Device Manager... > DMX Devices*. Select one or more interfaces and click the button. The corresponding fixtures at the selected interfaces will flash for a better identification or tests. This makes it easier to see them on stage. It considerably speeds up the procedure of programming or testing the selected interfaces.

DMX Watcher

*DMX Watcher* - Opens the DMX Watcher to monitor your DMX output or input under *Preferences > Device Manager... > DMX Devices*

Learn more »Tools

Resizing The Window

If wish to resize the window of the Device Manager to see more devices in the list, simply move your mouse pointer to the bottom of this window. Then, select the border and hold the left mouse button, while moving your mouse downwards.

Further Configuration

Remember to configure your virtual LED matrix in the »Matrix Generator or »Patch Editor

Make sure to save your MADRIX Setup after the configuration process.
Important Notes

- Keep in mind that network devices, if activated, cause network traffic!
- When using a network-based output protocol and when the Startup option Start MADRIX After Booting Windows is used, it is highly recommended to also activate the Startup option Start With Timeout(s) with a value of 30 or higher.

Additional Information

- A Hue bridge often has several status LEDs. Please consult the Hue manuals for more information. In general, they usually show these statuses:
  - Power LED Off: No power supplied.
  - Network LED Off: No network connected.
  - Network LED Blinking: No IP address assigned.
  - Network LED Permanently On: IP address successfully acquired.
  - Internet LED Off: No network connected.
  - Internet LED Blinking: No internet access available.
  - Internet LED Permanently On: Internet connection successfully established.
- You can use the official Philips Hue mobile App to update the firmware of your Philips Hue bridges.
7 INPUT And Remote Control

This topic includes:

- Introduction
- Topics Of This Chapter

Introduction

You can receive data in MADRIX through various ways. That means you can use another controller or device:

- to send data to the software and use this data.
- to send commands to the software for Remote Control.
- to route incoming data onto your output [also know as Mapping/Merging/DMX-Thru].

Topics Of This Chapter

There are several possibilities for input and remote control:

- **DMX-IN**
  Several protocols are implemented into MADRIX for remote control over DMX-IN. Any DMX console or desk can easily be used then to gain full control over the software.

- **Art-Net Remote**
  The Art-Net protocol includes Art-Net Remote. In this way, you can use a console for example to access certain software features remotely.

- **sACN Input**
  Receive Streaming ACN [E1.31] data for remote control.

- **MIDI-IN Configuration**
  MIDI controllers are an accessible and popular way to trigger the software. Learn how to configure your MIDI device in this section.
**MA-Net**
The MA-Net protocol is the direct connection to MA Lighting products that support MA-Net.

**Time Code [Art-Net / MIDI / SMPTE / System Time]**
Various types of Time Code can be received with MADRIX to synchronize equipment and devices with each other.

**CITP**
MADRIX supports CITP. This is a useful feature when controlling MADRIX remotely, especially when using it in a combination with a lighting desk.

**Remote HTTP**
MADRIX offers remote control with every internet browser. An internal web server is implemented in the software and can be started if required to gain external access.

**GamePort**
The GamePort is a device port to connect 3rd-party controllers.
7.1 DMX-IN / Art-Net Remote / sACN Input

This topic includes:
- Introduction
- Topics Of This Chapter

Introduction

This chapter is about DMX-IN, Art-Net Remote, and sACN input.

Topics Of This Chapter

Please refer to the corresponding chapters below:

- »DMX-IN Configuration
- »Art-Net Remote Configuration
- »sACN Input Configuration
- »DMX-IN [Essential Protocol]
- »DMX-IN [Standard Protocol]
- »DMX-IN [User]
- »DMX-IN Remote Editor
7.1.1 DMX-IN / Art-Net Remote / sACN Input Configuration

This topic includes:
- Overview
- DMX-IN
- Art-Net Remote
- Art-Net Remote Troubleshooting
- sACN Input
- Protocols [Overview]
- Important Notes

Overview

MADRIX can receive incoming data or can be controlled remotely [DMX Input].
That means you can use another controller or device:

- to send data to the software and use this data [e.g., for Scripts, Macros, or tests].
- to send commands to the software [Remote Control].
- to route incoming data onto your output [also known as Mapping/Merging/DMX-Thru].
- to trigger MADRIX TRI Effects.

In general, 3 options are available to you:

- **DMX-IN**
  [Receiving DMX input data]

- **Art-Net Remote**
  [Receiving Art-Net data]

- **sACN Input**
  [Receiving Streaming ACN data]
DMX-IN

Step-By-Step Configuration

1] Enable drivers for your MADRIX DMX device.
2] Activate your DMX device.
3] Enable DMX-IN.
4] Choose how to use incoming signals.

1] Enable Drivers For Your DMX Device

- Go to the menu Preferences > Options... > Devices USB
  [Keyboard shortcut: Ctrl+Alt+O > Devices USB]
- A new window will open.
- By default, the drivers for all MADRIX devices should be activated by default.
- If not, activate the appropriate driver. Learn more »Devices USB

2] Activate Your DMX Device

- Go to the menu Preferences > Device Manager... > DMX Devices
  [Keyboard shortcut: F4]
- A new window will open.
• MADRIX may have already found your connected DMX devices. They will be shown in the list.

• Click if your DMX devices are not shown in the list.

• Select your DMX device in the list.

• Activate Enable, and activate Input in the section Settings

• Click Apply to confirm.
3] Enable DMX-IN

- Go to the menu *Preferences > Device Manager... > DMX Input*

- Select your preferred DMX *Universe* in the list.
  [By default, DMX universe 1 to 8 are listed. If you wish to increase the number of DMX-IN universes, you can change the setting. Learn more »*Performance*]

- Choose your *DMX-IN Device* in the section *Device*
[If needed, you can disable DMX-IN by choosing None for your **DMX-IN Device** in the section **Device**]

### 4] Choose How To Use Incoming Signals

**Data**

- At this point, MADRIX is now already receiving any incoming data.
- You can now use this data, for example for Scripts and Macros. Learn more »[Macros And Scripts](#)
- If you want to monitor incoming signals, select your DMX universe/DMX device in the list and click Learn more »[Tools](#)

**Mapping**

- Use Mapping, if you want to route incoming DMX signals through MADRIX to your output [DMX-Thru].
- First, select your device in the list.
- **Activate Mapping**
- This feature maps incoming data to the specified DMX universe and channels.
- Configure the following settings in the section **Mapping**
  - **Map Channels From** - Defines which incoming channels are used. This is the start channel to specify the range of channels.
  - **To** - Defines which incoming channels are used. This is the end channel to specify the range of channels.
  - **To Universe** - Defines onto which output DMX universe MADRIX should map the specified range of incoming channels.
  - **Start At Channel** - Defines the first DMX channel of the output DMX universe MADRIX should use.
  - **Use HTP** - Activates the Highest Takes Precedence feature. You can map incoming data to a DMX address range that MADRIX already controls. Use HTP and MADRIX will compare incoming values with the DMX data it sends to the DMX output. As a result, MADRIX will only use the highest of both values on a particular channel and send it to the output.
- Click **Apply** to confirm.

**Remote Control**

- Use Remote Control, if you want to control the MADRIX Software remotely.
- First, select your device in the list.
- Activate **Remote**
Select one of the built-in protocols in the section **Remote Control** as explained below or create your own remote configuration.

**Open** - Loads a previously saved MADRIX DMX Remote Configuration file [of the file type *.mdrx].

**Protocols** - Choose from a pre-configured protocol [configuration].

Learn more [Protocols [Overview]]

**DMX-IN Remote Editor** - Allows you to modify a configuration or create a new configuration.

Learn more [DMX-IN Remote Editor]

**Start Address** - Defines on which particular DMX channel the protocol should start. The whole protocol will be mapped to this new address area.
**DMX Watcher** - Opens the DMX Watcher to monitor your DMX output or input.

Learn more »[Tools](#)

### Trigger

- Use Trigger, if you want to use incoming signals for the MADRIX TRI Effects.
- First, select your device in the list.
- Activate **Trigger**
**Port** - Defines the port [Port 1 - 8] that is assigned to this DMX-IN Device. MADRIX allows you to send trigger signals from up to 8 different devices [8 ports] and assign a MADRIX TRI Effect the corresponding port.

**Value Range** - Defines the range of incoming DMX values that can be used as trigger signal.
- The minimum and default value is 1.
- The maximum and default value is 512.

**Assign Minimum Value** - Automatically assigns the minimum value when using the controller.
- Click **Assign** and use the control on your controller for the minimum value and the value will be set automatically in the MADRIX Software.

**Assign Maximum Value** - Automatically assigns the maximum value when using the controller.
- Click **Assign** and use the control on your controller for the maximum value and the value will be set automatically in the MADRIX Software.

Learn more »[TRI] Trigger Effects

## Art-Net Remote

### Overview
An Art-Net device can be used for DMX input as well. This feature is called Art-Net Remote.

**Step-By-Step Configuration**

1] Set up network settings in Windows.
2] Activate Art-Net and create an input device.
3] Create an Art-Net input device.
4] Enable DMX-IN.
5] Choose how to use incoming signals.

**1] Set Up Network Settings In Windows**

Art-Net is used to send DMX512 data over Ethernet network. Because of this, you need to configure the settings of your network card in Windows first.

- Configure your network card in Windows.
- Use an *IP address* from the following address range:
  - 2.0.0.1 ... 2.255.255.254
  - or
  - 10.0.0.1 ... 10.255.255.254
- Use the following *Subnet mask*
  - 255.0.0.0
- Learn more »[Tips [Microsoft Windows / Networks / USB]]

**You must use this address area! Art-Net may not work otherwise.**

**2] Activate Art-Net And Create An Input Device**

- Go to the menu *Preferences > Device Manager... > Art-Net*
  - [Keyboard shortcut: *F4 > Art-Net*]`
- A new window will open.
- Activate the checkbox **Enable** [in the upper, right corner].

- Click 

- A new window will open.

- **Port Type** - Choose **Input**.
• **Number Of New Devices** - Enter the number of devices you wish to add. [1 is often enough and thus recommended.]

• **Port Count Per Device** - Enter the number of ports each newly created device should have. Per device a maximum number of 4 ports is available. [1 is often enough and thus recommended.]

• **Receive Via Unicast Mode** - Activates Unicast Mode for all newly created input devices.

Select the input device in the list.

Click

A new window will open.
Configure the following settings:

- **Port Count** - Defines how many DMX universes can be received by MADRIX. You can choose 1, 2, 3, or 4. [MADRIX can receive a maximum of 4 universes regarding Art-Net Remote.]

- **Universe Port IN** - Defines from which DMX universe MADRIX receives the data.
  - Choose the universe on which your Art-Net device is sending the data!
- **Receive Broadcast Mode** - If activated, MADRIX can receive data from all network addresses in the network.
  - Any Art-Net device, such as a lighting desk, can send data to MADRIX.
  - Select the correct network card.

- **Receive Unicast Mode** - If activated, MADRIX will only receive data from the specified IP address. [This is the recommended setting.]
  - **IP Address** - Needs to be set up if Unicast Mode is activated.
  - Enter the IP address of the device that is sending data to MADRIX. Do not enter the IP address of your MADRIX PC!

- Click **Apply** to confirm.
- Click **OK** to close the window.

### 3] Activate The Art-Net Input Device

- Go to the menu **Preferences > Device Manager... > DMX Devices**

- Your **ArtNet** input device will be shown in the list.
  - [If the **Port Count** above is set to 2, 3, or 4, you will see up to 4 devices in the list.]

- Select your devices in the list.
- Activate **Enable** in the section **Settings**.
  - **Input** is automatically selected.
• If needed, adjust **Frame Time (ms)** to increase or decrease the **FPS** [Frames Per Second].

• Click **Apply** to confirm.

---

**4] Enable DMX-IN**

• Go to the menu **Preferences > Device Manager... > DMX Input**
Select your preferred DMX *Universe* in the list. [By default, DMX universe 1 to 8 are listed. If you wish to increase the number of DMX-IN universes, you can change the setting. Learn more »Performance]

Select your *DMX-IN Device* in the section *Device* by choosing the *ArtNet* input device.

[If needed, you can disable DMX-IN by choosing *None* for your *DMX-IN Device* in the section *Device*]

5] Choose How To Use Incoming Signals

**Data**

- At this point, MADRIX is now already receiving any incoming data.
- You can now use this data, for example for Scripts and Macros. Learn more »Macros And Scripts
- If you want to monitor incoming signals, select your DMX universe/DMX device in the list and click Learn more »Tools

**Mapping**

- Use Mapping, if you want to route incoming DMX signals through MADRIX to your output [DMX-Thru].
First, select your device in the list.

Activate **Mapping**

This feature maps incoming data to the specified DMX universe and channels.

Configure the following settings in the section **Mapping**

- **Map Channels From** - Defines which incoming channels are used. This is the start channel to specify the range of channels.
- **To** - Defines which incoming channels are used. This is the end channel to specify the range of channels.
- **To Universe** - Defines onto which output DMX universe MADRIX should map the specified range of incoming channels.
- **Start At Channel** - Defines the first DMX channel of the output DMX universe MADRIX should use.
- **Use HTP** - Activates the Highest Takes Precedence feature. You can map incoming data to a DMX address range that MADRIX already controls. Use HTP and MADRIX will compare incoming values with the DMX data it sends to the DMX output. As a result, MADRIX will only use the highest of both values on a particular channel and send it to the output.

Click **Apply** to confirm.

**Remote Control**

Use Remote Control, if you want to control the MADRIX Software remotely
- First, select your device in the list.
- Activate Remote
- Select one of the built-in protocols in the section Remote Control as explained below or create your own remote configuration.

Open - Loads a previously saved MADRIX DMX Remote Configuration file [of the file type *.mdrx].

Protocols - Choose from a pre-configured protocol [configuration].
Learn more Protocols [Overview]

DMX-IN Remote Editor - Allows you to modify a configuration or create a new configuration.
Learn more »DMX-IN Remote Editor
**Start Address** - Defines on which particular DMX channel the protocol should start. The whole protocol will be mapped to this new address area.

**DMX Watcher** - Opens the DMX Watcher to monitor your DMX output or input.
Learn more »Tools

**Trigger**

- Use Trigger, if you want to use incoming signals for the MADRIX TRI Effects.
- First, select your device in the list.
- Activate **Trigger**
**Port** - Defines the port [Port 1 - 8] that is assigned to this DMX-IN Device. MADRIX allows you to send trigger signals from up to 8 different devices [8 ports] and assign a MADRIX TRI Effect the corresponding port.

**Value Range** - Defines the range of incoming DMX values that can be used as trigger signal.
- The minimum and default value is 1.
- The maximum and default value is 512.

**Assign Minimum Value** - Automatically assigns the minimum value when using the controller.
- Click **Assign** and use the control on your controller for the minimum value and the value will be set automatically in the MADRIX Software.

**Assign Maximum Value** - Automatically assigns the maximum value when using the controller.
- Click **Assign** and use the control on your controller for the maximum value and the value will be set automatically in the MADRIX Software.

Learn more »[TRI] Trigger Effects

**Art-Net Remote Troubleshooting**

If you are encountering problems, please work through the following checklist:
- Double-check the settings of your network card.
- Make sure to set up the Windows Firewall correctly. Learn more »Tips [Microsoft Windows / Networks / USB]
- Double-check the settings of the ArtNet Remote device in MADRIX.
- Use the DMX Watcher to monitor incoming data.

**sACN Input**

**Overview**

Streaming ACN devices can be used for DMX input as well.

1] **Windows Network Settings**

- MADRIX automatically sets up Streaming ACN network settings for you.
- You only need a computer with a network card and a valid IP address.

- You do not have to change the IP address settings in Windows for Streaming ACN!
- The IP address range for sACN devices is 239.255.X.X according to the Streaming ACN specifications.
  [Even if your sACN devices are set to a different IP address range, you may try the connection from MADRIX to your devices.]
- Make sure that your Firewall does not block data of the 239.255.X.X IP address range!
- Check the settings of the Windows Firewall.
- Learn more »Tips [Microsoft Windows / Networks / USB]

2] **Activating Streaming ACN**
Go to the menu *Preferences > Options... > Devices Network*
[Keyboard shortcut: *Ctrl+Alt+O > Devices Network*]

- **Activate Enable ESTA - Streaming ACN**

- **Choose your network card** from the drop-down list. Make sure to select the correct network adapter that will be used for Streaming ACN!
  
  [The IP address and Subnet mask label should help you select the correct adapter. It is not necessary to change any of these networks settings.]

- **ACN Device Count** - Set up how many you are going to use.
  
  [This is the total amount of OUT and IN devices. Please set the exact number of devices you are using. If the count is higher, this creates unnecessary network traffic.]

- Press **Apply**
- **ACN CID** - Being a network protocol, Streaming ACN sends a so-called CIDs [Component Identifier].
  - Every single ACN device has such a unique ID.
  - When using Streaming ACN, your MADRIX Software is one of those devices.
  - When you start MADRIX for the first time, this ID will be generated automatically for you. From this point onwards it will be used on your PC.
  - With this ID your MADRIX Software can be easily identified in the network. Interfaces can detect this unique ID and can be configured to receive data from this particular device. Please note that the ACN interface must support this feature.
  - **Do not change the ACN CID, unless you are an experienced user!**
- Press **OK** to close the window.

### 3] Enabling Input

- Go to **Preferences > Device Manager... > DMX Devices**
  [Keyboard shortcut: **F4**]
- MADRIX automatically creates and adds the number of interfaces to the list.
  [according to **ACN Device Count**]
- Select your device.
- Enable **Input** if you wish to receive incoming data through this device.
- Click **Apply**
- In DMX-IN mode, you will not be able to select the ACN protocol. MADRIX will automatically select the correct protocol version.
- **Note:** If you are loading a MADRIX Setup, please check if the number of ACN devices in your setup corresponds with the number that is activated. The Setup stores the number of devices. But if you changed the amount and then loaded the Setup, the newly defined number will be activated.

**4] Configure Your Device**

- Make sure that your device is still selected under *Preferences > Device Manager... > DMX Devices*

- Click 

- A new window will open.
Set up the following settings for your devices:

- **Source Name** - Allows you to set up a specific name for the device. This name is send via network as well. Therefore, interfaces may be able to retrieve this name and can be configured to receive data from this source.
  - If you are using the default name *MADRIX U:X*, the universe will automatically be displayed in the name [represented by X: 1, 2, 3, etc.].

- **ACN Universe** - Defines the DMX universe from which data is received.
  - **Set up the same universe that is set up in your sACN device.**
  - According to the Streaming ACN specifications, MADRIX will automatically change the ACN IP Address according to the ACN Universe.

- Press **Apply** to confirm your changes.
- Press **OK** to close the window.

### 5] Enable DMX-IN

- Go to the menu **Preferences > Device Manager... > DMX Input**
Select your preferred DMX *Universe* in the list.

[By default, DMX universe 1 to 8 are listed. If you wish to increase the number of DMX-IN universes, you can change the setting. Learn more »Performance.]

Choose your **DMX-IN Device** in the section **Device**

[If needed, you can disable DMX-IN by choosing None for your **DMX-IN Device** in the section **Device**]
6] Choose How To Use Incoming Signals

Data
- At this point, MADRIX is now already receiving any incoming data.
- You can now use this data, for example for Scripts and Macros. Learn more »[Macros And Scripts]
- If you want to monitor incoming signals, select your DMX universe/DMX device in the list and click Learn more »[Tools]

Mapping
- Use Mapping, if you want to route incoming DMX signals through MADRIX to your output [DMX-Thru].
- First, select your device in the list.
- Activate Mapping
- This feature maps incoming data to the specified DMX universe and channels.
• Configure the following settings in the section **Mapping**
  - **Map Channels From** - Defines which incoming channels are used. This is the start channel to specify the range of channels.
  - **To** - Defines which incoming channels are used. This is the end channel to specify the range of channels.
  - **To Universe** - Defines onto which output DMX universe MADRIX should map the specified range of incoming channels.
  - **Start At Channel** - Defines the first DMX channel of the output DMX universe MADRIX should use.
  - **Use HTP** - Activates the Highest Takes Precedence feature. You can map incoming data to a DMX address range that MADRIX already controls. Use HTP and MADRIX will compare incoming values with the DMX data it sends to the DMX output. As a result, MADRIX will only use the highest of both values on a particular channel and send it to the output.

• Click **Apply** to confirm.

**Remote Control**

• Use Remote Control, if you want to control the MADRIX Software remotely

• First, select your device in the list.

• Activate **Remote**

• Select one of the built-in protocols in the section **Remote Control** as explained below or create your own remote configuration.
Open - Loads a previously saved MADRIX DMX Remote Configuration file [of the file type *.mdrx].

Protocols - Choose from a pre-configured protocol [configuration].
Learn more Protocols [Overview]

DMX-IN Remote Editor - Allows you to modify a configuration or create a new configuration.
Learn more »DMX-IN Remote Editor

Start Address - Defines on which particular DMX channel the protocol should start. The whole protocol will be mapped to this new address area.

DMX Watcher - Opens the DMX Watcher to monitor your DMX output or input.
Learn more »Tools

Trigger

- Use Trigger, if you want to use incoming signals for the MADRIX TRI Effects.
- First, select your device in the list.
- Activate Trigger
Port - Defines the port [Port 1 - 8] that is assigned to this DMX-IN Device. MADRIX allows you to send trigger signals from up to 8 different devices [8 ports] and assign a MADRIX TRI Effect to the corresponding port.

Value Range - Defines the range of incoming DMX values that can be used as trigger signal.
- The minimum and default value is 1.
- The maximum and default value is 512.

Assign Minimum Value - Automatically assigns the minimum value when using the controller.
- Click Assign and use the control on your controller for the minimum value and the value will be set automatically in the MADRIX Software.
Assign

Assign Maximum Value - Automatically assigns the maximum value when using the controller.
- Click Assign and use the control on your controller for the maximum value and the value will be set automatically in the MADRIX Software.

Learn more » [TRI] Trigger Effects

Protocols [Overview]

There are preprogrammed DMX protocols you can choose from:

- >DMX-IN [Essential Protocol]
- >DMX-IN [Standard Protocol]
- >DMX-IN [User]

Important Notes

- Please make sure to save your MADRIX Setup file after the configuration process.
7.1.2 DMX-IN [Essential Protocol]

This topic includes:
- Introduction
- Overview
- Other Protocols

**Introduction**

The Essential Protocol is a pre-configured DMX protocol [or profile] you can use for Remote Control.

- Essential Protocol uses 6 DMX channels.
- Valid incoming DMX values are 0 - 255.

**Overview**

<table>
<thead>
<tr>
<th>DMX Channel</th>
<th>Remote Control Function</th>
<th>DMX Values</th>
<th>Functionality</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>Output Master</td>
<td>0 - 255</td>
<td>0 - 255</td>
<td>Control the overall intensity.</td>
</tr>
<tr>
<td>02</td>
<td>Deck A Storage ID</td>
<td>0 - 255</td>
<td>Storage, Deck A, 1 - 256</td>
<td>Choose Storage 1 to 256 on the left side.</td>
</tr>
<tr>
<td>03</td>
<td>Deck A Place ID + Fade</td>
<td>0 - 255</td>
<td>Storage Place, Deck A, 1 - 256</td>
<td>Choose your Storage Place in the selected Storage on the left side. A fade of the crossfader is applied automatically according to the Fade Time.</td>
</tr>
<tr>
<td>04</td>
<td>Fade In 1/10 Seconds</td>
<td>0 - 100</td>
<td></td>
<td>Set up the Fade Time of the crossfader in tenths of a second.</td>
</tr>
</tbody>
</table>
### Other Protocols

There are other preprogrammed DMX protocols you can choose from:

- »**DMX-IN [Standard Protocol]**
- »**DMX-IN [User]**

<p>| | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>05</td>
<td>Fade Type</td>
<td>0 – 255</td>
<td>Set up the Fadea Type of the crossfader.</td>
</tr>
<tr>
<td>06</td>
<td>Deck A Speed Master</td>
<td>0 – 255</td>
<td>Control the overall speed of Deck A.</td>
</tr>
</tbody>
</table>
7.1.3 DMX-IN [Standard Protocol]

This topic includes:
- Introduction
- Overview
- Other Protocols

Introduction

The Standard Protocol is a pre-configured DMX protocol [or profile] you can use for Remote Control.

- Standard Protocol uses 36 DMX channels.
- Valid incoming DMX values are 0 - 255.

Overview

<table>
<thead>
<tr>
<th>DMX Channel</th>
<th>Remote Control Function</th>
<th>DMX Values</th>
<th>Functionality</th>
<th>Comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>Output Master</td>
<td>0 - 255</td>
<td>0 - 255</td>
<td>Control the overall intensity.</td>
</tr>
<tr>
<td>02</td>
<td>Deck A Storage ID</td>
<td>0 - 255</td>
<td>Storage, Deck A, 1 - 256</td>
<td>Choose Storage 1 to 256 on the left side.</td>
</tr>
<tr>
<td>03</td>
<td>Deck A Place ID + Fade</td>
<td>0 - 255</td>
<td>Storage Place, Deck A, 1 - 256</td>
<td>Choose your Storage Place in the selected Storage on the left side. A fade of the crossfader is applied automatically according to the Fade Time.</td>
</tr>
<tr>
<td>04</td>
<td>Fade In 1/10 Seconds</td>
<td>0 - 100</td>
<td></td>
<td>Set up the Fade Time of the crossfader in tenths of a second.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td>---</td>
<td>---</td>
<td></td>
</tr>
<tr>
<td>05</td>
<td>Fade Type</td>
<td>0 - 255</td>
<td>Set up the Fadea Type of the crossfader.</td>
<td></td>
</tr>
<tr>
<td>06</td>
<td>Deck A Speed Master</td>
<td>0 - 255</td>
<td>Control the overall speed of Deck A.</td>
<td></td>
</tr>
<tr>
<td>07</td>
<td>Output Filter Color Mode</td>
<td>0 - 255</td>
<td></td>
<td></td>
</tr>
<tr>
<td>08</td>
<td>Output Filter Color Red</td>
<td>0 - 255</td>
<td></td>
<td></td>
</tr>
<tr>
<td>09</td>
<td>Output Filter Color Green</td>
<td>0 - 255</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Output Filter Color Blue</td>
<td>0 - 255</td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Output Filter Color White</td>
<td>0 - 255</td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Output Filter</td>
<td>0 - 255</td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>Output Strobe</td>
<td>0 - 255</td>
<td>Ranging from slow to fast. 0 = Off.</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>Output Strobe Color Mode</td>
<td>0 - 255</td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>Output Strobe Color Red</td>
<td>0 - 255</td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>Output Strobe Color Green</td>
<td>0 - 255</td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>Output Strobe Color Blue</td>
<td>0 - 255</td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>Output Strobe Color White</td>
<td>0 - 255</td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>Audio Output Level</td>
<td>0 - 255</td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>Audio Input Level</td>
<td>0 - 255</td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>Group Control Value Group 1</td>
<td>0 - 255</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Group Control</td>
<td>Value Group</td>
<td></td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>--------------</td>
<td>--------------</td>
<td>---</td>
<td></td>
</tr>
<tr>
<td>22</td>
<td>Group Control</td>
<td>Value Group 2</td>
<td>0 - 255</td>
<td></td>
</tr>
<tr>
<td>23</td>
<td>Group Control</td>
<td>Value Group 3</td>
<td>0 - 255</td>
<td></td>
</tr>
<tr>
<td>24</td>
<td>Group Control</td>
<td>Value Group 4</td>
<td>0 - 255</td>
<td></td>
</tr>
<tr>
<td>25</td>
<td>Group Control</td>
<td>Value Group 5</td>
<td>0 - 255</td>
<td></td>
</tr>
<tr>
<td>26</td>
<td>Group Control</td>
<td>Value Group 6</td>
<td>0 - 255</td>
<td></td>
</tr>
<tr>
<td>27</td>
<td>Group Control</td>
<td>Value Group 7</td>
<td>0 - 255</td>
<td></td>
</tr>
<tr>
<td>28</td>
<td>Group Control</td>
<td>Value Group 8</td>
<td>0 - 255</td>
<td></td>
</tr>
<tr>
<td>29</td>
<td>Group Control</td>
<td>Value Group 9</td>
<td>0 - 255</td>
<td></td>
</tr>
<tr>
<td>30</td>
<td>Group Control</td>
<td>Value Group 10</td>
<td>0 - 255</td>
<td></td>
</tr>
<tr>
<td>31</td>
<td>Group Control</td>
<td>Value Group 11</td>
<td>0 - 255</td>
<td></td>
</tr>
<tr>
<td>32</td>
<td>Group Control</td>
<td>Value Group 12</td>
<td>0 - 255</td>
<td></td>
</tr>
<tr>
<td>33</td>
<td>Group Control</td>
<td>Value Group 13</td>
<td>0 - 255</td>
<td></td>
</tr>
<tr>
<td>34</td>
<td>Group Control</td>
<td>Value Group 14</td>
<td>0 - 255</td>
<td></td>
</tr>
<tr>
<td>35</td>
<td>Group Control</td>
<td>Value Group 15</td>
<td>0 - 255</td>
<td></td>
</tr>
<tr>
<td>36</td>
<td>Group Control</td>
<td>Value Group 16</td>
<td>0 - 255</td>
<td></td>
</tr>
</tbody>
</table>
Other Protocols

There are other preprogrammed DMX protocols you can choose from:

- »DMX-IN [Essential Protocol]
- »DMX-IN [User]
7.1.4 DMX-IN [User]

This topic includes:
- Introduction
- Other Protocols

Introduction

The protocol DMX-IN [User] describes individual configurations you can create as a user. That means you can assign DMX-IN freely and create your own configuration. Set up your own configuration by using the DMX-IN Remote Editor.

Learn more »DMX-IN Remote Editor

Other Protocols

There are other preprogrammed DMX protocols you can choose from:

- »DMX-IN [Essential Protocol]
- »DMX-IN [Standard Protocol]
- »DMX-IN [User]
7.1.5 DMX-IN Remote Editor

This topic includes:
- Introduction
- Initial Configuration
- Overview
- Keyboard Shortcuts
- Configuration
- Examples

Introduction

Any DMX input signal can be used to control MADRIX remotely. While you can use preconfigured DMX protocols, you can also set up such a configuration according to your needs with the help of the **DMX-IN Remote Editor**. This topic describes how to use the DMX-IN Remote Editor.

Initial Configuration

- Make sure to configure your DMX device first.
  
  [For example, DMX devices can be consoles, DMX desks, fader boards, other DMX interfaces, etc.]

- Set up DMX Input.

- Learn more »[DMX-IN / Art-Net Remote / sACN Input](#)

Overview

- Go to the menu *Preferences > Device Manager... > DMX Input*
Click **Edit...** to open the **DMX-IN Remote Editor**

- A new window will open.

- If you are creating a new DMX protocol, the list will be empty.
- If you are modifying an existing DMX protocol map, the list will already contain all preconfigured settings.

**Add** - Adds a new item to the list.

**Remove** - Removes the currently selected list items.

**Duplicate/Copy** - Copies and duplicates the currently selected list item. The new item will be added to the list right after the selected item. You can change its settings afterwards.

**Navigation** - Allows you to select the next or previous list item.
**New** - Creates a new configuration while deleting all previous list items with your permission.
- Allows you to create an empty DMX Remote Configuration [*Empty*] or load a preconfigured DMX protocol [*Essential, Standard*].

**Open** - Loads a previously saved DMX Remote Configuration file into the DMX-IN Remote Editor from an external file [of the file type *.mdrx]*.

**Save** - Saves the current DMX Remote Configuration to an external file [of the file type *.mdrx]*.

**Save As** - Save the current DMX Remote Configuration to another external file [of the file type *.mdrx]. Simply enter a name and click Save.

**Assign** - Allows you to assign a control of your DMX controller to a function in MADRIX.
- 1] Activate **Assign**, select an list item you created and move the control of your DMX controller.
- 2] In most cases, MADRIX will automatically recognize the identify the DMX Channel, Control Type, and Interaction for the control. Learn more [Configuration](#).

**Test** - Allows you to test single list items and their functionality on the MADRIX user interface, while having the DMX-IN Remote Editor still opened.
- Activate Test, then use the control on your DMX controller. You can see if the control works as expected on the MADRIX user interface.
- If Test is activated, MADRIX will receive the signal directly and not the DMX-IN Remote Editor.

- Test is also useful for testing modifiers. Learn more [Modifiers](#).
Configuration Name - Allows you to type in an individual description for your DMX Remote Configuration.
- Once saved, you will be able to select your DMX Remote Configuration under Preferences > Device Manager... > MIDI > Remote Control and MADRIX will use this label.

Keyboard Shortcuts

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + A</td>
<td>Selects all items in the list.</td>
</tr>
<tr>
<td>Ctrl + E [hold]</td>
<td>Activates Assign, while holding this shortcut.</td>
</tr>
<tr>
<td>Ctrl + N</td>
<td>Creates a new configuration.</td>
</tr>
<tr>
<td>Ctrl + O</td>
<td>Opens a configuration.</td>
</tr>
<tr>
<td>Ctrl + S</td>
<td>Saves a configuration.</td>
</tr>
<tr>
<td>Ctrl + T [hold]</td>
<td>Activates Test, while holding this shortcut.</td>
</tr>
<tr>
<td>Del</td>
<td>Removes selected items from the list.</td>
</tr>
<tr>
<td>Arrow Up</td>
<td>Navigates upwards in the list.</td>
</tr>
<tr>
<td>Arrow Down</td>
<td>Navigates downwards in the list.</td>
</tr>
<tr>
<td>Double-click on an item</td>
<td>Calls up the context menu for the column.</td>
</tr>
<tr>
<td>Double-click on a head row of the list</td>
<td>Sorts the list alphabetically according to the column [ascending or descending].</td>
</tr>
</tbody>
</table>
Configuration

Overview

- Each list item represents 1 DMX remote functionality using 1 DMX control [i.e., button, fader, etc.].
- Configure each list item as required.
- Configure each column of an list item.
- Add or remove list items to add or remove the functionality you require.

<table>
<thead>
<tr>
<th>Function</th>
<th>DMX Channel</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="" /></td>
<td>![image]</td>
</tr>
</tbody>
</table>

1] Create a new item with +
Or select a list item and perform a double-click with your mouse on the column Function

2] Select the general topic [e.g., Audio]

3] Select the exact function you wish to configure [e.g., Volume]

A] Click Assign, select a list item and use a control on your DMX controller. In most cases, MADRIX will automatically recognize the DMX Channel, Control Type, and Interaction.

B] Or first select a list item and perform a double-click with your mouse on the column DMX Channel. Second, enter the correct DMX channel [e.g., CH01 for channel 01].
1] Select a list item and perform a double-click with your mouse on the column **Invert**.

2] The item will change between **No** and **Yes**
   - If Yes is selected, all values of this control will be inverted. That means for example that 0 becomes 255 and 255 becomes 0.
   - No is the default value. No values will be inverted.

- Select an item and perform a double-click with your mouse on the column **MIN**, **MAX**, or **Description**. Enter the desired value or text.

- **MIN** - Defines a minimum value for this functionality. The default value is 0.

- **MAX** - Defines requires a maximum value for this functionality.
   - For example, the Master Fader has a maximum value of 255, or you may want to set the maximum Fade Time to 10 seconds.

- **Description** - Allows you to enter a text to describe the functionality.
   - [By default, the name of the function will automatically be entered].
1] Select a list item and perform a double-click with your mouse on the column **Invert**.

2] The item will change between **Always** and **Value Changed**
   - If **Always** is selected, the remote command will be always processed by the software.
   - If **Value Changes** is selected, the remote command will only be processed when the incoming value on this DMX channel changed.

### Saving Your Configuration

- Please save your configuration after you have configured all functions!
- If you are closing the DMX-IN Remote Editor and have not yet saved, the MADRIX Software will remind you to save the file.
- If you do not save, your configuration will be discarded and is lost.

- The MADRIX Setup file does not include the external DMX Remote Configuration file, but will store the directory and a reference link in order to reload it when the Setup is loaded again.

### Examples
**Example 1**

- You wish to use single buttons of your DMX controller for each Storage Place.

- Use + to create a new function.

- Select **Deck A > Place ID +Fade**

- Use **Assign** to match your button to this function. Disable Assign again when done.

- Set **MAX** to 0 in order to trigger Storage Deck A S1 P1 [Storage 1 Place 1].

- Repeat the steps and set up **MAX** for each Storage Place you wish to control.
  - **MAX** will always have a value that is -1 compared to the actual Storage Place index number [e.g., set MAX to 6 in order to control S1 P7]

- Use **Deck B > Place ID +Fade** and repeat the steps accordingly to control the Storage Places on the right side.
7.2 MIDI-IN

This topic includes:
- Introduction
- Topics Of This Chapter

Introduction

This chapter is about DMX-IN, Art-Net Remote, and sACN input.

Topics Of This Chapter

Please refer to the corresponding chapters below:
- »MIDI-IN Configuration
- »MIDI Remote Editor
- »Akai Professional APC40
- »Akai Professional APC40 MKII
- »Akai Professional APCkey25
- »Akai Professional APCmini
- »Akai Professional LPD8
- »Akai Professional LPK25
- »Akai Professional MIDIMIX
- »Akai Professional MPK249
- »Akai Professional MPK261
- »Akai Professional MPKmini MKII
- »Behringer BCD3000
- »Behringer BCF2000
* Behringer BCR2000
* Creative Prodikeys PC-MIDI
* Elation Professional MIDICON
* Hercules DJ Console Rmx
* Hercules DJ Control MP3 And DJ Console MK2
* Hercules DJ Control MP3 e2
* KORG nanoKONTROL
* KORG nanoKONTROL2
* Livid Instruments Ohm64
* M_AUDIO Code 49
* M-AUDIO Oxygen 8 v2
* M-AUDIO Torq Xponent
* MIDI Keyboards
* MIDI Universal
* Novation Launchpad
* Numark NuVJ
* Numark Omni Control
* Numark Stealth Control
* Numark Total Control
* Omnitronic MMC-1
* Stanton SCS.3d
* USER User
* Vestax VCI-100
* Vestax VCM-100
7.2.1  MIDI-IN Configuration

This topic includes:
- Introduction
- Interruption-Free Operation
- Step-By-Step Configuration
- MIDI Audio
- MIDI Remote Control
- MIDI Time Code
- MIDI Trigger
- MIDI Watcher
- Important Notes

Introduction

MIDI [short for Musical Instrument Digital Interface] is a widely-known communication standard and digital interface. In MADRIX, there are mainly 4 areas of application for MIDI:

- Using MIDI devices for audio input via MIDI
- Using MIDI controllers for Remote Control
- Using MIDI Time Code
- Using MIDI controllers for MADRIX TRI Effects

MIDI devices are often simply connected directly via USB or via a MIDI-to-USB interface to the computer.
**Interruption-Free Operation**

To ensure interruption-free operation of the software and devices, please make sure to check the power-saving settings of Windows.

Learn more »[PC Power Management](#)

---

**Step-By-Step Configuration**

1] Connect your MIDI device.

2] Set up MIDI and enable your device.

3] Choose how to use the device and incoming signals.

---

**1] Connect Your MIDI Device**

- Connect your controller to the computer.
- Make sure that Windows recognizes the device and install drivers if necessary.

**2] Set Up MIDI**

- Go to the menu *Preferences > Remote Control > MIDI*..
  
  or to *Preferences > Device Manager... > MIDI*

  [Keyboard shortcut: `F4 > MIDI`]

- A new window will open.
Click \[\text{🔍}\]

MADRIX will automatically search for connected devices. 
Your MIDI device will be shown in the list.

Select your device in the list.

Activate **Enable**

[Please note that the **State** in the list will change from **Off** to **On**.]
3] Choose How To Use MIDI

Now, several options are available to you:

- **Audio** - Activates your MIDI device to be used as audio source [a MIDI keyboard, for example].
  Learn more [MIDI Audio](#)

- **Remote** - You can use your MIDI VJ/DJ controller or console to control MADRIX remotely.
  Learn more [MIDI Remote Control](#)

- **MTC** - You can use MADRIX to receive external MIDI Time Code.
  Learn more [MIDI Time Code](#)

- **Trigger** - You can use your MIDI VJ/DJ controller to trigger MADRIX TRI Effects.
  Learn more [MIDI Trigger](#)

- **Watch** - Launches the MIDI Watcher to monitor incoming signals or troubleshoot.
  Learn more [MIDI Watcher](#)

- You can activate several MIDI devices at the same time.

- You can use all options at the same time [Audio, Remote, MTC, Trigger, Watch].
MIDI Audio

- Activate your MIDI device as explained above.
- Again, go to the menu **Preferences > Remote Control > MIDI**
  or to **Preferences > Device Manager... > MIDI**
  [Keyboard shortcut: **F4 > MIDI**]
- A new window will open.

- Select your device in the list.
- Activate **Audio**
  [Please note that **Audio** in the list will change from **Off** to **On**.]

- Now, the **Audio** section below will be activated.

- **Use For S2L** - Activates the audio analysis of incoming MIDI signals for Sound2Light effects. This option is activated by default.
- **Use For M2L** - Activates the audio analysis of incoming MIDI signals for Music2Light effects. This option is activated by default.
**Channel Selection** - Defines which MIDI channel will be scanned and used by MADRIX.
- In general, MIDI offers 16 channels. You can configure each MIDI device to send on a particular channel. Make sure that this channel is also selected in this section here.
- If you wish to filter a channel, deselect the according number. As a result, the channel will not be used for MIDI-IN Configuration in combination with MADRIX.
- By default, all 16 channels are activated and will be used by MADRIX.

**MIDI Remote Control**

**Configuration**

- Activate your MIDI device as explained above.
- Again, go to the menu *Preferences > Remote Control > MIDI...*
  - or to *Preferences > Device Manager... > MIDI*
  - [Keyboard shortcut: F4 > MIDI]
  - A new window will open.
- Select your device in the list.
- Activate *Remote*
  - [Please note that Remote in the list will change from Off to On.]
- Now, the Remote Control section below will be activated.
Open - Loads a previously saved MADRIX MIDI Remote Configuration file [of the file type *.mmrx].

MIDI Maps - Choose from a pre-configured MIDI map [configuration]. Learn more MIDI Maps [Overview]

- If you wish to create a new MIDI map, choose USER User.
- You can edit every MIDI map. Learn more » MIDI-IN Configuration Remote Editor

MIDI Remote Editor - Allows you to modify a configuration or create a new configuration. Learn more » MIDI-IN Configuration Remote Editor

MIDI Commands

MADRiX can receive the following MIDI command types:

- Control Change
- Note
- Pitch Bend
- Program Change

**MIDI Maps [Overview]**

MADRIX includes a number of preprogrammed MIDI maps. Learn more in the following chapters.

- 

**MIDI Time Code**

- Activate your MIDI device as explained above.

- Again, go to the menu Preferences > Remote Control > MIDI...
or to Preferences > Device Manager... > MIDI
  [Keyboard shortcut: F4 > MIDI]
  
  - A new window will open.

- Select your device in the list.

- Activate MTC
  [Please note that MTC in the list will change from Off to On.]

- Now, you can receive MIDI Time via the Cue List.
  Learn more »»Time Code [Art-Net / MIDI / SMPTE / System Time]

**MIDI Trigger**

- Activate your MIDI device as explained above.
Again, go to the menu Preferences > Remote Control > MIDI...
or to Preferences > Device Manager... > MIDI
[Keyboard shortcut: F4 > MIDI]

A new window will open.

Select your device in the list.

Activate Trigger
[Please note that Trigger in the list will change from Off to On.]

Now, the Trigger section below will be activated.

Port - Defines the port [Port 1 - 8] that is assigned to this MIDI device. MADRIX allows you to send trigger signals from up to 8 different devices [8 ports] and assign a MADRIX TRI Effect the corresponding port.

Note - Enables that MADRIX can receive Note messages for trigger input.

CC - Enables that MADRIX can receive Control Change messages for trigger input.

Flush - Clears any pending trigger events that may not have been processed yet, but should also not be processed anymore.
**Value Range** - Defines the range of incoming MIDI values that can be used as trigger signal.
- The minimum and default value is 1.
- The maximum and default value is 127.

**Assign Minimum Value** - Automatically assigns the minimum value when using the controller.
- Click **Assign** and use the control on your controller for the minimum value and the value will be set automatically in the MADRIX Software.

**Assign Maximum Value** - Automatically assigns the maximum value when using the controller.
- Click **Assign** and use the control on your controller for the maximum value and the value will be set automatically in the MADRIX Software.

Learn more »[TRI] Trigger Effects

**MIDI Watcher**

- Activate your MIDI device as explained above.

- Again, go to **Preferences > Remote Control > MIDI...**
  
  or **Preferences > Device Manager... > MIDI**

  [Keyboard shortcut: **F4 > MIDI**]

- A new window will open.

- Select your device in the list.
- Activate **Watch**
  
  [Please note that **Watch** in the list will change from **Off** to **On**.]

- It is now possible to monitor incoming MIDI signals.

- Click **MIDI Watcher**...

- A new window will open.

- You can now check incoming signals.
  
  Learn more »[Tools](#)

---

**Important Notes**

- **Before using a MIDI device, please make sure that your MIDI device is connected to your computer** and that all necessary drivers are installed.

- Please also make sure to save your MADRIX Setup after following configuration process.
7.2.2 MIDI Remote Editor

This topic includes:

- Introduction
- Initial Configuration
- Overview
- Keyboard Shortcuts
- Configuration
- Examples

Introduction

MIDI controllers are often used to control MADRIX remotely. While you can use preconfigured MIDI maps [i.e., a MIDI Remote Configuration], you can also set up such a configuration according to your needs with the help of the **MIDI Remote Editor**. This topic describes how to use the MIDI Remote Editor.

Initial Configuration

- **Make sure to configure your MIDI device first.**
- Set up MIDI Remote Control.
- Learn more »[MIDI-IN Configuration](#)

Overview

- Go to the menu **Preferences > Remote Control > MIDI**.
  or to **Preferences > Device Manager... > MIDI**
  [Keyboard shortcut: **F4 > MIDI**]
- Click **Edit...** to open the **MIDI Remote Editor**

- A new window will open.

- If you are creating a new MIDI map, the list will be empty.

- If you are modifying an existing MIDI map, the list will already contain all preconfigured settings.

**Add** - Adds a new item to the list.

**Remove** - Removes the currently selected list items.

**Duplicate/Copy** - Copies and duplicates the currently selected list item. The new item will be added to the list right after the selected item. You can change its settings afterwards.
**Navigation** - Allows you to select the next or previous list item.

**New** - Creates a new MIDI Remote Configuration while deleting all previous list items with your permission.
- Allows you to create an empty MIDI map [Empty] or load a preconfigured MIDI map.

**Open** - Loads a MIDI Remote Configuration into the MIDI Remote Editor from an external file [of the file type *.mmrx].

**Save** - Saves the current MIDI Remote Configuration to an external file [of the file type *.mmrx].

**Save As** - Save the current MIDI Remote Configuration to another external file [of the file type *.mmrx]. Simply enter a name and click Save.

**Assign** - Allows you to assign a control of your MIDI console to a function in MADRIX.
- 1] Activate **Assign**, select an list item you created and move the control of your MIDI controller.
- 2] In most cases, MADRIX will automatically recognize the MIDI Command, Control Type, and Interaction for the control. Learn more Configuration

**Test** - Allows you to test single list items and their functionality on the MADRIX user interface, while having the MIDI Remote Editor still opened.
- Activate Test, then use the control on your MIDI controller. You can see if the control works as expected on the MADRIX user interface.
- If Test is activated, MADRIX will receive the signal directly and not the MIDI Remote Editor.

- Test is also useful for testing modifiers. Learn more Modifiers
**Configuration Name** - Allows you to type in an individual description for your MIDI configuration.
- Once saved, you will be able to select your MIDI configuration under Preferences > Device Manager... > MIDI > Remote Control and MADRIX will use this label.

**Keyboard Shortcuts**

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + A</td>
<td>Selects all items in the list.</td>
</tr>
<tr>
<td>Ctrl + E [hold]</td>
<td>Activates Assign, while holding this shortcut.</td>
</tr>
<tr>
<td>Ctrl + N</td>
<td>Creates a new MIDI map.</td>
</tr>
<tr>
<td>Ctrl + O</td>
<td>Opens a MIDI map.</td>
</tr>
<tr>
<td>Ctrl + S</td>
<td>Saves a MIDI map.</td>
</tr>
<tr>
<td>Ctrl + T [hold]</td>
<td>Activates Test, while holding this shortcut.</td>
</tr>
<tr>
<td>Del</td>
<td>Removes selected items from the list.</td>
</tr>
<tr>
<td>Arrow Up</td>
<td>Navigates upwards in the list.</td>
</tr>
<tr>
<td>Arrow Down</td>
<td>Navigates downwards in the list.</td>
</tr>
<tr>
<td>Double-click on an item</td>
<td>Calls up the context menu for the column.</td>
</tr>
<tr>
<td>Double-click on a head row of the list</td>
<td>Sorts the list alphabetically according to the column [ascending or descending].</td>
</tr>
</tbody>
</table>
Configuration

Overview

- Each list item represents 1 MIDI remote functionality using 1 MIDI control [i.e., button, fader, note, etc.].
- Configure each list item as required.
- Configure each column of an list item.
- Add or remove list items to add or remove the functionality you require.

| Function | 1] Create a new item with +  
|          | Or select a list item and perform a double-click with your mouse on the column **Function** |
|          | 2] Select the general topic [e.g., **Audio**] |
|          | 3] Select the exact function you wish to configure [e.g., **Volume**] |
**A**] Click **Assign**, select a list item and use a control on your MIDI controller. In most cases, MADRIX will automatically recognize the MIDI Command, Control Type, and Interaction.

**B**] Or first select a list item and perform a double-click with your mouse on the column **MIDI Command**. Second, select the MIDI channel [e.g., Channel 01]. Third, select the MIDI type [e.g., Control Change]. Fourth, select the value [e.g., 011] - In general, MIDI offers 16 channels. You can configure each MIDI device to send on a particular channel. Make sure that this **Channel** is also selected here.

MADRIX can receive the following MIDI command types:

- **Control Change**
- **Note**
- **Pitch Bend**
- **Program Change**

<table>
<thead>
<tr>
<th>MIDI Command</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Channel 01</td>
<td>Control Change</td>
</tr>
<tr>
<td>Channel 02</td>
<td>Note</td>
</tr>
<tr>
<td>Channel 03</td>
<td>Pitch Bend</td>
</tr>
<tr>
<td>Channel 04</td>
<td>Program Change</td>
</tr>
<tr>
<td>Channel 05</td>
<td></td>
</tr>
<tr>
<td>Channel 06</td>
<td></td>
</tr>
<tr>
<td>Channel 07</td>
<td></td>
</tr>
<tr>
<td>Channel 08</td>
<td></td>
</tr>
<tr>
<td>Channel 09</td>
<td></td>
</tr>
<tr>
<td>Channel 10</td>
<td></td>
</tr>
<tr>
<td>Channel 11</td>
<td></td>
</tr>
<tr>
<td>Channel 12</td>
<td></td>
</tr>
<tr>
<td>Channel 13</td>
<td></td>
</tr>
<tr>
<td>Channel 14</td>
<td></td>
</tr>
<tr>
<td>Channel 15</td>
<td></td>
</tr>
<tr>
<td>Channel 16</td>
<td></td>
</tr>
</tbody>
</table>
## [A] Click **Assign**, select a list item and use a control on your MIDI controller. In most cases, MADRIX will automatically recognize the MIDI Command, Control Type, and Interaction.

## [B] Or first select a list item and perform a double-click with your mouse on the column **Control Type**. Second, select the type of the control of your MIDI controller [e.g., Button].

- **Fader / Knob** - Defines a fader or knob control that has a wide range of available values with starting point and end point.

- **Encoder / Jogwheel** - Defines a knob or wheel control that has a wide range of available values that functions endlessly without a starting point or endpoint.

- **Button** - Defines a button control that has two states [On or Off]; often as switch, push button, or button.
A] Click **Assign**, select a list item and use a control on your MIDI controller. In most cases, MADRIX will automatically recognize the MIDI Command, Control Type, and Interaction.

B] Or first select a list item and perform a double-click with your mouse on the column **Interaction**. Second, select the mode [e.g., Toggle].

- **Toggle** - Defines that the Control Type only has two states [On or Off]. Is usually used for Button.

- **Relative Signed** - Is a mode how encoders / jogwheels can work. Use Assign to automatically detect the mode or consult the manual of the MIDI controller.

- **Relative Signed 2** - Is a mode how encoders / jogwheels can work. Use Assign to automatically detect the mode or consult the manual of the MIDI controller.

- **Relative Binary Offset** - Is a mode how encoders / jogwheels can work. Use Assign to automatically detect the mode or consult the manual of the MIDI controller.

- **Relative Signed 2's Complement** - Is a mode how encoders / jogwheels can work. Use Assign to automatically detect the mode or consult the manual of the MIDI controller.

- **Absolute** - Defines that the Control Type uses all available values [e.g., 0 to 255]. Is usually used for Fader / Knob.
### Invert

| Invert | 
|---|---|
| No | Yes |

1. Select a list item and perform a double-click with your mouse on the column **Invert**.

2. The item will change between **No** and **Yes**.
   - If Yes is selected, all values of this control will be inverted. That means for example that 0 becomes 255 and 255 becomes 0.
   - No is the default value. No values will be inverted.

### Condition

| Condition | 
|---|---|
| None | State 1 | State 2 | State 3 | State 4 | State 5 | State 6 | State 7 | State 8 | Value 1 | Value 2 | Value 3 | Value 4 | Value 5 | Value 6 | Value 7 | Value 8 |

1. Select a list item and perform a double-click with your mouse on the column **Cond**.

2. Select the condition [e.g., None].
   - If you select a **State**, click **Yes** or **No**
   - If you select a **Value**, select the according **number**

Learn more [Modifiers](#)
**Modifiers**

**Overview**

The MIDI Remote Editor allows you to create advanced MIDI configurations.

- Modifiers allow you to set certain conditions.

---

- Select an item and perform a double-click with your mouse on the column **MIN, MAX, Factor, Description**. Enter the desired value or text.

- **MIN** - Defines a minimum value for this functionality. The default value is 0.

- **MAX** - Defines a maximum value for this functionality.
  - For example, the Master has a maximum value of 255, or you may want to set the maximum Fade Time to 10 seconds.

- **Factor** - Valid values range from -127 and +127. 0 is the default value. Use this factor to slow down [-127 to -1] or speed up [+1 to +127] controls of your MIDI controller.
  - For example, a jog wheel might be too fast to select mix modes of MADRIX. Slow it down by entering a negative value.

- **Description** - Allows you to enter a text to describe the functionality.
  - [By default, the name of the function will automatically be entered].

---

<table>
<thead>
<tr>
<th>MIN, MAX, Factor, Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MIN</td>
</tr>
<tr>
<td>0</td>
</tr>
<tr>
<td>0</td>
</tr>
<tr>
<td>0</td>
</tr>
<tr>
<td>0</td>
</tr>
</tbody>
</table>
In general, these are the steps to follow:

1. Create a new item with + or select a list item and perform a double-click with your mouse on the column **Function**
2. Select **Modifier**
3. Select a **State** or **Value**
4. Create a new list item and configure its **Function** or use an existing list item
5. Assign the condition to this function.

Learn more [Condition](#)

### State

- **State** - Creates a requirement/condition that is required before the function will work.
- You can define up to 8 States.
- Valid values are Yes [Value = 1] or No [Value = 0].
- Normally, you should set up MIN = 0 and MAX = 1 for the corresponding State.
- Example:
  - List item 1 defines a button as a **Modifier, State 1** to be toggled. When pressed, **MAX** defines that a value of 1 is send to MADRIX. When not pressed, **MIN** defines that value 0 is sent to MADRIX.
  - List item 2 is a function to control the Master [Global Master]. A **Condition** was set up for this functionality. If MADRIX receives value 1 [Yes] from **State 1**, the function can be used.
  - Because of the Condition, the Master Fader can only be used when the button is pressed at the same time:

  ![State Table](#)

  - If no condition is assigned, the fader can be moved and the Master will always respond accordingly:

  ![State Table](#)

- When **Test** is activated, MADRIX shows the status of a State in the MIDI Remote Editor. A green button indicates status Yes, a gray button indicates status No.
Value

- **Value** - Allows to add several functions to one or more controls of the MIDI controller by combining it with other available controls.
- You can define up to 8 Values.
- Valid values range from 0 to 127.
- Example:
  - Your MIDI controller may only have 1 fader and a number of buttons.
  - But you would want to control the Master, the Speed Master Deck A, and the Speed Master Deck B with this one fader.
  - In this example, we have configured 3 buttons that activate three different configurations for the fader.
  - If button 1 is pressed one time, the fader will act as the Master.
  - If button 2 is pressed one time, the fader will act as Speed Master Deck A.
  - If button 3 is pressed one time, the fader will act as Speed Master Deck B.
  - Depending on which button is pressed, the modifier value changes between 1, 2, or 3. MADRIX checks this value and allows the fader to control the corresponding function on the MADRIX user interface.
- **Note:** Always assign the correct values to modifier and function.
  - For example if your modifier is assigned to Value 1 and Max. value 2, the function needs to have Value 1=002 as a Condition. In this case, Value 2=002 will not work!
• When **Test** is activated, MADRIX shows the status of a Value in the MIDI Remote Editor.

![Value](image)

### Saving Your Configuration

• Please save your configuration after you have configured all functions!

• If you are closing the MIDI Remote Editor and have not yet saved, the MADRIX Software will remind you to save the file.

• If you do not save, your configuration will be discarded and is lost.

![Save Reminder](image)

• The MADRIX Setup file does not include the external MIDI Remote Configuration file, but will store the directory and a reference link in order to reload it when the Setup is loaded again.

### Examples

**Example 1**
- You wish to use single buttons of your MIDI controller for each Storage Place.

- Use + to create a new function.

- Select **Deck A > Place ID +Fade**

- Use **Assign** to match your button to this function. Disable Assign again when done.

- Set **MAX** to 0 in order to trigger Storage Deck A S1 P1 [Storage 1 Place 1].

- Repeat the steps and set up **MAX** for each Storage Place you wish to control.
  - **MAX** will always have a value that is -1 compared to the actual Storage Place index number [e.g., set MAX to 6 in order to control S1 P7]

- Use **Deck B > Place ID +Fade** and repeat the steps accordingly to control the Storage Places on the right side.
### 7.2.3 Akai Professional APC40

<table>
<thead>
<tr>
<th>Mode: 1 (Required)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cue Storage Place Deck A</td>
</tr>
<tr>
<td>Cue List Open</td>
</tr>
<tr>
<td>Cue List Close</td>
</tr>
<tr>
<td>Cue Storage Place Deck B</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Storage Place Deck A / Deck B P1 – P16</th>
<th>Audio Input Level</th>
<th>Speed Master Deck A Pause</th>
</tr>
</thead>
<tbody>
<tr>
<td>Storage Place Deck A / Deck B DOWN</td>
<td>Master</td>
<td>Blackout</td>
</tr>
<tr>
<td>Storage Place Deck A / Deck B UP</td>
<td>Color Filter color RED</td>
<td>Main Output Freeze</td>
</tr>
<tr>
<td>Layer Deck A / Deck B DOWN</td>
<td>Color Filter color GREEN</td>
<td>Speed Master Deck B Pause</td>
</tr>
<tr>
<td>Layer Deck A / Deck B UP</td>
<td>Color Filter color BLUE</td>
<td>Cue List Back</td>
</tr>
<tr>
<td>Storage Place Submaster</td>
<td>Color Filter color WHITE</td>
<td>Cue List Play/Pause</td>
</tr>
<tr>
<td>Deck A / Deck B</td>
<td></td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>[22] + [27] Frame ID Deck A / Deck B</td>
<td>[36] Crossfader Fade Type UP</td>
<td>[51] Cue List Go</td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«
### 7.2.4 Akai Professional APC40 MKII

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Speed Master Deck A</td>
</tr>
<tr>
<td>2</td>
<td>Color Filter Deck A color RED</td>
</tr>
<tr>
<td>3</td>
<td>Color Filter Deck A color GREEN</td>
</tr>
<tr>
<td>4</td>
<td>Color Filter Deck A color BLUE</td>
</tr>
<tr>
<td>5</td>
<td>Color Filter Deck B color RED</td>
</tr>
<tr>
<td>6</td>
<td>Color Filter Deck B color GREEN</td>
</tr>
<tr>
<td>7</td>
<td>Color Filter Deck B color BLUE</td>
</tr>
<tr>
<td>8</td>
<td>Speed Master Deck B</td>
</tr>
<tr>
<td>54</td>
<td>Speed Master Pause Deck A ON/OFF</td>
</tr>
<tr>
<td>55</td>
<td>Storage Place Deck A DOWN</td>
</tr>
<tr>
<td>56</td>
<td>Storage Place Deck A UP</td>
</tr>
<tr>
<td>59</td>
<td>Storage Place Deck B DOWN</td>
</tr>
<tr>
<td>60</td>
<td>Storage Place Deck B UP</td>
</tr>
</tbody>
</table>
### Part G: INPUT And Remote Control

- **[61]** Speed Master Pause Deck B ON/OFF
- **[62]** Blackout
- **[63]** Mode: General
- **[64]** Mode: Deck A
- **[65]** Mode: Deck B
- **[66]** Mode: Group Control
- **[67]** Mode: Cue List
- **[84]** Audio Level
- **[93]** Master Level
- **[94]** Cue List Play/Pause
- **[95]** Fade Time
- **[96]** Cue List Back
- **[97]** Cue List Go
- **[118]** Crossfader Automatic Fade ON/OFF
- **[119]** Main Output Strobe ON/OFF
- **[120]** Crossfader

<table>
<thead>
<tr>
<th>Mode: General</th>
<th>Mode: Deck A</th>
<th>Mode: Deck B</th>
<th>Mode: Group Control</th>
<th>Mode: Cue List</th>
</tr>
</thead>
<tbody>
<tr>
<td>([63] is activated)</td>
<td>([64] is activated)</td>
<td>([65] is activated)</td>
<td>([66] is activated)</td>
<td>([67] is activated)</td>
</tr>
<tr>
<td>---------</td>
<td>---------</td>
<td>---------</td>
<td>----------------------------</td>
<td>----------------------------</td>
</tr>
<tr>
<td>[34] Storage Place Deck A 14</td>
<td>[34] Storage Place Deck A 26</td>
<td>[34] Storage Place Deck B 26</td>
<td>[34] Group Preset 26</td>
<td>[34] Cue List Goto 26</td>
</tr>
<tr>
<td>Storage Place Deck B 13</td>
<td>Storage Place Deck A 29</td>
<td>Storage Place Deck B 29</td>
<td>Group Preset 29</td>
<td>Cue List Goto 29</td>
</tr>
<tr>
<td>-------------------------</td>
<td>------------------------</td>
<td>------------------------</td>
<td>----------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>Storage Place Deck B 14</td>
<td>Storage Place Deck A 30</td>
<td>Storage Place Deck B 30</td>
<td>Group Preset 30</td>
<td>Cue List Goto 30</td>
</tr>
<tr>
<td>Storage Place Deck B 15</td>
<td>Storage Place Deck A 31</td>
<td>Storage Place Deck B 31</td>
<td>Group Preset 31</td>
<td>Cue List Goto 31</td>
</tr>
<tr>
<td>Storage Place Deck B 16</td>
<td>Storage Place Deck A 32</td>
<td>Storage Place Deck B 32</td>
<td>Group Preset 32</td>
<td>Cue List Goto 32</td>
</tr>
<tr>
<td>Storage Place Deck A 17</td>
<td>Storage Place Deck A 33</td>
<td>Storage Place Deck B 33</td>
<td>Group Preset 33</td>
<td>Cue List Goto 33</td>
</tr>
<tr>
<td>Storage Place Deck A 18</td>
<td>Storage Place Deck A 34</td>
<td>Storage Place Deck B 34</td>
<td>Group Preset 34</td>
<td>Cue List Goto 34</td>
</tr>
<tr>
<td>Storage Place Deck A 19</td>
<td>Storage Place Deck A 35</td>
<td>Storage Place Deck B 35</td>
<td>Group Preset 35</td>
<td>Cue List Goto 35</td>
</tr>
<tr>
<td>Storage Place Deck A 20</td>
<td>Storage Place Deck A 36</td>
<td>Storage Place Deck B 36</td>
<td>Group Preset 36</td>
<td>Cue List Goto 36</td>
</tr>
<tr>
<td>Storage Place Deck B 17</td>
<td>Storage Place Deck A 37</td>
<td>Storage Place Deck B 37</td>
<td>Group Preset 37</td>
<td>Cue List Goto 37</td>
</tr>
<tr>
<td>Storage Place Deck B 18</td>
<td>Storage Place Deck A 38</td>
<td>Storage Place Deck B 38</td>
<td>Group Preset 38</td>
<td>Cue List Goto 38</td>
</tr>
<tr>
<td>Storage Place Deck B 19</td>
<td>Storage Place Deck A 39</td>
<td>Storage Place Deck B 39</td>
<td>Group Preset 39</td>
<td>Cue List Goto 39</td>
</tr>
<tr>
<td>Storage Place Deck B 20</td>
<td>Storage Place Deck A 40</td>
<td>Storage Place Deck B 40</td>
<td>Group Preset 40</td>
<td>Cue List Goto 40</td>
</tr>
<tr>
<td>Storage Deck A / Deck B 1</td>
<td>Storage Deck A 1</td>
<td>Storage Deck B 1</td>
<td>Group 1 Flash ON/Off</td>
<td>Cue List Play</td>
</tr>
<tr>
<td>Storage Deck A / Deck B 2</td>
<td>Storage Deck A 2</td>
<td>Storage Deck B 2</td>
<td>Group 2 Flash ON/Off</td>
<td>Cue List Pause</td>
</tr>
<tr>
<td>Storage Deck A / Deck B 3</td>
<td>Storage Deck A 3</td>
<td>Storage Deck B 3</td>
<td>Group 3 Flash ON/Off</td>
<td>Group Control Toggle</td>
</tr>
<tr>
<td>Storage Deck A / Deck B 4</td>
<td>Storage Deck A 4</td>
<td>Storage Deck B 4</td>
<td>Group 4 Flash ON/Off</td>
<td>Cue List Toggle</td>
</tr>
<tr>
<td>Storage Deck A / Deck B 5</td>
<td>Storage Deck A 5</td>
<td>Storage Deck B 5</td>
<td>Group 5 Flash ON/Off</td>
<td>Cue List Back</td>
</tr>
<tr>
<td>Group Value Group 1</td>
<td>Layer Deck A Layer 1 Solo</td>
<td>Layer Deck B Layer 1 Solo</td>
<td>Group 6 Flash ON/Off</td>
<td>Cue List Go</td>
</tr>
<tr>
<td>Group Value Group 2</td>
<td>Layer Deck A Layer 1 Blind</td>
<td>Layer Deck B Layer 1 Blind</td>
<td>Group 7 Flash ON/Off</td>
<td></td>
</tr>
<tr>
<td>Group Value</td>
<td>Layer Deck A</td>
<td>Layer Deck B</td>
<td>Group 8 Flash ON/Off</td>
<td></td>
</tr>
<tr>
<td>Group 3</td>
<td>Layer 2 Solo</td>
<td>Layer 2 Solo</td>
<td>Off</td>
<td></td>
</tr>
<tr>
<td>--------</td>
<td>--------------</td>
<td>--------------</td>
<td>-----</td>
<td></td>
</tr>
<tr>
<td>[99] Fade Color GREEN</td>
<td>[77] Layer Deck A Layer 5 Blind</td>
<td>[77] Layer Deck B Layer 5 Blind</td>
<td>[91] Group Value Group 7</td>
<td></td>
</tr>
<tr>
<td>[106] Main Output Strobe Color RED OFF</td>
<td>[85] Layer Deck A Layer 1 Value</td>
<td>[85] Layer Deck B Layer 1 Value</td>
<td></td>
<td></td>
</tr>
<tr>
<td>[110] Fade Type DOWN</td>
<td>[89] Layer Deck A Layer 5 Value</td>
<td>[89] Layer Deck B Layer 5 Value</td>
<td></td>
<td></td>
</tr>
<tr>
<td>[Part G] INPUT And Remote Control</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-----------------------------------</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Value</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>[111] Fade Type UP</td>
<td>[90] Layer Deck A Layer 6 Value</td>
</tr>
<tr>
<td>[90] Layer Deck B Layer 6 Value</td>
<td></td>
</tr>
<tr>
<td>[112] Group Control Toggle</td>
<td>[91] Layer Deck A Layer 7 Value</td>
</tr>
<tr>
<td>[91] Layer Deck B Layer 7 Value</td>
<td></td>
</tr>
<tr>
<td>[113] Cue List Toggle</td>
<td>[92] Layer Deck A Layer 8 Value</td>
</tr>
<tr>
<td>[92] Layer Deck B Layer 8 Value</td>
<td></td>
</tr>
<tr>
<td>[106] Chaser Current Layer Deck B Play / Pause</td>
<td></td>
</tr>
<tr>
<td>[110] Chaser Current Layer Deck B Previous</td>
<td></td>
</tr>
<tr>
<td>[111] Chaser Current Layer Deck A Next</td>
<td></td>
</tr>
<tr>
<td>[111] Chaser Current Layer Deck B Next</td>
<td></td>
</tr>
<tr>
<td>[112] Layer Deck A DOWN</td>
<td></td>
</tr>
<tr>
<td>[112] Layer Deck B DOWN</td>
<td></td>
</tr>
<tr>
<td>[113] Layer Deck A UP</td>
<td></td>
</tr>
<tr>
<td>[113] Layer Deck B UP</td>
<td></td>
</tr>
<tr>
<td>[114] Storage Place Deck A DOWN</td>
<td></td>
</tr>
<tr>
<td>[114] Storage Place Deck B DOWN</td>
<td></td>
</tr>
<tr>
<td>[115] Storage Deck A UP</td>
<td></td>
</tr>
<tr>
<td>[115] Storage Deck B UP</td>
<td></td>
</tr>
<tr>
<td>[116] Storage Deck A DOWN</td>
<td></td>
</tr>
<tr>
<td>[116] Storage Deck B DOWN</td>
<td></td>
</tr>
<tr>
<td>[117] Storage Place Deck A UP</td>
<td></td>
</tr>
<tr>
<td>[117] Storage Place Deck B UP</td>
<td></td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«
7.2.5 Akai Professional APCkey25

<table>
<thead>
<tr>
<th>Mode: General</th>
<th>Mode: Deck A</th>
<th>Mode: Deck B</th>
<th>Mode: Group Control</th>
</tr>
</thead>
<tbody>
<tr>
<td>[50]</td>
<td>[51]</td>
<td>[52]</td>
<td>[53]</td>
</tr>
<tr>
<td>([50] is activated)</td>
<td>([51] is activated)</td>
<td>([52] is activated)</td>
<td>([53] is activated)</td>
</tr>
</tbody>
</table>

Crossfader Automatic Fade ON/OFF
Main Output Strobe
Cue List Play/Pause
Group Control Toggle
Blackout
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Storage Place Deck A</td>
<td>Storage Place Deck A</td>
<td>Storage Place Deck B</td>
<td>Storage Place Deck B</td>
<td></td>
</tr>
<tr>
<td>---------------------</td>
<td>---------------------</td>
<td>---------------------</td>
<td>---------------------</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>25</td>
<td>25</td>
<td>25</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>26</td>
<td>26</td>
<td>26</td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>27</td>
<td>27</td>
<td>27</td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>28</td>
<td>28</td>
<td>28</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>29</td>
<td>29</td>
<td>29</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>30</td>
<td>30</td>
<td>30</td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>31</td>
<td>31</td>
<td>31</td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>32</td>
<td>32</td>
<td>32</td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>33</td>
<td>33</td>
<td>33</td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>34</td>
<td>34</td>
<td>34</td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>35</td>
<td>35</td>
<td>35</td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>36</td>
<td>36</td>
<td>36</td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>37</td>
<td>37</td>
<td>37</td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>38</td>
<td>38</td>
<td>38</td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>39</td>
<td>39</td>
<td>39</td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>40</td>
<td>40</td>
<td>40</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>3</td>
<td>3</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>4</td>
<td>4</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>[Group Preset 25]</td>
<td>[Group Preset 30]</td>
<td>[Group Preset 31]</td>
<td>[Group Preset 32]</td>
<td></td>
</tr>
<tr>
<td>[Group Preset 29]</td>
<td>[Group Preset 33]</td>
<td>[Group Preset 34]</td>
<td>[Group Preset 35]</td>
<td></td>
</tr>
<tr>
<td>[Group Preset 28]</td>
<td>[Group Preset 36]</td>
<td>[Group Preset 37]</td>
<td>[Group Preset 38]</td>
<td></td>
</tr>
<tr>
<td>[Group Preset 27]</td>
<td>[Group Preset 39]</td>
<td>[Group Preset 40]</td>
<td>[Group Preset 41]</td>
<td></td>
</tr>
<tr>
<td>[Group Preset DOWN]</td>
<td>[Group Preset UP]</td>
<td>[Group Value Group 1]</td>
<td>[Group Value Group 2]</td>
<td></td>
</tr>
<tr>
<td>-----</td>
<td>---------------------------------</td>
<td>----------------------</td>
<td>----------------------</td>
<td>------------------------</td>
</tr>
<tr>
<td></td>
<td>[69] Group 3 Flash</td>
<td></td>
<td></td>
<td>[74] Group 8 Flash</td>
</tr>
<tr>
<td></td>
<td>[70] Group 4 Flash</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[71] Group 5 Flash</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[72] Group 6 Flash</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[73] Group 7 Flash</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[74] Group 8 Flash</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«
7.2.6 Akai Professional APCmini

<table>
<thead>
<tr>
<th>[69] Mode: General</th>
</tr>
</thead>
<tbody>
<tr>
<td>[70] Mode: Deck A</td>
</tr>
<tr>
<td>[71] Mode: Deck B</td>
</tr>
<tr>
<td>[72] Mode: Group Control</td>
</tr>
<tr>
<td>[86] Group Control Toggle</td>
</tr>
<tr>
<td>[87] Main Output Strobe</td>
</tr>
<tr>
<td>[88] Crossfader Automatic Fade ON/OFF</td>
</tr>
<tr>
<td>[89] Blackout</td>
</tr>
<tr>
<td>[90] Master</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Mode: General (69 is activated)</th>
<th>Mode: Deck A (70 is activated)</th>
<th>Mode: Deck B (71 is activated)</th>
<th>Mode: Group Control (72 is activated)</th>
</tr>
</thead>
<tbody>
<tr>
<td>---</td>
<td>--------------------------</td>
<td>--------------------------</td>
<td>--------------------------</td>
</tr>
<tr>
<td>Storage Place Deck A</td>
<td>Storage Place Deck A</td>
<td>Storage Place Deck B</td>
<td>Group Preset</td>
</tr>
<tr>
<td>----------------------</td>
<td>----------------------</td>
<td>----------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>13</td>
<td>25</td>
<td>25</td>
<td>25</td>
</tr>
<tr>
<td>14</td>
<td>26</td>
<td>26</td>
<td>26</td>
</tr>
<tr>
<td>15</td>
<td>27</td>
<td>27</td>
<td>27</td>
</tr>
<tr>
<td>16</td>
<td>28</td>
<td>28</td>
<td>28</td>
</tr>
<tr>
<td>13</td>
<td>29</td>
<td>29</td>
<td>29</td>
</tr>
<tr>
<td>14</td>
<td>30</td>
<td>30</td>
<td>30</td>
</tr>
<tr>
<td>15</td>
<td>31</td>
<td>31</td>
<td>31</td>
</tr>
<tr>
<td>16</td>
<td>32</td>
<td>32</td>
<td>32</td>
</tr>
<tr>
<td>17</td>
<td>33</td>
<td>33</td>
<td>33</td>
</tr>
<tr>
<td>18</td>
<td>34</td>
<td>34</td>
<td>34</td>
</tr>
<tr>
<td>19</td>
<td>35</td>
<td>35</td>
<td>35</td>
</tr>
<tr>
<td>20</td>
<td>36</td>
<td>36</td>
<td>36</td>
</tr>
<tr>
<td>17</td>
<td>37</td>
<td>37</td>
<td>37</td>
</tr>
<tr>
<td>18</td>
<td>38</td>
<td>38</td>
<td>38</td>
</tr>
<tr>
<td>19</td>
<td>39</td>
<td>39</td>
<td>39</td>
</tr>
<tr>
<td>20</td>
<td>40</td>
<td>40</td>
<td>40</td>
</tr>
<tr>
<td>21</td>
<td>41</td>
<td>41</td>
<td>41</td>
</tr>
<tr>
<td>22</td>
<td>42</td>
<td>42</td>
<td>42</td>
</tr>
<tr>
<td>23</td>
<td>43</td>
<td>43</td>
<td>43</td>
</tr>
<tr>
<td>24</td>
<td>44</td>
<td>44</td>
<td>44</td>
</tr>
<tr>
<td>Storage Place Deck B</td>
<td>Storage Place Deck A</td>
<td>Storage Place Deck B</td>
<td>Group Preset</td>
</tr>
<tr>
<td>---------------------</td>
<td>---------------------</td>
<td>---------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>24</td>
<td>44</td>
<td>44</td>
<td>45</td>
</tr>
<tr>
<td>[45]</td>
<td>[45]</td>
<td>[45]</td>
<td>[45]</td>
</tr>
<tr>
<td>21</td>
<td>45</td>
<td>45</td>
<td>Group Preset 45</td>
</tr>
<tr>
<td>[46]</td>
<td>[46]</td>
<td>[46]</td>
<td>[46]</td>
</tr>
<tr>
<td>22</td>
<td>46</td>
<td>46</td>
<td>Group Preset 46</td>
</tr>
<tr>
<td>[47]</td>
<td>[47]</td>
<td>[47]</td>
<td>[47]</td>
</tr>
<tr>
<td>23</td>
<td>47</td>
<td>47</td>
<td>Group Preset 47</td>
</tr>
<tr>
<td>[48]</td>
<td>[48]</td>
<td>[48]</td>
<td>[48]</td>
</tr>
<tr>
<td>24</td>
<td>48</td>
<td>48</td>
<td>Group Preset 48</td>
</tr>
<tr>
<td>[49]</td>
<td>[49]</td>
<td>[49]</td>
<td>[49]</td>
</tr>
<tr>
<td>25</td>
<td>49</td>
<td>49</td>
<td>Group Preset 49</td>
</tr>
<tr>
<td>[50]</td>
<td>[50]</td>
<td>[50]</td>
<td>[50]</td>
</tr>
<tr>
<td>26</td>
<td>50</td>
<td>50</td>
<td>Group Preset 50</td>
</tr>
<tr>
<td>[51]</td>
<td>[51]</td>
<td>[51]</td>
<td>[51]</td>
</tr>
<tr>
<td>27</td>
<td>51</td>
<td>51</td>
<td>Group Preset 51</td>
</tr>
<tr>
<td>[52]</td>
<td>[52]</td>
<td>[52]</td>
<td>[52]</td>
</tr>
<tr>
<td>28</td>
<td>52</td>
<td>52</td>
<td>Group Preset 52</td>
</tr>
<tr>
<td>[53]</td>
<td>[53]</td>
<td>[53]</td>
<td>[53]</td>
</tr>
<tr>
<td>25</td>
<td>53</td>
<td>53</td>
<td>Group Preset 53</td>
</tr>
<tr>
<td>[54]</td>
<td>[54]</td>
<td>[54]</td>
<td>[54]</td>
</tr>
<tr>
<td>26</td>
<td>54</td>
<td>54</td>
<td>Group Preset 54</td>
</tr>
<tr>
<td>[55]</td>
<td>[55]</td>
<td>[55]</td>
<td>[55]</td>
</tr>
<tr>
<td>27</td>
<td>55</td>
<td>55</td>
<td>Group Preset 55</td>
</tr>
<tr>
<td>[56]</td>
<td>[56]</td>
<td>[56]</td>
<td>[56]</td>
</tr>
<tr>
<td>28</td>
<td>56</td>
<td>56</td>
<td>Group Preset 56</td>
</tr>
<tr>
<td>[57]</td>
<td>[57]</td>
<td>[57]</td>
<td>[57]</td>
</tr>
<tr>
<td>29</td>
<td>57</td>
<td>57</td>
<td>Group Preset 57</td>
</tr>
<tr>
<td>[58]</td>
<td>[58]</td>
<td>[58]</td>
<td>[58]</td>
</tr>
<tr>
<td>30</td>
<td>58</td>
<td>58</td>
<td>Group Preset 58</td>
</tr>
<tr>
<td>[59]</td>
<td>[59]</td>
<td>[59]</td>
<td>[59]</td>
</tr>
<tr>
<td>31</td>
<td>59</td>
<td>59</td>
<td>Group Preset 59</td>
</tr>
<tr>
<td>[60]</td>
<td>[60]</td>
<td>[60]</td>
<td>[60]</td>
</tr>
<tr>
<td>32</td>
<td>60</td>
<td>60</td>
<td>Group Preset 60</td>
</tr>
<tr>
<td>[61]</td>
<td>[61]</td>
<td>[61]</td>
<td>[61]</td>
</tr>
<tr>
<td>29</td>
<td>61</td>
<td>61</td>
<td>Group Preset 61</td>
</tr>
<tr>
<td>[62]</td>
<td>[62]</td>
<td>[62]</td>
<td>[62]</td>
</tr>
<tr>
<td>30</td>
<td>62</td>
<td>62</td>
<td>Group Preset 62</td>
</tr>
<tr>
<td>[63]</td>
<td>[63]</td>
<td>[63]</td>
<td>[63]</td>
</tr>
<tr>
<td>31</td>
<td>63</td>
<td>63</td>
<td>Group Preset 63</td>
</tr>
<tr>
<td>Storage Place Deck B 32</td>
<td>Storage Place Deck A 64</td>
<td>Storage Place Deck B 64</td>
<td>Group Preset 64</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-------------------------</td>
<td>-------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Storage Deck A / Deck B UP</td>
<td>Storage Deck A UP</td>
<td>Storage Deck B UP</td>
<td>Group Preset DOWN</td>
</tr>
<tr>
<td>Storage Deck A / Deck B DOWN</td>
<td>Storage Deck A DOWN</td>
<td>Storage Deck B DOWN</td>
<td>Group Preset UP</td>
</tr>
<tr>
<td>Group Value Group 1</td>
<td>Group Value Group 1</td>
<td>Group Value Group 1</td>
<td>Group Value Group 1</td>
</tr>
<tr>
<td>Group Value Group 2</td>
<td>Group Value Group 2</td>
<td>Group Value Group 2</td>
<td>Group Value Group 2</td>
</tr>
<tr>
<td>Group Value Group 3</td>
<td>Group Value Group 3</td>
<td>Group Value Group 3</td>
<td>Group Value Group 3</td>
</tr>
<tr>
<td>Group Value Group 4</td>
<td>Group Value Group 4</td>
<td>Group Value Group 4</td>
<td>Group Value Group 4</td>
</tr>
<tr>
<td>Group Value Group 5</td>
<td>Group Value Group 5</td>
<td>Group Value Group 5</td>
<td>Group Value Group 5</td>
</tr>
<tr>
<td>Group Value Group 7</td>
<td>Group Value Group 7</td>
<td>Group Value Group 7</td>
<td>Group Value Group 7</td>
</tr>
<tr>
<td>Group Value Group 8</td>
<td>Group Value Group 8</td>
<td>Group Value Group 8</td>
<td>Group Value Group 8</td>
</tr>
<tr>
<td>Storage Deck A / Deck B 1</td>
<td>Storage Deck A Layer 1 Value</td>
<td>Storage Deck B Layer 1 Value</td>
<td>Group Value Group 1</td>
</tr>
<tr>
<td>Storage Deck A / Deck B 2</td>
<td>Storage Deck A Layer 2 Value</td>
<td>Storage Deck B Layer 2 Value</td>
<td>Group Value Group 2</td>
</tr>
<tr>
<td>Storage Deck A / Deck B 3</td>
<td>Storage Deck A Layer 3 Value</td>
<td>Storage Deck B Layer 3 Value</td>
<td>Group Value Group 3</td>
</tr>
<tr>
<td>Storage Deck A / Deck B 4</td>
<td>Storage Deck A Layer 4 Value</td>
<td>Storage Deck B Layer 4 Value</td>
<td>Group Value Group 4</td>
</tr>
<tr>
<td>Storage Deck A / Deck B 5</td>
<td>Storage Deck A Layer 5 Value</td>
<td>Storage Deck B Layer 5 Value</td>
<td>Group Value Group 5</td>
</tr>
<tr>
<td>Storage Deck A / Deck B 6</td>
<td>Storage Deck A Layer 6 Value</td>
<td>Storage Deck B Layer 6 Value</td>
<td>Group Value Group 6</td>
</tr>
<tr>
<td>Storage Deck A / Deck B 7</td>
<td>Storage Deck A Layer 7 Value</td>
<td>Storage Deck B Layer 7 Value</td>
<td>Group Value Group 7</td>
</tr>
<tr>
<td>Storage Deck A / Deck B 8</td>
<td>Storage Deck A Layer 8 Value</td>
<td>Storage Deck B Layer 8 Value</td>
<td>Group Value Group 8</td>
</tr>
</tbody>
</table>

---

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration"
## 7.2.7 Akai Professional LPD8

*Image of LPD8 with buttons and knobs labeled from 1 to 20.*

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>[9]</td>
<td>Group Value Group 1</td>
<td></td>
</tr>
<tr>
<td>[10]</td>
<td>Group Value Group 2</td>
<td></td>
</tr>
<tr>
<td>[12]</td>
<td>Group Value Group 4</td>
<td></td>
</tr>
<tr>
<td>[14]</td>
<td>Group Value Group 6</td>
<td></td>
</tr>
<tr>
<td>[16]</td>
<td>Group Value Group 8</td>
<td></td>
</tr>
</tbody>
</table>

[17] Program change (Program 1 must be activated)

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>[18]</td>
<td>Mode: Deck A</td>
<td></td>
</tr>
<tr>
<td>[19]</td>
<td>Mode: Deck B</td>
<td></td>
</tr>
<tr>
<td>[20]</td>
<td>Mode: Group Control</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Mode: Deck A</th>
<th>Mode: Deck B</th>
<th>Mode: Group Control</th>
</tr>
</thead>
<tbody>
<tr>
<td>([18] is activated)</td>
<td>([19] is activated)</td>
<td>([20] is activated)</td>
</tr>
<tr>
<td>1. Storage Place Deck A UP</td>
<td>1. Storage Place Deck B UP</td>
<td>1. Group 1 Flash</td>
</tr>
<tr>
<td>---------------------------</td>
<td>---------------------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>2. Storage Deck A UP</td>
<td>2. Storage Deck B UP</td>
<td>2. Group 2 Flash</td>
</tr>
<tr>
<td>3. Cue List Play/Pause</td>
<td>3. Cue List Play/Pause</td>
<td>3. Group 3 Flash</td>
</tr>
<tr>
<td>5. Storage Place Deck A DOWN</td>
<td>5. Storage Place Deck B DOWN</td>
<td>5. Group 5 Flash</td>
</tr>
<tr>
<td>7. Crossfader Skip To Left</td>
<td>7. Crossfader Skip To Left</td>
<td>7. Group 7 Flash</td>
</tr>
<tr>
<td>8. Crossfader Skip To Right</td>
<td>8. Crossfader Skip To Right</td>
<td>8. Group 8 Flash</td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«
7.2.8 Akai Professional LPK25

<table>
<thead>
<tr>
<th>Octave</th>
<th>Storage Place</th>
<th>Storage</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Deck A 8 – 22</td>
<td>Deck A 6 – 15</td>
</tr>
<tr>
<td></td>
<td>Deck A 15 – 29</td>
<td>Deck A 11 – 20</td>
</tr>
<tr>
<td></td>
<td>Deck A 22 – 35</td>
<td>Deck A 16 – 25</td>
</tr>
<tr>
<td></td>
<td>Deck A 29 – 35</td>
<td>Deck A 21 – 25</td>
</tr>
<tr>
<td></td>
<td>Deck B 1 – 8</td>
<td>Deck B 1 – 5</td>
</tr>
<tr>
<td></td>
<td>Deck B 1 – 15</td>
<td>Deck B 1 – 10</td>
</tr>
<tr>
<td></td>
<td>Deck B 8 – 22</td>
<td>Deck B 6 – 15</td>
</tr>
<tr>
<td></td>
<td>Deck B 15 – 29</td>
<td>Deck B 11 – 20</td>
</tr>
<tr>
<td></td>
<td>Deck B 22 – 35</td>
<td>Deck B 16 – 25</td>
</tr>
</tbody>
</table>
You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration"
## 7.2.9 Akai Professional MIDIMIX

<table>
<thead>
<tr>
<th>No.</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Speed Master Deck A</td>
</tr>
<tr>
<td>2</td>
<td>Color Filter Deck A color RED</td>
</tr>
<tr>
<td>3</td>
<td>Color Filter Deck A color GREEN</td>
</tr>
<tr>
<td>4</td>
<td>Color Filter Deck A color BLUE</td>
</tr>
<tr>
<td>5</td>
<td>Color Filter Deck B color RED</td>
</tr>
<tr>
<td>6</td>
<td>Color Filter Deck B color GREEN</td>
</tr>
<tr>
<td>7</td>
<td>Color Filter Deck B color BLUE</td>
</tr>
<tr>
<td>8</td>
<td>Speed Master Deck B</td>
</tr>
<tr>
<td>9</td>
<td>Layer Deck A Layer 1 Value</td>
</tr>
<tr>
<td>10</td>
<td>Layer Deck A Layer 2 Value</td>
</tr>
<tr>
<td>11</td>
<td>Layer Deck A Layer 3 Value</td>
</tr>
<tr>
<td>12</td>
<td>Layer Deck A Layer 4 Value</td>
</tr>
<tr>
<td>13</td>
<td>Layer Deck A Layer 5 Value</td>
</tr>
<tr>
<td>27</td>
<td>Storage Place Deck A DOWN</td>
</tr>
<tr>
<td>28</td>
<td>Storage Place Deck A UP</td>
</tr>
<tr>
<td>29</td>
<td>Storage Deck B DOWN</td>
</tr>
<tr>
<td>30</td>
<td>Storage Deck B UP</td>
</tr>
<tr>
<td>31</td>
<td>Storage Place Deck B DOWN</td>
</tr>
<tr>
<td>32</td>
<td>Storage Place Deck B UP</td>
</tr>
<tr>
<td>33</td>
<td>Group 1 Flash</td>
</tr>
<tr>
<td>34</td>
<td>Group 2 Flash</td>
</tr>
<tr>
<td>35</td>
<td>Group 3 Flash</td>
</tr>
<tr>
<td>36</td>
<td>Group 4 Flash</td>
</tr>
<tr>
<td>37</td>
<td>Group 5 Flash</td>
</tr>
<tr>
<td>38</td>
<td>Group 6 Flash</td>
</tr>
<tr>
<td>39</td>
<td>Group 7 Flash</td>
</tr>
<tr>
<td>Layer Deck A Layer 6 Value</td>
<td>Group 8 Flash</td>
</tr>
<tr>
<td>---------------------------</td>
<td>---------------</td>
</tr>
<tr>
<td>Layer Deck A Layer 7 Value</td>
<td>Group Value Group 1</td>
</tr>
<tr>
<td>Layer Deck A Layer 7 Value</td>
<td>Group Value Group 2</td>
</tr>
<tr>
<td>Layer Deck B Layer 1 Value</td>
<td>Group Value Group 3</td>
</tr>
<tr>
<td>Layer Deck B Layer 2 Value</td>
<td>Group Value Group 4</td>
</tr>
<tr>
<td>Layer Deck B Layer 3 Value</td>
<td>Group Value Group 5</td>
</tr>
<tr>
<td>Layer Deck B Layer 4 Value</td>
<td>Group Value Group 6</td>
</tr>
<tr>
<td>Layer Deck B Layer 5 Value</td>
<td>Group Value Group 7</td>
</tr>
<tr>
<td>Layer Deck B Layer 6 Value</td>
<td>Group Value Group 8</td>
</tr>
<tr>
<td>Layer Deck B Layer 7 Value</td>
<td>Main Output Strobe</td>
</tr>
<tr>
<td>Layer Deck B Layer 8 Value</td>
<td>Crossfader Automatic Fade ON/OFF</td>
</tr>
<tr>
<td>Storage Deck A DOWN</td>
<td>Blackout</td>
</tr>
<tr>
<td>Storage Deck A UP</td>
<td>Master</td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »[MIDI-IN Configuration]«
7.2.10 Akai Professional MPK249

- Please choose Preset 1 (LiveLite) and work on Octave 0.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>[1] Master</td>
</tr>
<tr>
<td></td>
<td>[2] Mode: Deck A</td>
</tr>
<tr>
<td>[22] Cue List Back</td>
<td>[23] Cue List Go</td>
</tr>
<tr>
<td>[26] Cue List Cue All</td>
<td>[27] Speed Master Deck A</td>
</tr>
</tbody>
</table>
[34] Speed Master Deck B
[35] Group Value Group 1
[36] Group Value Group 2
[37] Group Value Group 3
[38] Group Value Group 4
[39] Group Value Group 5
[40] Group Value Group 6
[41] Group Value Group 7
[42] Group Value Group 8
[43] Group Control Toggle
[44] Cue List Toggle
[45] Storage Deck A DOWN
[46] Storage Deck A UP
[47] Storage Place Deck A DOWN
[48] Storage Place Deck A UP
[49] Storage Deck B DOWN
[50] Storage Deck B UP
[51] Storage Place Deck B DOWN
[52] Storage Place Deck B UP
[53] Group Preset DOWN
[54] Group Preset UP
[55] Main Output Strobe
[56] Blackout
[57] Crossfader Automatic Fade ON/OFF
[58] Crossfader Skip To Left
[59] Crossfader Skip To Right

<table>
<thead>
<tr>
<th>Mode: Deck A</th>
<th>Mode: Deck B</th>
<th>Mode: Group Control</th>
<th>Mode: Cue List</th>
</tr>
</thead>
<tbody>
<tr>
<td>(2) is activated</td>
<td>(3) is activated</td>
<td>(66) is activated</td>
<td>(67) is activated</td>
</tr>
<tr>
<td>Storage Place Deck A</td>
<td>Storage Place Deck B</td>
<td>Group Preset</td>
<td>Cue List Goto</td>
</tr>
<tr>
<td>----------------------</td>
<td>----------------------</td>
<td>--------------</td>
<td>--------------</td>
</tr>
<tr>
<td>6</td>
<td>6</td>
<td>6</td>
<td>6</td>
</tr>
<tr>
<td>7</td>
<td>7</td>
<td>7</td>
<td>7</td>
</tr>
<tr>
<td>8</td>
<td>8</td>
<td>8</td>
<td>8</td>
</tr>
<tr>
<td>9</td>
<td>9</td>
<td>9</td>
<td>9</td>
</tr>
<tr>
<td>10</td>
<td>10</td>
<td>10</td>
<td>10</td>
</tr>
<tr>
<td>11</td>
<td>11</td>
<td>11</td>
<td>11</td>
</tr>
<tr>
<td>12</td>
<td>12</td>
<td>12</td>
<td>12</td>
</tr>
<tr>
<td>13</td>
<td>13</td>
<td>13</td>
<td>13</td>
</tr>
<tr>
<td>14</td>
<td>14</td>
<td>14</td>
<td>14</td>
</tr>
<tr>
<td>15</td>
<td>15</td>
<td>15</td>
<td>15</td>
</tr>
<tr>
<td>16</td>
<td>16</td>
<td>16</td>
<td>16</td>
</tr>
<tr>
<td>17</td>
<td>17</td>
<td>17</td>
<td>17</td>
</tr>
<tr>
<td>18</td>
<td>18</td>
<td>18</td>
<td>18</td>
</tr>
<tr>
<td>19</td>
<td>19</td>
<td>19</td>
<td>19</td>
</tr>
<tr>
<td>20</td>
<td>20</td>
<td>20</td>
<td>20</td>
</tr>
<tr>
<td>21</td>
<td>21</td>
<td>21</td>
<td>21</td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »**MIDI-IN Configuration**«
7.2.11 Akai Professional MPK261

Please choose Preset 1 (LiveLite) and work on Octave 0.

- [1] Master
- [2] Mode: Deck A
- [4] Mode: Group Control
- [5] Mode: Cue List
- [22] Cue List Back
- [23] Cue List Go
- [24] Cue List Pause
- [25] Cue List Play
- [26] Cue List Cue All
- [27] Speed Master Deck A
- [28] Color Filter Deck A color RED
- [29] Color Filter Deck A color GREEN
- [30] Color Filter Deck A color BLUE
- [31] Color Filter Deck B color RED
- [32] Color Filter Deck B color GREEN
- [33] Color Filter Deck B color BLUE
<table>
<thead>
<tr>
<th>Mode: Deck A</th>
<th>Mode: Deck B</th>
<th>Mode: Group Control</th>
<th>Mode: Cue List</th>
</tr>
</thead>
<tbody>
<tr>
<td>([2] is activated)</td>
<td>([3] is activated)</td>
<td>([66] is activated)</td>
<td>([67] is activated)</td>
</tr>
<tr>
<td>Storage Place Deck A</td>
<td>Storage Place Deck B</td>
<td>Group Preset</td>
<td>Cue List Goto</td>
</tr>
<tr>
<td>----------------------</td>
<td>----------------------</td>
<td>--------------</td>
<td>--------------</td>
</tr>
<tr>
<td>6</td>
<td>6</td>
<td>6</td>
<td>6</td>
</tr>
<tr>
<td>7</td>
<td>7</td>
<td>7</td>
<td>7</td>
</tr>
<tr>
<td>8</td>
<td>8</td>
<td>8</td>
<td>8</td>
</tr>
<tr>
<td>9</td>
<td>9</td>
<td>9</td>
<td>9</td>
</tr>
<tr>
<td>10</td>
<td>10</td>
<td>10</td>
<td>10</td>
</tr>
<tr>
<td>11</td>
<td>11</td>
<td>11</td>
<td>11</td>
</tr>
<tr>
<td>12</td>
<td>12</td>
<td>12</td>
<td>12</td>
</tr>
<tr>
<td>13</td>
<td>13</td>
<td>13</td>
<td>13</td>
</tr>
<tr>
<td>14</td>
<td>14</td>
<td>14</td>
<td>14</td>
</tr>
<tr>
<td>15</td>
<td>15</td>
<td>15</td>
<td>15</td>
</tr>
<tr>
<td>16</td>
<td>16</td>
<td>16</td>
<td>16</td>
</tr>
<tr>
<td>17</td>
<td>17</td>
<td>17</td>
<td>17</td>
</tr>
<tr>
<td>18</td>
<td>18</td>
<td>18</td>
<td>18</td>
</tr>
<tr>
<td>19</td>
<td>19</td>
<td>19</td>
<td>19</td>
</tr>
<tr>
<td>20</td>
<td>20</td>
<td>20</td>
<td>20</td>
</tr>
<tr>
<td>21</td>
<td>21</td>
<td>21</td>
<td>21</td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«
### 7.2.12 Akai Professional MPKmini MKII

<table>
<thead>
<tr>
<th>Key</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>26</td>
<td>Octave DOWN</td>
</tr>
<tr>
<td>27</td>
<td>Octave UP</td>
</tr>
<tr>
<td>30</td>
<td>Cue List Play/Pause</td>
</tr>
<tr>
<td>31</td>
<td>Crossfader Automatic Fade ON/OFF</td>
</tr>
<tr>
<td>34</td>
<td>Crossfader Skip To Left</td>
</tr>
<tr>
<td>35</td>
<td>Crossfader Skip To Right</td>
</tr>
<tr>
<td>36</td>
<td>Group Value Group 1</td>
</tr>
<tr>
<td>37</td>
<td>Group Value Group 2</td>
</tr>
<tr>
<td>38</td>
<td>Group Value Group 3</td>
</tr>
<tr>
<td>39</td>
<td>Group Value Group 4</td>
</tr>
<tr>
<td>40</td>
<td>Group Value Group 5</td>
</tr>
<tr>
<td>41</td>
<td>Group Value Group 6</td>
</tr>
<tr>
<td>42</td>
<td>Group Value Group 7</td>
</tr>
<tr>
<td>43</td>
<td>Group Value Group 8</td>
</tr>
<tr>
<td>44</td>
<td>Mode Switch</td>
</tr>
</tbody>
</table>
### [45] Prog. Change (must be activated to control the PADs)

<table>
<thead>
<tr>
<th>Octave</th>
<th>Storage Place</th>
<th>Storage</th>
</tr>
</thead>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »[MIDI-IN Configuration](#)
7.2.13 Behringer BCD3000

Also known as BCD 3000 / BCD-3000.

<table>
<thead>
<tr>
<th>No MIDI function</th>
<th>FREE</th>
<th>Layer Mix Mode UP</th>
</tr>
</thead>
<tbody>
<tr>
<td>FREE</td>
<td>FREE</td>
<td>Layer Mix Mode DOWN</td>
</tr>
<tr>
<td>FREE</td>
<td>No MIDI function</td>
<td>Crossfader Skip to Left/Skip To Right</td>
</tr>
<tr>
<td>Cue List Open/CLOSE</td>
<td>FREE</td>
<td>Master / Audio Input Level</td>
</tr>
<tr>
<td>Color RED for Color Filter or Color-fade</td>
<td>Crossfader Automatic Fade</td>
<td>Audio Input ON/OFF / Cue List Play/Pause</td>
</tr>
</tbody>
</table>

[1] No MIDI function
[2] FREE
[3] No MIDI function
[4] Cue List Open/CLOSE
[5] Color RED for Color Filter or Color-fade
[6] FREE
[7] CROSSFADER
[8] MASTER
[9] FREE
[10] FREE
[12] FREE
[13] FREE
[14] FREE
[15] No MIDI function
[16] FREE
[17] Crossfader Automatic Fade
[18] FREE
[19] FREE
[20] FREE
[21] FREE
[22] FREE
[23] FREE
[24] FREE
[25] Layer Mix Mode UP
[26] Layer Mix Mode DOWN
[27] Crossfader Skip to Left/Skip To Right
[28] Master / Audio Input Level
[29] Audio Input ON/OFF / Cue List Play/Pause

www.madrix.com
| [10] Crossfader Fade Type UP | [22 Low Knob] Storage ID S1 – S128 | [34] + [35] Storage Place Submaster |

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«
7.2.14 Behringer BCF2000

Also known as BCF 2000 or BCF-2000.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Color RED for Color Filter or Color-Fade (see [9])</td>
</tr>
<tr>
<td>2</td>
<td>Color GREEN for Color Filter or Color-Fade (see [9])</td>
</tr>
<tr>
<td>3</td>
<td>Color BLUE for Color Filter or Color-Fade (see [9])</td>
</tr>
<tr>
<td>4</td>
<td>Color WHITE for Color Filter or Color-Fade (see [9])</td>
</tr>
<tr>
<td>8</td>
<td>Crossfader Fade Time</td>
</tr>
<tr>
<td>9</td>
<td>Mode: Color Filter (Default) or Color-Fade</td>
</tr>
<tr>
<td>24</td>
<td>Speed Master Deck B Pause</td>
</tr>
<tr>
<td>25</td>
<td>Storage ID Deck B DOWN</td>
</tr>
<tr>
<td>26</td>
<td>Storage ID Deck B UP</td>
</tr>
<tr>
<td>29</td>
<td>Crossfader</td>
</tr>
<tr>
<td>30</td>
<td>Storage Place Deck A UP/DOWN</td>
</tr>
<tr>
<td>31</td>
<td>Speed Master Deck A</td>
</tr>
</tbody>
</table>
[19] Storage ID Deck A DOWN | [34] Speed Master Deck B
[21] Speed Master Deck A Pause |

You can get an overview over all preprogrammed MIDI maps in the chapter »[MIDI-IN Configuration]«
7.2.15 Behringer BCR2000

Also known as BCR 2000 or BCR-2000.

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Color RED for Color Filter or Color-Fade (see [9])</td>
</tr>
<tr>
<td>2</td>
<td>Color GREEN for Color Filter or Color-Fade (see [9])</td>
</tr>
<tr>
<td>3</td>
<td>Color BLUE for Color Filter or Color-Fade (see [9])</td>
</tr>
<tr>
<td>4</td>
<td>Color WHITE for Color Filter or Color-Fade (see [9])</td>
</tr>
<tr>
<td>8</td>
<td>Crossfader Fade Time</td>
</tr>
<tr>
<td>9</td>
<td>Mode: Color Filter (Default) or Color-Fade</td>
</tr>
<tr>
<td>24</td>
<td>Speed Master Deck B Pause</td>
</tr>
<tr>
<td>25</td>
<td>Storage ID Deck B DOWN</td>
</tr>
<tr>
<td>26</td>
<td>Storage ID Deck B UP</td>
</tr>
<tr>
<td>29</td>
<td>Crossfader</td>
</tr>
<tr>
<td>30</td>
<td>Storage Place Deck A UP/DOWN</td>
</tr>
<tr>
<td>31</td>
<td>Speed Master Deck A</td>
</tr>
</tbody>
</table>
### Input and Remote Control

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[11] Speed Master Deck A Reset</td>
<td>Reset Speed Master Deck A</td>
</tr>
<tr>
<td>[14] Speed Master Deck B Reset</td>
<td>Reset Speed Master Deck B</td>
</tr>
<tr>
<td>[19] Storage ID Deck A DOWN</td>
<td>Down Storage ID on Deck A</td>
</tr>
<tr>
<td>[20] Storage ID Deck A UP</td>
<td>Up Storage ID on Deck A</td>
</tr>
<tr>
<td>[21] Speed Master Deck A Pause</td>
<td>Pause Speed Master Deck A</td>
</tr>
<tr>
<td>[32] Master</td>
<td>Control Master</td>
</tr>
<tr>
<td>[33] Audio Input Level</td>
<td>Adjust Audio Input Level</td>
</tr>
<tr>
<td>[34] Speed Master Deck B</td>
<td>Speed Master Deck B</td>
</tr>
<tr>
<td>[35] Storage Place Deck B UP/DOWN</td>
<td>Up/Down Storage Place Deck B</td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »[MIDI-IN Configuration](#)«.
### 7.2.16 Creative Prodikeys PC-MIDI

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>[1]</strong> Cue List Back (MIDI note #53)</td>
<td><strong>[8 – 17]</strong> Storage Place Deck A P1 – P10</td>
</tr>
<tr>
<td><strong>[2]</strong> Cue List Play/Pause</td>
<td><strong>[18] + [8 – 17]</strong> Storage Place Deck A P11 – P20</td>
</tr>
<tr>
<td><strong>[3]</strong> Cue List Go</td>
<td><strong>[19] + [8 – 17]</strong> Storage Place Deck A P21 – P30</td>
</tr>
<tr>
<td><strong>[18] + [19] + [8 – 17]</strong> Storage Place Deck A P31 – P40</td>
<td></td>
</tr>
<tr>
<td><strong>[4]</strong> Storage ID Deck A DOWN</td>
<td></td>
</tr>
<tr>
<td><strong>[5]</strong> Storage ID Deck A UP</td>
<td><strong>[20 – 29]</strong> Storage Place Deck B P1 – P10</td>
</tr>
<tr>
<td><strong>[6]</strong> Storage ID Deck B DOWN</td>
<td><strong>[30] + [20 – 29]</strong> Storage Place Deck B P11 – P20</td>
</tr>
<tr>
<td><strong>[7]</strong> Storage ID Deck B UP</td>
<td><strong>[31] + [20 – 29]</strong> Storage Place Deck B P21 – P30</td>
</tr>
<tr>
<td><strong>[30] + [31] + [20 – 29]</strong> Storage Place Deck B P31 – P40</td>
<td></td>
</tr>
<tr>
<td><strong>[32]</strong> Crossfader Skip To Left</td>
<td></td>
</tr>
<tr>
<td><strong>[33]</strong> Crossfader Automatic Fade</td>
<td><strong>[35]</strong> Crossfader Fade Type DOWN</td>
</tr>
<tr>
<td><strong>[34]</strong> Crossfader Skip To Right</td>
<td><strong>[36]</strong> Crossfader Fade Type UP</td>
</tr>
<tr>
<td></td>
<td><strong>[37]</strong> Cue List Back (see [1]) (MIDI note #89)</td>
</tr>
<tr>
<td></td>
<td><strong>[38]</strong> Audio Input ON/OFF (Sustain on MIDI keyboards)</td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »[MIDI-IN Configuration](#)«.
### 7.2.17 Elation Professional MIDICON

![Elation Professional MIDICON Control Panel](image)

<table>
<thead>
<tr>
<th>Key Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[3]</td>
<td>Cue Storage Place Deck A</td>
</tr>
<tr>
<td>[8]</td>
<td>Cue Storage Place Deck B</td>
</tr>
<tr>
<td>[12]</td>
<td>Layer Deck A UP</td>
</tr>
<tr>
<td>[13]</td>
<td>Color-Fade color RED (ON/OFF)</td>
</tr>
<tr>
<td>[14]</td>
<td>Color-Fade color GREEN (ON/OFF)</td>
</tr>
<tr>
<td>[15]</td>
<td>Color-Fade color BLUE (ON/OFF)</td>
</tr>
<tr>
<td>[16]</td>
<td>Color-Fade color WHITE (ON/OFF)</td>
</tr>
<tr>
<td>[17]</td>
<td>Layer Deck B DOWN</td>
</tr>
<tr>
<td>[18]</td>
<td>Layer Deck B UP</td>
</tr>
<tr>
<td>[19]</td>
<td>Layer Deck A Solo Mode</td>
</tr>
<tr>
<td>[20]</td>
<td>Layer Deck A Mix Mode UP</td>
</tr>
<tr>
<td>[25]</td>
<td>Layer Deck B Mix Mode UP</td>
</tr>
<tr>
<td>[26]</td>
<td>Layer Deck B Solo Mode</td>
</tr>
<tr>
<td>[27]</td>
<td>Layer Deck A Blind Mode</td>
</tr>
<tr>
<td>[28]</td>
<td>Layer Deck A Mix Mode DOWN</td>
</tr>
<tr>
<td>[52]</td>
<td>Speed Master Deck B Pause</td>
</tr>
<tr>
<td>[56]</td>
<td>Cue List Open/Close</td>
</tr>
<tr>
<td>[57]</td>
<td>Cue List Play/Pause</td>
</tr>
<tr>
<td>[62]</td>
<td>Storage Place Deck A UP (Arrow key behavior)</td>
</tr>
<tr>
<td>[64]</td>
<td>Storage ID Deck A DOWN</td>
</tr>
<tr>
<td>[65]</td>
<td>Storage ID Deck A UP</td>
</tr>
<tr>
<td>[67]</td>
<td>Storage Place Deck B UP (Arrow key behavior)</td>
</tr>
<tr>
<td>[69]</td>
<td>Storage Place Deck A LEFT (Arrow key behavior)</td>
</tr>
<tr>
<td>[70]</td>
<td>Storage Place Deck A DOWN (Arrow key behavior)</td>
</tr>
<tr>
<td>[71]</td>
<td>Storage Place Deck A RIGHT (Arrow key behavior)</td>
</tr>
<tr>
<td>[72]</td>
<td>Storage ID Deck B DOWN</td>
</tr>
<tr>
<td>[73]</td>
<td>Storage ID Deck B UP</td>
</tr>
<tr>
<td>[74]</td>
<td>Storage Place Deck B LEFT (Arrow key behavior)</td>
</tr>
<tr>
<td>[75]</td>
<td>Storage Place Deck A DOWN (Arrow key behavior)</td>
</tr>
<tr>
<td>[76]</td>
<td>Storage Place Deck A RIGHT (Arrow key behavior)</td>
</tr>
<tr>
<td>[77]</td>
<td>Speed Master Deck A UP/DOWN</td>
</tr>
<tr>
<td>[33] Layer Deck B Mix Mode DOWN</td>
<td>[77 Push] Speed Master Deck A Reset</td>
</tr>
<tr>
<td>[34] Layer Deck B Blind Mode</td>
<td>[78] Crossfader</td>
</tr>
<tr>
<td>[35] Blackout</td>
<td>[78] + [89] Crossfader Fade Time UP/DOWN</td>
</tr>
<tr>
<td>[36] Layer Deck A Opacity</td>
<td>[78] + [91] Audio Input Level UP/DOWN</td>
</tr>
<tr>
<td>[37] Layer Deck A Submaster</td>
<td>[78 Push] Crossfader Automatic Fade</td>
</tr>
<tr>
<td>[38] Color Filter color RED</td>
<td>[79] Speed Master Deck B UP/DOWN</td>
</tr>
<tr>
<td>[40] Color Filter color BLUE</td>
<td>[80] Speed Master Deck A Pause (Hold)</td>
</tr>
<tr>
<td>[41] Color Filter color WHITE</td>
<td>[82] Crossfader Skip To Left</td>
</tr>
<tr>
<td>[42] Layer Deck B Submaster</td>
<td>[83] Crossfader Skip To Right</td>
</tr>
<tr>
<td>[43] Layer Deck B Opacity</td>
<td>[85] Speed Master Deck B Pause (Hold)</td>
</tr>
<tr>
<td>[44] Master</td>
<td>[86] Main Output Freeze (Hold)</td>
</tr>
<tr>
<td>[45] Speed Master Deck A Pause</td>
<td>[87] Main Output Freeze (Permanently)</td>
</tr>
<tr>
<td>[48] Cue List Go</td>
<td>[88] Crossfader Fade Type DOWN</td>
</tr>
<tr>
<td>[49] Cue List Back</td>
<td>[90] Audio Input ON/OFF</td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«
### 7.2.18 Hercules DJ Console Rmx

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>[23] Speed Master Deck B Reset</td>
<td>[24 HOLD] Speed Master Deck B Pause</td>
</tr>
<tr>
<td></td>
<td>[28] Crossfader Fade Type UP</td>
<td>[47] Cue List Go</td>
</tr>
</tbody>
</table>
You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration"
7.2.19 Hercules DJ Control MP3 And DJ Console MK2
<table>
<thead>
<tr>
<th>Button Combination</th>
<th>Function Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[1] + [40]</td>
<td>Storage Place Submaster Deck A</td>
</tr>
<tr>
<td>[2] + [40]</td>
<td>Layer Submaster Deck A</td>
</tr>
<tr>
<td>[3] + [40]</td>
<td>Layer Opacity Deck A</td>
</tr>
<tr>
<td>[4] + [41]</td>
<td>Storage Place Submaster Deck B</td>
</tr>
<tr>
<td>[5] + [41]</td>
<td>Layer Submaster Deck B</td>
</tr>
<tr>
<td>[6] + [41]</td>
<td>Layer Opacity Deck B</td>
</tr>
<tr>
<td>[7]</td>
<td>Crossfader Fade Type DOWN</td>
</tr>
<tr>
<td>[8]</td>
<td>Crossfader Fade Type UP</td>
</tr>
<tr>
<td>[9]</td>
<td>Cue List Back</td>
</tr>
<tr>
<td>[10]</td>
<td>Cue List Go</td>
</tr>
<tr>
<td>[11] + [40]</td>
<td>Fast Forward / Rewind Deck A</td>
</tr>
<tr>
<td>[16]</td>
<td>Audio Input ON/OFF</td>
</tr>
<tr>
<td>[17]</td>
<td>Cue Storage Place Deck B</td>
</tr>
<tr>
<td>[18]</td>
<td>Layer Deck A DOWN</td>
</tr>
<tr>
<td>[19]</td>
<td>Layer Deck A UP</td>
</tr>
<tr>
<td>[20]</td>
<td>Layer Deck B DOWN</td>
</tr>
<tr>
<td>[21]</td>
<td>Layer Deck B UP</td>
</tr>
<tr>
<td>[22]</td>
<td>Layer Mix Mode Deck A DOWN</td>
</tr>
<tr>
<td>[23]</td>
<td>Layer Mix Mode Deck A UP</td>
</tr>
<tr>
<td>[24]</td>
<td>Layer Mix Mode Deck B DOWN</td>
</tr>
<tr>
<td>[25]</td>
<td>Layer Mix Mode Deck B UP</td>
</tr>
<tr>
<td>[26]</td>
<td>(Left Mouse Button)</td>
</tr>
<tr>
<td>[31]</td>
<td>Crossfader Automatic Fade</td>
</tr>
<tr>
<td>[32]</td>
<td>Color-Fade color WHITE</td>
</tr>
<tr>
<td>[33]</td>
<td>Audio Input Level</td>
</tr>
<tr>
<td>[34]</td>
<td>Crossfader Fade Time</td>
</tr>
<tr>
<td>[35]</td>
<td>Storage Place Deck A UP/DOWN</td>
</tr>
<tr>
<td>[36]</td>
<td>Color-Fade color BLUE</td>
</tr>
<tr>
<td>[37]</td>
<td>Color-Fade color GREEN</td>
</tr>
<tr>
<td>[38]</td>
<td>Color-Fade color RED</td>
</tr>
<tr>
<td>[39]</td>
<td>Storage Place Deck B UP/DOWN</td>
</tr>
<tr>
<td>[40]</td>
<td>See [1], [2], [3]</td>
</tr>
<tr>
<td>[41]</td>
<td>See [4], [5], [6]</td>
</tr>
<tr>
<td>Function</td>
<td>Deck A Operation</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>------------------</td>
</tr>
<tr>
<td>[12] + [41] Fast Forward / Rewind</td>
<td>[27] (Right Mouse Button)</td>
</tr>
<tr>
<td>Deck B</td>
<td></td>
</tr>
<tr>
<td>[14] Cue List Play/Pause</td>
<td>[29] Speed Master Deck B</td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«
### 7.2.20 Hercules DJ Control MP3 e2

<table>
<thead>
<tr>
<th></th>
<th>Main Output Freeze (Hold)</th>
<th>Mode: Storage</th>
<th>Mode: Layer</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>[26] Speed Master Deck A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[27] Speed Master Deck B</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[28] Speed Master Deck A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[29] Speed Master Deck B</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[30] Speed Master Deck A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[31] Speed Master Deck B</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[32] Speed Master Deck A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[33] Speed Master Deck B</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[34] Speed Master Deck A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[35] Speed Master Deck B</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[36] Speed Master Deck A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[37] Speed Master Deck B</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[38] Speed Master Deck A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[39] Speed Master Deck B</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[40] Speed Master Deck A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[41] Speed Master Deck B</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[42] Speed Master Deck A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[43] Speed Master Deck B</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[44] Speed Master Deck A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[45] Speed Master Deck B</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[46] Speed Master Deck A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[47] Speed Master Deck B</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[48] Speed Master Deck A</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>[49] Speed Master Deck B</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

---

**Diagram:**

![Hercules DJ Control MP3 e2 Diagram](image-url)
<table>
<thead>
<tr>
<th>Color-Fade color</th>
<th>Storage Place</th>
<th>Layer Submaster</th>
<th>Layer Fast</th>
</tr>
</thead>
<tbody>
<tr>
<td>GREEN</td>
<td>Submaster Deck A UP</td>
<td>Deck A UP</td>
<td>Forward / Rewind Deck A (Layer Mode)</td>
</tr>
<tr>
<td>BLUE</td>
<td>Submaster Deck B UP</td>
<td>Deck B UP</td>
<td></td>
</tr>
<tr>
<td>WHITE</td>
<td>Submaster, Mix Mode, Opacity Deck A Reset</td>
<td></td>
<td></td>
</tr>
<tr>
<td>FREE</td>
<td>Submaster Deck B Reset</td>
<td>Deck B Reset</td>
<td></td>
</tr>
<tr>
<td>Crossfader Fade Time</td>
<td>Submaster Deck A P1</td>
<td>Layer 1 Deck A</td>
<td></td>
</tr>
<tr>
<td>Crossfader Automatic</td>
<td>Submaster Deck B P1</td>
<td>Layer 1 Deck B</td>
<td></td>
</tr>
<tr>
<td>Fade NEXT</td>
<td>Submaster Deck A P2</td>
<td>Layer 2 Deck A</td>
<td></td>
</tr>
<tr>
<td>Crossfader Fade Type</td>
<td>Submaster Deck B P2</td>
<td>Layer 2 Deck B</td>
<td></td>
</tr>
<tr>
<td>Audio Input ON/OFF</td>
<td>ID Deck A DOWN</td>
<td>Layer 3 Deck A</td>
<td></td>
</tr>
<tr>
<td>Master</td>
<td>ID Deck B DOWN</td>
<td>Layer 3 Deck B</td>
<td></td>
</tr>
<tr>
<td>Audio Input level</td>
<td>ID Deck A UP</td>
<td>Layer 4 Deck A</td>
<td></td>
</tr>
<tr>
<td>Crossfader</td>
<td>ID Deck B UP</td>
<td>Layer 4 Deck B</td>
<td></td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«
7.2.21 KORG nanoKONTROL

- Please always select Scene '1'.

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>[27] Cue List Stop</td>
</tr>
<tr>
<td></td>
<td></td>
<td>[28] Cue List Open/Close</td>
</tr>
<tr>
<td></td>
<td>[29] Mode: ON = Storage Deck A; OFF = Storage Deck B</td>
<td></td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«
### 7.2.22 KORG nanoKONTROL2

You can get an overview over all preprogrammed MIDI maps in the chapter »**MIDI-IN Configuration**

![KORG nanoKONTROL2 Control Surface](image-url)

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>[1]</td>
<td>[17]</td>
<td>[2]</td>
<td>[18]</td>
<td>[3]</td>
<td>[19]</td>
<td>[4]</td>
<td>[20]</td>
<td>[5]</td>
<td>[21]</td>
<td>[6]</td>
<td>[22]</td>
<td>[7]</td>
<td>[23]</td>
<td>[8]</td>
<td>[24]</td>
<td>[9]</td>
<td>[25]</td>
<td>[10]</td>
<td>[26]</td>
<td>[11]</td>
<td>[27]</td>
<td>[12]</td>
<td>[28]</td>
<td>[13]</td>
<td>[29]</td>
<td>[14]</td>
<td>[30]</td>
<td>[15]</td>
<td>[31]</td>
<td>[16]</td>
<td>[32]</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
7.2.23 Livid Instruments Ohm64

<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>[59] Layer Deck A UP</td>
<td>[59] Layer Deck B UP</td>
</tr>
<tr>
<td>[60] Speed Master Deck A Pause (Permanently)</td>
<td>[60] Speed Master Deck B Pause (Permanently)</td>
</tr>
<tr>
<td>[95] Storage ID Deck A DOWN</td>
<td>[95] Storage ID Deck B DOWN</td>
</tr>
<tr>
<td>[97] Storage Place Deck A DOWN</td>
<td>[97] Storage Place Deck B DOWN</td>
</tr>
<tr>
<td>[98] Storage Place Deck A UP</td>
<td>[98] Storage Place Deck B UP</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>[61] Crossfader Fade Type UP/DOWN</th>
<th>[73] Main Output Freeze</th>
<th>[84] Layer 1 Opacity (Deck A / Deck B)</th>
</tr>
</thead>
<tbody>
<tr>
<td>[64] Audio Input Level</td>
<td>[76] Cue List Back</td>
<td>[87] Layer 4 Opacity (Deck A / Deck B)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>[65] Color-Fade color RED</td>
<td>[77] Cue List Open/Close</td>
<td>[88] Layer 1 Blind Mode (Deck A / Deck B)</td>
</tr>
<tr>
<td>[66] Color-Fade color GREEN</td>
<td>[78] Cue List Play/Pause</td>
<td>[89] Layer 2 Blind Mode (Deck A / Deck B)</td>
</tr>
<tr>
<td>[70] Color Filter color GREEN</td>
<td>[82] Speed Master Deck B</td>
<td></td>
</tr>
<tr>
<td>[71] Color Filter color BLUE</td>
<td>[83] Storage Place Submaster Deck B</td>
<td></td>
</tr>
<tr>
<td>[72] Color Filter color WHITE</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«
7.2.24 M-AUDIO Code 49

- Please choose Preset 10 and work with RED illuminated Encoder Mode.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Speed Master Deck A / Deck B</td>
</tr>
<tr>
<td>2</td>
<td>Audio Input Level</td>
</tr>
<tr>
<td>3</td>
<td>PAD Octave DOWN</td>
</tr>
<tr>
<td>4</td>
<td>PAD Octave UP</td>
</tr>
<tr>
<td>5</td>
<td>KEY Octave DOWN</td>
</tr>
<tr>
<td>6</td>
<td>KEY Octave UP</td>
</tr>
<tr>
<td>7</td>
<td>Master</td>
</tr>
<tr>
<td>8</td>
<td>Group Value Group 1</td>
</tr>
<tr>
<td>9</td>
<td>Group Value Group 2</td>
</tr>
<tr>
<td>10</td>
<td>Group Value Group 3</td>
</tr>
<tr>
<td>11</td>
<td>Group Value Group 4</td>
</tr>
<tr>
<td>12</td>
<td>Group Value Group 5</td>
</tr>
<tr>
<td>13</td>
<td>Group Value Group 6</td>
</tr>
<tr>
<td>14</td>
<td>Group Value Group 7</td>
</tr>
<tr>
<td>15</td>
<td>Group Value Group 8</td>
</tr>
<tr>
<td>16</td>
<td>Color Filter Main Output RED</td>
</tr>
<tr>
<td>17</td>
<td>Color Filter Main Output GREEN</td>
</tr>
<tr>
<td>18</td>
<td>Color Filter Main Output BLUE</td>
</tr>
<tr>
<td>19</td>
<td>Color Filter Main Output WHITE</td>
</tr>
<tr>
<td>20</td>
<td>Color Fade Color RED</td>
</tr>
<tr>
<td>21</td>
<td>Color Fade Color Green</td>
</tr>
<tr>
<td>22</td>
<td>Color Fade Color BLUE</td>
</tr>
</tbody>
</table>
### [23] Color Fade Color WHITE

<table>
<thead>
<tr>
<th>PAD Octave</th>
<th>Storage Place</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>KEY Octave</th>
<th>Storage Place</th>
</tr>
</thead>
<tbody>
<tr>
<td>-3</td>
<td>[40] – [88] Storage Place Deck B 1 – 49</td>
</tr>
<tr>
<td>-2</td>
<td>[40] – [88] Storage Place Deck B 13 – 61</td>
</tr>
<tr>
<td>-1</td>
<td>[40] – [88] Storage Place Deck B 25 – 72</td>
</tr>
<tr>
<td>0</td>
<td>[40] – [88] Storage Place Deck B 37 – 85</td>
</tr>
<tr>
<td>+1</td>
<td>[40] – [88] Storage Place Deck B 49 – 97</td>
</tr>
<tr>
<td>+2</td>
<td>[40] – [88] Storage Place Deck B 61 – 109</td>
</tr>
<tr>
<td>+3</td>
<td>[40] – [88] Storage Place Deck B 73 – 121</td>
</tr>
<tr>
<td>+4</td>
<td>[40] – [88] Storage Place Deck B 85 – 121</td>
</tr>
<tr>
<td>+5</td>
<td>[40] – [83] Storage Place Deck B 97 – 128</td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »[MIDI-IN Configuration](#)«
7.2.25 M-AUDIO Oxygen 8 v2

- Make sure to activate Preset 1 [General MIDI] and c 01 with button [6].

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>[3] Storage Place Area (Octaves)</td>
<td>[25] Storage Place Deck A P3 (If Octave -4)</td>
<td>[37] Storage Place Deck B P3 (If Octave -4)</td>
</tr>
<tr>
<td>[4] No MIDI function</td>
<td>[26] Storage Place Deck A P4 (If Octave -4)</td>
<td>[38] Storage Place Deck B P4 (If Octave -4)</td>
</tr>
<tr>
<td>[6] No MIDI function</td>
<td>[28] Storage Place Deck A P6 (If Octave -4)</td>
<td>[40] Storage Place Deck B P6 (If Octave -4)</td>
</tr>
<tr>
<td>[7] FREE</td>
<td>[29] Storage Place Deck A P7 (If Octave -4)</td>
<td>[41] Storage Place Deck B P7 (If Octave -4)</td>
</tr>
</tbody>
</table>
### Part G: INPUT And Remote Control

<table>
<thead>
<tr>
<th>9</th>
<th>Storage ID Deck A S1 – S128</th>
<th>31</th>
<th>Storage Place Deck A P9 (If Octave -4)</th>
<th>43</th>
<th>Storage Place Deck B P9 (If Octave -4)</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Storage ID Deck B S1 – S128</td>
<td>32</td>
<td>Storage Place Deck A P10 (If Octave -4)</td>
<td>44</td>
<td>Storage Place Deck B P10 (If Octave -4)</td>
</tr>
<tr>
<td>11</td>
<td>FREE</td>
<td>33</td>
<td>Storage Place Deck A P11 (If Octave -4)</td>
<td>45</td>
<td>Storage Place Deck B P11 (If Octave -4)</td>
</tr>
<tr>
<td>12</td>
<td>Audio Input Level</td>
<td>34</td>
<td>Storage Place Deck A P12 (If Octave -4)</td>
<td>46</td>
<td>Storage Place Deck B P12 (If Octave -4)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>13</td>
<td>Crossfader</td>
</tr>
<tr>
<td>14</td>
<td>Speed Master Deck A</td>
<td>23</td>
<td>Storage Place Deck A P13 (If Octave -2)</td>
<td>35</td>
<td>Storage Place Deck B P13 (If Octave -2)</td>
</tr>
<tr>
<td>15</td>
<td>Speed Master Deck B</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>Crossfader Fade Time</td>
<td>34</td>
<td>Storage Place Deck A P24 (If Octave -2)</td>
<td>46</td>
<td>Storage Place Deck B P24 (If Octave -2)</td>
</tr>
<tr>
<td>17</td>
<td>Main Output Freeze</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>Cue List Back</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>Cue List Go</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>Cue List Stop</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>Crossfader Fade Type (Toggle)</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>22</td>
<td>Crossfader Skip to Deck A / Deck B</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »[MIDI-IN Configuration](#)«
## 7.2.26 M-AUDIO Torq Xponent

<table>
<thead>
<tr>
<th>Feature</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>[3] Crossfader Skip To Left</td>
<td>[27] Crossfader Automatic Fade</td>
</tr>
<tr>
<td>[7] Color-Fade color GREEN</td>
<td>[31] See [33], [34], [35], [36]</td>
</tr>
<tr>
<td>[8] Color-Fade color RED</td>
<td>[32] See [37], [37], [39], [40]</td>
</tr>
<tr>
<td>[9] Color Filter color WHITE</td>
<td>[33] + [31] Storage Place Submaster Deck A</td>
</tr>
<tr>
<td>[10] Color Filter color BLUE</td>
<td>[34] + [31] Layer Opacity Deck A</td>
</tr>
<tr>
<td>[12] Color Filter color RED</td>
<td>[36] + [31] Layer Submaster Deck A</td>
</tr>
<tr>
<td>[19] Fade Type Color-Fade</td>
<td>[38] + [32] Layer Opacity Deck B</td>
</tr>
<tr>
<td>[46] Storage ID Deck A S129 – S256</td>
<td></td>
</tr>
<tr>
<td>[49] Storage ID Deck B S1 – S128</td>
<td></td>
</tr>
<tr>
<td>[50] Storage ID Deck B S129 – S256</td>
<td></td>
</tr>
<tr>
<td>[61] Cue List Play / Pause</td>
<td></td>
</tr>
<tr>
<td>[62] Cue Storage Place Deck A</td>
<td></td>
</tr>
<tr>
<td>[63] Storage Place Deck A DOWN</td>
<td></td>
</tr>
<tr>
<td>[64] Storage Place Deck A UP</td>
<td></td>
</tr>
<tr>
<td>[65] Cue List Play/Pause</td>
<td></td>
</tr>
<tr>
<td>[66] Cue Storage Place Deck B</td>
<td></td>
</tr>
<tr>
<td>[67] Storage Place Deck B DOWN</td>
<td></td>
</tr>
<tr>
<td>[68] Storage Place Deck B UP</td>
<td></td>
</tr>
<tr>
<td>[69] Speed Master Deck A</td>
<td></td>
</tr>
<tr>
<td>[70] Speed Master Deck B</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>[21] Fade Type White-Fade</td>
<td>[40] + [32] Layer Submaster Deck B</td>
</tr>
<tr>
<td>[22] Fade Type Cross-Fade</td>
<td>[41] Layer Deck A DOWN</td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«
### 7.2.27 MIDI Keyboards

<table>
<thead>
<tr>
<th>MIDI Note</th>
<th>Value</th>
<th>MIDI Note</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>#48</td>
<td>Crossfader Skip To Left</td>
<td>#84</td>
<td>Storage ID Deck A DOWN</td>
</tr>
<tr>
<td>#49</td>
<td>Crossfader Automatic Fade</td>
<td>#85</td>
<td>Storage ID Deck A UP</td>
</tr>
<tr>
<td>#50</td>
<td>Crossfader Skip To Right</td>
<td>#86</td>
<td>Storage ID Deck B DOWN</td>
</tr>
<tr>
<td>#51</td>
<td>Crossfader Fade Type DOWN</td>
<td>#87</td>
<td>Storage ID Deck B UP</td>
</tr>
<tr>
<td>#52</td>
<td>Crossfader Fade Type UP</td>
<td>#88</td>
<td></td>
</tr>
<tr>
<td>#53</td>
<td>Cue List Back</td>
<td>#89</td>
<td></td>
</tr>
<tr>
<td>#54</td>
<td>Cue List Play/Pause</td>
<td>#90</td>
<td></td>
</tr>
<tr>
<td>#55</td>
<td>Cue List Go</td>
<td>#91</td>
<td></td>
</tr>
<tr>
<td>#56</td>
<td>Storage Place Deck A DOWN</td>
<td>#92</td>
<td></td>
</tr>
<tr>
<td>#57</td>
<td>Storage Place Deck A UP</td>
<td>#93</td>
<td></td>
</tr>
<tr>
<td>#58</td>
<td>Storage Place Deck B DOWN</td>
<td>#94</td>
<td></td>
</tr>
<tr>
<td>#59</td>
<td>Storage Place Deck B UP</td>
<td>#95</td>
<td></td>
</tr>
<tr>
<td>#60…#69</td>
<td>Storage Place Deck A P1 – P10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>#60…#69 + #70</td>
<td>Storage Place Deck A P11 – P20</td>
<td></td>
<td></td>
</tr>
<tr>
<td>#60…#69 + #71</td>
<td>Storage Place Deck A P21 – P30</td>
<td></td>
<td></td>
</tr>
<tr>
<td>#60…#69 + #70 + #71</td>
<td>Storage Place Deck A P31 – P40</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Storage Place Deck B

<table>
<thead>
<tr>
<th></th>
<th>Storage Place Deck B P1 – P10</th>
<th>Storage Place Deck B P11 – P20</th>
<th>Storage Place Deck B P21 – P30</th>
<th>Storage Place Deck B P31 – P40</th>
<th>Control Change 0x40 (0xB0 0x40 0x00)</th>
<th>Audio Input ON/OFF</th>
</tr>
</thead>
<tbody>
<tr>
<td>#72...#81</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>#72...#81 + #82</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>#72...#81 + #83</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>#72...#81 + #82 + #83</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

---

### Octave #

<table>
<thead>
<tr>
<th>Octave #</th>
<th>Note Numbers</th>
</tr>
</thead>
<tbody>
<tr>
<td>C</td>
<td>0</td>
</tr>
<tr>
<td>C#</td>
<td>1</td>
</tr>
<tr>
<td>D</td>
<td>2</td>
</tr>
<tr>
<td>D#</td>
<td>3</td>
</tr>
<tr>
<td>E</td>
<td>4</td>
</tr>
<tr>
<td>F</td>
<td>5</td>
</tr>
<tr>
<td>F#</td>
<td>6</td>
</tr>
<tr>
<td>G</td>
<td>7</td>
</tr>
<tr>
<td>G#</td>
<td>8</td>
</tr>
<tr>
<td>A</td>
<td>9</td>
</tr>
<tr>
<td>A#</td>
<td>10</td>
</tr>
<tr>
<td>B</td>
<td>11</td>
</tr>
<tr>
<td>-1</td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>12</td>
</tr>
<tr>
<td>1</td>
<td>24</td>
</tr>
<tr>
<td>2</td>
<td>36</td>
</tr>
<tr>
<td>3</td>
<td>48</td>
</tr>
<tr>
<td>4</td>
<td>60</td>
</tr>
<tr>
<td>5</td>
<td>72</td>
</tr>
<tr>
<td>6</td>
<td>84</td>
</tr>
<tr>
<td>7</td>
<td>96</td>
</tr>
<tr>
<td>8</td>
<td>108</td>
</tr>
<tr>
<td>9</td>
<td>120</td>
</tr>
</tbody>
</table>

---

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«
7.2.28 MIDI Universal

- Do not use MIDI channels/controllers that are currently not assigned. These entries are reserved for future features.

MIDI Message Type 0xb0 [Controller 0xb, Channel 1]

<table>
<thead>
<tr>
<th>Controller</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>#00</td>
<td>Storage Place Deck A</td>
</tr>
<tr>
<td>#01</td>
<td>Storage Place Deck B</td>
</tr>
<tr>
<td>#02</td>
<td>Storage Place Deck A + Fade</td>
</tr>
<tr>
<td>#03</td>
<td>Storage Place Deck B + Fade</td>
</tr>
<tr>
<td>#04</td>
<td>Storage Place Deck A UP</td>
</tr>
<tr>
<td>#05</td>
<td>Storage Place Deck A DOWN</td>
</tr>
<tr>
<td>#06</td>
<td>Storage Place Deck B UP</td>
</tr>
<tr>
<td>#07</td>
<td>Storage Place Deck B DOWN</td>
</tr>
<tr>
<td>#08</td>
<td>Storage Place Deck A UP + Fade</td>
</tr>
<tr>
<td>#09</td>
<td>Storage Place Deck A DOWN +Fade</td>
</tr>
<tr>
<td>#0A</td>
<td>Storage Place Deck B UP + Fade</td>
</tr>
<tr>
<td>#0B</td>
<td>Storage Place Deck B DOWN +Fade</td>
</tr>
<tr>
<td>#10</td>
<td>Storage Place Submaster Deck A</td>
</tr>
<tr>
<td>#11</td>
<td>Storage Place Submaster Deck B B</td>
</tr>
<tr>
<td>#12</td>
<td>Storage Place Submaster Deck A UP</td>
</tr>
<tr>
<td>#13</td>
<td>Storage Place Submaster Deck A DOWN</td>
</tr>
<tr>
<td>#14</td>
<td>Storage Place Submaster Deck B UP</td>
</tr>
<tr>
<td>#15</td>
<td>Storage Place Submaster Deck B DOWN</td>
</tr>
<tr>
<td>#20</td>
<td>Speed Master Deck A</td>
</tr>
<tr>
<td>#21</td>
<td>Speed Master Deck A UP</td>
</tr>
<tr>
<td>#22</td>
<td>Speed Master Deck A DOWN</td>
</tr>
<tr>
<td>#23</td>
<td>Speed Master Deck A Reset</td>
</tr>
<tr>
<td>#24</td>
<td>Speed Master Deck A Pause</td>
</tr>
<tr>
<td>#25</td>
<td>Speed Master Deck A Pause (Hold)</td>
</tr>
<tr>
<td>#26</td>
<td>Speed Master Deck A Play</td>
</tr>
<tr>
<td>#28</td>
<td>Speed Master Deck B</td>
</tr>
<tr>
<td>Controller</td>
<td>Value</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>#29</td>
<td>Speed Master Deck B UP</td>
</tr>
<tr>
<td>#2A</td>
<td>Speed Master Deck B Down</td>
</tr>
<tr>
<td>#2B</td>
<td>Speed Master Deck B Reset</td>
</tr>
<tr>
<td>#2C</td>
<td>Speed Master Deck B Pause</td>
</tr>
<tr>
<td>#2D</td>
<td>Speed Master Deck B Pause (Hold)</td>
</tr>
<tr>
<td>#2E</td>
<td>Speed Master Deck B Play</td>
</tr>
<tr>
<td>#30</td>
<td>Storage Deck A Frame ID UP</td>
</tr>
<tr>
<td>#31</td>
<td>Storage Deck A Frame ID DOWN</td>
</tr>
<tr>
<td>#32</td>
<td>Storage Deck B Frame ID UP</td>
</tr>
<tr>
<td>#33</td>
<td>Storage Deck B Frame ID DOWN</td>
</tr>
<tr>
<td>#3A</td>
<td>Main Output Freeze ON</td>
</tr>
<tr>
<td>#3B</td>
<td>Main Output Freeze OFF</td>
</tr>
<tr>
<td>#3C</td>
<td>Main Output Freeze (Hold)</td>
</tr>
<tr>
<td>#40</td>
<td>Layer Deck A</td>
</tr>
<tr>
<td>#41</td>
<td>Layer Deck B</td>
</tr>
<tr>
<td>#42</td>
<td>Layer Deck A UP</td>
</tr>
<tr>
<td>#43</td>
<td>Layer Deck B DOWN</td>
</tr>
<tr>
<td>#44</td>
<td>Layer Deck B UP</td>
</tr>
<tr>
<td>#45</td>
<td>Layer Deck B DOWN</td>
</tr>
<tr>
<td>#50</td>
<td>Layer Opacity Deck A</td>
</tr>
<tr>
<td>#51</td>
<td>Layer Opacity Deck B</td>
</tr>
<tr>
<td>#52</td>
<td>Layer Opacity Deck A UP</td>
</tr>
<tr>
<td>#53</td>
<td>Layer Opacity Deck A DOWN</td>
</tr>
<tr>
<td>#54</td>
<td>Layer Opacity Deck B UP</td>
</tr>
<tr>
<td>#55</td>
<td>Layer Opacity Deck B DOWN</td>
</tr>
<tr>
<td>#60</td>
<td>Layer Submaster Deck A</td>
</tr>
<tr>
<td>#61</td>
<td>Layer Submaster Deck B</td>
</tr>
<tr>
<td>#62</td>
<td>Layer Submaster Deck A UP</td>
</tr>
<tr>
<td>#63</td>
<td>Layer Submaster Deck A DOWN</td>
</tr>
<tr>
<td>#64</td>
<td>Layer Submaster Deck B UP</td>
</tr>
<tr>
<td>#65</td>
<td>Layer Submaster Deck B DOWN</td>
</tr>
<tr>
<td>#70</td>
<td>Layer Mix Mode Deck A</td>
</tr>
</tbody>
</table>
### Part G: INPUT And Remote Control

**Table: Layer Mix Mode Controller Values**

<table>
<thead>
<tr>
<th>Controller</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>#71</td>
<td>Layer Mix Mode Deck B</td>
</tr>
<tr>
<td>#72</td>
<td>Layer Mix Mode Deck A UP</td>
</tr>
<tr>
<td>#73</td>
<td>Layer Mix Mode Deck A DOWN</td>
</tr>
<tr>
<td>#74</td>
<td>Layer Mix Mode Deck B UP</td>
</tr>
<tr>
<td>#75</td>
<td>Layer Mix Mode Deck B DOWN</td>
</tr>
</tbody>
</table>

**MIDI Message Type 0xb1 [Controller 0xb, Channel 2]**

<table>
<thead>
<tr>
<th>Controller</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>#00</td>
<td>Layer Frame ID Deck A UP</td>
</tr>
<tr>
<td>#01</td>
<td>Layer Frame ID Deck A DOWN</td>
</tr>
<tr>
<td>#02</td>
<td>Layer Frame ID Deck B UP</td>
</tr>
<tr>
<td>#03</td>
<td>Layer Frame ID Deck B DOWN</td>
</tr>
<tr>
<td>#10</td>
<td>Crossfader Fade Time</td>
</tr>
<tr>
<td>#12</td>
<td>Crossfader Automatic Fade</td>
</tr>
<tr>
<td>#13</td>
<td>Crossfader</td>
</tr>
<tr>
<td>#14</td>
<td>Crossfader Step Deck A</td>
</tr>
<tr>
<td>#15</td>
<td>Crossfader Step Deck B</td>
</tr>
<tr>
<td>#16</td>
<td>Crossfader Skip to Left</td>
</tr>
<tr>
<td>#17</td>
<td>Crossfader Skip to Right</td>
</tr>
<tr>
<td>#1A</td>
<td>Master</td>
</tr>
<tr>
<td>#1B</td>
<td>Master UP</td>
</tr>
<tr>
<td>#1C</td>
<td>Master Down</td>
</tr>
<tr>
<td>#20</td>
<td>Crossfader Fade Type UP</td>
</tr>
<tr>
<td>#21</td>
<td>Crossfader Fade Type DOWN</td>
</tr>
<tr>
<td>#22</td>
<td>Crossfader Fade Type Cross-Fade</td>
</tr>
<tr>
<td>#23</td>
<td>Crossfader Fade Type White-Fade</td>
</tr>
<tr>
<td>#24</td>
<td>Crossfader Fade Type Black-Fade</td>
</tr>
<tr>
<td>#25</td>
<td>Crossfader Fade Type Color-Fade</td>
</tr>
<tr>
<td>#40</td>
<td>Color-Fade color RED</td>
</tr>
<tr>
<td>#41</td>
<td>Color-Fade color RED UP</td>
</tr>
<tr>
<td>#</td>
<td>Description</td>
</tr>
<tr>
<td>-----</td>
<td>-----------------------------------</td>
</tr>
<tr>
<td>#42</td>
<td>Color-Fade color RED DOWN</td>
</tr>
<tr>
<td>#43</td>
<td>Color-Fade color GREEN</td>
</tr>
<tr>
<td>#44</td>
<td>Color-Fade color GREEN UP</td>
</tr>
<tr>
<td>#45</td>
<td>Color-Fade color GREEN DOWN</td>
</tr>
<tr>
<td>#46</td>
<td>Color-Fade color BLUE</td>
</tr>
<tr>
<td>#47</td>
<td>Color-Fade color BLUE UP</td>
</tr>
<tr>
<td>#48</td>
<td>Color-Fade color BLUE DOWN</td>
</tr>
<tr>
<td>#49</td>
<td>Color-Fade color WHITE</td>
</tr>
<tr>
<td>#4A</td>
<td>Color-Fade color WHITE UP</td>
</tr>
<tr>
<td>#4B</td>
<td>Color-Fade color WHITE DOWN</td>
</tr>
<tr>
<td>#50</td>
<td>Cue Storage Place Deck A</td>
</tr>
<tr>
<td>#51</td>
<td>Cue Storage Place Deck B</td>
</tr>
<tr>
<td>#52</td>
<td>Delete Cue List Entry VALUE</td>
</tr>
<tr>
<td>#53</td>
<td>Delete CURRENT Cue List Entry</td>
</tr>
<tr>
<td>#54</td>
<td>Cue List Play</td>
</tr>
<tr>
<td>#55</td>
<td>Cue List Stop</td>
</tr>
<tr>
<td>#56</td>
<td>Cue List Play/Pause</td>
</tr>
<tr>
<td>#57</td>
<td>Cue List Go</td>
</tr>
<tr>
<td>#58</td>
<td>Cue List Back</td>
</tr>
<tr>
<td>#59</td>
<td>PLACEHOLDER</td>
</tr>
<tr>
<td>#5A</td>
<td>Cue List Goto</td>
</tr>
<tr>
<td>#5C</td>
<td>Cue List Open</td>
</tr>
<tr>
<td>#5D</td>
<td>Cue List Close</td>
</tr>
<tr>
<td>#5E</td>
<td>Cue List Open/Close</td>
</tr>
<tr>
<td>#60</td>
<td>Audio Input ON</td>
</tr>
<tr>
<td>#61</td>
<td>Audio Input OFF</td>
</tr>
<tr>
<td>#62</td>
<td>Audio Input ON/OFF</td>
</tr>
<tr>
<td>#63</td>
<td>PLACEHOLDER</td>
</tr>
<tr>
<td>#64</td>
<td>PLACEHOLDER</td>
</tr>
<tr>
<td>#65</td>
<td>PLACEHOLDER</td>
</tr>
<tr>
<td>#66</td>
<td>Audio Input Level</td>
</tr>
<tr>
<td>#67</td>
<td>Audio Input Level UP</td>
</tr>
<tr>
<td>#68</td>
<td>Audio Input Level DOWN</td>
</tr>
</tbody>
</table>
### Color Filter Colors

<table>
<thead>
<tr>
<th>Color Filter color</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>RED</td>
<td>#70</td>
</tr>
<tr>
<td>RED UP</td>
<td>#71</td>
</tr>
<tr>
<td>RED DOWN</td>
<td>#72</td>
</tr>
<tr>
<td>GREEN</td>
<td>#73</td>
</tr>
<tr>
<td>GREEN UP</td>
<td>#74</td>
</tr>
<tr>
<td>GREEN DOWN</td>
<td>#75</td>
</tr>
<tr>
<td>BLUE</td>
<td>#76</td>
</tr>
<tr>
<td>BLUE UP</td>
<td>#77</td>
</tr>
<tr>
<td>BLUE DOWN</td>
<td>#78</td>
</tr>
<tr>
<td>WHITE</td>
<td>#79</td>
</tr>
<tr>
<td>WHITE UP</td>
<td>#7A</td>
</tr>
<tr>
<td>WHITE DOWN</td>
<td>#7B</td>
</tr>
</tbody>
</table>

### MIDI Message Types

#### 0x80 [Note OFF]

<table>
<thead>
<tr>
<th>Value</th>
<th>Message Type</th>
<th>Storage Place</th>
<th>Fade Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>#0</td>
<td>0x80</td>
<td>Deck A P1</td>
<td>+Fade</td>
</tr>
<tr>
<td>#59</td>
<td></td>
<td>Deck A P60</td>
<td>+Fade</td>
</tr>
<tr>
<td>#12</td>
<td></td>
<td>Deck A DOWN</td>
<td></td>
</tr>
<tr>
<td>#12</td>
<td></td>
<td>Deck A UP</td>
<td></td>
</tr>
<tr>
<td>#6</td>
<td></td>
<td>Deck B P1</td>
<td>+Fade</td>
</tr>
<tr>
<td>#19</td>
<td></td>
<td>Deck B P60</td>
<td>+Fade</td>
</tr>
<tr>
<td>#26</td>
<td></td>
<td>Deck B DOWN</td>
<td></td>
</tr>
<tr>
<td>#27</td>
<td></td>
<td>Deck B UP</td>
<td></td>
</tr>
</tbody>
</table>

#### 0x90 [Note ON]

<table>
<thead>
<tr>
<th>Value</th>
<th>Message Type</th>
<th>Storage Place</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>#0</td>
<td>0x90</td>
<td>Deck A P1</td>
<td></td>
</tr>
<tr>
<td>#59</td>
<td></td>
<td>Deck A P60</td>
<td></td>
</tr>
<tr>
<td>#12</td>
<td></td>
<td>Deck A DOWN</td>
<td></td>
</tr>
<tr>
<td>#60</td>
<td></td>
<td>Deck B P1</td>
<td></td>
</tr>
<tr>
<td>#11</td>
<td></td>
<td>Deck B P60</td>
<td></td>
</tr>
<tr>
<td>#12</td>
<td></td>
<td>Deck B DOWN</td>
<td></td>
</tr>
</tbody>
</table>
You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«.
7.2.29 Novation Launchpad

[70] Mode: Deck A

[71] Mode: Deck B

| [1] – [56] Storage Place P1 – P60 (Deck A / Deck B) | [68] Crossfader Skip To Right |
| [57] Storage ID DOWN (Deck A / Deck B) | [69] Crossfader Fade Type DOWN |
| [58] Storage ID UP (Deck A / Deck B) | [72] Crossfader Automatic Fade |
| [59] Storage Place DOWN (Deck A / Deck B) | [73] Cue List Go |
| [60] Storage Place UP (Deck A / Deck B) | [74] Cue List Back |
| [61] Layer UP (Deck A / Deck B) | [75] Cue List Play/Pause |
| [62] Layer Mix Mode UP (Deck A / Deck B) | [76] Cue List Open/Close |
| [63] Layer Blind Mode (Deck A / Deck B) | [77] Audio Input Level UP |
| [64] Layer Solo Mode (Deck A / Deck B) | [78] Audio Input Level DOWN |
| [65] Crossfader Fade Time UP | [79] Speed Master UP (Deck A / Deck B) |
| [66] Crossfader Fade Time DOWN | [80] Speed Master DOWN (Deck A / Deck B) |
| [67] Crossfader Skip To Left | |

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«
7.2.30 Novation Launchpad Mini

[70] Mode: Deck A

[71] Mode: Deck B

<table>
<thead>
<tr>
<th>1 – 56</th>
<th>Storage Place P1 – P60 (Deck A / Deck B)</th>
<th>68</th>
<th>Crossfader Skip to Right</th>
</tr>
</thead>
<tbody>
<tr>
<td>57</td>
<td>Storage ID DOWN (Deck A / Deck B)</td>
<td>69</td>
<td>Crossfader Fade Type DOWN</td>
</tr>
<tr>
<td>58</td>
<td>Storage ID UP (Deck A / Deck B)</td>
<td>72</td>
<td>Crossfader Automatic Fade</td>
</tr>
<tr>
<td>59</td>
<td>Storage Place DOWN (Deck A / Deck B)</td>
<td>73</td>
<td>Cue List Go</td>
</tr>
<tr>
<td>60</td>
<td>Storage Place UP (Deck A / Deck B)</td>
<td>74</td>
<td>Cue List Back</td>
</tr>
<tr>
<td>61</td>
<td>Layer UP (Deck A / Deck B)</td>
<td>75</td>
<td>Cue List Play/Pause</td>
</tr>
</tbody>
</table>
### Layer Mix Mode UP (Deck A / Deck B)

### Layer Blind Mode (Deck A / Deck B)

### Layer Solo Mode (Deck A / Deck B)

### Crossfader Fade Time UP

### Crossfader Fade Time DOWN

### Crossfader Skip to Left

### Cue List Open/Close

### Audio Input Level UP

### Audio Input Level DOWN

### Speed Master UP (Deck A / Deck B)

### Speed Master DOWN (Deck A / Deck B)

You can get an overview over all preprogrammed MIDI maps in the chapter »**MIDI-IN Configuration**«
7.2.31 Numark NuVJ

<table>
<thead>
<tr>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Mode: Layer</strong></td>
</tr>
<tr>
<td>[6 PUSH] Layer Mix Mode Reset</td>
</tr>
</tbody>
</table>
### GLOBAL

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>[3]</td>
<td>Master / Audio Input Level</td>
</tr>
<tr>
<td>[5]</td>
<td>Cue List Back/Go</td>
</tr>
<tr>
<td>[13]</td>
<td>Crossfader Fade type UP/DOWN</td>
</tr>
<tr>
<td>[14]</td>
<td>Cue List Open/Close</td>
</tr>
<tr>
<td>[15]</td>
<td>Color Filter color RED</td>
</tr>
<tr>
<td>[17]</td>
<td>Cue List Play/Pause</td>
</tr>
<tr>
<td>[18]</td>
<td>Color Filter color GREEN</td>
</tr>
<tr>
<td>[19]</td>
<td>Color Filter color WHITE</td>
</tr>
<tr>
<td>[20]</td>
<td>Crossfader Automatic Fade</td>
</tr>
<tr>
<td>[21]</td>
<td>Color Filter color BLUE</td>
</tr>
<tr>
<td>[22]</td>
<td>Crossfader</td>
</tr>
<tr>
<td>[24]</td>
<td>Crossfader Fade Time</td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »[MIDI-IN Configuration]"
7.2.32 Numark Omni Control

To use the Numark Omni Control, please refer to the MIDI MAP of the »Numark Total Control«.

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«.
7.2.33 Numark Stealth Control

To use the Numark Stealth Control, please refer to the MIDI MAP of the »Numark Total Control«.

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«.
7.2.34 Numark Total Control

1. Cue List Go/Back
2. Speed Master Reset (Deck A / Deck B)
3. Cue List Play/Pause
4. Crossfader Fade Type DOWN/UP
5. Storage Place Submaster (Deck A / Deck B)
6. Cue List / Audio Input ON/OFF
7. Layer Mix Mode UP/DOWN (Deck A / Deck B)
8. Cue Storage Place (Deck A / Deck B)
9. Layer Mix Mode Reset (Deck A / Deck B)
10. Speed Master Pause
11. Storage Place Submaster Reset (Deck A / Deck B)
12. Layer Submaster (Deck A / Deck B)
13. Master / Audio Input Level
14. Storage ID DOWN (Deck A / Deck B)
15. Speed Master
16. Layer Opacity (Deck A / Deck B)
17. Speed Master Pause
18. Storage ID UP (Deck A / Deck B)
<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>[10]</td>
<td>Crossfader Automatic Fade</td>
</tr>
<tr>
<td>[29]</td>
<td>Color-Fade color RED</td>
</tr>
<tr>
<td>[30]</td>
<td>Color-Fade color GREEN</td>
</tr>
<tr>
<td>[12]</td>
<td>Layer UP/DOWN (Deck A / Deck B)</td>
</tr>
<tr>
<td>[31]</td>
<td>Color-Fade color BLUE</td>
</tr>
<tr>
<td>[15]</td>
<td>Crossfader</td>
</tr>
<tr>
<td>[32]</td>
<td>Color-Fade color WHITE</td>
</tr>
<tr>
<td>[16]</td>
<td>Crossfader Fade Time</td>
</tr>
<tr>
<td>[33]</td>
<td>Color Filter color RED</td>
</tr>
<tr>
<td>[18]</td>
<td>FREE</td>
</tr>
<tr>
<td>[34]</td>
<td>Color Filter color GREEN</td>
</tr>
<tr>
<td>[19]</td>
<td>FREE</td>
</tr>
<tr>
<td>[35]</td>
<td>Color Filter color BLUE</td>
</tr>
<tr>
<td>[36]</td>
<td>Color Filter color WHITE</td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration«
7.2.35 Omnitronic MMC-1

- Please power on the console with every new start!

```
[21 B HOLD] + [37] Mode: Color Filter (Default)

[21 A HOLD] + [36] Mode: Color-Fade

[39] Color RED for Color Filter or Color-Fade
[40] Color GREEN for Color Filter or Color-Fade
[41] Color BLUE for Color Filter or Color-Fade
[42] Color WHITE for Color Filter or Color-Fade

<table>
<thead>
<tr>
<th>[2] Mode 1</th>
<th>[22]</th>
<th>[22 PUSH]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layer Opacity</td>
<td>Layer Opacity Reset</td>
<td></td>
</tr>
<tr>
<td>(Deck A / Deck B)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>[3] Mode 2</td>
<td>[22]</td>
<td>[22 PUSH]</td>
</tr>
<tr>
<td>Layer Submaster</td>
<td>Layer Submaster Reset</td>
<td></td>
</tr>
<tr>
<td>(Deck A / Deck B)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>[4] Mode 3</td>
<td>[22]</td>
<td>[22 PUSH]</td>
</tr>
<tr>
<td>Layer Mix Mode</td>
<td>Layer Mix Mode Reset</td>
<td></td>
</tr>
<tr>
<td>UP/DOWN (Deck A</td>
<td></td>
<td></td>
</tr>
<tr>
<td>/ Deck B)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>[5] Mode 4</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

[1] Power On

[10] Layer 1 (Deck A / Deck B)

[21 HOLD] + [19] Cue List Open/Close

[31] Speed Master Pause (Permanently) (Deck A / Deck B)

[21 HOLD] + [20] Cue List Back

[32 HOLD] Speed Master Pause (Hold) (Deck A / Deck B)
```
### Layer 2 (Deck A / Deck B)
- [23] Storage Place Submaster (Deck A / Deck B)
- [33] Storage ID DOWN (Deck A / Deck B)

### Layer 3 (Deck A / Deck B)
- [23 PUSH] Storage Place Submaster Reset (Deck A / Deck B)
- [34] Storage ID UP (Deck A / Deck B)

### Layer 4 (Deck A / Deck B)
- [24] Storage Place UP/DOWN (Deck A / Deck B)
- [35] Speed Master (Deck A / Deck B)

### Layer DOWN (Deck A / Deck B)
- [21 HOLD] + [24] Skip 5 Storage Places UP/DOWN (Deck A / Deck B)
- [36] Crossfader Skip to Left

### Layer UP (Deck A / Deck B)
- [24 PUSH] Storage Place P1 (Deck A / Deck B)
- [37] Crossfader Skip to Right

### Layer Solo Mode (Deck A / Deck B)
- [25] Cue List Play/Pause
- [38] Crossfader Fade Type

### Layer Blind Mode (Deck A / Deck B)
- [26] Cue List Go
- [43] Crossfader Fade Time

### Solo Mode/Blind Mode OFF
- [27] Cue List Open/Close
- [45] Master

### Cue Storage Place (Deck A / Deck B)
- [28] Cue List Back
- [46] Audio Input Level

### Cue List Go
- [29] Frame ID (Deck A / Deck B)
- [47] Crossfader

### Speed Master Reset (Deck A / Deck B)

---

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration"
7.2.36 Stanton SCS.3d

<table>
<thead>
<tr>
<th></th>
<th>Mode: Main Mode</th>
<th>Mode: Deck A / Deck B</th>
</tr>
</thead>
</table>
### Part G: INPUT And Remote Control

<table>
<thead>
<tr>
<th><strong>[8]</strong> FREE</th>
<th>[8] Storage ID UP</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>[9]</strong> Main Output Freeze</td>
<td>[9] Storage ID DOWN</td>
</tr>
<tr>
<td><strong>[10]</strong> Audio Input Level</td>
<td>[10] Storage Place Submaster</td>
</tr>
<tr>
<td><strong>[12]</strong> Crossfader Automatic Fade</td>
<td>[12] Storage Place UP</td>
</tr>
<tr>
<td><strong>[13]</strong> Cue List Open/Close</td>
<td>[13] Speed Master Pause</td>
</tr>
<tr>
<td><strong>[14]</strong> Cue List Back</td>
<td>[14] Cue Storage Place</td>
</tr>
<tr>
<td><strong>[15]</strong> Cue List Stop</td>
<td>[15] Layer Mix Mode NEXT</td>
</tr>
<tr>
<td><strong>[16]</strong> Cue List Go</td>
<td>[16] Layer NEXT</td>
</tr>
<tr>
<td><strong>[17]</strong> Crossfader Fade Time</td>
<td>[17] Layer Submaster</td>
</tr>
<tr>
<td><strong>[18]</strong> Crossfader</td>
<td>[18] Layer Opacity</td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »[MIDI-IN Configuration](#)
7.2.37 USER User

- In order to learn how to assign MIDI freely and how to program your own MIDI map, please read the chapter »MIDI-IN Configuration Remote Editor

- You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration
### 7.2.38 Vestax VCI-100

**Mode: Layer / Storage**  
(*Storage Mode = light on*)

<table>
<thead>
<tr>
<th>Mode: Layer</th>
<th>Mode: Storage</th>
</tr>
</thead>
<tbody>
<tr>
<td>[25] + [42] Layer Submaster</td>
<td>[25] + [42] Storage Place Submaster</td>
</tr>
<tr>
<td>[26] + [42] Layer Opacity</td>
<td>[42] Frame ID</td>
</tr>
<tr>
<td>[42] Switch Layers</td>
<td>[48] + [42] Storage ID S1 – S256</td>
</tr>
<tr>
<td>[49] + [42] Layer UP/DOWN</td>
<td>[49] + [42] Storage Place P1 – P256</td>
</tr>
</tbody>
</table>

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>[1] Speed Master Deck A / Deck B</strong></td>
<td><strong>[19] Color Filter color WHITE</strong></td>
</tr>
<tr>
<td><strong>[5] Cue List Stop</strong></td>
<td><strong>[22] Crossfader Automatic Fade</strong></td>
</tr>
<tr>
<td><strong>[6] Cue List Back</strong></td>
<td><strong>[23] Main Output Freeze</strong></td>
</tr>
<tr>
<td><strong>[8] Cue List Go</strong></td>
<td><strong>[28] Crossfader Skip to Deck A / Deck B</strong></td>
</tr>
<tr>
<td><strong>[9] Cue List Go + Start</strong></td>
<td><strong>[29] Must be value &quot;mas.&quot;! If &quot;A&quot; or &quot;B&quot; is selected, select &quot;mas.&quot;., then</strong></td>
</tr>
<tr>
<td><strong>[47] Speed Master Pause (Hold)</strong></td>
<td><strong>[50] Fade Type Cross-fade</strong></td>
</tr>
<tr>
<td><strong>[51] Fade Type White-fade</strong></td>
<td><strong>[52] Fade Type Black-fade</strong></td>
</tr>
<tr>
<td><strong>[53] Fade Type Color-Fade</strong></td>
<td></td>
</tr>
</tbody>
</table>
disconnect and reconnect the VCI100.

<table>
<thead>
<tr>
<th>Function</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>[18] Color Filter color BLUE</td>
<td>[46] Speed Master Pause (Permanently)</td>
</tr>
</tbody>
</table>

You can get an overview over all preprogrammed MIDI maps in the chapter »MIDI-IN Configuration"
### 7.2.39 Vestax VCM-100

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
</table>

![Vestax VCM-100 Image]

*www.madrix.com*
You can get an overview over all preprogrammed MIDI maps in the chapter »[MIDI-IN Configuration]"
7.3 MA-Net

This topic includes:
- Introduction
- Step-By-Step Configuration
- Protocols [Overview]
- Important Notes
- Troubleshooting

Introduction

MA-Net from MA Lighting is a proprietary Ethernet network protocol. MADRIX supports it natively.

MADRIX supports:
- MA-Net 1
- MA-Net 2

Step-By-Step Configuration

1] Set up networking for your MA product.
2] Set up the correct network settings in Windows.
3] Enable drivers in MADRIX.
5] Set up remote control.

1] Setting Up MA Networking
- Make sure to connect your MA devices and the MADRIX computer in the same Ethernet network over network cabling [and possibly a network switch]!
  [For example, use the **Ethernet 1** port for products of the grandMA 2 series and the network card of the computer that runs the MADRIX software.]
- Consult the user manual of your MA product to set up the correct settings for MA-Net for your MA product.
- Start Networking for your MA product.
  [For example, go to **Setup > Network** to start or join a session for products of the grandMA 2 series.]

### 2] Windows Network Settings

MA-Net is a network-based protocol. MADRIX will use the network card of your computer to receive data.

- **It is required to set up the correct network settings in Windows, first.**
- **You must use the correct IP address and Subnet mask settings. Otherwise, MA-Net might not work!**
- **The IP addresses of your computer and your MA-Net devices need to be different.**

- Set up an individual **IP address** according to the IP address range of your MA product.
  - Make sure that the first, second, and third part of the IP address are the same. The fourth part must be different from your MA product.
  - A general recommendation is:  
    - **192.168.X.1 ... 192.168.X.254**
- Set up the corresponding **Subnet mask**
  - **255.0.0.0**

- **Restart MADRIX, if you have changed the network settings in Windows while MADRIX was running.**
- **Check the settings of the Windows Firewall.**
- Learn more »[Tips [Microsoft Windows / Networks / USB]](https://www.madrix.com)

- Example for PCs that are running MADRIX:
3] Enabling Drivers In MADRIX

- Go to the menu Preferences > Options... > Devices Network
  [Keyboard shortcut: Ctrl+Alt+O > Devices Network]
- Activate MA Lighting - MA-Net
Choose the correct network/network card from the drop-down list.
- Always make sure that you have selected the correct network. Otherwise, no data can be received.

- MA-Net 2 - Defines the protocol version.
  - Choose the correct MA-Net here [MA-Net 1 or MA-Net 2].
  - MA-Net 1 is used by the grandMA1 series.
  - MA-Net 2 is used by the grandMA2 series.

- Session ID - Defines the session you want to work in. Choose the session you have set up in your MA product also here.

- Universes (Start / End) - Defines the universe or universe you wish to receive.
  - The default Start Universe is 1 and the default End Universe is 1, which means that one DMX universe will be received.

4] Activating Devices
Go to the menu *Preferences > Device Manager... > DMX Devices*

[Keyboard shortcut: **F4**]

MADRIX automatically adds the number of MA-Net universes/devices according to your settings for **Start Universe** and **End Universe**

Your devices are automatically activated.

If it is no activated, select your devices in the list, activate **Enable**, and click **Apply**

**Input** is automatically activated.

Since MADRIX will receive data, the **Frame Time** and **FPS**[Frame Rate] are managed automatically by MADRIX.

[Please note when checking incoming data via the Task Watcher: A maximum frame rate of 30 Hz will be sent by your MA product over MA-Net.]

---

![Device Manager](image)

---

5] Setting Up Remote Control

Go to the menu *Preferences > Device Manager... > DMX Input*
• Select your preferred DMX Universe in the list.
  [By default, DMX universe 1 to 8 are listed. If you wish to increase the number of DMX-IN universes, you can change the setting. Learn more »Performance.]

• Select your DMX-IN Device in the section Device by choosing the MA Lighting MA-Net device.

• [If needed, you can disable DMX-IN by deselecting the device under DMX-IN Device and choose the list entry that is empty or disable the interface under Device Manager... > DMX Devices.]
- Make sure that your device is still selected in the list.
- Activate Remote
- Select one of the built-in protocols in the section Remote Control [as explained below] or create your own remote configuration. Learn more ➔ DMX-IN Remote Editor

**Open** - Loads a previously saved MADRIX DMX Remote Configuration file [of the file type *.mdrx].

**Protocols** - Choose from a pre-configured protocol [configuration].

Learn more Protocols [Overview]
**DMX-IN Remote Editor** - Allows you to modify a configuration or create a new configuration.
Learn more »[DMX-IN Remote Editor](#)

**Start Address** - Defines on which particular DMX channel the protocol should start. The whole protocol will be mapped to this new address area.

**DMX Watcher** - Opens the DMX Watcher to monitor your DMX output or input.
Learn more »[Tools](#)

*Mapping is not available for MA-Net and cannot be enabled.*

## Protocols [Overview]

There are preprogrammed DMX protocols you can choose from:

- »[DMX-IN (Essential Protocol)](#)
- »[DMX-IN (Standard Protocol)](#)
- »[DMX-IN (User)](#)

## Important Notes

- Always make sure to have a valid network card active! Otherwise, MADRIX cannot receive MA-Net [even when using MADRIX and MA on PC on the same computer].
Always make sure to have a valid license for your MA product to send out Ethernet data or use a console.

[MA on PC requires an MA 2Port Node or MA onPC command wing, for example.]

Please make sure to save your MADRIX Setup file after the configuration process.

**Troubleshooting**

If you are encountering problems, please work through the following checklist:

- Double-check the settings of your network card.
- Make sure to set up the Windows Firewall correctly. Learn more »[Tips [Microsoft Windows / Networks / USB]]
- Double-check the settings of the MA-Net devices in MADRIX.
- Double-check the configuration of your MA product.
- Check if your MA product has a valid license to send out Ethernet data.
- Use the DMX Watcher to monitor incoming data.
7.4 Time Code [Art-Net / MIDI / SMPTE / System Time]

This topic includes:

- Introduction
- Overview
- Time Code
- Cue List
- More Information

Introduction

Time Code is a useful way to integrate time synchronization across devices in order to synchronize the equipment with each other.

Small messages will be sent in regular intervals and every device thereby knows the overall time of the system.

MADRIX can receive

- MIDI Time Code [MTC]
- Art-Net Time Code
- SMPTE Time Code
- System Time

If such a time code is sent in the network, through MADRIX USB SMPTE or through other interfaces, they will be received by MADRIX if the feature is activated as explained below.

Overview

Time Code can be received as:

- 24 FPS
- 25 FPS
- 30 Drop [30/1.001 FPS]
- 30 FPS

**Time Code**

**MIDI Time Code [MTC]**

You need to activate your MIDI device in MADRIX and activate MTC reception.

- Go to the menu **Preferences > Remote Control > MIDI...**
  or **Preferences > Device Manager... > MIDI**
  [Keyboard shortcut: **F4 > MIDI**]
- A new window will open.

![](image)

- Click ✗
MADRIX will automatically search for connected devices.
Your MIDI device will be shown in the list.

- Select your device in the list.
- Activate **Enable**
  [Please note that the **State** in the list will change from **Off** to **On**.]
- Activate **MTC**
  [Please note that the **MTC** in the list will change from **Off** to **On**.]

---

**MADRIX 5.0c Help And Manual**

[Part G] INPUT And Remote Control

www.madrix.com //722
Software Sending MTC

- You might want to work with another software that sends MIDI Time Code.
- Often, that also means that you want to run MADRIX and the other software on one computer.
- Various 3rd-party programs are available to create virtual MIDI devices and use them to connect MADRIX and the other software.
- Configure MADRIX as explained above

Art-Net Time Code

- To send Art-Net Time Code, it is recommended to use the MADRIX Time Code Sender, separate tool that is automatically installed together with MADRIX.
  Learn more »MADRIX Time Code Sender
- To receive Art-Net Time Code, you need to activate Art-Net first.
  Learn more »Art-Net [DMX Over Ethernet]
MADRIX USB SMPTE

- The MADRIX USB SMPTE hardware interface allows you to receive SMPTE time code with MADRIX.
  Learn more »MADRIX I/O

System Time

- You can use the clock of your computer to generate Time Code.
  Learn more below

Cue List

You can use Time Code in the Cue List.

- Configure your Time Code sender first and set up MADRIX to receive Time Code as explained above

- Go to the menu Tools > Cue List...
- Press F7
- Or click Layer Control > Cue List... on the user interface

- Select the Time Code Source

![Time Code Source]

www.madrix.com
Select the **Time Code Format**

- MADRIX will automatically start receiving external Time Code.
- The Time Code format is *HH:MM:SS:FF* [hours:minutes:seconds:frames]
  
  **Example:**
  - 10 o'clock and 20 minutes, 30 seconds, and 10 frames will be shown as
  
  **10:20:30:10**

- Configure the column **Time Code** for your Cue List entries.
- Add or edit more entries according to your requirements.

**More Information**

Learn more »[Cue List](#)
7.5 CITP

This topic includes:
- Introduction
- Usage
- Network Settings
- Configuration Of MADRIX As Server
- Configuration Of MADRIX As Visualizer
- Configuration Of Other Devices

Introduction

CITP [abbr., Controller Interface Transport Protocol] is a communication protocol often used between media servers, lighting consoles, and visualizers.

The main reasons for using CITP are:

- SDMX
- Browsing
- Streaming media between devices
- To display preview images [Thumbnails]

Usage

Overview

MADRIX supports

- CITP version 1.0 with MSEX version 1.0 and MSEX version 1.1
  [Features of higher versions are not supported.]
As a media server, MADRIX is sending CITP data and making information available to other devices. For example, MADRIX will not show Thumbnails from other devices.

CITP is used between at least two devices [or possibly more].
If you want to use CITP, you need a second device [hardware or software] to actually see the result. You will usually not see the result in MADRIX, but mainly on the other device [e.g., a lighting console or visualizer].

Your second device needs to support CITP. Otherwise, the connection will not work. Moreover, not every product might support all of the features the CITP protocol has to offer. Please refer to the user manual of your other devices to learn more about the features available to you.

In MADRIX, you can use CITP

- to show preview images [Thumbnails]
- to stream media [Streaming]
- to use it as visualizer to show a stream from another CITP server [Stream Visualizer]

**Supported File Formats**

- Supported file formats for Thumbnails are: JPEG, RGB8
- Supported file formats for Streaming are: RGB8

**Thumbnails**

Showing Thumbnails is a useful feature, when you are using a lighting desk to control MADRIX remotely [for example via »Art-Net Remote]. You may not have direct access to the PC that runs the MADRIX software and thus would like to preview the effects and visuals that you preconfigured.
MADRIX generates Thumbnails for every Storage Place. On the graphical user interface of MADRIX, you have access to a total of 256 x 256 Storage Places. When you hover over a Storage Place with your mouse cursor, you will see the preview image (Thumbnail).

- You can use CITP to display those preview images (Thumbnails) directly on your lighting desk.
- Please make sure that MADRIX has created these Thumbnails. Thumbnails are created when leaving (or re-selecting) a Storage Place. If no preview image has been generated for a Storage Place, you will only see a black image for this Storage Place on your console when using CITP.
- **Important Note:** When using CITP 1.0 with MSEX version 1.0 or MSEX version 1.1, you will only be able to use up to 255 Storages and up to 255 Storage Places due to a restriction in the MSEX 1.0 and MSEX 1.1 specifications.

### Streaming

While Thumbnails provide a static preview of MADRIX Effects, you may use Streaming to directly preview the Main Output (Preview Output). MADRIX features three live Preview windows to show your effects. The Main Output (Preview Output) will show the visuals that are sent to your LEDs (Learn more »3 Previews).

You can use CITP to stream, i.e. show, the Main Output (Preview Output) directly on your lighting desk. It will not look like a static image, but like a fluent video. The maximum frame rate for Streaming via CITP in MADRIX is 10 FPS by default. If you want to capture Streaming with a higher frame rate, you can adjust this frame rate to the Main Mix FPS as described below. The default frame rate is sufficient for operators and usage in combination with consoles.

`Due to the supported file format [RGB8], a maximum of 21,823 pixels can be streamed.`

Not every product may support this feature.
**Visualizer**

In addition, you can use MADRIX as a visualizer to show the media stream of another CITP server. Instead of streaming the Main Output of MADRIX to another CITP device, MADRIX can receive a stream from another CITP server and show it in MADRIX using the SCE Capture effect.

**Network Settings**

- Devices that should communicate with each other via CITP, should be configured to be in the same network!
  
  Learn more »[Tips](Microsoft%20Windows%20/%20Networks%20/%20USB)

- The network protocol of CITP does not have any special restrictions.

**Configuration Of MADRIX As Server**

- Go to the menu **Preferences > Options... > Devices Network**
  
  [Keyboard shortcut: **Ctrl+Alt+0 > Devices Network**]
- Activate **Enable Server** in the section **Capture - CTP**
  [The checkbox will change from gray to green.]

- **Choose your network card** from the drop-down list. Make sure to select the correct network adapter that will be used for CTP!
  [The IP address and Subnet mask label should help you select the correct adapter. It is not necessary to change any of these networks settings.]

- No further steps are required to configure MADRIX as CTP server.

- **Use Main Mixer FPS** - Removes the 10 FPS limit for Streaming and couples the frame rate to the frame rate of the Main Mixer of MADRIX. The Main Mixing FPS is 50 FPS by default.
  Learn more »**Performance**

---

**Configuration Of MADRIX As Visualizer**
- Go to the menu **Preferences > Options... > Devices Network**
  [Keyboard shortcut: **Ctrl+Alt+0 > Devices Network**]

- Activate **Enable Visualizer (SCE Capture)** in the section **Capture - CITP**
  [The checkbox will change from gray to green.]

- **Choose your network card** from the drop-down list. Make sure to select the correct network adapter that will be used for CITP!
  [The IP address and Subnet mask label should help you select the correct adapter. It is not necessary to change any of these networks settings.]

- Click **OK** to close the window.

- Now, choose an empty Storage Place on the user interface of MADRIX and set it up as effect **SCE Capture**

- In **SCE Capture**, make sure to connect the CITP server via [Link]

---

**Configuration Of Other Devices**
• Once CITP is enabled in MADRIX, your lighting console [or any other second device] should be able to find MADRIX in the network.

• In order to enable CITP for the device that you want to connect to MADRIX, please consult the user manual of the other device.
7.6 Remote HTTP

This topic includes:
- Introduction
- Network Settings
- Web Server Configuration
- Testing The MADRIX Web Server
- Connecting To The MADRIX Web Server
- Creating Your Individual HTML Page
- Help File And Commands
- Where To Find
- Troubleshooting

Introduction

MADRIX can be controlled remotely using Remote HTTP and the integrated web server. Connect MADRIX to a TCP/IP network and you can control MADRIX remotely [from a remote location] using a device with internet or network access [such as computer, tablet, smartphone] via the HTTP Remote Control function.

Network Settings

- Devices, that should communicate with each other via HTTP, should be configured to be in the same network!
  - Learn more »Tips [Microsoft Windows / Networks / USB]
- When you wish to access the HTTP remote control via WiFi, make sure that both, the computer that runs the MADRIX software as well as the remote control device, are connected to the same WiFi network [by using a WiFi router, for example].
**Web Server Configuration**

- Go to the menu *Preferences > Remote Control > HTTP...*
  
  [Keyboard shortcut: *Ctrl+Alt+H*]
  
  - A new window will open.

- **Enable** - Activates the web server.
  
  - The web server is needed for remote control via HTTP.

- **Hostname** - Shows the name of the computer / the name of the host of the web server. [Usually, this will be your computer’s name.]
  
  - Call - Allows you to test the configuration. Learn more below

- **IP Addresses** - Shows the IP address of the web server.
  
  - Since the web server is started in MADRIX and MADRIX runs on your computer, your computer’s IP address will be shown.
  
  - When multiple networks are available on your computer, multiple IP addresses will be shown in the list. [Usually, only one network will be used for Remote HTTP.]
- **Network Port** - Defines the protocol port on which the web server will be running.
  - Always click **Apply** to confirm any changes.
  - **Note:** Other software [e.g., SKYPE or similar clients with the same principle] might block the port you have selected. To solve the problem, please use the alternative ports suggested below or close other software.

<table>
<thead>
<tr>
<th>Recommended Ports</th>
<th>Alternative Ports</th>
</tr>
</thead>
<tbody>
<tr>
<td>80</td>
<td>If you are encountering problems, please enter any port higher than 1024.</td>
</tr>
<tr>
<td>3128</td>
<td></td>
</tr>
<tr>
<td>8080</td>
<td></td>
</tr>
<tr>
<td>8081</td>
<td></td>
</tr>
</tbody>
</table>

- **Directory** - Defines the location of the HTML start pages.
  - These HTML pages will be provided by the web server and can be accessed as a website through connected remote control devices.
  - By default, select the folder `public_remote_html` in your MADRIX installation folder.
    [E.g., C:\Program Files\MADRIX5\public_remote_html]
  - If you have created individual HTML pages and have saved them in a different location, use the button ... to locate the directory where the files are saved.
  - Always click **Apply** to confirm any changes.
**Parsed File Types** - Allows you to define how file types will be processed by the web server.
- By default, file types with the following file extension will be parsed:
  - *.html
  - *.htm
  - *.js
  - *.svg
- Files that are not parsed will still be provided by the web server. But these files will not be analyzed for remote control commands.
- Files that are parsed will be processed and analyzed for remote control commands to be able to trigger MADRIX remotely via HTTP.
- Not parsing files can save performance and memory usage.

- Removes all file types from the list.
- Loads a previously saved File Extension List from an external file [of the file type *.mfelx or *.csv]. A new window opens for you to select the file on your harddisk.
- Loads a previously saved File Extension List from an external file [of the file type *.mfelx or *.csv] and adds it to the current list.
- Saves a File Extension List in an external file [of the file type *.mfelx or *.csv].
- Adds a new file type / file extension to the list.
- Removes currently selected items from the list.

- Always click **Apply** to confirm any changes.

**Defaults** - Restores the default settings.

**OK** - Applies any changes and closes the window.

**Apply** - Applies any changes without closing the window.

**Cancel** - Disregards any changes and closes the window.
Testing The MADRIX Web Server

1] First, make sure that you have configured the web server correctly as explained above!

2] Select one or more IP Addresses and click Call
- Your default web browser will open.
- MADRIX will open a new tab for each IP Address separately.

3] Choose the HTML interface:
- The web server will now access the Directory and the web browser will display the HTML files included in this directory.
- By default, the web browser will display the default overview as shown below.
- MADRIX already offers several interfaces that can be used with Remote HTTP. Choose from the provided interfaces [such as 4x4, 16x16, etc.]. Use the interface that is the best for your needs.
- When creating a custom HTML website instead of using the default configuration, MADRIX will now show your custom website.
- In this way, you can test and use the web server locally using the web browser on your computer.
Connecting To The MADRIX Web Server

- Make sure that devices, which should communicate with each other via HTTP, are connected in the same network!
- Connect to the web server using the remote control device.
  - Often, this will mean that you will use a web browser on the remote control device.
  - Open the web browser and type in the IP Address that shown in the web server configuration [Web Server Configuration].
  - Make sure to use the correct IP Address, since it is possible that multiple networks are available on the computer that runs the MADRIX software. Usually, only one network will be used for HTTP remote control.

Creating Your Individual HTML Page

MADRIX already provides a range of interfaces for HTTP remote control. These HTML examples do work and at the same time they are a demonstration to show what is possible.

You can modify or create your own HTML files to integrate them in your own setups. [An example is the integration with the DJ Software »ULTRAMIXER.]

- Create your own HTML websites using the full set of commands.
- Learn more Help File And Commands
- Learn from the provided interfaces and use these HTML sites as starting point or templates.
- Learn more Where To Find

Please note: You should name your individually created HTML start page 'index.html'.

Help File And Commands

A full range of commands is available for remote control. To create a custom layout and remote control interface, information about all available commands is needed. MADRIX provides this information in the following way:
1] Call the MADRIX web server as explained above.
   - [Testing The MADRIX Web Server](#)

2] Click on **MADRIX Remote Members**
   - A full list and documentation of remote commands [remote members] is shown.

---

## Where To Find

The original HTML files including all provided interfaces can be found in the MADRIX installation directory:

- C:\Program Files\MADRIX5\public_remote_html

---

## Troubleshooting

- If the internet browser is opening [and closing] with no visible result, please change the port.
- Make sure to use / type in the correct IP Address of the web server. When multiple IP addresses are shown, use the network that the devices are connected to [including web server and device accessing the web server].
- Note that other software [e.g., SKYPE or similar clients with the same principle] might block the port you have selected. To solve the problem, please use the alternative ports suggested above or close other software.
- Make sure that the Directory points to the right location on your harddisk or the medium where your HTML files are stored.
- Press Apply to confirm any changes you have made.
- When using **MADRIX Remote Members** and individual communication [via a 3rd-party HTTP sender] or custom layouts, please note that commands are case-sensitive! You need to pay attention to the use of capital or small letters. [That does not apply to any parameters you want to pass. They are used as strings and will be passed as written.]
- To connect to the MADRIX Remote HTTP functionality via a 3rd-party device, make sure that both are connected to the same TCP/IP network. Make also sure that no required port is blocked and that devices are able to find each other in the network.
- You can check the Logfile for errors [go to Tools > Logfile...].
7.7 GamePort

This topic includes:
- Introduction
- Overview
- Step-By-Step Configuration
- Monitoring Incoming DMX Data
- Example 1
- Example 2

Introduction

MADRIX supports the GamePort.
The GamePort is a device port to connect 3rd-party controllers [such as Joysticks or GamePads] to computers. It used to be a physical, serial connector [often found on sound cards]. Nowadays, it is mainly implemented in Microsoft Windows as software interface to connect such game controllers simply via USB.

Overview

- The GamePort supports up to 32 individual buttons and up to 6 axes.
- A maximum of 16 GamePorts can be used at the same time as per DirectX.
- Using buttons directly translates to DMX data in MADRIX [button off = DMX value 0; button on = DMX value 255].
- Using an axis directly translates to DMX data in MADRIX [axis center = DMX value 127; axis one direction = DMX value 0; axis opposite direction = DMX value 255].

Step-By-Step Configuration
1] Connect your controller.

2] Enable drivers in MADRIX.

3] Enable your device.

4] Set up DMX Input.

5] Choose how to use incoming data.

1] Connect Your Controller

- Connect your controller to the serial GamePort of your computer or to a free USB port.
- Make sure that Windows recognizes the device and install drivers if necessary.
- Calibrate your controller. This will ensure that all buttons and axes work properly. It is important to have calibrated and centered axes.

2] Enable Drivers In MADRIX

- Go to the menu Preferences > Options... > Devices USB
- Enable GamePort
- Click Apply and OK
3] Enable Your Device

- Go to the menu **Preferences > Device Manager... > DMX Devices**
- Click ![search icon](image) if your device is not shown in the list.
- Select your device in the list [usually shown as **Microsoft PC-Joystick driver**] and select **Enable** in the section **Settings**
- Click **Apply**
- Now, in the list the **State** will switch to **On**[indicated by green light].
4] Set Up DMX Input

- Go to the menu Preferences > Device Manager... > DMX Input
- Select one entry in the list [e.g., Universe 1] and go to the section Device. Choose your device [e.g., Microsoft PC-Joystick driver] under DMX-IN Device
- MADRIX will now receive DMX data via your controller.
5] Choose How To Use Incoming Data

Now you have several options to choose from:

A] You can activate Remote and choose a protocol in the section Remote Control. This will allow you to control MADRIX remotely using your controller. Learn more »DMX-IN / Art-Net Remote / sACN Input

B] You can use incoming data in a Script or Macro. Learn more »Macros And Scripts

C] You can activate Mapping and route incoming DMX signals through MADRIX to your output [DMX-Thru]. Learn more »DMX-IN / Art-Net Remote / sACN Input

D] You can monitor incoming DMX data in the DMX Watcher. Select your device in the list and click Learn more below.

Close the Device Manager with OK

Monitoring Incoming DMX Data

To effectively work with incoming DMX data from your controller, you can use the DMX Watcher to monitor incoming signals. Learn how to read the data in the tables below.

- Open the DMX Watcher as explained above or go to the menu Tools > DMX Watcher...
- Select Input
- Set up the correct Universe
  - This is the same number as you have chosen in the list under Preferences > Device Manager... > DMX Input [e.g., Universe 1].
Channels 1 to 32 will display incoming DMX data for up to 32 buttons of your controller [DMX value 0 = Off or 255 = On].

Channels 33 to 44 will display incoming data for up to 6 axes. Each axis is divided into two directions on two DMX channels. This shows the deviation of the axis towards the center position [e.g., channel 33: left to center and channel 34: center to right]. A DMX value of 0 shows that the axis is located at the center. A DMX value of 255 shows that the axis is fully moved in the one direction.

Channels 49 to 60 will display incoming data for up to 6 axes. Incoming DMX data is separated into two DMX channels, the main value and a decimal place. Because of this, both channels can be seen as one value. A value of 127.0 [e.g., Channel 49 and Channel 50] shows that the axis is located at the center. A DMX value of 0.0 shows that the axis is fully moved in one direction [e.g., left], while a DMX value of 255.255 shows that the axis is fully moved to the opposite direction [e.g., right].

The following chart shows which function is assigned to which DMX channel, starting with DMX channel 1.
### CH 17 - 32
<table>
<thead>
<tr>
<th>Button</th>
<th>Axis</th>
<th>Valid values are 0 or 255.</th>
</tr>
</thead>
<tbody>
<tr>
<td>17</td>
<td>1</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>18</td>
<td>2</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>19</td>
<td>3</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>20</td>
<td>4</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>21</td>
<td>5</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>22</td>
<td>6</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>23</td>
<td>7</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>24</td>
<td>8</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>25</td>
<td>9</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>26</td>
<td>10</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>27</td>
<td>11</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>28</td>
<td>12</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>29</td>
<td>13</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>30</td>
<td>14</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>31</td>
<td>15</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>32</td>
<td>16</td>
<td>Valid values are 0 or 255.</td>
</tr>
</tbody>
</table>

### CH 33 - 48
<table>
<thead>
<tr>
<th>Axis</th>
<th>Direction 1</th>
<th>Valid values are 0 or 255.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Direction 2</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>2</td>
<td>Direction 3</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>3</td>
<td>Direction 4</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>4</td>
<td>Direction 5</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>5</td>
<td>Direction 6</td>
<td>Valid values are 0 or 255.</td>
</tr>
<tr>
<td>6</td>
<td>Direction 7</td>
<td>Valid values are 0 or 255.</td>
</tr>
</tbody>
</table>

- The further away from the center, the higher will be the DMX value.
- Valid values range from 0 to 255.

### CH 49 - 64
<table>
<thead>
<tr>
<th>Axis</th>
<th>Axis</th>
<th>Axis</th>
<th>Axis</th>
<th>Axis</th>
<th>Axis</th>
<th>Axis</th>
<th>Axis</th>
<th>Axis</th>
<th>Axis</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>2</td>
<td>2</td>
<td>3</td>
<td>3</td>
<td>4</td>
<td>4</td>
<td>5</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>2</td>
<td>3</td>
<td>3</td>
<td>4</td>
<td>4</td>
<td>5</td>
<td>5</td>
<td>6</td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>3</td>
<td>4</td>
<td>4</td>
<td>5</td>
<td>5</td>
<td>6</td>
<td>6</td>
<td>6</td>
</tr>
</tbody>
</table>

- Valid values range from 0 to 255.
Channels 33 to 44 divide each axis into two DMX channels.

Channels 49, 51, 53, 55, 57, 59 will show the main value of an axis and thus represent each axis as one value.

Regarding axes, some joysticks may only use the decimal place due to technical reasons. Then, the main value might not be useful to you and you should use channel 50, 52, 54, 56, 58, and 60 instead.

If you are using more than 1 controller, channel 65 to 124 will be used for the second controller, etc.

**Example 1**
- Buttons 1 to 6 are not pressed [0].
- Button 7 is pressed [255].
- Buttons 8 to 32 are not pressed [0].
- Axis 1 is fully moved to one direction [255 / 0].
- Axis 2 is fully moved to one direction [255 / 0].
- Axis 3 is fully moved to the opposite direction [0 / 255].
- Axis 4 is fully moved to the opposite direction [0 / 255].
- Axis 5 is fully moved to the opposite direction [0 / 255].
- Axis 6 is fully moved to one direction [255 / 0].
- Axis 1 is fully moved to one direction [0.0].
- Axis 2 is fully moved to one direction [0.0].
- Axis 3 is fully moved to the opposite direction [255.255].
- Axis 4 is fully moved to the opposite direction [255.255].
- Axis 5 is fully moved to the opposite direction [255.255].
- Axis 6 is fully moved to one direction [0.0].

**Example 2**

When monitoring an axis, there are 4 main modes that can be seen:

<table>
<thead>
<tr>
<th>Fully moved in one direction [e.g., left]</th>
<th>Fully moved in the opposite direction [e.g., right]</th>
<th>Centered</th>
<th>Not available</th>
</tr>
</thead>
<tbody>
<tr>
<td>Channel 33 255 Channel 34 0 Channel 33 0 Channel 34 255</td>
<td>Channel 33 0 Channel 34 0</td>
<td>Channel 33 0 Channel 34 0</td>
<td>Channel 33 0 Channel 34 0</td>
</tr>
<tr>
<td>Channel 49 0 Channel 50 0 Channel 49 255 Channel 50 255</td>
<td>Channel 49 127 Channel 50 0</td>
<td>Channel 49 0 Channel 50 0</td>
<td>Channel 49 0 Channel 50 0</td>
</tr>
</tbody>
</table>
//PART H
MADRIX Effects
8 MADRIX Effects

This topic includes:
- Introduction
- Topics Of This Chapter

Introduction

MADRIX offers a large variety of effects. All MADRIX Effects are arranged into 5 distinct categories with various features: [SCE, S2L, M2L, TRI, MAS].

Topics Of This Chapter

- [SCE] Static Color Effects
  Static Color Effects produce a multitude of creative lighting patterns and visuals. No extra input or content is necessary. In addition, they provide the tools to load images or video files.

- [S2L] Sound2Light Effects
  Sound2Light Effects require an audio input signal. As a result, amazing light effects that are synchronized to the music will be generated!

- [M2L] Music2Light Effects
  Music2Light Effects require an audio input signal. M2L Effects go one step further than S2L Effects and analyse music theoretical parameters to create truly unique representations of the music.

- [TRI] Trigger Effects
  TRI Effects are based on existing MADRIX Effects. On top, you can trigger them manually using DMX-IN or MIDI. This adds a whole new level of interaction.

- [MAS] MADRIX Script Effect
  The powerful Script Editor, which is included in the software, allows you to program your own effects. The script language allows you to easily realize ideas for effects of your own.
• Macros And Scripts
  You can control and manipulate running effects using the script language.

• Using BPM Control
  Many MADRIX Effects use the BPM Effect Setting to control the speed.

• Using Colors And Intensity
  Learn how to use the different color options of the MADRIX Effects.

• Using Directions
  Many MADRIX Effects allow you to choose a specific movement direction.
8.1 [SCE] Static Color Effects

This topic includes:
- Introduction
- Topics Of This Chapter

Introduction

Static Color Effects [SCE] produce a multitude of creative lighting patterns and visuals. No extra input or content is necessary.

In addition, they provide the tools to load images or video files.

Topics Of This Chapter

MADRIX includes the following Static Color Effects:

- SCE Bounce
- SCE Capture
- SCE Clouds
- SCE Color
- SCE Color Change
- SCE Color Scroll
- SCE Counter
- SCE Drops
- SCE Explosions
- SCE Fill Drops
- SCE Fill Random
- SCE Fill Snake
- SCE Fill Solid
- SCE Fire
- SCE Flames
- SCE Fluid
- SCE Gradient
- SCE Graph
- SCE Image
- SCE Level Color Simulator
- SCE Metaballs
- SCE Noise
- SCE Plasma
- SCE Pulse / Stroboscope
- SCE Rotating Shapes
- SCE Screen Capture
- SCE Shapes
- SCE Simple Shape
- SCE Starfield
- SCE Swarm
- SCE Ticker / Scrolling Text
- SCE Tubes
- SCE Video
- SCE Wave / Radial
8.1.1 SCE Bounce

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Bounce displays flying objects that bounce off of the outer boundaries or each other.

Overview

Default Settings

Customized Example
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- Colors - Opens the Color Table to specify the colors. The default colors are Red, Yellow, Green, Cyan, Blue, Magenta.
  Learn more »Using Colors And Intensity
- BPM - Defines the speed. The default value is 1500. Valid values range from 0 to 9999.
  Learn more »Using BPM Control
- Count - Defines the number of bouncing objects. The default value is 1. Valid values range from 1 to 100.
- Points - Defines the number of edges [points] an object is made of. The default value is 3. Valid values range from 1 to 20.
- Width - Defines the width of objects [in %]. It is only available for certain Shapes. The default value is 10. Valid values range from 0.01 to 100.
- Height - Defines the width of objects [in %]. It is only available for certain Shapes. The default value is 10. Valid values range from 0.01 to 100.
- Depth - Defines the depth of objects [in %]. This is mainly relevant for 3D. It is only available for certain Shapes. The default value is 10. Valid values range from 0.01 to 100.
- Border - Is only available for 2D outlined shapes or 3D unfilled shapes. Defines how thick the outer line [border] of objects is. The default value is 1. Valid values range from 0.01 to 100.
- Fade Out - Adds a visual tail to objects and fades them out slowly. The default value is 0. Valid values range from 0 to 1000.
**Distribution** - Allows you to choose a certain Distribution Mode for the specific parameter. Often, you can then define a minimum value and a maximum value.

- **Uniform** - Each object has the same size.
- **Linear** - A linear distribution is used to increase the size regularly.
- **Quadratic** - The majority of objects will be smaller than the rest.
- **SQRT** - Using a square root function the majority of objects will be larger.
- **Cubic** - Uses a cubic distribution with mixed sizes.
- **Random** - Sizes will be generated randomly.

**RND** - Generates random object sizes each time. This automatically activates Random Distribution Mode.

**Outer Glow / Inner Glow** - Is only available for specific Shapes. Defines the outer shimmer or inner gleam of objects. The default values are 0.00. Valid values range from 0.01 to 100.

**Shape** - Allows you to choose a specific shape as bouncing objects. The default Shape is Line.

**Shape Alignment** - Allows you to choose to which side objects are aligned to. This is mainly relevant for 3D. The default Shape Alignment is Front.

**Shape Rotation Type** - Is only available for specific Shapes. Defines the angle in which objects are rotated [0°, 90°, 180°, 270°, Random].

**Collision** - Is not available for Shape Line or Curve. Activates or deactivates if objects collide and bounce off of each other. The default mode is Off.

**Restoring The Default Settings**
**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.2 SCE Capture

This topic includes:

- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings
- Slices

**Introduction**

SCE Capture allows you to use any video signal of capture devices in MADRIX for live video feeds, such as installed webcams or TV-cards. Such devices need to provide the required Windows driver.

- Several capture devices can be used at the same time. For every single Layer a different capture device or the same capture device can be utilized.
- If your device offers the correct drivers and is recognized in Windows as a capture device, MADRIX will also have access to the device.

**Overview**
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  
  Learn more »Effect Areas [Deck A / Deck B]
  
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Filter** - Defines a filter color. The default color is White.
  - **GS** - Activates grayscale mode to show the input only in gray shades. The Filter is independent of this mode.
  - **RGBW** - Converts the input into RGBW. This is useful when using RGBW fixtures to convert from the standard RGB color values of the input. If the option is disabled when using RGBW fixtures, the input will appear darker since the White channel is not used. The W color channel of the Filter only works if RGBW is activated.

Learn more »Using Colors And Intensity
- **BPM** - Defines the speed [when using a direction/movement]. The default value is 1500. Valid values range from 0 to 9999.
  
  Learn more » [Using BPM Control](#)

- **Position** - Defines the position of the object in \(X, Y,\) and \(Z\) [in %]. The default values are 0, 0, 0. Valid values range from -1000 to 1000.

- **Extrusion** - Adds depth to the input; i.e. duplicates the input image [in % of the Matrix Size]. This is mainly relevant for 3D. The default value is 100. Valid values range from 0.01 to 100.

---

**Open** - Allows you to connect a capture device. A new window opens for you to select your device. First, select the device. Second, click OK.

**Deinterlace Mode** - Allows you to choose from several Deinterlace Modes. [Is available when a capture device has been opened and connected.]

Often digital cameras, digital broadcasting, or digital filming is done via interlacing. In order to get 25 frames per seconds, 50 pictures are shot and merged/mixed with one another. You receive 25 odd frames [frame set 1] and 25 even frames [frame set 2] that contain different picture information [alternating pixel lines]. In order to get an undisturbed picture, proper deinterlacing is necessary.

- **None** - Deactivates deinterlacing.

- **Bob** - Uses one set of 25 frames [even or odd] and copies missing information from the pictures provided. Pixel lines are copied to create a full image. Activate **Top Field First** in order to choose odd frames to be processed.

- **Bob Linear** - This is the recommended deinterlace mode. It uses one set of 25 frames, but builds an average for the missing pixel lines. Activate **Top Field First** in order to choose odd frames to be processed.

- **Blend** - Renders an average image from frame set 1 and frame set 2.

- **Discard** - Simply dismisses missing information. Thereby, pixel lines are excluded. This results in half of the original resolution for the final image. Activate **Top Field First** in order to choose odd frames to be processed.

---

**Slices** - Is a way to bring 2D content to 3D LED matrices by slicing the content into different parts and applying each slice to X-levels, Y-levels, or Z-levels as required. Learn more [Slices](#)
**Configuration** - Allows you to configure the connected device further if such configuration is provided by the device and its driver. [Is available when a capture device has been opened and connected.]

**Filtering** - Defines how input is processed and displayed. Mainly affects the visual outcome when the input is scaled up or down [e.g., when choosing a different mode for Stretching / Aspect Ratio]. Choose from 2 different modes. The default setting is None.
- **None** - Prioritizes processing speed over image quality.
- **Linear** - Prioritizes image quality over processing speed. This mode may affect performance.

**Direction** - Allows you to choose the direction. This includes all directions for 2D and 3D mode. The default value is None.

**Look-At Type** - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more »Using Directions

**Rotation** - Allows you to rotate the input [0°, 90°, 180°, 270°]. The default value is 0.

**Tile** - Allows you to tile and duplicate the input and thereby generating patterns.

**Seamless** - Activates or deactivates a continuous stream of the input image. MADRIX will automatically display the input image again to create a continuous display.

**Stretching / Aspect Ratio** - Allows you to choose the aspect ratio of the input. The default value is Matrix.

- **None** - Disables stretching.
- **Matrix** - Stretches to the current aspect ratio of the virtual LED matrix.
- **Original** - Stretches to the original aspect ratio of the source.
- **4:3** - Applies a 4:3 aspect ratio.
- **16:9** - Applies a 16:9 aspect ratio.
Restoring The Default Settings

*Restore Default Layer Settings* - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].

Slices

*SL* - Calls up *Slice Settings*

- *Slice Settings* - Is a way to bring 2D content to 3D LED matrices by slicing the content into different parts and applying each slice to X-levels, Y-levels, or Z-levels as required. [You will get the most benefit out of this feature when using content that are made up of different parts and are especially created for this area of application.]

**Example:** Your virtual LED matrix is 10 x 8 x 4. Now, you have prepared a video feed and want to display it not only on the first Z-level or use Extrude, but on all 4 Z-levels. Then, you would let MADRIX create 4 slices.
- **Slice Type** - Defines the 3D orientation of how slices are applied to your LED matrix.
  - **X-Slices** - Uses slices to fill the LED matrix; always starting from left to right.
  - **Y-Slices** - Uses slices to fill the LED matrix; always starting from top to bottom.
  - **Z-Slices** - Uses slices to fill the LED matrix; always starting from front to back.

- **Slice Order** - Defines how your source content is processed.
  - **Left To Right** - MADRIX slices the content starting left.
    [The first, left slice will then be applied to the left for X-Slices, to the top for Y-Slices, and to the front for Z-Slices.]
  - **Right To Left** - MADRIX slices the content starting right.
    [The first, right slice will then be applied to the left for X-Slices, to the top for Y-Slices, and to the front for Z-Slices.]
  - **Top To Bottom** - MADRIX slices the content starting top.
    [The first, top slice will then be applied to the left for X-Slices, to the top for Y-Slices, and to the front for Z-Slices.]
  - **Bottom To Top** - MADRIX slices the content starting bottom.
    [The first, bottom slice will then be applied to the left for X-Slices, to the top for Y-Slices, and to the front for Z-Slices.]

- **Slice Count** - Defines in how many slices the content is divided. A value of 1 means that no slices are created and that the video feed is used as one. [A value of 4, for example, will create 4 slices that each make up 25% of the source content.]

- The settings with the highest performance are **Z-Slices** and **Top To Bottom**

- Confirm with **OK**, reset to default settings via **Default**, or abort the process using **Cancel**

- Learn more » **SCE Image**
8.1.3 SCE Clouds

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Clouds creates random, organic visuals that are reminiscent of clouds.

Overview

![Default Settings](image)

![Customized Example](image)
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.

  Learn more » Effect Areas [Deck A / Deck B]

  Learn more » Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Gradient to specify the colors. The default color is White, Black.
  
  Learn more » Using Colors And Intensity

- **BPM** - Defines the speed [when using a direction/movement]. The default value is 1500. Valid values range from 0 to 9999.
  
  Learn more » Using BPM Control

- **Frequency** - Defines the rate at which new, organic visuals are created [in Hz]. The default value is 10. Valid values range from 0 to 50.

- **Stretch** - Defines the stretch or compression factor at which the visuals are displayed [X, Y, Z]. The default values are 1, 1, 1. Valid values range from 0.01 to 1000.

- **Contrast** - Defines the visual differentiation of colors and shapes [in %]. The default value is 50. Valid values range from 1 to 1000.

- **Detail** - Defines the sharpness [in %]. The higher the Detail, the more computer performance is required. The default value is 2. Valid values range from 1 to 10.

- **Distinction** - Defines the cohesiveness of the effect [in %]. The default value is 50. Valid values range from 1 to 100.

**Generate** - Creates the effect anew to produce different visuals. [This is mainly useful when setting a Frequency of 0.]
**Direction** - Allows you to choose the direction. This includes all directions for 2D and 3D mode. The default value is None. Learn more »[Using Directions]

![Direction Options]

**Display Mode** - Allows you to choose how the effect mainly looks [Low Contrast, Medium Contrast, High Contrast, Outline, Cluster]. The default mode is Low Contrast.

![Display Mode Options]

**Restoring The Default Settings**

**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].

![Default Restored Icon]
8.1.4 SCE Color

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Color displays a simple, plain color.

Overview

![SCE Color interface](image)
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more » Effect Areas [Deck A / Deck B]
  Learn more » Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Color** - Defines the color. The default color is Black.
  Learn more » Using Colors And Intensity

Restoring The Default Settings

*Restore Default Layer Settings* - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.5 SCE Color Change

This topic includes:

- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Color Change automatically changes colors.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.

  Learn more »[Effect Areas [Deck A / Deck B]]

  Learn more »[Layers]

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default colors are Red, Yellow, Green, Cyan, Blue, Magenta.

  Learn more »[Using Colors And Intensity]

- **BPM** - Defines the speed. You can either use BPM or Time. The default value is 60. Valid values range from 0 to 9999.

  Learn more »[Using BPM Control]

- **Time** - Defines the time interval a color is displayed [in s]. You can either use BPM or Time Slot. The default value is 1. Valid values range from 0.01 to 9999.

Restoring The Default Settings

**Restore Default Layer Settings** - Restores the default settings of the Layer.

- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.6 SCE Color Scroll

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Color Scroll displays various, moving colors. This MADRIX Effect is extremely versatile.

Overview

![SCE Color Scroll Interface]

Default Settings

Customized Example
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.

Learn more » Effect Areas [Deck A / Deck B]
Learn more » Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default colors are Red, Yellow, Green, Cyan, Blue, Magenta.
  Learn more » Using Colors And Intensity

- **BPM** - Defines the speed. The default value is 600. Valid values range from 0 to 9999.
  Learn more » Using BPM Control

- **Step Width** - Defines the number of pixels the effect should scroll/skip in the direction per frame [in % of the Matrix Size]. The default value is 0.01. Valid values range from 0.01 to 100.

- **Color Width** - Defines the width of a single color [in % of the Matrix Size]. The default value is 10. Valid values range from 0.01 to 100.

- **Cross Width** - Is only available for Cross Mode [»Using Directions]. Defines the size of crossing colors [in %]. The default value is 50. Valid values range from 0.01 to 100.

- **Displacement** - Defines the amount of distortion. The default value is 0. Valid values range from 0 to 100.

**Cross Mode Axes** - Is only available for Cross Mode. Allows you to choose to which axis Cross Mode applies [Axes 1 And 2, Axis 1, or Axis 2]. The default mode is Axes 1 And 2.
Displacement Speed - Is only available for Displacement. Allows you to choose to speed in which the distortion affects the visuals. The default value is 10.0.

Displacement Distribution - Is only available for Displacement. Is applied in dependence of the direction that is chosen. Allows you to choose the area the distortion is applied to [Uniform, Linear Increasing, Linear Decreasing, Triangle]. The default value is Uniform.

Direction/Mode - Allows you to choose the direction of the movement, including Cross Mode. This includes all directions for 2D and 3D mode. This heavily influences the visual outcome of the effect. The default Direction is Right. Learn more »Using Directions

Look-At Type - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more »Using Directions

Restoring The Default Settings

Restore Default Layer Settings - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.7 SCE Counter

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings
- String Table
- Important Details

Introduction

SCE Counter shows any characters/text in sequence [strings]. One of its main uses is the countdown.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default color is White.
  Learn more »Using Colors And Intensity

- **BPM** - Defines the speed, i.e. how long strings are displayed. The default value is 60. Valid values range from 0 to 600. [60 BPM represent 1 second, while 600 BPM represent a tenth of a second.]
  Learn more »Using BPM Control

- **Position** - Defines the position of the strings in $X$, $Y$, and $Z$ [in %]. The default values are 50, 50, 50. Valid values range from 0 to 100. [Make sure to set up Vertical Alignment and Horizontal Alignment as well.]

- **Scale** - Defines a scale factor that determines if strings are scaled in $X$, $Y$, and $Z$. In this way, you can add an animation to characters of the String Table and upscale or downscale the individuals elements. Scaling mainly references the font size set up via Aa [Font]. It also influenced references how long characters are displayed as set up via BPM and for the animation the Interpolation and the two Interpolation Types. The default values are 1, 1, 1. Valid values range from 0.01 to 9999. [Values lower than 1 decrease the size, while values higher than 1 increase the size. If you change the value for Scale Z to a value higher than 1, make sure to reduce the Extrude value as well.]

- **Extrusion** - Adds depth to the characters [in % of the Matrix Size]. This is mainly relevant for 3D. The default value is 100. Valid values range from 0.01 to 100.

- **Pitch** - Defines the distance between elements of the String Table. The smaller the Pitch, the more elements will be displayed at the same time. Pitch affects how long elements are displayed within the time set up via BPM. The default value is 100. Valid values range from 0.01 to 999.
- **Fade** - Defines if a Fade In and Fade Out is added to the characters. Fade references how long characters are displayed as set up via BPM. The bottom fader defines how long the Fade In takes. The upper fader defines how long the Fade Out takes. The default values are 0, 100. Valid values range from 0 to 100.

[A Fade of 0, 100 means that no Fade In and no Fade Out is added and elements are fully visible at 100% of the set up time. A Fade of 50, 50 means that the Fade In takes 50% of the set up time and that the Fade Out also takes 50% of the set up time. A Fade of 0, 50 means that elements are immediately visible, stay visible for 50% of the set up time and fade out 50% of the set up time. A Fade of 50, 100 means that elements are faded in and it takes 50% of the set up time and they stay fully visible for the rest of the time.]

- **Interpolation** - Affects Scale and the movement set up via Direction. In this way, it determines how these animations looks like. It basically divides the animations into three parts. The bottom fader defines the first phase, which is the start phase. The second phase is the phase inbetween the bottom and the upper fader. The upper fader defines the third phase, which is the end phase. Interpolation references how long characters are displayed as set up via BPM. It is also directly affected by Interpolation Type 1 for the start phase and Interpolation Type 2 for the end phase. The default values are 25, 75. Valid values range from 0 to 100.

[An Interpolation of 25, 75 means that the start phase and the end phase take 25% of the set up time, while 50% of the time no animation is displayed. An Interpolation of 50, 50 means that the animation start phase is directly followed by the animation end phase. An Interpolation of 0, 50 means that there is no animation at first and that the animation end phase starts at 50% of the set up time. An Interpolation of 0, 100 means that there is no animation displayed at all.]

**Open String Table** - Opens the String Table, a window that includes all characters [i.e., letters, words, symbols, numbers, etc.] you wish to display. Learn more **String Table**

**Loop Mode** - All strings of the String Table will be looped, that means the content of the String Table will constantly be repeated. It is activated by default. Can be used together with Shuffle Mode.

**Shuffle Mode** - Creates an internal list that orders elements randomly to show next. Deactivate and activate again to create a new random list. Can be used together with Loop Mode.

**Autostart** - If activated, the effect will automatically start when the corresponding Storage Place is selected. It is activated by default.

**Start** - Force-starts the effect to start again from the beginning.
Horizontal Alignment - Defines the horizontal alignment of characters [Left, Center, Right] in relation to the Position. The default value is Center.

Vertical Alignment - Defines the vertical alignment of characters [Top, Center, Bottom] in relation to the Position. The default value is Center.

Font - Opens a new window and allows you to choose a specific font, font size, and other font settings. [Any color set up in this window will be ignored. Use the MADRIX color controls instead.]

Interpolation Type 1 / Interpolation Type 2 - Determine how the animation of Scale and the movement via Direction look like [Linear, Ease In Bounce, Ease Out Bounce, Ease In Out Bounce, Ease In Circular, Ease Out Circular, Ease In Out Circular, Ease In Cubic, Ease Out Cubic, Ease In Out Cubic, Ease In Sinusoidal, Ease Out Sinusoidal, Ease In Out Sinusoidal, Ease In Exponential, Ease Out Exponential, Ease In Out Exponential]. You can set them up individually. The default value is Linear.

Last Element Mode - Is only available when Loop Mode of the String Table is disabled. Defines what happens to the last element of the String Table once it has been displayed. The default value is Move.

- **Move** - Moves the last element in the same way the previous elements have been displayed and moved.
- **Stay** - Leaves the last element on display.
- **Clear** - Makes the last element disappear without an animation.
Direction - Allows you to choose the direction. This includes all directions for 2D and 3D mode. The default value is None. Learn more »Using Directions

Look-At Type - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more »Using Directions

Rotation - Allows you to rotate the elements \([0^\circ, 90^\circ, 180^\circ, 270^\circ]\). The default value is 0.

Filtering - Defines how input is processed and displayed. Mainly affects the visual outcome when the input is scaled up or down [e.g., when choosing a different mode for Stretching / Aspect Ratio]. Choose from 2 different modes. The default setting is None.
- None - Prioritizes processing speed over image quality.
- Linear - Prioritizes image quality over processing speed. This mode may affect performance.

Restoring The Default Settings

Restore Default Layer Settings - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].

String Table
Overview

SCE Counter allows you to show any characters/text you want. Use the String Table to manage all elements that should be displayed.

By default, the String Table includes the elements from 10 to 0 [as a countdown].

- **Left Mouse Click** - Selects an item in the list.
- **Ctrl + Left Mouse Click** - Allows you to select several elements in the String Table at different positions.
- **Shift + Left Mouse Click** - Allows you to select several elements by selecting 1] the first element, 2] the last element, 3] and all elements in-between will be selected automatically.

**Element** - Allows you to change an element or enter a new one. To change an element, select it first. To add a new element, use Add Element first.

**Split Into Characters** - Is an automatism that helps you to split the element you have just added or changed into separate elements. Select an element in the list first and it will be split into several list entries [incl. word spaces], each with a single character instead of the complete word.
**Split Into Words** - Is an automatism that helps you to split the element you have just added or changed into separate words. Select an element in the list first and it will be split into several list entries, each with a single word instead of the complete sentence. Word spaces will be ignored, except if you enter two word spaces in a row.

**New** - Removes all elements from the list.

**Open** - Loads a previously saved MADRIX String Table from an external file [of the file type *.mstrtx].

**Open And Attach** - Loads a previously saved MADRIX String Table from an external file [of the file type *.mstrtx] and adds the new elements to the elements that are already included.

**Save** - Saves the String Table to an external file [of the file type *.mstrtx].

**Add Element** - Allows you to add a new element to the String Table. Make sure to enter the correct characters for the element next.

**Remove Element** - Allows you to remove one or several images from the Image Table. First, select the images in the list.

**Duplicate Images** - Copies the currently selected elements and adds them as new items to the String Table.

**# 11**

- Shows the total number of elements in the String Table. An empty list shows # 0
**Swap Position** - Swaps the position of elements in the list when several elements are selected first.

**Position Up** - Changes the order, and positions currently selected elements one step higher up in the list.

**Position Down** - Changes the order, and positions currently selected elements one step lower down in the list.

**Defaults** - Restores the default elements of the String Table.

**Close** - Closes the String Table window.

**Context Menu**

- **Right Mouse Click** - You can call up the context menu by performing a right mouse click on *Strings*.

  - A small window will be shown.

  ![Strings Menu](image)

You can quickly perform the following actions:

- **Edit...** - Opens the String Table [in the same way you can open the window by clicking on *Strings* with the left mouse button].
- **Open**... - Loads a previously saved String Table from an external file [of the file type *.mstrtx].  
  A new window opens for you to select the file on your harddisk.

- **Copy** - Copies the current elements into the clipboard as a duplicate.
- **Paste** - Applies all elements from the clipboard to the currently focused String Table [Strings].

- **Defaults** - Restores all default elements of the String Table.

### Important Details

#### Typefaces

Typefaces can be grouped into two main categories:

- Serif [Such fonts contain small features at the end of strokes within letters]
- Sans-serif [Such fonts have a clearer, simple appearance]

![Serif Font](AaBbCc) ![Sans-Serif Font](AaBbCc)

#### How To Use Other Languages [Such As Russian Or Chinese]

- In Windows 7, go to **Start > Control Panel > Region and Language > Keyboards and Languages**
- In Windows 10, go to **Start > Windows System > Control Panel > Language**
- Set up the language you want to use [Russian, Chinese, etc.].
  - Regarding Windows 7, only when using Windows 7 Ultimate you are allowed to install additional languages in addition to the standard language.
In MADRIX, select **SCE Counter**

- Click **Aa** to open the Font window.
- Choose a universal, extensive font, such as **Arial**
- Choose **Cyrillic** [or Chinese, etc.] under **Script**
- Close the Font window.
- Input any elements into the **String Table**
8.1.8 SCE Drops

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Drops displays [falling] drops.

Overview

![Default Settings](image1.png)

![Customized Example](image2.png)
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default color is White.
  Learn more »Using Colors And Intensity
- **Shapes** - Opens the Shape Table to specify the shapes. The default color is Rectangle Filled.
  Learn more »Using Shapes [Shape Table]
- **BPM** - Defines the speed. The default value is 1500. Valid values range from 0 to 9999.
  Learn more »Using BPM Control
- **Size** - Defines the size of objects [Width, Height, Depth]. The default values are 1, 1, 1. Valid values range from 0.1 to 1000.
- **Length** - Defines how long the trace of a drop is [in % of the Matrix Size]. The default value is 10. Valid values range from 0 to 100.
- **Rotation** - Defines the rotation of objects in \(X\), \(Y\), and \(Z\) [in °]. The default values are 0, 0, 0. Valid values range from -180 to 180.
- **Displacement** - Defines the amount of movement distortion. The default value is 0. Valid values range from 0 to 100.
- **Alpha Mix** - Defines the upper limit of how much alpha is added to each drop [in %]. Alpha Mix will be visible when using additional Layers. The default value is 100. Valid values range from 0 to 100.
- **Count** - Defines the number of objects displayed at once. The default value is 10. Valid values range from 1 to 100.
Pitch 1 - Defines the first distance between objects depending on the direction [in % of the Matrix Size]. The default value is 0. Valid values range from 0 to 100.

Pitch 2 - Defines the second distance between objects depending on the direction [in % of the Matrix Size]. The default value is 0. Valid values range from 0 to 100.

Distribution - Allows you to choose a certain Distribution Mode for the specific parameter. Often, you can then define a minimum value and a maximum value.

Uniform - Each object has the same size.
Random - Sizes will be generated randomly.

RND - Generates random object sizes each time. This automatically activates Random Distribution Mode.

Length Offset - Defines if an offset is added to the trace of a drop [in % of the Matrix Size]. The default value is 0. Valid values range from 0 to 100.

Continuous Rotation - Animates the shapes and rotates them around the corresponding axis permanently.

Rotation Origin Type - Defines the point of origin of the applied rotation.

Rotation Offset - Defines if an offset is added to the rotation of a drop [in % of the Matrix Size]. The default value is 0. Valid values range from 0 to 100.

Displacement Speed - Is only available for Displacement. Allows you to choose to speed in which the distortion affects the visuals. The default value is 10.0.

Displacement Distribution - Is only available for Displacement. Is applied in dependence of the direction that is chosen. Allows you to choose the area the distortion is applied to [Uniform, Linear Increasing, Linear Decreasing, Triangle]. The default value is Uniform.
**Invert** - Inverts the position of objects.

**Mirror** - Mirrors objects by creating duplicates on the opposite position.

**Direction** - Allows you to choose the direction of the movement. The default Direction is Down. Learn more »[Using Directions](#)

**Direction** - Allows you to choose the direction of the movement [To The Front or To The Back]. This is mainly relevant for 3D. The default Direction is Down. Learn more »[Using Directions](#)

**Rendering Mode** - Defines how objects are rendered. Each mode may enable additional settings [such as additional Shapes]. Choose from 2 different modes. The default setting is Simple.
- **Simple** - Prioritizes processing speed over rendering possibilities.
- **Extended** - Prioritizes rendering possibilities over over processing speed. This mode may require more performance.

**Mode** - Allows you to choose the mode in which way objects are generated [Random, Linear, or Ping Pong]. The default Mode is Random.

**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].

---

**Restoring The Default Settings**
**Restore Default Layer Settings** - Restores the default settings of the Layer.

- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.9 SCE Explosions

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Explosions displays all kinds of explosions as well as fireworks.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table. The default colors are Red, Yellow, Green, Cyan, Blue, Magenta.
  Learn more »Using Colors And Intensity
- **BPM** - Defines the speed. The default value is 3000. Valid values range from 0 to 9999.
  Learn more »Using BPM Control
- **Explosion Size** - Defines the magnitude of each explosion. The default value is 400. Valid values range from 1 to 9999.
- **Shape Size** - Defines the size of each object within an explosion. The default value is 8. Valid values range from 1 to 100.
- **Explosions** - Defines how many explosions are displayed at the same time. The default value is 1. Valid values range from 1 to 100.
- **Shapes** - Defines the number of single objects a single explosion includes. The default value is 75. Valid values range from 1 to 1000.
- **Fade Out** - Defines how fast MADRIX displays objects. The default value is 20. Valid values range from 0 to 1000.
- **Gravity** - Defines how strong objects are pulled to the bottom depending on the direction [in %]. The default value is 0.25. Valid values range from 0 to 100.
- **Colors** - Opens a second Color Table to define the second colors of each explosion. The default color is White.
  Learn more »Using Colors And Intensity
**Outer Glow / Inner Glow** - Is only available for specific Shapes. Defines the outer shimmer or inner gleam of objects. The default values are 0.00. Valid values range from 0.01 to 100.

**Explosion Shape** - Allows you to choose a specific shape for explosions [Sphere, Sphere Glow, Spiral, Radial, Diamond, Star, Random]. The default Explosion Shape is Random.

**Direction** - Allows you to choose the direction of the movement. The default Direction is Up. Learn more »[Using Directions](#)

**Direction** - Allows you to choose the direction of the movement [To The Front or To The Back]. This is mainly relevant for 3D. The default Direction is Up. Learn more »[Using Directions](#)

**Shape** - Allows you to choose a specific shape for objects. A certain Size is required before a shape becomes visible. The default Shape is Square Filled.

**Look-At Type** - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more »[Using Directions](#)

**Shape Rotation Type** - Is only available for specific Shapes. Defines the angle in which objects are rotated [0°, 90°, 180°, 270°, Random].

**Rendering Mode** - Defines how objects are rendered. Each mode may enable additional settings [such as additional Shapes]. Choose from 2 different modes. The default setting is Simple.
- **Simple** - Prioritizes processing speed over rendering possibilities.
- **Extended** - Prioritizes rendering possibilities over over processing speed. This mode may require more performance.

**Mode** - Allows you to choose the mode [Explosions or Fireworks]. The default Mode is Explosions.
Restoring The Default Settings

**Restore Default Layer Settings** - Restores the default settings of the Layer.

- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.10 SCE Fill Drops

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Fill Drops creates randomly falling objects.

Overview

![Default Settings]

![Customized Example]
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default colors are Red, Yellow, Green, Cyan, Blue, Magenta.
  Learn more »Using Colors And Intensity

- **Fill Time** - Defines the time how long it takes to fill the complete LED matrix with shapes [in s]. The default value is 5. Valid values range from 0.01 to 3600.

- **Duration** - Defines the time the complete matrix is shown in solid color until the next round of objects begins to fill the matrix [in s]. The default value is 1. Valid values range from 0 to 3600.

- **Size** - Defines the size of objects [Width, Height, Depth]. The default values are 10, 10, 10. Valid values range from 0.01 to 1000.

- **Pitch 1** - Defines the first distance between objects depending on the direction [in % of the Matrix Size]. The default value is 0. Valid values range from 10 to 100.

- **Pitch 2** - Defines the second distance between objects depending on the direction [in % of the Matrix Size]. The default value is 0. Valid values range from 10 to 100.

- **Border** - Is only available for 2D outlined shapes or 3D unfilled shapes. Defines how thick the outer line [border] of objects is. The default value is 0.01. Valid values range from 0.01 to 100.

  **Position Origin Type** - Defines the point of origin of Shapes [and hence their relative position].
**Outer Glow / Inner Glow** - Is only available for specific Shapes. Defines the outer shimmer or inner gleam of objects. The default values are 0.00. Valid values range from 0.01 to 100.

**Direction** - Allows you to choose the direction of the movement. The default Direction is Down. Learn more »[Using Directions](#)

**Direction** - Allows you to choose the direction of the movement [To The Front or To The Back]. This is mainly relevant for 3D. The default Direction is Down. Learn more »[Using Directions](#)

**Shape** - Allows you to choose a specific shape for objects. A certain Size is required before a shape becomes visible. The default Shape is Rectangle Filled.

**Shape Alignment** - Allows you to choose to which side objects are aligned to. This is mainly relevant for 3D. The default Shape Alignment is Front.

**Shape Rotation Type** - Is only available for specific Shapes. Defines the angle in which objects are rotated [0°, 90°, 180°, 270°, Random].

---

**Restoring The Default Settings**

**Restore Default Layer Settings** - Restores the default settings of the Layer.

- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.11 SCE Fill Random

This topic includes:

- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

**Introduction**

SCE Fill Random continuously adds new objects until the whole LED matrix is filled.

**Overview**

![Default Settings](image1)

![Customized Example](image2)
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »[Effect Areas (Deck A / Deck B)]
  Learn more »[Layers]

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default colors are Red, Yellow, Green, Cyan, Blue, Magenta.
  Learn more »[Using Colors And Intensity]

- **Fill Time** - Defines the time how long it takes to fill the complete LED matrix with shapes [in s]. The default value is 5. Valid values range from 0.01 to 3600.

- **Duration** - Defines the time the complete matrix is shown in solid color until the next round of objects begins to fill the matrix [in s]. The default value is 1. Valid values range from 0 to 3600.

- **Size** - Defines the size of objects [Width, Height, Depth]. The default values are 10, 10, 10. Valid values range from 0.01 to 1000.

- **Pitch** - Defines the distance between objects for all 3 axes. The default values are 10, 10, 10. Valid values range from 0 to 100.

- **Border** - Is only available for 2D outlined shapes or 3D unfilled shapes. Defines how thick the outer line [border] of objects is. The default value is 0.01. Valid values range from 0.01 to 100.

- **Position Origin Type** - Defines the point of origin of Shapes [and hence their relative position].
**Outer Glow / Inner Glow** - Is only available for specific Shapes. Defines the outer shimmer or inner gleam of objects. The default values are 0.00. Valid values range from 0.01 to 100.

**Shape** - Allows you to choose a specific shape for objects. A certain Size is required before a shape becomes visible. The default Shape is Rectangle Filled.

**Shape Alignment** - Allows you to choose to which side objects are aligned to. This is mainly relevant for 3D. The default Shape Alignment is Front.

**Shape Rotation Type** - Is only available for specific Shapes. Defines the angle in which objects are rotated [0°, 90°, 180°, 270°, Random].

---

**Restoring The Default Settings**

**Restore Default Layer Settings** - Restores the default settings of the Layer.

- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.12 SCE Fill Snake

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Fill Snake fills the matrix in a snake-like mode.

Overview

![Default Settings]

![Customized Example]
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more » Effect Areas [Deck A / Deck B]
  Learn more » Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default colors are Red, Yellow, Green, Cyan, Blue, Magenta.
  Learn more » Using Colors And Intensity

- **Fill Time** - Defines the time how long it takes to fill the complete LED matrix with shapes [in s]. The default value is 5. Valid values range from 0.01 to 3600.

- **Duration** - Defines the time the complete matrix is shown in solid color until the next round of objects begins to fill the matrix [in s]. The default value is 1. Valid values range from 0 to 3600.

- **Size** - Defines the size of objects [Width, Height, Depth]. The default values are 10, 10, 10. Valid values range from 0.01 to 1000.

- **Pitch** - Defines the distance between objects for all 3 axes [in % of the Matrix Size]. The default values are 10, 10, 10. Valid values range from 0 to 100.

- **Border** - Is only available for 2D outlined shapes or 3D unfilled shapes. Defines how thick the outer line [border] of objects is. The default value is 0.01. Valid values range from 0.01 to 100.

  **Position Origin Type** - Defines the point of origin of Shapes [and hence their relative position].
Outer Glow / Inner Glow - Is only available for specific Shapes. Defines the outer shimmer or inner gleam of objects. The default values are 0.00. Valid values range from 0.01 to 100.

Shape - Allows you to choose a specific shape for objects. A certain Size is required before a shape becomes visible. The default Shape is Rectangle Filled.

Shape Alignment - Allows you to choose to which side objects are aligned to. This is mainly relevant for 3D. The default Shape Alignment is Front.

Shape Rotation Type - Is only available for specific Shapes. Defines the angle in which objects are rotated [0°, 90°, 180°, 270°, Random].

Start Corner - Defines where the snake movements starts [Front Top Left, Front Top Right, Front Bottom Left, Front Bottom Right, Back Top Left, Back Top Right, Back Bottom Left, Back Bottom Right]. This setting is available for 2D, but only in 3D all options are viable.

Orientation Mode - Defines the general movement direction [XYZ Orientation, XZY Orientation, YXZ Orientation, YZX Orientation, ZYX Orientation, ZXY Orientation]. This setting is available for 2D, but only in 3D all options are viable.

Circle Mode - Activates a circular snake movement.

Center Mode - Starts movement from the center instead of the outer edge.

Mirror Mode - Duplicates the effect by mirroring it.

Restoring The Default Settings
**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.13 SCE Fill Solid

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Fill Solid constantly fills the matrix with a new color.

Overview

![Default Settings](image1)

![Customized Example](image2)
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default colors are Red, Yellow, Green, Cyan, Blue, Magenta.
  Learn more »Using Colors And Intensity

- **Fill Time** - Defines the time how long it takes to fill the complete LED matrix with shapes [in s]. The default value is 5. Valid values range from 0.01 to 3600.

- **Duration** - Defines the time the complete matrix is shown in solid color until the next round of objects begins to fill the matrix [in s]. The default value is 1. Valid values range from 0 to 3600.

- **Step Width** - Defines the number of pixels the effect should scroll in the direction per frame [in %]. The default value is 0.01. Valid values range from 0.01 to 100.

- **Color Width** - Is only available for Color Mix Mode [»Using Colors And Intensity]. Defines the width of a single color [in %]. The default value is 10. Valid values range from 0.01 to 100.

- **Cross Width** - Is only available for Cross Mode [»Using Directions]. Defines the size of crossing colors [in %]. The default value is 50. Valid values range from 0.01 to 100.

**Cross Mode Axes**- Is only available for Cross Mode. Allows you to choose to which axis Cross Mode applies [Axes 1 And 2, Axis 1, or Axis 2]. The default mode is Axes 1 And 2.
**Direction/Mode** - Allows you to choose the direction of the movement, including Cross Mode. This includes all directions for 2D and 3D mode. This heavily influences the visual outcome of the effect. The default Direction is Right. Learn more »[Using Directions](#)

**Look-At Type** - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more »[Using Directions](#)

---

**Restoring The Default Settings**

**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.14 SCE Fire

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings
- Context Menu

### Introduction

SCE Fire is one of two fire effects.
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Color** - Defines the color via a Color Gradient and various options.
  Learn more »Using Colors And Intensity

- **BPM** - Defines the speed. The default value is 1500. Valid values range from 0 to 9999.
  Learn more »Using BPM Control

- **Height** - Defines the height of the flames [in %]. The default value is 75. Valid values range from 1 to 1000.
  Learn more »Using Directions

  **Direction** - Allows you to choose the direction of the movement. The default Direction is Up.
  Learn more »Using Directions

  **Direction** - Allows you to choose the direction of the movement [To The Front or To The Back]. This is mainly relevant for 3D. The default Direction is Up. Learn more »Using Directions
Restoring The Default Settings

*Restore Default Layer Settings* - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].

Context Menu

A context menu allows you to quickly make changes to the colors.

- **Right Mouse Click** - Click with your right mouse button on the color gradient to call up the context menu.

  ![Context Menu](image)

- **Open...** - Loads a previously saved Color Table file from an external file [of the file type *.mctx]*.
- **Save...** - Saves the current colors as a Color Table file [of the file type *.mctx]*.

- **Copy** - Copies the current colors into the clipboard as a duplicate.
- **Paste** - Applies all colors from the clipboard to the currently focused color control [Colors, M2L Colors]*.

- **Defaults** - Restores all default gradient colors.
8.1.15 SCE Flames

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Flames is one of two fire effects.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Gradient to specify the colors. The default color is Black, Red, Yellow, White.
  Learn more »Using Colors And Intensity
- **BPM** - Defines the speed. The default value is 3000. Valid values range from 0 to 9999.
  Learn more »Using BPM Control
- **Width** - Defines the size of the flames [in %]. The default value is 24. Valid values range from 0 to 100.
- **Height** - Defines the height of the flames [in %]. The default value is 30. Valid values range from 0 to 100.
- **Depth** - Defines the depth of the flames [in %]. This is mainly relevant for 3D. The default value is 24. Valid values range from 0 to 100.
- **Intensity** - Defines the thickness of flames [in %]. The default value is 15. Valid values range from 0 to 100.

Direction - Allows you to choose the direction of the movement. The default Direction is Up.
Learn more »Using Directions

Direction - Allows you to choose the direction of the movement [To The Front or To The Back]. This is mainly relevant for 3D. The default Direction is Up. Learn more »Using Directions
Restoring The Default Settings

**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.16 SCE Fluid

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Fluid simulates gas or liquids.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  - Learn more »Effect Areas [Deck A / Deck B]
  - Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table or Color Gradient depending on the Color Mode. The default colors are Red, Yellow, Green, Cyan, Blue, Magenta.
  - Learn more »Using Colors And Intensity

- **BPM** - Defines the speed. The default value is 3000. Valid values range from 0 to 9999.
  - Learn more »Using BPM Control

- **Radius** - Defines the size of impulses [in %]. The default value is 10. Valid values range from 0 to 100.

- **Vorticity** - Defines how much impulses can swirl in the gas [in %]. The default value is 12. Valid values range from 0 to 100.

- **Duration** - Defines how long impulses can move through the gas [in %]. The default value is 64. Valid values range from 0 to 100.

- **Density** - Defines the thickness of the gas [in %]. The default value is 10. Valid values range from 0 to 100.

- **Velocity** - Defines how fast impulses can move through the gas [in %]. The default value is 10. Valid values range from 0 to 100.

- **Fade** - Defines how quickly impulses evaporate [in %]. The default value is 5. Valid values range from 0 to 100.

- **Deceleration** - Slows down the movement of impulses [in %]. The default value is 0. Valid values range from 0 to 100.
**Direction** - Allows you to choose the direction of the movement. The default Direction is Up. Learn more »[Using Directions](#)

---

**Direction** - Allows you to choose the direction of the movement [To The Front or To The Back]. This is mainly relevant for 3D. The default Direction is Up. Learn more »[Using Directions](#)

---

**Color Mode** - Allows you to choose the color mode [Color Table or Color Gradient]. The default Color Mode is Color Table.

---

**Restoring The Default Settings**

**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.17 SCE Gradient

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings
- Context Menu

Introduction

SCE Gradient is all about creating various color gradients.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Color** - Defines the color via a Color Gradient and various options.
  Learn more »Using Colors And Intensity

- **Angle** - Allows you to change the angle in which the effect is displayed [in °]. Is only available for Mode Radial.
  The default value is 0. Valid values range from 0 to 359.

- **Cross Width** - Is only available for Cross Mode »Using Directions. Defines the size of crossing colors [in %].
  The default value is 50. Valid values range from 0.01 to 100.

**Cross Mode Axes** - Is only available for Cross Mode. Allows you to choose to which axis Cross Mode applies [Axes 1 And 2, Axis 1, or Axis 2]. The default mode is Axes 1 And 2.

**Direction/Mode** - Allows you to choose the direction, including Cross Mode. This includes all directions for 2D and 3D mode. This heavily influences the visual outcome of the effect.
  The default Direction is Bottom. Learn more »Using Directions

**Look-At Type** - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more »Using Directions
Restoring The Default Settings

**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].

Context Menu

A context menu allows you to quickly make changes to the colors.

- **Right Mouse Click** - Click with your right mouse button on the color gradient to call up the context menu.

- **Open...** - Loads a previously saved Color Table file from an external file [of the file type *.mctx].
- **Save...** - Saves the current colors as a Color Table file [of the file type *.mctx].

- **Copy** - Copies the current colors into the clipboard as a duplicate.
- **Paste** - Applies all colors from the clipboard to the currently focused color control [Colors, M2L Colors].

- **Defaults** - Restores all default gradient colors.
8.1.18 SCE Graph

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings
- Edit Text

Introduction

SCE Graph effect creates trigonometric graphs. This MADRIX Effect is extremely versatile.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table. The default colors are Red, Yellow, Green, Cyan, Blue, Magenta.
  Learn more »Using Colors And Intensity

- **BPM** - Defines the speed. The default value is 1500. Valid values range from 0 to 9999.
  Learn more »Using BPM Control

- **Height** - Defines the height of elements depending on the direction [in % of the Matrix Size]. The default value is 10. Valid values range from 0.01 to 100.

- **Width** - Defines the width of elements depending on the direction [in % of the Matrix Size]. When Register Z1, Z2, or Z3 is selected, you are controlling a different width. If you are The default value is 10. Valid values range from 0.01 to 100.

- **Pitch** - Defines the distance between elements depending on the direction [in % of the Matrix Size]. When Register Z1, Z2, or Z3 is selected, you are controlling a different pitch. The default value is 10. Valid values range from 0.01 to 100.

- **Border** - Is only available for 2D outlined shapes or 3D unfilled shapes. Defines how thick the outer line [border] of objects is. The default value is 1. Valid values range from 1 to 100.

- **Frequency** - Defines the rate. A value of 1 means that the complete wave is shown. The default value is 1. Valid values range from 0 to 100.

- **Amplitude** - Defines the maximum oscillation of the elements in relation to the baseline. The default value is 100. Valid values range from -1000 to 1000.
- **Phase** - Defines an offset that allows you to shift the waves compared to each other when combining at least 2 graphs in order to avoid overlapping [in % of the wave length]. The default value is 0. Valid values range from 0 to 100.

- **Distribution** - Allows you to choose a certain Distribution Mode for the specific parameter. Often, you can then define a minimum value and a maximum value.

  - **Uniform** - Each object has the same size.
  - **Linear** - A linear distribution is used to increase the size regularly.
  - **Quadratic** - The majority of objects will be smaller than the rest.
  - **SQRT** - Using a square root function the majority of objects will be larger.
  - **Cubic** - Uses a cubic distribution with mixed sizes.
  - **Random** - Sizes will be generated randomly.

- **RND** - Generates random object sizes each time. This automatically activates Random Distribution Mode.

- **Outer Glow / Inner Glow** - Is only available for specific Shapes. Defines the outer shimmer or inner gleam of objects. The default values are 1. Valid values range from 0.01 to 100.

- **Peak** - Defines the peak of the wave [in % of the wavelength]. It is only available for Draw Mode Triangle and Square. The default value is 50. Valid values range from 0 to 100.

- **Direction/Mode** - Allows you to choose the direction, including Look-At Type. This includes all directions for 2D and 3D mode. The default Direction is Left. Learn more » Using Directions

- **Shape** - Allows you to choose a specific shape for objects. A certain Size is required before a shape becomes visible. This heavily influences the visual outcome of the effect. The default Shape is Rectangle Filled.

- **Look-At Type** - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more » Using Directions
**Shape Rotation Type** - Is only available for specific Shapes. Defines the angle in which objects are rotated [0°, 90°, 180°, 270°, Random].

**Edit Text** - Allows you to freely enter any text to display when Shape Text is selected first. A new window opens. Learn more [Edit Text](#).

**Draw Mode** - Allows you to change the graph form, which influences how the effect is drawn [Sine, Absolute Sine, Cosine, Triangle, Square]. The default Draw Mode is Sine.

**X-Axis Registers X1, X2, X3** - Allow you to combine up to 3 graphs with each other regarding the X-Axis. Each Register influences the visual outcome. Simply set up the **Amplitude**. More settings will be available then for this Register.

**Z-Axis Registers Z1, Z2, Z3** - Allow you to combine up to 3 graphs with each other regarding the Z-Axis. Each Register influences the visual outcome. Simply set up the **Amplitude**. More settings will be available then for this Register. This is mainly relevant for 3D.

**Phase Registers P1, P2, P3** - Allow you to combine up to 3 graphs with each other regarding the extruded phase. Each Register influences the visual outcome. Simply set up the **Amplitude**. More settings will be available then for this Register. This is mainly relevant for 3D.

**Right Mouse Click > Clear** restores the default settings of a Register.

---

**Restoring The Default Settings**
*Restores Default Layer Settings* - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].

**Edit Text**

- Choose Draw Mode *Text* in order to use text as elements of the graph.
- Clock *Edit Text* to change the text settings.

A new window opens.

Change the following settings as required:

- *Text* - Allows you to enter any text. Simply write something via your keyboard.
- **Aa** - Opens a new window and allows you to choose a specific font, font size, and other font settings.

![Font dialog box](image)

- **Splitting** - Allows you to split your text.
  - **None** - Is the default value and does not apply any splitting.
  - **Words** - Splits your text using each word, adds line breaks, and displays each word below the other.
  - **Characters** - Splits your text using each character [letter], adds line breaks, and displays each character below the other.

- **Repeat Text** - Uses your text continuously for each element of the graph.

- **Reverse Words** - Displays the words of your text in reverse order.

- **Reverse Characters** - Displays your complete text in reverse order, character by character.
8.1.19 SCE Image

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings
- Supported File Types
- Image Table
- Image Import Settings
- Using Images In Your MADRIX Setup
- Important Notes

Introduction

SCE Image allows you to load and display one or several images, pictures, logos, etc. on your LEDs. And you can add certain animations to them.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.

Learn more »Effect Areas [Deck A / Deck B]
Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Filter** - Applies a multiplicative color filter to the image. The default value is White.
  - **GS** - Activates grayscale mode to show the input only in gray shades. The Filter is independent of this mode.
  - **RGBW** - Converts the input into RGBW. This is useful when using RGBW fixtures to convert from the standard RGB color values of the input. If the option is disabled when using RGBW fixtures, the input will appear darker since the White channel is not used. The W color channel of the Filter only works if RGBW is activated.

Learn more »Using Colors And Intensity
- **BPM** - Defines the speed (when using a direction/movement). The default value is 1500. Valid values range from 0 to 9999.
  
  Learn more » [Using BPM Control](#)

- **Position** - Defines the position of the image in X, Y, and Z [in %]. The default values are 0, 0, 0. Valid values range from -1000 to 1000.

- **Playback Rate** - Defines the speed of the Image Table and how fast images are changed. Valid values range from 0 to 50.
  
  - The default value is 1, which means that the Duration of the Image Table for each image is used. A rate of 2 doubles the speed and cuts the Duration in half, for example.

- **Extrusion** - Adds depth to the input; i.e. duplicates the input image [in % of the virtual LED matrix]. This is mainly relevant for 3D. The default value is 100. Valid values range from 0.01 to 100.

---

**Open** - Allows you to load an image into MADRIX. Select the file on your computer or another source. Continue with [Image Import Settings](#)

**Open Image Table** - Opens the Image Table, a window to organize multiple images. Learn more [Image Table](#)

**Filtering** - Defines how input is processed and displayed. Mainly affects the visual outcome when the input is scaled up or down [e.g., when choosing a different mode for Stretching / Aspect Ratio]. Choose from 2 different modes. The default setting is None.
  
  - **None** - Prioritizes processing speed over image quality.
  - **Linear** - Prioritizes image quality over processing speed. This mode may affect performance.

**Direction** - Allows you to choose the direction. This includes all directions for 2D and 3D mode. The default value is None. Learn more » [Using Directions](#)

**Look-At Type** - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more » [Using Directions](#)
**Rotation** - Rotates the image \([0^\circ, 90^\circ, 180^\circ, 270^\circ]\). The default value is 0.

**Tile** - Tiles and duplicates the input and thereby generating patterns.

**Seamless** - Activates or deactivates a continuous stream of the input image. MADRIX will automatically display the input image again to create a continuous display.

**Stretching / Aspect Ratio** - Defines the aspect ratio of the image. The default value is Matrix.

- **None** - Disables stretching.
- **Matrix** - Stretches to the current aspect ratio of the virtual LED matrix.
- **Original** - Stretches to the original aspect ratio of the source.
- **4:3** - Applies a 4:3 aspect ratio.
- **16:9** - Applies a 16:9 aspect ratio.

**Restoring The Default Settings**

**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].

**Supported File Types**

SCE Image supports the following file types:
- BMP [of the file type *.bmp]
- GIF and Animated GIF [of the file type *.gif]
- JPG [of the file type *.jpg]
- PNG [of the file type *.png]
- TIFF [of the file type *.tif or *.tiff]

- MADRIX Image Table [of the file type *.mitz]
- MADRIX Image Table Uncompressed [of the file type *.mitx]

**Image Table**

**Overview**

SCE Image allows you to load one image or multiple images at a time. Use the Image Table to manage multiple images as described below.
- **Left Mouse Click** - Selects an image in the Image Table.

- **Double-Click Left Mouse Button** - Immediately chooses and activates the selected image and displays it on the LEDs. In this way, you can define which image to show next. MADRIX will automatically continue in the list then, beginning with this image.

- **Ctrl + Left Mouse Click** - Allows you to select several images in the Image Table at different positions.

- **Shift + Left Mouse Click** - Allows you to select several images by selecting 1] the first image, 2] the last image, 3] and all images in-between will be selected automatically.

- Automatic Loop - When the last image of the Image List is shown, MADRIX will automatically loop back to the first image and start from the beginning again.

**Thumbnail**
- Displays a small preview of the loaded or currently selected image.

**File Name**
- Shows the file name of the image.

**Duration**
- Defines how long an image is displayed [in s]. Select one or multiple images to adjust the value.

**Fade Time**
- Defines how long it takes to fade from one image to the next [in s]. Select one or multiple images and then adjust the value.

**Rotation**
- Rotates the image [0°, 90°, 180°, 270°]. The default value is 0°.

**New** - Immediately removes all items from the list.

**Open** - Loads a previously saved MADRIX Image Table from an external file [of the file type *.mitz or *.mitx].
Open And Attach - Loads a previously saved MADRIX Image Table from an external file [of the file type *.mitz or *.mitx] and adds the new images to the images that are already loaded.

Save - Saves the Image Table to an external file [of the file type *.mitz or *.mitx].

Add Images - Adds and appends one or several images to the Image Table. Choose the files from your harddisk or another storage location. Continue with Image Import Settings.

Remove Images - Removes one or several images from the Image Table. First, select the images in the list.

Duplicate Images - Copies the currently selected entries and adds them as new items to the Image Table.

#5 - Shows the total number of images in the Image Table. An empty list shows # 0

Swap Position - Swaps the position of images in the Image Table when several images are selected first.

Position Up - Changes the order, and positions currently selected images one step higher up in the list.

Position Down - Changes the order, and positions currently selected images one step lower down in the list.

Close - Closes the Image Table window.
**Context Menu**

- **Right Mouse Click** - You can call up the context menu by performing a right mouse click on **Images**.
  
  A small window will be shown.

![Context Menu Image]

You can quickly perform the following actions:

- **Edit...** - Opens the Image Table [in the same way you can open the window by clicking on **Images** with the left mouse button].

- **Open...** - Loads images or a previously saved Image Table from an external file [of the file type *.mitz or *.mitx].
  
  A new window opens for you to select the file on your harddisk.

- **Copy** - Copies the current images into the clipboard as a duplicate.

- **Paste** - Applies all images from the clipboard to the currently focused Image Table [**Images**].

- **Clear** - Removes all images from the Image Table.

**Drag And Drop [Copy And Paste]**

- **Left Mouse Click And Hold** - You can perform a Copy and Paste with the mouse.

  Click with the left mouse button on the **Images** button and hold for 3 seconds. A small + appears. Now, continue to hold and drag the mouse to another image control [of a different layer] and release the mouse to instantly apply the images.
- **File Drag And Drop** - You can select a MADRIX Image Table file [of the file type *.mitz or *.mitx] in Windows and drag it to a color control of your choice in MADRIX in order to load it in MADRIX.

### Image Import Settings

After opening an image or loading it into the Image Table, please use the following options to finally import your images into MADRIX. [When importing an image, a copy will be created and used within MADRIX. Your original content will not be changed.]

### Optimize Size

- **Optimize Size** - When activated, MADRIX automatically optimizes the file size of images loaded into MADRIX. If the image has a larger pixel resolution than your virtual LED matrix in MADRIX, the software automatically reduces the pixel resolution of the image to fit the virtual LED matrix. Thereby the file size is reduced, which in turn reduces the required space in the local memory of your computer [RAM]. This increases performance and stability of the software and computer. It is recommended to activate Optimize. Learn more [Important Notes]

- Confirm with OK, restore the default settings via Defaults, or abort the process using Cancel.
Create Slices For 3D

- **Create Slices For 3D** - Is a way to bring 2D content to 3D LED matrices by slicing the image into different parts and applying each slice to X-levels, Y-levels, or Z-levels as required. [You will get the most benefit out of this feature when using images that are made up of different parts and are especially created for this area of application.]

**Example:** Your virtual LED matrix is 10 x 8 x 4. Now, you have prepared an image and want to display it not only on the first Z-level or use Extrude, but on all 4 Z-levels. Then, you would let MADRIX create 4 slices.

- **Slice Type** - Defines the 3D orientation of how slices are applied to your LED matrix.
  - **X-Slices** - Uses slices to fill the LED matrix; always starting from left to right.
  - **Y-Slices** - Uses slices to fill the LED matrix; always starting from top to bottom.
  - **Z-Slices** - Uses slices to fill the LED matrix; always starting from front to back.
- **Slice Order** - Defines how your source image is processed.
  - **Left To Right** - MADRIX slices the image starting left.
    [The first, left slice will then be applied to the left for X-Slices, to the top for Y-Slices, and to the front for Z-Slices.]
  - **Right To Left** - MADRIX slices the image starting right.
    [The first, right slice will then be applied to the left for X-Slices, to the top for Y-Slices, and to the front for Z-Slices.]
  - **Top To Bottom** - MADRIX slices the image starting top.
    [The first, top slice will then be applied to the left for X-Slices, to the top for Y-Slices, and to the front for Z-Slices.]
  - **Bottom To Top** - MADRIX slices the image starting bottom.
    [The first, bottom slice will then be applied to the left for X-Slices, to the top for Y-Slices, and to the front for Z-Slices.]

- **Slice Count** - Defines in how many slices an image is divided. A value of 1 means that no slices are created and that the image is used as one. [A value of 4, for example, will create 4 slices that each make up 25% of the source image.]

- The settings with the highest performance are **Z-Slices** and **Top To Bottom**

- Confirm with **OK**, restore the default settings via **Defaults**, or abort the process using **Cancel**
Y-Slices - Left To Right

X-Slices - Left To Right

Z-Slices - Right To Left

Z-Slices - Top To Bottom
Using Images In Your MADRIX Setup

- When using image files, MADRIX will automatically locate these files on your harddisk. It also saves the folder location internally to access the image file.
- But MADRIX 5 will not save the images in your MADRIX Setup File!
- In order to play the setup on a different computer, you will need to copy your images, too. Make sure that they are placed in the same folder location.

Important Notes

- Please do use pictures with a pixel resolution according to the size of your LED matrix!
- It is not useful to use a resolution of 3000x2000 pixels if your LED matrix has a size of 192x128, for example. Please resize your pictures before using them in MADRIX. Please do also use 72 DPI. Both means will improve performance considerably. At the same time, you will avoid that the RAM of your computer will overload.
- Optimize Size - When activated, MADRIX automatically optimizes the file size of images loaded into MADRIX. If the image has a larger pixel resolution than your virtual LED matrix in MADRIX, the software automatically reduces the pixel resolution of the image to fit the virtual LED matrix. Thereby the file size is reduced, which in turn reduces the required space in the local memory of your computer [RAM]. This increases performance and stability of the software and computer.
8.1.20 SCE Level Color Simulator

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Level Color Simulator simulates audio input and displays the loudness of the input with the help of color. The more input, the brighter the effect.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »[Effect Areas [Deck A / Deck B]]
  Learn more »[Layers]

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Gradient to specify the colors. The default color is White, Black.
  Learn more »[Using Colors And Intensity]
- **Fade Out / In** - Defines how fast MADRIX displays color. You can specify the fade-in speed as well as the fade-out speed. The default values are 120 and 120. Valid values range from 1 to 3000.

![Stereo Linear]

**Mode** - Allows you to choose the mode [Mono, Stereo Linear, Stereo Radial]. This heavily influences the visual outcome of the effect.

![Direction]

**Direction** - Allows you to choose the direction. This includes all directions for 2D and 3D mode. The default value is Right. Learn more »[Using Directions]
Restoring The Default Settings

**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.21 SCE Metaballs

This topic includes:

- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

**Introduction**

SCE Metaballs creates objects that morph into each other creating a fluent animation.

**Overview**

![Default Settings](image1)

![Customized Example](image2)
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  
  Learn more » Effect Areas [Deck A / Deck B]
  
  Learn more » Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default color is White.
  
  Learn more » Using Colors And Intensity

- **BPM** - Defines the speed. The default value is 1200. Valid values range from 0 to 9999.
  
  Learn more » Using BPM Control

- **Count** - Defines the number of objects. The default value is 5. Valid values range from 1 to 20.

- **Size** - Defines the size of objects [in %]. The default value is 20. Valid values range from 1 to 100.

- **Outer Glow** - Defines the outer shimmer of objects. The default value is 20. Valid values range from 1 to 100.

- **Inner Glow** - Defines the inner gleam of objects which are not filled. The default value is 20. Valid values range from 1 to 100.

- **Border** - Is only available for 2D outlined shapes or 3D unfilled shapes. Defines how thick the outer line [border] of objects is. The default value is 20. Valid values range from 1 to 100.

- **Influence** - Is only available for Motion Type Swarm. Defines a radius in which objects influence other objects [in %]. The higher the value, the more visible the swarm behavior. The default value is 15. Valid values range from 0 to 100.

- **Separation** - Is only available for Motion Type Swarm. Defines how close objects can be to each other [in %]. The higher the value, the more space will be between objects. The default value is 5. Valid values range from 0 to 100.
**Distribution** - Allows you to choose a certain Distribution Mode for the specific parameter. Often, you can then define a minimum value and a maximum value.

- **Uniform** - Each object has the same size.
- **Linear** - A linear distribution is used to increase the size regularly.
- **Quadratic** - The majority of objects will be smaller than the rest.
- **SQRT** - Using a square root function the majority of objects will be larger.
- **Cubic** - Uses a cubic distribution with mixed sizes.
- **Random** - Sizes will be generated randomly.

**RND** - Generates random object sizes each time. This automatically activates Random Distribution Mode.

**Scale** - Is only available for Random Distribution Mode. It allows you to generally increase or decrease the size of objects.

**Shape** - Allows you to choose a specific shape for objects. A certain Size is required before a shape becomes visible. The default Mode is Circle Filled.

- Set up at least 2 colors if you want to define a second shape. Both shapes and both colors will then be morphed together. By default, the second shape equals the first shape.
- Deselect **Auto Adjustment [Color Mixing Link]** to set up a different, second shape.
- When using at least 2 colors or using the Color Table Random Mode [RND], you can set up the **Color Mixing Sharpness**. It allows you to choose how intensely the colors are mixed [Very Blurry, Blurry, Slightly Blurry, Medium, Slightly Clear, Clear, or Very Clear]. The default Color Mixing Sharpness is Medium.

**Shape Alignment** - Allows you to choose to which side objects are aligned to. This is mainly relevant for 3D. The default Shape Alignment is Front.

**Shape Rotation Type** - Is only available for specific Shapes. Defines the angle in which objects are rotated [0°, 90°, 180°, 270°, Random].
Motion Type - Choose how objects move and behave. The default value is Random.

Random - Objects move randomly and independently of each other.

Swarm - Objects react according to a swarm intelligence and thus imitate their movement behavior.

Restoring The Default Settings

Restore Default Layer Settings - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.22 SCE Noise

This topic includes:

- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

**Introduction**

SCE Noise displays by default objects with different shades to create an effect that is often referred to as visual noise.

**Overview**

![Default Settings](image)
![Customized Example](image)
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default color is White.
  Learn more »Using Colors And Intensity

- **BPM** - Defines the speed [when using a direction/movement]. The default value is 1500. Valid values range from 0 to 9999.
  Learn more »Using BPM Control

- **Frequency** - Defines the rate at which new visuals are created [in Hz]. The default value is 25. Valid values range from 0 to 50.

- **Size** - Defines the size of objects [Width, Height, Depth] [in % of the Matrix Size]. The default values are 1, 1, 1. Valid values range from 0.01 to 100.

- **Pitch** - Defines the distance between objects for all 3 axes [in % of the Matrix Size]. The default values are 1, 1, 1. Valid values range from 0.01 to 100.

- **Border** - Is only available for 2D outlined shapes or 3D unfilled shapes. Defines how thick the outer line [border] of objects is. The default value is 0.01. Valid values range from 0.01 to 100.

- **Variance** - Refers to the colors that are specified in the Color Table. Defines the minimum and maximum color variability of colors and objects, i.e. shades [in %]. The default values are 0 and 100. Valid values range from 0 to 100.

- **Alpha Mix** - Defines the upper limit of how much alpha is added to each object [in %]. Alpha Mix will be visible when using additional Layers. The default value is 100. Valid values range from 0 to 100.
**Recolor** - Is only available when setting up at least 2 colors in the Color Table. Assigns a new color to an object every time the effect is generated anew; either automatically via the Frequency or manually via Generate.

**Reshape** - Is only available when using the Shape *Random*. Assigns a new, random Shape to objects every time the effect is generated anew; either automatically via the Frequency or manually via Generate.

**Resize** - Is only available when setting up a Minimum Size that is lower than 100 [0 to 99]. Assigns a new, random Size to objects every time the effect is generated anew; either automatically via the Frequency or manually via Generate.

**Generate** - Creates the effect anew to produce different visuals. [This is mainly useful when setting a Frequency of 0.]

**Minimum Size** - Refers to Size. Defines the minimum size of objects [in %]. The default value is 100. Valid values range from 1 to 100.

**Outer Glow / Inner Glow** - Is only available for specific Shapes. Defines the outer shimmer or inner gleam of objects. The default values are 0.00. Valid values range from 0.01 to 100.

**Direction** - Allows you to choose the direction. This includes all directions for 2D and 3D mode. The default value is None. Learn more »Using Directions

**Shape** - Allows you to choose a specific shape for objects. A certain Size is required before a shape becomes visible. The default Shape is Rectangle Filled.

**Shape Alignment** - Allows you to choose to which side objects are aligned to. This is mainly relevant for 3D. The default Shape Alignment is Front.

**Shape Rotation Type** - Is only available for specific Shapes. Defines the angle in which objects are rotated [0°, 90°, 180°, 270°, Random].
Rendering Mode - Defines how objects are rendered. Each mode may enable additional settings [such as additional Shapes]. Choose from 2 different modes. The default setting is Simple.
  - Simple - Prioritizes processing speed over rendering possibilities.
  - Extended - Prioritizes rendering possibilities over over processing speed. This mode may require more performance.

Fade - Activates or deactivates fading between colors.

Restoring The Default Settings

Restore Default Layer Settings - Restores the default settings of the Layer.
  - All Layer Settings and Effect Settings will be restored to their default values.
  - This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.23 SCE Plasma

This topic includes:

- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings
- Context Menu

Introduction

SCE Plasma creates a liquid and moving color gradient.

Overview
**Layer Settings**

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.

  Learn more » [Effect Areas [Deck A / Deck B]]

  Learn more » [Layers]

**Effect Settings**

This MADRIX Effect uses the following, individual controls:

- **Color** - Defines the color via a Color Gradient and various options.
  
  Learn more » [Using Colors And Intensity]

- **BPM** - Defines the speed. The default value is 600. Valid values range from 0 to 9999.
  
  Learn more » [Using BPM Control]

- **Stretch** - Defines the stretch or compression factor at which the visuals are displayed [X, Y, Z, XY, YZ]. The default values are 1, 1, 1, 1.00, 1.00. Valid values range from 0.01 to 10.

- **Distance** - Defines how much of the visuals are displayed; like a zoom level. The default value is 1. Valid values range from 0.01 to 10.

**Restoring The Default Settings**

**Restore Default Layer Settings** - Restores the default settings of the Layer.

- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
Context Menu

A context menu allows you to quickly make changes to the colors.

- **Right Mouse Click** - Click with your right mouse button on the color gradient to call up the context menu.

- **Open...** - Loads a previously saved Color Table file from an external file [of the file type *.mctx].

- **Save...** - Saves the current colors as a Color Table file [of the file type *.mctx].

- **Copy** - Copies the current colors into the clipboard as a duplicate.

- **Paste** - Applies all colors from the clipboard to the currently focused color control [Colors, M2L Colors].

- **Defaults** - Restores all default gradient colors.
8.1.24 SCE Pulse / Stroboscope

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Pulse / Stroboscope produces a stroboscope or pulsating effect.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.

  Learn more »[Effect Areas [Deck A / Deck B]]
  Learn more »[Layers]

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default color is White.
  Learn more »[Using Colors And Intensity]

- **BPM** - Defines the speed. The default value is 1080. Valid values range from 0 to 9999.
  Learn more »[Using BPM Control]

- **Ratio** - Defines the ratio and relation between Fade In and Fade Out [in %]. The default value is 50. Valid values range from 0 to 100.
  - A Ratio of 50 means that Fade In and Fade Out have the same duration.
  - A Ratio of 0 means that there is a Fade In, but no Fade Out.
  - A Ratio of 100 means that there is no Fade In, but a Fade Out.

  **Fade** - Activates or deactivates fading between colors.
  - When activated, the effect pulses.
  - When deactivated, the effect strobes.
Restoring The Default Settings

**Restore Default Layer Settings** - Restores the default settings of the Layer.

- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.25 SCE Rotating Shapes

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Rotating Shapes displays various shapes that circle around a centric point.

Overview

![Default Settings]

![Customized Example]
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more » [Effect Areas [Deck A / Deck B]]
  Learn more » [Layers]

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default color is White.
  Learn more » [Using Colors And Intensity]

- **Shapes** - Opens the Shape Table to specify the shapes. The default color is Circle Filled.
  Learn more » [Using Shapes [Shape Table]]

- **BPM** - Defines the speed. The default value is 600. Valid values range from 0 to 9999.
  Learn more » [Using BPM Control]

- **Path Count** - Defines the number of concentric paths on which shapes circle around the center. The default value is 3. Valid values range from 1 to 20.

- **Path Bounds** - Defines the inner and outer limits of where paths can run along on the virtual LED matrix. The default values are 10 and 90. Valid values range from 0 to 10000.

- **Offset** - Defines a location deviation of shapes across different paths. The default value is 0. Valid values range from -10000 to 10000.

- **Shape Count** - Defines the number of shapes [multiplied by the Patch Count]. The default value is 1. Valid values range from 1 to 50.

- **Size** - Defines the minimum and maximum size of shapes. Outer shapes are large than inner shapes. The default value are 10 and 20. Valid values range from 0 to 1000.

- **Rotation** - Defines the number of path on which shapes circle around the center. The default value is 0. Valid values range from -3600 to 3600.

- **Center** - Defines the position of the center in X, Y, and Z [in %]. The default values are 50, 50, 50. Valid values range from -1000 to 1000.
**Path Alignment** - Lets shapes rotate along the path instead of the rotation against the horizon.

**Motion** - Activates movement across the different paths defined by the Path Count. The default value is 0. Valid values range from -100 to 100.

**Distribution** - Allows you to choose a certain Distribution Mode for the specific parameter. Often, you can then define a minimum value and a maximum value.

- **Linear** - A linear distribution is used to increase the size regularly.
- **Quadratic** - The majority of objects will be smaller than the rest.
- **SQRT** - Using a square root function the majority of objects will be larger.
- **Cubic** - Uses a cubic distribution with mixed sizes.

**Shape On Bounds** - Locates shapes on each Patch Bound instead of placing them towards the Paths Bounds.

**Offset Animation** - Animates the shapes and rotates them additionally with the offset against each path.

**Path Cross Width** - Lets shapes move against each other on the different paths. The default value is 0. Valid values range from 0 to 20.
**Distribution** - Allows you to choose a certain Distribution Mode for the specific parameter. Often, you can then define a minimum value and a maximum value.

- **Uniform** - Each path has the same distribution.
- **Linear** - A linear distribution is used to increase the parameter regularly starting from the inside.
- **Quadratic** - The parameter is more prominent on the outer paths.
- **SQRT** - Using a square root function the parameter is more prominent on the outer paths.
- **Cubic** - Uses a cubic distribution with a mixed distribution.
- **Inverted Linear** - A linear distribution is used to decrease the parameter regularly starting from the inside.
- **Triangle** - The majority of objects will be on the middle paths.
- **Inverted Quadratic** - The parameter is more prominent on the inner paths.
- **Inverted SQRT** - Using a square root function the majority of objects will be on the inner paths.
- **Inverted Cubic** - Uses a cubic distribution with a mixed distribution.

**Rotation Animation** - Animates the shapes and rotates them individually and permanently.

**Rotation Cross Width** - Lets shapes rotate against each other on the different paths. The default value is 0. Valid values range from 0 to 20.

**Look-At Type** - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more »Using Directions

**Speed** - Is only available for specific shapes [Implode, Explode, Pulse]. Defines how fast the shapes implode, explode, or pulse. The default value is 1. Valid values range from 0 to 10.

**Delay** - Is only available for specific shapes [Implode, Explode, Pulse]. Adds a delay to the shapes and lets them implode, explode, or pulse across the different paths. The default value is 0. Valid values range from -100 to 100.
Delay 2 - Is only available for specific shapes [Implode, Explode, Pulse]. Adds a delay to the shapes and lets them implode, explode, or pulse along each path. The default value is 0. Valid values range from -100 to 100.

Display Mode - Defines how the effect is shown. The default Display Mode is Fit.

- **Clip** - The maximum size of the effect is determined by the largest side of the virtual LED matrix.
- **Fit** - The maximum size of the effect is determined by the smallest side of the virtual LED matrix.
- **Stretch** - The effect is stretched to be fully shown on the virtual LED matrix.

Restoring The Default Settings

**Restore Default Layer Settings** - Restores the default settings of the Layer.

- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.26 SCE Screen Capture

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings
- Configuration
- Slices

Introduction

SCE Screen Capture allows you to use any area of your Windows Desktop / Monitor / Screen and capture its content in order to directly bring it into MADRIX. In this way, you can integrate any other software and their output into MADRIX [such as visualizers, presentations, and more]. Basically anything that you can show on your monitor can also be brought into MADRIX.
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »[Effect Areas [Deck A / Deck B]]
  Learn more »[Layers]

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Filter** - Defines a filter color. The default color is White.
  - **GS** - Activates grayscale mode to show the input only in gray shades. The Filter is independent of this mode.
  - **RGBW** - Converts the input into RGBW. This is useful when using RGBW fixtures to convert from the standard RGB color values of the input. If the option is disabled when using RGBW fixtures, the input will appear darker since the White channel is not used. The W color channel of the Filter only works if RGBW is activated.
  Learn more »[Using Colors And Intensity]
- **BPM** - Defines the speed [when using a direction/movement]. The default value is 1500. Valid values range from 0 to 9999.
  
  Learn more »**Using BPM Control**

- **Position** - Defines the position of the object in \( X, Y, \) and \( Z \) [in %]. The default values are 0, 0, 0. Valid values range from -1000 to 1000.

- **Extrusion** - Adds depth to the input; i.e. duplicates the input image [in % of the Matrix Size]. This is mainly relevant for 3D. The default value is 100. Valid values range from 0.01 to 100.

  **Configuration** - Allows you to configure the effect. It is highly recommended to adjust the settings. Learn more **Configuration**

  **Slices** - Is a way to bring 2D content to 3D LED matrices by slicing the content into different parts and applying each slice to X-levels, Y-levels, or Z-levels as required. Learn more **Slices**

  **Filtering** - Defines how input is processed and displayed. Mainly affects the visual outcome when the input is scaled up or down [e.g., when choosing a different mode for Stretching / Aspect Ratio]. Choose from 2 different modes. The default setting is None.
  - **None** - Prioritizes processing speed over image quality.
  - **Linear** - Prioritizes image quality over processing speed. This mode may affect performance.

  **Direction** - Allows you to choose the direction. This includes all directions for 2D and 3D mode. The default value is None.

  **Look-At Type** - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more »**Using Directions**

  **Rotation** - Allows you to rotate the input \([0^\circ, 90^\circ, 180^\circ, 270^\circ]\). The default value is 0.

  **Tile** - Allows you to tile and duplicate the input and thereby generating patterns.
**Seamless** - Activates or deactivates a continuous stream of the input image. MADRIX will automatically display the input image again to create a continuous display.

**Stretching / Aspect Ratio** - Allows you to choose the aspect ratio of the input. The default value is Matrix.

- **None** - Disables stretching.
- **Matrix** - Stretches to the current aspect ratio of the virtual LED matrix.
- **Original** - Stretches to the original aspect ratio of the source.
- **4:3** - Applies a 4:3 aspect ratio.
- **16:9** - Applies a 16:9 aspect ratio.

**Restoring The Default Settings**

**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].

**Configuration**

**Overview**

- In order to use this MADRIX Effect, click **Configuration** first.
A new window opens.

Configure the **Screen Capture Configuration** as required and as explained below.

**Performance**

Is only available in Windows 7. These settings affect the performance of the screen capturing. Screen capturing can require a considerable amount of computer performance!

**Aero Off**

- Turns off the Windows desktop composition system called Aero in Windows 7 [which is used for visual effects of the Windows user interface]. MADRIX will check first if the Aero is enabled.

  - **It is recommended to turn Aero off. This increases the capture frame rate!**
  - If you activate Aero Off, it will be turned on again once you close the MADRIX Software.

**Capture Frame Rate**

- **FPS** - Defines the frame rate with which MADRIX captures the content.
  
  - **D** - Restores the default settings. The default value is 50.0 FPS.
Capture Area

These settings define the screen area that is used for the screen capturing.

**Preset**

- Allows you to choose a preset for your capture area:
  
  **Custom Size** - Defines a custom area as the capture area.
  - Is automatically selected if you use a *Selection Tool* or define a *Custom Area*.
  
  **Monitor** - Defines a complete output of one monitor as the capture area. The available selection choices depend on the configuration of monitors in Windows [e.g., if one or more monitors are installed].

  **Virtual Screen** - Defines the complete screen output of Windows as the capture area. This often includes all monitors, for example.
Selection Tool

- Allows you to define a Custom Area using one of two tools:

  ![Custom Area Definition](image)

  Left: 150, Top: 150
  
  Width: 350, Height: 200
  
  Right: 500, Bottom: 350

Marquee - Allows you to define a capture area via your mouse and keyboard.
- Click Marquee and an overlay will be shown.
- You can freely move the overlay around in order to position it correctly.
- To do so, use the mouse [left mouse click and hold and drag the overlay window].
- Or use the arrow keys on your keyboard [Left, Right, Up, Down].

- You can freely change the size of this overlay in order to set up the correct size.
- To do so, use the mouse and drag the edges of the overlay.
- Or use the following keyboard shortcuts:
  - Shift + Arrow Up / Arrow Down - Reduces the Height.
  - Ctrl + Arrow Up / Arrow Down - Increases the Height.
  - Shift + Arrow Left / Arrow Right - Reduces the Width.
  - Ctrl + Arrow Left / Arrow Right - Increases the Width.

- The upper left coordinates of the overlay [Left, Top] are always displayed in the upper left corner.
- The lower right coordinates of the overlay [Right, Bottom] are always displayed in the lower right corner.
- The Width and the Height of the overlay are always displayed in the center.

- **Escape / Enter / Left Mouse Double-Click** - Confirms your selection.

**Window** - Allows you to quickly choose a specific window to use as capture area.
- Click Window and an overlay will be shown that covers complete windows.
- You can freely choose which window should be used as screen capture area.
- Move the mouse to select the window via the overlay.
- Use Ctrl + left mouse click in order to select specific parts of a window [e.g., to select only a specific area of an application].

- **Escape / Enter / Left Mouse Double-Click** - Confirms your selection.
**Custom Area**
- Define an individual screen capture area by using the four input fields.

  *Left* and *Top* - Define the start coordinates in a coordinate system that starts with 0,0 in the top left corner.

  *Width* - Defines the total horizontal size of the screen capture area in X.

  *Height* - Defines the total vertical size of the screen capture area in Y.

**Slices**

- **SL** - Calls up *Slice Settings*

  ![Slice Settings](image)

- **Slice Settings** - Is a way to bring 2D content to 3D LED matrices by slicing the content into different parts and applying each slice to X-levels, Y-levels, or Z-levels as required. [You will get the most benefit out of this feature when using content that are made up of different parts and are especially created for this area of application.]

  **Example**: Your virtual LED matrix is 10 x 8 x 4. Now, you have prepared a video feed and want to display it not only on the first Z-level or use Extrude, but on all 4 Z-levels. Then, you would let MADRIX create 4 slices.

- **Slice Type** - Defines the 3D orientation of how slices are applied to your LED matrix.
  - **X-Slices** - Uses slices to fill the LED matrix; always starting from left to right.
  - **Y-Slices** - Uses slices to fill the LED matrix; always starting from top to bottom.
  - **Z-Slices** - Uses slices to fill the LED matrix; always starting from front to back.
- **Slice Order** - Defines how your source content is processed.
  - **Left To Right** - MADRIX slices the content starting left.
    [The first, left slice will then be applied to the left for X-Slices, to the top for Y-Slices, and to the front for Z-Slices.]
  - **Right To Left** - MADRIX slices the content starting right.
    [The first, right slice will then be applied to the left for X-Slices, to the top for Y-Slices, and to the front for Z-Slices.]
  - **Top To Bottom** - MADRIX slices the content starting top.
    [The first, top slice will then be applied to the left for X-Slices, to the top for Y-Slices, and to the front for Z-Slices.]
  - **Bottom To Top** - MADRIX slices the content starting bottom.
    [The first, bottom slice will then be applied to the left for X-Slices, to the top for Y-Slices, and to the front for Z-Slices.]

- **Slice Count** - Defines in how many slices the content is divided. A value of 1 means that no slices are created and that the video feed is used as one. [A value of 4, for example, will create 4 slices that each make up 25% of the source content.]

- The settings with the highest performance are **Z-Slices** and **Top To Bottom**

- Confirm with **OK**, restore the default settings via **Defaults**, or abort the process using **Cancel**

- Learn more »**SCE Image**
8.1.27 SCE Shapes

This topic includes:

- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Shapes creates various objects at random positions.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  - Learn more »[Effect Areas [Deck A / Deck B]]
  - Learn more »[Layers]

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default color is White.
  - Learn more »[Using Colors And Intensity]
- **BPM** - Defines the speed. The default value is 1500. Valid values range from 0 to 9999.
  - Learn more »[Using BPM Control]
- **Fade** - Defines how fast objects disappear. The default value is 150. Valid values range from 1 to 3000.
- **Size** - Defines the size of the objects [in % of the Matrix Size, depending on the Shape Alignment]. The default value is 10. Valid values range from 0.01 to 1000.
- **Pitch** - Defines the distance between objects for all 3 axes [in % of the Matrix Size]. The default values are 10, 10, 10. Valid values range from 0.01 to 100.
- **Border** - Defines the size of an object's border [in % of the shape size]. The default value is 1. Valid values range from 0.01 to 100.
- **Alpha Mix** - Defines the upper limit of how much alpha is added to each object [in %]. Alpha Mix will be visible when using additional Layers. The default value is 100. Valid values range from 0 to 100.
- **Count** - Defines the number of objects created at once. The default value is 1. Valid values range from 1 to 100.
**Distribution** - Allows you to choose a certain Distribution Mode for the specific parameter. Often, you can then define a minimum value and a maximum value.

- **Uniform** - Each object has the same size.
- **Random** - Sizes will be generated randomly.

**RND** - Generates random object sizes each time. This automatically activates Random Distribution Mode.

**Position Origin Type** - Defines the point of origin of Shapes [and hence their relative position].

**Outer Glow / Inner Glow** - Is only available for specific Shapes. Defines the outer shimmer or inner gleam of objects. The default values are 1.00. Valid values range from 0.01 to 100.

**Shape** - Allows you to choose a specific shape for objects. A certain Size is required before a shape becomes visible. The default Shape is Square Filled.

**Shape Alignment** - Allows you to choose to which side objects are aligned to. This is mainly relevant for 3D. The default Shape Alignment is Front.

**Shape Rotation Type** - Is only available for specific Shapes. Defines the angle in which objects are rotated \([0°, 90°, 180°, 270°, Random]\).

**Rendering Mode** - Defines how objects are rendered. Each mode may enable additional settings [such as additional Shapes]. Choose from 2 different modes. The default setting is Extended.

- **Simple** - Prioritizes processing speed over rendering possibilities.
- **Extended** - Prioritizes rendering possibilities over over processing speed. This mode may require more performance.
**Restoring The Default Settings**

*Restore Default Layer Settings* - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.28 SCE Simple Shape

This topic includes:

- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

**Introduction**

SCE Simple Shape displays very basic objects.

This effect is particularly useful for 3D or in combination with other Layers and Mix Modes.

**Overview**
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Color** - Defines the color. The default color is White.
  Learn more »Using Colors And Intensity

- **Position** - Defines the position of the object in X, Y, and Z [in %]. The default values are 25, 25, 25. Valid values range from -1000 to 1000.

- **Size** - Defines the size of objects [Width, Height, Depth] [in %]. The default values are 50, 50, 50. Valid values range from 0.01 to 100.

- **Rotation** - Defines the rotation of objects in X, Y, and Z [in °]. The default values are 0, 0, 0. Valid values range from -180 to 180.

- **Outer Glow** - Defines the outer shimmer of objects. The default value is 25. Valid values range from 1 to 100.

- **Border** - Is only available for 2D outlined shapes or 3D unfilled shapes. Defines how thick the outer line [border] of objects is. The default value is 25. Valid values range from 0.01 to 100.

- **Inner Glow** - Defines the inner gleam of objects which are not filled. The default value is 25. Valid values range from 1 to 100.

- **Proportion** - Is only available for Cross and Cross Straight Shapes. Defines the size of arms in relation to the overall size of the Shape. The default value is 37.5. Valid values range from 0.01 to 100.

- **Diagonals** - Is only available for certain Cross and Star Shapes. Defines the length of the diagonal arms in relation to the overall size of the Shape. The default value is 70.7. Valid values range from 0.01 to 100.
**Position Origin Type** - Defines the point of origin of the Shape [and hence its relative position].

**Rotation Origin Type** - Defines the point of origin of the applied rotation.

**Interpolation Type** - Defines how the Outer Glow will look like [Linear, Ease In Bounce, Ease Out Bounce, Ease In Out Bounce, Ease In Circular, Ease Out Circular, Ease In Out Circular, Ease In Cubic, Ease Out Cubic, Ease In Out Cubic, Ease In Sinusoidal, Ease Out Sinusoidal, Ease In Out Sinusoidal, Ease In Exponential, Ease Out Exponential, Ease In Out Exponential]. The default value is Linear.

**Shape** - Allows you to choose a specific shape for objects. A certain Size is required before a shape becomes visible. The default Shape is Rectangle Outlined.

**Shape Alignment** - Allows you to choose to which side objects are aligned to. This is mainly relevant for 3D. The default Shape Alignment is Front.

**Shape Rotation Type** - Is only available for specific Shapes. Defines the angle in which objects are rotated [0°, 90°, 180°, 270°].

**Rendering Mode** - Defines how objects are rendered. Each mode may enable additional settings [such as additional Shapes]. Choose from 2 different modes. The default setting is Extended.

- **Simple** - Prioritizes processing speed over rendering possibilities.
- **Extended** - Prioritizes rendering possibilities over over processing speed. This mode may require more performance.
Restoring The Default Settings

**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.29 SCE Starfield

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

**Introduction**

SCE Starfield mainly simulates a field of stars streaming towards the viewer from the center. This creates a depth effect.

---

**Overview**

![SCE Starfield interface](image)

**Default Settings**

![Default Settings](image)

**Customized Example**

![Customized Example](image)
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  
  Learn more »Effect Areas [Deck A / Deck B]
  
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Color** - Defines the color. The default color is White.
  
  Learn more »Using Colors And Intensity

- **BPM** - Defines the speed. The default value is 1500. Valid values range from 0 to 9999.
  
  Learn more »Using BPM Control

- **Length** - Defines the length of objects’ trace. The default value is 25. Valid values range from 1 to 1000.

- **Count** - Defines the number of displayed objects. The default value is 50. Valid values range from 1 to 1000.

- **Size** - Defines the size of objects [in % of the Matrix Size]. The default value is 10. Valid values range from 0.01 to 1000.

- **Border** - Is only available for 2D outlined shapes or 3D unfilled shapes. Defines how thick the outer line [border] of objects is. The default value is 25. Valid values range from 1 to 100.

- **Rotation** - Defines if the objects rotate around the center [in °]. The default value is 0. Valid values range from -3600 to 3600.

- **Distortion** - Defines the distortion towards the center creating the depth effect [in %]. The default value is 75. Valid values range from 1 to 100.
**Distribution** - Allows you to choose a certain Distribution Mode for the specific parameter. Often, you can then define a minimum value and a maximum value.

- **Uniform** - Each object has the same size.
- **Random** - Sizes will be generated randomly.

**RND** - Generates random object sizes each time. This automatically activates Random Distribution Mode.

**Outer Glow / Inner Glow** - Is only available for specific Shapes. Defines the outer shimmer or inner gleam of objects. The default values are 25. Valid values range from 0.01 to 100.

**Shape** - Allows you to choose a specific shape for objects. A certain Size is required before a shape becomes visible. The default Shape is Star.

**Look-At Type** - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more »[Using Directions](#)

**Shape Rotation Type** - Is only available for specific Shapes. Defines the angle in which objects are rotated [0°, 90°, 180°, 270°, Random].

**Path Alignment** - Lets shapes rotate along the path instead of the general direction.

**Rendering Mode** - Defines how objects are rendered. Each mode may enable additional settings [such as additional Shapes]. Choose from 2 different modes. The default setting is Extended.

- **Simple** - Prioritizes processing speed over rendering possibilities.
- **Extended** - Prioritizes rendering possibilities over over processing speed. This mode may require more performance.

**Invert** - Inverts the direction of the effect [from outwards to inwards/from near to far].
Restoring The Default Settings

*Restored Default Layer Settings* - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.30 SCE Swarm

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Swarm creates moving objects that react according to a swarm intelligence and thus imitate movement behavior.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more » Effect Areas [Deck A / Deck B]
  Learn more » Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default color is White.
  Learn more » Using Colors And Intensity

- **Size** - Defines the size of objects [Width, Height, Depth]. The default values are 5, 5, 5. Valid values range from 0.1 to 100.

- **Border** - Is only available for 2D outlined shapes or 3D unfilled shapes. Defines how thick the outer line [border] of objects is. The default value is 1. Valid values range from 0.01 to 100.

- **Count** - Defines the number of objects. The default value is 24. Valid values range from 1 to 100.

- **Influence** - Defines a radius in which objects influence other objects [in %]. The higher the value, the more visible the swarm behavior. The default value is 15. Valid values range from 0 to 100.

- **Separation** - Defines how close objects can be to each other [in %]. The higher the value, the more space will be between objects. The default value is 5. Valid values range from 0 to 100.

- **Imitation** - Defines how closely objects imitate the movement of other objects [in %]. The default value is 10. Valid values range from 0 to 100.

- **Length** - Defines the length of objects and their tail [in %]. The default value is 30. Valid values range from 0 to 100.
**Outer Glow / Inner Glow** - Is only available for specific Shapes. Defines the outer shimmer or inner gleam of objects. The default values are 0.00. Valid values range from 0.01 to 100.

**Shape** - Allows you to choose a specific shape for objects. A certain Size is required before a shape becomes visible. The default Shape is Square Filled.

**Shape Alignment** - Allows you to choose to which side objects are aligned to. This is mainly relevant for 3D. The default Shape Alignment is Front.

**Shape Rotation Type** - Is only available for specific Shapes. Defines the angle in which objects are rotated \[0°, 90°, 180°, 270°, Random\].

**Rendering Mode** - Defines how objects are rendered. Each mode may enable additional settings [such as additional Shapes]. Choose from 3 different modes. The default setting is Simple.
- **Simple** - Prioritizes processing speed over rendering possibilities.
- **Extended** - Prioritizes rendering possibilities over over processing speed. This mode may require more performance.
- **Blobby** - Prioritizes rendering possibilities over over processing speed and produces blobby objects. This mode may require more performance.

**Bounce** - When activated, objects will bounce of the boundaries of the virtual LED matrix. Deactivate it and objects will appear on the opposite side when crossing a boundary.

**Restoring The Default Settings**
**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.31 SCE Ticker / Scrolling Text

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings
- Important Details

Introduction

SCE Ticker / Scrolling Text allows you to bring any text message to your LEDs.

Overview

![Default Settings](Image)

![Customized Example](Image)
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »[Effect Areas [Deck A / Deck B]]
  Learn more »[Layers]

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Color** - Defines the color. The default color is White.
  Learn more »[Using Colors And Intensity]

- **BPM** - Defines the speed [when using a direction/movement]. The default value is 600. Valid values range from 0 to 9999.
  Learn more »[Using BPM Control]

- **Position** - Defines the position of the text in X, Y, and Z [in %]. The default values are 0, 0, 0. Valid values range from -1000 to 1000.

- **Extrusion** - Adds depth to the text [in % of the Matrix Size]. This is mainly relevant for 3D. The default value is 100. Valid values range from 0.01 to 100.

- **Text** - Allows you to enter any text. Simply write something via your keyboard. The default text is MADRIX.

- **Splitting** - Allows you to split your text.
  - **None** - Is the default value and does not apply any splitting.
  - **Words** - Splits your text using each word, adds line breaks, and displays each word below the other.
  - **Characters** - Splits your text using each character [letter], adds line breaks, and displays each character below the other.

- **Reverse Words** - Displays the words of your text in reverse order.

- **Reverse Characters** - Displays your complete text in reverse order, character by character.
Font - Opens a new window and allows you to choose a specific font, font size, and other font settings. [Any color set up in this window will be ignored. Use the MADRIX color controls instead.]

Filtering - Defines how input is processed and displayed. Mainly affects the visual outcome when the input is scaled up or down [e.g., when choosing a different mode for Stretching / Aspect Ratio]. Choose from 2 different modes. The default setting is None.
- None - Prioritizes processing speed over image quality.
- Linear - Prioritizes image quality over processing speed. This mode may affect performance.

Direction - Allows you to choose the direction. This includes all directions for 2D and 3D mode. The default value is Left. Learn more »Using Directions

Look-At Type - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more »Using Directions

Rotation - Allows you to rotate the text [0°, 90°, 180°, 270°]. The default value is 0.

Tile - Allows you to tile and duplicate the text and thereby generating patterns.
**Seamless** - Activates or deactivates a continuous stream of text. MADRIX will automatically display the text again, when the main text has ended. Otherwise, MADRIX will display the complete text first, before displaying it again.

**Stretching / Aspect Ratio** - Allows you to choose the aspect ratio of the text. The default value is None.

- **None** - Disables stretching.
- **Matrix** - Stretches to the current aspect ratio of the virtual LED matrix.
- **Original** - Stretches to the original aspect ratio of the source.
- **4:3** - Applies a 4:3 aspect ratio.
- **16:9** - Applies a 16:9 aspect ratio.

### Restoring The Default Settings

**Restore Default Layer Settings** - Restores the default settings of the Layer.

- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].

### Important Details

**How To Create Smoother Text Movements**

Depending on your LEDs, the pixel pitch, and other factors, you might have the impression that text is not moving as fluently and smoothly as it should.
Follow these steps to create a better perceived image quality.

In general, stuttering effects are perceived to be less,

- the smaller the pixel pitch of your LED products is,
- the faster the text is scrolling [BPM],
- and the wider and larger the text is.

1] Choose a BPM value that makes the SCE Ticker Effect look good. Some recommended speeds are: 300 BPM, 350 BPM, 600 BPM, 750 BPM, 1500 BPM, and 3000 BPM.

2] Choose a font that is bold. Please avoid fine fonts or italics.

3] Try to choose a font that automatically has Anti-Aliasing applied to it. Not every font family automatically supports Anti-Aliasing. Anti-Aliasing reduces hard edges and makes the font smoother.

4] Reduce the overall tonal contrast of the Effect and image output. For example, white text on black background creates one of the highest contrasts. The higher the contrast, the more the text seems to be flickering.

Typefaces

Typefaces can be grouped into two main categories:

- Serif [Such fonts contain small features at the end of strokes within letters]
- Sans-serif [Such fonts have a clearer, simple appearance]

Serif Font

Sans-Serif Font

AaBbCc

How To Use Other Languages [Such As Russian Or Chinese]
In Windows 7, go to **Start > Control Panel > Region and Language > Keyboards and Languages**

In Windows 10, go to **Start > Windows System > Control Panel > Language**

Set up the language you want to use [Russian, Chinese, etc.].

- Regarding Windows 7, only when using Windows 7 Ultimate you are allowed to install additional languages in addition to the standard language.

In MADRIX, select **SCE Counter**

Click **Aa** to open the Font window.

Choose a universal, extensive font, such as **Arial**

Choose **Cyrillic** [or Chinese, etc.] under **Script**

Close the Font window.

Input any elements into the **String Table**
8.1.32 SCE Tubes

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

SCE Tubes displays various kinds of tubes at various positions.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default color is White.
  
  Learn more »Using Colors And Intensity

- **BPM** - Defines the speed. The default value is 1200. Valid values range from 0 to 9999.
  
  Learn more »Using BPM Control

- **Fade** - Defines how fast MADRIX displays the effect [in %]. The default value is 60. Valid values range from 1 to 3000.

- **Size 1** - Defines the first size of tubes depending on the direction [in % of the Matrix Size]. The default value is 10. Valid values range from 0.01 to 100.

- **Pitch 1** - Defines the first distance between tubes depending on the direction [in % of the Matrix Size]. The default value is 10. Valid values range from 0.01 to 100.

- **Size 2** - Defines the second size of tubes depending on the direction [in % of the Matrix Size]. The default value is 100. Valid values range from 0.01 to 100.

- **Pitch 2** - Defines the first distance between objects depending on the direction [in % of the Matrix Size]. The default value is 100. Valid values range from 0.01 to 100.

- **Alpha Mix** - Defines the upper limit of how much alpha is added to each object. Alpha Mix will be visible when using additional Layers. The default value is 100. Valid values range from 0 to 100.

- **Count** - Defines the number of objects. The default value is 1. Valid values range from 1 to 9999.
### Invert
Inverts the position of objects.

### Mirror
Mirrors objects by creating duplicates on the opposite position.

### Vertical Mode
Activates or deactivates the use of vertical objects. All 3 modes can be used at the same time.

### Horizontal Mode
Activates or deactivates the use of horizontal objects. All 3 modes can be used at the same time.

### Depth Mode
Activates or deactivates the use of objects in the depth. All 3 modes can be used at the same time.

### Mode
Allows you to choose the mode in which way objects are generated [Random, Linear, or Ping Pong]. The default Mode is Random.

---

#### Restoring The Default Settings

- **Restore Default Layer Settings** - Restores the default settings of the Layer.
  - All Layer Settings and Effect Settings will be restored to their default values.
  - This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.1.33 SCE Video

Introduction

SCE Video allows you to load a video file into MADRIX and display it on your LEDs.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.

  Learn more » [Effect Areas [Deck A / Deck B]]

  Learn more » [Layers]

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Filter** - Applies a multiplicative color filter to the image. The default value is White.
  - **GS** - Activates grayscale mode to show the input only in gray shades. The Filter is independent of this mode.
  - **RGBW** - Converts the input into RGBW. This is useful when using RGBW fixtures to convert from the standard RGB color values of the input. If the option is disabled when using RGBW fixtures, the input will appear darker since the White channel is not used. The W color channel of the Filter only works if RGBW is activated.

  Learn more » [Using Colors And Intensity]
- **BPM** - Defines the speed [when using a direction/movement]. The default value is 1500. Valid values range from 0 to 9999.
  Learn more »Using BPM Control

- **Position** - Defines the position of the image in $X$, $Y$, and $Z$ [in %]. The default values are 0, 0, 0. Valid values range from -1000 to 1000.

- **Playback Rate** - Defines the speed of the Image Table and how fast images are changed.
  - The default value is 1, which means that the Duration of the Image Table for each image is used. A rate of 2 doubles the speed and cuts the Duration in half, for example.
  - Is only available for compatible video codecs [such as, QuickTime].

- **Extrusion** - Adds depth to the input; i.e. duplicates the input image [in %]. This is mainly relevant for 3D. The default value is 100. Valid values range from 0.01 to 100.

---

**Open** - Allows you to load a video into MADRIX. Select the file on your computer or another source.

**Volume** - Is only available for videos with an audio track/sound. Allows you to define the audio output level for the loaded video. Valid values range from 0 to 100. The default value 0 [Off].

**Start Time** - Displays the Start Time of the video. The time format is hours:minutes:seconds [HH:MM:SS].
  - When loading a video file, MADRIX automatically displays the Start Time, which is normally **00:00:00**
  - Also allows you to enter an individual Start Time to begin the video at a different position.

**Spacebar** - Resets to the default value.

**Set Start Time** - Allows you to define an individual Start Time to begin the video at a different position. First, please enter a different Start Time.
**End Time** - Displays the End Time of the video. The time format is hours:minutes:seconds \([HH:MM:SS]\).
- When loading a video file, MADRIX automatically displays the End Time for the loaded video file.
- Also allows you to enter an individual End Time to let the video end/stop at a different position.

  **Spacebar** - Resets to the default value.

**Set End Time** - Allows you to define an individual End Time to let the video end/stop at a different position. First, please enter a different End Time.

**Position Slider** - This slider shows the current position of the video.
- You can use the slider to set a different position.
- You can use the small handles to define a different Start Time and End Time.

**Current Position** - Displays the current position of the video. The time format is hours:minutes:seconds \([HH:MM:SS]\).

**Skip To Start** - Instantly skips to the Start Time of the video.

**Step 1 Frame Back** - Allows you to go 1 frame backward. Is only available for compatible video codecs [such as, QuickTime].

**Play Backwards** - Allows you to play the video backwards. Is only available for compatible video codecs [such as, QuickTime].

**Play** - Starts the video playback.

**Skip 1 Frame** - Allows you to go 1 frame forward. Is only available for compatible video codecs [such as, QuickTime].

**Skip To End** - Instantly skips to the End Time of the video.

**Pause** - Allows you to pause video playback. The video stops at the current position.
**Playback Mode** - Allows you to define the playback behavior.

*Once* - Plays back the video normally, one time, from start to end. The Position will remain at the End Time.

*Loop [Default]* - Activates forward [or backwards] looping. The video file will be played back repeatedly in a loop.

*Bounce* - Is only available when the MotionJPG video codec is used [MJPG]. Activates changing the playback direction when reaching the video End Time or Start Time.

**Autostart** - Automatically starts the video after it has been loaded into MADRIX or after changing a Storage Place.

**Filtering** - Defines how input is processed and displayed. Mainly affects the visual outcome when the input is scaled up or down [e.g., when choosing a different mode for Stretching / Aspect Ratio]. Choose from 2 different modes. The default setting is None.

- *None* - Prioritizes processing speed over image quality.
- *Linear* - Prioritizes image quality over processing speed. This mode may affect performance.

**Decoder** - Allows you to choose from two decoders.

When playing back video files, MADRIX accesses certain decoders to convert the data back into imagery.

*Automatic* - Automatically decides which decoder to use based on the video file.

- However, this automatic selection might not be able to always choose the correct decoder.

- **If you are experiencing issues with your video, please make sure:**

  - to install the correct video codec and
  - to manually select a different decoder.

*Media Foundation* - Uses the Media Foundation video decoder.

*Direct Show* - Uses the Direct Show video decoder.
**Deinterlace Mode** - Allows you to choose from several Deinterlace Modes.

Often digital cameras, digital broadcasting, or digital filming is done via interlacing. In order to get 25 frames per seconds, 50 pictures are shot and merged/mixed with one another. You receive 25 odd frames [frame set 1] and 25 even frames [frame set 2] that contain different picture information [alternating pixel lines]. In order to get an undisturbed picture, proper deinterlacing is necessary.

**None** - Deactivates deinterlacing.

**Bob** - Uses one set of 25 frames [even or odd] and copies missing information from the pictures provided. Pixel lines are copied to create a full image. Activate **Top Field First** in order to process the frame set with the first pixel line first.

**Bob Linear** - This is the recommended deinterlace mode. It uses one set of 25 frames, but builds an average for the missing pixel lines. Activate **Top Field First** in order to process the frame set with the first pixel line first.

**Blend** - Renders an average image from frame set 1 and frame set 2.

**Discard** - Simply dismisses missing information. Thereby, pixel lines are excluded. This results in half of the original resolution for the final image. Activate **Top Field First** in order to process the frame set with the first pixel line first.

**Slices** - Is a way to bring 2D content to 3D LED matrices by slicing the content into different parts and applying each slice to X-levels, Y-levels, or Z-levels as required. Learn more **Slices**

**Direction** - Allows you to choose the direction. This includes all directions for 2D and 3D mode. The default value is None.

**Look-At Type** - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more »**Using Directions**

**Rotation** - Allows you to rotate the input \([0°, 90°, 180°, 270°]\). The default value is 0.

**Tile** - Allows you to tile and duplicate the input and thereby generating patterns.
**Seamless** - Activates or deactivates a continuous stream of the video image. MADRIX will automatically display the video image again to create a continuous display.

**Stretching / Aspect Ratio** - Allows you to choose the aspect ratio of the video. The default value is Matrix.

- **None** - Disables stretching.
- **Matrix** - Stretches to the current aspect ratio of the virtual LED matrix.
- **Original** - Stretches to the original aspect ratio of the source.
- **4:3** - Applies a 4:3 aspect ratio.
- **16:9** - Applies a 16:9 aspect ratio.

---

**Restoring The Default Settings**

**Restore Default Layer Settings** - Restores the default settings of the Layer.

- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].

---

**Slices**

**SL** - Calls up **Slice Settings**
- **Slice Settings** - Is a way to bring 2D content to 3D LED matrices by slicing the content into different parts and applying each slice to X-levels, Y-levels, or Z-levels as required. [You will get the most benefit out of this feature when using content that are made up of different parts and are especially created for this area of application.]

**Example:** Your virtual LED matrix is 10 x 8 x 4. Now, you have prepared a video and want to display it not only on the first Z-level or use Extrude, but on all 4 Z-levels. Then, you would let MADRIX create 4 slices.

- **Slice Type** - Defines the 3D orientation of how slices are applied to your LED matrix.
  - **X-Slices** - Uses slices to fill the LED matrix; always starting from left to right.
  - **Y-Slices** - Uses slices to fill the LED matrix; always starting from top to bottom.
  - **Z-Slices** - Uses slices to fill the LED matrix; always starting from front to back.

- **Slice Order** - Defines how your source content is processed.
  - **Left To Right** - MADRIX slices the content starting left.
    [The first, left slice will then be applied to the left for X-Slices, to the top for Y-Slices, and to the front for Z-Slices.]
  - **Right To Left** - MADRIX slices the content starting right.
    [The first, right slice will then be applied to the left for X-Slices, to the top for Y-Slices, and to the front for Z-Slices.]
  - **Top To Bottom** - MADRIX slices the content starting top.
    [The first, top slice will then be applied to the left for X-Slices, to the top for Y-Slices, and to the front for Z-Slices.]
  - **Bottom To Top** - MADRIX slices the content starting bottom.
    [The first, bottom slice will then be applied to the left for X-Slices, to the top for Y-Slices, and to the front for Z-Slices.]

- **Slice Count** - Defines in how many slices the content is divided. A value of 1 means that no slices are created and that the video is used as one. [A value of 4, for example, will create 4 slices that each make up 25% of the source content.]
- The settings with the highest performance are *Z-Slices* and *Top To Bottom*

- Confirm with **OK**, restore the default settings via **Defaults**, or abort the process using **Cancel**

- Learn more »[SCE Image](#)

## Audio Tracks / Sound Playback

MADRIX 5 can play back the audio track / sound of a video file.

- Make sure to configure audio output first.
  
  Learn more »[Audio And Sound](#)

- Make sure to set up the audio volume for the video.
  
  Learn more [Volume](#)

## Important Notes

- If you are experiencing issues with your video, please make sure:
  
  - to install the correct video codec and
  
  - to manually select a different decoder.

- To play back video, a video codec is required. Each video file format requires a special video codec.

- Windows already provides a number of codecs, but often additional codecs are necessary.

- If some features described above are not available, the video codec might simply not support this feature.

- Learn more below.
Video Codecs

Overview

- All video codecs that are installed on your computer are automatically supported by MADRIX.
- If you are experiencing problems, read below.

Solving Codec Problems

- If MADRIX is not able to play back a video file, make sure to install the appropriate video codec on your computer.
- Collections of video codecs are available in so-called video codec packs.
- If you install a new codec pack, make sure to uninstall a previously installed codec pack first. Often, it also makes no sense to install multiple codec packs since similar codecs may not work correctly anymore.
- The following codec packs can be recommended for download:
  - Web Link: »K-Lite Codec Pack
  - Web Link: »LAV Filters

Using Videos In Your MADRIX Setup

- When using video files, MADRIX will automatically locate these files on your harddisk. It also saves the folder location internally to access the video file.
- But MADRIX will not save the videos in your MADRIX Setup File!
- In order to play the setup on a different computer, you will need to copy your videos, too. Make sure that they are placed in the same folder location.
MADRIX Record Files

- The SCE Video effect is also able to play back MADRIX Record Files [of the file type *.mrec].
  Learn more »Recording
8.1.34 SCE Wave / Radial

This topic includes:

- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

**Introduction**

SCE Wave / Radial displays various linear or circular waves.

**Overview**

![Default Settings](image1)

![Customized Example](image2)
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Color** - Defines the color. The default color is White.
  Learn more »Using Colors And Intensity
- **BPM** - Defines the speed. The default value is 600. Valid values range from 0 to 9999.
  Learn more »Using BPM Control
- **Length** - Defines the length of the wave. The default value is 100. Valid values range from 1 to 500.
- **Width** - Defines the width of the wave. The default value is 100. Valid values range from 1 to 500.
- **Count** - Defines the number of extensions for mode Radar and Helix. The default value is 1. Valid values range from 1 to 50.
- **Factor** - Influences how the wave is drawn and bends the wave [in %]. The default value is 0. Valid values range from 0 to 100.
- **Amplitude** - Defines the intensity of Factor. The default value is 50. Valid values range from 0 to 100. Factor needs to be higher than 0 to use Amplitude.
- **Peak** - Defines the position of the peak of the wave for Draw Mode Triangle. The default value is 50. Valid values range from 0 to 100.
- **Center** - Defines the position of the center in X, Y, and Z [in %]. The default values are 50, 50, 50. Valid values range from -1000 to 1000.
**Direction** - Allows you to choose the direction of the movement. This includes all directions for 2D and 3D mode. The default Direction is Front. Learn more »[Using Directions](#)

**Mode** - Allows you to choose the main mode. This heavily influences the visual outcome of the effect [Linear, Circle, Square, Diamond, Radar, Helix, 3D Sphere, 3D Cube, 3D Octahedron]. The default Mode is Circle.
- **Make sure to adjust the Direction as required [especially for Mode Linear]!**

**Draw Mode** - Allows you to change the wave form, which influences how the effect is drawn [Sine, Absolute Sine, or Triangle]. The default Draw Mode is Sine.

**Movement** - Allows you to choose the movement direction [Inwards or Outwards]. The default Movement is Outwards.

**Rotation** - Is only available for specific shapes. Allows you to choose the rotation direction [Clockwise or Counter-clockwise]. The default Rotation is Clockwise.

**Restoring The Default Settings**

**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.2 [S2L] Sound2Light Effects

This topic includes:
- Introduction
- Performance Adjustments
- Topics Of This Chapter

Introduction

Sound2Light Effects [S2L] require an audio input signal. As a result, amazing light effects that are synchronized to the music will be generated!

Performance Adjustments

You are able to adjust parameters for the audio analysis and influence how S2L Effects work.
Learn more »Audio And Sound

Topics Of This Chapter

MADRIX includes the following Sound2Light Effects:
- »S2L Drops
- »S2L EQ / Spectrum
- »S2L Frequency Flash
- »S2L Level Color
- »S2L Level Color Scroll
- »S2L Level Meter
- »S2L Level Shape
- »S2L Shapes
- »S2L Tubes
- »S2L Waveform
- »S2L Wavegraph
8.2.1 S2L Drops

This topic includes:

- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

**Introduction**

S2L Drops displays drops according to the audio input.

**Overview**

![Default Settings](image1)

![Customized Example](image2)
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default color is White.
  Learn more »Using Colors And Intensity
- **Shapes** - Opens the Shape Table to specify the shapes. The default color is Rectangle Filled.
  Learn more »Using Shapes [Shape Table]
- **BPM** - Defines the speed. The default speed is 1500. Valid values range from 0 to 9999.
  Learn more »Using BPM Control
- **Size** - Defines the size of objects [Width, Height, Depth]. The default values are 1, 1, 1. Valid values range from 0.01 to 1000.
- **Length** - Defines how long the trace of a drop is [in % of the Matrix Size, depending on the direction]. The default value is 10. Valid values range from 0 to 100.
- **Rotation** - Defines the rotation of objects in X, Y, and Z [in °]. The default values are 0, 0, 0. Valid values range from -180 to 180.
- **Displacement** - Defines the amount of movement distortion. The default value is 0. Valid values range from 0 to 100.
- **Alpha Mix** - Defines the upper limit of how much alpha is added to each drop [in %]. Alpha Mix will be visible when using additional Layers. The default value is 100. Valid values range from 0 to 100.
- **Sensitivity** - Defines how quickly and accurately MADRIX reacts when such frequencies occur [in %]. The default value is 50. Valid values range from 0 to 100.
**Pitch 1** - Defines the first distance between objects depending on the direction [in % of the Matrix Size]. The default value is 0. Valid values range from 0 to 100.

**Pitch 2** - Defines the second distance between objects depending on the direction [in % of the Matrix Size]. The default value is 0. Valid values range from 0 to 100.

**Distribution** - Allows you to choose a certain Distribution Mode for the specific parameter. Often, you can then define a minimum value and a maximum value.

- **Uniform** - Each object has the same size.
- **Random** - Sizes will be generated randomly.

**RND** - Generates random object sizes each time. This automatically activates Random Distribution Mode.

**Length Offset** - Defines if an offset is added to the trace of a drop [in % of the Matrix Size]. The default value is 0. Valid values range from 0 to 100.

**Continuous Rotation** - Animates the shapes and rotates them around the corresponding axis permanently.

**Rotation Origin Type** - Defines the point of origin of the applied rotation.

**Rotation Offset** - Defines if an offset is added to the rotation of a drop [in % of the Matrix Size]. The default value is 0. Valid values range from 0 to 100.

**Displacement Speed** - Is only available for Displacement. Allows you to choose to speed in which the distortion affects the visuals. The default value is 10.0.

**Displacement Distribution** - Is only available for Displacement. Is applied in dependence of the direction that is chosen. Allows you to choose the area the distortion is applied to [Uniform, Linear Increasing, Linear Decreasing, Triangle]. The default value is Uniform.
**Shift** - Shifts the position of equalizer bands [in %]. By default, lower frequencies are shown to the left and high frequencies are shown to the left. The default value is 0. Valid values range from 0 to 100.

**Amplification** - Amplifies the audio input and as a result increases the visual intensity [in %]. The default value is 0. Valid values range from 0 to 100.

**Invert** - Inverts the position of objects.

**Mirror** - Mirrors objects by creating duplicates on the opposite position.

**Direction** - Allows you to choose the direction. The default Direction is Down. Learn more ➔ Using Directions

**Rendering Mode** - Defines how objects are rendered. Each mode may enable additional settings [such as additional Shapes]. Choose from 2 different modes. The default setting is Simple.

- **Simple** - Prioritizes processing speed over rendering possibilities.
- **Extended** - Prioritizes rendering possibilities over over processing speed. This mode may require more performance.

**Mode** - Allows you to choose the mode in which way objects are generated [**EQ**, **Level Mono**, or **Level Stereo**]. The default Mode is EQ.

---

**Restoring The Default Settings**
**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.2.2 S2L EQ / Spectrum

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

S2L EQ / Spectrum displays a real-time equalization and visualization of the audio signal [i.e., audio spectrum].

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.

Learn more » [Effect Areas (Deck A / Deck B)]

Learn more » [Layers]

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Gradient to specify the colors. The default color is Red, Orange, Green.
  Learn more » [Using Colors And Intensity]

- **Drop** - Defines how quickly spectrum bars are not displayed any more and drop out of the matrix [in %]. The default value is 50. Valid values range from 1 to 100.

- **Fade** - Defines how fast MADRIX displays the effect [in %]. The default value is 3000. Valid values range from 1 to 3000.

- **Width 1** - Defines the first size of spectrum bars depending on the direction [in % of the Matrix Size]. The default value is 0.1. Valid values range from 0.01 to 100.

- **Pitch 1** - Defines the first distance between spectrum bars depending on the direction [in % of the Matrix Size]. The default value is 0.1. Valid values range from 0.01 to 100.

- **Width 2** - Defines the second size of spectrum bars depending on the direction [in % of the Matrix Size]. The default value is 100. Valid values range from 0.01 to 100.

- **Pitch 2** - Defines the first distance between spectrum bars depending on the direction [in % of the Matrix Size]. The default value is 100. Valid values range from 0.01 to 100.

- **Logarithmic** - Displays the spectrum in a logarithmic way.
**Dynamic Range Control** - Visually amplifies and balances frequencies to get a more interesting spectrum.

**Shift** - Shifts the position of equalizer bands [in %]. By default, lower frequencies are shown to the left and high frequencies are shown to the left. The default value is 0. Valid values range from 0 to 100.

**Amplification** - Amplifies the audio input and as a result increases the visual intensity [in %]. The default value is 0. Valid values range from 0 to 100.

**Invert** - Inverts the position of objects.

**Mirror** - Mirrors objects by creating duplicates on the opposite position.

**Direction/Mode** - Allows you to choose the direction, including Cross Mode. This includes all directions for 2D and 3D mode. This heavily influences the visual outcome of the effect. The default Direction is Top. Learn more »[Using Directions](##)

**Look-At Type** - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more »[Using Directions](##)

**Shape** - Allows you to choose a specific shape for objects. A certain Size is required before a shape becomes visible. The default Shape is Filled.

**Shape Alignment** - Allows you to choose to which side objects are aligned to. This is mainly relevant for 3D. The default Shape Alignment is Front.

**Restoring The Default Settings**
**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.2.3 S2L Frequency Flash

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

**Introduction**

S2L Frequency Flash analyzes the audio input for certain frequencies and flashes the LED matrix when such frequencies occur in the audio input.

**Overview**

![Default Settings](image1.png)

![Customized Example](image2.png)
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.

Learn more »Effect Areas [Deck A / Deck B]
Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Color** - Defines the color. The default color is White.
  Learn more »Using Colors And Intensity

- **Fade Out / In** - Defines how fast MADRIX flashes [in %]. You can specify the fade-in speed as well as the fade-out speed. This value represents Beats Per Minute [BPM]. The default values are 120 and 3000. Valid values range from 1 to 3000.

- **Sensitivity** - Defines how quickly and accurately MADRIX reacts when such frequencies occur [in %]. The default value is 20. Valid values range from 1 to 100.

- Defines the lower limit of the analyzed frequency spectrum. If a frequency in this range occurs, MADRIX will flash the matrix.

- Defines the upper limit of the analyzed frequency spectrum. If a frequency in this range occurs, MADRIX will flash the matrix.
Restoring The Default Settings

*Restore Default Layer Settings* - Restores the default settings of the Layer.
* - All Layer Settings and Effect Settings will be restored to their default values.
* - This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.2.4 S2L Level Color

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

S2L Level Color displays the loudness of the audio input with the help of color. The louder the input, the brighter the effect.

Overview

![Default Settings](image1)

![Customized Example](image2)
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  
  Learn more » Effect Areas [Deck A / Deck B]
  
  Learn more » Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Gradient to specify the colors. The default color is White, Black.
  
  Learn more » Using Colors And Intensity

- **Fade Out / In** - Defines how fast MADRIX displays color. You can specify the fade-in speed as well as the fade-out speed. The default values are 120 and 120. Valid values range from 1 to 3000.

- **Amplification** - Amplifies the audio input and as a result increases the visual intensity [in %]. The default value is 0. Valid values range from 0 to 100.

  *Mode* - Allows you to choose the mode [Mono, Stereo Linear, Stereo Radial]. This heavily influences the visual outcome of the effect.

  *Direction* - Allows you to choose the direction. This includes all directions for 2D and 3D mode. The default value is Right. Learn more » Using Directions
Restoring The Default Settings

*Restore Default Layer Settings* - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.2.5 S2L Level Color Scroll

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

S2L Color Scroll displays moving colors based on incoming audio.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  
  Learn more »Effect Areas [Deck A / Deck B]
  
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default colors are White, Black.
  
  Learn more »Using Colors And Intensity

- **BPM** - Defines the speed. The default value is 600. Valid values range from 0 to 9999.
  
  Learn more »Using BPM Control

- **Step Width** - Defines the number of pixels the effect should scroll in the direction per frame [in %]. The default value is 0.01. Valid values range from 0.01 to 100.

- **Color Width** - Defines the width of a single color [in %]. The default value is 10. Valid values range from 0.01 to 100.

- **Cross Width** - Is only available for Cross Mode [»Using Directions]. Defines the size of crossing colors [in %]. The default value is 50. Valid values range from 0.01 to 100.

- **Displacement** - Defines the amount of distortion. The default value is 0. Valid values range from 0 to 100.

- **Amplification** - Amplifies the audio input and as a result increases the visual intensity [in %]. The default value is 0. Valid values range from 0 to 100.

**Cross Mode Axes** - Is only available for Cross Mode. Allows you to choose to which axis Cross Mode applies [Axes 1 And 2, Axis 1, or Axis 2]. The default mode is Axes 1 And 2.
**Displacement Speed** - Is only available for Displacement. Allows you to choose to speed in which the distortion affects the visuals. The default value is 10.0.

**Logarithmic** - Displays the effect in a logarithmic way.

**Direction/Mode** - Allows you to choose the direction of the movement, including Cross Mode. This includes all directions for 2D and 3D mode. This heavily influences the visual outcome of the effect. The default Direction is Right. Learn more » [Using Directions](#)

**Look-At Type** - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more » [Using Directions](#)

---

**Restoring The Default Settings**

**Restore Default Layer Settings** - Restores the default settings of the Layer.

- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.2.6 S2L Level Meter

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

S2L Level Meter displays the audio input level. By default, the left audio channel and the right audio channel are shown.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Color** - Opens the Color Gradient to specify the colors. The default color is White, Black.
  Learn more »Using Colors And Intensity

- **Drop** - Defines how quickly the effect is shown. The default value is 50. Valid values range from 1 to 100.

- **Fade** - Defines how fast MADRIX displays the effect [in %]. The default value is 3000. Valid values range from 1 to 3000.

- **Width 1** - Defines the first size of spectrum bars depending on the direction [in % of the Matrix Size]. The default value is 50. Valid values range from 0.01 to 100.

- **Pitch 1** - Defines the first distance between objects depending on the direction [in % of the Matrix Size]. The default value is 50. Valid values range from 0.01 to 100.

- **Width 2** - Defines the second size of spectrum bars depending on the direction [in % of the Matrix Size]. The default value is 100. Valid values range from 0.01 to 100.

- **Pitch 2** - Defines the first distance between objects depending on the direction [in % of the Matrix Size]. The default value is 100. Valid values range from 0.01 to 100.

**View Logarithmic** - Displays the effect in a logarithmic way.

**Mono** - Deactivates Stereo and only uses 1 audio channel.
**Amplification** - Amplifies the audio input and as a result increases the visual intensity [in %]. The default value is 0. Valid values range from 0 to 100.

**Invert** - Inverts the position of objects.

**Mirror** - Mirrors objects by creating duplicates on the opposite position.

**Direction/Mode** - Allows you to choose the direction, including Cross Mode. This includes all directions for 2D and 3D mode. This heavily influences the visual outcome of the effect. The default Direction is Top. Learn more »[Using Directions](#)

**Look-At Type** - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more »[Using Directions](#)

**Shape** - Allows you to choose a specific shape for objects. The default Shape is Filled.

**Shape Alignment** - Allows you to choose to which side objects are aligned to. This is mainly relevant for 3D. The default Shape Alignment is Front.

---

**Restoring The Default Settings**

**Restore Default Layer Settings** - Restores the default settings of the Layer.

- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.2.7 S2L Level Shape

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

S2L Level Shape represents the incoming audio level.

Overview

![Default Settings](image1)

![Customized Example](image2)
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default colors are Red, Yellow, Green, Cyan, Blue, Magenta.
  Learn more »Using Colors And Intensity

- **Drop** - Defines how quickly the effect is shown. The default value is 50. Valid values range from 1 to 100.

- **Amplification** - Amplifies the audio input and as a result increases the visual intensity [in %]. The default value is 0. Valid values range from 0 to 100.

- **Limit** - Acts as a compressor and defines the minimum and maximum level [size] of the effect depending on the actual audio input. The default values are 0 and 100. Valid values range from 0 to 10000.

- **Outer Glow** - Defines the outer shimmer of objects. The default value is 10. Valid values range from 1 to 100.

- **Border** - Is only available for 2D outlined shapes or 3D unfilled shapes. Defines the border size of outlined or unfilled objects. The default value is 25. Valid values range from 1 to 100.

- **Inner Glow** - Is only available for 2D outlined shapes or 3D unfilled shapes. Defines the inner gleam of objects which are not filled. The default value is 10. Valid values range from 1 to 100.

- **Proportion** - Is only available for certain Cross, Cross Straight, and Star Shapes. Defines the size of arms in relation to the overall size of the Shape. The default value is 37.5. Valid values range from 0.01 to 100.

- **Diagonals** - Is only available for certain Cross and Star Shapes. Defines the length of the diagonal arms in relation to the overall size of the Shape. The default value is 70.7. Valid values range from 0.01 to 100.
**Interpolation Type** - Defines how the Outer Glow will look like [Linear, Ease In Bounce, Ease Out Bounce, Ease In Out Bounce, Ease In Circular, Ease Out Circular, Ease In Out Circular, Ease In Cubic, Ease Out Cubic, Ease In Out Cubic, Ease In Sinusoidal, Ease Out Sinusoidal, Ease In Out Sinusoidal, Ease In Exponential, Ease Out Exponential, Ease In Out Exponential]. The default value is Linear.

**Interpolation Type** - Defines how the Inner Glow will look like [Linear, Ease In Bounce, Ease Out Bounce, Ease In Out Bounce, Ease In Circular, Ease Out Circular, Ease In Out Circular, Ease In Cubic, Ease Out Cubic, Ease In Out Cubic, Ease In Sinusoidal, Ease Out Sinusoidal, Ease In Out Sinusoidal, Ease In Exponential, Ease Out Exponential, Ease In Out Exponential]. The default value is Linear.

**Shape** - Allows you to choose a specific shape for objects. The default Shape is Ellipse Filled.

**Shape Alignment** - Allows you to choose to which side objects are aligned to. This is mainly relevant for 3D. The default Shape Alignment is Front.

**Shape Rotation Type** - Is only available for specific Shapes. Defines the angle in which objects are rotated [0°, 90°, 180°, 270°].

**Logarithmic** - Displays the effect in a logarithmic way.

**Mono** - Deactivates Stereo and only uses 1 audio channel.

**Display Mode** - Defines how the effect is shown. The default Display Mode is Fit.

- **Clip** - The maximum size of the effect is determined by the largest side of the virtual LED matrix.
- **Fit** - The maximum size of the effect is determined by the smallest side of the virtual LED matrix.
- **Stretch** - The effect is stretched to be fully shown on the virtual LED matrix.
Restoring The Default Settings

**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.2.8 S2L Shapes

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

S2L Shapes are a real-time equalization of the audio signal using a variation of shapes to display the audio input. By default, low frequencies will be displayed at the bottom of the matrix and high tones at the top.
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »[Effect Areas (Deck A / Deck B)]
  Learn more »[Layers]

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default color is White.
  Learn more »[Using Colors And Intensity]
- **Fade** - Defines how fast objects disappear. This value represents Beats Per Minute [BPM]. The default value is 150. Valid values range from 1 to 3000.
- **Size** - Defines the size of the objects [in % of the Matrix Size]. The default value is 10. Valid values range from 0.01 to 100.
- **Pitch** - Defines the distance between objects for all 3 axes [in % of the Matrix Size]. The default values are 10, 10, 10. Valid values range from 0.01 to 100.
- **Border** - Defines the size of an object's border [in % of the shape size]. The default value is 1. Valid values range from 0.01 to 100.
- **Alpha Mix** - Defines the upper limit of how much alpha is added to each object [in %]. Alpha Mix will be visible when using additional Layers. The default value is 100. Valid values range from 0 to 100.
- **Sensitivity** - Defines how quickly and accurately MADRIX reacts to the music [in %]. The default value is 50. Valid values range from 0 to 100.
**Distribution** - Allows you to choose a certain Distribution Mode for the specific parameter. Often, you can then define a minimum value and a maximum value.

- **Uniform** - Each object has the same size.
- **Random** - Sizes will be generated randomly.

**RND** - Generates random object sizes each time. This automatically activates Random Distribution Mode.

**Position Origin Type** - Defines the point of origin of Shapes [and hence their relative position].

**Outer Glow / Inner Glow** - Is only available for specific Shapes. Defines the outer shimmer or inner gleam of objects. The default values are 1.00. Valid values range from 0.01 to 100.

**Shift** - Shifts the position of equalizer bands [in %]. By default, lower frequencies are shown to the left and high frequencies are shown to the left. The default value is 0. Valid values range from 0 to 100.

**Amplification** - Amplifies the audio input and as a result increases the visual intensity [in %]. The default value is 0. Valid values range from 0 to 100.

**Invert** - Inverts the position of objects.

**Mirror** - Mirrors objects by creating duplicates on the opposite position.

**Shape** - Allows you to choose a specific shape for objects. A certain Size is required before a shape becomes visible. The default Shape is Square Filled.

**Shape Alignment** - Allows you to choose to which side objects are aligned to. This is mainly relevant for 3D. The default Shape Alignment is Front.

**Shape Rotation Type** - Is only available for specific Shapes. Defines the angle in which objects are rotated [0°, 90°, 180°, 270°, Random].
**Rendering Mode** - Defines how objects are rendered. Each mode may enable additional settings [such as additional Shapes]. Choose from 2 different modes. The default setting is Extended.
- **Simple** - Prioritizes processing speed over rendering possibilities.
- **Extended** - Prioritizes rendering possibilities over processing speed. This mode may require more performance.

### Restoring The Default Settings

**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.2.9 S2L Tubes

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

S2L Tubes display the frequencies of the audio signal in form of various tubes.

Overview

![S2L Tubes interface](image)

Default Settings

Customized Example
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Color** - Defines the color. The default color is White.
  Learn more »Using Colors And Intensity

- **Fade** - Defines how fast MADRIX displays the effect [in %]. The default value is 60. Valid values range from 1 to 3000.

- **Size 1** - Defines the first size of tubes depending on the direction [in % of the Matrix Size]. The default value is 10. Valid values range from 0.01 to 100.

- **Pitch 1** - Defines the first distance between tubes depending on the direction [in % of the Matrix Size]. The default value is 10. Valid values range from 0.01 to 100.

- **Size 2** - Defines the second size of tubes depending on the direction [in % of the Matrix Size]. The default value is 100. Valid values range from 0.01 to 100.

- **Pitch 2** - Defines the second distance between objects depending on the direction [in % of the Matrix Size]. The default value is 100. Valid values range from 0.01 to 100.

- **Alpha Mix** - Defines the upper limit of how much alpha is added to each object [in %]. Alpha Mix will be visible when using additional Layers. The default value is 100. Valid values range from 0 to 100.

- **Sensitivity** - Defines how quickly and accurately MADRIX reacts to the audio input [in %]. The default value is 50. Valid values range from 0 to 100.
**Shift** - Shifts the position of equalizer bands [in %]. By default, lower frequencies are shown to the left and high frequencies are shown to the left. The default value is 0. Valid values range from 0 to 100.

**Amplification** - Amplifies the audio input and as a result increases the visual intensity [in %]. The default value is 0. Valid values range from 0 to 100.

**Invert** - Inverts the position of objects.

**Mirror** - Mirrors objects by creating duplicates on the opposite position.

**Vertical Mode** - Activates or deactivates the use of vertical objects. All 3 modes can be used at the same time.

**Horizontal Mode** - Activates or deactivates the use of horizontal objects. All 3 modes can be used at the same time.

**Depth Mode** - Activates or deactivates the use of objects in the depth. All 3 modes can be used at the same time.

**Mode** - Allows you to choose the mode in which way objects are generated [**EQ**, **Level Mono**, or **Level Stereo**]. The default Mode is EQ.

---

**Restoring The Default Settings**

**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.2.10 S2L Waveform

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings
- Context Menu

Introduction

S2L Waveform displays the audio input graphically. It is a timeline representation.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Color** - Defines the color using a Color Gradient control. The default color is Red, Yellow, Green, Cyan, Blue, Magenta.
  Learn more »Using Colors And Intensity

- **BPM** - Defines the speed. The default speed is 60. You can either use BPM or Time Slot. Valid values range from 0 to 9999.
  Learn more »Using BPM Control

- **Time Slot** - Defines the time interval [in s]. The default value is 1. You can either use BPM or Time Slot. Valid values range from 0.01 to 9999.

  **Direction/Mode** - Allows you to choose the direction, including Look-At Type. This includes all directions for 2D and 3D mode. This heavily influences the visual outcome of the effect. The default Direction is Left. Learn more »Using Directions

  **Channel** - Allows you to choose the displayed audio channels [Stereo, Mono, Left, Right]. The default value is Mono.
Restoring The Default Settings

*Restore Default Layer Settings* - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].

Context Menu

A context menu allows you to quickly make changes to the colors.

- **Right Mouse Click** - Click with your right mouse button on the color gradient to call up the context menu.

- **Open...** - Loads a previously saved Color Table file from an external file [of the file type *.mctx].

- **Save...** - Saves the current colors as a Color Table file [of the file type *.mctx].

- **Copy** - Copies the current colors into the clipboard as a duplicate.

- **Paste** - Applies all colors from the clipboard to the currently focused color control [*Colors, M2L Colors*].

- **Defaults** - Restores all default gradient colors.
8.2.11 S2L Wavegraph

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

**Introduction**

S2L Waveform displays the audio input as a graph.

**Overview**
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Color** - Defines the color. The default color is White.
  Learn more »Using Colors And Intensity

- **BPM** - Defines the speed. The default speed is 6000. You can either use BPM or Time Slot. Valid values range from 0 to 9999.
  Learn more »Using BPM Control

- **Time Slot** - Defines the time interval [in s]. The default value is 0.01. You can either use BPM or Time Slot. Valid values range from 0.01 to 9999.

- **Direction/Mode** - Allows you to choose the direction, including Look-At Type. This includes all directions for 2D and 3D mode. This heavily influences the visual outcome of the effect. The default Direction is Left. Learn more »Using Directions

- **Channel** - Allows you to choose the displayed audio channels [Stereo, Mono, Left, Right]. The default value is Mono.
**Restoring The Default Settings**

*Restore Default Layer Settings* - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.3 [M2L] Music2Light Effects

This topic includes:

- Introduction
- Performance Adjustments
- Topics Of This Chapter

Introduction

Music2Light Effects [M2L] require an audio input signal. M2L Effects go one step further than S2L Effects and analyse music theoretical parameters to create truly unique representations of the music.

Performance Adjustments

You are able to adjust parameters for the audio analysis and influence how M2L Effects work.

Learn more »Audio And Sound

Topics Of This Chapter

MADRIX includes the following Music2Light Effects:

- »M2L Color Change
- »M2L Color Scroll
- »M2L Drops
- »M2L Note Flash
- »M2L Shapes
- [M2L Single Tone Spectrum](#)
- [M2L Tubes](#)
8.3.1  M2L Color Change

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

M2L Color Change automatically changes the color according to the music. This effect analyzes the key of the music and shows different colors for different keys in the music [i.e., the mood].

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Base Color** - Defines the background color of the effect. If no audio input or music is available, this color is shown. The default color is Black.
  Learn more »Using Colors And Intensity

- **Fade** - Defines how fast MADRIX changes colors [in %]. The higher the value, the slower MADRIX fades from one color to the next color. The default value is 20. Valid values range from 1 to 100.

- **M2L Colors** - Opens the M2L Color Table to specify which color is shown for which key.
  Learn more »Using Colors And Intensity

Restoring The Default Settings

**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.3.2 M2L Color Scroll

This topic includes:

- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

M2L Color Scroll displays moving colors based on the incoming audio.

Overview

![Default Settings](image)

![Customized Example](image)
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Base Color** - Defines the background color of the effect. If no audio input or music is available, this color is shown. The default color is Black.
  Learn more »Using Colors And Intensity

- **BPM** - Defines the speed. The default value is 600. Valid values range from 0 to 9999.
  Learn more »Using BPM Control

- **Step Width** - Defines the number of pixels the effect should scroll in the direction per frame [in %]. The default value is 0.01. Valid values range from 0.01 to 100.

- **Color Width** - Defines the minimum width of a single color [in %]. The default value is 10. Valid values range from 0.01 to 100.

- **Cross Width** - Is only available for Cross Mode [»Using Directions]. Defines the size of crossing colors [in %]. The default value is 50. Valid values range from 0.01 to 100.

- **Sensitivity** - Defines how accurately MADRIX reacts when notes occur [in %] or if notes are filtered out. The default value is 80. Valid values range from 0 to 100.

- **Displacement** - Defines the amount of distortion. The default value is 0. Valid values range from 0 to 100.

**Cross Mode Axes** - Is only available for Cross Mode. Allows you to choose to which axis Cross Mode applies [Axes 1 And 2, Axis 1, or Axis 2]. The default mode is Axes 1 And 2.
**Displacement Speed** - Is only available for Displacement. Allows you to choose to speed in which the distortion affects the visuals. The default value is 10.0.

**Direction/Mode** - Allows you to choose the direction of the movement, including Cross Mode. This includes all directions for 2D and 3D mode. This heavily influences the visual outcome of the effect. The default Direction is Right. Learn more » [Using Directions](#).

**Look-At Type** - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more » [Using Directions](#).

---

**Restoring The Default Settings**

**Restore Default Layer Settings** - Restores the default settings of the Layer.

- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.3.3 M2L Drops

This topic includes:

- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

M2L Drops analyzes the intervals of the music and displays in form of moving drops.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default color is White.
  Learn more »Using Colors And Intensity
- **Shapes** - Opens the Shape Table to specify the shapes. The default color is Rectangle Filled.
  Learn more »Using Shapes [Shape Table]
- **BPM** - Defines the speed. The default speed is 1500. Valid values range from 0 to 9999.
  Learn more »Using BPM Control
- **Size** - Defines the width, height, and depth of the drops. The default values are 1, 1, 1. Valid values range from 0.01 to 1000.
- **Length** - Defines how long the tail of a drop is [in %]. The default value is 10. Valid values range from 0 to 100.
- **Rotation** - Defines the rotation of objects in X, Y, and Z [in °]. The default values are 0, 0, 0. Valid values range from -180 to 180.
- **Displacement** - Defines the amount of movement distortion. The default value is 0. Valid values range from 0 to 100.
- **Alpha Mix** - Defines the upper limit of how much alpha is added to each drop [in %]. Alpha Mix will be visible when using additional Layers. The default value is 100. Valid values range from 0 to 100.
- **Tone Range** - Defines the range of tones analyzed and used by setting a minimum and a maximum value. Narrow the range if your audio signal does not include a wide range of tones to avoid a lot of empty space where no objects are shown. The default values are C1 and C9. Valid values range from C-1 to G9.
**Pitch 1** - Defines the first distance between objects depending on the direction [in % of the Matrix Size]. The default value is 0. Valid values range from 0 to 100.

**Pitch 2** - Defines the second distance between objects depending on the direction [in % of the Matrix Size]. The default value is 0. Valid values range from 0 to 100.

**Distribution** - Allows you to choose a certain Distribution Mode for the specific parameter. Often, you can then define a minimum value and a maximum value.
  
  **Uniform** - Each object has the same size.
  
  **Random** - Sizes will be generated randomly.

**RND** - Generates random object sizes each time. This automatically activates Random Distribution Mode.

**Length Offset** - Defines if an offset is added to the trace of a drop [in % of the Matrix Size]. The default value is 0. Valid values range from 0 to 100.

**Continuous Rotation** - Animates the shapes and rotates them around the corresponding axis permanently.

**Rotation Origin Type** - Defines the point of origin of the applied rotation.

**Rotation Offset** - Defines if an offset is added to the rotation of a drop [in % of the Matrix Size]. The default value is 0. Valid values range from 0 to 100.

**Displacement Speed** - Is only available for Displacement. Allows you to choose to speed in which the distortion affects the visuals. The default value is 10.0.

**Displacement Distribution** - Is only available for Displacement. Is applied in dependence of the direction that is chosen. Allows you to choose the area the distortion is applied to [Uniform, Linear Increasing, Linear Decreasing, Triangle]. The default value is Uniform.
**Invert** - Inverts the position of objects.

**Mirror** - Mirrors objects by creating duplicates on the opposite position.

**Direction** - Allows you to choose the direction. This includes all directions for 2D and 3D mode. The default value is Down. Learn more »Using Directions

**Direction** - Allows you to choose the direction of the movement [To The Front or To The Back]. This is mainly relevant for 3D. The default Direction is Down. Learn more »Using Directions

**Rendering Mode** - Defines how objects are rendered. Each mode may enable additional settings [such as additional Shapes]. Choose from 2 different modes. The default setting is Simple.
- **Simple** - Prioritizes processing speed over rendering possibilities.
- **Extended** - Prioritizes rendering possibilities over processing speed. This mode may require more performance.

**Mode** - Allows you to choose which musical parameter is used [Tone, Interval, Base Type].

---

**Restoring The Default Settings**

**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.3.4 M2L Note Flash

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

M2L Note Flash analyzes the music for certain notes and flashes the LED matrix when such notes occur in the music.
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more » [Effect Areas [Deck A / Deck B]]
  Learn more » [Layers]

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Color** - Defines the color. The default color is White.
  Learn more » [Using Colors And Intensity]

- **Fade Out / In** - Defines how fast MADRIX flashes [in %]. You can specify the fade-in speed as well as the fade-out speed. The default values are 120 and 3000. Valid values range from 1 to 300.

- **Sensitivity** - Defines how quickly and accurately MADRIX reacts when such notes occur [in %]. The default value is 50. Valid values range from 1 to 100.

- Defines the lower limit of the analyzed frequency spectrum. If a note in this range occurs, MADRIX will flash the matrix.

- Defines the upper limit of the analyzed frequency spectrum. If a note in this range occurs, MADRIX will flash the matrix.

Restoring The Default Settings
**Restore Default Layer Settings** - Restores the default settings of the Layer.

- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.3.5 M2L Shapes

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

M2L Shapes displays various objects available in different shapes according to the music.

Overview

![Default Settings]

![Customized Example]
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Table to specify the colors. The default color is White.
  Learn more »Using Colors And Intensity

- **Fade** - Defines how fast MADRIX displays objects [in %]. The default value is 150. Valid values range from 1 to 3000.

- **Size** - Defines the size of the objects [in %]. The default value is 10. Valid values range from 0.01 to 100.

- **Pitch** - Defines the distance between objects for all 3 axes [in %]. The default value is 10, 10, 10. Valid values range from 0.01 to 100.

- **Border** - Defines the size of an object's border [in %]. The default value is 1. Valid values range from 0.01 to 100.

- **Alpha Mix** - Defines the upper limit of how much alpha is added to each object. Alpha Mix will be visible when using additional Layers. The default value is 100. Valid values range from 0 to 100.

- **Sensitivity** - Defines how quickly and accurately MADRIX reacts to the music. The default value is 50. Valid values range from 0 to 100.

- **Tone Range** - Defines the range of tones analyzed and used by setting a minimum and a maximum value. Narrow the range if your audio signal does not include a wide range of tones to avoid a lot of empty space where no objects are shown. The default values are C1 and C9. Valid values range from C-1 to G9.
**Distribution** - Allows you to choose a certain Distribution Mode for the specific parameter. Often, you can then define a minimum value and a maximum value.

- **Uniform** - Each object has the same size.
- **Random** - Sizes will be generated randomly.

**RND** - Generates random object sizes each time. This automatically activates Random Distribution Mode.

**Position Origin Type** - Defines the point of origin of Shapes [and hence their relative position].

**Outer Glow / Inner Glow** - Is only available for specific Shapes. Defines the outer shimmer or inner gleam of objects. The default values are 0.00. Valid values range from 0.01 to 100.

**Invert** - Inverts the position of objects.

**Mirror** - Mirrors objects by creating duplicates on the opposite position.

**Shape** - Allows you to choose a specific shape for objects. A certain Size is required before a shape becomes visible. The default Shape is Square Filled.

**Shape Alignment** - Allows you to choose to which side objects are aligned to. This is mainly relevant for 3D. The default Shape Alignment is Front.

**Shape Rotation Type** - Is only available for specific Shapes. Defines the angle in which objects are rotated [0°, 90°, 180°, 270°, Random].

**Rendering Mode** - Defines how objects are rendered. Each mode may enable additional settings [such as additional Shapes]. Choose from 2 different modes. The default setting is Extended.

- **Simple** - Prioritizes processing speed over rendering possibilities.
- **Extended** - Prioritizes rendering possibilities over over processing speed. This mode may require more performance.
Restoring The Default Settings

*Restore Default Layer Settings* - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.3.6 M2L Single Tone Spectrum

This topic includes:

- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

M2L Single Tone Spectrum displays all notes based on the A440 pitch standard if they occur in the music.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  Learn more »Effect Areas [Deck A / Deck B]
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Colors** - Opens the Color Gradient to specify the colors. The default color is Red, Orange, Green.
  Learn more »Using Colors And Intensity

- **Drop** - Defines how quickly spectrum bars are not displayed any more and drop out of the matrix. The default value is 50. Valid values range from 1 to 100.

- **Fade** - Defines how fast MADRIX displays the effect [in %]. The default value is 3000. Valid values range from 1 to 3000.

- **Width 1** - Defines the first size of spectrum bars depending on the direction [in %]. The default value is 0.1. Valid values range from 0.01 to 100.

- **Pitch 1** - Defines the first distance between objects depending on the direction [in %]. The default value is 0.1. Valid values range from 0.01 to 100.

- **Width 2** - Defines the second size of spectrum bars depending on the direction [in %]. The default value is 100. Valid values range from 0.01 to 100.

- **Pitch 2** - Defines the first distance between objects depending on the direction [in %]. The default value is 100. Valid values range from 0.01 to 100.

- **Tone Range** - Defines the range of tones analyzed and used by setting a minimum and a maximum value. Narrow the range if your audio signal does not include a wide range of tones to avoid a lot of empty space where no objects are shown. The default values are C1 and C9. Valid values range from C-1 to G9.
**Logarithmic** - Displays the spectrum in a logarithmic way.

**Dynamic Range Control** - Visually amplifies and balances frequencies to get a more interesting spectrum.

**Shift** - Shifts the position of equalizer bands [in %]. By default, lower frequencies are shown to the left and high frequencies are shown to the left. The default value is 0. Valid values range from 0 to 100.

**Amplification** - Amplifies the audio input and as a result increases the visual intensity [in %]. The default value is 0. Valid values range from 0 to 100.

**Invert** - Inverts the position of objects.

**Mirror** - Mirrors objects by creating duplicates on the opposite position.

**Direction/Mode** - Allows you to choose the direction, including Cross Mode. This includes all directions for 2D and 3D mode. This heavily influences the visual outcome of the effect. The default Direction is Top. Learn more »Using Directions

**Look-At Type** - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D. The default value is Front. Learn more »Using Directions

**Shape** - Allows you to choose a specific shape for objects. A certain Size is required before a shape becomes visible. The default Shape is Filled.

**Shape Alignment** - Allows you to choose to which side objects are aligned to. This is mainly relevant for 3D. The default Shape Alignment is Front.
**Restoring The Default Settings**

*Restore Default Layer Settings* - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.3.7 M2L Tubes

This topic includes:
- Introduction
- Overview
- Layer Settings
- Effect Settings
- Restoring The Default Settings

Introduction

M2L Tubes displays the music in form of tubes.

Overview
Layer Settings

- Various buttons and controls have universal functions. They are available for each MADRIX Effect / Layer.
  
  Learn more »Effect Areas [Deck A / Deck B]
  
  Learn more »Layers

Effect Settings

This MADRIX Effect uses the following, individual controls:

- **Color** - Defines the color. The default color is White.
  
  Learn more »Using Colors And Intensity

- **Fade** - Defines how fast MADRIX displays the effect [in %]. The default value is 60. Valid values range from 1 to 3000.

- **Size 1** - Defines the first size of tubes depending on the direction [in %]. The default value is 10. Valid values range from 0.01 to 100.

- **Pitch 1** - Defines the first distance between tubes depending on the direction [in %]. The default value is 10. Valid values range from 0.01 to 100.

- **Size 2** - Defines the second size of tubes depending on the direction [in %]. The default value is 100. Valid values range from 0.01 to 100.

- **Pitch 2** - Defines the first distance between objects depending on the direction [in %]. The default value is 100. Valid values range from 0.01 to 100.

- **Alpha Mix** - Defines the upper limit of how much alpha is added to each object [in %]. Alpha Mix will be visible when using additional Layers. The default value is 100. Valid values range from 0 to 100.

- **Tone Range** - Defines the range of tones analyzed and used by setting a minimum and a maximum value. Narrow the range if your audio signal does not include a wide range of tones to avoid a lot of empty space where no objects are shown. The default values are C1 and C9. Valid values range from C-1 to G9.
**Invert** - Inverts the position of objects.

**Mirror** - Mirrors objects by creating duplicates on the opposite position.

**Vertical Mode** - Activates or deactivates the use of vertical objects. All 3 modes can be used at the same time.

**Horizontal Mode** - Activates or deactivates the use of horizontal objects. All 3 modes can be used at the same time.

**Depth Mode** - Activates or deactivates the use of objects in the depth. All 3 modes can be used at the same time.

**Mode** - Allows you to choose which musical parameter is used [Tone, Interval, Base Type].

---

**Restoring The Default Settings**

**Restore Default Layer Settings** - Restores the default settings of the Layer.
- All Layer Settings and Effect Settings will be restored to their default values.
- This does not include the MADRIX Effect selection, the Effect Parameter Chaser [which will be paused], or the Layer Macro [which will be stopped].
8.4 [TRI] Trigger Effects

This topic includes:
- Introduction
- Topics Of This Chapter

Introduction

Trigger Effects [TRI] are based on existing MADRIX Effects. On top, you can trigger them manually using DMX-IN or MIDI. This adds a whole new level of interaction.

Topics Of This Chapter

MADRIX includes the following Trigger Effects:
- >Configuration Of TRI
- >TRI Color Change
- >TRI Drops
- >TRI Explosions
- >TRI Shapes
- >TRI Tubes
8.4.1 Configuration Of TRI

This topic includes:
- Introduction
- Overview
- DMX-IN
- MIDI

Introduction

You need to set up the correct configuration first before you can use MADRIX TRI Effects.

Overview

TRI Effects can be triggered in 2 ways:

- **DMX-IN**
  [Including DMX512, Art-Net, Streaming ACN]

- **MIDI**

DMX-IN

If you wish to use DMX512, Art-Net, or Streaming ACN as trigger input source, make sure to set them up correctly:

- »**DMX-IN**
- »**Art-Net Remote**
MIDI

If you wish to use MIDI as trigger input source, make sure to set it up correctly:

- »MIDI-IN Configuration

8.4.2 TRI Color Change

Coming soon.

8.4.3 TRI Drops

Coming soon.

8.4.4 TRI Explosions

Coming soon.

8.4.5 TRI Shapes

Coming soon.

8.4.6 TRI Tubes

Coming soon.
8.5 [MAS] MADRIX Script Effect

This topic includes:
- Introduction
- Topics Of This Chapter

Introduction

MADRIX Script [MAS] makes use of the integrated scripting language for very advanced use of the software.

Topics Of This Chapter

MADRIX includes the following MAS Effect:
- »MAS Script
8.5.1 MAS Script

This topic includes:
- Introduction
- Controls
- More Information

Introduction

MADRIX offers numerous effects to create a stunning light show. MAS Script is an addition to that. It allows you to program your own effects.

The MADRIX Scripting language is an advanced topic, but allows you to realize very unique and customized effects.
The Script Help [user manual] is for all those who want to develop light effects with MADRIX Script. However, this does not require much knowledge of programming. The different parts of this language will be explained with various examples. We recommend for your first steps into this area to work through these examples. In a second step you might want to try to alter the settings of those examples. In this way you will get a feeling for the programming language and the syntax.

**Controls**

- **Load** - Allows you to open a previously saved script from an external file [of the file type *.mas or *.macs].

- **MAS Effect Script Editor** - Opens the Script Editor to edit any MAS Script.

- **Play/Pause** - Starts or pauses the execution of a script.

- **Limit Script Execution** - Can be a helpful option if you run a script with a very long execution time. MADRIX will stop the execution of a script and runs it from the beginning if it takes up too much processing time or is stuck in a loop. This option ensures the stability and performance of MADRIX.

- **BPM** - Defines the speed. The default value is 1200. Learn more »Using BPM Control

- **Asynchronous Rendering** - Allows you to choose the Synchronization Mode.
  - Activate **ASYNC** to control the render frequency using BPM.
  - Deactivate **ASYNC** to synchronize the render frequency with the Main Mixer [50 FPS by default].
More Information

The complete MADRIX Script Language is described in the MADRIX Script Help.

- In Windows 7, go to Start > All Programs > MADRIX 5 > Documentation > Help MADRIX 5 Script
- In Windows 10, go to Start > MADRIX 5 > Help MADRIX 5 Script
8.6 Using BPM Control

This topic includes:
- Introduction
- Overview

Introduction

The BPM control for MADRIX Effects is the main control to increase or decrease the speed of effects.

Overview

- Represent the standard controls to control the speed. Use the controls in the following way:
  - **Slider** - Move the slider to increase or decrease the speed.
  - **Input Field** - Enter the BPM speed directly.
    - Valid values range from 0 to 9999.
    - 60 BPM = 1 second.

- **Tap** - Allows you to set the speed manually. Use it to get synchronous movements of effects to the beat of the music. Click this button at least four times in a row according to the beat of the music [1/4 notes]. MADRIX will calculate the BPM value automatically.
**Speed Pitch** - Allows you to change the speed further. It works as a multiplier/factor.

- Example: A Speed Master of 2.0 will double the current speed.
- Move the fader upwards to increase the speed.
- Move the fader downwards to decrease the speed.
- The default value is 1.0 [which is normal speed].
- A value of 0.0 will stop the effects.
- The highest value is +10.
- The lowest value is -10.
- Negative values will reverse the direction of effects [if possible].
- Right-click on the Pitch button to reset to the value of 1.0
- The tooltip shows the currently set value.

**Speed Variance** - Adds variety to the speed of each individual object.

- If activated, each object will have a different speed.
- The higher the value, the larger the differences in speed between objects.
- Valid values range from 0 to 500.
- The default value is 0.
- Right-click on the SV button to reset to the value of 0.
8.7 Using Colors And Intensity

This topic includes:
- Introduction
- Overview
- Color
- Color Table
- Color Gradient
- Music2Light Colors
- Intensity

Introduction

Choosing the right colors is an important part when creating the lighting visuals you wish to use.

- This chapter explains the different ways of working with MADRIX Effects and colors.
- Different MADRIX Effects have different color controls.
- This chapter lists all possible controls. Not all controls are used for each MADRIX Effect.

Overview

- MADRIX controls up to 4 channels per pixel/voxel.
  For example:
  - 1-channel fixtures
  - 2-channel fixtures
  - RGB fixtures
  - RGBW fixtures
- MADRIX automatically adjusts the color selection tools according to the number of channels used by your fixtures [Color Depth].
  For example:
• Every color channel can have a value between 0 and 255.
• 0 is the lowest value.
• 255 is the highest value.
• Additive color mixing is used to produce a whole variety of different colors.

Examples:

**RGB White**
255, 255, 255

![RGB White](image)

**RGB Black**
0, 0, 0

![RGB Black](image)

**RGB Red**
255, 0, 0

![RGB Red](image)

**RGB Green**
0, 255, 0

![RGB Green](image)

**RGB Blue**
0, 0, 255

![RGB Blue](image)

**Color**

• Represent the standard controls to choose the color. Use the controls in the following way:
**Color Picker** - You can control the intelligent Color Picker simply with the mouse.

1] Click inside the color field next to **Color** and hold the mouse button.

2] While holding the mouse button, you can easily navigate inside the color field and pick your preferred color.

3] If you have chosen a color, release the mouse button.

- 14 presets are available at the top to quickly choose the most common colors.

**Input Fields** - You can use these input fields to choose a color. Use one of 3 ways:

A] Click into an input field and enter a number between 0 and 255 for each channel.

B] Click into an input field and use the spacebar to set a value to either 0 or 255.

C] Click into an input field and continue to hold the mouse button. Then, move your mouse up or down to adjust the value.

- Up to 4 color channels [R, G, B, W] are available depending on the settings of your virtual LED matrix [Color Depth].

**Alpha** - Is only available for certain MADRIX Effects. Defines an individual Opacity for a single color. The color becomes transparent and blends with the background.

**Fader Box** - Opens the Fader Box.

- Use the fader for each color channel separately to adjust the color.

- The color mixing and the final color will be shown at the bottom.

- **Close** - Closes the Fader Box.
**Phase Mode** - Uses all color channels separately to define the colors.

### Color Table

#### Overview

- Represent the standard controls to choose the color using the Color Table. Below you will find a description of each item.

**Colors** - Opens the Color Table.
**Color Table** - Contains a list of different colors. Each of the colors is used in the effect. Simply adjust the color values as described above and work with the Color Table in the following way:

- Adds a new color to the list according to the color settings at the top.

- Removes currently selected colors from the list.

- Duplicates currently selected colors in the list.

#6 - Shows the total number of colors in the list.

- Inverts the whole list. Or swaps the position of colors in the list when several colors are selected first.

- Moves currently selected colors one item up in the list.

- Moves currently selected colors one item down in the list.

- Loads a previously saved Color Table from an external file [of the file type *.mctx]. A new window opens for you to select the file on your harddisk.

- Loads a previously saved Color Table from an external file [of the file type *.mctx] and adds the new colors to the colors that are already included.

- Saves a Color Table in an external file [of the file type *.mctx].
- Inverts the currently selected colors to quickly create the complimentary colors.

- Converts the currently selected colors quickly to grayscale colors.

**Defaults** - Restores the default colors.

**Close** - Closes the Color Table.

**Loop Mode** - Activates Loop Mode for the Color Table. All colors in the Color Table will be used in their respective order [from top to down].

**Shuffle Mode** - Activates Shuffle Mode for the Color Table. All colors in the Color Table will be used but randomly selected without a specific order.

**Random Mode** - Activates Random Mode for the Color Table. Only randomly generated colors will be used. The colors in the Color Table will be ignored.

**Fade** - Adds a smooth transition between colors with the help of intermediate colors instead of switching with hard cuts between colors.

**Mix Mode** - Activates Mix Mode for the Color Table. All colors in the Color Table will be used at the same time but randomly selected without a specific order.

**Context Menu**

- **Right Mouse Click** - You can call up the context menu by performing a right mouse click on **Colors**

- A small window will be shown.
You can quickly perform the following actions:

- **Edit**... - Opens the Color Table [in the same way you can open the window by clicking on Colors with the left mouse button].

- **Open**... - Loads a previously saved Color Table from an external file [of the file type *mctx].
  A new window opens for you to select the file on your harddisk.

- **Copy** - Copies the current colors into the clipboard as a duplicate.

- **Paste** - Applies all colors from the clipboard to the currently focused color control [Colors, M2L Colors].

- **Defaults** - Restores all default colors.

**Drag And Drop [Copy And Paste]**

- **Left Mouse Click And Hold** - You can perform a Copy and Paste with the mouse.
  Click with the left mouse button on the Colors button and hold for 3 seconds. A small + appears. Now, continue to hold and drag the mouse to another color control [Colors, M2L Colors, Color Table, Color Gradient] and release the mouse to instantly apply the colors.

- **File Drag And Drop** - You can select a MADRIX Color Table file [of the file type *mctx] in Windows and drag it to a color control of your choice in MADRIX in order to load it in MADRIX.

**Color Gradient**
Overview

- The Color Gradient control is available in two versions:

**Color Gradient Window**

**Color Gradient Effect Control**

Add - Click inside the large colored area to create a new color at this particular position with the particular color you picked. Simply drag and drop it afterwards to change its position. Change the color values as described above.

Relocate - Select and hold a color [using the small square button] and move the mouse if you want to relocate a color.

Remove - Click the small x-button at the bottom of a color to remove it.

Position - Defines the position of a color on the Color Gradient.

Fade - Adds a transition between colors with the help of intermediate colors instead of switching with hard cuts between colors. This option is available separately for each color of the Color Gradient.
**Fade All** - Activates a smooth color transitions for all colors.

**Fade None** - Deactivates smooth color transitions for all colors.

**Uniform Distances** - Make sure that all colors have the same distance to each other.

**Invert Position** - Change and inverses the position of all colors.

**Invert Colors** - Inverts each color and thus creates the complementary equivalents of the colors before.

**Open** - Allows you to open a previously saved Color Table from an external file [of the file type *.mctx].

**Save** - Allows you to store a Color Table configuration in an external file [of the file type *.mctx].
**Close** - Closes the Color Gradient window.

**Color Mode** - Allows you to choose the Color Mode.

- **Monochrome** - Displays the effect only in White [and Black].
- **Band** - Applies the colors of the Color Gradient to each object individually [e.g., an EQ band].
- **Matrix** - Applies the colors of the Color Gradient to the virtual LED matrix and the effect as a whole.

### Context Menu

- **Right Mouse Click** - You can call up the context menu by performing a right mouse click on **Colors**
  - A small window will be shown.

You can quickly perform the following actions:

- **Edit...** - Opens the Color Gradient [in the same way you can open the window by clicking on **Colors** with the left mouse button].

- **Open...** - Loads a previously saved Color Table from an external file [of the file type *.mctx].
  - A new window opens for you to select the file on your harddisk.

- **Copy** - Copies the current colors into the clipboard as a duplicate.
- **Paste** - Applies all colors from the clipboard to the currently focused color control [Colors, M2L Colors].

- **Defaults** - Restores all default colors.

### Drag And Drop [Copy And Paste]

- **Left Mouse Click And Hold** - You can perform a Copy and Paste with the mouse. Click with the left mouse button on the **Colors** button and hold for 3 seconds. A small + appears. Now, continue to hold and drag the mouse to another color control [Colors, M2L Colors, Color Table, Color Gradient] and release the mouse to instantly apply the colors.

- **File Drag And Drop** - You can select a MADRIX Color Table file [of the file type *.mctx] in Windows and drag it to a color control of your choice in MADRIX in order to load it in MADRIX.

### Music2Light Colors

**Overview**

- Certain Music2Light Effects use special Music2Light Colors.

- You can decide which color is assigned to which key.

**M2L Colors** - Opens M2L Color Table.
**M2L Color Table** - Allows you match colors to specific keys.

- Major keys are listed in the left part of the window.
- Minor keys are listed in the right part of the window.

For example:

- **C** [written in capital letters] represents C-major and has a pure yellow as its color value [RGB: 255, 255, 0].
- **C-minor** [written as lower case c] has a darker yellow assigned [RGB: 153, 153, 0].

- **Open** - Allows you to open a previously saved Color Table from an external file [of the file type *.mctx].

- **Save** - Allows you to store a Color Table configuration in an external file [of the file type *.mctx].

- **C1** - Loads the default Color Table configuration.

- **C2** - Loads another Color Table preset.

- **R** - Loads another Color Table preset, starting with Red.

- **G** - Loads another Color Table preset, starting with Green.

- **B** - Loads another Color Table preset, starting with Blue.

- **Close** - Closes the Color Table window.

**Fade** - Adds a smooth transition between colors with the help of intermediate colors instead of using hard cuts between colors.
Default Color Table - The Circle of Fifths from music education is used for the default M2L Color Table. Starting with C, this notion describes a circle. Because of that, the relationship of the keys is visible from the arrangement.

- Adjacent keys are named parallel keys. The greater the distance between two keys, the less related they are. To support this fact, complementary colors are used in MADRIX.
- The outer ring of the circle describes the major keys, the inner ring the minor keys.
- While colors describe the tonality, the scale of the color is being expressed with the help of the brightness.

Context Menu

- Right Mouse Click - You can call up the context menu by performing a right mouse click on M2L Colors
- A small window will be shown.

You can quickly perform the following actions:

- Edit... - Opens the M2L Color Table [in the same way you can open the window by clicking on Colors with the left mouse button].

- Open... - Loads a previously saved Color Table from an external file [of the file type *.mctx].
  A new window opens for you to select the file on your harddisk.
- **Copy** - Copies the current colors into the clipboard as a duplicate.

- **Paste** - Applies all colors from the clipboard to the currently focused color control [Colors, M2L Colors].

- **Defaults** - Restores all default colors.

## Drag And Drop [Copy And Paste]

- **Left Mouse Click And Hold** - You can perform a Copy and Paste with the mouse.
  
  Click with the left mouse button on the **Colors** button and hold for 3 seconds. A small + appears. Now, continue to hold and drag the mouse to another color control [Colors, M2L Colors, Color Table, Color Gradient] and release the mouse to instantly apply the colors.

- **File Drag And Drop** - You can select a MADRIX Color Table file [of the file type *.mctx] in Windows and drag it to a color control of your choice in MADRIX in order to load it in MADRIX.

## Intensity

The user interface of MADRIX mainly provides 4 options to control the brightness:

- **Master** - Controls the overall brightness.
  
  Learn more »Main Output / Master / Audio Levels

- **Submaster A / B** - Controls the brightness of the entire Deck A or Deck B.
  
  Learn more »Controls [Deck A / Deck B]

- **Storage Place Submaster** - Controls the complete brightness of the entire Storage Place, including all of its Layers.
  
  Learn more »Storages

- **Layer Submaster** - Controls the complete brightness of the Layer.
  
  Learn more »Effect Areas [Deck A / Deck B]

- **Layer Opacity** - Makes the Layer transparent. This is mainly useful when using at least 2 Layers or more. If you are using only 1 Layer, the Submaster controls the Layer brightness.
  
  Learn more »Layers
8.8 Using Directions

This topic includes:

- Introduction
- Overview

Introduction

MADRIX Effects have various controls to set up the preferred direction of effects.

- Directions include all options, including 2D and 3D directions.
- 3D directions can be selected even when you are working in 2D Mode. But they only work correctly in 3D Mode.
- Especially for 3D a multiple of choices is available. That includes so-called Look-At Types.

Overview

Direction - Simply choose a direction by selecting it. The arrows will point towards the direction the effect will take.

- In the example to the left, the effect will move from up to down.

Front / Back - Allows you to choose the direction as well. This is mainly relevant for 3D.

To The Front - The effect will start in the back and move to the front.

To The Back - The effect will start in the front and move to the back.
Look-At Type - Allows you to choose from which side you want to look at the effect. This is mainly relevant for 3D.

- Front - Positions the effect to see it mainly from the front.
- Back - Positions the effect to see it mainly from the back.
- Left - Positions the effect to see it mainly from the left.
- Right - Positions the effect to see it mainly from the right.
- Top - Positions the effect to see it mainly from the top.
- Bottom - Positions the effect to see it mainly from the bottom.

Cross Mode - Activates Cross Mode. Certain MADRIX Effects can display the effect in two or more directions at the same time. [In addition, the Cross Width defines how much space each direction takes up].

- Example 1: SCE Color Scroll with Cross Mode and a Cross Width of 50% will display 2 color scrolls moving in opposite directions.
- Example 2: SCE Color Scroll with Cross Mode and a Cross Width of 20% will display 5 color scrolls moving in opposite directions.

None - Stops any movement.
8.9 Using Shapes [Shape Table]

This topic includes:
- Introduction
- Shape Table

Introduction

Certain MADRIX Effects allow you to work with one or multiple shapes at a time. Use the Shape Table to manage the shape objects as described below.

Shape Table

Overview
- **Left Mouse Click** - Selects a shape entry in the Shape Table.
- **Double-Click Left Mouse Button** - Allows you to change the settings for each column.
- **Ctrl + Left Mouse Click** - Allows you to select several entries in the Shape Table at different positions.
- **Shift + Left Mouse Click** - Allows you to select several entries by selecting 1] the first entry, 2] the last entry, 3] and all entries in-between will be selected automatically.

**Type**
- Defines the shape for this entry. Depending on the MADRIX Effect you may choose from different types [2D, 3D, Filled, Unfilled, Explode, Pulse, etc.].

**Alignment**
- Defines which side objects are aligned to. This is mainly relevant for 3D.

**Outer Glow**
- Defines the outer shimmer of objects.

**Border**
- Defines how thick the outer line [border] of objects is.

**Inner Glow**
- Defines the inner gleam of objects.

**Origin**
- Defines the point of origin of Shapes [and hence their relative position].

**Open** - Loads a previously saved MADRIX Shape Table from an external file [of the file type *.mshtx].

**Open And Attach** - Loads a previously saved MADRIX Shape Table from an external file [of the file type *.mshtx] and adds the shapes to the shapes that are already loaded.

**Save** - Saves the Shape Table to an external file [of the file type *.mshtx].
**Add Shapes** - Adds and appends one or several shapes to the Shape Table.

**Remove Shapes** - Removes one or several shapes from the Image Table. First, select the entries in the list.

**Duplicate Shapes** - Copies the currently selected shapes and adds them as new items to the Shape Table.

#5  
- Shows the total number of shapes in the Shape Table. An empty list shows #0

**Swap Position** - Swaps the position of shapes in the Shape Table when several entries are selected first.

**Position Up** - Changes the order, and positions currently selected shapes one step higher up in the list.

**Position Down** - Changes the order, and positions currently selected shapes one step lower down in the list.

**Defaults** - Restores all default settings.

**Close** - Closes the Shape Table window.

**Context Menu**

- **Right Mouse Click** - You can call up the context menu by performing a right mouse click on **Shapes**

- A small window will be shown.
You can quickly perform the following actions:

- **Edit** - Opens the Shape Table [in the same way you can open the window by clicking on *Shapes* with the left mouse button].

- **Open** - Loads a previously saved Shape Table from an external file [of the file type *.mshtx].
  A new window opens for you to select the file on your harddisk.

- **Copy** - Copies the current shapes into the clipboard as a duplicate.

- **Paste** - Applies all shapes from the clipboard to the currently focused Shape Table [Shapes].

- **Clear** - Removes all entries from the Shape Table.

**Drag And Drop [Copy And Paste]**

- **Left Mouse Click And Hold** - You can perform a Copy and Paste with the mouse.
  Click with the left mouse button on the *Shapes* button and hold for 3 seconds. A small + appears. Now, continue to hold and drag the mouse to another Shape Table control [of a different layer] and release the mouse to instantly apply the shapes.

- **File Drag And Drop** - You can select a MADRIX Shape Table file [of the file type *.mshtx] in Windows and drag it to a Shape Table control in MADRIX in order to load it in MADRIX.
8.10 Macros And Scripts

This topic includes:
- Introduction
- Usage
- How To Use
- More Information

Introduction

MADRIX features its own scripting language. With this programming language you can create scripts or macros for MADRIX.

- You can use it to create your own light effects, as was described in the previous chapter.
- In addition, it may be used to control and manipulate running effects.

Usage

Editor - Controls the corresponding Macro Editor.

There are 4 possibilities to use Macros in MADRIX:

- **MAS Script Effect**
  The first option to create a new effect from scratch.

- **Macros for Effects**
  The second option involves modifying the settings of an MADRIX Effect. This includes all SCE, S2L, M2L, TRI, and MAS effects.

- **Storage Place Macro**
  Fourth, you can use storage place macros to control every single storage place individually
- **Global Macro**
  The third possibility controls the main output and global features directly.

- On the one hand, macros can be used to manipulate the outcome of an effect.
  Examples include rendering parts of effects transparent or changing the color via a gray filter.
- On the other hand, macros can be used to change settings of an effect.
  A macro can set the text of the SCE Ticker effect to current time, for example.
- Each effect is equipped with a **Macro** button that opens the Macro Editor. Use the window to write, load, and edit existing macros.
- Each Storage Area has one macro button.
- The Fade Area includes the button to the Main Output Macro.
- The MAS Script Effect does have one button for scripts and a standard button for a macro.

## How To Use

- **Macro** - Allows you to configure and manage a Macro. At the same time this means that no Macro is running or included.

- **Deactivated [Macro Included]** - A macro is included/inserted in the Macro Editor, but the macro is currently not running.
  
  **Left Mouse Click** - Click once to activate the Macro.

- **Activated** - A macro has been compiled and is currently running.
  
  **Left Mouse Click** - Click once to deactivate the Macro.
**Right Mouse Click** - Opens the context menu.

*Edit...* - Opens the Macro Editor to write, edit, include, and compile Macros.

*Open...* - Loads a Macro from an external file [of the file type *.mms or *.mcm]. Once loaded, the Macro will automatically be activated.

*Copy* -Copies the Macro to the clipboard of the computer.

*Paste* - Pastes the Macro from the clipboard into the currently selected Macro Editor.
- If the copied Macro is running, the new Macro will be automatically activated as well.
- If the copied Macro is deactivated, the new Macro will be automatically deactivated as well.

*Clear* - Removes all content from the Macro Editor and thereby deactivates and erases any Macro. The default content will be restored.

**More Information**

The complete MADRIX Script Language is described in the MADRIX Script Help. In the Windows Start Menu, go to:

- In Windows 7, go to *Start > All Programs > MADRIX 5 > Documentation > Help MADRIX 5 Script*
- In Windows 10, go to *Start > MADRIX 5 > Help MADRIX 5 Script*
//PART I

Cue List
9  Cue List

This topic includes:
- Introduction
- Topics Of This Chapter

Introduction

The Cue List is an automated playlist and scheduler. It offers the possibility to precisely manage the automatic playback of effects.

Topics Of This Chapter

- Cue List
9.1 Cue List

This topic includes:

- Introduction
- Basic Controls
- How To Work With The Cue List
- Setting Up Cues
- Time Code
- Important Notes
- Playback Side
- Live Control
- File Watcher [Automatic Cue List Reloading]

Introduction

The Cue List is an automated playlist. It offers the possibility to precisely manage the automatic playback of effects. Once the Cue List is started, MADRIX will automatically play back your visuals according to your configuration and schedule. That means MADRIX switches from Storage Place to Storage Place [i.e. from effect to effect].

You can open the Cue List in 3 ways:

- Go to the menu Tools > Cue List...
- Or press F7
- Or click Layer Control > Cue List on the user interface.

To close the Cue List and change back to the original MADRIX user interface:

- Go to the menu Tools > Cue List...
- Or press F7
- Or click Cue List > Layer Control on the user interface.
Basic Controls

The main user interface offers 3 control buttons for the Cue List.

- **Go** - Skips to the next Cue.
- **Back** - Returns to the previous Cue.
- **Play/Pause** - Starts or holds playback.

**Layer Control > Cue List** - Opens the actual Cue List window. This is the Cue List itself. Use it to set up your Cue List configuration.

How To Work With The Cue List

Cue List Window

The Cue List window can be used in 2 modes:

- **A** The Cue List is part of the MADRIX user interface. You can switch between different views [e.g., Layer Control, Cue List, Group Control].
- **B** The Cue List can be undocked and used freely as a separate window.
**A] Cue List Docked**

![Cue List Docked Image]

**B] Cue List Undocked**

![Cue List Undocked Image]

**Controls**

**New** - Creates a new Cue List. It also clears all entries from the current Cue List!

**Open** - Loads an already existing Cue List [of the file type *.mclx or *.csv]. Choose the file from your harddisk.

**Open And Attach** - Loads an already existing Cue List [of the file type *.mclx or *.csv] and adds it to the current Cue List.

**Save** - Stores your Cue List in an external file. You can choose to save in standard *.mclx file format; or to save in *.csv file format in order to easily edit the file with a text editor, for example.
Add Cue - Adds a new cue to the Cue List. When a Time Code is received, MADRIX will also automatically add the currently received Time Code to the cue [by filling in the column Time Code].

Remove Cues - Removes all currently selected cues from the list.

Duplicate Cues - Copies the currently selected cues and adds them as new cues to the list.

Cue All - Adds new Cue List entries for all Storage Places that have a MADRIX Effect customized and stored.

# 3 - Displays the total number of cues in the Cue List.

Swap Position - Swaps the position of cues in the list when several cues are selected first.

Position Up - Changes the order, and positions currently selected cues one item higher up in the list.

Position Down - Changes the order, and positions currently selected cues one item lower down in the list.

Play/Pause - Starts or holds playback.

Back - Returns to the previous cue.

Go - Skips to the next cue.

Goto - Jumps to the specified cue. Make sure to enter the correct number in the nearby input field.

Progress - Shows you the relative time progression of the current cue in a progress bar.
**Setting Up Cues**

1] Add new cues to the Cue List by using
   
   A] **Cue** on the user interface,
   
   B] + in the Cue List window, or
   
   C] **Cue All** in the Cue List window.

2] Change each cue as explained in the list below.
   
   - Change values as described above in the section **Controls**
   
   - You can even edit the Cue List while it is playing.
   
   - **Make sure to change the settings for each cue according to your requirements!**
### The first column shows the current playback state [Playing, Pause] and can also be used to perform a **Goto** with the mouse. Perform a double-click on the column in order to start playing from this cue. You can even jump to specific cues during Cue List playback in this way.

### #

- MADRIX automatically numbers each cue consecutively with an index number, beginning with 1.  
  - **Note:** Change this index number in order to quickly change the order of cues. MADRIX will automatically rearrange the list.

### Description

- Automatically fills in a label. This label is based on the Description field of the Storage Place on the user interface. You can change the label if you wish.
<table>
<thead>
<tr>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Defines if the entry will be played at a specific date. You can enter 3 different types:</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td><strong>Daily</strong> -</td>
</tr>
<tr>
<td>This is the default value.</td>
</tr>
<tr>
<td>Enter <strong>0, d, or D</strong> and the cue will be considered every single day.</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>A weekday -</td>
</tr>
<tr>
<td>Enter <strong>m or M</strong> for Monday,</td>
</tr>
<tr>
<td><strong>t</strong> for Tuesday,</td>
</tr>
<tr>
<td><strong>w</strong> or <strong>W</strong> for Wednesday,</td>
</tr>
<tr>
<td><strong>T</strong> for Thursday,</td>
</tr>
<tr>
<td><strong>f</strong> for Friday,</td>
</tr>
<tr>
<td><strong>s</strong> for Saturday,</td>
</tr>
<tr>
<td><strong>S</strong> for Sunday.</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>A specific date -</td>
</tr>
<tr>
<td>Use one of the following formats:</td>
</tr>
<tr>
<td><strong>[Year Month Day]</strong></td>
</tr>
<tr>
<td><strong>2013/12/31</strong></td>
</tr>
<tr>
<td><strong>2013:12:31</strong></td>
</tr>
<tr>
<td><strong>2013;12;31</strong></td>
</tr>
<tr>
<td><strong>2013-12-31</strong></td>
</tr>
<tr>
<td><strong>13-12-31</strong></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td><strong>[Specific Day of Current Month of Current Year]</strong></td>
</tr>
<tr>
<td><strong>01</strong> - First day of this month of this year</td>
</tr>
<tr>
<td><strong>02</strong> - Second day</td>
</tr>
<tr>
<td>etc.</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td><strong>[Specific Day of Specific Month of Current Year]</strong></td>
</tr>
<tr>
<td><strong>01-01</strong> - First day, first month of this year</td>
</tr>
<tr>
<td><strong>01-02</strong> - Second day, second month</td>
</tr>
<tr>
<td>etc.</td>
</tr>
</tbody>
</table>
### Time Code
- Defines a specific time the cue should be played. Use the hours:minutes:seconds:frames format to enter the time: **HH:MM:SS:FF**

  **Example**
  - 10 o'clock and 20 minutes, 30 seconds, and 10 frames
  - Use one of the following formats:
    - 10:20:30:10
    - 10,20,30,10
    - 10.20.30.10
    - 10/20/30/10
    - 10h20m30s10f

  [Short versions for single items]
  - 10h
  - 20m
  - 30s
  - 10f

- **Offset**
  - Works for single or multiple cues.
  - Use **Shift + Right Mouse Click** and enter a number to add an Offset. [Otherwise you are entering the Time Code anew.]
  - Use **Ctrl + Right Mouse Click** and enter a number to subtract an Offset. [Otherwise you are entering the Time Code anew.]

- **Automatic Completion**
  - MADRIX will automatically fill in the Time Code when adding a new cue [if a Time Code is received at the time].

### Duration
- Defines how long an effect is going to be played. The **Fade Time** is calculated as part of the Duration [and is thus a fade in]. Leave the Duration empty if the effect should be active as long as you do not control the Cue List manually [via **Go, Back, Play/Pause**, or **Goto**]. Use the hours:minutes:seconds:frames format to enter the time: **HH:MM:SS:FF** as explained under **Time Code**
### Follow Cue
- You can assign a certain cue to be played after another. As such, a Follow cue assigns the next cue the Cue List should play right after this cue. Follow cues allow you to define a certain order in which cues should be played by the Cue List. Simply enter the number of the cue that should follow. Leave empty if not required.

### Storage
- Defines in which Storage the effect is located. Enter a number between 1 and 256

### Place
- Defines the exact Storage Place, where the effect is located. Enter a number between 1 and 256

### Fade
- Defines the **Fade Type** for the crossfader when the Cue List automatically fades from one effect to another. All Fade Types of the crossfader are available here. Learn more » [Crossfader](#)

### Fade Time
- Defines the length of the automatic fade for the crossfader and thus creates a fade in. Enter a value in seconds:milliseconds format: **SS:MM**. Learn more » [Crossfader](#)

### Group Preset
- Defines which Group Preset is triggered together with this cue. [The Fade Time of the Cue List will automatically be used as the Fade-In Time of the Group Control.] Enter a number between 1 and 256. Leave empty if not required. Learn more » [Fixture Groups [Group Control]](#)

---

### Time Code

#### Overview

![Time Code](image)

**System Time**: 12:48:27:22

25 FPS
Time Code is a useful option to trigger effects at certain times of the day or at certain points in time. For example, you might want to trigger Storage Place S1 P1 at 10:00 a.m. or when 3 minutes have passed after the start. Time Code is a convenient way to synchronize independent equipment of your LED installation with each other. This could be external audio equipment, other MADRIX computers, or even the same computer. You might want to set up a time-controlled show in sync with timelines of lighting effects of MADRIX and sound.

Receiving Time Code is possible with all MADRIX software license versions [including all MADRIX KEYs, MADRIX NEO, and MADRIX PLEXUS].

### Configuration

<table>
<thead>
<tr>
<th>Time Code Source</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Deactivates the usage of Time Code.</td>
</tr>
<tr>
<td>Art-Net</td>
<td>Receives Art-Net Time Code from an Art-Net source [for example, a console, another software, the »MADRIX Time Code Sender, etc.]. You need to activate Art-Net first. Learn more »<a href="Link">Art-Net (DMX Over Ethernet)</a></td>
</tr>
<tr>
<td>MIDI</td>
<td>Receives MIDI Time Code from a MIDI source. You need to activate MIDI first. Learn more »<a href="Link">MIDI-IN Configuration</a></td>
</tr>
<tr>
<td>SMPTE</td>
<td>Receives SMPTE Time Code from the MADRIX USB SMPTE hardware interface. Learn more »<a href="Link">MADRIX I/O</a></td>
</tr>
<tr>
<td>System Time</td>
<td>Uses the internal computer clock [i.e. the clock of the operating system] to generate the Time Code. If the time of your computer system is 10:00 a.m., the generated Time Code will be 10:00:00:00, for example.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Time Code Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>24 FPS</td>
<td>Allows you choose between different Time Code formats. When receiving Time Code from an external source, use the format sent by the external source. You can choose from:</td>
</tr>
<tr>
<td>25 FPS</td>
<td>- 24 FPS</td>
</tr>
<tr>
<td>30 Drop</td>
<td>- 25 FPS</td>
</tr>
<tr>
<td>30 FPS</td>
<td>- 30 Drop[30/1.001 FPS]</td>
</tr>
<tr>
<td></td>
<td>- 30 FPS</td>
</tr>
</tbody>
</table>
**Displays the currently used Time Code. The hours:minutes:seconds:frames format is used: HH:MM:SS:FF**

Learn more » [Time Code [MIDI / Art-Net / SMPTE / System Time]]

**Stop**

According to your configuration, you may have to set the Time Code Source to None to fully stop the Cue List.

**Important Notes**

- Do not forget to save your Cue List or the complete MADRIX Setup file.
- When you are using Date, Time Code, and/or Duration, logical routines are implemented to determine which cue should be currently active. These routines are explained in more detail below.

**Date**

If you are setting up a Date for a cue, 3 options are available to you:

- Daily,
- A specific weekday,
- Or an explicit date.
If you are using a mixture of those three options, a cue will be favored and activated according to the following hierarchy if applicable:

**An explicit date overrides a weekday entry. And a weekday entry overrides a daily entry.**

For example, daily will activate a cue every single day. But on Mondays, another cue should be activated and it will be. But 2010/04/19 is also a Monday and this cue will be activated this day instead of the daily cue and instead of the Monday cue.

**Time Code Without Duration**

- If you are using the column Time Code without the column Duration, a cue will only be activated if the Time Code passes this predefined time.
- If the Time Code of a cue [without Duration] has already passed that deadline, the cue will not be activated.

**Time Code With Duration**

**A**] If you are using the column Time Code and the column Duration, a cue will be activated when the current Time Code falls into this time window.

- A cue using Time Code and Duration will be activated if it falls into the time window.
- In addition, the logical routine will check if the Date needs to be considered according to the information above [Date].
  For example, if your daily cue should start at 8 o'clock for 8 hours and the current Time Code says 10 o'clock, the cue will be activated.

**B**] When using Time Code and Duration, you should be aware of what should happen when the Duration is over. A cue with a Time Code and Duration will expire eventually.

- When a cue with Time Code and Duration is over or has expired, MADRIX will automatically select the next cue; regardless of what the next cue is.
- MADRIX will not check if the next cue is valid or logic. If you do not want MADRIX to select the next cue, use Follow cues for example or make sure the next cue is set up correctly!
Loop Function

- If all cues have been assigned a Duration, the Cue List will automatically start from the beginning again after the last cue.
- If a cue inside the Cue List does not have a pre-defined duration, the Cue List will stop at this cue.
- If you want to stop the Cue List with the last entry, you only have to remove the duration for the last cue in your Cue List.

Playback Side

You can choose how MADRIX manages the user interface when playing back the Cue List.

- Go to the menu Preferences > Options... > User Interface
  [Keyboard shortcut: Ctrl+Alt+O > User Interface]
- **Playback Side** - Defines which sides are used during Cue List playback. Choose from 2 modes:
  
  **Alternating** - MADRIX automatically switches from side to side between Deck A and Deck B.
  - Example: The first Cue will be played on Deck A of the user interface, the second Cue on Deck B, the third Cue on Deck A again, and so on.
  
  **By Storage ID Parity** - MADRIX will decide which side to use depending on the Storage ID.
  - Cues that refer to an odd Storage ID [e.g., Storage 1 or Storage 3] will be played back on Deck A only.
  - Cues that refer to an even Storage ID [e.g., Storage 2 or Storage 4] will be played back on Deck B only.

- **D** - Restores the default settings. The default value is By Storage ID Parity.

- Click **Apply** to confirm.
- Click **OK** to close the window.

---

**Live Control**

The majority of controls in MADRIX is disabled while the Cue List is running. The following control controls are available to you even during Cue List playback:

- Cue List and Cue List controls
- Submaster Deck A / Deck B
- Color Filter Deck A / Deck B
- Filter Deck A / Deck B
- Speed Masters Deck A / Deck B, including Pause

Learn more » [Controls [Deck A / Deck B]]

- Crossfader
- Main Output Color Filter
- Main Output Filter
- Main Output Strobe
Learn more »**Crossfader**

- Master, including Freeze and Blackout
- Audio Output Level, including Mute
- Audio Input Level, including AGC and Mute

Learn more »**Main Output / Master / Audio Levels**

- Group Control

Learn more »**Fixture Groups [Group Control]**

---

**File Watcher [Automatic Cue List Reloading]**

MADRIX can automatically reload a Cue List within a predefined refresh time.

Learn more »**General**
//PART J

Extra Tools And 3rd-Party Software
10 Extra Tools And 3rd-Party Software

This topic includes:

- Introduction
- Topics Of This Chapter

Introduction

A number of separate tools [programs] are automatically installed together with MADRIX. They serve different purposes and are very useful when working with MADRIX.

Additionally, MADRIX can work together with certain 3rd-party applications.

Topics Of This Chapter

Learn more about separate tools:

- »MADRIX 5 Fixture Editor
- »MADRIX 5 Device Updater
- »MADRIX 5 KEY Firmware Updater
- »MADRIX 5 Quick Support
- »MADRIX 5 Restore
- »MADRIX 5 Time Code Sender
10.1 MADRIX 5 Fixture Editor

This topic includes:
- Introduction
- Usage
- Where To Find
- Important Notes
- More Information

Introduction

LED fixtures are implemented using the MADRIX 5 Fixture Editor. The fixtures are stored in the MADRIX Fixture Library [madrix.mfix].
Usage

With the help of the MADRIX 5 Fixture Editor, you can

- see how fixtures are integrated in MADRIX,
- see how many and which fixtures are already included,
- adjust settings to your requirements,
- implement and add fixtures to the library yourself.

Where To Find

MADRIX 5 Fixture Editor is included in the MADRIX Installer. After installing MADRIX 5, you can find the link to the tool in the Windows Start menu:

- In Windows 7, go to Start > All Programs > MADRIX 5 > MADRIX 5 Fixture Editor
- In Windows 10, go to Start > MADRIX 5 > MADRIX 5 Fixture Editor

The original, executable program can be found in the MADRIX installation directory:

- C:\Program Files\MADRIX5

Important Notes

- Always make a backup of the madrix.mflx before and after applying any changes.
- When updating your MADRIX Software, the Setup [Auto Installer] will automatically create a "madrix.mflx.bak". This file is a backup of your old MADRIX Fixture Library. Moreover, the Setup will overwrite the current madrix.mflx completely to update the library.
- Please quit MADRIX before using the Fixture Editor and making any changes to the MADRIX Fixture Library.
More Information

- You can learn more in the separate user guide for the MADRIX Fixture Editor.

10.2 MADRIX 5 Device Updater

Coming soon.
10.3 MADRIX 5 KEY Firmware Updater

This topic includes:
- Introduction
- MADRIX KEY Firmware Update

Introduction

The MADRIX KEY itself is a technologically advanced device. That is why it also comes with its own firmware. In order to function correctly, the MADRIX Software requires a minimum firmware version for the MADRIX KEY.

MADRIX KEY Firmware Update

Overview

Make sure that your MADRIX KEY uses the correct firmware. You can update the MADRIX KEY firmware in different ways.

- MADRIX Software Installation
- Windows Start Menu
- First Software Start
- Help Menu

MADRIX Software Installation

During the MADRIX Software setup, you can choose to automatically update all connected USB software protection dongles.
● Make sure to select MADRIX KEY Firmware Update
   [Deselect it if you don’t want to update any connected USB security dongles now.]

Windows Start Menu

You can find the link to the MADRIX 5 KEY Firmware Updater in the Windows Start menu:

● In Windows 7, go to **Start > All Programs > MADRIX 5 > Tools > MADRIX 5 KEY Firmware Updater**

● In Windows 10, go to **Start > MADRIX 5 > MADRIX 5 KEY Firmware Updater**

First Software Start

When starting a new MADRIX Software version for the first time, the MADRIX Software will automatically check if the connected MADRIX KEY uses an older firmware version.
Click Yes in order to continue and update all connected USB software protection dongles.
- Only connect MADRIX KEYS that should be updated.
- Unplug all dongles that should not be updated.
- Do not unplug any dongles during the update process.

Click No if you do not wish to continue to update the connected USB software protection dongles.
- Note: Your MADRIX Software will not be able to recognize any MADRIX KEY that uses a firmware that is older than the required firmware version.

Help Menu

You can also find the link to the MADRIX 5 KEY Firmware Updater in the MADRIX Software:

- Go to the menu Help > MADRIX KEY > Update MADRIX KEY Firmware...
10.4 MADRIX 5 Quick Support

This topic includes:
- Introduction
- Instructions
- Where To Find

Introduction

Along with the MADRIX Software another separate tool is provided. It is called MADRIX 5 Quick Support.

Instructions
When contacting the MADRIX Support Team, you may be asked by them to use the MADRIX 5 Quick Support tool for technical support assistance on your computer.

Click on the shortcut in order to launch it [see below where to find it].

After the tool has been launched, wait until **Ready to connect (secure connection)** is shown.

![Ready to connect (secure connection)](image)

The MADRIX Support Team will then be able to connect to your computer.

A new message window opens that reads: **'MADRIX would like to view and control your desktop. Would you like to allow that?'**

Please confirm by clicking **Allow**

![MADRIX - Remote control](image)

The MADRIX Support Team will now be connected.

**Where To Find**

MADRIX 5 Quick Support is included in the MADRIX Installer. After installing MADRIX 5, you can find the link to MADRIX 5 Quick Support in the Windows Start menu:

- In Windows 7, go to **Start > All Programs > MADRIX 5 > Tools > MADRIX 5 Quick Support**
- In Windows 10, go to **Start > MADRIX 5 > MADRIX 5 Quick Support**

The original, executable program can be found in the MADRIX installation directory:

- C:\Program Files\MADRIX5
10.5 MADRIX 5 Restore

This topic includes:
- Introduction
- Usage
- Where To Find

Introduction

Along with MADRIX another separate tool is provided. It is called _MADRIX 5 Restore_

Usage
MADRIX 5 Restore should mainly be used, when it is impossible for you to start the MADRIX Software for any reason.

**MADRIX Restore is a tool including advanced options and should not be used without reason!**

- MADRIX 5 Restore is used for all settings that are locally stored on your computer and written into the Windows Registry.
  Often, such settings can be configured in the Options. Learn more »Options
- MADRIX 5 Restore is not a tool to manage your MADRIX files, whichever files that may be [e.g., MADRIX Setup files].

MADRIX 5 Restore can be used for several, specific tasks.

**Version** - Allows you to select the kind of software version you are using. The default version is MADRIX5.
- **MADRIX5** - Includes any final release version of MADRIX 5.
- **MADRIX5 RC** - Includes any version of MADRIX 5 that is labeled as Release Candidate test version [RC].
- **MADRIX5 BETA** - Includes any version of MADRIX 5 that is labeled as BETA test version [BETA].
- **MADRIX5 Fixture Editor** - Includes the MADRIX 5 Fixture Editor.

**Reset To Default Settings** - Resets all settings of MADRIX, just like installing MADRIX on a computer for the first time.

**Reset To Fail-Safe Settings** - Resets all settings of MADRIX and at the same time deactivates any settings that might prevent MADRIX to start fully.

**Open** - Loads settings from an external file. [In this way you can open a backup of your settings or transfer settings from one computer to another computer].
**Save** - Saves MADRIX settings to an external file in order to store them. [In this way you can create a backup of your settings or transfer settings from one computer to another computer].

**Where To Find**

MADRIX 5 Restore is included in the MADRIX Installer. After installing MADRIX, you can find the link to MADRIX 5 Restore in the Windows Start menu:

- In Windows 7, go to **Start > All Programs > MADRIX 5 > Tools > MADRIX 5 Restore**
- In Windows 10, go to **Start > MADRIX 5 > MADRIX 5 Restore**

The original, executable program can be found in the MADRIX installation directory:

- `C:\Program Files\MADRIX5`
10.6 MADRIX 5 Time Code Sender

This topic includes:
- Introduction
- Usage
- Step-By-Step Instructions
- Configuration
- Where To Find

Introduction

MADRIX 5 Time Code Sender is a separate tool.
The small application sends out Time Code. This is particularly useful in combination with the Cue List.

- Time Code is a convenient way to synchronize independent equipment with each other.
  - This could be external audio equipment, other MADRIX computers, or even the same computer.
  - You might want to set up a time-controlled show in sync with timelines of sound and lighting effects of MADRIX.
- The Cue List is the automated playlist feature of MADRIX.
  - When using the Cue List, you can use Time Code to trigger effects at certain times of the day or at certain points in time.
  - For example, you might want to trigger Storage Place S1 P1 at 10:00 a.m. or when 3 minutes have passed after the start, for example.
- In the Cue List, you can choose to receive Time Code [None, Art-Net, MIDI, SMPTE, System Time].
- Receiving Time Code is possible with all MADRIX 5 Licenses.
- You can use the MADRIX 5 Time Code Sender to generate such Time Code.

Learn more » Cue List

Usage

You can use MADRIX 5 Time Code Sender to produce Time Code [i.e. Art-Net Time Code] and send it to devices in an Ethernet network. The data will be sent via Broadcast to all receivers in the network. As explained above, MADRIX can be such a recipient.

Example 1

- You are using two MADRIX computers to control two independent areas of LED products. [Although you could control both areas with one MADRIX computer, it makes sense to use two computers because of the distance between the areas.] At night, both LED areas should show similar effects and you wish to synchronize the Cue List of both computers.
- You can use the MADRIX 5 Time Code Sender to synchronize the Cue Lists of both computers.

Example 2
You wish to create a time-controlled show on one computer that starts at 00:00 and runs for 10 minutes. Using the System Time would not help you in this case, but the MADRIX 5 Time Code Sender will be useful.

**Step-By-Step Instructions**

1. Configure the MADRIX Software according to your needs [including all Effects, etc.].
2. Activate »Art-Net [DMX Over Ethernet]: In MADRIX, go to the menu Preferences > Device Manager... > Art-Net. Activate the checkbox Enable [in the upper, right corner]. Close the window afterwards.
3. Create a »Cue List [including Time Code and/or Duration].
   - If you want to synchronize multiple MADRIX computers, set up a Cue List for each MADRIX Software.
5. Start sending Time Code with the help of the MADRIX Time Code Sender. Learn more [Configuration](#).

It is not important if you open MADRIX 5 or the MADRIX 5 Time Code Sender first, and then the other program.

**Configuration**

Please set up the MADRIX Time Code Sender according to the following parameters:

*Play/Pause* - Starts or pauses sending Time Code.

*Stop* - Fully stops sending Time Code. And automatically resets the Time Code to zero [00:00:00:00] or to the corresponding Start Code.
**Freeze** - Freezes the Time Code generation and the display, but the Time Code will still be generated in the background. Deactivate the button to see and send the current Time Code again. You can also stop generating new Time Code when Freeze is active.

**Rewind** - Rewinds the Time Code back to zero [00:00:00:00] or to the corresponding Start Code; even if Time Code is running.

**Time Code** - The generated Time Code is displayed in the following format: *HH:MM:SS:FF [00:00:00:00]*, meaning *hours : minutes : seconds : frames*.

**Presets** - You can use 42 presets to quickly set up and utilize individual Start Codes.

**Preset Configuration** - Use the configuration button to set up the Start Code presets.

**HostName**
- Displays the name of the computer.

**IP Addresses**
- Displays the IP address of the computer. Several addresses are shown when the computer has multiple network cards.

**SMPTE Rate**
- Provides four modes on how the Time Code is generated.

- **24 FPS** [Standard frame rate for films]
- **25 FPS** [Standard frame rate for PAL video]
- **30 Drop** [30/1.001 FPS drop-frame time code for color NTSC video]
- **30 FPS** [Monochrome NTSC video]
**Start Code**

- You can define a start time, when the Time Code counter should start. By default it starts at 00:00:00:00.

**Use System Time**

- You can use the local clock of your computer to generate Time Code. The computer time will be used.

---

**Where To Find**

MADRIX 5 Time Code Sender is included in the MADRIX Installer. After installing MADRIX 5, you can find a link to the tool in the Windows Start menu:

- In Windows 7, go to **Start > All Programs > MADRIX 5 > Tools > MADRIX 5 Time Code Sender**
- In Windows 10, go to **Start > MADRIX 5 > MADRIX 5 Time Code Sender**

The original, executable program can be found in the MADRIX installation directory:

- C:\Program Files\MADRIX5
11 MADRIX Hardware

This topic includes:
- Introduction
- Topics Of This Chapter

Introduction

Combined with neat hardware products, the MADRIX system is a proven and innovative LED control solution. MADRIX hardware reliably transfers the lighting data to your LEDs and controllers. Any small or large LED installation benefits from prime build quality and outstanding features, such as the built-in synchronization mode that ensures an optimal image on your LEDs without visual interruption.

Topics Of This Chapter

Learn more about separate tools:

- »MADRIX USB ONE
- »MADRIX NEO
- »MADRIX PLEXUS
- »MADRIX LUNA
- »MADRIX NEBULA
- »MADRIX STELLA
- »MADRIX ORION
- »MADRIX I/O
11.1 MADRIX USB ONE

This topic includes:
- Overview
- MADRIX 5 Software License
- Loading The Drivers
- Using DMX Output Or DMX Input
- Further Configuration
- Interruption-Free Operation

Overview

MADRIX USB ONE is a USB 2.0 DMX512 interface. It can be used for input [DMX-IN] or output [DMX-OUT]. The MADRIX USB ONE allows you to control 512 DMX channels in combination with the MADRIX Software.

MADRIX 5 Software License

- The MADRIX 5 Software license is not included and sold separately. A MADRIX 5 KEY is necessary if you want to use DMX output [DMX-OUT].
- No separate license is required for DMX input [DMX-IN].
Loading The Drivers

- Go to the menu Preferences > Options... > Devices USB
- Activate **MADRIX USB ONE / MADRIX NEO**
  [The option is activated by default.]
- Click **Apply** to confirm.
- Click **OK** to close the window.

### Using DMX Output Or DMX Input

The MADRIX USB ONE allows you to send [DMX-OUT] or receive [DMX-IN] data via MADRIX using 512 DMX channels.

- The MADRIX USB ONE features a 5-pin, female XLR connector.
- If you want to use DMX-IN, please use a 5-pin XLR male to 5-pin XLR male gender changer.

Learn more »**DMX512 [DMX-OUT]**
Learn more »**DMX-IN / Art-Net Remote / sACN Input**

### Further Configuration

Remember to configure your light matrix in the »**Matrix Generator** or »**Patch Editor**

Make sure to save your MADRIX Setup after the configuration process.

### Interruption-Free Operation
To ensure interruption-free operation of the software and devices, please make sure to check the power-saving settings of Windows.
Learn more »[PC Power Management]
11.2 MADRIX NEO

This topic includes:

- Overview
- Important Note
- MADRIX 5 Software License
- Loading The Drivers
- Using DMX Output or DMX Input
- Further Configuration
- Interruption-Free Operation

Overview

MADRIX NEO is a USB 2.0 DMX512 interface. It can be used for input [DMX-IN] or output [DMX-OUT]. The MADRIX NEO allows you to control 512 DMX channels in combination with the MADRIX Software.

Important Note

- Make sure to read the provided MADRIX NEO Quick Start Guide & Technical Manual first!
  Find it in your product box or download it from »help.madrix.com
MADRIX 5 Software License

- The MADRIX 5 Software license is not included and sold separately. A MADRIX 5 KEY is necessary if you want to use DMX output [DMX-OUT].
- No separate license is required for DMX input [DMX-IN].

Loading The Drivers

- Go to the menu Preferences > Options... > Devices USB
  [Keyboard shortcut: Ctrl+Alt+O > Devices USB]
- Activate **MADRIX USB ONE / MADRIX NEO**
  [The option is activated by default.]
- Click **Apply** to confirm.
- Click **OK** to close the window.

### Using DMX Output Or DMX Input

The MADRIX NEO allows you to send [DMX-OUT] or receive [DMX-IN] data via MADRIX using 512 DMX channels.

- The MADRIX NEO features a 5-pin, female XLR connector.
- If you want to use DMX-IN, please use a 5-pin XLR male to 5-pin XLR male gender changer.

Learn more »[DMX512 [DMX-OUT]]
Learn more »[DMX-IN / Art-Net Remote / sACN Input]

### Further Configuration

Remember to configure your light matrix in the »[Matrix Generator] or »[Patch Editor].

Make sure to save your MADRIX Setup after the configuration process.

### Interruption-Free Operation
To ensure interruption-free operation of the software and devices, please make sure to check the power-saving settings of Windows.

Learn more » [PC Power Management]
11.3 MADRIX PLEXUS

This topic includes:

- Overview
- Important Note
- MADRIX 5 Software License
- More Information

Overview

MADRIX PLEXUS is a USB 2.0 DMX512 interface or Art-Net node.

The device can be used as a live controller [Live Mode] or stand-alone interface [Stand-Alone Mode].

Important Note

- Make sure to read the provided MADRIX PLEXUS Quick Start Guide & Technical Manual first!

  Find it in your product box or download it from »help.madrix.com
MADRIX 5 Software License

- The MADRIX 5 Software license is not included and sold separately. A MADRIX 5 KEY is necessary if you want to use DMX output [DMX-OUT] or Art-Net output.
- No separate license is required for DMX Input [DMX-IN].

More Information

MADRIX PLEXUS offers a lot features. Because of this, a separate, complete guide is available. You can find the majority information about the MADRIX PLEXUS in the

- MADRIX PLEXUS Quick Start Guide & Technical Manual
  Download it from »help.madrix.com

- MADRIX PLEXUS User Manual
  Download it from »help.madrix.com
11.4 MADRIX LUNA

This topic includes:
- Overview
- Important Notes
- LED Status Codes
- Automatic HTP Merging
- Reset To Factory Default Settings
- Using A 3rd-Party Controller
- Using The MADRIX Software
- MADRIX Device Configuration
- Firmware Updates

Overview
MADRIX LUNA is an easy-to-use and reliable Art-Net node. The MADRIX LUNA reliably distributes DMX512 data over long or short distances using Ethernet network or USB. Its sync mode makes sure that lighting effects look their best on the LEDs.

3 versions are available:

- MADRIX LUNA 4
- MADRIX LUNA 8
- MADRIX LUNA 16

**Important Notes**

- Make sure to read the provided MADRIX LUNA Quick Start Guide & Technical Manual first!
  Find it in your product box or download it from »help.madrix.com

**LED Status Codes**

The following tables describe the LED status codes on the front of the device.

<table>
<thead>
<tr>
<th>STATUS</th>
<th>POWER</th>
</tr>
</thead>
<tbody>
<tr>
<td>Powered off</td>
<td>Power cable not connected.</td>
</tr>
<tr>
<td></td>
<td>➔ The device has no power.</td>
</tr>
<tr>
<td>Permanently green</td>
<td>Connected to power.</td>
</tr>
<tr>
<td></td>
<td>➔ The power is on.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>STATUS</th>
<th>ETHERNET</th>
<th>USB</th>
</tr>
</thead>
<tbody>
<tr>
<td>Powered off</td>
<td>Ethernet not connected or the device has no power.</td>
<td>USB not connected or the device has no power.</td>
</tr>
</tbody>
</table>
Automatic HTP Merging

Overview

- MADRIX LUNA features automatic HTP merging from 2 Art-Net sources.

[Usually, the first source will be MADRIX. The second source could be a console, for example.]

- Data from both source will be merged together and sent out as 1 signal. This happens across all 8 output ports and by using the HTP principle.

- **HTP** - Is the acronym for Highest Takes Precedence. Data from both sources will be compared for each individual channel. The higher value wins per channel.

- **Example:** We are using an LED fixture with a total of 5 control channels [3 color channels and 2 movement channels]. MADRIX should provide the color data for channels 1 to 3 and the console should provide the movement data for channels 4 and 5. Using the MADRIX Fixture Editor, we could create a corresponding fixture where channel 4 and 5 are set up as Fixed channel using always a value of 0. On the other hand, the console will always send a value of 0 for the first 3 channels of each fixture. This will ensure that the data from the console will always provide the higher value on channels 4 and 5, while MADRIX provides the color data. Due to the automatic HTP merging of the device, the LED fixture will receive correct data from both sources as desired.
Configuration And Recommendations

1] Correctly set up and enable Art-Net for each source.

2] Make sure to activate ArtSync for Art-Net in MADRIX. Learn more Sync Mode

3] Make sure that MADRIX has a lower IP address compared to the second source.
   [E.g., 2.0.0.1 compared to 2.0.0.20]

4] Always use Unicast Mode in MADRIX to directly send data to the correct IP addresses of your MADRIX LUNA devices.
   [It is not recommend to have any of the two sources or any other source in the network to send data via Broadcast Mode.]

Reset To Factory Default Settings

Reset Via Reset Button

- Disconnect MADRIX LUNA from power.
- Use a suitable tool to press the reset button on the unit’s back side.
- Continue to press the reset button and connect to power again.
- Continue to press the reset button and wait until all status LEDs on the front of the device flash repeatedly or wait 10 seconds.

Reset Via USB [MADRIX 5 Device Updater / MADRIX 5 LUNA Updater]

- Connect MADRIX LUNA to power.
  [Please see safety instructions in the MADRIX LUNA Quick Start Guide & Technical Manual!]
- Connect MADRIX LUNA to your computer via USB.
  [Use the provided USB cable.]
- Close the MADRIX Software.
- Start the separate MADRIX 5 Device Updater tool.
  [In Windows 7, go to Start > All Programs > MADRIX 5 > Tools > MADRIX 5 Device Updater]
  [In Windows 10, go to Start > MADRIX 5 > MADRIX 5 Device Updater]
• Select **Load LUNA 4 / 8 / 16** and confirm with **OK**

• In the MADRIX LUNA Updater, click **Reset To Factory Default Settings (F4)**

• Wait for the reset process to end [usually it takes only seconds].

  Learn more **MADRIX 5 LUNA Updater**

---

**Using A 3rd-Party Controller**

**Overview**

MADRIX LUNA is a standard Art-Net node. Because of this, you can use the device with applications, consoles, desks, or controllers that are compatible with Art-Net to distribute Art-Net data via Ethernet network.

**Web Device Configuration Page**

When connected to Ethernet network, you can easily configure MADRIX LUNA using the built-in web configuration interface.

You have 2 options to access the web interface. Both, LUNA and your computer, need to be in the same network.

**A**] Using a standard web browser:

• Connect MADRIX LUNA and your computer to the same network.

• Assign correct network settings for your PC in the Windows operating system.

  [Recommended default settings: IP address 10.0.0.1 / Subnet mask 255.0.0.0]

• Open your web browser and enter the IP address of MADRIX LUNA.

  [You can find the default IP address on the back side of the device.]

• The web configuration page will be launched. Now, you have access to various information and settings.

**B**] Using the MADRIX Software:

• Connect MADRIX LUNA and your computer to the same network.
- Assign correct network settings for your PC in the Windows operating system.
  [Recommended default settings: IP address 10.0.0.1 / Subnet mask 255.0.0.0]

- Go to the menu **Tools > MADRIX Device Configuration...**
  [Keyboard shortcut: *Ctrl+Alt+L*]

- Select your MADRIX LUNA device in the list.

- Click ![HTTP]( HTTP )

- Your default web browser will open and the web configuration page will be launched. Now, you have access to various information and settings.
### Device Name

**MADRIX LUNA 8**

**Set**

### Device Settings

<table>
<thead>
<tr>
<th>IP Address</th>
<th>10</th>
<th>206</th>
<th>222</th>
<th>138</th>
</tr>
</thead>
<tbody>
<tr>
<td>Subnet Mask</td>
<td>255</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

**Set**

### DMX Output Settings

<table>
<thead>
<tr>
<th>Output Port</th>
<th>Art-Net Universe</th>
<th>Send Always Full Frames (512 CH)</th>
</tr>
</thead>
<tbody>
<tr>
<td>DMX 1</td>
<td>0x0000</td>
<td></td>
</tr>
<tr>
<td>DMX 2</td>
<td>0x0001</td>
<td></td>
</tr>
<tr>
<td>DMX 3</td>
<td>0x0002</td>
<td></td>
</tr>
<tr>
<td>DMX 4</td>
<td>0x0003</td>
<td></td>
</tr>
<tr>
<td>DMX 5</td>
<td>0x0004</td>
<td></td>
</tr>
<tr>
<td>DMX 6</td>
<td>0x0005</td>
<td></td>
</tr>
<tr>
<td>DMX 7</td>
<td>0x0006</td>
<td></td>
</tr>
<tr>
<td>DMX 8</td>
<td>0x0007</td>
<td></td>
</tr>
</tbody>
</table>

**In Case Of Data Connection Loss**

- On Each Affected Port
- Send The Last Received Frame Continually

**Set**

### Network Output

<table>
<thead>
<tr>
<th>DMX-IN Port</th>
<th>Send To Art-Net Universe</th>
<th>Full Frames</th>
<th>Broadcast Mode</th>
<th>Unicast Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>256</td>
<td>256</td>
<td>256</td>
<td>256</td>
</tr>
</tbody>
</table>

**Set**

### Device Information

<table>
<thead>
<tr>
<th>Model</th>
<th>MADRIX LUNA 8</th>
</tr>
</thead>
<tbody>
<tr>
<td>IP Address</td>
<td>10.206.224.13</td>
</tr>
<tr>
<td>MAC Address</td>
<td>40 D8 55 05 E0 0D</td>
</tr>
<tr>
<td>Serial Number</td>
<td>LUNA000013</td>
</tr>
<tr>
<td>Firmware</td>
<td>1.6.7134 (Build Date: Jun 22, 2018 14:10:13)</td>
</tr>
<tr>
<td>Bootloader</td>
<td>1.4.5981 (Build Date: Feb 17, 2016 21:15:33)</td>
</tr>
<tr>
<td>Hardware</td>
<td>1.0</td>
</tr>
</tbody>
</table>
**Device Name**
You can change the description of the device. Enter a name and confirm with **Set**. This label is only shown in this web interface.

**Device Settings**
You can change the IP address and Subnet Mask. Enter the specific addresses and confirm with **Set**.

**DMX Output Settings**
This section shows specific settings for the DMX output ports [DMX 1 - 4/8/16].
By default, Art-Net universe 1 - 4/8/16 are assigned to DMX 1 - 4/8/16. [This is the recommended setting when using one MADRIX LUNA].

If you are broadcasting data for a large number of Universes [using Broadcast Mode instead of using Unicast Mode] with MADRIX or a 3rd-party controller for example, you can assign different DMX universes to each LUNA device with these settings. Each MADRIX LUNA will then only receive data from the specific Art-Net universe and send it to its specified output port. Example: You can set up that LUNA 8 #1 only listens to Art-Net universe 1 - 8, while LUNA 8 #2 listens to Art-Net universe 9 - 16, and LUNA 8 #3 listens to Art-Net universe 17 - 24, and so on.

**Send Always Full Frames (512 CH)** - Is another specific setting. The XLR DMX output port will always send out 512 channels, even if the data sent to LUNA includes less than 512 channels for this port and universe. LUNA automatically sends values of 0 on channels that are not used.

**In Case Of Data Connection Loss** - Is only available in the web configuration page. Allows you to specify the output settings of the LUNA should the device not receive data anymore for a specified DMX universe. Choose from the following options:

- **Send The Last Received Frame Continually**
- **Send Black Frames Continually**
- **Stop Sending After Sending A Black Frame**
- **Stop Sending**
**DMX Input Settings**

This section allows you to specify settings for DMX input. When data is received through the DMX-IN port, MADRIX LUNA will automatically forward it to Ethernet network.

LUNA can receive 512 channels via the DMX-IN port. Use **Send To Art-Net Universe** to specify on which Art-Net universe those 512 channels are sent. By default, **256** is selected. Valid values range from 1 to 256.

**Send Always Full Frames (512 CH) To Art-Net** - Is another specific setting. The XLR DMX input port will always send out 512 channels, even if the data sent to LUNA includes less than 512 channels for this port and universe. LUNA automatically sends values of 0 on channels that are not used.

Additionally, choose to how MADRIX LUNA sends the data into the network:

- Use **Broadcast Mode** if LUNA should sent to all IP addresses in the network. Use **Unicast Mode** to specify one recipient, e.g. your MADRIX computer [Enter the IP address of your MADRIX computer].
- Confirm with **Set**

**Device Information**

This section displays various details about the device, including:

- **Model** [Device type]
- **IP Address** [The current IP address.]
- **MAC Address** [A permanent, unique address.]
- **Serial Number**
- **Firmware** [The current firmware version.]
- **Bootloader** [The current bootloader version.]
- **Hardware** [Hardware revision/model]

**Using The MADRIX Software**
The MADRIX LUNA works great in combination with the MADRIX Software.

**MADRIX 5 Software License**

- The MADRIX 5 Software license is not included and sold separately. A MADRIX 5 KEY is necessary if you want to use output.
- No separate license is required for DMX Input [DMX-IN].

**Operating Modes**

You can mainly use 4 operating modes together with MADRIX:

- **DMX-OUT Via Ethernet Network [Art-Net]**
- **DMX-OUT Via USB**
- **DMX-IN Via Ethernet Network [Art-Net Remote]**
- **DMX-IN Via USB**

**Notes:**

- DMX-OUT and DMX-IN can be used at the same time.
- You always have 1 to 4/8/16 output ports available [DMX 1 - 4/8/16].
  - In total, 2048 DMX channels can be sent per LUNA 4 unit.
  - In total, 4096 DMX channels can be sent per LUNA 8 unit.
  - In total, 8192 DMX channels can be sent per LUNA 16 unit.
- You always have 1 DMX input port available per unit [DMX-IN].
  - In total, 512 DMX channels can be received per unit.

**DMX-OUT Via Ethernet Network [Art-Net]**

**Overview**
You can connect the LUNA via Ethernet network to the network card of your computer that runs the MADRIX software. Data is sent to the LUNA via network [Ethernet] and distributed to the XLR output ports [DMX 1 - 4/8/16].

1] Initial Configuration

- Connect your LED controllers or fixtures to the XLR ports of MADRIX LUNA [DMX 1 - 4/8/16].
- Connect MADRIX LUNA to power.
  [Please see safety instructions in the MADRIX LUNA Quick Start Guide & Technical Manual!]
- Connect MADRIX LUNA to your computer using network cabling.
- It is highly recommended to only use Gigabit Ethernet network components [network card, switches, etc.].

2] Windows Network Settings

Art-Net is a network-based protocol. MADRIX will use the network card of your computer to send data.

- It is required to set up the correct network settings in Windows, first.
- You must use these IP address and Subnet mask settings. Otherwise, Art-Net might not work!
- The IP addresses of your computer and your MADRIX LUNA devices need to be different.

- Set up an individual IP address in the following IP address range:
  - 2.0.0.1 ... 2.255.255.254 or
  - 10.0.0.1 ... 10.255.255.254
- Set up the corresponding Subnet mask
  - 255.0.0.0

  [Via factory default settings, MADRIX LUNA devices will have an IP address in the 10.x.x.x network range, such as 10.206.224.100, for example].

- Restart MADRIX, if you have changed the network settings in Windows while MADRIX was running.
- Learn more »Tips [Microsoft Windows / Networks / USB]

- Example for PCs that are running MADRIX:
3] Fixture Configuration In MADRIX

- Start MADRIX.
- Configure the virtual LED matrix using the »Matrix Generator or »Patch Editor

4] Activating Art-Net

- Go to the menu Preferences > Device Manager... > Art-Net
  [Keyboard shortcut: F4 > Art-Net]
- Activate the checkbox Enable [in the upper, right corner].
5] Adding Devices Automatically

MADRIX can automatically add your MADRIX LUNA devices.

- Click ![Search Icon]

  [MADRIX will automatically search the network for connected MADRIX LUNA devices. Devices that are found will appear in the list. A number of entries will be created in the list for each LUNA device.]

  [The Art-Net standards only supports a maximum of 4 output ports per device. Since LUNA 8 features 8 ports plus 1 IN port, 3 list items are created in MADRIX, for example. Two entries will be shown for LUNA 4. Five entries will be shown for LUNA 16.]
6] Activating Devices

Each of your MADRIX LUNA devices and its ports need to be activated. By default, they are still deactivated. 4 ports will be shown for LUNA 4 [plus an additional IN port], 8 ports will be shown for LUNA 8 [plus an additional IN port], and 16 ports will be shown for LUNA 16 [plus an additional IN port].
- Go to the menu **Preferences > Device Manager... > DMX Devices**  
  [Keyboard shortcut: **F4**]

- Select your devices and their ports in the list.

- Activate **Enable**

- **Output** is activated by default.

- Click **Apply**

![Device Manager Screen](image)

- [In the screenshot above, one LUNA 8 is connected. If more devices are connected, please use the different IP addresses of different devices to identify them in the Device Manager.]

### 7] Configuration Of DMX Output

- Make sure that your devices are still selected under **Preferences > Device Manager... > DMX Devices**

- Set up **Universe**
  - Enter the specific DMX universe number.

- This setting assigns a specific DMX universe [of the Patch] to the device or the port of the device.
- **Make sure the correct universe is assigned according to your requirements.**
  
  Learn more »[Glossary](#)
  
- **Click **Apply**

- By default, DMX universe 1 - 4/8/16 are assigned to the ports DMX 1 - 4/8/16 when using one MADRIX LUNA:

<table>
<thead>
<tr>
<th>LUNA Output Port</th>
<th>Name under Device Manager... &gt; DMX Devices</th>
</tr>
</thead>
<tbody>
<tr>
<td>DMX 1</td>
<td>BindIdx1 Port:0</td>
</tr>
<tr>
<td>DMX 2</td>
<td>BindIdx1 Port:1</td>
</tr>
<tr>
<td>DMX 3</td>
<td>BindIdx1 Port:2</td>
</tr>
<tr>
<td><strong>DMX 4</strong></td>
<td><strong>BindIdx1 Port:3</strong></td>
</tr>
<tr>
<td>DMX 5</td>
<td>BindIdx2 Port:0</td>
</tr>
<tr>
<td>DMX 6</td>
<td>BindIdx2 Port:1</td>
</tr>
<tr>
<td>DMX 7</td>
<td>BindIdx2 Port:2</td>
</tr>
<tr>
<td><strong>DMX 8</strong></td>
<td><strong>BindIdx2 Port:3</strong></td>
</tr>
<tr>
<td>DMX 9</td>
<td>BindIdx3 Port:0</td>
</tr>
<tr>
<td>DMX 10</td>
<td>BindIdx3 Port:1</td>
</tr>
<tr>
<td>DMX 11</td>
<td>BindIdx3 Port:2</td>
</tr>
<tr>
<td>DMX 12</td>
<td>BindIdx3 Port:3</td>
</tr>
<tr>
<td>DMX 13</td>
<td>BindIdx4 Port:0</td>
</tr>
<tr>
<td>DMX 14</td>
<td>BindIdx4 Port:1</td>
</tr>
<tr>
<td>DMX 15</td>
<td>BindIdx4 Port:2</td>
</tr>
</tbody>
</table>
8] Frame Time

- Make sure that your device is still selected under **Preferences > Device Manager... > DMX Devices**

- Set up **Frame Time (ms)**
  - The Frame Time affects the Frame Rate. The Frame Rate specifies how fast data is sent to the device or received from it [Frames Per Second; FPS].
  - Increase the Frame Time in order to decrease the Frame Rate [e.g., 40ms = 25 FPS].
  - Decrease the Frame Time in order to increase the Frame Rate [e.g., 20ms = 50 FPS].
  - The default value is 30 ms / 33.3 FPS.
  - **Some LED fixtures might have problems with a high Frame Rate. Then, it is recommended to increase the Frame Time / to decrease the Frame Rate.**

- Click **Apply**

- [When using Art-Net, the Frame Time [ms] can be individually set for each port. But it cannot be set individually for each port, when Sync Mode is activated. Learn more below.]
9] Optimized Frames Or Full Frames

- Make sure that your device is still selected under Preferences > Device Manager... > DMX Devices
- Activate or deactivate Send Full Frames
  - Per DMX512 standard, MADRIX only sends the number of DMX channels that is configured. For example, if you are using 312 DMX channels on a DMX universe, only 312 DMX channels will be sent with every single frame on this universe [Optimized Frames].
  - Activate Send Full Frames if devices should always send full frames on a particular universe, instead of optimized frames. Sending full frames means that always the full 512 DMX channels of a DMX universe will be sent with every frame [even when you are using less than 512 channels].
  - Activating Send Full Frames is recommended if problems with the data output on your LEDs occur.
- Click Apply

- In addition, you can activate Full Frames for the device and each MADRIX LUNA output port separately.
  Learn more MADRIX Device Configuration

10] Sync Mode

MADRIX LUNA can use the special sync mode of Art-Net.

- Large LED projects require dependable data distribution. The MADRIX software and LUNA hardware allow you to synchronize data output for all 4/8/16 DMX ports and even across multiple LUNA devices to get an optimal image on the LEDs.
- When Art-Net sync mode is activated, MADRIX and MADRIX LUNA will automatically handle the synchronization of data.

Art-Net Sync Mode is highly recommended for MADRIX LUNA!
**ArtSync** - Allows you to activate or deactivate the usage of sync packages for Art-Net.
- Your Art-Net devices need to support this feature in order for it to work correctly.
- All MADRIX hardware Art-Net nodes support ArtSync.

In addition, you can choose between **Post-Sync** [default] and **Pre-Sync**. By default, the sync data is sent after the color data. Pre-Sync would send it before the color data.

- **Before activating sync, make sure that all activated Art-Net devices are available in your network! Else, the frame rate of Art-Net might drop. If you are not sure, do not enable any sync mode.**

### Additional Art-Net Device Settings

It is very important to set up the correct settings for your devices!

**Broadcast Mode Or Unicast Mode**

MADRIX can send Art-Net data in 2 ways to your Art-Net devices:

- **Broadcast Mode** - Means that every packet sent from a single transmitter will be received by all recipients in the network. MADRIX will send data to all devices in the network.
  - Advantage: The same data [e.g., DMX universe 1 and 2] can be made available for different points of your setup.
  - Disadvantage: A potentially huge number of data packages will be sent over the network. This can reduce the overall network performance and cause data issues or instability.

- **Unicast Mode** - Means that the specific data will only be sent to the specified recipient.
  - Advantage: Data traffic is reduced immensely, which means that a larger number of Art-Net devices can be used in one network. Reduced network traffic increases the performance and stability.
  - Disadvantage: The network settings of all devices need to be 100% correct.

Unicast Mode is recommended in general.
- Go to the menu *Preferences > Device Manager... > Art-Net*
  [Keyboard shortcut: *F4 > Art-Net*]
- Select your device in the list.
- Click ![Unicast Mode](image)
- A new window will open.

  **A]** Choose *Send Unicast Mode* to activate Unicast Mode:
  - Make sure to enter the correct *IP Address* of your device that should receive the Art-Net data. When MADRIX LUNA has been automatically found by MADRIX, the IP address will be pre-configured for you.
  - MADRIX will send the corresponding data only to this device.

  **B]** Choose *Send Broadcast Mode* to activate Broadcast Mode:
  - Make sure to select the correct *Network* card of your computer that should send the Art-Net data. When MADRIX LUNA has been automatically found by MADRIX, the correct network will be pre-configured for you.
  - MADRIX will send data to the whole Art-Net network.
- Click *Apply*

### Status Indicators [ArtAddress]

In order to use these features, please *Enable ArtAddress* first.

[Please make sure that your nodes fully support this Art-Net feature, such as MADRIX LUNA, MADRIX NEBULA, MADRIX PLEXUS, MADRIX STELLA. You will also get notified by a message box. Confirm the message with *OK* or abort via *Cancel*]

- **Mute Status Indicators** - Switches off and disables all built-in status indicators of a device over Art-Net [ArtAddress > AcLedMute].

- **Operate Status LEDs Normally** - Allows the built-in status indicators of a device to operate normally again, after having them switched off [ArtAddress > AcLedNormal].
**Highlight Device** - Activates the highlight mode [ArtAddress > AcLedLocate]. Select one or more interfaces and click the button. The corresponding status indicators of the selected interfaces will flash for a better identification or tests. This makes it easier to see them on site/stage. It considerably speeds up the procedure of programming or testing the selected interfaces.

**More Information About Art-Net**

Learn more »[Art-Net (DMX Over Ethernet)]

**DMX-OUT Via USB**

**Overview**

You can connect the LUNA directly via USB to the computer that runs the MADRIX Software. Data is sent to the MADRIX LUNA via USB and distributed to the XLR output ports [DMX 1 - 4/8/16].

**1] Initial Configuration**

- Connect your LED controllers or fixtures to the XLR ports of MADRIX LUNA [DMX 1 - 4/8/16]
- Connect power to MADRIX LUNA.
  [Please see safety instructions in the MADRIX LUNA Quick Start Guide & Technical Manual!]
- Connect MADRIX LUNA to your computer via USB.
  [Use the provided USB cable.]
- Make sure to check the power management options of Windows. Learn more »[PC Power Management]

**2] Fixture Configuration In MADRIX**

- Start MADRIX.
- Configure the virtual LED matrix using the »Matrix Generator or »Patch Editor

3] Enabling Drivers In MADRIX

- Go to the menu Preferences > Options... > Devices USB
  [Keyboard shortcut: Ctrl+Alt+O > Devices USB]

- Activate MADRIX LUNA
  [The option is activated by default.]

- Click Apply

- Close the window with OK
4] Activating Devices

- Go to the menu Preferences > Device Manager... > DMX Devices
  [Keyboard shortcut: F4]

- Your LUNA devices and all of their ports [4/8/16 output ports, 1 input port] will appear in the list.

- If your devices are not in the list, click
  [In the screenshot below, one LUNA 8 is connected.]

- By default, all output ports are activated [State On].

![Device Manager]

- If your device and ports are not activated, do the following:
  - Select the device/port in the list.
  - Activate Enable
  - Activate Output
  - Click Apply

5] Configuration Of DMX Output

- Make sure that your devices are still selected under Preferences > Device Manager... > DMX Devices
Set up **Universe**
- Enter the specific DMX universe number.

This setting assigns a specific DMX universe [of the Patch] to the device or the port of the device.

By default, DMX universe 1 - 4/8/16 are assigned to the ports DMX 1 - 4/8/16 when using one MADRIX LUNA.

**Make sure the correct universe is assigned according to your requirements.**

Learn more »**Glossary**

- Click **Apply**

---

### 6] Frame Time

- Make sure that your device is still selected under **Preferences > Device Manager... > DMX Devices**

- Set up **Frame Time (ms)**
  - The Frame Time affects the Frame Rate. The Frame Rate specifies how fast data is sent to the device or received from it [Frames Per Second; FPS].
  - Increase the Frame Time in order to decrease the Frame Rate [e.g., 40ms = 25 FPS].
  - Decrease the Frame Time in order to increase the Frame Rate [e.g., 20ms = 50 FPS].
  - The default value is 30 ms / 33.3 FPS.
  - **Some LED fixtures might have problems with a high Frame Rate. Then, it is recommended to increase the Frame Time / to decrease the Frame Rate.**

- Click **Apply**

- [When using USB, the Frame Time (ms) will be automatically set to the same value for all output ports.]
7] Optimized Frames Or Full Frames

- Make sure that your device is still selected under Preferences > Device Manager... > DMX Devices
- Activate or deactivate Send Full Frames
  - Per DMX512 standard, MADRIX only sends the number of DMX channels that is configured. For example, if you are using 312 DMX channels on a DMX universe, only 312 DMX channels will be sent with every single frame on this universe [Optimized Frames].
  - Activate Send Full Frames if devices should always send full frames on a particular universe, instead of optimized frames. Sending full frames means that always the full 512 DMX channels of a DMX universe will be sent with every frame [even when you are using less than 512 channels].
  - Activating Send Full Frames is recommended if problems with the data output of your devices occur.
- Click Apply

- In addition, you can activate Send Full Frames for the device and each MADRIX LUNA output port separately.
  Learn more MADRIX Device Configuration

More Information About DMX Output

Learn more »DMX512 [DMX-OUT]

DMX-IN Via Ethernet Network [Art-Net Remote]

Overview

You can connect MADRIX LUNA via Ethernet network directly or indirectly to the network card of your computer that runs the MADRIX Software. Data is sent into the LUNA via DMX-IN [XLR] and from the LUNA to MADRIX via Ethernet network.
1] Initial Configuration

- Connect your external DMX controller to the DMX-IN port of MADRIX LUNA.
- Connect MADRIX LUNA to power.
  [Please see safety instructions in the MADRIX LUNA Quick Start Guide & Technical Manual!]
- Connect MADRIX LUNA directly or indirectly to your computer via network cabling.
- It is highly recommended to only use Gigabit Ethernet network components [network card, switches, etc.].

2] Windows Network Settings

Art-Net is a network-based protocol. MADRIX will use the network card of your computer to receive data.

- **It is required to set up the correct network settings in Windows, first.**
- You must use these IP address and Subnet mask settings. Otherwise, Art-Net might not work!
- The IP addresses of your computer and your MADRIX LUNA devices need to be different and each needs to be unique.

- Set up an individual **IP address** in the following IP address range:
  - 2.0.0.1 ... 2.255.255.254 or
  - 10.0.0.1 ... 10.255.255.254
- Set up the corresponding **Subnet mask**
  - 255.0.0.0

  [Via factory default settings, MADRIX LUNA devices will have an IP address in the 10.x.x.x network range, such as 10.206.224.100, for example].

- **Restart MADRIX, if you have changed the network settings in Windows while MADRIX was running.**
- Learn more » [Tips [Microsoft Windows / Networks / USB]]

3] Activating Art-Net
Go to the menu **Preferences > Device Manager... > Art-Net**   
[Keyboard shortcut: F4 > Art-Net]

- Activate **Enable**

![Device Manager]

---

### 4] Adding Devices Automatically

MADRIX can automatically add your MADRIX LUNA devices.

- Click ![search]

  [MADRIX will automatically search the network for connected MADRIX LUNA devices. Devices that are found will appear in the list. A number of entries will be created in the list for each LUNA device.]

  [The Art-Net standards only supports a maximum of 4 output ports per device. Since LUNA 8 features 8 ports plus 1 IN port, 3 list items are created in MADRIX, for example. Two entries will be shown for LUNA 4. Five entries will be shown for LUNA 16.]
5) Configuration Of Art-Net Input

- Select your LUNA input device in the list [Universe IN].

- Click

- A new window opens [Art-Net Device Configuration].
- **Universe Port IN**
  - By default, MADRIX LUNA sends DMX-IN data to Art-Net universe 256. You can change these settings in the Web Configuration or MADRIX Device Configuration window if required.
  - If you have changed the settings, enter the exact same Art-Net universe here!
- Activate **Receive Direct IP Mode** and enter the **IP Address** of your MADRIX LUNA. Confirm with **Apply** [E.g., 10.206.224.14]
- [You can also activate **Receive Broadcast Mode**. In this mode, MADRIX will receive any DMX data that is sent in the network on this particular Art-Net universe.]
- Click **OK**
6] Activating Your Art-Net Input Device

You need to activate the Art-Net input device. It is still deactivated.

- Go to the menu Preferences > Device Manager... > DMX Devices
  [Keyboard shortcut: F4]

  ![Device Manager](image)

- Select the LUNA input device in the list.
- Activate Enable
- Input is automatically selected.
- Click Apply
If required, change the **Frame Time (ms)**

The higher the Frame Time, the lower the FPS will be. The lower the Frame Time, the higher the FPS will be.

The default Frame Time is 33.

Press **Apply** to confirm.

7) **Activating DMX Input**

- Go to the menu **Preferences > Device Manager... > DMX Input**
Select your preferred DMX **Universe** in the list.

[By default, DMX universe 1 to 8 are listed. If you wish to increase the number of DMX-IN universes, you can change the setting. Learn more »Performance](#)

Choose your **DMX-IN Device** in the section **Device**. Select the **ArtNet** input device.

Art-Net input is now activated. MADRIX can already receive DMX data.
Now, choose how to use incoming data. Learn more »[Art-Net Remote]

DMX-IN Via USB

Overview

You can connect the LUNA directly via USB to the computer that runs the MADRIX software. Data is sent into the MADRIX LUNA via DMX-IN [XLR] and from the LUNA to MADRIX via USB.

1] Initial Configuration

- Connect your external DMX controller to the DMX-IN port of MADRIX LUNA.
- Connect MADRIX LUNA to power.
  [Please see safety instructions in the MADRIX LUNA Quick Start Guide & Technical Manual!]
- Connect MADRIX LUNA to your computer via USB.
  [Use the provided USB cable.]
- Make sure to check the power management options of Windows. Learn more »[PC Power Management]

2] Enabling Drivers In MADRIX

- Go to the menu Preferences > Options... > Devices USB
  [Keyboard shortcut: Ctrl+Alt+O > Devices USB]

- Activate MADRIX LUNA
  [The option is activated by default.]

- Click Apply

- Close the window with OK
3] Activating Devices

- Go to the menu Preferences > Device Manager... > DMX Devices
  [Keyboard shortcut: F4]
- Your LUNA devices and all of their ports [4/8/16 output ports, 1 input port] will appear in the list.
- If your devices are not in the list, click
  [In the screenshot below, one LUNA 8 is connected.]

- Select MADRIX LUNA DMX-IN in the list.
- Activate Enable
- Input is automatically selected.
- Click Apply
• If required, change the **Frame Time (ms)**
  The higher the Frame Time, the lower the FPS will be. The lower the Frame Time, the higher the FPS will be.
  The default Frame Time is 33.
  Press **Apply** to confirm.

6] Activating DMX Input

• Go to the menu **Preferences > Device Manager... > DMX Input**
- Select your preferred DMX *Universe* in the list.
  [By default, DMX universe 1 to 8 are listed. If you wish to increase the number of DMX-IN universes, you can change the setting. Learn more »Performance]
- Choose your *DMX-IN Device* in the section *Device*. Select *MADRIX LUNA - DMX-IN*
DMX-IN is now activated. MADRIX can already receive DMX data.

Now, choose how to use incoming data. Learn more »DMX-IN

MADRIX Device Configuration

You can access information and settings of the web configuration page also in MADRIX using the MADRIX Device Configuration window.

[DMX Output Settings - In Case Of Data Connection Loss is only available in the web configuration page.]

• In MADRIX, go to the menu Tools > MADRIX Device Configuration...
  [Keyboard shortcut: Ctrl+Alt+L]
- Scans the USB ports of your computer and the network for connected MADRIX LUNA devices. If devices are found, they will be shown in the list.
  - To see USB devices, you need to enable LUNA USB drivers first [they are activated by default]. Learn more » [Devices USB]
  - To see network devices, you need to enable LUNA networking drivers [they are activated by default] and connect MADRIX LUNA and your computer to the same network first. Learn more » [Devices Network]

- Refreshes already connected devices and brings the information in the list up to date.

- Allows you to change the settings of your device. Apply your changes by confirming with 'Set'.

- Enables remote access to the web configuration as explained above. MADRIX LUNA needs to be connected via Ethernet [network connection required]. First, connect your computer and the MADRIX LUNA to one and the same network. Second, select your MADRIX LUNA in the list. Third, click this button. A web browser opens automatically.

- Imports the MADRIX LUNA Device Settings from an external file [of the file type *.mldx]. Use this option to easily restore all device settings from a file [as described below].

- Exports the MADRIX LUNA Device Settings to an external file [of the file type *.mldx]. Use this option to easily store all device settings in a file. Simply enter a name in the window that opens and click 'Save'.

- Updates the firmware of your MADRIX LUNA if a newer firmware is available [USB connection required].

Learn more [Web Device Configuration Page]
**Firmware Updates**

**Update Via USB**

- Connect MADRIX LUNA to power.
  [Please see safety instructions in the MADRIX LUNA Quick Start Guide & Technical Manual!]
- Connect MADRIX LUNA to your computer via USB.
  [Use the provided USB cable.]
- Start the MADRIX Software.
- Open the MADRIX Device Configuration window. Go to the menu **Tools > MADRIX Device Configuration...**
- Click ![search](image) to search for connected devices and your device will appear in the list.
- Select your device in the list and click **Firmware**
- Wait for the process to end [usually it takes only seconds].
- Disconnect MADRIX LUNA from power. Afterwards, connect it again.
- [You can also use the MADRIX LUNA Updater. Learn more MADRIX LUNA Updater]

**Update Via Ethernet**

- Connect MADRIX LUNA to power.
  [Please see safety instructions in the MADRIX LUNA Quick Start Guide & Technical Manual!]
- Connect MADRIX LUNA to your computer via Ethernet network.
- In MADRIX, go to the menu **Preferences > Device Manager... > Art-Net**
- Activate **Art-Net**
- Click ![search](image)  
  Learn more DMX-OUT Via Ethernet Network [Art-Net]
- Select the device in the list. Click ![search](image). A new window opens.
- Click **Firmware**
  The update process will starts.
  The MADRIX logo on the front of the device will start to flash and the firmware will be updated.
- Wait for the process to end [usually it takes only seconds].
- Disconnect MADRIX LUNA from power. Afterwards, connect it again.
MADRİX 5 LUNA Updater

Overview

MADRİX 5 LUNA Updater is a separate tool only for MADRIX LUNA. It is integrated into the MADRIX 5 Device Updater.

Usage
MADRIX 5 LUNA Updater can be used for several, specific tasks.

- Updates the firmware of all LUNA devices that are connected to the computer via USB. First, select the correct firmware in the list above this button [Example: LUNA 1.0.000 Type V1.0 MADRIX 5.0]. Second, click the button. Third, disconnect the power after updating in order to restart the device.

- Resets all settings of all LUNA devices that are connected to the computer via USB to the standard values. Use this function to restore the original settings of the device.

- Performs both actions, a LUNA firmware update as well as a reset to factory default settings.

- Additional information on the status of the performed functions will be given on the right side of the window. Information is displayed from down to top [the latest information is shown at the top].

**Important Notes**

- **If new drivers and a new firmware are available for the MADRIX LUNA, please always update the firmware first and then the drivers!**
- MADRIX LUNA Updater does not work when MADRIX is running. Please close MADRIX and restart MADRIX 5 Device Updater / MADRIX LUNA Updater.

Where To Find The MADRIX 5 Device Updater

The MADRIX LUNA Updater is included in the MADRIX installation as part of the MADRIX 5 Device Updater. After installing MADRIX, you can find a link in the Windows Start menu:

- In Windows 7, go to Start > All Programs > MADRIX 5 > Tools > MADRIX 5 Device Updater
- In Windows 10, go to Start > MADRIX 5 > MADRIX 5 Device Updater
- Select Load LUNA 4 / 8 / 16 and confirm with OK

The original, executable program can be found in the MADRIX installation directory:

- C:\Program Files\MADRIX5

Available Firmware Updates

<table>
<thead>
<tr>
<th>LUNA Firmware</th>
<th>MADRIX Version</th>
<th>Release Date</th>
<th>Highlights</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.00.4547</td>
<td>MADRIX 3.0</td>
<td>July 2013</td>
<td>Initial Release</td>
</tr>
<tr>
<td>1.01.4555</td>
<td>MADRIX 3.1</td>
<td>November 2013</td>
<td>Improved functionality and communication with the MADRIX Software.</td>
</tr>
<tr>
<td>1.02.4946</td>
<td>MADRIX 3.2</td>
<td>March 2014</td>
<td>Added support for LUNA 4 and LUNA 16 in addition to LUNA 8.</td>
</tr>
<tr>
<td>Version</td>
<td>MADRIX VERSION</td>
<td>Release Date</td>
<td>Changes</td>
</tr>
<tr>
<td>-----------</td>
<td>----------------</td>
<td>--------------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| 1.03.5043 | MADRIX 3.3     | November 2014| - Optimized device reply time (Poll Reply) to ensure that all connected devices are found when searching for them automatically in MADRIX.  
- Fixed an issue that would reset the network settings with the next start when a Subnet Mask higher than 255.255.255.0 was set up.  
- Fixed issues with sending out data when receiving Art-Net data from two sources.  
- Fixed an issue that only used the last of DMX output ports to send out data when several ports had been assigned the same Art-Net universe. |
<p>| 1.04.5298 | MADRIX 3.3a    | December 2014| - Fixed an issue that the IP address could not be changed using the web configuration tool. |
| 1.05.5501 | MADRIX 3.4     | June 2015    | - Fixed that the Poll Reply only returned 4 ports for LUNA 8 or LUNA 16. |
| 1.05.5997 | MADRIX 3.6     | May 2016     | - All built-in status LEDs can now be switched off over Art-Net via ArtAdress. |
| 1.05.6298 | MADRIX 3.6b    | September 2016| - Web configuration page: Added the Refresh button to always show the latest information that was last saved on the device in the web browser (instead of using a browser refresh which may change settings again). |
| 1.05.6996 | MADRIX 3.6d    | December 2016| - Fixed an issue for LUNA 4 that returned an incorrect BindIndex after receiving a PollReply. |</p>
<table>
<thead>
<tr>
<th>Version</th>
<th>MADRIX Version</th>
<th>Date</th>
<th>Changes</th>
</tr>
</thead>
</table>
| 1.06.7074     | MADRIX 3.6h    | February 2018 | - Added 4 distinct options for sending data output in case of data connection loss [only available in the web configuration tool]:  
  - Send The Last Received Frame Continually  
  - Send Black Frames Continually  
  - Stop Sending After Sending A Black Frame  
  - Stop Sending  
  - Increased the minimum output frequency that is sent on each port from 10 FPS to 20 FPS [in order to ensure functionality with lighting fixtures that are not functioning well with low frame rates]. |
| 1.06.7104     | MADRIX 5.0     | May 2018    | - Added BindIdx 3 to the PollReply to better communicate the additional DMX-IN port. |
| 1.06.7106     | MADRIX 5.0a    | June 2018   | - Web configuration page: Updated the visual appearance for MADRIX 5.  
  - Web configuration page: Art-Net universes are now also shown in hexadecimal notation in addition to the decimal notation. |
| 1.06.7134     | MADRIX 5.0c    | July 2018   | - Web configuration page: Updated the MADRIX Logo.  
  - Web configuration page: Renamed Direct IP Mode to Unicast Mode. |
11.5 MADRIX NEBULA

This topic includes:

- Overview
- Using A 3rd-Party Controller
- Supported LEDs
- Putting The Device Into Operation
- LED Status Codes
- Automatic HTP Merging
- Reset To Factory Default Settings
- Device Configuration
- Using The MADRIX Software
- Firmware Updates
- Important Information
- Technical Advice

Overview
MADRIX NEBULA is a flexible interface to directly control a wide range of digital LEDs. The MADRIX NEBULA directly connects to your LED pixels. This advanced SPI decoder receives control data over Ethernet network or USB and is built to provide excellent image quality.

**Using A 3rd-Party Controller**

MADRIX NEBULA is a standard network node. Because of this, you can use the device with applications, consoles, desks, or controllers that are compatible with Art-Net or Streaming ACN to distribute data via Ethernet network.

**Supported LEDs**

MADRIX NEBULA supports the following LEDs [as of July 2018 with firmware version 2.0.7140]:

---

MADRIX 5.0c Help And Manual  [Part K] MADRIX Hardware
The protocols above currently have the following frequencies implemented and available:

<table>
<thead>
<tr>
<th>Protocol</th>
<th>Frequency</th>
<th>Special Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>APA101</td>
<td>24 MHz</td>
<td>TM1804</td>
</tr>
<tr>
<td></td>
<td>12 MHz</td>
<td>TM1809</td>
</tr>
<tr>
<td></td>
<td>8 MHz</td>
<td>TM1812</td>
</tr>
<tr>
<td></td>
<td>4 MHz</td>
<td>TM1814</td>
</tr>
<tr>
<td></td>
<td>2 MHz</td>
<td>TM1829</td>
</tr>
<tr>
<td></td>
<td>1 MHz</td>
<td>UCS1903</td>
</tr>
<tr>
<td>APA102</td>
<td>24 MHz</td>
<td>UCS512B3</td>
</tr>
<tr>
<td></td>
<td>12 MHz</td>
<td>UCS8904</td>
</tr>
<tr>
<td></td>
<td>8 MHz</td>
<td>UCS9812S</td>
</tr>
<tr>
<td></td>
<td>2 MHz</td>
<td>WS2801</td>
</tr>
<tr>
<td></td>
<td>1 MHz</td>
<td>WS2803</td>
</tr>
<tr>
<td></td>
<td></td>
<td>WS2811</td>
</tr>
<tr>
<td></td>
<td></td>
<td>WS2811S</td>
</tr>
<tr>
<td></td>
<td></td>
<td>WS2812</td>
</tr>
<tr>
<td></td>
<td></td>
<td>WS2812B</td>
</tr>
<tr>
<td></td>
<td></td>
<td>WS2813</td>
</tr>
<tr>
<td></td>
<td></td>
<td>WS2815</td>
</tr>
<tr>
<td></td>
<td></td>
<td>WS2818</td>
</tr>
<tr>
<td></td>
<td></td>
<td>WS2822S</td>
</tr>
<tr>
<td></td>
<td></td>
<td>WS2822S Addressing</td>
</tr>
<tr>
<td>Device</td>
<td>Frequency Options</td>
<td></td>
</tr>
<tr>
<td>------------</td>
<td>-----------------------------</td>
<td></td>
</tr>
<tr>
<td>APA104</td>
<td>800 kHz, 400 kHz</td>
<td></td>
</tr>
<tr>
<td>APA106</td>
<td>800 kHz, 400 kHz</td>
<td></td>
</tr>
<tr>
<td>GW6201</td>
<td>800 kHz</td>
<td></td>
</tr>
<tr>
<td>GW6205</td>
<td>800 kHz, 400 kHz</td>
<td></td>
</tr>
<tr>
<td>LPD1882S</td>
<td>1.25 MHz</td>
<td></td>
</tr>
<tr>
<td>LPD6803</td>
<td>12 MHz, 8 MHz, 4 MHz, 2 MHz, 1 MHz</td>
<td></td>
</tr>
<tr>
<td>LPD8806</td>
<td>12 MHz, 8 MHz, 4 MHz, 2 MHz, 1 MHz</td>
<td></td>
</tr>
<tr>
<td>MBI6120</td>
<td>1.2 MHz, 800 kHz, 400 kHz, 1.2 MHz, 800 kHz, 400 kHz, 1.2 MHz, 800 kHz, 400 kHz, 1.2 MHz, 800 kHz, 400 kHz, Limit 66 %, Limit 66 %, Limit 66 %, Limit 33 %, Limit 33 %, Limit 33 %</td>
<td></td>
</tr>
<tr>
<td>P9883</td>
<td>800 kHz</td>
<td></td>
</tr>
<tr>
<td>SJ1221</td>
<td>800 kHz, 800 kHz, 800 kHz, 800 kHz, 800 kHz, 800 kHz, 800 kHz, 800 kHz, 100 %, 75 %, 50 %, 25 %, MIN</td>
<td></td>
</tr>
<tr>
<td>SK6822</td>
<td>800 kHz</td>
<td></td>
</tr>
<tr>
<td>SK6812</td>
<td>800 kHz</td>
<td></td>
</tr>
<tr>
<td>SM16703</td>
<td>800 kHz</td>
<td></td>
</tr>
<tr>
<td>Device</td>
<td>Frequencies</td>
<td>2 MHz</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
<td>----------------</td>
</tr>
<tr>
<td>SM16716</td>
<td>24 MHz, 12 MHz, 8 MHz, 4 MHz, 2 MHz, 1 MHz</td>
<td>2 MHz, 1 MHz, 800 kHz, 400 kHz, 2 MHz, 1 MHz</td>
</tr>
<tr>
<td>TLS3001</td>
<td>2 MHz, 1 MHz, 800 kHz, 400 kHz, 2 MHz, 1 MHz</td>
<td>2 MHz, 1 MHz, 800 kHz, 400 kHz, 2 MHz, 1 MHz</td>
</tr>
<tr>
<td>TLS3008</td>
<td>1 MHz, 800 kHz, 400 kHz</td>
<td>1 MHz, 800 kHz, 400 kHz</td>
</tr>
<tr>
<td>TM1804</td>
<td>800 kHz</td>
<td>800 kHz</td>
</tr>
<tr>
<td>TM1809</td>
<td>800 kHz</td>
<td>800 kHz</td>
</tr>
<tr>
<td>TM1812</td>
<td>800 kHz</td>
<td>800 kHz</td>
</tr>
<tr>
<td>TM1814</td>
<td>800 kHz, 800 kHz, 800 kHz, 800 kHz, 800 kHz</td>
<td>800 kHz, 800 kHz, 800 kHz, 800 kHz, 800 kHz</td>
</tr>
<tr>
<td>TM1829</td>
<td>1.6 MHz, 1.6 MHz, 1.6 MHz, 1.6 MHz, 1.6 MHz, 1.6 MHz, 800 kHz, 800 kHz, 800 kHz, 800 kHz</td>
<td>1.6 MHz, 1.6 MHz, 1.6 MHz, 1.6 MHz, 1.6 MHz, 1.6 MHz, 800 kHz, 800 kHz, 800 kHz, 800 kHz</td>
</tr>
<tr>
<td>UCS1903</td>
<td>800 kHz, 400 kHz</td>
<td>800 kHz, 400 kHz</td>
</tr>
<tr>
<td>Device</td>
<td>Frequency</td>
<td>Addressing</td>
</tr>
<tr>
<td>--------------</td>
<td>----------------</td>
<td>------------</td>
</tr>
<tr>
<td>UCS512B3</td>
<td>750 kHz, 500 kHz, 250 kHz</td>
<td></td>
</tr>
<tr>
<td>UCS8904</td>
<td>800 kHz, 800 kHz</td>
<td>16 Bit</td>
</tr>
<tr>
<td>UCS9812S</td>
<td>1.1 MHz</td>
<td>100 %, 75 %, 50 %, 25 %, MIN</td>
</tr>
<tr>
<td>WS2801</td>
<td>24 MHz, 12 MHz, 8 MHz, 4 MHz, 2 MHz, 1 MHz</td>
<td></td>
</tr>
<tr>
<td>WS2803</td>
<td>24 MHz, 12 MHz, 8 MHz, 4 MHz, 2 MHz, 1 MHz</td>
<td></td>
</tr>
<tr>
<td>WS2811</td>
<td>800 kHz, 400 kHz</td>
<td></td>
</tr>
<tr>
<td>WS2811S</td>
<td>800 kHz, 400 kHz</td>
<td></td>
</tr>
<tr>
<td>WS2812</td>
<td>800 kHz</td>
<td></td>
</tr>
<tr>
<td>WS2812B</td>
<td>800 kHz</td>
<td></td>
</tr>
<tr>
<td>WS2813</td>
<td>800 kHz</td>
<td></td>
</tr>
<tr>
<td>WS2815</td>
<td>800 kHz</td>
<td></td>
</tr>
<tr>
<td>WS2818</td>
<td>800 kHz</td>
<td></td>
</tr>
<tr>
<td>WS2822S</td>
<td>750 kHz, 500 kHz, 250 kHz</td>
<td>Addressing</td>
</tr>
</tbody>
</table>
Putting The Device Into Operation

1] Connecting Your LEDs

Please see the *MADRIX NEBULA Quick Start Guide & Technical Manual* on how to connect your LEDs to MADRIX NEBULA.

» [help.madrix.com](http://help.madrix.com)

2] Connecting To Power And Data

Please see the *MADRIX NEBULA Quick Start Guide & Technical Manual* on how to connect to power and data.

» [help.madrix.com](http://help.madrix.com)

3] Setting The Output Protocol

In order to put MADRIX NEBULA fully into operation, it is necessary to set the correct output protocol according to the LEDs you have connected.

Learn more:

- [Device Configuration](http://help.madrix.com)

4] Setting The Network Data Source

Make sure to set the correct network data source and other settings according to the controller/sender you want to use.

Learn more:

- [Device Configuration](http://help.madrix.com)
# LED Status Codes

The following tables describe the LED status codes of the device.

### STATUS | STATUS LED POWER
--- | ---
**Powered off** | Power not connected. → The device has no power.
**Permanently green** | Connected to power. → The power is on.
**Blinking green** | Bootloader activated. → Reset the device to factory default settings.

### STATUS | STATUS LED USB
--- | ---
**Powered off** | USB not connected.
**Red + blinking green** | Communicating over USB. → Sending or receiving data over USB. The USB port works.
**Fading between red + green** | Connected to USB; Drivers installed correctly. → No data is sent over USB.
**Orange** | Connected to USB; No drivers installed. → Reinstall software and drivers or try a different USB port.

### STATUS | STATUS LED PORT 1 | STATUS LED PORT 2
--- | --- | ---
**Powered off** | No data is sent. | No data is sent.
**Blinking green** | Sending data to Port 1. → The output port works. | Sending data to Port 2. → The output port works.

### STATUS | ETHERNET
--- | ---
**Green off** | 10 MBit/s connected.
**Green on** | 100 MBit/s connected.
**Orange on** | Network connected.
**Orange blinking** | Sending or receiving data. → The Ethernet port works.
Automatic HTP Merging

Overview

- MADRIX NEBULA features automatic HTP merging from 2 Art-Net sources.
  [Usually, the first source will be MADRIX. The second source could be a console, for example.]
- Data from both source will be merged together and sent out as 1 signal. This happens across all output ports and by using the HTP principle.
- **HTP** - Is the acronym for **Highest Takes Precedence**. Data from both sources will be compared for each individual channel. The higher value wins per channel.

**Example:** We are using an LED fixture with a total of 5 control channels [3 color channels and 2 movement channels]. MADRIX should provide the color data for channels 1 to 3 and the console should provide the movement data for channels 4 and 5. Using the MADRIX Fixture Editor, we could create a corresponding fixture where channel 4 and 5 are set up as **Fixed** channel using always a value of 0. On the other hand, the console will always send a value of 0 for the first 3 channels of each fixture. This will ensure that the data from the console will always provide the higher value on channels 4 and 5, while MADRIX provides the color data. Due to the automatic HTP merging of the device, the LED fixture will receive correct data from both sources as desired.

Configuration And Recommendations

1] Correctly set up and enable Art-Net for each source.

2] Make sure to activate **ArtSync** for Art-Net in MADRIX.

3] Make sure that MADRIX has a **lower IP address** compared to the second source.
   [E.g., 2.0.0.1 compared to 2.0.0.20]

4] Always use **Unicast Mode** to directly send data to the correct IP addresses of your MADRIX NEBULA devices.
   [It is not recommend to have any of the two sources or any other source in the network to send data via Broadcast Mode.]
Reset To Factory Default Settings

In rare cases you might need to do a reset to factory default settings, for example to reset to the device to its default IP address as shown on the side of the device:

Reset Via Reset Button

1. Disconnect all connections from the device [power, data, LEDs].
2. Use a suitable tool to press the reset button [between Port 1 and Port 2].
3. Continue to press the reset button and supply power again over 'Power' or USB.
4. Continue to press the reset button and wait until all status LEDs of the device flash repeatedly or wait 10 seconds.
   [Simply repeat these steps should the process fail.]

Device Configuration

When connected to Ethernet network, you can easily configure MADRIX NEBULA using the built-in web configuration page.

You have 2 options to access the web interface. Both, NEBULA and your computer, need to be in the same network.

A] Using a standard web browser:
   - Connect MADRIX NEBULA and your computer to the same network.
   - Assign correct network settings for your PC in the Windows operating system.
     [Recommended default settings: IP address 10.0.0.1 / Subnet mask 255.0.0.0]
   - Open your web browser and enter the IP address of MADRIX NEBULA.
     [You can find the default IP address on the back side of the device.]
   - The web configuration page will be launched. Now, you have access to various information and settings.

B] Using the MADRIX Software:
   - Connect MADRIX NEBULA and your computer to the same network.
• Assign correct network settings for your PC in the Windows operating system.
  [Recommended default settings: IP address 10.0.0.1 / Subnet mask 255.0.0.0]

• Go to the menu Tools > MADRIX Device Configuration...
  [Keyboard shortcut: Ctrl+Alt+L]

• Select your MADRIX NEBULA device in the list.

• Click HTTP

• Your default web browser will open and the web configuration page will be launched. Now, you have access to various information and settings.
### Device Name
You can change the description of the device. This label is only shown in this web interface.

### Device Settings
You can change the **IP address** and **Subnet Mask**.
DMX Output Settings

This section shows specific settings for the output ports [Port 1 and Port 2].

Network Universe - By default, universes 1 - 4 are assigned to Port 1 and universes 4 - 8 are assigned to Port 2.
- If you are broadcasting data for a large number of Universes [using Broadcast Mode instead of Unicast Mode] with MADRIX or a 3rd-party controller for example, you can assign different DMX universes to each device with these settings. Each MADRIX NEBULA will then only receive data from the specific universe and send it to its specified output port.
- Example: You can set up that NEBULA #1 only listens to universe 1 - 8, while NEBULA #2 listens to universe 9 - 16, and NEBULA #3 listens to universe 17 - 24, and so on.
Channels Per Universe - Allows you to define how many DMX channels are sent per DMX universe for each port. This option enables you to adjust the device settings to the controller and LEDs you are using.

- **Automatic**: The number of channels that is received is also sent out. This is the default value. This is also the recommended setting when using NEBULA in combination with the MADRIX Software.

- **1 - 512**: Limits the number of output channels to this value. If your controller sends more channels than set up here, any channels that are higher than this value will be discarded. If your controller sends fewer channels, NEBULA will fill up the rest of the channels with values of 0 [Black].

- Using RGB LEDs: 170 RGB LEDs can be controlled with one single DMX universe. That means a maximum of 510 DMX channels is used. Depending on your controller [please see below], the recommended setting is **Automatic** or **510**.

- Using RGBW LEDs: 128 RGBW LEDs can be controlled with one single DMX universe. That means a maximum of 512 DMX channels is used. Depending on your controller [please see below], the recommended setting is **Automatic** or **512**.

- Using 1-channel LEDs: 512 single color LEDs can be controlled with one single DMX universe. That means a maximum of 512 DMX channels is used. Depending on your controller [please see below], the recommended setting is **Automatic** or the number of LEDs used.

- Using MADRIX: By default, MADRIX sends optimized frames as set up in the Device Manager. That means according to the number of channels used by the fixtures and Patch, MADRIX and then NEBULA will send out the correct number of channels to the LEDs.

- Using a 3rd-party controller: When your controller is only able to send full frames [which means that it always sends 512 DMX channels per single frame], it is recommended to set up a specific value here as described above in order to correctly work with MADRIX NEBULA and your LEDs. Recommendation: If using RGB LEDs, set up 510 channels per universe.
Port Output Settings

Output Protocol - In order to put MADRIX NEBULA fully into operation, it is necessary to set the correct output protocol according to the LEDs you have connected. You can set it up here.

- Choose a signal frequency according to the specifications of your LEDs.
- If you do not have this information, choose a signal frequency that works for your LEDs. If the refresh rate is set too high, you will usually notice that your LEDs flicker uncontrollably. If that is the case, choose a lower frequency.
- Certain LEDs need to be addressed first. If your LEDs need to be addressed and have not been addressed yet, please address them first.

Learn More

Start Channel - Is especially useful for splitting a specific universe onto the two ports. For example, your sender sends 3 1/2 universes and some of those LEDs are connected on the second port. On Port 1, you would like to send 3 universes and 45 channels and on Port 2, you would like to send another 150 channels from universe 3. Then, you can set the Start Channel of Port 2 to 46 and universe 3.

Channel Order - Allows you to change the order of [color] channels for the output. For example, if you receive channels 1-2-3 [i.e. RGB, for example], the setting 1-2-3-(4) will send it out as R-G-B. In contrast, the setting 3-2-1 would send B-G-R.

In Case Of Data Connection Loss

On Each Affected Port - Defines the output settings of the NEBULA if the device does not receive data anymore for a specified port. Choose from the following options:

- Send The Last Received Frame Continually
- Send Black Frames Continually
- Stop Sending After Sending A Black Frame
- Stop Sending

Network Data Sources

Device Accepts Data From - Defines the data source:

- Art-Net
- Streaming ACN
- Art-Net And sACN
Device Information

- This section displays various details about the device, including:
  - **Model** [Device type]
  - **IP Address** [The current IP address.]
  - **MAC Address** [A permanent, unique address.]
  - **Serial Number**
  - **Firmware** [The current firmware version.]
  - **Bootloader** [The current bootloader version.]
  - **Hardware** [Hardware model]
  - **Voltage** [The current voltages for Input, Port 1, and Port 2.]
  - **Temperature** [The current ambient temperature.]
  - **Ethernet** [The current status of the network connection.]

Please Note Regarding LEDs That Need Be Addressed First

Certain LEDs need to addressed first. Please check the below table to see if your LEDs might need to be addressed.

- If they are already addressed with another tool, you do not need to address them again.
- If your LEDs are not yet addressed, please address them:
  1. Connect your LEDs as described above.
  2. Connect to power and data as described above.
  3. Choose the corresponding Addressing Protocol as Output Protocol of the MADRIX NEBULA. Confirm with 'Set'. You only have to do this once for your each LED tape.
  4. Once your LEDs are addressed, continue by selecting the correct Output Protocol according to your LEDs.

<table>
<thead>
<tr>
<th>LED</th>
<th>Addressing Protocol</th>
</tr>
</thead>
<tbody>
<tr>
<td>WS2822S</td>
<td>Choose the Addressing Protocol 'WS2822S Addressing' in order to address your LEDs.</td>
</tr>
</tbody>
</table>
Using The MADRIX Software

The MADRIX NEBULA works great in combination with the MADRIX Software.

MADRIX 5 Software License

- The MADRIX 5 Software license is not included and sold separately. A MADRIX 5 KEY is necessary if you want to use output.

Operating Modes

You can use 3 operating modes together with the MADRIX Software:

- Data Output Over Ethernet Network [Art-Net]
- Data Output Over Ethernet Network [Streaming ACN / sACN]
- Data Output Over USB

Data Output Over Ethernet Network [Art-Net]

Overview

You can connect the NEBULA over Ethernet network to the network card of your computer that runs the MADRIX Software. Data is distributed to the device over network cabling [Ethernet] and sent to the output ports [Port 1 and Port 2].

1] Initial Configuration
Put MADRIX NEBULA into operation by connecting the LEDs, supplying power, setting the output protocol, and setting the network data sources as described above. Learn more Putting The Device Into Operation.

Connect MADRIX NEBULA to your computer using Ethernet network cabling.

It is highly recommended to use Gigabit Ethernet network components [network card, switches, etc.].

2] Windows Network Settings

Art-Net is a network-based protocol. MADRIX will use the network card of your computer to send data.

- It is required to set up the correct network settings in Windows, first.
- You must use these IP address and Subnet mask settings. Otherwise, Art-Net might not work!
- The IP addresses of your computer and your MADRIX NEBULA devices need to be different.

- Set up an individual **IP address** in the following IP address range:
  - 2.0.0.1 ... 2.255.255.254 or
  - 10.0.0.1 ... 10.255.255.254
- Set up the corresponding **Subnet mask**
  - 255.0.0.0

[Via factory default settings, MADRIX NEBULA devices will have an IP address in the 10.x.x.x network range, such as 10.77.64.86, for example].

- Restart MADRIX, if you have changed the network settings in Windows while MADRIX was running.
- Learn more »Tips [Microsoft Windows / Networks / USB]

- Example for PCs that are running MADRIX:
3] Fixture Configuration In MADRIX

- Start MADRIX 5.
- Configure the virtual LED matrix using the »Matrix Generator or »Patch Editor

4] Activating Art-Net

- Go to the menu Preferences > Device Manager... > Art-Net
  [Keyboard shortcut: F4 > Art-Net]
- Activate the checkbox Enable [in the upper, right corner].
5] Adding Devices Automatically

MADRIX can automatically add your MADRIX NEBULA devices.

- Click ![Click](image)

  [MADRIX will automatically search the network for connected devices. Devices that are found will appear in the list. Two entries will be created in the list for each NEBULA device.]

  [The Art-Net standards only supports a maximum of 4 output ports per device. Since NEBULA features 2 ports, 2 list items are created in MADRIX.]
6] Activating Devices

Each of your MADRIX NEBULA devices and its ports need to be activated. By default, they are still deactivated.
Go to the menu **Preferences > Device Manager... > DMX Devices**

[Keyboard shortcut: F4]

- Select your devices and their ports in the list. 8 output universes will be shown.
- Activate **Enable**
- Click **Apply**

![Device Manager](image)

- [In the screenshot above, one NEBULA is connected. If more devices are connected, please use the different IP addresses of different devices to identify them in the Device Manager.]

### 7] Configuration Of DMX Output

- Make sure that your output port is still selected under **Preferences > Device Manager... > DMX Devices**
- Set up **Universe**
  - Enter the specific DMX universe number.
- This setting assigns a specific DMX universe [of the Patch] to the device or the port of the device.
- **Make sure the correct universe is assigned according to your requirements.**
  
  Learn more »**Glossary**
- Click **Apply**

- By default, DMX universe 1 - 8 are assigned when using one MADRIX NEBULA.

<table>
<thead>
<tr>
<th>NEBULA Output Universe</th>
<th>Device Manager... &gt; DMX Devices &gt; Device Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>DMX 1</td>
<td>BindIdx1 Port:0</td>
</tr>
<tr>
<td>DMX 2</td>
<td>BindIdx1 Port:1</td>
</tr>
<tr>
<td>DMX 3</td>
<td>BindIdx1 Port:2</td>
</tr>
<tr>
<td>DMX 4</td>
<td>BindIdx1 Port:3</td>
</tr>
<tr>
<td>DMX 5</td>
<td>BindIdx2 Port:0</td>
</tr>
<tr>
<td>DMX 6</td>
<td>BindIdx2 Port:1</td>
</tr>
<tr>
<td>DMX 7</td>
<td>BindIdx2 Port:2</td>
</tr>
<tr>
<td>DMX 8</td>
<td>BindIdx2 Port:3</td>
</tr>
</tbody>
</table>
8] Frame Time

- Make sure that your device is still selected under Preferences > Device Manager... > DMX Devices

- Set up **Frame Time (ms)**
  - The Frame Time affects the Frame Rate. The Frame Rate specifies how fast data is sent to the device or received from it [Frames Per Second; FPS].
  - Increase the Frame Time in order to decrease the Frame Rate [e.g., 40ms = 25 FPS].
  - Decrease the Frame Time in order to increase the Frame Rate [e.g., 20ms = 50 FPS].
  - The default value is 30 ms / 33.3 FPS.
  - **Some LED fixtures might have problems with a high Frame Rate. Then, it is recommended to increase the Frame Time / to decrease the Frame Rate.**

- Click **Apply**

- [When using Art-Net, the Frame Time [ms] can be individually set for each port. But it cannot be set individually for each port, when Sync Mode is activated. Learn more below.]
9] Sync Mode

MADRIX STELLA can use the special sync mode of Art-Net.

- Large LED projects require dependable data distribution. The MADRIX software and NEBULA hardware allow you to fully synchronize data output for all output DMX ports and even across multiple NEBULA devices to get an optimal image on the LEDs.
- When Art-Net sync mode is activated, MADRIX and MADRIX NEBULA will automatically handle the synchronization of data.

Art-Net Sync Mode is highly recommended for MADRIX NEBULA!

![ArtSync] - Allows you to activate or deactivate the usage of sync packages for Art-Net.
- Your Art-Net devices need to support this feature in order for it to work correctly.
- All MADRIX hardware Art-Net nodes support ArtSync.

In addition, you can choose between Post-Sync [default] and Pre-Sync. By default, the sync data is sent after the color data. Pre-Sync would send it before the color data.

- Before activating sync, make sure that all activated Art-Net devices are available in your network! Else, the frame rate of Art-Net might drop. If you are not sure, do not enable any sync mode.

Additional Art-Net Device Settings

It is very important to set up the correct settings of your devices!
Broadcast Mode Or Unicast Mode

MADRIX can send Art-Net data in 2 ways to your Art-Net devices:

- **Broadcast Mode** - Means that every packet sent from a single transmitter will be received by all recipients in the network. MADRIX will send data to all devices in the network.
  - Advantage: The same data [e.g., DMX universe 1 and 2] can be made available at different points of your setup.
  - Disadvantage: A potentially huge number of data packages will be sent over the network. This can reduce the overall network performance and cause data issues or instability.

- **Unicast Mode** - Means that the specific data will only be sent to the specified recipient.
  - Advantage: Data traffic is reduced immensely, which means that a larger number of Art-Net devices can be used in one network. Reduced network traffic increases the performance and stability.
  - Disadvantage: The network settings of all devices need to be 100% correct.

Unicast Mode is recommended in general.

- Go to the menu **Preferences > Device Manager... > Art-Net**
  - [Keyboard shortcut: F4 > Art-Net]
- Select your device in the list.
- Click [ ]
  - A new window will open.
- **A**] Choose **Send Unicast Mode** to activate unicast mode:
  - Make sure to enter the correct **IP Address** of your device that should receive the Art-Net data.
  - MADRIX will send the corresponding data only to this device.
- **B**] Choose **Send Broadcast Mode** to activate Broadcast Mode:
  - Make sure to select the correct **Network** card of your computer that should send the Art-Net data.
  - MADRIX will send data to the whole Art-Net network.
- Click **Apply**

Status Indicators [ArtAddress]
In order to use these features, please **Enable** ArtAddress first.

[Please make sure that your nodes fully support this Art-Net feature, such as MADRIX LUNA, MADRIX NEBULA, MADRIX PLEXUS, MADRIX STELLA. You will also get notified by a message box. Confirm the message with **OK** or abort via **Cancel**]

- **Mute Status Indicators** - Switches off and disables all built-in status indicators of a device over Art-Net [ArtAddress > AcLedMute].

- **Operate Status LEDs Normally** - Allows the built-in status indicators of a device to operate normally again, after having them switched off [ArtAddress > AcLedNormal].

- **Highlight Device** - Activates the highlight mode [ArtAddress > AcLedLocate]. Select one or more interfaces and click the button. The corresponding status indicators of the selected interfaces will flash for a better identification or tests. This makes it easier to see them on site/stage. It considerably speeds up the procedure of programming or testing the selected interfaces.

**More Information About Art-Net**

Learn more »[Art-Net [DMX Over Ethernet]]

**Data Output Over Ethernet Network [Streaming ACN / sACN]**

**Overview**

You can connect the NEBULA over Ethernet network to the network card of your computer that runs the MADRIX Software. Data is distributed to the device over network cabling [Ethernet] and sent to the output ports [Port 1 and Port 2].
1] Initial Configuration

- Put MADRIX NEBULA into operation by connecting the LEDs, supplying power, setting the output protocol, and setting the network data sources as described above. Learn more Putting The Device Into Operation
- Connect MADRIX NEBULA to your computer using Ethernet network cabling.
- It is highly recommended to use Gigabit Ethernet network components [network card, switches, etc.].

2] Windows Network Settings

- MADRIX automatically sets up Streaming ACN network settings for you.
  [MADRIX supports multicast Streaming ACN. Data is automatically sent to all corresponding sACN devices in the network. Unicast is also supported.]
- You only need a computer with a network card and a valid IP address.

- You do not have to change the IP address settings in Windows for Streaming ACN!
- The IP address range for sACN devices is 239.255.X.X according to the Streaming ACN specifications. MADRIX NEBULA automatically works this way.
- Make sure that your Firewall does not block data of the 239.255.X.X IP address range!
- Check the settings of the Windows Firewall.
- Learn more »Tips [Microsoft Windows / Networks / USB]

3] Fixture Configuration In MADRIX

- Start MADRIX 5.
- Configure the virtual LED matrix using the »Matrix Generator or »Patch Editor

4] Activating Streaming ACN

- Go to the menu Preferences > Options... > Devices Network
  [Keyboard shortcut: Ctrl+Alt+O > Devices Network]
- Activate ESTA - Streaming ACN
Choose your network card from the drop-down list. Make sure to select the correct network adapter that will be used for Streaming ACN!

[The IP address and Subnet mask label should help you select the correct adapter. It is not necessary to change any of these networks settings.]

ACN Device Count - Set up how many you are going to use. MADRIX NEBULA requires 8 sACN devices per unit. [This is the total amount of devices. Please set the exact number of devices you are using. If the count is higher, this creates unnecessary network traffic.]

Press Apply

ACN CID - Being a network protocol, Streaming ACN sends a so-called CIDs [Component Identifier].

- Every single ACN device has such a unique ID.
- When using Streaming ACN, your MADRIX Software is one of those devices.
- When you start MADRIX for the first time, this ID will be generated automatically for you. From this point onwards it will be used on your PC.
- With this ID your MADRIX Software can be easily identified in the network. Interfaces can detect this unique ID and can be configured to receive data from this particular device. Please note that the ACN interface must support this feature.
- Do not change the ACN CID, unless you are an experienced user!
- Press **OK** to close the window.

### 5] Activating Devices

Each of the ports need to be activated. By default, they are still deactivated.
- Go to the menu **Preferences > Device Manager... > DMX Devices**  
  [Keyboard shortcut: **F4**]

- Select your devices and their ports in the list. 8 output universes will be shown.

- Activate **Enable**

- Click **Apply**

- [In the screenshot above, one NEBULA is connected. If more devices are connected, please use the different universes of different devices to identify them in the Device Manager.]

- **Universe** - Defines which universe of your MADRIX Patch is sent to this particular device.

**6A] Configuration Of Single Devices**

- Select a device in the list and click 🌠
A new window will open.

Set up the following settings for your devices:

- **Source Name** - Allows you to set up a specific name for the device. This name is send via network as well. Therefore, interfaces may be able to retrieve this name and can be configured to receive data from this source.
  - If you are using the default name **MADRiX U:X**, the universe will automatically be displayed in the name [represented by X: 1, 2, 3, etc.].
- **ACN Universe** - Defines the DMX universe of the device.
  - *Set up the same universe that is set up in your sACN device, which is MADRIX NEBULA.*
  - According to the Streaming ACN specifications, MADRIX will automatically change the ACN IP Address according to the ACN Universe.

- **ACN Priority** - Was implemented for backup solutions. Valid values range from 0 to 200, which is the highest priority.
  - For example, you may have set up two MADRIX PCs. One gets a priority of 100. The second PC gets a priority of 50. If the first PC fails and only if it malfunctions, data will be automatically received from PC #2.
  - Data will always be received from the device with the highest priority. Please note that the ACN device must support this feature.

- **ACN Protocol** - Automatically selects the **ANSI 2009** standard.

- **Use Multicast**
  - **ACN Multicast IP Address** - Displays the IP address of the device as automatically assigned by MADRIX according to the Streaming ACN specifications. The last 2 digits match the assigned DMX universe.

- **Use Unicast**
  - **ACN Unicast IP Address** - Uses a specific IP address to send data to.

- Press **Apply** to confirm your changes.
- Press **OK** to close the window.

### 6B] Configuration Of Multiple Devices

- You can configure **several interfaces** at the same time.

- Follow the steps of 6A, but select multiple devices and press .
- A new window will open.
- Set up the settings as described under 6A.
- For **ACN Universe** you have now additional options for **Auto Numbering**:
  - Leave this button deactivated and every device will get the same number of universes.
  - Activate the button and MADRIX will automatically increase the number for all the selected devices, starting with the ACN Universe value you entered.
- Press **Apply** to confirm your changes.
- Press **OK** to close the window.

7] **Frame Time**
- Make sure that your device is still selected under **Preferences > Device Manager... > DMX Devices**
- Set up **Frame Time (ms)**
  - The Frame Time affects the Frame Rate. The Frame Rate specifies how fast data is sent to the device or received from it [Frames Per Second; FPS].
  - Increase the Frame Time in order to decrease the Frame Rate [e.g., 40ms = 25 FPS].
  - Decrease the Frame Time in order to increase the Frame Rate [e.g., 20ms = 50 FPS].
  - The default value is 30 ms / 33.3 FPS.
  - Some LED fixtures might have problems with a high Frame Rate. Then, it is recommended to increase the Frame Time / to decrease the Frame Rate.
Data Output Over USB

Overview

You can connect the NEBULA directly via USB to the computer that runs the MADRIX software. Data is distributed to the MADRIX NEBULA over USB and sent to the two output ports [Port 1 and Port 2].

1] Initial Configuration

- Put MADRIX NEBULA into operation by connecting the LEDs, supplying power, and setting the output protocol as described above. Learn more Putting The Device Into Operation
- Connect MADRIX NEBULA to your computer via USB.
  [Use the provided USB cable.]
- Make sure to check the power management options of Windows. Learn more »PC Power Management

2] Fixture Configuration In MADRIX

- Start MADRIX.
- Configure the virtual LED matrix using the »Matrix Generator or »Patch Editor

3] Enabling Drivers In MADRIX

- Go to the menu Preferences > Options... > Devices USB
  [Keyboard shortcut: Ctrl+Alt+O > Devices USB]
- Activate MADRIX NEBULA
  [The option is activated by default.]
- Click Apply
- Close the window with OK
4] Activating Devices

- Go to the menu Preferences > Device Manager... > DMX Devices  
  [Keyboard shortcut: F4]
- Your NEBULA devices and all of their output universes will appear in the list.
- If your devices are not in the list, click
  [In the screenshot below, one NEBULA is connected.]
- By default, all output ports are activated [State On].

![Device Manager](image)

- If your device and ports are not activated, do the following:
  - Select the device/port in the list.
  - Activate Enable
  - Click Apply

5] Configuration Of DMX Output

- Make sure that your output port is still selected under Preferences > Device Manager... > DMX Devices
Set up **Universe**
- Enter the specific DMX universe number.
- This setting assigns a specific DMX universe [of the Patch] to the device or the port of the device.
- By default, DMX universe 1 - 8 are assigned when using one MADRIX NEBULA.
- **Make sure the correct universe is assigned according to your requirements.**
  Learn more »[Glossary](#)
- Click **Apply**

6] **Frame Time**
- Make sure that your output port is still selected under **Preferences > Device Manager... > DMX Devices**
- Set up **Frame Time (ms)**
  - The Frame Time affects the Frame Rate. The Frame Rate specifies how fast data is sent to the device or received from it [Frames Per Second; FPS].
  - Increase the Frame Time in order to decrease the Frame Rate [e.g., 40ms = 25 FPS].
  - Decrease the Frame Time in order to increase the Frame Rate [e.g., 20ms = 50 FPS].
  - The default value is 30 ms / 33.3 FPS.
  - **Some LED fixtures might have problems with a high Frame Rate. Then, it is recommended to increase the Frame Time / to decrease the Frame Rate.**
- Click **Apply**
- [When using USB, the Frame Time (ms) will be automatically set to the same value for all output ports.]
Firmware Updates

It is highly recommended to update the firmware of the device should a new firmware version become available. You can do so in different ways.

Update Via USB

1. Connect MADRIX NEBULA to your computer over USB. [Use the provided USB cable.]
2. Start the MADRIX software.
3. Open the MADRIX Device Configuration window. Go to the menu Tools > MADRIX Device Configuration...
4. Click to search for connected devices and your device will appear in the list.
5. Select your device in the list and click Firmware
6. Wait for the process to end [usually it takes only seconds].
7. Disconnect MADRIX NEBULA from USB and power. Afterwards, connect it again.

Update Via Ethernet

1. Connect MADRIX NEBULA to power.
2. Connect MADRIX NEBULA to your computer over Ethernet network.
3. In MADRIX, go to the menu Preferences > Device Manager... > Art-Net
4. Activate Art-Net
5. Click . Learn more Data Output Over Ethernet Network [Art-Net]
6. Select the device in the list. Click . A new window opens.
7. Click Firmware
8. The update process will start.
9. Wait for the process to end [usually it takes only seconds].
10) Disconnect MADRIX NEBULA from USB and power. Afterwards, connect it again.

**MADRIX 5 NEBULA Updater**

**Overview**

MADRIX 5 NEBULA Updater is a separate tool only for MADRIX NEBULA. It is integrated into the MADRIX 5 Device Updater.

**Usage**

![MADRIX NEBULA Updater Screenshot](image-url)
MADRIX 5 NEBULA Updater can be used for several, specific tasks.

- Updates the firmware of all NEBULA devices that are connected to the computer via USB. First, select the correct firmware in the list above this button [Example: NEBULA 2.0.000 Type V1.0 MADRIX 5.0]. Second, click the button. Third, disconnect the power after updating in order to restart the device.

- Resets all settings of all NEBULA devices that are connected to the computer via USB to the standard values. Use this function to restore the original settings of the device.

- Performs both actions, a NEBULA firmware update as well as a reset to factory default settings.

- Additional information on the status of the performed functions will be given on the right side of the window. Information is displayed from down to top [the latest information is shown at the top].

**Important Notes**

- If new drivers and a new firmware are available for the MADRIX NEBULA, please always update the firmware first and then the drivers!
- MADRIX NEBULA Updater does not work when MADRIX is running. Please close MADRIX and restart MADRIX 5 Device Updater / MADRIX 5 NEBULA Updater.

Where To Find The MADRIX 5 Device Updater

The MADRIX 5 NEBULA Updater is included in the MADRIX installation as part of the MADRIX 5 Device Updater. After installing MADRIX, you can find a link in the Windows Start menu:

- In Windows 7, go to **Start > All Programs > MADRIX 5 > Tools > MADRIX 5 Device Updater**
- In Windows 10, go to **Start > MADRIX 5 > MADRIX 5 Device Updater**
- Select **Load NEBULA** and confirm with **OK**

The original, executable program can be found in the MADRIX installation directory:

- C:\Program Files\MADRIX5

Available Firmware Updates

<table>
<thead>
<tr>
<th>NEBULA Firmware</th>
<th>MADRIX Version</th>
<th>Release Date</th>
<th>Highlights</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0.6127</td>
<td>MADRIX 3.6 RC</td>
<td>May 2016</td>
<td>- Initial Release</td>
</tr>
</tbody>
</table>
| 1.1.6147        | MADRIX 3.6     | May 2016     | - Added new supported LEDs: P9883.  
- Added new supported LEDs: SK6812.  
- Added new supported LEDs: SK6822. |
<table>
<thead>
<tr>
<th>Version</th>
<th>MADRIX 3.6a</th>
<th>Date</th>
<th>Changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.1.6168</td>
<td></td>
<td>July 2016</td>
<td>- Web configuration tool: Added Voltage to the Device Information section.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Web configuration tool: Added the Refresh button to always show the latest information that was last saved on the device in the web browser [instead of using a browser refresh which may change settings again].</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Web configuration tool: Streamlined spelling of output protocols.</td>
</tr>
<tr>
<td>Version</td>
<td>MADRIX Hardware</td>
<td>Date</td>
<td>Features</td>
</tr>
<tr>
<td>-----------</td>
<td>-----------------</td>
<td>------------</td>
<td>--------------------------------------------------------------------------</td>
</tr>
<tr>
<td>1.2.6346</td>
<td>MADRIX 3.6d</td>
<td>December 2016</td>
<td>- Added new supported LEDs: GW6201.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Added new supported LEDs: TM1814.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Added new supported LEDs: WS2813.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Added new supported LEDs: WS2818.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Changed name of supported LEDs: From TLS3001 To TLS3001 Linear.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Added supported LEDs: TLS3001 Quadratic [For 12-bit LEDs].</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Output settings: Added the option to define the number of channels sent per universe for each port [Channels Per Universe].</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Sensor data: Devices can now report back if voltage is connected/disconnected over USB [Voltage USB].</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Sensor data: Devices can now report back which voltage is used for Power, Port 1, and Port 2 [Voltage Power, Voltage Port 1, Voltage Port 2].</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Sensor data: For NEBULA models V1.1 and higher, devices can now report back the ambient temperature [Temperature].</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Fixed an issue that could make the device become unresponsive under certain circumstances when connecting, disconnecting, and calling up the website several times in a row.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Fixed an issue that could produce display issues with the built-in web configuration tool when confirming changes via 'Set'.</td>
</tr>
<tr>
<td>Version</td>
<td>MADRIX 3.x</td>
<td>Date</td>
<td>Changes</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
<td>------------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| 1.2.7014 | MADRIX 3.6e | February 2017 | - Added new supported LEDs: MBI6120.  
- Added new supported LEDs: WS2822S.  
- Added new supported LEDs: WS2822S Addressing [To linearly address LEDs that haven't been initialized yet].  
- Added new supported LEDs: UCS512B3. |
| 1.2.7035 | MADRIX 3.6f | May 2017    | - Added new supported LEDs: WS2811S.  
- Added supported LEDs: MBI6120, Limit 33 % [To limit the output to 33 % of the possible maximum].  
- Added supported LEDs: MBI6120, Limit 66 %. [To limit the output to 66 % of the possible maximum].  
- Fixed an issue with the following protocols that are now working correctly again: UCS1903, SK6822, P9883.  
- Fixed an issue that could leave the status LEDs permanently on when using the ArtAddress functionality for Art-Net to switch from normal operation to off while the status LEDs were currently active.  
- Fixed an issue that did not allow to select every 40th number of the Channels Per Universe setting. |
<table>
<thead>
<tr>
<th>Version</th>
<th>Software Version</th>
<th>Date</th>
<th>Changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.2.7055</td>
<td>MADRIX 3.6g</td>
<td>September 2017</td>
<td>- Added new supported LEDs: GW6205.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Added new supported LEDs: SJ1221.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Added new supported LEDs: LPD1882S.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Added new supported LEDs: WS2815.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Fixed an important issue that allowed the device to only send with the lowest, received frame rate, when receiving different frame rates for different DMX universes on a single port. This behaviour was mainly triggered when used with a lighting console.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Fixed an issue that correctly set Channels Per Universe in the web configuration but still displayed the value as 'Automatic'.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Fixed an issue that did not set Channels Per Universe for Port 2 if USB as well as Ethernet were connected and the settings was changed for both ports in the MADRIX Device Configuration.</td>
</tr>
<tr>
<td>1.4.7082</td>
<td>MADRIX 3.6h</td>
<td>February 2018</td>
<td>- Added new supported LEDs: UCS9812S.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>- Fixed a connection issue that did not report the device settings and status correctly in the MADRIX Device Configuration dialog when only connecting over Ethernet network.</td>
</tr>
</tbody>
</table>
Important Information

- In general, it is recommended to always activate all output universes. SPI communication is based on strictly serial protocols, which means that data is always sent in succession. For example, when having output universe 1 and 4 activated and having output universe 2 and 3 deactivated, the data for output universe 4 will be sent directly after the data for output universe 1.

Technical Advice

This section contains technical information that point out specific advice for certain LED types.

<table>
<thead>
<tr>
<th>LED</th>
<th>Technical Advice</th>
</tr>
</thead>
</table>
- WS2815
- LEDs of the type WS2815 normally require 12 V to work.
- MADRIX NEBULA offers a variety of wiring possibilities as shown in the MADRIX NEBULA Quick Start Guide & Technical Manual.
- Due to this variety of options, WS2815 might start to flicker when the data signal from the NEBULA unit to the LEDs does not provide enough voltage in certain ways of wiring.
- The issue described above usually only becomes apparent when 12 V power is supplied to the WS2815 LEDs as well as 5 V separately to NEBULA via an external power supply, such as USB or USB power supply.
- Then, the data signal from the NEBULA might fall below the required voltage to control the LEDs due to the power loss from power input to data output.
- If power is supplied separately, to NEBULA at 5 V and to WS2815 at 12 V, then it is recommended to supply power of more than 5 V to the NEBULA (> 5 V) in order to counteract the power loss and avoid data signal issues, which can result in flickering on the LEDs.
11.6 MADRIX STELLA

This topic includes:

- Overview
- Using A 3rd-Party Controller
- Putting The Device Into Operation
- LED Status Codes
- Automatic HTP Merging
- Reset To Factory Default Settings
- Device Configuration
- Using The MADRIX Software
- DMX Watcher
- Firmware Updates

Overview
MADRIX STELLA is a 2-port network node for solid-state projects.
The MADRIX STELLA is a dedicated control interface for DMX512 and Art-Net or Streaming ACN that is designed for high quality and practicability in permanent LED installations.

Using A 3rd-Party Controller

MADRIX STELLA is a standard network node. Because of this, you can use the device with applications, consoles, desks, or controllers that are compatible with Art-Net or Streaming ACN to distribute network data via Ethernet network.

Putting The Device Into Operation

1] Connecting Your LED Fixtures

Please see the MADRIX STELLA Quick Start Guide & Technical Manual on how to connect your LED fixtures to MADRIX STELLA.
» help.madrix.com

2] Connecting To Power And Data

Please see the MADRIX STELLA Quick Start Guide & Technical Manual on how to connect to power and data.
» help.madrix.com

3] Device Settings
Make sure to set the correct network data source and other settings according to the controller/sender you want to use.

Learn more:

- Device Configuration

### LED Status Codes

The following tables describe the LED status codes of the device.

<table>
<thead>
<tr>
<th>STATUS</th>
<th>STATUS LED POWER</th>
</tr>
</thead>
<tbody>
<tr>
<td>Powered off</td>
<td>Power not connected. The device has no power.</td>
</tr>
<tr>
<td>Permanently green</td>
<td>Connected to power. The power is on.</td>
</tr>
<tr>
<td>Blinking green</td>
<td>Bootloader activated. Reset the device to factory default settings.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>STATUS</th>
<th>STATUS LED USB</th>
</tr>
</thead>
<tbody>
<tr>
<td>Powered off</td>
<td>USB not connected.</td>
</tr>
<tr>
<td>Red + blinking green</td>
<td>Communicating over USB. Sending or receiving data over USB. The USB port works.</td>
</tr>
<tr>
<td>Fading between red + green</td>
<td>Connected to USB; Drivers installed correctly. No data is sent over USB.</td>
</tr>
<tr>
<td>Orange</td>
<td>Connected to USB; No drivers installed. Reinstall software and drivers or try a different USB port.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>STATUS</th>
<th>STATUS LED DMX 1</th>
<th>STATUS LED DMX 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Powered off</td>
<td>No data is sent.</td>
<td>No data is sent.</td>
</tr>
<tr>
<td>Blinking green</td>
<td>Sending or receiving data. The DMX port works.</td>
<td>Sending or receiving data. The DMX port works.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>STATUS</th>
<th>STATUS LED ETHERNET</th>
</tr>
</thead>
</table>

www.madrix.com
Automatic HTP Merging

Overview

- MADRIX STELLA features automatic HTP merging from 2 Art-Net sources.
  [Usually, the first source will be MADRIX. The second source could be a console, for example.]
- Data from both source will be merged together and sent out as 1 signal. This happens across all ports and by using the HTP principle.
- **HTP** - Is the acronym for Highest Takes Precedence. Data from both sources will be compared for each individual channel. The higher value wins per channel.

**Example:** We are using an LED fixture with a total of 5 control channels [3 color channels and 2 movement channels]. MADRIX should provide the color data for channels 1 to 3 and the console should provide the movement data for channels 4 and 5. Using the MADRIX Fixture Editor, we could create a corresponding fixture where channel 4 and 5 are set up as Fixed channel using always a value of 0. On the other hand, the console will always send a value of 0 for the first 3 channels of each fixture. This will ensure that the data from the console will always provide the higher value on channels 4 and 5, while MADRIX provides the color data. Due to the automatic HTP merging of the device, the LED fixture will receive correct data from both sources as desired.

Configuration And Recommendations

1) Correctly set up and enable Art-Net for each source.
2) Make sure to activate ArtSync for Art-Net in MADRIX. Learn more Sync Mode.
3] Make sure that MADRIX has a **lower IP address** compared to the second source.
   [E.g., 2.0.0.1 compared to 2.0.0.20]

4] Always use **Unicast Mode** to directly send data to the correct IP addresses of your MADRIX STELLA devices.
   [It is not recommend to have any of the two sources or any other source in the network to send data via Broadcast Mode.]

---

**Reset To Factory Default Settings**

In rare cases you might need to do a reset to factory default settings, for example to reset to the device to its default IP address as shown on the side of the device:

**Reset Via Reset Button**

1] Disconnect all connections from the device [power, data, DMX].

2] Use a suitable tool to press the reset button [between DMX 1 and DMX 2].

3] Continue to press the reset button and supply power again over 'Power' or USB.

4] Continue to press the reset button and wait until all status LEDs of the device flash repeatedly or wait 10 seconds.
   [Simply repeat these steps should the process fail.]

---

**Device Configuration**

When connected to Ethernet network, you can easily configure MADRIX STELLA using the built-in web configuration page.

You have 2 options to access the web interface. Both, STELLA and your computer, need to be in the same network.

A] Using a standard web browser:

- Connect MADRIX STELLA and your computer to the same network.
• Assign correct network settings for your PC in the Windows operating system.
  [Recommended default settings: IP address 10.0.0.1 / Subnet mask 255.0.0.0]

• Open your web browser and enter the IP address of MADRIX STELLA.
  [You can find the default IP address on the back side of the device.]

• The web configuration page will be launched. Now, you have access to various information and settings.

B] Using the MADRIX Software:

• Connect MADRIX STELLA and your computer to the same network.

• Assign correct network settings for your PC in the Windows operating system.
  [Recommended default settings: IP address 10.0.0.1 / Subnet mask 255.0.0.0]

• Go to the menu Tools > MADRIX Device Configuration...
  [Keyboard shortcut: Ctrl+Alt+L]

• Select your MADRIX STELLA device in the list.

• Click HTTP

• Your default web browser will open and the web configuration page will be launched. Now, you have access to various information and settings.
### STELLA

**Device Name**
- MADRIX STELLA

**Device Settings**

<table>
<thead>
<tr>
<th>IP Address</th>
<th>Submit Mask</th>
</tr>
</thead>
<tbody>
<tr>
<td>192.168.0.70</td>
<td>255.0.0.0</td>
</tr>
</tbody>
</table>

**DMX Output Settings**

<table>
<thead>
<tr>
<th>Port</th>
<th>Network Universe</th>
<th>Start Channel</th>
<th>Channels Per Universe</th>
<th>Channel Order</th>
</tr>
</thead>
<tbody>
<tr>
<td>DMX 1</td>
<td>0x00</td>
<td>0x01</td>
<td>Automatic</td>
<td>1-3-3-3-0</td>
</tr>
<tr>
<td>DMX 2</td>
<td>0x01</td>
<td>0x02</td>
<td>Automatic</td>
<td>1-2-2-3-0</td>
</tr>
</tbody>
</table>

**In Case Of Data Connection Loss**
- On Each Affected Port: Stop Sending

**Network Data Sources**
- Device Accepts Data From: Art-Net And sACN

**DMX Input Settings**

<table>
<thead>
<tr>
<th>Input Port</th>
<th>Network Universe</th>
<th>Send Always Full Frames (512 Ch) To Network</th>
</tr>
</thead>
<tbody>
<tr>
<td>DMXIN Port 1</td>
<td>0xFF</td>
<td></td>
</tr>
<tr>
<td>DMXIN Port 2</td>
<td>0xFE</td>
<td></td>
</tr>
<tr>
<td>Art-Net Broadcast Mode</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Art-Net Unicast Mode</td>
<td>255</td>
<td>255</td>
</tr>
<tr>
<td>sACN Multicast Mode</td>
<td>To IP: 293.255.1.0 / 293.255.0.255</td>
<td></td>
</tr>
</tbody>
</table>

**Device Information**

- Model: MADRIX STELLA
- IP Address: 10.78.0.86
- MAC Address: 00:00:00:00:00:00
- Serial Number: STELLA0000086
- Firmware: 2.0.7140 Jun 28 2018 13:45:17
- Bootloader: 1.2.9010 Mar 11 2018 10:10:53
- Hardware: 1.0
- Voltage: Power: 0.0 V
- Temperature: °C / °F
- Ethernet: 100 MB/s Full-Duplex

For more information visit [www.madrix.com](http://www.madrix.com).
Please confirm any changes with `Set`.

**Device Name**
You can change the description of the device. This label is only shown in this web interface.

**Device Settings**
You can change the *IP address* and *Subnet Mask*. 
**DMX Output Settings**  
This section shows specific settings for the DMX ports for output.

**Network Universe** - Defines the universe on which data is sent. By default, universe 1 and 2 assigned to DMX 1 and DMX 2.

If you are broadcasting data for a large number of Universes [using Broadcast Mode instead of using Unicast Mode] with MADRIX or a 3rd-party controller for example, you can assign different DMX universes to each STELLA device with these settings. Each MADRIX STELLA will then only receive data from the specific Art-Net universe and send it to its specified output port. Example: You can set up that STELLA #1 only listens to Art-Net universe 1 and 2, while STELLA #2 listens to Art-Net universe 3 and 4, and STELLA #3 listens to Art-Net universe 5 and 6, and so on.

**Start Channel** - Is especially useful for splitting a single universe onto the two ports. For example, your sender can only send on one universe and you wish to output it on both ports. On DMX 1, you would like to send the first 150 channels and on DMX 2, you would like to send channels 151 to 300. Then, you can set the Start Channel of DMX 2 to 151.

**Channels Per Universe** - Defines how many channels are being sent out. 512 means full frames. Automatic means optimized frames and that the number that is received is also sent out.

**Channel Order** - Allows you to change the order of [color] channels for the output. For example, if you receive channels 1-2-3 [i.e. RGB, for example], the setting 1-2-3-(4) will send it out as R-G-B. In contrast, the setting 3-2-1 would send B-G-R. [Please only change this setting when needed and when using simple, standard fixtures with RGB or RGBW, for example.]

**In Case Of Data Connection Loss**

**On Each Affected Port** - Defines the output settings of the STELLA if the device does not receive data anymore for a specified port. Choose from the following options:

- **Send The Last Received Frame Continually**
- **Send Black Frames Continually**
- **Stop Sending After Sending A Black Frame**
- **Stop Sending**
**Network Data Sources**  

**Device Accepts Data From** - Defines the data source:

- Art-Net
- Streaming ACN
- Art-Net And sACN

**DMX Input Settings**  

This section allows you to specify settings for the DMX ports for input.

When data is received, MADRIX STELLA will automatically forward it to Ethernet network.

**Network Universe** - STELLA can receive 512 channels per port. This setting defines on which universe those 512 channels are sent. By default, **256** is set for DMX 1 and **255** is set for DMX 2. Valid values range from 1 to 256.

**Send Always Full Frames (512 CH) To Network** - Defines that the STELLA will always send out 512 channels, even if the data received by STELLA includes less than 512 channels for this port and universe. STELLA automatically sends values of 0 on channels that are not used.

Additionally, choose to how MADRIX STELLA sends the data into the network:

- **Art-Net Broadcast Mode** - Sents Art-Net data to all IP addresses in the network.
- **Art-Net Unicast Mode** - Sents Art-Net data only to one recipient, e.g. your MADRIX computer [Enter the IP address of your MADRIX computer].
- **sACN Multicast Mode** - Sents sACN data to IP address 293.255.1.0.
Device Information

This section displays various details about the device, including:

- **Model** [Device type]
- **IP Address** [The current IP address.]
- **MAC Address** [A permanent, unique address.]
- **Serial Number**
- **Firmware** [The current firmware version.]
- **Bootloader** [The current bootloader version.]
- **Hardware** [Hardware model]
- **Voltage** [The current voltage for Input.]
- **Temperature** [The current ambient temperature.]
- **Ethernet** [The current status of the network connection.]

Using The MADRIX Software

The MADRIX STELLA works great in combination with the MADRIX Software.

MADRIX 5 Software License

- The MADRIX 5 Software license is not included and sold separately. A MADRIX 5 KEY is necessary if you want to use output.
- No separate license is required for DMX Input [DMX-IN].

Operating Modes

You can mainly use 6 operating modes together with MADRIX:
DMX-OUT Via Ethernet Network [Art-Net]
DMX-OUT Via Ethernet Network [Streaming ACN / sACN]
DMX-OUT Via USB
DMX-IN Via Ethernet Network [Art-Net Remote]
DMX-IN Via Ethernet Network [Streaming ACN / sACN]
DMX-IN Via USB

Notes:
- DMX 1 can be configured as either DMX-IN or DMX-OUT.
- DMX 2 can be configured as either DMX-IN or DMX-OUT.
- You can use DMX 1 and DMX 2 at the same time.

DMX-OUT Via Ethernet Network [Art-Net]

Overview

You can connect the STELLA over Ethernet network to the network card of your computer that runs the MADRIX Software. Data is distributed to the STELLA over network cabling [Ethernet] and sent to the two ports [DMX 1 and DMX 2].

1] Initial Configuration
- Put MADRIX STELLA into operation; as described above. Learn more Putting The Device Into Operation
- Connect MADRIX STELLA to your computer using Ethernet network cabling.
- It is highly recommended to use Gigabit Ethernet network components [network card, switches, etc.].

2] Windows Network Settings
Art-Net is a network-based protocol. MADRIX will use the network card of your computer to send data.

- It is required to set up the correct network settings in Windows, first.
- You must use these IP address and Subnet mask settings. Otherwise, Art-Net might not work!
- The IP addresses of your computer and your MADRIX STELLA devices need to be different.

- Set up an individual **IP address** in the following IP address range:
  - 2.0.0.1 ... 2.255.255.254 or
  - 10.0.0.1 ... 10.255.255.254
- Set up the corresponding **Subnet mask**
  - 255.0.0.0

[Via factory default settings, MADRIX STELLA devices will have an IP address in the 10.x.x.x network range, such as 10.78.0.86, for example].

- **Restart MADRIX, if you have changed the network settings in Windows while MADRIX was running.**
- Learn more »[Tips [Microsoft Windows / Networks / USB]]

- Example for PCs that are running MADRIX:
3] Fixture Configuration In MADRIX

- Start the MADRIX Software.
- Configure the virtual LED matrix using the »Matrix Generator« or »Patch Editor«.

4] Activating Art-Net

- Go to the menu Preferences > Device Manager... > Art-Net
  [Keyboard shortcut: F4 > Art-Net]
- Activate the checkbox Enable [in the upper, right corner].
5] Adding Devices Automatically

MADRiX can automatically add your MADRIX STELLA devices.

- Click [Search] button.

[MADRiX will automatically search the network for connected MADRIX STELLA devices. Devices that are found will appear in the list. One entry will be created in the list for each STELLA device.]
6] Activating Devices

Each of your MADRIX STELLA devices and its ports need to be activated. By default, they are still deactivated.
- Go to the menu **Preferences > Device Manager... > DMX Devices**
  [Keyboard shortcut: F4]
- Select your devices and their ports in the list.
- Activate **Enable**
- **Output** is activated by default.
- Click **Apply**

- [In the screenshot above, one STELLA is connected. If more devices are connected, please use the different IP addresses of different devices to identify them in the Device Manager.]

### 7] Configuration Of DMX Output

- Make sure that your devices are still selected under **Preferences > Device Manager... > DMX Devices**
- Set up **Universe**
  - Enter the specific DMX universe number.
- This setting assigns a specific DMX universe [of the Patch] to the device or the port of the device.
- Make sure the correct universe is assigned according to your requirements.
  Learn more »Glossary

- Click Apply

- By default, DMX universe 1 is assigned to DMX 1 and DMX universe 2 is assigned to DMX 2.

8] Frame Time

- Make sure that your device is still selected under Preferences > Device Manager... > DMX Devices

- Set up Frame Time (ms)
  - The Frame Time affects the Frame Rate. The Frame Rate specifies how fast data is sent to the device or received from it [Frames Per Second; FPS].
  - Increase the Frame Time in order to decrease the Frame Rate [e.g., 40ms = 25 FPS].
  - Decrease the Frame Time in order to increase the Frame Rate [e.g., 20ms = 50 FPS].
  - The default value is 30 ms / 33.3 FPS.
  - Some LED fixtures might have problems with a high Frame Rate. Then, it is recommended to increase the Frame Time / to decrease the Frame Rate.

- Click Apply

- [When using Art-Net, the Frame Time [ms] can be individually set for each port. But it cannot be set individually for each port, when Sync Mode is activated. Learn more below.]
9] Sync Mode

MADRIX STELLA can use the special sync mode of Art-Net.

- Large LED projects require dependable data distribution. The MADRIX software and STELLA hardware allow you to fully synchronize data output for all output DMX ports and even across multiple STELLA devices to get an optimal image on the LEDs.
- When Art-Net sync mode is activated, MADRIX and MADRIX STELLA will automatically handle the synchronization of data.

Art-Net Sync Mode is highly recommended for MADRIX STELLA!

**ArtSync** - Allows you to activate or deactivate the usage of sync packages for Art-Net.
- Your Art-Net devices need to support this feature in order for it to work correctly.
- All MADRIX hardware Art-Net nodes support ArtSync.

In addition, you can choose between **Post-Sync** [default] and **Pre-Sync**. By default, the sync data is sent after the color data. Pre-Sync would send it before the color data.

- **Before activating sync**, make sure that all activated Art-Net devices are available in your network! Else, the frame rate of Art-Net might drop. If you are not sure, do not enable any sync mode.

Additional Art-Net Device Settings

**It is very important to set up the correct settings of your devices!**

Broadcast Mode Or Unicast Mode

MADRIX can send Art-Net data in 2 ways to your Art-Net devices:

- **Broadcast Mode** - Means that every packet sent from a single transmitter will be received by all recipients in the network. MADRIX will send data to all devices in the network.
  - Advantage: The same data [e.g., DMX universe 1 and 2] can be made available at different points of your setup.
  - Disadvantage: A potentially huge number of data packages will be sent over the network. This can reduce the overall network performance and cause data issues or instability.

- **Unicast Mode** - Means that the specific data will only be sent to the specified recipient.
  - Advantage: Data traffic is reduced immensely, which means that a larger number of Art-Net devices can be used in one network. Reduced network traffic increases the performance and stability.
  - Disadvantage: The network settings of all devices need to be 100% correct.

**Unicast Mode is recommended in general.**

- Go to the menu *Preferences > Device Manager... > Art-Net*
  [Keyboard shortcut: *F4 > Art-Net*]
- Select your device in the list.
- Click ![icon](image)
- A new window will open.
- **A**] Choose *Send Unicast Mode* to activate Unicast Mode:
  - Make sure to enter the correct *IP Address* of your device that should receive the Art-Net data.
  - MADRIX will send the corresponding data only to this device.
- **B**] Choose *Send Broadcast Mode* to activate Broadcast Mode:
  - Make sure to select the correct *Network* card of your computer that should send the Art-Net data.
  - MADRIX will send data to the whole Art-Net network.
- Click *Apply*

**Status Indicators [ArtAddress]**
In order to use these features, please **Enable ArtAddress** first.

[Please make sure that your nodes fully support this Art-Net feature, such as MADRIX LUNA, MADRIX NEBULA, MADRIX PLEXUS, MADRIX STELLA. You will also get notified by a message box. Confirm the message with **OK** or abort via **Cancel**]  

**Mute Status Indicators** - Switches off and disables all built-in status indicators of a device over Art-Net [ArtAddress > AcLedMute].

**Operate Status LEDs Normally** - Allows the built-in status indicators of a device to operate normally again, after having them switched off [ArtAddress > AcLedNormal].

**Highlight Device** - Activates the highlight mode [ArtAddress > AcLedLocate]. Select one or more interfaces and click the button. The corresponding status indicators of the selected interfaces will flash for a better identification or tests. This makes it easier to see them on site/stage. It considerably speeds up the procedure of programming or testing the selected interfaces.

**More Information About Art-Net**

Learn more »[Art-Net [DMX Over Ethernet]]

**Data Output Over Ethernet Network [Streaming ACN / sACN]**

**Overview**

You can connect the STELLA over Ethernet network to the network card of your computer that runs the MADRIX Software. Data is distributed to the device over network cabling [Ethernet] and sent to the output ports [DMX 1 and DMX 2].
1] Initial Configuration
- Put MADRIX STELLA into operation; as described above. Learn more Putting The Device Into Operation
- Connect MADRIX STELLA to your computer using Ethernet network cabling.
- It is highly recommended to use Gigabit Ethernet network components [network card, switches, etc.].

2] Windows Network Settings
- MADRIX automatically sets up Streaming ACN network settings for you.
  [MADRIX supports multicast Streaming ACN. Data is automatically sent to all corresponding sACN devices in the network. Unicast is also supported.]
- You only need a computer with a network card and a valid IP address.
- You do not have to change the IP address settings in Windows for Streaming ACN!
- The IP address range for sACN devices is 239.255.X.X according to the Streaming ACN specifications. MADRIX STELLA automatically works this way.
- Make sure that your Firewall does not block data of the 239.255.X.X IP address range!
- Check the settings of the Windows Firewall.
- Learn more »Tips [Microsoft Windows / Networks / USB]}

3] Fixture Configuration In MADRIX
- Start MADRIX 5.
- Configure the virtual LED matrix using the »Matrix Generator or »Patch Editor

4] Activating Streaming ACN
- Go to the menu Preferences > Options... > Devices Network
  [Keyboard shortcut: Ctrl+Alt+O > Devices Network]
- Activate ESTA - Streaming ACN
- **Choose your network card** from the drop-down list. Make sure to select the correct network adapter that will be used for Streaming ACN!
  [The IP address and Subnet mask label should help you select the correct adapter. It is not necessary to change any of these networks settings.]

- **ACN Device Count** - Set up how many you are going to use. MADRIX STELLA requires 2 sACN devices per unit.
  [This is the total amount of devices. Please set the exact number of devices you are using. If the count is higher, this creates unnecessary network traffic.]

- Press **Apply**

- **ACN CID** - Being a network protocol, Streaming ACN sends a so-called CIDs [Component Identifier].
  - Every single ACN device has such a unique ID.
  - When using Streaming ACN, your MADRIX Software is one of those devices.
  - When you start MADRIX for the first time, this ID will be generated automatically for you. From this point onwards it will be used on your PC.
  - With this ID your MADRIX Software can be easily identified in the network. Interfaces can detect this unique ID and can be configured to receive data from this particular device. Please note that the ACN interface must support this feature.
  - **Do not change the ACN CID, unless you are an experienced user!**
- Press **OK** to close the window.

5] Activating Devices

Each of the ports need to be activated. By default, they are still deactivated.
Go to the menu **Preferences > Device Manager... > DMX Devices**

[Keyboard shortcut: **F4**]

- Select your devices and their ports in the list. 8 output universes will be shown.
- Activate **Enable**
- Click **Apply**

![Device Manager Screenshot](image)

- [In the screenshot above, one STELLA is connected. If more devices are connected, please use the different universes of different devices to identify them in the Device Manager.]
- **Universe** - Defines which universe of your MADRIX Patch is sent to this particular device.

### 6A] Configuration Of Single Devices

- Select a device in the list and click **Apply**
A new window will open.

Set up the following settings for your devices:

- **Source Name** - Allows you to set up a specific name for the device. This name is send via network as well. Therefore, interfaces may be able to retrieve this name and can be configured to receive data from this source.
  - If you are using the default name **MADRIX U:X**, the universe will automatically be displayed in the name [represented by X: 1, 2, 3, etc.].
- **ACN Universe** - Defines the DMX universe of the device.
  - **Set up the same universe that is set up in your sACN device, which is MADRIX STELLA.**
  - According to the Streaming ACN specifications, MADRIX will automatically change the ACN IP Address according to the ACN Universe.

- **ACN Priority** - Was implemented for backup solutions. Valid values range from 0 to 200, which is the highest priority.
  - For example, you may have set up two MADRIX PCs. One gets a priority of 100. The second PC gets a priority of 50. If the first PC fails and only if it malfunctions, data will be automatically received from PC #2.
  - Data will always be received from the device with the highest priority. Please note that the ACN device must support this feature.

- **ACN Protocol** - Automatically selects the **ANSI 2009** standard.

- **Use Multicast**
  - **ACN Multicast IP Address** - Displays the IP address of the device as automatically assigned by MADRIX according to the Streaming ACN specifications. The last 2 digits match the assigned DMX universe.

- **Use Unicast**
  - **ACN Unicast IP Address** - Uses a specific IP address to send data to.

- Press **Apply** to confirm your changes.
- Press **OK** to close the window.

### 6B] Configuration Of Multiple Devices

- You can configure **several interfaces** at the same time.

- Follow the steps of 6A, but select multiple devices and press

- A new window will open.
Set up the settings as described under 6A].

For **ACN Universe** you have now additional options for **Auto Numbering**:

- Leave this button deactivated and every device will get the same number of universes.
- Activate the button and MADRIX will automatically increase the number for all the selected devices, starting with the ACN Universe value you entered.

Press **Apply** to confirm your changes.

Press **OK** to close the window.

### 7] Frame Time

- Make sure that your device is still selected under **Preferences > Device Manager... > DMX Devices**

- Set up **Frame Time (ms)**
  - The Frame Time affects the Frame Rate. The Frame Rate specifies how fast data is sent to the device or received from it [Frames Per Second; FPS].
  - Increase the Frame Time in order to decrease the Frame Rate [e.g., 40ms = 25 FPS].
  - Decrease the Frame Time in order to increase the Frame Rate [e.g., 20ms = 50 FPS].
  - The default value is 30 ms / 33.3 FPS.
  - **Some LED fixtures might have problems with a high Frame Rate. Then, it is recommended to increase the Frame Time / to decrease the Frame Rate.**
DMX-OUT Via USB

Overview

You can connect the STELLA directly over USB to the computer that runs the MADRIX Software. Data is distributed to the MADRIX STELLA via USB and sent to the two ports [DMX 1 and DMX 2].

1] Initial Configuration

- Put MADRIX STELLA into operation by connecting the LED fixtures and supplying power; as described above.
  Learn more Putting The Device Into Operation
- Connect MADRIX STELLA to your computer via USB.
  [Use the provided USB cable.]
- Make sure to check the power management options of Windows. Learn more »PC Power Management

2] Fixture Configuration In MADRIX

- Start MADRIX.
- Configure the virtual LED matrix using the »Matrix Generator or »Patch Editor

3] Enabling Drivers In MADRIX

- Go to the menu Preferences > Options... > Devices USB
  [Keyboard shortcut: Ctrl+Alt+O > Devices USB]
- Activate MADRIX STELLA
- Click Apply
- Close the window with OK
4] Activating Devices

- Go to the menu Preferences > Device Manager... > DMX Devices
  [Keyboard shortcut: F4]

- Your STELLA devices and their two ports will appear in the list.

- If your devices are not in the list, click
  [In the screenshot below, one STELLA is connected.]

- By default, all ports are activated [State On].

- If your device and ports are not activated, do the following:
  - Select the device/port in the list.
  - Activate Enable
  - Activate Output
  - Click Apply

5] Configuration Of DMX Output

- Make sure that your devices are still selected under Preferences > Device Manager... > DMX Devices
- Set up *Universe*
  - Enter the specific DMX universe number.

- This setting assigns a specific DMX universe [of the Patch] to the device or the port of the device.

- **Make sure the correct universe is assigned according to your requirements.**
  Learn more »[Glossary](#)

- Click *Apply*

- By default, DMX universe 1 is assigned to DMX 1 and DMX universe 2 is assigned to DMX 2.

### 6] Frame Time

- Make sure that your device is still selected under *Preferences > Device Manager... > DMX Devices*

- Set up *Frame Time (ms)*
  - The Frame Time affects the Frame Rate. The Frame Rate specifies how fast data is sent to the device or received from it [Frames Per Second; FPS].
  - Increase the Frame Time in order to decrease the Frame Rate [e.g., 40ms = 25 FPS].
  - Decrease the Frame Time in order to increase the Frame Rate [e.g., 20ms = 50 FPS].
  - The default value is 30 ms / 33.3 FPS.
  - Some LED fixtures might have problems with a high Frame Rate. Then, it is recommended to increase the Frame Time / to decrease the Frame Rate.

- Click *Apply*

**More Information About DMX Output**

Learn more »[DMX512 [DMX-OUT]](#)

**DMX-IN Via Ethernet Network [Art-Net Remote]**

**Overview**
You can connect MADRIX STELLA over Ethernet network to the network card of your computer that runs the MADRIX software. Data is sent to the STELLA via a port and from the STELLA to MADRIX via Ethernet network.

1] Initial Configuration

- Connect your external DMX controller to the DMX port of MADRIX STELLA.
- Connect MADRIX STELLA to power.
  [Please see safety instructions in the *MADRIX STELLA Quick Start Guide & Technical Manual*]
- Connect MADRIX STELLA to your computer via network cabling.
- It is highly recommended to use Gigabit Ethernet network components [network card, switches, etc.].
- Put MADRIX STELLA into operation by setting the correct device settings; as described above. Learn more
  *Putting The Device Into Operation*

2] Windows Network Settings

Art-Net is a network-based protocol. MADRIX will use the network card of your computer to send data.

- **It is required to set up the correct network settings in Windows, first.**
- You must use these IP address and Subnet mask settings. Otherwise, Art-Net might not work!
- The IP addresses of your computer and your MADRIX STELLA devices need to be different.

- Set up an individual *IP address* in the following IP address range:
  - 2.0.0.1 ... 2.255.255.254 or
  - 10.0.0.1 ... 10.255.255.254
- Set up the corresponding *Subnet mask*
  - 255.0.0.0

  [Via factory default settings, MADRIX STELLA devices will have an IP address in the 10.x.x.x network range, such as 10.78.0.86, for example].

- **Restart MADRIX, if you have changed the network settings in Windows while MADRIX was running.**
- Learn more »*Tips [Microsoft Windows / Networks / USB]*
3] Activating Art-Net

- Go to the menu Preferences > Device Manager... > Art-Net
  [Keyboard shortcut: F4 > Art-Net]

- Activate the checkbox Enable [in the upper, right corner].

- MADRIX will automatically create the entry ArtNet Remote
  This device is used only for Remote Control.

4] Adding Devices Automatically

MADRIX can automatically add your MADRIX STELLA devices.

- Click
  [MADRIX will automatically search the network for connected MADRIX STELLA devices. Devices that are found will appear in the list. One entry will be created in the list for each STELLA device.]
5] Configuration Of Art-Net Input

- Select your STELLA device in the list.

- Click 

- A new window opens [Art-Net Device Configuration].
- **Universe Port IN**
  - By default, MADRIX STELLA sends DMX-IN data to universe 256 for Port 1 and to universe 255 for Port 2. You can change these settings in the Web Configuration or MADRIX Device Configuration window if required.
  - If you have changed the settings, enter the exact same network universes here!

- Activate **Receive Direct IP Mode** and enter the **IP Address** of your MADRIX STELLA. Confirm with **Apply** [E.g., 10.206.224.14]

- [You can also activate **Receive Broadcast Mode**. In this mode, MADRIX will receive any DMX data that is sent in the network on this particular Art-Net universe.]

- Click **OK**
6] Activating Your Art-Net Input Device

You need to activate the Art-Net input device. It is still deactivated.

- Go to the menu **Preferences > Device Manager... > DMX Devices**
  [Keyboard shortcut: **F4**]

- Select the STELLA device in the list per its port.

- Activate **Enable**

- Activate **Input**

- Click **Apply**
If required, change the *Frame Time (ms)*

The higher the Frame Time, the lower the FPS will be. The lower the Frame Time, the higher the FPS will be.
The default Frame Time is 33.
Press *Apply* to confirm.

7] Activating DMX Input

- Go to the menu *Preferences > Device Manager... > DMX Input*
- Select your preferred DMX **Universe** in the list.
  
  [By default, DMX universe 1 to 8 are listed. If you wish to increase the number of DMX-IN universes, you can change the setting. Learn more »**Performance**](Performance)]

- Choose your **DMX-IN Device** in the section **Device**. Select the **ArtNet** input device.

- Art-Net input is now activated. MADRIX can already receive DMX data.
Now, choose how to use incoming data. Learn more »Art-Net Remote

DMX-IN Via Ethernet Network [Streaming ACN / sACN]

Overview

You can connect MADRIX STELLA over Ethernet network to the network card of your computer that runs the MADRIX Software. Data is sent to the STELLA via a port and from the STELLA to the MADRIX via Ethernet network.

1] Initial Configuration

- Connect your external DMX controller to the DMX port of MADRIX STELLA.
- Connect MADRIX STELLA to power.
  [Please see safety instructions in the MADRIX STELLA Quick Start Guide & Technical Manual]
- Connect MADRIX STELLA to your computer via network cabling.
- It is highly recommended to use Gigabit Ethernet network components [network card, switches, etc.].
- Put MADRIX STELLA into operation by setting the correct device settings; as described above. Learn more Putting The Device Into Operation

2] Windows Network Settings

- MADRIX automatically sets up Streaming ACN network settings for you.
- You only need a computer with a network card and a valid IP address.
  - You do not have to change the IP address settings in Windows for Streaming ACN!
  - The IP address range for sACN devices is 239.255.X.X according to the Streaming ACN specifications.
    [Even if your sACN devices are set to a different IP address range, you may try the connection from MADRIX to your devices.]
  - Make sure that your Firewall does not block data of the 239.255.X.X IP address range!
  - Check the settings of the Windows Firewall.
3] Activating Streaming ACN

- Go to the menu *Preferences > Options... > Devices Network*
  [Keyboard shortcut: *Ctrl+Alt+O > Devices Network*]

- Activate *Enable ESTA - Streaming ACN*

- **Choose your network card** from the drop-down list. Make sure to select the correct network adapter that will be used for Streaming ACN!
  [The IP address and Subnet mask label should help you select the correct adapter. It is not necessary to change any of these networks settings.]

- **ACN Device Count** - Set up how many you are going to use.
  [This is the total amount of OUT and IN devices. Please set the exact number of devices you are using. If the count is higher, this creates unnecessary network traffic.]

- Press **Apply**
- **ACN CID** - Being a network protocol, Streaming ACN sends a so-called CIDs [Component Identifier].
  - Every single ACN device has such a unique ID.
  - When using Streaming ACN, your MADRIX Software is one of those devices.
  - When you start MADRIX for the first time, this ID will be generated automatically for you. From this point onwards it will be used on your PC.
  - With this ID your MADRIX Software can be easily identified in the network. Interfaces can detect this unique ID and can be configured to receive data from this particular device. Please note that the ACN interface must support this feature.
  - **Do not change the ACN CID, unless you are an experienced user!**
- Press **OK** to close the window.

**4] Enabling Input**

- Go to **Preferences > Device Manager... > DMX Devices**
  - [Keyboard shortcut: F4]
  - MADRIX automatically creates and adds the number of interfaces to the list.
    - [according to **ACN Device Count**]
- Select your device.
- Enable **Input** if you wish to receive incoming data through this device.
- Click **Apply**
- In DMX-IN mode, you will not be able to select the ACN protocol. MADRIX will automatically select the correct protocol version.
• **Note:** If you are loading a MADRIX Setup, please check if the number of ACN devices in your setup corresponds with the number that is activated. The Setup stores the number of devices. But if you changed the amount and then loaded the Setup, the newly defined number will be activated.

5] **Configure Your Device**

• Make sure that your device is still selected under *Preferences > Device Manager... > DMX Devices*

• Click ![Device Manager Icon]

• A new window will open.
Set up the following settings for your devices:

- **Source Name** - Allows you to set up a specific name for the device. This name is send via network as well. Therefore, interfaces may be able to retrieve this name and can be configured to receive data from this source.
  - If you are using the default name **MADRiX U:X**, the universe will automatically be displayed in the name [represented by X: 1, 2, 3, etc.].

- **ACN Universe** - Defines the DMX universe from which data is received.
  - Set up the same universe that is set up in your MADRIX STELLA according to the Web Configuration. By default, MADRIX STELLA sends input data to network universe 256 for DMX 1 and universe 255 for DMX 2. You can change these settings in the Web Configuration if required.
  - According to the Streaming ACN specifications, MADRIX will automatically change the ACN IP Address according to the ACN Universe.

Press **Apply** to confirm your changes.

Press **OK** to close the window.

6] **Enable DMX-IN**

- Go to the menu **Preferences > Device Manager... > DMX Input**
Select your preferred DMX *Universe* in the list.  
[By default, DMX universe 1 to 8 are listed. If you wish to increase the number of DMX-IN universes, you can change the setting. Learn more >Performance](#).  
  
- Choose your *DMX-IN Device* in the section *Device*  

  ![Device Manager](image)

- [If needed, you can disable DMX-IN by choosing *None* for your *DMX-IN Device* in the section *Device*](#)
sACN input is now activated. MADRIX can already receive DMX data.

Now, choose how to use incoming data. Learn more »sACN Input

DMX-IN Via USB

Overview

You can connect the STELLA directly via USB to the computer that runs the MADRIX Software. Data is sent to the STELLA via a port and from the STELLA to MADRIX via USB.

1] Initial Configuration

- Connect your external DMX controller to the required DMX port of MADRIX STELLA.
- Connect MADRIX STELLA to your computer via USB.
  [Use the provided USB cable]
- Make sure to check the power management options of Windows. Learn more »PC Power Management

2] Enabling Drivers In MADRIX

- Go to the menu Preferences > Options... > Devices USB
  [Keyboard shortcut: Ctrl+Alt+O > Devices USB]
- Activate MADRIX STELLA
  [The option is activated by default.]
- Click Apply
- Close the window with OK
3] Activating Devices

- Go to the menu Preferences > Device Manager... > DMX Devices
  [Keyboard shortcut: \texttt{F4}]
- Your STELLA devices and their two ports will appear in the list.
- If your devices are not in the list, click \texttt{search}
  [In the screenshot below, one STELLA is connected.]

- Select the required port in the list.
- Activate \textit{Enable}
- Activate \textit{Input}
- Click \textit{Apply}
- If required, change the **Frame Time (ms)**
  - The higher the Frame Time, the lower the FPS will be. The lower the Frame Time, the higher the FPS will be.
  - The recommended Frame Time is 30.
  - Press **Apply** to confirm.

4] Activating DMX Input

- Go to the menu **Preferences > Device Manager... > DMX Input**
- Select your preferred DMX **Universe** in the list.
  [By default, DMX universe 1 to 8 are listed. If you wish to increase the number of DMX-IN universes, you can change the setting. Learn more »**Performance**]

- Choose your **DMX-IN Device** in the section **Device**. Select **MADRIX STELLA**

- DMX-IN is now activated. MADRIX can already receive DMX data.
Now, choose how to use incoming data. Learn more »DMX-IN

DMX Watcher

DMX Watcher - Opens the DMX Watcher to monitor your DMX output or input under Preferences > Device Manager... > DMX Devices

Learn more »Tools

Firmware Updates

It is highly recommended to update the firmware of the device should a new firmware version become available. You can do so in different ways.

Update Via USB

1] Connect MADRIX STELLA to your computer over USB. [Use the provided USB cable.]
2] Start the MADRIX software.
3] Open the MADRIX Device Configuration window. Go to Tools > MADRIX Device Configuration...
4] Click to search for connected devices and your device will appear in the list.
5] Select your device in the list and click Firmware
6] Wait for the process to end [usually it takes only seconds].
7] Disconnect MADRIX STELLA from USB and power. Afterwards, connect it again.
Update Via Ethernet

1] Connect MADRIX STELLA to power.
2] Connect MADRIX STELLA to your computer over Ethernet network.
3] In MADRIX, go to Preferences > Device Manager... > Art-Net
4] Activate Art-Net
5] Click Learn more DMX-OUT Via Ethernet Network [Art-Net]
6] Select the device in the list. Click A new window opens.
7] Click Firmware
8] The update process will starts.
9] Wait for the process to end [usually it takes only seconds].
10] Disconnect MADRIX STELLA from USB and power. Afterwards, connect it again.

MADRIX 5 STELLA Updater

Overview

MADRIX 5 STELLA Updater is a separate tool only for MADRIX STELLA. It is integrated into the MADRIX 5 Device Updater.
MADRIX 5 STELLA Updater can be used for several, specific tasks.

- Updates the firmware of all STELLA devices that are connected to the computer via USB. First, select the correct firmware in the list above this button [Example: STELLA 2.0.000 Type V1.0 MADRIX 5.0]. Second, click the button. Third, disconnect the power after updating in order to restart the device.

- Resets all settings of all STELLA devices that are connected to the computer via USB to the standard values. Use this function to restore the original settings of the device.
Performs both actions, a STEALLA firmware update as well as a reset to factory default settings.

- Additional information on the status of the performed functions will be given on the right side of the window. Information is displayed from down to top [the latest information is shown at the top].

Important Notes

- **If new drivers and a new firmware are available for the MADRIX STELLA, please always update the firmware first and then the drivers!**
- **MADRIX STELLA Updater does not work when MADRIX is running. Please close MADRIX and restart MADRIX 5 Device Updater / MADRIX 5 STELLA Updater.**

Where To Find The MADRIX 5 Device Updater

The MADRIX 5 STELLA Updater is included in the MADRIX installation as part of the MADRIX 5 Device Updater. After installing MADRIX, you can find a link in the Windows Start menu:

- In Windows 7, go to **Start > All Programs > MADRIX 5 > Tools > MADRIX 5 Device Updater**
- In Windows 10, go to **Start > MADRIX 5 > MADRIX 5 Device Updater**
- Select **Load STELLA** and confirm with **OK**

The original, executable program can be found in the MADRIX installation directory:

- **C:\Program Files\MADRIX5**

Available Firmware Updates
<table>
<thead>
<tr>
<th>STELLA Firmware</th>
<th>MADRIX Version</th>
<th>Release Date</th>
<th>Highlights</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0.6127</td>
<td>MADRIX 3.6 RC</td>
<td>May 2016</td>
<td>- Initial Release</td>
</tr>
<tr>
<td>1.1.6147</td>
<td>MADRIX 3.6</td>
<td>May 2016</td>
<td></td>
</tr>
</tbody>
</table>
| 1.1.6168        | MADRIX 3.6a    | July 2016    | - Web configuration page: Added Voltage to the Device Information section.  
- Web configuration page: Added the Refresh button to always show the latest information that was last saved on the device in the web browser [instead of using a browser refresh which may change settings again]. |
| 1.2.6346        | MADRIX 3.6d    | December 2016| - Sensor data: Devices can now report back if voltage is connected/disconnected over USB [Voltage USB].  
- Sensor data: Devices can now report back which voltage is used for Power [Voltage Power].  
- Sensor data: For STELLA models V1.1 and higher, devices can now report back the ambient temperature [Temperature].  
- Fixed an issue that could make the device become unresponsive under certain circumstances when connecting, disconnecting, and calling up the website several times in a row. |
<p>| 1.2.7035        | MADRIX 3.6f    | May 2017     | - Fixed an issue that could leave the status LEDs permanently on when using the ArtAddress functionality for Art-Net to switch from normal operation to off while the status LEDs were currently active. |</p>
<table>
<thead>
<tr>
<th>Version</th>
<th>MADRIX Version</th>
<th>Release Date</th>
<th>Changes</th>
</tr>
</thead>
</table>
| 1.4.7082 | MADRIX 3.6h | February 2018 | - Added 4 distinct options for sending data output in case of data connection loss [only available in the web configuration tool]:
  - Send The Last Received Frame Continually
  - Send Black Frames Continually
  - Stop Sending After Sending A Black Frame
  - Stop Sending
- Increased the minimum output frequency that is sent on each port from 10 FPS to 20 FPS [in order to ensure functionality with lighting fixtures that are not working correctly when receiving low frame rates].
- Fixed an issue that could prevent reception of DMX input when Sync Mode had been enabled in the MADRIX Software. |
| 2.0.7140 | MADRIX 5.0b | July 2018 | - Web configuration page: Updated the visual appearance for MADRIX 5.
- Web configuration page: Network universes are now also shown in hexadecimal notation in addition to the decimal notation.
- Added support for Streaming ACN [sACN] for input and output.
- You can now choose the network data source: Art-Net, Streaming ACN, or Art-Net And sACN.
- You can set the Start Channel for each port.
- You can change the Channel Order for the output. |
11.7 MADRIX ORION

This topic includes:

- Overview
- Important Note
- LED Status Codes
- Daisy-Chain Support
- Reset To Factory Default Settings
- Using A 3rd-Party Controller
- Using The MADRIX Software
- MADRIX Device Configuration
- Firmware Updates
- MADRIX Orion Updater

Overview

MADRIX ORION adds a whole new level of interaction and control to your project.
The MADRIX ORION is specifically designed as a general-purpose input device for analog input and Ethernet-based output for remote control and interactivity.
Important Note

- Make sure to read the provided MADRIX ORION Quick Start Guide & Technical Manual first!
  Find it in your product box or download it from »help.madrix.com

LED Status Codes

The following tables describe the LED status codes of the device.

<table>
<thead>
<tr>
<th>STATUS</th>
<th>STATUS LED POWER</th>
</tr>
</thead>
<tbody>
<tr>
<td>Powered off</td>
<td>Power not connected. → The device has no power.</td>
</tr>
<tr>
<td>Permanently green</td>
<td>Connected to power. → The power is on.</td>
</tr>
<tr>
<td>Blinking green</td>
<td>Bootloader activated. → Reset device / upload firmware.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>STATUS</th>
<th>STATUS LED USB</th>
</tr>
</thead>
<tbody>
<tr>
<td>Powered off</td>
<td>USB not connected.</td>
</tr>
<tr>
<td>Red + blinking green</td>
<td>Communicating over USB. → Sending or receiving data over USB. The USB port works.</td>
</tr>
<tr>
<td>Fading between red + green</td>
<td>Connected to USB; Drivers installed correctly.  → No data is sent over USB.</td>
</tr>
<tr>
<td>Orange</td>
<td>Connected to USB; No drivers installed. → Reinstall software and drivers or try a different USB port.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>STATUS</th>
<th>STATUS LED PORT 1</th>
<th>STATUS LED PORT 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Powered off</td>
<td>No data is sent.</td>
<td>No data is sent.</td>
</tr>
<tr>
<td>Blinking green</td>
<td>Receiving data / changes. → The input port works.</td>
<td>Receiving data / changes. → The input port works.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>STATUS</th>
<th>STATUS LEDS ETHERNET PORTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green off</td>
<td>10 MBit/s connected.</td>
</tr>
</tbody>
</table>
**Daisy-Chain Support**

The device features 2 separate Ethernet network ports. Either one is fully functionally for IN and OUT and can be used for the data connection without using a separate network switch or router.

![Daisy-Chain Support Diagram](image)

**Please note:**

- It is recommended to connect a maximum of 8 units after one another in a row.
- It is important to set up the correct network universe where each device should send data to.
- If all devices should send to the same universe, it is important to set up the correct DMX channels for each port and device.
- ORION always sends data on the configured universe and channels unless the ports are deactivated. Make sure that several devices do not send data on the same DMX channels!
- Make sure to receive data in unicast mode in your receiver.

**Reset To Factory Default Settings**
Reset Via Reset Button

1] Disconnect all connections from the device [power, data, input].
2] Use a suitable tool to press the reset button [between Port 1 and Port 2].
3] Continue to press the reset button and supply power again over 'Power' or over USB.
4] Continue to press the reset button and wait until all status LEDs of the device flash repeatedly or wait 10 seconds.
   [Simply repeat these steps should the process fail.]

Reset Via USB [MADRIX 5 Device Updater / MADRIX ORION Updater]

1] Connect MADRIX ORION to power.
   [Please see safety instructions in the MADRIX ORION Quick Start Guide & Technical Manual!]
2] Connect MADRIX ORION to your computer via USB.
   [Use the provided USB cable.]
3] Close the MADRIX Software.
4] Start the separate MADRIX 5 Device Updater tool.
   [In Windows 7, go to Start > All Programs > MADRIX 5 > Tools > MADRIX 5 Device Updater]
   [In Windows 10, go to Start > MADRIX 5 > MADRIX 5 Device Updater]
5] Select Load ORION and confirm with OK
6] In the MADRIX ORION Updater, click Reset To Factory Default Settings (F4)
7] Wait for the reset process to end [usually it takes only seconds].
Learn more MADRIX ORION Updater

Using A 3rd-Party Controller

Overview
MADRIX ORION is a standard network node for Art-Net or Streaming ACN. Because of this, you can use the device with applications, consoles, desks, or controllers that are compatible with Art-Net or Streaming ACN to receive data via Ethernet network.

Web Device Configuration Page

When connected to Ethernet network, you can easily configure MADRIX ORION using the built-in web configuration interface.

You have 2 options to access the web interface. Both, ORION and your computer, need to be in the same network.

A] Using a standard web browser:

- Connect MADRIX ORION and your computer to the same network.
- Assign correct network settings for your PC in the Windows operating system.
  [Recommended default settings: IP address 10.0.0.1 / Subnet mask 255.0.0.0]
- Open your web browser and enter the IP address of MADRIX ORION.
  [You can find the default IP address on the back side of the device.]
- The web configuration page will be launched. Now, you have access to various information and settings.

B] Using the MADRIX Software:

- Connect MADRIX ORION and your computer to the same network.
- Assign correct network settings for your PC in the Windows operating system.
  [Recommended default settings: IP address 10.0.0.1 / Subnet mask 255.0.0.0]
- Go to the menu Tools > MADRIX Device Configuration...
  [Keyboard shortcut: Ctrl+Alt+L]
- Select your MADRIX ORION device in the list.
- Click HTTP

- Your default web browser will open and the web configuration page will be launched. Now, you have access to various information and settings.
**Device Name**  
You can change the description of the device. Enter a name and confirm with *Set*.

**Device Settings**  
You can change the IP address and Subnet Mask. Enter the specific addresses and confirm with *Set*.

**Pin Input Configuration**  
This section is an important part of the configuration.
Please see **below**.

**DMX Channel Configuration**  
This section is an important part of the configuration.
Please see **below**.

**Network Output**  
This section is an important part of the configuration.
Please see **below**.

**Device Information**  
This section displays various details about the device, including:

- **Model** [Device type]
- **IP Address** [The current IP address.]
- **MAC Address** [A permanent, unique address.]
- **Serial Number**
- **Firmware** [The current firmware version.]
- **Bootloader** [The current bootloader version.]
- **Hardware** [Hardware revision/model]
- **Voltage** [The current voltage for External Power, Port 1 (V+), and Port 2 (V+).]
- **Temperature** [The current ambient temperature inside the device case.]
- **Ethernet** [The current status of the two Ethernet ports.]

**Pin Input Configuration**

This section is an important part of the configuration. It allows you to specify how the input data is parameterized.

- You can change the settings for each of the 8 input pins individually [**Pin 1 - Pin 8**].
- **Pin Voltage** - Shows how much volt is applied at the particular pin.

- **Measure Function** - Defines how the input data is parameterized. Confirm with Set or restore the default values with **Defaults**. Choose from different options:

**Disabled**

- Deactivates the specified pin.
- This also frees up DMX channels as well as processing resources.
- The more pins are deactivated, the higher the measure frequency can be [12.5 FPS / Hz for 8 pins and up to 100 FPS / Hz for 1 pin].

**Analog (Between Limits)**

- Linearly measures the incoming voltage at the particular pin.
- In addition, you can specify the lower and upper limit in which the device measures the analog signal by setting them with help of the **Current Limit Values**

**Digital (Hysteresis Threshold)**

- Measures the incoming voltage at the particular pin, but interprets it digitally.
- The lower and upper limit, which are set by **Limits**, are used as thresholds.
- Once the signal goes below or above those limits, the provided result changes to the low or to the high value accordingly.
- Low value and high value are directly set via **From Value** and **To Value** in the **DMX Channel Configuration**

**Pin Voltage**

- Measures the incoming voltage at the particular pin.
- In addition, you can specify the lower and upper limit in which the device measures the analog signal by setting them with help of the **Limits**
- The result will be provided as decimal value.
- If you are using 8 bit with 1 DMX channel as **Result Modifier** in the **DMX Channel Configuration**, the main value before the comma will be provided as result (e.g. 3 Volt).
- If you are using 16 bit with 2 DMX channels as **Result Modifier** in the **DMX Channel Configuration**, both values, before and after the comma, will be provided as result (e.g. 3.12 Volt).
**External Voltage**

\((V+)\)

- Measures the incoming voltage at Power.
- In addition, you can specify the lower and upper limit in which the device measures the analog signal by setting them with help of the **Limits**.
- The result will be provided as decimal value.
- If you are using 8 bit with 1 DMX channel as **Result Modifier** in the **DMX Channel Configuration**, the main value before the comma will be provided as result (e.g. 3 Volt).
- If you are using 16 bit with 2 DMX channels as **Result Modifier** in the **DMX Channel Configuration**, both values, before and after the comma, will be provided as result (e.g. 3.12 Volt).

**Counter**

\((Hysteresis Threshold)\)

- Measures the incoming voltage at the particular pin, but interprets it digitally.
- The lower and upper limit, which are set by **Limits**, are used as thresholds.
- Once the signal goes below or above those limits, the provided result is increased by 1.
- Low value and high value are directly set via **From Value** and **To Value** in the **DMX Channel Configuration**.

**Count Per Second**

\((Slow)\)

- Measures the incoming voltage at the particular pin, but interprets it digitally.
- The lower and upper limit, which are set by **Limits**, are used as thresholds.
- Once the signal goes below or above those limits, it is counted towards the provided result per second.
- Low value and high value are directly set via **From Value** and **To Value** in the **DMX Channel Configuration**.
- Due to the processing, only signals that result in a maximum of 100 counts and are thus slower than 50 FPS (< 50 Hz) can be measured.

**Count Per Second**

\((Fast)\)

- Measures the incoming voltage at the particular pin, but interprets it digitally.
- The lower and upper limit, which are set by **Limits**, are used as thresholds.
- Once the signal goes below or above those limits, it is counted towards the provided result per second.
- Low value and high value are directly set via **From Value** and **To Value** in the **DMX Channel Configuration**.
- The device exclusively monitors this particular pin for a quarter of a second. Thus, very high counts can be possible. The count will then be multiplied by 4 and provided as result in FPS /Hz.
**Beats Per Minute (BPM)**

- Measures the incoming voltage at the particular pin, but interprets it digitally.
- The lower and upper limit, which are set by **Limits**, are used as thresholds.
- Once the signal goes below or above those limits, it is counted towards the provided result per second.
- Low value and high value are directly set via **From Value** and **To Value** in the **DMX Channel Configuration**
- The device monitors each low and high threshold count and sets the provided result for 1 second to the **To Value**. Afterwards, the provided result will be set to the **From Value** again.
- Due to the processing, it makes it possible to reliably detect very short impulses.

**Signal Slope Detections**

- Measures the incoming voltage at the particular pin, but interprets it digitally.
- The lower and upper limit, which are set by **Limits**, are used as thresholds.
- Once the signal goes below or above those limits, it is counted towards the provided result per second.
- Low value and high value are directly set via **From Value** and **To Value** in the **DMX Channel Configuration**
- The device monitors the time between low and high threshold counts and recalculates them to FPS / Hz.
• **Limits** - Defines in which range the analog input signal is received. Confirm with **Set** or restore the default values with **Defaults**. Choose from different options for the minimum value and maximum value:
  - 0.0 Volt
  - 1.0 Volt
  - 2.0 Volt
  - 3.0 Volt
  - 4.0 Volt
  - 5.0 Volt
  - 6.0 Volt
  - 7.0 Volt
  - 8.0 Volt
  - 9.0 Volt
  - 10.0 Volt
  - 11.0 Volt
  - 12.0 Volt
  - 10 % Of V+
  - 25 % Of V+
  - 50 % Of V+
  - 75 % Of V+
  - 90 % Of V+
  - 100 % Of V+

**DMX Channel Configuration**

This section is an important part of the configuration. It allows you to specify how the input data is sent out.

• You can change the settings for each of the 8 input pins individually [*Pin 1 - Pin 8*].

• **DMX Channel** - Defines on which channel the data is sent.
  - For 8 Bit - This defines the channel for each individual pin.
  - For 16 Bit - This defines the start channel. 2 channels are required per pin. Make sure to correctly set up all other channels without overlapping channel assignments!
- **Result Modifier** - Defines how the data is processed.
  - 1 Channel (8 Bit)
  - 1 Channel (8 Bit), Inverted
  - 2 Channels (16 Bit)
  - 2 Channels (16 Bit), Inverted
  - 2 Channels (16 Bit), Swapped
  - 2 Channels (16 Bit), Inverted, Swapped

- **From Value** - Defines the DMX value range. This is the minimum value.

- **To Value** - Defines the DMX value range. This is the maximum value.

### Network Output

This section is an important part of the configuration. It allows you to specify the network settings.

When data is received through the ports, MADRIX ORION will automatically forward it to Ethernet network.

- **Input Data > Send To Network Universe** - ORION receives input data worth up to 16 DMX channels. This setting specifies on which universe the data is sent into the network [Art-Net universe or Streaming ACN universe.]
  - By default, **256** is selected. Valid values range from 1 to 256.

- **Full Frames > Send Always Full Frames (512 CH) To Network** - If activated, ORION will always send out 512 channels on the specified network universe.
  - ORION automatically sends values of 0 on channels that are not used.

- **Art-Net Broadcast Mode** - Activates Art-Net and broadcasts the data into the network.

- **Art-Net Unicast Mode** - Activates Art-Net and only sends data to the specified IP address in order to reduce network traffic and bandwidth.
  - Make sure to set up the correct IP address where to send the data to.

- **sACN Multicast Mode** - Activates Streaming ACN. This mode multicasts data to the fixed IP address 293.255.1.0 according to the sACN specifications.

### Using The MADRIX Software
The MADRIX ORION works great in combination with the MADRIX Software.

**Operating Modes**

You can mainly use 3 operating modes together with MADRIX:

- DMX-IN Via Art-Net
- DMX-IN Via Streaming ACN
- DMX-IN Via USB

Notes:

- MADRIX ORION receives analog input data via its two ports and processes and sends the data out via USB or Ethernet network [incl. Art-Net and Streaming ACN].
- MADRIX ORION uses a maximum of 16 DMX channels.
  - Up to 8 DMX channels are used when letting the device send only 8-bit data.
  - Up to 16 DMX channels are used when letting the device send only 16-bit data.

**DMX-IN Via Art-Net**

**Overview**

You can connect MADRIX ORION via Ethernet network directly or indirectly to the network card of your computer that runs the MADRIX Software. Data is sent to the ORION via a port and from the ORION to MADRIX via Ethernet network.

**1] Initial Configuration**

- Connect your external equipment [such as, compatible sensors, potentiometers, switches, and triggers] to the required port of MADRIX ORION.
- Connect MADRIX ORION to power.
  
  [Please see safety instructions in the MADRIX ORION Quick Start Guide & Technical Manual!]
Connect MADRIX ORION directly or indirectly to your computer via network cabling.

- It is highly recommended to only use Gigabit Ethernet network components [network card, switches, etc.].
- Make sure that you have configured MADRIX ORION correctly via the Web Device Configuration Page

2] Windows Network Settings

Art-Net is a network-based protocol. MADRIX will use the network card of your computer to receive data.

- It is required to set up the correct network settings in Windows, first.
- You must use these IP address and Subnet mask settings. Otherwise, Art-Net might not work!
- The IP addresses of your computer and of your MADRIX ORION devices need to be different and each needs to be unique.

- Set up an individual IP address in the following IP address range:
  - 2.0.0.1 ... 2.255.255.254 or
  - 10.0.0.1 ... 10.255.255.254
- Set up the corresponding Subnet mask
  - 255.0.0.0

[Via factory default settings, MADRIX ORION devices will have an IP address in the 10.x.x.x network range, such as 10.80.0.100, for example].

- Restart MADRIX, if you have changed the network settings in Windows while MADRIX was running.
- Learn more »Tips [Microsoft Windows / Networks / USB]

3] Activating Art-Net

- Go to the menu Preferences > Device Manager... > Art-Net
  [Keyboard shortcut: F4 > Art-Net]

- Activate Enable
4] Adding Devices Automatically

MADRIX can automatically add your MADRIX ORION devices.

- Click 
  
  [MADRIX will automatically search the network for connected MADRIX ORION devices. Devices that are found will appear in the list. One entry will be created in the list for each ORION device.]
5] Configuration Of Art-Net Input

- Select your ORION device in the list.

- Click

- A new window opens [Art-Net Device Configuration].
- **Universe Port IN**
  - By default, MADRIX ORION sends input data to network universe 256. You can change these settings in the Web Configuration or MADRIX Device Configuration window if required.

- Activate **Receive Direct IP Mode** and enter the **IP Address** of your MADRIX ORION. Confirm with **Apply** [E.g., 10.80.0.223]

- [You can also activate **Receive Broadcast Mode**. In this mode, MADRIX will receive any DMX data that is sent in the network on this particular Art-Net universe.]

- Click **OK**
6] Activating Your Art-Net Input Device

You need to activate the Art-Net input device. It is still deactivated.

- Go to the menu Preferences > Device Manager... > DMX Devices
  [Keyboard shortcut: F4]

  ![Device Manager](image)

- Select the ORION device in the list.
- Activate Enable
- Input is automatically selected.
- Click Apply
• If required, change the **Frame Time (ms)**
  The higher the Frame Time, the lower the FPS will be. The lower the Frame Time, the higher the FPS will be.
  The default Frame Time is 33.
  Press **Apply** to confirm.

7] Activating DMX Input

• Go to the menu **Preferences > Device Manager... > DMX Input**
- Select your preferred DMX *Universe* in the list.
  [By default, DMX universe 1 to 8 are listed. If you wish to increase the number of DMX-IN universes, you can change the setting. Learn more >Performance]
- Choose your **DMX-IN Device** in the section **Device**. Select the **ArtNet** input device.

- Art-Net input is now activated. MADRIX can already receive DMX data.
Now, choose how to use incoming data. Learn more »Art-Net Remote

DMX-IN Via Streaming ACN

Overview

You can connect MADRIX ORION via Ethernet network directly or indirectly to the network card of your computer that runs the MADRIX Software. Data is sent to the ORION via a port and from the ORION to MADRIX via Ethernet network.

1] Initial Configuration

- Connect your external equipment [such as, compatible sensors, potentiometers, switches, and triggers] to the required port of MADRIX ORION.
- Connect MADRIX ORION to power.
  [Please see safety instructions in the MADRIX ORION Quick Start Guide & Technical Manual!]
- Connect MADRIX ORION directly or indirectly to your computer via network cabling.
- It is highly recommended to only use Gigabit Ethernet network components [network card, switches, etc.].
- Make sure that you have configured MADRIX ORION correctly via the Web Device Configuration Page

2] Windows Network Settings

- MADRIX automatically sets up Streaming ACN network settings for you.
- You only need a computer with a network card and a valid IP address.

- You do not have to change the IP address settings in Windows for Streaming ACN!
- The IP address range for sACN devices is 239.255.X.X according to the Streaming ACN specifications.
  [Even if your sACN devices are set to a different IP address range, you may try the connection from MADRIX to your devices.]
- Make sure that your Firewall does not block data of the 239.255.X.X IP address range!
- Check the settings of the Windows Firewall.
3] Activating Streaming ACN

- Go to the menu Preferences > Options... > Devices Network
  [Keyboard shortcut: Ctrl+Alt+O > Devices Network]
- Activate Enable ESTA - Streaming ACN
- Choose your network card from the drop-down list. Make sure to select the correct network adapter that will be used for Streaming ACN!
  [The IP address and Subnet mask label should help you select the correct adapter. It is not necessary to change any of these networks settings.]
- ACN Device Count - Set up how many you are going to use.
  [This is the total amount of OUT and IN devices. Please set the exact number of devices you are using. If the count is higher, this creates unnecessary network traffic.]
- Press Apply
- **ACN CID** - Being a network protocol, Streaming ACN sends a so-called CIDs [Component Identifier].
  - Every single ACN device has such a unique ID.
  - When using Streaming ACN, your MADRIX Software is one of those devices.
  - When you start MADRIX for the first time, this ID will be generated automatically for you. From this point onwards it will be used on your PC.
  - With this ID your MADRIX Software can be easily identified in the network. Interfaces can detect this unique ID and can be configured to receive data from this particular device. Please note that the ACN interface must support this feature.
  - **Do not change the ACN CID, unless you are an experienced user!**

- Press **OK** to close the window.

4] Enabling Input

- Go to **Preferences > Device Manager... > DMX Devices**
  [Keyboard shortcut: **F4**]

  - MADRIX automatically creates and adds the number of interfaces to the list.
  [according to **ACN Device Count**]

- Select your device.

- Enable **Input** if you wish to receive incoming data through this device.

- Click **Apply**

- In DMX-IN mode, you will not be able to select the ACN protocol. MADRIX will automatically select the correct protocol version.
Note: If you are loading a MADRIX Setup, please check if the number of ACN devices in your setup corresponds with the number that is activated. The Setup stores the number of devices. But if you changed the amount and then loaded the Setup, the newly defined number will be activated.

5] Configure Your Device

- Make sure that your device is still selected under Preferences > Device Manager… > DMX Devices
- Click ![Device Manager Icon]
- A new window will open.
Set up the following settings for your devices:

- **Source Name** - Allows you to set up a specific name for the device. This name is send via network as well. Therefore, interfaces may be able to retrieve this name and can be configured to receive data from this source.
  - If you are using the default name *MADRIX U:X*, the universe will automatically be displayed in the name [represented by X: 1, 2, 3, etc.].

- **ACN Universe** - Defines the DMX universe from which data is received.
  - Set up the same universe that is set up in your MADRIX ORION according to the Web Configuration. By default, MADRIX ORION sends input data to network universe 256. You can change these settings in the Web Configuration if required.
  - According to the Streaming ACN specifications, MADRIX will automatically change the ACN IP Address according to the ACN Universe.

- Press **Apply** to confirm your changes.
- Press **OK** to close the window.

6] **Enable DMX-IN**

- Go to the menu *Preferences > Device Manager... > DMX Input*
- Select your preferred DMX **Universe** in the list.
  [By default, DMX universe 1 to 8 are listed. If you wish to increase the number of DMX-IN universes, you can change the setting. Learn more »Performance.]
- Choose your **DMX-IN Device** in the section **Device**. Select the **ACN input device**.

- **sACN input** is now activated. MADRIX can already receive DMX data.
Now, choose how to use incoming data. Learn more »**sACN Input**

**DMX-IN Via USB**

**Overview**

You can connect the ORION directly via USB to the computer that runs the MADRIX Software. Data is sent to the ORION via a port and from the ORION to MADRIX over USB.

1] **Initial Configuration**

- Connect your external equipment [such as, compatible sensors, potentiometers, switches, and triggers] to the required port of MADRIX ORION.
- Connect MADRIX ORION to your computer via USB. [Use the provided USB cable.]
- Make sure to check the power management options of Windows. Learn more »**PC Power Management**
- Make sure that you have configured MADRIX ORION correctly via the **MADRIX Device Configuration**

2] **Enabling Drivers In MADRIX**

- Go to the menu **Preferences > Options... > Devices USB**
  [Keyboard shortcut: **Ctrl+Alt+O > Devices USB**]

- Activate **MADRIX ORION**
  [The option is activated by default.]

- Click **Apply**
- Close the window with **OK**
3] Activating Devices

- Go to the menu Preferences > Device Manager... > DMX Devices
  [Keyboard shortcut: F4]

- Your ORION devices will appear in the list.

- If your devices are not in the list, click search

  [In the screenshot below, one ORION is connected.]

- Select the required device in the list.

- Activate Enable

- Input is automatically selected.

- Click Apply
- If required, change the **Frame Time (ms)**
  - The higher the Frame Time, the lower the FPS will be. The lower the Frame Time, the higher the FPS will be.
  - The recommended Frame Time is 30.
  - Press **Apply** to confirm.

**4] Activating DMX Input**

- Go to the menu **Preferences > Device Manager... > DMX Input**
- Select your preferred DMX **Universe** in the list.
  [By default, DMX universe 1 to 8 are listed. If you wish to increase the number of DMX-IN universes, you can change the setting. Learn more »Performance]
- Choose your **DMX-IN Device** in the section **Device**. Select **MADRIX ORION**

- DMX-IN is now activated. MADRIX can already receive DMX data.
Now, choose how to use incoming data. Learn more »DMX-IN

MADRIX Device Configuration

You can access the majority of information and settings of the web configuration page also in MADRIX using the MADRIX Device Configuration window.

In MADRIX, go to the menu Tools > MADRIX Device Configuration...

[Keyboard shortcut: Ctrl+Alt+L]
- Scans the USB ports of your computer and the network for connected MADRIX ORION devices. If devices are found, they will be shown in the list.
- To see USB devices, you need to enable ORION USB drivers first [they are activated by default]. Learn more »Devices USB
- To see network devices, you need to enable ORION networking drivers [they are activated by default] and connect MADRIX ORION and your computer to the same network first. Learn more »Devices Network

- Refreshes already connected devices and brings the information in the list up to date.

- Allows you to change the settings of your device. Apply your changes by confirming with Set

- Enables remote access to the web configuration as explained above. MADRIX ORION needs to be connected via Ethernet [network connection required]. First, connect your computer and the MADRIX ORION to one and the same network. Second, select your MADRIX ORION in the list. Third, click this button. A web browser opens automatically.

- Imports the MADRIX ORION Device Settings from an external file [of the file type *.modx]. Use this option to easily restore all device settings from a file [as described below].

- Exports the MADRIX ORION Device Settings to an external file [of the file type *.modx]. Use this option to easily store all device settings in a file. Simply enter a name in the window that opens and click 'Save'.

- Updates the firmware of your MADRIX ORION if a newer firmware is available [USB connection required].

Learn more Web Device Configuration Page
**Firmware Updates**

### Update Via USB

- Connect MADRIX ORION to power.
  [Please see safety instructions in the MADRIX ORION Quick Start Guide & Technical Manual!]
- Connect MADRIX ORION to your computer via USB.
  [Use the provided USB cable.]
- Start the MADRIX Software.
- Open the MADRIX Device Configuration window. Go to the menu **Tools > MADRIX Device Configuration...**
- Click ![search icon] to search for connected devices and your device will appear in the list.
- Select your device in the list and click **Firmware**
- Wait for the process to end [usually it takes only seconds].
- Disconnect MADRIX ORION from power and connect again.
- [You can also use the MADRIX ORION Updater. Learn more](http://www.madrix.com/MADRIX/Updater)

### Update Via Ethernet

- Connect MADRIX ORION to power.
  [Please see safety instructions in the MADRIX ORION Quick Start Guide & Technical Manual!]
- Connect MADRIX ORION to your computer via Ethernet network.
- In MADRIX, go to the menu **Preferences > Device Manager... > Art-Net**
- Activate **Art-Net**
- Click ![search icon]  
  Learn more [DMX-OUT Via Ethernet Network [Art-Net]]
- Select the device in the list. Click ![device select icon]. A new window opens.
- Click **Firmware**
  The update process will starts.
  The MADRIX logo on the front of the device will start to flash and the firmware will be updated.
- Wait for the process to end [usually it takes only seconds].
MADRIX ORION Updater

Overview

MADRIX ORION Updater is a separate tool only for MADRIX ORION. It is integrated into the MADRIX 5 Device Updater.

Usage

![MADRIX ORION Updater Interface](image)
MADRIX ORION Updater can be used for several, specific tasks.

- Updates the firmware of all ORION devices that are connected to the computer via USB. First, select the correct firmware in the list above this button [Example: ORION 1.0.000 Type V1.0 MADRIX 5.0]. Second, click the button. Third, disconnect the power after updating in order to restart the device.

- Resets all settings of all ORION devices that are connected to the computer via USB to the standard values. Use this function to restore the original settings of the device.

- Performs both actions, a ORION firmware update as well as a reset to factory default settings.

- Additional information on the status of the performed functions will be given on the right side of the window. Information is displayed from down to top [the latest information is shown at the top].

### Available Firmware Updates

<table>
<thead>
<tr>
<th>ORION Firmware</th>
<th>MADRIX Version</th>
<th>Release Date</th>
<th>Highlights</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.00.7140</td>
<td>MADRIX 5.0b</td>
<td>July 2018</td>
<td>• Initial Release</td>
</tr>
</tbody>
</table>
Important Notes

- If new drivers and a new firmware are available for the MADRIX ORION, please always update the firmware first and then the drivers!
- MADRIX ORION Updater does not work when MADRIX is running. Please close MADRIX and restart MADRIX 5 Device Updater / MADRIX ORION Updater.

Where To Find The MADRIX 5 Device Updater

The MADRIX ORION Updater is included in the MADRIX installation as part of the MADRIX 5 Device Updater. After installing MADRIX, you can find a link in the Windows Start menu:

- In Windows 7, go to Start > All Programs > MADRIX 5 > Tools > MADRIX 5 Device Updater
- In Windows 10, go to Start > MADRIX 5 > MADRIX 5 Device Updater
- Select Load ORION and confirm with OK

The original, executable program can be found in the MADRIX installation directory:

- C:\Program Files\MADRIX5
11.8 MADRIX I/O

This topic includes:

- Introduction
- MADRIX USB contact closure, MADRIX USB temperature, MADRIX USB light sensor
- MADRIX USB SMPTE
- Interruption-Free Operation

Introduction

MADRIX I/O is a product category for supplementary input and output devices. External equipment, such as sensors, brings additional automation processes and interaction to any LED project using MADRIX.

The following accessories are included in this category:

- MADRIX USB contact closure
- MADRIX USB light sensor
- MADRIX USB temperature
- MADRIX USB SMPTE

MADRIX USB contact closure, MADRIX USB temperature, MADRIX USB light sensor

MADRIX USB contact closure
- Registers if its internal circuit is either open or closed.
- Can be used as connector for a digital switch or button, for example.
- Is an input device.
- Can simply be connected to any USB 2.0 port.

- The recommended **Frame Time (ms)** is 500.
- Incoming data directly translates into DMX data in MADRIX.
- Data is sent to **DMX channel 1 - DMX channel 2** on your selected DMX universe.

- **Incoming DMX values on DMX channel 1** are 0 or 255 [Off or On].
- **Inverted incoming DMX values on DMX channel 2** are 255 or 0 [On or Off].

**MADRIX USB light sensor**
- Can be used to measure the ambient light level.
- Is an input device.
- Can simply be connected to any USB 2.0 port.

- The recommended *Frame Time (ms)* is 500.
- Incoming data directly translates into DMX data in MADRIX.
- Data is sent to **DMX channel 1 - DMX channel 8** on your selected DMX universe.

- **DMX channel 1** represents the light level in percent. Valid values range from 0% to 100%.
- **DMX channel 2** represents the decimal place in percent. Valid values range from .0% to .99%.
- **DMX channel 3** represents the light level in DMX values. Valid values range from 0 to 255.
- **DMX channel 4** represents the decimal place in DMX values. Valid values range from 0 to 255.
- **DMX channel 5** represents the inverted light level in percent. Valid values range from 0% to 100%.
- **DMX channel 6** represents the inverted decimal place in percent. Valid values range from .0% to .99%.
- **DMX channel 7** represents the inverted light level in DMX values. Valid values range from 0 to 255.
- **DMX channel 8** represents the inverted decimal place in DMX values. Valid values range from 0 to 255.

**MADRIX USB temperature**
Can be used as temperature sensor.

Is an input device.

Can simply be connected to any USB 2.0 port.

The recommended **Frame Time (ms)** is 1000.

Incoming data directly translates into DMX data in MADRIX.

Data is sent to **DMX channel 1 - DMX channel 10** on your selected DMX universe.

- **DMX channel 1** represents the temperature in degree Celsius. Valid values range from -20 °C to +80 °C.
- **DMX channel 2** represents the decimal place of degree Celsius. Valid values range from .0 to .99.
- **DMX channel 3** shows if the temperature values shown on DMX channel 1 are above zero [0] or below zero [255].
- **DMX channel 4** is not used.
- **DMX channel 5** represents the temperature in degree Fahrenheit. Valid values range from -4 °F to +176 °F.
- **DMX channel 6** represents the temperature decimal place of degree Fahrenheit. Valid values range from .0 to .99.
- **DMX channel 7** shows if the temperature values shown on DMX channel 5 are above zero [0] or below zero [255].
- **DMX channel 8** is not used.
- **DMX channel 9** represents the temperature in DMX values. Valid values range from 0 to 255.
- **DMX channel 10** represents the decimal place of DMX values. Valid values range from 0 to 255.
Step-By-Step Configuration

1] Connect your device.
2] Enable drivers in MADRIX.
3] Enable your device.
4] Set up DMX Input.
5] Choose how to use incoming data.

1] Connect Your Device

- Connect your MADRIX I/O device to a free USB 2.0 port of your computer.
- Make sure that Windows recognizes the device. Windows will automatically install the drivers for the device.

2] Enable Drivers In MADRIX

- Go to the menu Preferences > Options... > Devices USB
- Activate MADRIX I/O
  [The option is activated by default.]
- Click Apply and OK
3] Enable Your Device

- Go to the menu **Preferences > Device Manager... > DMX Devices**

- Click ![search](image) if your device is not shown in the list.

- Select your device in the list and select **Enable** in the section **Settings**. Click **Apply**
  
  - Now, in the list the **State** will switch to **On** [indicated by green light].

- It is not recommended to change the **Frame Time (ms)** of your device. Instead, it is highly recommended to use the default settings. [Recommended settings are provided above.]
4] Set Up DMX Input

- Go to the menus Preferences > Device Manager... > DMX Input
- Select one entry in the list [e.g., Universe 1] and go to the section Device. Choose your device under DMX-IN Device
- MADRIX will now receive data from your device.
5] Choose How To Use Incoming Data

Now, you have several options to choose from:

A] You can activate Remote and choose a protocol in the section Remote Control. This will allow you to control MADRIX remotely using your controller. Learn more »DMX-IN / Art-Net Remote / sACN Input

B] You can use incoming data in a Script or Macro. Learn more »Macros And Scripts

C] You can activate Trigger and choose the trigger functionality in the section Trigger.

D] You can monitor incoming DMX data in the DMX Watcher. Select your device in the list and click Learn more below.

Close the Device Manager with OK

Monitoring Incoming DMX Data

To effectively work with incoming DMX data from your device, you can use the DMX Watcher to monitor incoming signals.
- Open the DMX Watcher as explained above or go to **Tools > DMX Watcher**...
- Select **Input**
- Set up the correct **Universe**
  
  - This is the same number as you have chosen in the list under **Preferences > Device Manager... > DMX Input** [e.g., **Universe 1**].

---

**MADRIX USB SMPTE**

**Overview**
This input device allows you to effortlessly use SMPTE time code for time synchronization across devices.

- Data is received via the 3-pin, female XLR connector.
- The device can simply be connected to any USB 2.0 port.

**Step-By-Step Configuration**

1] Connect your device.

2] Enable drivers in MADRIX.

3] Use the Cue List.

**1] Connect Your Device**

- Connect your SMPTE time code source to the 3-pin, female XLR connector of MADRIX USB SMPTE.
- Make sure that your SMPTE time code source is sending data.

- Connect your MADRIX USB SMPTE to a free USB 2.0 port of your computer.
- Make sure that Windows recognizes the device. Windows will automatically install the drivers for the device.

**2] Enable Drivers In MADRIX**

- Go to the menu to *Preferences > Options... > Devices USB*

- Activate *MADRIX USB SMPTE*
  
  [The option is activated by default.]
3] Use The Cue List

The Cue List is the feature in MADRIX to work with Time Code.

- Go to the menu **Tools > Cue List**...
- Or press **F7**
- Or click **Layer Control > Cue List** on the user interface.

- Select the Time Code source **SMPTE**
- Select the required **Time Code Format**

![Time Code Format]

- MADRIX will automatically start receiving external Time Code.

- The Time Code format is `HH:MM:SS:FF` [hours:minutes:seconds:frames]

Example:
- 10 o'clock and 20 minutes, 30 seconds, and 10 frames will be shown as

  **10:20:30:10**

- Configure the column **Time Code** for your Cue List entries.

- Add or edit more entries according to your requirements.

- Learn more »[Cue List](#)

---

**Interruption-Free Operation**

To ensure interruption-free operation of the software and devices, please make sure to check the power-saving settings of Windows.

Learn more »[PC Power Management](#)
12 Tips And Tricks

This topic includes:
- MADRIX KEY Serial Number
- Message Windows
- Tooltips

MADRIX KEY Serial Number

You can quickly retrieve the serial number for products that activate a MADRIX software license.

If you want to retrieve the serial number of your MADRIX product [copy and paste], follow these steps:

1] Go to the menu Help > About...
   [A new window will open.]

2] Left Mouse Double-Click - Quickly click twice with the left mouse button on the serial number in order to automatically select it.
3] **Right Mouse Click > Copy** - Click once on the right mouse button to call up the context menu and then choose *Copy*.

[Keyboard shortcut: *Ctrl+C*]

4] **Right Mouse Click > Paste** - Click once on the right mouse button to call up the context menu again and then choose *Paste* in order to insert the serial number into a separate document, for example.

[Keyboard shortcut: *Ctrl+V*]

---

**Message Windows**

When working with MADRIX, you might see notifications and messages for your information and attention.

If you want to retrieve the content of such a message [copy and paste], you can do the following:

- *Ctrl+C* - Press this key combination on the keyboard in order to copy the text of the message to the clipboard.
- *Ctrl+V* - Pastes the copied text from the clipboard to any text processing software application which you may have opened [e.g., e-mail client, word processor, etc.]

---

**Tooltips**
Most of the controls of the MADRIX user interface [e.g., buttons, text and input fields, sliders etc.] can show you
details about the functionality of the control. A tooltip will be shown that includes more information.

- **Mouse Hover** - Use the mouse cursor to hover over a specific control; please do not click on the control. One
second later, you will see a small window that includes the tooltip and as such more information for you about
the control you are looking at.
13 Imprint And Copyright

This topic includes:
- Company And Address
- Copyright
- Credits
- Third Parties

Company And Address

inoage GmbH
Wiener Straße 56
01219 Dresden
Germany

Managing Directors: Christian Hertel, Sebastian Pinzer, Sebastian Wissmann

Phone: +49 351 862 6869 0
Fax: +49 351 862 6869 68

Web: www.madrix.com
E-mail: info@madrix.com

Copyright

Copyright (c) 2001 - 2018 inoage GmbH. All rights reserved.
MADRiX is a trademark of inoage GmbH.

All other company names and/or product names are trademarks and/or entered trademarks of their respective holders. The product might not always be conforming to the presentation, features, and performances. Technical data can differ slightly, depending on the operating system and the chosen hardware.

We withhold the option of changes without notification. inoage GmbH does not give any guaranty for function capability for a certain purpose, the marked ability or other features of the product. No other guaranty claims, on legal or other terms, can be enforced.

Under no circumstances does inoage GmbH take on the responsibility for liabilities for faults for losses in sales volume or profits, that occur through the usage of the product, through the serviceability, through abuse, happenings, circumstances or actions, that we have no influence on. No matter if the damages were caused by the holder of the product or a third person.

Credits

- Microsoft, Windows are U.S. registered trademarks of Microsoft Corporation.
- Art-Net™ - Designed by and Copyright Artistic Licence Holdings Ltd.
- ASIO is a trademark and software of Steinberg Media Technologies GmbH.
- Intel, the Intel logo, Intel Core, Intel Xeon are trademarks of Intel Corporation or its subsidiaries in the U.S. and/or other countries.
- NVIDIA is a trademark and/or registered trademark of NVIDIA Corporation in the U.S. and/or other countries.
- This product includes software by NetGroup, Politecnico di Torino and CACE Technologies, Davis.
- Other product and company names, terms, or [trade] marks are the property of their respective holders.

Third Parties
ASIO

- ASIO Interface Technology by Steinberg Media Technologies GmbH.

Qt

Included Libraries

MADRIX uses the following libraries of the Qt development framework. The libraries and their use are covered by GNU LGPL v.2.1.

- QtCore4.dll
- QtGui4.dll
- OpenGL4.dll
- XmI4.dll
- Svg4.dll
- Network4.dll
- qgif4.dll [Qt Plugin DLL]
- qico4.dll [Qt Plugin DLL]
- jpeg4.dll [Qt Plugin DLL]
- qmng4.dll [Qt Plugin DLL]
- qsvg4.dll [Qt Plugin DLL]
- qtf4.dll [Qt Plugin DLL]

The complete, corresponding, and machine-readable source code of these files, incl. the license text, is available:

- On the MADRIX product CD, in the subfolder ThirdParty. For example, D:\ThirdParty

Copy of License

GNU LESSER GENERAL PUBLIC LICENSE
Version 2.1, February 1999

Copyright (C) 1991, 1999 Free Software Foundation, Inc.
51 Franklin Street, Fifth Floor, Boston, MA  02110-1301  USA
Everyone is permitted to copy and distribute verbatim copies
of this license document, but changing it is not allowed.

[This is the first released version of the Lesser GPL.  It also counts
as the successor of the GNU Library Public License, version 2, hence
the version number 2.1.]

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By
contrast, the GNU General Public Licenses are intended to guarantee your freedom to share and
change free software--to make sure the software is free for all its users.

This license, the Lesser General Public License, applies to some specially designated software
packages--typically libraries--of the Free Software Foundation and other authors who decide to
use it. You can use it too, but we suggest you first think carefully about whether this license
or the ordinary General Public License is the better strategy to use in any particular case,
based on the explanations below.

When we speak of free software, we are referring to freedom of use, not price. Our General
Public Licenses are designed to make sure that you have the freedom to distribute copies of free
software (and charge for this service if you wish); that you receive source code or can get it
if you want it; that you can change the software and use pieces of it in new free programs; and
that you are informed that you can do these things.

To protect your rights, we need to make restrictions that forbid distributors to deny you these
rights or to ask you to surrender these rights. These restrictions translate to certain
responsibilities for you if you distribute copies of the library or if you modify it.

For example, if you distribute copies of the library, whether gratis or for a fee, you must give
the recipients all the rights that we gave you. You must make sure that they, too, receive or
can get the source code. If you link other code with the library, you must provide complete
object files to the recipients, so that they can relink them with the library after making
changes to the library and recompiling it. And you must show them these terms so they know their
rights.

We protect your rights with a two-step method: (1) we copyright the library, and (2) we offer
you this license, which gives you legal permission to copy, distribute and/or modify the
library.
To protect each distributor, we want to make it very clear that there is no warranty for the free library. Also, if the library is modified by someone else and passed on, the recipients should know that what they have is not the original version, so that the original author's reputation will not be affected by problems that might be introduced by others.

Finally, software patents pose a constant threat to the existence of any free program. We wish to make sure that a company cannot effectively restrict the users of a free program by obtaining a restrictive license from a patent holder. Therefore, we insist that any patent license obtained for a version of the library must be consistent with the full freedom of use specified in this license.

Most GNU software, including some libraries, is covered by the ordinary GNU General Public License. This license, the GNU Lesser General Public License, applies to certain designated libraries, and is quite different from the ordinary General Public License. We use this license for certain libraries in order to permit linking those libraries into non-free programs.

When a program is linked with a library, whether statically or using a shared library, the combination of the two is legally speaking a combined work, a derivative of the original library. The ordinary General Public License therefore permits such linking only if the entire combination fits its criteria of freedom. The Lesser General Public License permits more lax criteria for linking other code with the library.

We call this license the "Lesser" General Public License because it does Less to protect the user's freedom than the ordinary General Public License. It also provides other free software developers Less of an advantage over competing non-free programs. These disadvantages are the reason we use the ordinary General Public License for many libraries. However, the Lesser license provides advantages in certain special circumstances.

For example, on rare occasions, there may be a special need to encourage the widest possible use of a certain library, so that it becomes a de-facto standard. To achieve this, non-free programs must be allowed to use the library. A more frequent case is that a free library does the same job as widely used non-free libraries. In this case, there is little to gain by limiting the free library to free software only, so we use the Lesser General Public License.

In other cases, permission to use a particular library in non-free programs enables a greater number of people to use a large body of free software. For example, permission to use the GNU C Library in non-free programs enables many more people to use the whole GNU operating system, as well as its variant, the GNU/Linux operating system.

Although the Lesser General Public License is Less protective of the users' freedom, it does ensure that the user of a program that is linked with the Library has the freedom and the wherewithal to run that program using a modified version of the Library.
The precise terms and conditions for copying, distribution and modification follow. Pay close attention to the difference between a "work based on the library" and a "work that uses the library". The former contains code derived from the library, whereas the latter must be combined with the library in order to run.

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License Agreement applies to any software library or other program which contains a notice placed by the copyright holder or other authorized party saying it may be distributed under the terms of this Lesser General Public License (also called "this License"). Each licensee is addressed as "you".

A "library" means a collection of software functions and/or data prepared so as to be conveniently linked with application programs (which use some of those functions and data) to form executables.

The "Library", below, refers to any such software library or work which has been distributed under these terms. A "work based on the Library" means either the Library or any derivative work under copyright law: that is to say, a work containing the Library or a portion of it, either verbatim or with modifications and/or translated straightforwardly into another language. (Hereinafter, translation is included without limitation in the term "modification".)

"Source code" for a work means the preferred form of the work for making modifications to it. For a library, complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the library.

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running a program using the Library is not restricted, and output from such a program is covered only if its contents constitute a work based on the Library (independent of the use of the Library in a tool for writing it). Whether that is true depends on what the Library does and what the program that uses the Library does.

1. You may copy and distribute verbatim copies of the Library's complete source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and distribute a copy of this License along with the Library.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.
2. You may modify your copy or copies of the Library or any portion of it, thus forming a work based on the Library, and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

a) The modified work must itself be a software library.
b) You must cause the files modified to carry prominent notices stating that you changed the files and the date of any change.
c) You must cause the whole of the work to be licensed at no charge to all third parties under the terms of this License.
d) If a facility in the modified Library refers to a function or a table of data to be supplied by an application program that uses the facility, other than as an argument passed when the facility is invoked, then you must make a good faith effort to ensure that, in the event an application does not supply such function or table, the facility still operates, and performs whatever part of its purpose remains meaningful.
   (For example, a function in a library to compute square roots has a purpose that is entirely well-defined independent of the application. Therefore, Subsection 2d requires that any application-supplied function or table used by this function must be optional: if the application does not supply it, the square root function must still compute square roots.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Library, and can be reasonably considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the same sections as part of a whole which is a work based on the Library, the distribution of the whole must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to control the distribution of derivative or collective works based on the Library.

In addition, mere aggregation of another work not based on the Library with the Library (or with a work based on the Library) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.

3. You may opt to apply the terms of the ordinary GNU General Public License instead of this License to a given copy of the Library. To do this, you must alter all the notices that refer to this License, so that they refer to the ordinary GNU General Public License, version 2, instead of to this License. (If a newer version than version 2 of the ordinary GNU General Public License has appeared, then you can specify that version instead if you wish.) Do not make any other change in these notices.
Once this change is made in a given copy, it is irreversible for that copy, so the ordinary GNU General Public License applies to all subsequent copies and derivative works made from that copy.

This option is useful when you wish to copy part of the code of the Library into a program that is not a library.

4. You may copy and distribute the Library (or a portion or derivative of it, under Section 2) in object code or executable form under the terms of Sections 1 and 2 above provided that you accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange.

If distribution of object code is made by offering access to copy from a designated place, then offering equivalent access to copy the source code from the same place satisfies the requirement to distribute the source code, even though third parties are not compelled to copy the source along with the object code.

5. A program that contains no derivative of any portion of the Library, but is designed to work with the Library by being compiled or linked with it, is called a "work that uses the Library". Such a work, in isolation, is not a derivative work of the Library, and therefore falls outside the scope of this License.

However, linking a "work that uses the Library" with the Library creates an executable that is a derivative of the Library (because it contains portions of the Library), rather than a "work that uses the library". The executable is therefore covered by this License. Section 6 states terms for distribution of such executables.

When a "work that uses the Library" uses material from a header file that is part of the Library, the object code for the work may be a derivative work of the Library even though the source code is not. Whether this is true is especially significant if the work can be linked without the Library, or if the work is itself a library. The threshold for this to be true is not precisely defined by law.

If such an object file uses only numerical parameters, data structure layouts and accessors, and small macros and small inline functions (ten lines or less in length), then the use of the object file is unrestricted, regardless of whether it is legally a derivative work. (Executables containing this object code plus portions of the Library will still fall under Section 6.)

Otherwise, if the work is a derivative of the Library, you may distribute the object code for the work under the terms of Section 6. Any executables containing that work also fall under Section 6, whether or not they are linked directly with the Library itself.
6. As an exception to the Sections above, you may also combine or link a "work that uses the Library" with the Library to produce a work containing portions of the Library, and distribute that work under terms of your choice, provided that the terms permit modification of the work for the customer's own use and reverse engineering for debugging such modifications.

You must give prominent notice with each copy of the work that the Library is used in it and that the Library and its use are covered by this License. You must supply a copy of this License. If the work during execution displays copyright notices, you must include the copyright notice for the Library among them, as well as a reference directing the user to the copy of this License. Also, you must do one of these things:

a) Accompany the work with the complete corresponding machine-readable source code for the Library including whatever changes were used in the work (which must be distributed under Sections 1 and 2 above); and, if the work is an executable linked with the Library, with the complete machine-readable "work that uses the Library", as object code and/or source code, so that the user can modify the Library and then relink to produce a modified executable containing the modified Library. (It is understood that the user who changes the contents of definitions files in the Library will not necessarily be able to recompile the application to use the modified definitions.)

b) Use a suitable shared library mechanism for linking with the Library. A suitable mechanism is one that (1) uses at run time a copy of the library already present on the user's computer system, rather than copying library functions into the executable, and (2) will operate properly with a modified version of the library, if the user installs one, as long as the modified version is interface-compatible with the version that the work was made with.

c) Accompany the work with a written offer, valid for at least three years, to give the same user the materials specified in Subsection 6a, above, for a charge no more than the cost of performing this distribution.

d) If distribution of the work is made by offering access to copy from a designated place, offer equivalent access to copy the above specified materials from the same place.

e) Verify that the user has already received a copy of these materials or that you have already sent this user a copy.

For an executable, the required form of the "work that uses the Library" must include any data and utility programs needed for reproducing the executable from it. However, as a special exception, the materials to be distributed need not include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies the executable.

It may happen that this requirement contradicts the license restrictions of other proprietary libraries that do not normally accompany the operating system. Such a contradiction means you cannot use both them and the Library together in an executable that you distribute.
7. You may place library facilities that are a work based on the Library side-by-side in a single library together with other library facilities not covered by this License, and distribute such a combined library, provided that the separate distribution of the work based on the Library and of the other library facilities is otherwise permitted, and provided that you do these two things:

a) Accompany the combined library with a copy of the same work based on the Library, uncombined with any other library facilities. This must be distributed under the terms of the Sections above.

b) Give prominent notice with the combined library of the fact that part of it is a work based on the Library, and explaining where to find the accompanying uncombined form of the same work.

8. You may not copy, modify, sublicense, link with, or distribute the Library except as expressly provided under this License. Any attempt otherwise to copy, modify, sublicense, link with, or distribute the Library is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

9. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the Library or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Library (or any work based on the Library), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Library or works based on it.

10. Each time you redistribute the Library (or any work based on the Library), the recipient automatically receives a license from the original licensor to copy, distribute, link with or modify the Library subject to these terms and conditions. You may not impose any further restrictions on the recipients' exercise of the rights granted herein. You are not responsible for enforcing compliance by third parties with this License.

11. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you may not distribute the Library at all. For example, if a patent license would not permit royalty-free redistribution of the Library by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be to refrain entirely from distribution of the Library.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply, and the section as a whole is intended to apply in other circumstances.
It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system which is implemented by public license practices. Many people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

12. If the distribution and/or use of the Library is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright holder who places the Library under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

13. The Free Software Foundation may publish revised and/or new versions of the Lesser General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Library specifies a version number of this License which applies to it and "any later version", you have the option of following the terms and conditions either of that version or of any later version published by the Free Software Foundation. If the Library does not specify a license version number, you may choose any version ever published by the Free Software Foundation.

14. If you wish to incorporate parts of the Library into other free programs whose distribution conditions are incompatible with these, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY
15. BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE LIBRARY, TO THE
EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT
HOLDERS AND/OR OTHER PARTIES PROVIDE THE LIBRARY "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXpressed OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY
 AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE
LIBRARY IS WITH YOU. SHOULD THE LIBRARY PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY
SERVICING, REPAIR OR CORRECTION.

16. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT
HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE LIBRARY AS PERMITTED ABOVE, BE
LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES
ARISING OUT OF THE USE OR INABILITY TO USE THE LIBRARY (INCLUDING BUT NOT LIMITED TO LOSS OF
DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE
OF THE LIBRARY TO OPERATE WITH ANY OTHER SOFTWARE), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN
ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Libraries

If you develop a new library, and you want it to be of the greatest possible use to the public,
we recommend making it free software that everyone can redistribute and change. You can do so by
permitting redistribution under these terms (or, alternatively, under the terms of the ordinary
General Public License).

To apply these terms, attach the following notices to the library. It is safest to attach them
to the start of each source file to most effectively convey the exclusion of warranty; and each
file should have at least the "copyright" line and a pointer to where the full notice is found.

one line to give the library's name and an idea of what it does.
Copyright (C) year  name of author

This library is free software; you can redistribute it and/or
modify it under the terms of the GNU Lesser General Public
License as published by the Free Software Foundation; either
version 2.1 of the License, or (at your option) any later version.

This library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details.

You should have received a copy of the GNU Lesser General Public
License along with this library; if not, write to the Free Software
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301  USA
Also add information on how to contact you by electronic and paper mail.

You should also get your employer (if you work as a programmer) or your school, if any, to sign
a "copyright disclaimer" for the library, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in
the library 'Frob' (a library for tweaking knobs) written
by James Random Hacker.

signature of Ty Coon, 1 April 1990
Ty Coon, President of Vice
That's all there is to it!

OpenSceneGraph

Included Libraries

MADRIX uses the following libraries of the OpenSceneGraph 3D graphics toolkit. The libraries and their use are
covered by OSGPL v0.0

- ot12-OpenThreads.dll
- osg80-osg.dll
- osg80-osgUtil.dll
- osg80-osgViewer.dll
- osg80-osgQt.dll
- osg80-osgGA.dll
- osg80-osgDB.dll
- osg80-osgFX.dll
- osg80-osgText.dll

The complete, corresponding, and machine-readable source code of these files, incl. the license text, is available:

- On the MADRIX product CD, in the subfolder ThirdParty. For example, D:\ThirdParty
Copy of License

OpenSceneGraph Public License, Version 0.0

=================================================================================

Copyright (C) 2002 Robert Osfield.

Everyone is permitted to copy and distribute verbatim copies of this licence document, but
changing it is not allowed.

OPENSCENEGRAPH PUBLIC LICENCE

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

This library is free software; you can redistribute it and/or modify it under the terms of the
OpenSceneGraph Public License (OSGPL) version 0.0 or later.

Notes: the OSGPL is based on the LGPL, with the 4 exceptions laid out in the wxWindows section
below. The LGPL is contained in the final section of this license.

=================================================================================

wxWindows Library Licence, Version 3

=================================================================================

Copyright (C) 1998 Julian Smart, Robert Roebling [...]

Everyone is permitted to copy and distribute verbatim copies of this licence document, but
changing it is not allowed.

WXWINDOWS LIBRARY LICENCE

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

This library is free software; you can redistribute it and/or modify it under the terms of the
GNU Library General Public Licence as published by the Free Software Foundation; either version
2 of the Licence, or (at your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY;
without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See
the GNU Library General Public Licence for more details.
You should have received a copy of the GNU Library General Public Licence along with this software, usually in a file named COPYING.LIB. If not, write to the Free Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.

EXCEPTION NOTICE

1. As a special exception, the copyright holders of this library give permission for additional uses of the text contained in this release of the library as licenced under the wxWindows Library Licence, applying either version 3 of the Licence, or (at your option) any later version of the Licence as published by the copyright holders of version 3 of the Licence document.

2. The exception is that you may use, copy, link, modify and distribute under the user's own terms, binary object code versions of works based on the Library.

3. If you copy code from files distributed under the terms of the GNU General Public Licence or the GNU Library General Public Licence into a copy of this library, as this licence permits, the exception does not apply to the code that you add in this way. To avoid misleading anyone as to the status of such modified files, you must delete this exception notice from such code and/or adjust the licensing conditions notice accordingly.

4. If you write modifications of your own for this library, it is your choice whether to permit this exception to apply to your modifications. If you do not wish that, you must delete the exception notice from such code and/or adjust the licensing conditions notice accordingly.

------------------------------------------------------------------------------

GNU LESSER GENERAL PUBLIC LICENSE

Version 2.1, February 1999

Copyright (C) 1991, 1999 Free Software Foundation, Inc.
51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

[This is the first released version of the Lesser GPL. It also counts as the successor of the GNU Library Public License, version 2, hence the version number 2.1.]

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public Licenses are intended to guarantee your freedom to share and change free software--to make sure the software is free for all its users.
This license, the Lesser General Public License, applies to some specially designated software packages--typically libraries--of the Free Software Foundation and other authors who decide to use it. You can use it too, but we suggest you first think carefully about whether this license or the ordinary General Public License is the better strategy to use in any particular case, based on the explanations below.

When we speak of free software, we are referring to freedom of use, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish); that you receive source code or can get it if you want it; that you can change the software and use pieces of it in new free programs; and that you are informed that you can do these things.

To protect your rights, we need to make restrictions that forbid distributors to deny you these rights or to ask you to surrender these rights. These restrictions translate to certain responsibilities for you if you distribute copies of the library or if you modify it.

For example, if you distribute copies of the library, whether gratis or for a fee, you must give the recipients all the rights that we gave you. You must make sure that they, too, receive or can get the source code. If you link other code with the library, you must provide complete object files to the recipients, so that they can relink them with the library after making changes to the library and recompiling it. And you must show them these terms so they know their rights.

We protect your rights with a two-step method: (1) we copyright the library, and (2) we offer you this license, which gives you legal permission to copy, distribute and/or modify the library.

To protect each distributor, we want to make it very clear that there is no warranty for the free library. Also, if the library is modified by someone else and passed on, the recipients should know that what they have is not the original version, so that the original author's reputation will not be affected by problems that might be introduced by others.

Finally, software patents pose a constant threat to the existence of any free program. We wish to make sure that a company cannot effectively restrict the users of a free program by obtaining a restrictive license from a patent holder. Therefore, we insist that any patent license obtained for a version of the library must be consistent with the full freedom of use specified in this license.

Most GNU software, including some libraries, is covered by the ordinary GNU General Public License. This license, the GNU Lesser General Public License, applies to certain designated libraries, and is quite different from the ordinary General Public License. We use this license for certain libraries in order to permit linking those libraries into non-free programs.
When a program is linked with a library, whether statically or using a shared library, the combination of the two is legally speaking a combined work, a derivative of the original library. The ordinary General Public License therefore permits such linking only if the entire combination fits its criteria of freedom. The Lesser General Public License permits more lax criteria for linking other code with the library.

We call this license the "Lesser" General Public License because it does Less to protect the user's freedom than the ordinary General Public License. It also provides other free software developers Less of an advantage over competing non-free programs. These disadvantages are the reason we use the ordinary General Public License for many libraries. However, the Lesser license provides advantages in certain special circumstances.

For example, on rare occasions, there may be a special need to encourage the widest possible use of a certain library, so that it becomes a de-facto standard. To achieve this, non-free programs must be allowed to use the library. A more frequent case is that a free library does the same job as widely used non-free libraries. In this case, there is little to gain by limiting the free library to free software only, so we use the Lesser General Public License.

In other cases, permission to use a particular library in non-free programs enables a greater number of people to use a large body of free software. For example, permission to use the GNU C Library in non-free programs enables many more people to use the whole GNU operating system, as well as its variant, the GNU/Linux operating system.

Although the Lesser General Public License is Less protective of the users' freedom, it does ensure that the user of a program that is linked with the Library has the freedom and the wherewithal to run that program using a modified version of the Library.

The precise terms and conditions for copying, distribution and modification follow. Pay close attention to the difference between a "work based on the library" and a "work that uses the library". The former contains code derived from the library, whereas the latter must be combined with the library in order to run.

TERM AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License Agreement applies to any software library or other program which contains a notice placed by the copyright holder or other authorized party saying it may be distributed under the terms of this Lesser General Public License (also called "this License"). Each licensee is addressed as "you".

A "library" means a collection of software functions and/or data prepared so as to be conveniently linked with application programs (which use some of those functions and data) to form executables.
The "Library", below, refers to any such software library or work which has been distributed under these terms. A "work based on the Library" means either the Library or any derivative work under copyright law: that is to say, a work containing the Library or a portion of it, either verbatim or with modifications and/or translated straightforwardly into another language. (Hereinafter, translation is included without limitation in the term "modification".)

"Source code" for a work means the preferred form of the work for making modifications to it. For a library, complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the library.

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running a program using the Library is not restricted, and output from such a program is covered only if its contents constitute a work based on the Library (independent of the use of the Library in a tool for writing it). Whether that is true depends on what the Library does and what the program that uses the Library does.

1. You may copy and distribute verbatim copies of the Library's complete source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and distribute a copy of this License along with the Library.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Library or any portion of it, thus forming a work based on the Library, and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

a) The modified work must itself be a software library.
b) You must cause the files modified to carry prominent notices stating that you changed the files and the date of any change.
c) You must cause the whole of the work to be licensed at no charge to all third parties under the terms of this License.
d) If a facility in the modified Library refers to a function or a table of data to be supplied by an application program that uses the facility, other than as an argument passed when the facility is invoked, then you must make a good faith effort to ensure that, in the event an application does not supply such function or table, the facility still operates, and performs whatever part of its purpose remains meaningful.
(For example, a function in a library to compute square roots has a purpose that is entirely well-defined independent of the application. Therefore, Subsection 2d requires that any application-supplied function or table used by this function must be optional: if the application does not supply it, the square root function must still compute square roots.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Library, and can be reasonably considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the same sections as part of a whole which is a work based on the Library, the distribution of the whole must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to control the distribution of derivative or collective works based on the Library.

In addition, mere aggregation of another work not based on the Library with the Library (or with a work based on the Library) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.

3. You may opt to apply the terms of the ordinary GNU General Public License instead of this License to a given copy of the Library. To do this, you must alter all the notices that refer to this License, so that they refer to the ordinary GNU General Public License, version 2, instead of to this License. (If a newer version than version 2 of the ordinary GNU General Public License has appeared, then you can specify that version instead if you wish.) Do not make any other change in these notices.

Once this change is made in a given copy, it is irreversible for that copy, so the ordinary GNU General Public License applies to all subsequent copies and derivative works made from that copy.

This option is useful when you wish to copy part of the code of the Library into a program that is not a library.

4. You may copy and distribute the Library (or a portion or derivative of it, under Section 2) in object code or executable form under the terms of Sections 1 and 2 above provided that you accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange.
If distribution of object code is made by offering access to copy from a designated place, then offering equivalent access to copy the source code from the same place satisfies the requirement to distribute the source code, even though third parties are not compelled to copy the source along with the object code.

5. A program that contains no derivative of any portion of the Library, but is designed to work with the Library by being compiled or linked with it, is called a "work that uses the Library". Such a work, in isolation, is not a derivative work of the Library, and therefore falls outside the scope of this License.

However, linking a "work that uses the Library" with the Library creates an executable that is a derivative of the Library (because it contains portions of the Library), rather than a "work that uses the library". The executable is therefore covered by this License. Section 6 states terms for distribution of such executables.

When a "work that uses the Library" uses material from a header file that is part of the Library, the object code for the work may be a derivative work of the Library even though the source code is not. Whether this is true is especially significant if the work can be linked without the Library, or if the work is itself a library. The threshold for this to be true is not precisely defined by law.

If such an object file uses only numerical parameters, data structure layouts and accessors, and small macros and small inline functions (ten lines or less in length), then the use of the object file is unrestricted, regardless of whether it is legally a derivative work. (Executables containing this object code plus portions of the Library will still fall under Section 6.)

Otherwise, if the work is a derivative of the Library, you may distribute the object code for the work under the terms of Section 6. Any executables containing that work also fall under Section 6, whether or not they are linked directly with the Library itself.

6. As an exception to the Sections above, you may also combine or link a "work that uses the Library" with the Library to produce a work containing portions of the Library, and distribute that work under terms of your choice, provided that the terms permit modification of the work for the customer’s own use and reverse engineering for debugging such modifications.

You must give prominent notice with each copy of the work that the Library is used in it and that the Library and its use are covered by this License. You must supply a copy of this License. If the work during execution displays copyright notices, you must include the copyright notice for the Library among them, as well as a reference directing the user to the copy of this License. Also, you must do one of these things:
a) Accompany the work with the complete corresponding machine-readable source code for the
Library including whatever changes were used in the work (which must be distributed under
Sections 1 and 2 above); and, if the work is an executable linked with the Library, with the
complete machine-readable "work that uses the Library", as object code and/or source code, so
that the user can modify the Library and then relink to produce a modified executable containing
the modified Library. (It is understood that the user who changes the contents of definitions
files in the Library will not necessarily be able to recompile the application to use the
modified definitions.)

b) Use a suitable shared library mechanism for linking with the Library. A suitable mechanism is
one that (1) uses at run time a copy of the library already present on the user's computer
system, rather than copying library functions into the executable, and (2) will operate properly
with a modified version of the library, if the user installs one, as long as the modified
version is interface-compatible with the version that the work was made with.

c) Accompany the work with a written offer, valid for at least three years, to give the same
user the materials specified in Subsection 6a, above, for a charge no more than the cost of
performing this distribution.

d) If distribution of the work is made by offering access to copy from a designated place, offer
equivalent access to copy the above specified materials from the same place.

e) Verify that the user has already received a copy of these materials or that you have already
sent this user a copy.

For an executable, the required form of the "work that uses the Library" must include any data
and utility programs needed for reproducing the executable from it. However, as a special
exception, the materials to be distributed need not include anything that is normally
distributed (in either source or binary form) with the major components (compiler, kernel, and
so on) of the operating system on which the executable runs, unless that component itself
accompanies the executable.

It may happen that this requirement contradicts the license restrictions of other proprietary
libraries that do not normally accompany the operating system. Such a contradiction means you
cannot use both them and the Library together in an executable that you distribute.

7. You may place library facilities that are a work based on the Library side-by-side in a
single library together with other library facilities not covered by this License, and
distribute such a combined library, provided that the separate distribution of the work based on
the Library and of the other library facilities is otherwise permitted, and provided that you do
these two things:

a) Accompany the combined library with a copy of the same work based on the Library, uncombined
with any other library facilities. This must be distributed under the terms of the Sections
above.

b) Give prominent notice with the combined library of the fact that part of it is a work based
on the Library, and explaining where to find the accompanying uncombined form of the same work.
8. You may not copy, modify, sublicense, link with, or distribute the Library except as expressly provided under this License. Any attempt otherwise to copy, modify, sublicense, link with, or distribute the Library is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

9. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the Library or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Library (or any work based on the Library), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Library or works based on it.

10. Each time you redistribute the Library (or any work based on the Library), the recipient automatically receives a license from the original licensor to copy, distribute, link with or modify the Library subject to these terms and conditions. You may not impose any further restrictions on the recipients' exercise of the rights granted herein. You are not responsible for enforcing compliance by third parties with this License.

11. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you may not distribute the Library at all. For example, if a patent license would not permit royalty-free redistribution of the Library by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be to refrain entirely from distribution of the Library.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply, and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system which is implemented by public license practices. Many people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.
12. If the distribution and/or use of the Library is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright holder who places the Library under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

13. The Free Software Foundation may publish revised and/or new versions of the Lesser General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Library specifies a version number of this License which applies to it and "any later version", you have the option of following the terms and conditions either of that version or of any later version published by the Free Software Foundation. If the Library does not specify a license version number, you may choose any version ever published by the Free Software Foundation.

14. If you wish to incorporate parts of the Library into other free programs whose distribution conditions are incompatible with these, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

15. BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE LIBRARY, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE LIBRARY "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE LIBRARY IS WITH YOU. SHOULD THE LIBRARY PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

16. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE LIBRARY AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE LIBRARY (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE LIBRARY TO OPERATE WITH ANY OTHER SOFTWARE), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS
How to Apply These Terms to Your New Libraries

If you develop a new library, and you want it to be of the greatest possible use to the public, we recommend making it free software that everyone can redistribute and change. You can do so by permitting redistribution under these terms (or, alternatively, under the terms of the ordinary General Public License).

To apply these terms, attach the following notices to the library. It is safest to attach them to the start of each source file to most effectively convey the exclusion of warranty; and each file should have at least the "copyright" line and a pointer to where the full notice is found.

one line to give the library's name and an idea of what it does.
Copyright (C) year  name of author

This library is free software; you can redistribute it and/or modify it under the terms of the GNU Lesser General Public License as published by the Free Software Foundation; either version 2.1 of the License, or (at your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU Lesser General Public License for more details.

You should have received a copy of the GNU Lesser General Public License along with this library; if not, write to the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA  02110-1301  USA
Also add information on how to contact you by electronic and paper mail.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a "copyright disclaimer" for the library, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the library 'Frob' (a library for tweaking knobs) written by James Random Hacker.

signature of Ty Coon, 1 April 1990
Ty Coon, President of Vice
That's all there is to it!
WinPcap

Copyright (c) 1999 - 2005 NetGroup, Politecnico di Torino (Italy).
Copyright (c) 2005 - 2009 CACE Technologies, Davis (California).
All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
3. Neither the name of the Politecnico di Torino, CACE Technologies nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes software developed by the University of California, Lawrence Berkeley Laboratory and its contributors.
This product includes software developed by the Kungliga Tekniska Högskolan and its contributors.
This product includes software developed by Yen Yen Lim and North Dakota State University.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
3. All advertising materials mentioning features or use of this software must display the following acknowledgement: "This product includes software developed by the University of California, Berkeley and its contributors."

4. Neither the name of the University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE INSTITUTE AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Portions Copyright (c) 1983 Regents of the University of California. All rights reserved.

Redistribution and use in source and binary forms are permitted provided that the above copyright notice and this paragraph are duplicated in all such forms and that any documentation, advertising materials, and other materials related to such distribution and use acknowledge that the software was developed by the University of California, Berkeley. The name of the University may not be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED "AS IS" AND WITHOUT ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.

Portions Copyright (c) 1995, 1996, 1997 Kungliga Tekniska Högskolan (Royal Institute of Technology, Stockholm, Sweden). All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
3. All advertising materials mentioning features or use of this software must display the following acknowledgement: "This product includes software developed by the Kungliga Tekniska Högskolan and its contributors."
4. Neither the name of the University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE INSTITUTE AND CONTRIBUTORS `''AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE INSTITUTE OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Portions Copyright (c) 1997 Yen Yen Lim and North Dakota State University. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
3. All advertising materials mentioning features or use of this software must display the following acknowledgement: "This product includes software developed by Yen Yen Lim and North Dakota State University"
4. The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR `''AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Portions Copyright (c) 1993 by Digital Equipment Corporation.

Permission to use, copy, modify, and distribute this software for any purpose with or without fee is hereby granted, provided that the above copyright notice and this permission notice appear in all copies, and that the name of Digital Equipment Corporation not be used in advertising or publicity pertaining to distribution of the document or software without specific, written prior permission.
THE SOFTWARE IS PROVIDED "AS IS" AND DIGITAL EQUIPMENT CORP. DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL DIGITAL EQUIPMENT CORPORATION BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

Portions Copyright (C) 1995, 1996, 1997, 1998, and 1999 WIDE Project. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
3. Neither the name of the project nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE PROJECT OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Portions Copyright (c) 1996 Juniper Networks, Inc. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that: (1) source code distributions retain the above copyright notice and this paragraph in its entirety, (2) distributions including binary code include the above copyright notice and this paragraph in its entirety in the documentation or other materials provided with the distribution. The name of Juniper Networks may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED "AS IS" AND WITHOUT ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. Portions Copyright (c) 2001 Daniel Hartmeier All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Portions Copyright 1989 by Carnegie Mellon.

Permission to use, copy, modify, and distribute this program for any purpose and without fee is hereby granted, provided that this copyright and permission notice appear on all copies and supporting documentation, the name of Carnegie Mellon not be used in advertising or publicity pertaining to distribution of the program without specific prior permission, and notice be given in supporting documentation that copying and distribution is by permission of Carnegie Mellon and Stanford University. Carnegie Mellon makes no representations about the suitability of this software for any purpose. It is provided "as is" without express or implied warranty.

Easing Equations

Open source under the BSD License.

Copyright © 2001 Robert Penner
All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
- Neither the name of the author nor the names of contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.